Utilisation de plusieurs types de fichiers dans Animate

  1. Guide de l’utilisateur d’Adobe Animate
  2. Présentation d’Animate
    1. Nouveautés d’Adobe Animate
    2. Glossaire visuel
    3. Configuration requise pour Animate
    4. Raccourcis clavier d’Animate
    5. Utilisation de plusieurs types de fichiers dans Animate
  3. Animation
    1. Principes de base de l’animation dans Animate
    2. Utilisation des images et des images-clés dans Animate
    3. Animation image par image dans Animate
    4. Utilisation d’une animation interpolée classique dans Animate
    5. Outil Pinceau
    6. Guide du mouvement
    7. Interpolation de mouvement et ActionScript 3.0
    8. À propos de l’animation d’une interpolation de mouvement
    9. Animation d’une interpolation de mouvement
    10. Création d’une animation d’interpolation de mouvement
    11. Utilisation des images-clés de propriété
    12. Animation d’une position à l’aide d’une interpolation
    13. Modification des interpolations de mouvement avec l’Éditeur de mouvement
    14. Modification de la trajectoire de mouvement d’une animation d’interpolation
    15. Manipulation d’interpolations de mouvement
    16. Ajout d’accélérations personnalisées
    17. Création et application de présélections de mouvement
    18. Configuration de plages d’interpolation d’une animation
    19. Utilisation d’interpolations de mouvement enregistrées au format XML
    20. Interpolations de mouvement et interpolations classiques : comparatif
    21. Interpolation de forme
    22. Utilisation de l’animation de l’outil de segment dans Animate
    23. Utilisation du squelettage de personnage dans Animate
    24. Utilisation de calques de masque dans Adobe Animate
    25. Utilisation de séquences dans Animate
  4. Interactivité
    1. Création de boutons avec Animate
    2. Conversion de projets Animate en d’autres formats de document
    3. Création et publication de documents HTML5 Canvas dans Animate
    4. Ajout d’interactivité à l’aide de fragments de code dans Animate
    5. Création de composants HTML5 personnalisés
    6. Utilisation de composants dans HTML5 Canvas
    7. Création de composants personnalisés : exemples
    8. Fragments de code des composants personnalisés
    9. Pratiques recommandées – Publicité avec Animate
    10. Création et publication de contenu de réalité virtuelle
  5. Espace de travail et workflow
    1. Création et gestion des pinceaux
    2. Utilisation de polices Google Fonts dans les documents HTML5 Canvas
    3. Utilisation des bibliothèques Creative Cloud et d’Adobe Animate
    4. Utilisation de la scène et du panneau Outils pour Animate
    5. Workflow et espace de travail Animate
    6. Utilisation de polices web dans les documents HTML5 Canvas
    7. Scénarios et ActionScript
    8. Utilisation de plusieurs scénarios
    9. Définition des préférences
    10. Utilisation des panneaux de création Animate
    11. Création de calques de scénario avec Animate
    12. Exportation d’animations pour les applications mobiles et les moteurs de jeu
    13. Déplacement et copie d’objets
    14. Modèles
    15. Recherche et remplacement de contenu dans Animate
    16. Commandes Annuler et Rétablir, et panneau Historique
    17. Raccourcis clavier
    18. Utilisation du scénario dans Animate
    19. Création d’extensions HTML
    20. Options d’optimisation des images et des GIF animés
    21. Paramètres d’exportation des images et des fichiers GIF
    22. Panneau Éléments dans Animate
  6. Multimédia et vidéo
    1. Transformation et combinaison d’objets graphiques dans Animate
    2. Création et utilisation d’instances de symboles dans Animate
    3. Vectorisation de l’image
    4. Utilisation du son dans Adobe Animate
    5. Exportation de fichiers SVG
    6. Création de fichiers vidéo en vue de les utiliser dans Animate
    7. Comment ajouter une vidéo dans Animate
    8. Utilisation des points de repère vidéo
    9. Dessin et création d’objets avec Animate
    10. Remodelage des lignes et des formes
    11. Traits, remplissages et dégradés avec Animate CC
    12. Utilisation d’Adobe Premiere Pro et d’After Effects
    13. Panneaux Couleur dans Animate CC
    14. Ouverture de fichiers Flash CS6 à l’aide d’Animate
    15. Utilisation de texte classique dans Animate
    16. Placement d’illustrations dans Animate
    17. Images bitmap importées dans Animate
    18. Graphiques 3D
    19. Utilisation de symboles dans Animate
    20. Dessin de traits et de formes avec Adobe Animate
    21. Utilisation de bibliothèques dans Animate
    22. Exportation de sons
    23. Sélection d’objets dans Animate CC
    24. Utilisation de fichiers AI d’Illustrator dans Animate
    25. Application de motifs avec l’outil Pinceau pulvérisateur
    26. Application de modes de fusion
    27. Disposition d’objets
    28. Automatisation des tâches à l’aide du menu Commandes
    29. Texte multilingue
    30. Utilisation de la caméra dans Animate
    31. Utilisation d’Animate avec Adobe Scout
    32. Utilisation de fichiers Fireworks
    33. Filtres graphiques
    34. Sons et ActionScript
    35. Préférences de dessin
    36. Dessin avec l’outil Plume
  7. Plateformes
    1. Conversion de projets Animate en d’autres formats de document
    2. Prise en charge des plateformes personnalisées
    3. Création et publication de documents HTML5 Canvas dans Animate
    4. Création et publication d’un document WebGL
    5. Assemblage d’applications AIR pour iOS
    6. Publication d’applications AIR pour Android
    7. Publication pour Adobe AIR for Desktop
    8. Paramètres de publication d’ActionScript
    9. Pratiques recommandées – Organisation du code ActionScript dans une application
    10. Utilisation d’ActionScript avec Animate
    11. Pratiques recommandées – Recommandations sur l’accessibilité
    12. Accessibilité dans l’espace de travail Animate
    13. Écriture et gestion des scripts
    14. Activation de la prise en charge des plateformes personnalisées
    15. Présentation de la prise en charge des plateformes personnalisées
    16. Création de contenu accessible
    17. Utilisation du plug-in de prise en charge des plateformes personnalisées
    18. Débogage du code ActionScript 3.0
    19. Activation de la prise en charge des plateformes personnalisées
  8. Exportation et publication
    1. Exportation de fichiers d’Animate CC
    2. Publication OAM
    3. Exportation de fichiers SVG
    4. Exportation d’images et de vidéos avec Animate
    5. Publication de documents AS3
    6. Exportation d’animations pour les applications mobiles et les moteurs de jeu
    7. Exportation de sons
    8. Exportation de fichiers vidéo QuickTime
    9. Contrôle de la lecture vidéo externe à l’aide d’ActionScript
    10. Pratiques recommandées – Conseils pour la création de contenu pour appareils mobiles
    11. Pratiques recommandées – Conventions des vidéos
    12. Pratiques recommandées – Recommandations sur la création d’applications SWF
    13. Pratiques recommandées – Structuration des fichiers FLA
    14. Pratiques recommandées d’optimisation des fichiers FLA pour Animate
    15. Paramètres de publication d’ActionScript
    16. Spécification des paramètres de publication pour Animate
    17. Exportation de fichiers de projection
    18. Exportation d’images et de GIF animés
    19. Modèles de publication HTML
    20. Utilisation d’Adobe Premiere Pro et d’After Effects
    21. Partage et publication rapides de vos animations

À propos des fichiers Animate

Dans Animate, vous pouvez travailler avec des types de fichiers variés, chacun d’eux jouant un rôle particulier :

  • Les fichiers FLA, qui sont les fichiers principaux que vous utilisez dans Animate, contiennent les informations de base sur les supports, les scénarios et les scripts concernant un document Animate. Les objets multimédias représentent les différents objets comme les graphiques, le texte, le son et la vidéo composant le contenu de votre document Animate. Le scénario permet d’indiquer à Animate quand faire apparaître des objets multimédias spécifiques sur la scène. Vous pouvez ajouter du code ActionScript® à des documents Animate pour mieux contrôler leur comportement et leur façon de répondre aux interactions avec les utilisateurs.

  • Les fichiers XFL non compressés sont similaires aux fichiers FLA. Un fichier XFL (ainsi que tous les fichiers associés à l'intérieur du même dossier) est l'équivalent non compressé d'un fichier FLA. Ce format permet aux groupes d’utilisateurs de travailler simultanément sur plusieurs éléments d’un projet Animate. Pour plus d’informations, voir Utilisation de fichiers XFL non compressés.

  • Les fichiers SWF, qui constituent les versions compilées des fichiers FLA, sont ceux que vous affichez dans une page Web. Lorsque vous publiez un fichier FLA, Animate crée un fichier SWF.

    Le format de fichier SWF Animate est une norme ouverte que d’autres applications prennent en charge. Pour plus d’informations sur les formats de fichier Animate, voir www.adobe.com/go/flashplayer_fr.

  • Les fichiers AS sont des fichiers ActionScript. Vous pouvez les utiliser pour conserver tout ou une partie de votre code ActionScript hors de vos fichiers FLA. Cette disposition s’avère pratique pour l’organisation du code et pour les projets sur lesquels plusieurs personnes travaillent sur différentes parties du contenu Animate.

  • Les fichiers SWC contiennent les composants Animate réutilisables. Chaque fichier SWC contient un clip compilé, du code ActionScript et de nombreux autres actifs requis par le composant. Remarque : Il est impossible d’importer les fichiers SWC dans Animate.
  • Les fichiers ASC servent à stocker le code ActionScript qui sera exécuté sur un ordinateur exécutant Adobe Media Server. Ces fichiers permettent de déployer une logique côté serveur qui fonctionne en combinaison avec le code ActionScript d’un fichier SWF. Remarque : Les fichiers ASC ne sont pas pris en charge dans Animate.
  • Les fichiers JSFL sont des fichiers JavaScript que vous pouvez utiliser pour ajouter une nouvelle fonction à l’outil de création Animate.
  • Le format de fichier .APR permet de regrouper le modèle de publication du plan de travail avec ses paramètres de profil de publication. Dorénavant, tout nouvel actif associé à un profil de publication est regroupé et partagé. Pour en savoir plus, voir Paramètres de publication.

 

Qu’est-ce qu’Animate ?

Adobe

Le didacticiel suivant explique l’utilisation d’Animate/Flash Pro.

Utilisation d’autres applications Adobe

Animate est conçu pour fonctionner avec d’autres applications Adobe® afin de vous offrir une large palette de flux de travail créatifs. Vous pouvez importer des fichiers Illustrator® et Photoshop® directement dans Animate. Vous pouvez également créer une vidéo à partir d’Animate et la modifier dans Adobe® Premiere® Pro ou After Effects®, ou encore importer une vidéo dans Animate partir de l’une de ces applications. Lorsque vous publiez vos fichiers SWF, vous pouvez utiliser Dreamweaver® pour intégrer le contenu dans vos pages Web et lancer Animate directement depuis Dreamweaver pour modifier ce contenu.

Ouverture de fichiers XFL

À compter d’Animate, XFL est le format interne des fichiers FLA que vous créez. Lorsque vous enregistrez un fichier dans Animate, le format par défaut est FLA, mais le format interne du fichier est XFL.

D’autres applications Adobe®, telles que After Effects®, peuvent exporter des fichiers au format XFL. Ces fichiers portent l’extension XFL et non l’extension FLA. InDesign® peut exporter directement au format FLA (format XFL en interne). Vous pouvez ainsi commencer un projet dans After Effects ou InDesign, puis le poursuivre dans Animate.

Vous pouvez ouvrir et utiliser des fichiers XFL dans Animate de la même manière que pour un fichier FLA. Lorsque vous ouvrez un fichier XFL dans Animate, vous pouvez l’enregistrer en tant que fichier FLA ou au format XFL non compressé.

Pour ouvrir un fichier XFL dans Animate :

  1. Dans une autre application Adobe®, telle qu’InDesign ou After Effects, exportez votre travail dans un fichier XFL.

    L’application préserve tous les calques et tous les objets du fichier original dans le fichier XFL.

  2. Dans Animate, sélectionnez Fichier > Ouvrir, puis accédez au fichier XFL. Cliquez sur Ouvrir.

    Le fichier XFL s’ouvre dans Animate comme s’il s’agissait d’un fichier FLA. Tous les calques du fichier original apparaissent dans le Scénario et les objets d’origine apparaissent dans le panneau Bibliothèque.

    Vous pouvez maintenant travailler normalement avec le fichier.

  3. Pour enregistrer le fichier, choisissez Fichier > Enregistrer.

    Animate vous invite à nommer le nouveau fichier FLA dans la boîte de dialogue Enregistrer sous.

  4. Tapez un nom, puis enregistrez le fichier FLA.

Utilisation de fichiers XFL non compressés

À compter d’Animate, vous pouvez choisir d’utiliser vos fichiers Animate au format XFL non compressé. Ce format permet de voir tous les composants individuels, ou sous-fichiers, qui constituent le fichier Animate. Ces composants sont les suivants :

  • Un fichier XML qui décrit le fichier Animate comme un tout.

  • Des fichiers XML indépendants pour décrire chaque symbole de bibliothèque.

  • Des fichiers XML supplémentaires contenant les paramètres de publication, les paramètres mobiles, etc.

  • Des dossiers contenant les actifs externes, tels que les fichiers bitmap, utilisés par le fichier Animate.

L’utilisation d’un format XFL non compressé permet à plusieurs personnes de travailler de façon indépendante sur chaque partie du fichier Animate. Il est également possible d’utiliser un système de contrôle de code source pour gérer les modifications effectuées sur chaque sous-fichier dans votre fichier XFL non compressé. Ensemble, ces fonctionnalités facilitent la collaboration entre plusieurs concepteurs et développeurs sur des projets volumineux.

Utilisation de la mise en jour automatique avec les fichiers XFL

La mise à jour automatique des actifs modifiables pour les documents XFL non compressés permet de modifier tous les actifs de bibliothèque à partir d’un document XFL non compressé lorsque le document est ouvert dans Animate. Vos modifications apparaissent dans Animate lorsque vous terminez de modifier l’actif dans une autre application.

Pour modifier un actif à partir d’un document XFL non compressé dans une autre application :

  1. Enregistrez un document Animate au format XFL non compressé.

  2. Dans un éditeur approprié, tel que Photoshop, ouvrez l’actif que vous souhaitez modifier depuis le dossier LIBRARY du document XFL non compressé.

  3. Modifiez l’actif et enregistrez vos modifications.

  4. Revenez à Animate.

    La mise à jour de l’actif apparaît immédiatement dans Animate.

Modification d’un fichier SWF dans Animate depuis Dreamweaver

Si Animate et Dreamweaver sont installés, vous pouvez sélectionner un fichier SWF dans un document Dreamweaver et utiliser Animate pour le modifier. Animate ne modifie pas directement le fichier SWF ; il modifie le document source (fichier FLA), puis exporte à nouveau le fichier SWF.

  1. Dans Dreamweaver, ouvrez l’inspecteur des propriétés (Fenêtre > Propriétés).
  2. Dans le document Dreamweaver, utilisez l’une des méthodes suivantes :
    • Cliquez sur l’espace réservé du fichier SWF pour le sélectionner, puis sur Modifier dans l’inspecteur des propriétés.

    • Cliquez sur l’espace réservé du fichier SWF avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) et choisissez Modifier avec Animate dans le menu contextuel.

      Dreamweaver passe sur Animate, qui tente à son tour de localiser le fichier de création Animate (FLA) correspondant au fichier SWF sélectionné. Si Animate ne parvient pas à localiser le fichier de création Animate, un message vous invite à le faire.

      Remarque : Si le fichier FLA ou SWF est verrouillé, extrayez-le dans Dreamweaver.

  3. Dans Animate, modifiez le fichier FLA. La fenêtre Document Animate indique que vous êtes en train de modifier le fichier à partir de Dreamweaver.

  4. Une fois les modifications effectuées, cliquez sur Terminé.

    Animate met à jour le fichier FLA, le réexporte en tant que fichier SWF, se ferme et revient au document Dreamweaver.

    Remarque :

    Pour mettre à jour le fichier SWF et garder Animate ouvert, sélectionnez la commande Animate Fichier > Mettre à jour dans Dreamweaver.

  5. Pour afficher le fichier mis à jour dans le document, cliquez sur le bouton Lecture dans l’inspecteur des propriétés de Dreamweaver ou appuyez sur la touche F12 pour afficher un aperçu de votre page dans une fenêtre de navigateur.

Création d’un nouveau document

Dans Animate, vous pouvez créer un document ou ouvrir un document enregistré précédemment et vous pouvez également ouvrir une nouvelle fenêtre pendant que vous travaillez. Vous pouvez définir des propriétés pour des documents nouveaux ou existants.

Vous pouvez choisir la destination d’une animation avec n’importe lequel des modes ; Animate fournit les formats prédéfinis. Choisissez un mode dans les onglets situés en haut de l’écran, tels que Animation des personnages, Social, Jeu, Éducation, Publicités, Web et Avancé.

Sélectionnez les paramètres prédéfinis appropriés pour chacun des modes, puis cliquez sur Créer pour commencer à créer des animations. Vous pouvez afficher les ressources récemment utilisées dans le volet gauche. Des exemples de ressource sont fournis au bas de l’écran de démarrage.

Création d’un document

  1. Sélectionnez Fichier > Nouveau.

    Nouveau document
    Nouveau document

  2. Choisissez un mode dans les onglets situés en haut de l’écran, tels que Animation des personnages, Social, Jeu, Éducation, Publicités, Web et Avancé.

  3. Sélectionnez les paramètres prédéfinis appropriés pour chacun des modes, puis cliquez sur Créer.

    Vous pouvez également choisir les paramètres du document. Voir Définition des propriétés pour un document nouveau ou existant

Utilisation de types de documents dans Animate

Dans Animate, la conversion de documents vers différents types (par exemple, HTML 5, WegGl, GLTF, 360 degrés, panaroma, etc.) s'effectue en deux clics. Vous voulez convertir vos vidéos pour les visionner sur différentes plateformes avec une variété d'options ? Regardez le didacticiel à la fin de cet exemple et suivez ces étapes.

  1. Sur la page Accueil, cliquez sur l'onglet Avancé.

  2. Afficher les options d'utilisation du document sur différentes plates-formes.

  3. Cliquez sur Fichier> Convertir vers et sélectionnez l'option requise.

Comment utiliser les types de documents dans Animate

Regardez la vidéo pour en savoir plus sur les caractéristiques de chaque fonctionnalité.

Création d’un nouveau document à l’aide d’un modèle

  1. Sélectionnez Fichier > Nouveau à partir du modèle.

    Boîte de dialogue Nouveau à partir d’un modèle
    Boîte de dialogue Nouveau à partir d’un modèle

  2. Sélectionnez l’une des catégories de la liste des catégories, choisissez un document dans la liste des éléments de catégorie, puis cliquez sur OK. Vous pouvez choisir parmi les modèles standard fournis avec Animate ou ouvrir un modèle que vous avez enregistré précédemment.

Ouverture d’un document existant

  1. Choisissez Fichier > Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez le fichier ou saisissez le chemin d’accès au fichier dans le champ Atteindre.
  3. Cliquez sur Ouvrir.

Affichage d’un document lorsque plusieurs documents sont ouverts

Lorsque vous ouvrez plusieurs documents sur la plate-forme Windows, des onglets placés en haut de la fenêtre Document vous permettent d’identifier aisément les documents ouverts et de passer de l’un à l’autre. Ces onglets apparaissent uniquement lorsque les documents sont agrandis dans la fenêtre Document.

  1. Cliquez sur l’onglet du document que vous désirez afficher.

    Par défaut, les onglets apparaissent dans l’ordre dans lequel les documents ont été créés. Vous pouvez changer l’ordre des onglets en les faisant glisser.

Ouverture d’une nouvelle fenêtre pour le document en cours

  1. Sélectionnez Fenêtre > Dupliquer la fenêtre.

Définition des propriétés pour un document nouveau ou existant

  1. Ouvrez votre document et choisissez Modification > Document.

    La boîte de dialogue Paramètres du document apparaît.

  2. Pour définir les dimensions de la scène, procédez de l'une des façons suivantes :
    • Pour spécifier la taille de la scène en pixels, saisissez des valeurs dans les champs Largeur et Hauteur. La taille minimale est 1 x 1 pixel ; la taille maximale étant 2 880 x 2 880 pixels.

    • Pour que la taille de la scène corresponde à la quantité exacte d'espace utilisée par le contenu de la scène, sélectionnez l'option Identique à : Contenu.

    • Pour définir la taille de la scène sur la zone d’impression maximale, sélectionnez Identique à : Imprimante. Cette zone est déterminée par la taille du papier moins la marge actuelle sélectionnée dans la zone Marges de la boîte de dialogue Mise en page (Windows) ou Marges d’impression (Macintosh).

    • Pour attribuer à la taille de la scène la taille par défaut, 550 x 400 pixels, cliquez sur Identique à : Par défaut.

  3. Pour spécifier la cadence, entrez-la à l’aide de l’option Cadence.

    Cadence

  4. Pour ajuster la position et l'orientation des objets 3D sur la scène afin de maintenir leur aspect par rapport aux bords de la scène, sélectionnez l'option Ajuster l'angle de perspective 3D pour préserver la projection actuelle de la scène.

    Cette option est disponible uniquement si vous modifiez la taille de la scène.

  5. (CS5.5 uniquement) Pour automatiquement mettre à l'échelle le contenu de la scène en fonction de la modification de la taille de la scène, sélectionnez l'option Mettre à l'échelle le contenu avec la scène.

    Cette option est disponible uniquement si vous modifiez la taille de la scène. Vous pouvez choisir de mettre à l'échelle le contenu dans les calques verrouillés et invisibles dans le panneau Préférences. Pour plus d'informations, voir Définition des préférences générales.

  6. Pour spécifier l'unité de mesure des règles affichées dans la zone de travail, sélectionnez une option dans le menu Unités de la règle. (Ce paramètre fixe également les unités utilisées dans le panneau Info.)
  7. Pour définir la couleur d’arrière-plan de votre document, cliquez sur le nuancier de couleurs d’arrière-plan, puis sélectionnez l’une des couleurs de la palette.
  8. Pour Cadence, indiquez le nombre d’images qui doivent être affichées par seconde.

    Pour la plupart des animations affichées sur ordinateur, en particulier celles qui sont lues à partir d’un site Web, une cadence de 8 à 15 images par seconde est suffisante. Lorsque vous changez la cadence, la nouvelle cadence devient la configuration par défaut pour les nouveaux documents.

  9. (CS5.5 uniquement) Pour enregistrer automatiquement le document à des intervalles définis, sélectionnez l’option d’enregistrement automatique et spécifiez le nombre de minutes entre les enregistrements.
  10. Effectuez l’une des opérations suivantes :
    • Pour appliquer les nouveaux paramètres au document actuel uniquement, cliquez sur OK.

    • Pour que les nouveaux paramètres deviennent les propriétés par défaut de tous les nouveaux documents, cliquez sur Établir comme valeurs par défaut.

Modification des propriétés du document à l’aide de l’inspecteur des propriétés

  1. Cliquez sur l’espace de travail en dehors de la scène pour désélectionner tous les objets sur la scène. Les propriétés du document s’affichent dans l’inspecteur des propriétés. Pour ouvrir l’inspecteur des propriétés, choisissez Fenêtre > Propriétés.
  2. (CS5.5 uniquement) Dans la section Publication, choisissez une version de Flash Player et une version d’ActionScript pour votre document. Pour accéder à des paramètres de publication supplémentaires, cliquez sur le bouton Paramètres de publication. Pour plus d’informations, voir Paramètres de publication.

  3. Dans la section Propriétés, indiquez le nombre d’images d’animation à lire par seconde dans le champ IPS (images par seconde).
  4. Pour modifier la taille de la scène, indiquez les valeurs de largeur et de hauteur de la scène.
  5. Pour sélectionner une couleur d’arrière-plan pour la scène, cliquez sur le nuancier en regard de la propriété Scène et sélectionnez une couleur dans la palette.
  6. Pour modifier d’autres propriétés du document, cliquez sur le bouton Modifier en regard de la propriété Taille. Pour plus d’informations sur l’ensemble des propriétés du document, voir Définition des propriétés pour un document nouveau ou existant.

Animate CC est convivial et vous permet d'utiliser ses différents composants. Vous voulez apprendre à utiliser l'interface de base et les outils d'Animate ? Regardez le didacticiel à la fin de cet exemple et suivez ces étapes.

Ajout de métadonnées XMP à un document

Vous pouvez inclure des données XMP (Extensible Metadata Platform), telles que le titre, l’auteur, la description, les informations de copyright, etc., dans vos fichiers FLA. XMP est un format de métadonnées que gèrent certaines autres applications Adobe®. Les métadonnées peuvent être affichées dans Animate et dans Adobe® Bridge. Pour plus d’informations sur les métadonnées XMP, voir Métadonnées et mots-clés dans l’Aide de Bridge.

Remarque : L’application Bridge 32 bits n’est pas prise en charge dans Adobe Animate.

L’intégration de métadonnées améliore les capacités des moteurs de recherche Web à renvoyer des résultats plus pertinents pour votre contenu Animate. Les métadonnées de recherche sont basées sur les spécifications XMP (Extensible Metadata Platform) et sont stockées dans le fichier FLA sous un format compatible W3C.

Les métadonnées d’un fichier contiennent des informations sur le contenu, les droits de copyright, l’origine et l’historique du fichier. Dans la boîte de dialogue Infos sur le fichier, vous pouvez afficher et modifier les métadonnées du fichier en cours.

Selon le fichier sélectionné, les types de métadonnées suivants peuvent apparaître :

Description

Contient le nom de l’auteur, le titre, les droits de copyright et d’autres informations.

IPTC

Affiche les métadonnées modifiables. Vous pouvez ajouter des légendes à vos fichiers, ainsi que des informations de copyright. IPTC Core est une spécification qui a été approuvée par le conseil IPTC (International Press Telecommunications Council) en octobre 2004. Cette spécification est différente de l’ancienne norme IPTC (IIM, héritée). En effet, de nouvelles propriétés ont été ajoutées, certains noms de propriété ont changé et des propriétés ont été supprimées.

Données de la caméra (Exif)

Affiche des informations attribuées par les caméras numériques, dont les paramètres utilisés au moment de la prise de la photo.

Données vidéo

Affiche les métadonnées des fichiers vidéo, dont les proportions en pixels, la séquence et le plan.

Données audio

Affiche les métadonnées des fichiers audio, dont le nom de l’artiste et de l’album, le numéro de la piste et le genre.

Fichiers SWF pour mobile

Affiche des informations sur les fichiers SWF, dont le titre, le nom de l’auteur, la description et le copyright.

Historique

Journalise les changements apportés aux images avec Photoshop.

Remarque : Pour que le journal soit enregistré avec les métadonnées du fichier, les préférences du Journal de l’historique doivent être activées dans Photoshop.

Version Cue

Affiche toutes les informations de version des fichiers Version Cue.

DICOM

Affiche les informations sur les images enregistrées au format DICOM (Digital Imaging and Communications in Medicine).

Pour ajouter des métadonnées :

  1. Choisissez Fichier > Informations.
  2. Dans la boîte de dialogue Infos fichier qui s’affiche, entrez les métadonnées que vous souhaitez inclure. Vous pouvez ajouter ou supprimer des métadonnées dans le fichier FLA au moment de l’exécution.

Enregistrement de documents Animate

Vous pouvez enregistrer un document FLA Animate en utilisant le nom et l’emplacement actuels ou en utilisant un nouveau nom et un nouvel emplacement.

Lorsqu’un document contient des changements qui n’ont pas été enregistrés, un astérisque (*) apparaît à la suite du nom du document dans la barre de titre du document, la barre de titre de l’application et l’onglet du document. Dès que vous enregistrez le document, l’astérisque disparaît.

Enregistrement d’un document Animate au format FLA par défaut

  1. Effectuez l’une des opérations suivantes :
    • Pour écraser la version actuelle stockée sur le disque, sélectionnez Fichier > Enregistrer.

    • Pour enregistrer le document à un autre emplacement et/ou sous un nouveau nom ou pour compresser le document, sélectionnez Fichier>Enregistrer sous.

  2. Si vous choisissez la commande Enregistrer sous ou si le document n’a jamais été enregistré, vous devez saisir le nom du fichier ainsi que son emplacement.
  3. Cliquez sur Enregistrer.

Enregistrement d’un document au format XFL non compressé

  1. Choisissez Fichier > Enregistrer sous.
  2. Dans le menu Type, sélectionnez Document non compressé Animate (*xfl).

  3. Choisissez le nom et l’emplacement du fichier, puis cliquez sur Enregistrer.

Rétablissement de la dernière version enregistrée d’un document

  1. Sélectionnez Fichier > Rétablir.

Enregistrement d’un document comme modèle

  1. Choisissez Fichier > Enregistrer comme modèle.
  2. Dans la boîte de dialogue Enregistrer comme modèle, saisissez le nom du modèle dans Nom.
  3. Sélectionnez l’une des catégories du menu contextuel Catégorie ou saisissez un nom pour créer une catégorie.
  4. Saisissez la description du modèle dans le champ correspondant (255 caractères au maximum) et cliquez sur OK.

    Lorsque le modèle apparaît dans la boîte de dialogue Nouveau document, sa description s’affiche.

    Pour supprimer un modèle enregistré, accédez à l’un des dossiers suivants et supprimez le fichier FLA de modèle du dossier de catégorie qui le contient.

    • Windows 10 : C:\Users\<nom d’utilisateur>\AppData\Local\Adobe\<version>\<app_locale>\Configuration\Templates\
    • Mac OS : <disque dur>/Utilisateurs/<nom d’utilisateur>/Bibliothèque/Application Support/Adobe/Flash CS5/<langue>/Configuration/Templates/

Enregistrement de documents en quittant Animate

  1. Sélectionnez Fichier > Quitter (Windows) ou Animate > Quitter Animate (Macintosh).

  2. Si un ou plusieurs documents ouverts comportent des modifications non enregistrées, Animate vous invite à les enregistrer ou à les ignorer pour chaque document.

    • Cliquez sur Oui pour enregistrer les modifications et fermer le document.

    • Cliquez sur Non pour fermer le document sans enregistrer les modifications.

Impression de documents Animate (déconseillé avec Flash Professional)

Pour afficher un aperçu de vos documents et les modifier, imprimez des images à partir de documents Adobe Animate ou sélectionnez les images susceptibles d’être imprimées à partir de Flash Player par une visionneuse.

Lors de l’impression d’images à partir d’un document Animate, utilisez la boîte de dialogue Imprimer pour spécifier la plage de scènes ou d’images à imprimer, ainsi que le nombre d’exemplaires. Sous Windows, la boîte de dialogue Mise en page permet de spécifier la taille du papier, son orientation, ainsi que différentes options d’impression (notamment les marges et si toutes les images doivent être imprimées pour chaque page). Sur Macintosh, ces options sont réparties entre les boîtes de dialogue Mise en page et Marges d’impression.

Les boîtes de dialogue Imprimer et Mise en page sont standard pour les deux systèmes d’exploitation et leur apparence dépend du pilote d’imprimante sélectionné.

  1. Sélectionnez Fichier > Mise en page (Windows) ou Fichier > Marges d’impression (Macintosh).
  2. Définissez les marges de la page. Sélectionnez les deux options de centrage pour imprimer l’image au centre de la page.
  3. Dans le menu déroulant Images, indiquez si vous souhaitez imprimer toutes les images du document ou uniquement la première image de chaque séquence.
  4. Dans le menu Disposition, sélectionnez l’une des options suivantes :

    Taille réelle

    Imprime l’image en vraie grandeur. Saisissez une valeur d’échelle pour réduire ou agrandir l’image imprimée.

    Ajuster sur une page

    Réduit ou agrandit chaque image de telle sorte qu’elle remplit la zone d’impression de la page.

    Storyboard

    Imprime plusieurs vignettes sur une page. Choisissez entre Cases, Grille ou Vide. Saisissez le nombre de vignettes par page sous Images. Définissez l’espace entre les vignettes dans le champ Marge d’image et sélectionnez Étiqueter les images pour imprimer l’étiquette de l’image sous forme de vignette.

  5. Pour imprimer des images, sélectionnez Fichier > Imprimer.

Utilisation des étiquettes d’image pour désactiver l’impression

Si vous souhaitez qu’aucune image du scénario principal ne soit imprimée, vous pouvez attribuer l’étiquette !#p à une image pour rendre l’intégralité du fichier SWF non imprimable. Le fait d’étiqueter une image !#p estompe la commande Imprimer du menu contextuel de Flash Player. Vous pouvez également désactiver le menu contextuel tout entier de Flash Player.

Si vous désactivez l’impression à partir de Flash Player, l’utilisateur peut toujours imprimer des images en utilisant la commande Imprimer du navigateur. Cette commande étant une fonction du navigateur, vous ne pouvez ni la contrôler ni la désactiver avec Animate.

Désactivation de l’impression dans le menu contextuel de Flash Player

  1. Ouvrez ou activez le document Animate (fichier FLA) que vous souhaitez publier.

  2. Sélectionnez la première image-clé dans le scénario principal.
  3. Sélectionnez Fenêtre > Propriétés pour afficher l’inspecteur des propriétés.
  4. Dans l’inspecteur des propriétés, pour l’étiquette d’image, saisissez !#p pour définir l’image comme non imprimable.

    Vous n’avez besoin de spécifier qu’une seule étiquette !#p pour estomper la commande Imprimer du menu contextuel.

    Remarque :

    Vous pouvez également sélectionner une image vide (à la place d’une image-clé) et lui attribuer une étiquette #p.

Désactivation de l’impression par la suppression du menu contextuel de Flash Player

  1. Ouvrez ou activez le document Animate (fichier FLA) que vous souhaitez publier.

  2. Choisissez Fichier > Paramètres de publication.
  3. Cliquez sur l’onglet HTML et désactivez l’option Afficher le menu. Cliquez ensuite sur OK.

Spécification d’une zone d’impression lors de l’impression des images

  1. Ouvrez le document Animate (fichier FLA) contenant les images à imprimer.

  2. Sélectionnez une image avec une étiquette d’image #p que vous n’avez pas choisi d’imprimer, mais qui se trouve sur le même calque qu’une image étiquetée #p.

    Pour organiser votre travail, vous pouvez sélectionner l’image qui suit une image étiquetée #p.

  3. Créez une forme sur la scène ayant la taille de la zone d’impression souhaitée. Vous pouvez également sélectionner une image contenant un objet disposant de la taille de zone d’impression appropriée pour utiliser le cadre de sélection de cette image.
  4. Sélectionnez l’image du scénario qui contient la forme que vous utiliserez comme cadre de sélection.
  5. Dans l’inspecteur des propriétés (Fenêtre > Propriétés), saisissez #b pour Étiquette d’image et pour définir la forme sélectionnée comme cadre de sélection de la zone d’impression.

    Vous ne pouvez saisir qu’une seule étiquette d’image #b par scénario. Cette option revient à sélectionner l’option Cadre de délimitation avec l’action Imprimer.

Changement de la couleur d’impression de l’arrière-plan

Vous pouvez imprimer la couleur d’arrière-plan définie dans la boîte de dialogue Propriétés du document. Vous pouvez changer la couleur d’arrière-plan des seules images à imprimer en plaçant un objet coloré dans le calque le plus bas du scénario à imprimer.

  1. Placez une forme remplie couvrant la scène sur le calque le plus bas du scénario à imprimer.
  2. Sélectionnez la forme et choisissez Modification > Document. Sélectionnez la couleur pour l’impression de l’arrière-plan.

    La couleur d’arrière-plan du document entier, y compris celle des clips et des fichiers SWF chargés, est modifiée.

  3. Effectuez l’une des opérations suivantes :
    • Pour imprimer cette couleur comme arrière-plan du document, assurez-vous que l’image dans laquelle vous avez placé la forme est désignée pour l’impression.

    • Pour conserver une couleur d’arrière-plan différente pour les images non imprimables, répétez les étapes 2 et 3. Placez ensuite la forme dans le calque le plus bas du scénario, dans toutes les images qui ne sont pas désignées pour l’impression.

Utilisez la commande Imprimer du menu contextuel de Flash Player pour imprimer les images de tout fichier SWF Animate.

La commande Imprimer du menu contextuel ne permet pas d’imprimer des transparences, des effets de couleur ou des images provenant d’autres clips. Seuls l’objet PrintJob et la fonction print() vous permettent d’accéder à des fonctions d’impression plus élaborées.

  1. Ouvrez le document.

    La commande imprime les images étiquetées #p en utilisant la scène comme zone d’impression ou le cadre de sélection spécifié.

    Si vous n’avez désigné aucune image spécifique pour l’impression, toutes les images du scénario principal du document sont imprimées.

  2. Sélectionnez Fichier > Aperçu avant publication > Par défaut ou appuyez sur la touche F12 pour afficher le contenu Animate dans un navigateur.

  3. Cliquez avec le bouton droit de la souris (Windows) ou en appuyant sur la touche Contrôle (Macintosh) dans le contenu Animate affiché dans le navigateur pour faire apparaître le menu contextuel de Flash Player.

  4. Sélectionnez Imprimer dans le menu contextuel de Flash Player pour afficher la boîte de dialogue d’impression.
  5. Sous Windows, sélectionnez la plage des images à imprimer.
  6. Sur le Macintosh, dans la boîte de dialogue Imprimer, sélectionnez les pages à imprimer.
  7. Activez les autres options d’impression en fonction des propriétés de votre imprimante.
  8. Cliquez sur OK (Windows) ou sur Imprimer (Macintosh).
Remarque :

l’impression depuis le menu contextuel n’interagit pas avec des appels de l’objet PrintJob.

Logo Adobe

Accéder à votre compte