Guide d'utilisation Annuler

Utilisation du squelettage de personnage dans Animate

  1. Guide de l’utilisateur d’Adobe Animate
  2. Présentation d’Animate
    1. Nouveautés d’Adobe Animate
    2. Glossaire visuel
    3. Configuration requise pour Animate
    4. Raccourcis clavier d’Animate
    5. Utilisation de plusieurs types de fichiers dans Animate
  3. Animation
    1. Principes de base de l’animation dans Animate
    2. Utilisation des images et des images-clés dans Animate
    3. Animation image par image dans Animate
    4. Utilisation d’une animation interpolée classique dans Animate
    5. Outil Pinceau
    6. Guide du mouvement
    7. Interpolation de mouvement et ActionScript 3.0
    8. À propos de l’animation d’une interpolation de mouvement
    9. Animation d’une interpolation de mouvement
    10. Création d’une animation d’interpolation de mouvement
    11. Utilisation des images-clés de propriété
    12. Animation d’une position à l’aide d’une interpolation
    13. Modification des interpolations de mouvement avec l’Éditeur de mouvement
    14. Modification de la trajectoire de mouvement d’une animation d’interpolation
    15. Manipulation d’interpolations de mouvement
    16. Ajout d’accélérations personnalisées
    17. Création et application de présélections de mouvement
    18. Configuration de plages d’interpolation d’une animation
    19. Utilisation d’interpolations de mouvement enregistrées au format XML
    20. Interpolations de mouvement et interpolations classiques : comparatif
    21. Interpolation de forme
    22. Utilisation de l’animation de l’outil de segment dans Animate
    23. Utilisation du squelettage de personnage dans Animate
    24. Utilisation de calques de masque dans Adobe Animate
    25. Utilisation de séquences dans Animate
  4. Interactivité
    1. Création de boutons avec Animate
    2. Conversion de projets Animate en d’autres formats de document
    3. Création et publication de documents HTML5 Canvas dans Animate
    4. Ajout d’interactivité à l’aide de fragments de code dans Animate
    5. Création de composants HTML5 personnalisés
    6. Utilisation de composants dans HTML5 Canvas
    7. Création de composants personnalisés : exemples
    8. Fragments de code des composants personnalisés
    9. Pratiques recommandées – Publicité avec Animate
    10. Création et publication de contenu de réalité virtuelle
  5. Espace de travail et workflow
    1. Création et gestion des pinceaux
    2. Utilisation de polices Google Fonts dans les documents HTML5 Canvas
    3. Utilisation des bibliothèques Creative Cloud et d’Adobe Animate
    4. Utilisation de la scène et du panneau Outils pour Animate
    5. Workflow et espace de travail Animate
    6. Utilisation de polices web dans les documents HTML5 Canvas
    7. Scénarios et ActionScript
    8. Utilisation de plusieurs scénarios
    9. Définition des préférences
    10. Utilisation des panneaux de création Animate
    11. Création de calques de scénario avec Animate
    12. Exportation d’animations pour les applications mobiles et les moteurs de jeu
    13. Déplacement et copie d’objets
    14. Modèles
    15. Recherche et remplacement de contenu dans Animate
    16. Commandes Annuler et Rétablir, et panneau Historique
    17. Raccourcis clavier
    18. Utilisation du scénario dans Animate
    19. Création d’extensions HTML
    20. Options d’optimisation des images et des GIF animés
    21. Paramètres d’exportation des images et des fichiers GIF
    22. Panneau Éléments dans Animate
  6. Multimédia et vidéo
    1. Transformation et combinaison d’objets graphiques dans Animate
    2. Création et utilisation d’instances de symboles dans Animate
    3. Vectorisation de l’image
    4. Utilisation du son dans Adobe Animate
    5. Exportation de fichiers SVG
    6. Création de fichiers vidéo en vue de les utiliser dans Animate
    7. Comment ajouter une vidéo dans Animate
    8. Utilisation des points de repère vidéo
    9. Dessin et création d’objets avec Animate
    10. Remodelage des lignes et des formes
    11. Traits, remplissages et dégradés avec Animate CC
    12. Utilisation d’Adobe Premiere Pro et d’After Effects
    13. Panneaux Couleur dans Animate CC
    14. Ouverture de fichiers Flash CS6 à l’aide d’Animate
    15. Utilisation de texte classique dans Animate
    16. Placement d’illustrations dans Animate
    17. Images bitmap importées dans Animate
    18. Graphiques 3D
    19. Utilisation de symboles dans Animate
    20. Dessin de traits et de formes avec Adobe Animate
    21. Utilisation de bibliothèques dans Animate
    22. Exportation de sons
    23. Sélection d’objets dans Animate CC
    24. Utilisation de fichiers AI d’Illustrator dans Animate
    25. Application de motifs avec l’outil Pinceau pulvérisateur
    26. Application de modes de fusion
    27. Disposition d’objets
    28. Automatisation des tâches à l’aide du menu Commandes
    29. Texte multilingue
    30. Utilisation de la caméra dans Animate
    31. Utilisation d’Animate avec Adobe Scout
    32. Utilisation de fichiers Fireworks
    33. Filtres graphiques
    34. Sons et ActionScript
    35. Préférences de dessin
    36. Dessin avec l’outil Plume
  7. Plateformes
    1. Conversion de projets Animate en d’autres formats de document
    2. Prise en charge des plateformes personnalisées
    3. Création et publication de documents HTML5 Canvas dans Animate
    4. Création et publication d’un document WebGL
    5. Assemblage d’applications AIR pour iOS
    6. Publication d’applications AIR pour Android
    7. Publication pour Adobe AIR for Desktop
    8. Paramètres de publication d’ActionScript
    9. Pratiques recommandées – Organisation du code ActionScript dans une application
    10. Utilisation d’ActionScript avec Animate
    11. Pratiques recommandées – Recommandations sur l’accessibilité
    12. Accessibilité dans l’espace de travail Animate
    13. Écriture et gestion des scripts
    14. Activation de la prise en charge des plateformes personnalisées
    15. Présentation de la prise en charge des plateformes personnalisées
    16. Création de contenu accessible
    17. Utilisation du plug-in de prise en charge des plateformes personnalisées
    18. Débogage du code ActionScript 3.0
    19. Activation de la prise en charge des plateformes personnalisées
  8. Exportation et publication
    1. Exportation de fichiers d’Animate CC
    2. Publication OAM
    3. Exportation de fichiers SVG
    4. Exportation d’images et de vidéos avec Animate
    5. Publication de documents AS3
    6. Exportation d’animations pour les applications mobiles et les moteurs de jeu
    7. Exportation de sons
    8. Exportation de fichiers vidéo QuickTime
    9. Contrôle de la lecture vidéo externe à l’aide d’ActionScript
    10. Pratiques recommandées – Conseils pour la création de contenu pour appareils mobiles
    11. Pratiques recommandées – Conventions des vidéos
    12. Pratiques recommandées – Recommandations sur la création d’applications SWF
    13. Pratiques recommandées – Structuration des fichiers FLA
    14. Pratiques recommandées d’optimisation des fichiers FLA pour Animate
    15. Paramètres de publication d’ActionScript
    16. Spécification des paramètres de publication pour Animate
    17. Exportation de fichiers de projection
    18. Exportation d’images et de GIF animés
    19. Modèles de publication HTML
    20. Utilisation d’Adobe Premiere Pro et d’After Effects
    21. Partage et publication rapides de vos animations

Découvrez comment modifier vos personnages à l’aide de squelettes dans Animate.

Squelettage moderne

Le squelettage moderne est la nouvelle façon de constituer rapidement un squelette à l’aide de l’outil Déformation d’élément, de faire pivoter les segments ou de déformer les liaisons afin de créer des poses et d’appliquer une interpolation classique pour créer automatiquement les images intermédiaires et produire une animation homogène.

Voici quelques-unes des fonctionnalités offertes par le workflow Squelettage moderne :

  • Possibilité de créer des segments rigides et souples à l’aide de l’outil Déformation d’élément
  • Possibilité de changer le type de segment de rigide à souple et inversement
  • Possibilité de modifier la densité du filet afin d’équilibrer la qualité de la déformation et les performances
  • Possibilité d’ajouter/de retirer l’épingle sans affecter l’interpolation
  • Possibilité de figer une liaison
  • Possibilité de faire pivoter le segment ou de spécifier l’angle souhaité pour le segment sélectionné dans le panneau Propriétés
  • Onglet Outil dédié dans le panneau Propriétés de l’outil Déformation d’élément
  • Option pour activer/désactiver la propagation des épingles entre les images-clés et plus encore

Création de squelette

Étapes de création d’un squelette :

  • Vous devez sélectionner une forme ou une image bitmap sur scène pour le squelettage.
  • L’outil Déformation d’élément dans le panneau Outils, comme indiqué dans l’image, peut être utilisé pour le squelettage.
création_squelette_1

  • À l’aide de l’outil Déformation d’élément, cliquez sur la partie de la forme ou de l’image bitmap pour ajouter la première liaison. Remarquez qu’il crée un filet triangulé et ajoute une liaison à l’endroit où vous avez cliqué.
création_squelette_2

  • Cliquez ensuite pour ajouter une liaison. Cela ajoute également le segment de la liaison précédemment sélectionnée à la liaison nouvellement ajoutée. Comme le montre l’image, reportez-vous à la section Options de déformation de l’onglet Outil de l’Inspecteur des propriétés lorsque l’outil Déformation d’élément est sélectionné. Ici, l’option Créer des segments qui est activée par défaut garantit qu’un segment est ajouté à la nouvelle liaison à partir de celle précédemment sélectionnée. Si Créer des segments est désactivé ou si aucune des liaisons n’est sélectionnée, la nouvelle liaison n’ajoutera aucun segment.
création_squelette_3

  • Avant d’ajouter une nouvelle liaison, veillez à sélectionner une liaison appropriée à partir de laquelle le segment doit être ajouté à la nouvelle liaison.
création_squelette_4

  • Complétez le squelette en ajoutant tous les segments requis.
modifier_squelette_1


Modification du squelette et de l’interpolation

Déformation

Grâce à l’outil Déformation d’élément, vous pouvez déformer le filet en maintenant la pression sur la liaison et en la faisant glisser. 

modifier_squelette_1

En outre, vous pouvez cliquer sur un segment et le faire glisser afin de le faire pivoter. Lorsque vous faites glisser un segment, sa taille ne change pas de la même façon que lorsque vous faites glisser une liaison.

modifier_squelette_2

Utilisation des images clés

Les images clés du scénario peuvent être utilisées en vue de créer différentes poses. Ajoutez une nouvelle image clé et déformez à l’aide d’une liaison/d’un segment. Chaque image clé conservera sa propre pose préalablement définie. Une fois la pose créée, d’autres transformations peuvent également être appliquées comme le déplacement de l’objet, la mise à l’échelle, la rotation, etc. L’image suivante montre 3 poses différentes sur 3 images clés affichées en utilisant le mode Modifier plusieurs images.

Interpolation classique pour l’interpolation

Une fois les poses créées, l’interpolation classique peut être créée sur des plages d’images en vue de produire une animation fluide sur la base de poses créées sur des images clés. L’image suivante capture la « pelure d’oignon » entre les poses pour montrer comment une animation fluide peut être effectuée à l’aide d’une interpolation classique.

modifier_squelette_4

Ajout/retrait de liaisons

Après avoir défini des poses sur des images clés, si vous devez apporter des modifications au squelette en ajoutant/supprimant des liaisons ou des segments, Animate applique automatiquement la modification correspondante sur toutes les images clés. Par conséquent, il n’est pas nécessaire de basculer manuellement vers chaque image clé pour modifier le squelette.

Vous pouvez retirer un segment en cliquant dessus, puis en appuyant sur la touche Suppr. Tous les segments qui se connectent à cette liaison sont également automatiquement retirés. Si vous souhaitez supprimer uniquement le segment, mais pas la liaison qui y est connectée, vous pouvez le faire en sélectionnant un segment et en appuyant sur la touche Suppr.

modifier_squelette_5

modifier_squelette_6

modifier_squelette_7


Capacités améliorées

Segments souples

Les segments souples sont utiles afin d’obtenir une courbure plus lisse pour le filet sous-jacent lors de la déformation. Par défaut, tous les segments sont rigides. Pour utiliser un segment souple, sélectionnez le segment et modifiez la propriété Type de segment dans la section Options de déformation de l’onglet Objet de l’Inspecteur des propriétés afin d’en faire un segment souple.

segments_souples

Figer les liaisons

Une autre fonctionnalité très utile pour le squelettage est Figer la liaison. Toute liaison figée ne bouge pas lorsqu’une autre partie du squelette est déplacée. Pour figer n’importe quelle liaison, sélectionnez-la et basculez la propriété Figer la liaison dans la section Options de déformation de l’onglet Objet de l’Inspecteur des propriétés.

liaisons_figées

L’image suivante montre un exemple de déformation obtenue en déplaçant simplement la liaison racine vers le bas. D’autres liaisons ne bougent pas parce qu’elles sont figées.

liaisons_figées_1


Autres workflows et raccourcis

Voici quelques-uns des workflows et raccourcis supplémentaires qui se révéleront utiles lors de la création de squelettes.

Faire pivoter le segment

Il existe deux façons de faire pivoter le segment sans changer sa taille. Comme indiqué précédemment, sélectionnez le segment et faites-le glisser pour le faire pivoter. Un autre workflow consiste à sélectionner le segment (ou la liaison à son extrémité) et à modifier avec précision la valeur de rotation à l’aide de la propriété Angle de rotation dans la section Options de déformation de l’onglet Objet de l’Inspecteur des propriétés.

segments_pivotés

Densité du filet

Il existe une case à cocher dans la section Options de déformation de l’onglet Outils et objets de l’Inspecteur des propriétés qui permet d’activer/de désactiver l’affichage sur scène du filet triangulé. En outre, la densité du filet peut être modifiée à l’aide du curseur illustré dans l’image ci-dessous. Une densité de filet plus élevée offre des déformations plus lisses, mais réduit l’efficacité lorsque vous utilisez plusieurs images clés. D’autre part, une densité de filet plus faible se traduit par de meilleures performances au détriment de la qualité de la déformation. Animate calcule automatiquement la densité de filet du personnage déformé en vue d’obtenir un équilibre entre qualité et performances. Cependant, vous pouvez le modifier à l’aide du curseur.

densité_filet

Contrôle de la propagation des modifications

Chaque fois que les propriétés des liaisons ou des segments sont modifiées (Figer la liaison, segment souple/rigide, liaison ouverte/fixe), Animate veille à propager ce changement de manière automatique sur toutes les images clés. Dans certains scénarios, cela peut ne pas être souhaitable. Par exemple, vous avez besoin d’un segment souple uniquement pour des images clés spécifiques et d’un segment rigide sur d’autres images clés. La propriété Propager les modifications dans la section Options de déformation de l’onglet Outil de l’Inspecteur des propriétés vous permet de contrôler si vous avez besoin de propagation ou non.

propagation

Connecter le segment entre les points existants

Afin de créer un segment entre les liaisons existantes, sélectionnez d’abord la liaison qui est censée être la liaison principale du segment. À présent, maintenez la pression sur la touche de modification Alt/Option et cliquez sur une autre liaison qui est censée être l’extrémité du segment.

Déplacer la liaison sans modifier la déformation

Le déplacement de toute liaison entraîne une déformation. Parfois, après avoir créé une pose déformée, il est nécessaire de simplement changer la position de la liaison sans changer la déformation. Pour ce faire, vous pouvez maintenir la pression sur la touche de modification Alt/Option tout en déplaçant la liaison.

Déplacer uniquement la liaison sélectionnée (sans déplacer la liaison enfant)

Sélectionnez la liaison à déplacer en double-cliquant dessus. Maintenant, le déplacement de cette liaison n’affectera pas les autres liaisons reliées à celle-ci au moyen de segments. Il s’agit de désactiver temporairement la cinématique avant.

Quelle est la prochaine étape ?

Nous avons tout ce qu’il vous faut pour créer le squelette de votre personnage. Vous pouvez maintenant apprendre à partager votre animation sur les réseaux sociaux à partir d’Animate.

Logo Adobe

Accéder à votre compte