Layers overview

Layers are the elements that make up a composition. Without layers, a composition is only an empty frame. Use as many layers as necessary to create your composition. Some compositions contain thousands of layers, whereas some compositions contain only one layer.

Layers in After Effects are similar to tracks in Adobe Premiere Pro. The primary difference is that each After Effects layer can have no more than one footage item as its source, whereas a Premiere Pro track typically contains multiple clips. Layers in After Effects are also similar to layers in Photoshop, though the interface for working with layers differs. Working with layers in the Timeline panel in After Effects is similar to working with layers in the Layers panel in Photoshop.

You can create several kinds of layers:

  • Video and audio layers that are based on footage items that you import, such as still images, movies, and audio tracks

  • Layers that you create within After Effects to perform special functions, such as cameras, lights, adjustment layers, and null objects

  • Solid-color layers that are based on solid-color footage items that you create within After Effects

  • Synthetic layers that hold visual elements that you create within After Effects, such as shape layers and text layers

  • Precomposition layers, which use compositions as their source footage items

When you modify a layer, you do not affect its source footage item. You can use the same footage item as the source for more than one layer and use the footage differently in each instance. (See Importing and interpreting footage items.)

Changes made to one layer do not affect other layers, unless you specifically link the layers. For example, you can move, rotate, and draw masks for one layer without disturbing any other layers in the composition.

After Effects automatically numbers all layers in a composition. By default, these numbers are visible in the Timeline panel next to the layer name. The number corresponds to the position of that layer in the stacking order. When the stacking order changes, After Effects changes all numbers accordingly. The layer stacking order affects rendering order and therefore affects how the composition is rendered for previews and final output. (See Render order and collapsing transformations.)

Layers in the Layer, Composition, and Timeline panels

After you add a layer to a composition, you can reposition the layer in the Composition panel. In the Timeline panel, you can change a layer’s duration, starting time, and place in the layer stacking order. You can also change any of the properties of a layer in the Timeline panel. (See Layer properties in the Timeline panel.)

You can perform many tasks—such as drawing masks—in either the Composition panel or the Layer panel. However, other tasks—such as tracking motion and using the paint tools—must be performed in the Layer panel.

The Layer panel shows you a layer before any transforms are applied to the layer. For example, the Layer panel does not show the result of modifying the Scale property of a layer. To see a layer in context with other layers and with the results of transforms, use the Composition panel.

Layers that are not based on a source footage item are synthetic layers. Synthetic layers include text layers and shape layers. You cannot open a synthetic layer in the Layer panel. You can, however, precompose a synthetic layer and open the precomposition in the Layer panel.

Note:

To view changes to a layer (such as masks or effects) in the Layer panel, select Render in the Layer panel. Deselect Render to view the original, unaltered layer.

Opening layers and layer sources

  • To open a layer other than a precomposition layer in the Layer panel, double-click the layer, or select the layer and choose Layer > Open Layer.

  • To open the source composition of a precomposition layer in the Composition panel, double-click the layer, or select the layer and choose Layer > Open Composition.

  • To open the source footage item of a layer, Alt-double-click (Windows) or Option-double-click (Mac OS) the layer, or select the layer and choose Layer > Open Layer Source.

Note:

If you right-click (Windows) or Control-click (Mac OS) a layer, you can choose Open Footage or Open Composition to open the layer’s source item.

  • To open a precomposition layer in the Layer panel, Alt-double-click (Windows) or Option-double-click (Mac OS) the layer, or select the layer and choose Layer > Open Layer.

Create layers from footage items or change layer source

You can create a layer from any footage item in the Project panel, including another composition. After you add a footage item to a composition, you can modify and animate the resulting layer.

When you add a composition to another composition, you create a layer that uses the composition that you added as its source. (See Precomposing, nesting, and pre-rendering.)

The Still Footage preference setting (Preferences > Import) controls the default duration of layers that use still footage items as their sources. By default, when you create a layer with a still image as its source, the duration of the layer is the duration of the composition. You can change the duration of the layer after it’s created by trimming the layer.

Note:

By default, new layers begin at the beginning of the composition duration. You can instead choose to have new layers begin at the current time by deselecting the Create Layers At Composition Start Time preference (Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac OS)).

Often, the next step after adding a layer to a composition is scaling and positioning the layer to fit in the frame. (See Scale or flip a layer.)

Create layers from one or more footage items

When you create layers from multiple footage items, the layers appear in the layer stacking order in the Timeline panel in the order in which they were selected in the Project panel.

  1. Select one or more footage items and folders in the Project panel.
  2. Do one of the following:
    • Drag the selected footage items to the Composition panel.

    Note:

    Hold Shift while dragging to snap the layer to the center or edges of the composition.

    • Drag the selected footage items to the Timeline panel. When you drag the item into the layer outline, a highlight bar indicates where the layer will appear when you release the mouse button. If you drag the item over the time graph area, a time marker indicates where the In point of the layer will be when you release the mouse button.

    Note:

    Hold Shift while dragging to snap the In point to the current-time indicator.

    • Drag the selected footage items to the composition name or icon in the Project panel, or press Ctrl+/ (Windows) or Command+/ (Mac OS). New layers are created immediately above a selected layer and at the center of the composition. If no layer is selected, then new layers are created at the top of the layer stack.

Create a layer from a trimmed footage item

You can trim a moving-image footage item in the Footage panel before inserting a layer based on that footage item into a composition.

  1. Double-click a footage item in the Project panel to open it in the Footage panel. (See View footage items in the Footage panel.)

  2. Move the current-time indicator in the Footage panel to the frame that you want to use as the In point of the layer, and click the Set In Point button  at the bottom of the Footage panel.
  3. Move the current-time indicator in the Footage panel to the frame that you want to use as the Out point of the layer, and click the Set Out Point button  at the bottom of the Footage panel.
  4. To create a layer based on this trimmed footage item, click an Edit button at the bottom of the Footage panel:

    Overlay Edit

    Creates the new layer at the top of the layer stacking order, with the In point set at the current time in the Timeline panel.

    Ripple Insert Edit

    Also creates the new layer at the top of the layer stacking order, with the In point set at the current time in the Timeline panel, but splits all other layers. Newly created split layers are moved later in time so that their In points are at the same time as the Out point of the inserted layer.

Replace layer sources with references to another footage item

  1. Select one or more layers in the Timeline panel
  2. Alt-drag (Windows) or Option-drag (Mac OS) a footage item from the Project panel onto a selected layer in the Timeline panel.

Solid-color layers and solid-color footage items

You can create layers of any solid color and any size (up to 30,000x30,000 pixels). Solid-color layers have solid-color footage items as their sources. Solid-color layers and solid-color footage items are both usually called solids.

Solids work just like any other footage item: You can add masks, modify transform properties, and apply effects to a layer that has a solid as its source footage item. Use solids to color a background, as the basis of a control layer for a compound effect, or to create simple graphic images.

Solid-color footage items are automatically stored in the Solids folder in the Project panel.

Jeff Almasol provides a script on his redefinery website with which you can rename the selected solid footage items in the Project panel. You can use this script to, for example, include the pixel dimensions, aspect ratio, and RGB color values in the name.

Note:

In After Effects CS6 and later, new solid layers are 17% gray (45/255) so they can contrast with the new default darker user interface brightness

Create a solid-color layer or solid-color footage item

  • To create a solid footage item but not create a layer for it in a composition, choose File > Import > Solid.
  • To create a solid footage item and create a layer for it in the current composition, choose Layer > New > Solid or press Ctrl+Y (Windows) or Command+Y (Mac OS).

    To create a layer that fits the composition when you create a solid-color layer, choose Make Comp Size.

Modify settings for solid-color layers and solid-color footage items

  • To modify settings for the selected solid-color layer or footage item, choose Layer > Solid Settings.

    To apply the changes to all solid-color layers that use the footage item, select Affect All Layers That Use This Solid. If you don’t select this option, you create a new footage item, which becomes the source for the selected layer.

Adjustment layers

When you apply an effect to a layer, the effect applies only to that layer and no others. However, an effect can exist independently if you create an adjustment layer for it. Any effects applied to an adjustment layer affect all layers below it in the layer stacking order. An adjustment layer at the bottom of the layer stacking order has no visible result.

Because effects on adjustment layers apply to all layers beneath them, they are useful for applying effects to many layers at once. In other respects, an adjustment layer behaves like other layers; for example, you can use keyframes or expressions with any adjustment layer property.

Note:

A more accurate description is that the adjustment layer applies the effect to the composite created from all layers below the adjustment layer in the layer stacking order. For this reason, applying an effect to an adjustment layer improves rendering performance compared with applying the same effect separately to each of the underlying layers.

Note:

If you want to apply an effect or transformation to a collection of layers, you can precompose the layers and then apply the effect or transformation to the precomposition layer. (See Precompose layers.)

Use masks on an adjustment layer to apply an effect to only parts of the underlying layers. You can animate masks to follow moving subjects in the underlying layers.

  • To create an adjustment layer, choose Layer > New > Adjustment Layer, or press Ctrl+Alt+Y (Windows) or Command+Option+Y (Mac OS).
  • To convert selected layers to adjustment layers, select the Adjustment Layer switch for the layers in the Timeline panel or choose Layer > Switches > Adjustment Layer.

Note:

You can deselect the Adjustment Layer switch for a layer to convert it to a normal layer.

Online resources about adjustment layers

Andrew Kramer provides a video tutorial on his Video Copilot website in which he shows how to use an adjustment layer to apply an effect to only a short duration and to only specific portions of a movie.

Eran Stern provides a video tutorial on the Creative COW website that demonstrates the use of lights as adjustment layers, to precisely control which layers are affected by which lights.

Lloyd Alvarez provides a script on his After Effects Scripts website that creates an adjustment layer above each selected layer, with each new adjustment layer trimmed to the duration of the selected layer.

Create a layer and new Photoshop footage item

When you create an Adobe Photoshop file from After Effects, Photoshop starts and creates a new PSD file. This PSD file consists of a blank Photoshop layer that has the same dimensions as your composition, with the appropriate title-safe, and action-safe guides. The color bit depth of the PSD file is the same as the color bit depth of your After Effects project.

The newly created PSD file is automatically imported into After Effects as a footage item. Any changes that you save in Photoshop appear in the footage item in After Effects.

  • To create a Photoshop footage item and use it as the source for a new layer in the current composition, choose Layer > New > Adobe Photoshop File. The Photoshop layer is added as the top layer in your composition.
  • To create a Photoshop footage item with the settings of the most recently open composition, without adding it to a composition, choose File > New > Adobe Photoshop File.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy