Проблем

Когато влезете в конкретен потребителски акаунт на Mac компютър или компютър, работещ под Windows 7 или следваща, дадено приложение на Adobe проявява неочаквано поведение.Например то не ще да се стартира, изпълнява командите неправилно, връща грешки или се затваря неочаквано. Проблемите не възникват при влизане в нов или друг потребителски акаунт.

Преди да започнете

Mac OS

Направете резервно копие на стартовия диск, преди да започнете да изпълнявате задачите в този документ.

Когато изпълнявате някои от стъпките в този документ, Finder показва прозорец за удостоверяване. Когато се покаже прозорец за удостоверяване, въведете потребителското име и паролата за потребителски акаунт на администратор, след което щракнете върху OK.

Има много възможни причини за неочакваното поведение в конкретен акаунт. Този документ разглежда само най-честите причини. За допълнителна помощ при отстраняване на проблеми с потребителските акаунти се свържете с Поддръжка на Apple.

Windows

Направете архивиране на системния диск, преди да започнете да изпълнявате задачите в този документ.

Тези задачи понякога показват диалогов прозорец за контрол на потребителските акаунти, който изисква вашето разрешение за продължаване. Прочетете подробностите в диалоговия прозорец, за да определите дали искате да продължите. Ако решите да откажете разрешение в диалоговия прозорец, не можете да продължите с тази задача.

Някои от задачите в този документ включват скрити папки. По подразбиране Windows Explorer не показва скритите папки. За да направите скритите папки видими, вижте Показване на скрити файлове, папки, разширения на файлови имена | Windows XP, Vista, Windows 7.

Има много възможни причини за неочакваното поведение в конкретен акаунт. Този документ разглежда само най-честите причини. За допълнителна помощ при отстраняване на проблеми с потребителските акаунти, свържете се с производителя на компютъра ви или посетете сайта за помощ и поддръжка на Microsoft на адрес http://support.microsoft.com.

Решения

Влезте в потребителския акаунт, в който приложението на Adobe показва неочаквано поведение. След това изпълнете следните задачи:

Mac OS

1. Дайте разрешения за четене и писане на необходимите папки.

Уверете се, че потребителският акаунт има права за четене и писане за следните папки:

  • /Applications/Adobe
  • /Applications/.AdobePatchFiles (скрита, използвайте командата Go > Go to Folder)
  • /Applications/Utilities/Adobe
  • /Library/Application Support/Adobe
  • /Library/Preferences/com.adobe
  • /Users/[потребител]/Library/Application Support/Adobe
  • /Users/[потребител]/Library/Caches/Adobe
  • /Users/[потребител]/Library/Caches/com.adobe
  • /Users/[потребител]/Library/Preferences/Adobe
  • /Users/[потребител]/Library/Preferences/com.adobe

След като предоставите разрешенията, за да влязат в сила промените, излезте от потребителския акаунт и влезте отново, или рестартирайте устройството.

2. Създайте отново файловете с предпочитания за приложението на Adobe за конкретния акаунт.

Приложенията на Adobe съхраняват персонализираните потребителски настройки във файлове за предпочитания. Всеки потребителски акаунт има собствен набор от файлове за предпочитания.

Когато дадено приложение на Adobe проявява неочаквано поведение само в конкретен потребителски акаунт, причината може да е в повредата на някой от файловете за предпочитания на приложението. Можете да принудите приложението на Adobe да създаде неповредени файлове с предпочитания, като преименувате текущите файлове с предпочитания. Някои приложения на Adobe съхраняват няколко файла с предпочитания в папка; за тези приложения можете да преименувате папката.

Някои приложения на Adobe записват предпочитанията както в папки, така и в отделни файлове. Например, Adobe Photoshop CS4 използва както файл с предпочитания, наречен com.adobe.Photoshop.plist, така и папка с предпочитания, наречена Adobe Photoshop CS4 Settings. За да накарате Photoshop CS4 да създаде неповредени файлове с предпочитания, преименувайте тези два елемента. Например, преименувайте ги като Old com.adobe.Photoshop.plist и Old Adobe Photoshop CS4 Settings, съответно.

Обикновено приложенията на Adobe съхраняват файловете и папките с предпочитания в едно или повече от следните места:

  • /Users/[потребителско име]/Library/Preferences
  • /Users/[потребителско име]/Library/Preferences/Adobe
  • /Users/[потребителско име]/Library/Application Support/Adobe

Важно: Apple направи папката на потребителските библиотеки скрита по подразбиране от Mac OS X 10.7 насам. Ако имате нужда от достъп до файлове в скритата папка с библиотеки, за да отстранявате проблеми, свързани с Adobe, вижте Как се получава достъп до скритите файлове на потребителските библиотеки.

Някои приложения на Adobe съхраняват допълнителни файлове с предпочитания на други места. Например Adobe Premiere Pro CS4 съхранява допълнителни файлове с предпочитания в папки с имена „Layouts“, „Settings“ и „Styles“. Тези файлове се намират в /Users/[потребителско име]/Documents/Adobe/Premiere Pro/4.0.

За да определите точните имена и местоположения на папките и файловете с предпочитания за приложението на Adobe, за което отстранявате проблеми, отидете на www.adobe.com/bg/support. Потърсете в базата знания думата "предпочитания" плюс името и версията на приложението. След това разгледайте документа "Системни грешки или увисвания" или други документи, които са показани в резултатите от търсенето.

За да създадете отново файлове с предпочитания за приложение на Adobe, направете следното:

  1. Излезте от приложението на Adobe.
  2. Преименувайте папките и файловете с предпочитания на приложението на Adobe.
  3. Отворете приложението на Adobe. Приложението ще създаде файлове с предпочитания.

След като сте създали отново файловете и папките с предпочитания, опитайте да възпроизведете проблема.

Ако проблемът все още се появява, тогава причината не е в повреден файл с предпочитания. За да възстановите персонализираните настройки на потребителския акаунт, изтрийте новите файлове и папки с предпочитания. След това възстановете първоначалните имена на всички елементи, които преименувахте преди това.

Ако проблемът не се появява повече, тогава причината е била в повреден файл с предпочитания. Обаче персонализираните настройки, свързани с предишните файлове с предпочитания, са загубени.

3. Отстранете проблемите с шрифтовете в конкретния акаунт.

Шрифтовете в Mac OS могат да бъдат инсталирани или за всички потребителски акаунти, или само за конкретен потребителски акаунт. Файловете с шрифтове за конкретен акаунт се намират в /Users/[потребителско име]/Library/Fonts.

Когато дадено приложение на Adobe се държи неочаквано само в определен акаунт, причината може да е повреден файл с шрифтове, инсталиран само за този акаунт.

Използвайте приложението Font Book, което е включено в Mac OS X, за временно деактивиране на всички шрифтове за конкретния акаунт. След като деактивирате шрифтовете за конкретния акаунт, потърсете и изтрийте кешовите файловете за шрифтове на Adobe. Направете следното:

  1. Излезте от всички отворени приложения.
  2. Ако обикновено за активиране и деактивиране шрифтовете използвате помощна програма за управление на шрифтовете от трето лице, временно я забранете. За инструкции вижте нейната документация.
  3. Отворете Font Book. (По подразбиране Font Book се намира в папка Applications.)
  4. В колоната „Collection“ (Колекция) изберете потребител. След това направете едно от следните неща:

    • Ако колоната "Font“ (Шрифт) е празна, тогава няма инсталирани шрифтове за конкретния потребителски акаунт. Пропуснете останалите стъпки от тази задача и продължете със Задача 3.
    • Ако в колоната „Font“ (Шрифт) се появи поне един шрифт, изберете Edit > Disable „User“ (Редактиране > Забрани „Потребител“).
  5. Във Finder изберете File > Find (Файл > Намери). Опциите за търсене се показват в горната част на най-предния прозорец на Finder.

  6. Потърсете кеш файловете за шрифтове на Adobe, като зададете опциите за търсене, както следва:

    • Mac OS X v.10.4.x: В горния ред от опциите за търсене изберете „Home“. На втория ред изберете „Name“ (Име) и „Begins With“ (Започва с) от двете изскачащи менюта. След това въведете AdobeFnt в текстовото поле вдясно от „Begins With“ (Започва с).
    • Mac OS X v.10.5.x: и следващи: В горния ред от опциите за търсене изберете името на потребителския акаунт (което се показва в кавички). На втория ред изберете „Name“ (Име) и „Begins With“ (Започва с) от двете изскачащи менюта. След това въведете AdobeFnt в текстовото поле вдясно от „Begins With“ (Започва с).
  7. В резултатите от търсенето изтрийте всички файлове, чието име започва с AdobeFnt и завършва на .lst.

  8. Отворете приложението на Adobe и опитайте да възпроизведете проблема.

Ако проблемът все още се появява, тогава причината не е в шрифт на конкретния акаунт. Повторно активирайте шрифтове за конкретния акаунт, като отворите Font Book и изберете потребител в колоната „Collection“ (Колекция) и изберете "Edit > Enable“ (Редактиране > Разреши). След това продължете със Задача 3.

Ако проблемът вече не се появява, тогава причината е в шрифт на конкретния акаунт. За да определите точния шрифтов файл, който причинява проблема, направете следното:

  1. Отворете Font Book.

  2. В колоната „Collection“ (Колекция) изберете User (Потребител).

  3. В колоната „Font“ (Шрифт) изберете един от забранените шрифтове.

  4. Изберете Edit (Редактиране) > Enable (Разреши) [Име на шрифта].

  5. Отворете приложението на Adobe и опитайте да възпроизведете проблема. След това направете едно от следните неща:

    • Ако проблемът все още възниква, излезте от приложението на Adobe и повторете стъпки от 3 до 5.
    • Ако проблемът вече не възниква, причината е в шрифта, който последно сте активирали отново. Оставете този шрифт деактивиран; или изтрийте този шрифт и се свържете с издателя на шрифтове за заместващ файл с шрифтове.

4. Изтрийте кешовите файлове на Adobe за конкретния акаунт.

Някои приложения на Adobe създават временни файлове с данни, известни като кешови файлове. Прекалено големите или повредени кешови файлове в даден потребителски акаунт могат да причинят неочаквано поведение на приложение на Adobe.

Направете следното:

  1. Затворете всички приложения на Adobe.

  2. Във Finder отидете до /Users/[потребителско име]/Library/Caches.

  3. В папка „Caches“ изтрийте папка „Adobe“.

  4. Изтрийте всички други папки в папката "Caches" (Кеш), които са наречени на името на приложението на Adobe, за което отстранявате проблеми.

  5. Изтрийте всички други папки в папката "Caches" (Кеш), които са наречени на името на компонент на приложението на Adobe, за което отстранявате проблеми. Ако например отстранявате проблеми във Photoshop CS4, изтрийте също и папката „Adobe Camera Raw“, която е в папка „Caches“.

  6. Отворете приложението на Adobe и опитайте да възпроизведете проблема.

Ако проблемът все още се появява, преминете към следващата задача.

5. Отстранете проблемите със стартиращите елементи а конкретния акаунт.

Стартиращите елементи са приложения или документи, които се отварят автоматично, когато влезете в даден потребителски акаунт. (Те също така се отварят автоматично, когато стартирате компютъра, ако сте активирали автоматичното влизане.) Някои стартиращи елементи остават скрити след отварянето им. Когато приложение на Adobe се държи неочаквано в даден акаунт, възможно е един от стартиращите елементи да работи неправилно, да е повреден или да е несъвместим с приложението на Adobe.

За да определите дали някои от стартиращите елементи на потребителския акаунт причиняват проблема в приложението на Adobe, направете следното:

  1. Изберете Apple Menu > Log Out [потребителско име].

  2. В диалоговия прозорец за потвърждение щракнете върху Log Out (Излизане). След няколко минути ще се покаже прозорецът за влизане.

  3. В прозореца за влизане изберете името на потребителския акаунт, в който отстранявате проблеми.

  4. Въведете паролата на потребителския акаунт в полето за парола; ноне натискайте Return, и все още не щракайте върху „Log In“ (Влизане).

  5. Задръжте натиснат клавиша Shift и щракнете върху Log In (Влизане). Отпуснете клавиша Shift, когато се появи Dock. Стартиращите елементи са деактивирани, докато не излезете (или рестартирате компютъра).

  6. Отворете приложението на Adobe и опитайте да възпроизведете проблема.

Ако проблемът все още се появява, тогава причината не е в стартиращ елемент. Разрешете отново стартиращите елементи, като излезете (чрез Apple Menu > Log Out [потребителско име]). След това влезте отново в същия акаунт, без да държите натиснат клавиша Shift. След това продължете със Задача 5.

Ако проблемът вече не се появява, тогава причината е в стартиращ елемент. За да определите точния стартиращ елемент, който причинява проблема, направете следното:

Ако проблемът все още се появява, тогава причината не е в шрифт на конкретния акаунт. Повторно активирайте шрифтовете за конкретния акаунт, като отворите Font Book и изберете потребител в колоната „Collection“ (Колекция) и изберете Edit > Enable (Редактиране > Разреши). След това продължете със Задача 3.

Ако проблемът вече не се появява, тогава причината е в шрифт на конкретния акаунт. За да определите точния шрифтов файл, който причинява проблема, направете следното:

  1. Изберете Apple Menu > Log Out [потребителско име].

  2. Влезте отнововсъщия акаунт. Не дръжте натиснат клавиша Shift.

  3. Изберете Apple Menu > System Preferences (Предпочитания за системата).

  4. В прозореца „System Preferences“ (Предпочитания за системата) изберете Accounts (Акаунти).

  5. Ако иконата на катинарчето в долната част на прозореца е в заключено състояние, тогава щракнете върху иконата и се удостоверете.

  6. Изберете потребителския акаунт, в който отстранявате проблеми.

  7. Щракнете върху раздел Login Items (Стартиращи елементи).

  8. Направете списък на текущите стартиращи елементи.

  9. Изберете стартиращ елемент и натиснете „Delete“ (Изтриване).

  10. Отворете приложението на Adobe и опитайте да възпроизведете проблема. След това направете едно от следните неща:

    • Ако проблемът все още възниква, излезте от приложението на Adobe и повторете стъпките от 9 до 10.
    • Ако проблемът вече не възниква, причината е в стартиращия елемент, който последно сте изтрили. Свържете се с издателя на този стартиращ елемент за информация относно наличието на актуализирана версия. Възстановете другите стартиращи елементи, като плъзнете техните икони в областта на стартиращите елементи в предпочитанията за системата. Или инсталирайте отново приложението, свързано с дадения стартиращ елемент.

6. Върнете първоначалните настройки за достъп до папката с библиотеки на потребителския акаунт.

Завършете тази задача само ако акаунтът, в който отстранявате проблеми, е администраторски акаунт и има парола.

Всеки файл и папка в том на Mac OS X има настройки за собственост и разрешения в стила на Unix. Тези настройки определят кои потребителски акаунти имат достъп до файла или папката и кои акаунти нямат достъп.

Приложението на Adobe може да се държи неочаквано в даден акаунт, ако неговите настройки за достъп до папката на библиотеките (или подпапка) са повредени или имат неправилни лимити. Можете да използвате Unix командите chmod и chown, за да коригирате тези настройки. Направете следното:

  1. Във Finder изберете Go > Home (Отиди в > Начална страница). Най-предният прозорец на Finder отива в папка „Home“ на потребителския акаунт. Запишете си името в заглавието на този прозорец на Finder. Това име е „краткотопотребителско име" за потребителския акаунт. (Това краткопотребителско имее необходимо, з ада се завърши Стъпка 3.)

  2. Отворете приложението Terminal, което се намира по подразбиране в /Applications/Utilities.

  3. Като използвате една от командите по-долу като шаблон, въведете действителната команда в прозореца Terminal и след това натиснете Return. (След като натиснете Return в края на командата, ще видите подкана за въвеждане на парола. Въведете паролата за потребителския акаунт и натиснете отново Return. Докато въвеждате всеки знак на паролата, няма да имате никаква обратна връзка за въведеното, като например звездички. Това поведение е нормално.)

    Важно: Всяка от командите по-долу е примерна, а не действителна команда, която трябва да въведете. В действителната команда, която въвеждате, заменете username с краткото потребителско име, което сте идентифицирали в стъпка 1. Въведете краткото потребителско име с малки букви. (В Mac OS X v10.4.x въведете краткото потребителско име два пъти, разделено с двоеточие. В Mac OS X v.10.5.x въведете краткото потребителско име, последвано от двоеточие и думата staff.)

    Шаблонна команда за Mac OS X v.10.4.x:


    sudo chown-R username:username

    Шаблонна команда за Mac OS X v.10.5.x:

    sudo chown-R username:staff~/Library

  4. Напишете командата по-долу точно както е показано, и след това натиснете Return.

    sudo chmod -R 700 ~/Library

  5. Излезте от Terminal.

  6. Отворете приложението на Adobe и опитайте да възпроизведете проблема.

Ако проблемът все още се появява, преминете към следващата задача.

7. Поправете стартовия диск.

Повреждане на диска, което засяга само конкретен потребителски акаунт, може да доведе до неочаквано поведение на приложение на Adobe в този акаунт.

Изпълнете стъпките по-долу, ако имате инсталационния диск за Mac OS X, който се доставя заедно с компютъра ви. Ако нямате този диск, можете да поправите стартовия диск с помощта на командата fsck в Terminal. Или можете да използвате помощна програма за поправка на дискове на трето лице. За инструкции относно използването на командата fsck вижте статия TS1417 на сайта за поддръжка на Apple. За инструкции относно използването на помощна програма за поправка на дискове от трето лице вижте документацията на помощната програма.

  1. Поставете инсталационния диск за Mac OS X в оптичното устройство на компютъра.
  2. Изберете Apple Menu > Restart (Рестартиране).
  3. Когато чуете стартовия сигнал, задръжте натиснат клавиша C на клавиатурата.
  4. Когато видите прозореца за стартиране с лентата за хода на изпълнението, опуснете клавиша C.
  5. Ако инсталиращата програма на Mac OS X ви подкани да изберете език, тогава изберете предпочитания от вас език.
  6. Когато се покаже менюто на инсталиращата програма (в горната лява част на екрана) изберете Installer > Disk Utility.
  7. В Disk Utility изберете стартовия диск от лявата страна.
  8. Щракнете върху First Aid (Първа помощ)отдясната страна.

  9. Щракнете върху Repair Disk (Поправяне на диск).

  10. Ако процесът на поправка приключи с индикация, че е коригирал дисковите грешки, тогава повторете стъпка 9. Когато процесът на поправка завърши без показване на намерени грешки, отворете приложението на Adobe и опитайте да възпроизведете проблема.

Ако проблемът все още се появява, преминете към следващата задача.

8. Използвайте нов потребителски акаунт.

Ако приложението все още се държи неочаквано в даден акаунт, тогава препоръчване да копирате (или преместите) всички лични файлове в новия потребителски акаунт. След това използвайте новия акаунт като ваш нормален акаунт.

За помощ при копиране на личните файлове в нов потребителски акаунт се свържете с Поддръжка на Apple.

Windows

1. Дайте разрешения за четене и писане на необходимите папки.

Уверете се, че потребителският акаунт има права за четене и писане за следните папки:

  • C:\Program Files\Adobe
  • C:\Program Files\Common Files\Adobe
  • C:\Program Files (x86)\Adobe
  • C:\Program Files (x86)\Common Files\Adobe
  • C:\ProgramData\Adobe
  • C:\Users\\AppData\Roaming\Adobe
  • C:\Users\\AppData\Roaming\com.adobe.
  • C:\Users\\AppData\Local\Adobe
  • C:\Users\\AppData\LocalLow\Adobe
  • C:\Users\\AppData\Local\VirtualStore\Program Files\Common Files\Adobe

2. Създайте отново файловете с предпочитания за приложението на Adobe за конкретния акаунт.

Приложенията на Adobe съхраняват персонализираните потребителски настройки във файлове за предпочитания. Всеки потребителски акаунт има собствен набор от файлове за предпочитания.

Когато дадено приложение на Adobe проявява неочаквано поведение само в конкретен потребителски акаунт, причината може да е в повредата на някой от файловете за предпочитания на приложението. Можете да принудите приложението на Adobe да създаде неповредени файлове с предпочитания, като преименувате папката, която съдържа файловете с предпочитания.

Например Adobe Premiere Pro CS4 записва файловете с предпочитания в папка, наречена 4.0, която се намира в C:\Users\[потребителско име]\AppData\Roaming\Adobe\Premiere Pro. За да принудите Adobe Premiere Pro CS4 да създаде отново файлове с предпочитания, преименувайте папката 4.0 (например я преименувайте на Old 4.0).

Обикновено приложенията на Adobe съхраняват файловете и папките с предпочитания в едното или и в двете от следните места:

  • C:\Users\[потребителско име]\AppData\Roaming\Adobe
  • C:\Users\[потребителско име]\AppData\Local\Adobe

Някои приложения на Adobe съхраняват допълнителни файлове с предпочитания на други места. Например Adobe Premiere Pro CS4 съхранява допълнителни файлове с предпочитания в папки с имена „Styles“ и „Layouts“, които се намират в C:\Users\[потребителско име]\Documents\Adobe\Premiere Pro\4.0.

За да определите точните имена и местоположения на папките с предпочитания за приложението на Adobe, за което отстранявате проблеми, отидете в www.adobe.com/bg/support.Потърсете в базата знания думата "предпочитания" плюс името и версията на приложението. След това вижтевдокумента "Системни грешки или увисвания" или други документи, които са показани в резултатите от търсенето.

За да създадете отново файлове с предпочитания за приложение на Adobe, направете следното:

  1. Затворете приложението на Adobe.

  2. Преименувайте папките с предпочитания на приложението на Adobe.

  3. Стартирайте приложението на Adobe. Приложението ще създаде неповредени файлове с предпочитания.

След като сте създали отново файловете с предпочитания, опитайте да възпроизведете проблема.

Ако проблемът все още се появява, тогава причината не е в повреден файл с предпочитания. За да възстановите персонализираните настройки на потребителския акаунт за приложението на Adobe, изтрийте новите папки с предпочитания. След това възстановете първоначалните имена на папките, които преименувахте преди това.

Ако проблемът не се появява повече, тогава причината е била в повреден файл с предпочитания. (Потребителският акаунт е загубил персонализираните настройки, свързани с предишните файлове с предпочитания.)

3. Изтрийте временните файлове за конкретния акаунт.

Някои приложения на Adobe съхраняват данни във временни файлове. Дадено приложение на Adobe може да проявява неочаквано поведение, ако временните файлове за конкретния акаунт станат прекомерни стари или се повредят.

За да изтриете временните файлове, използвайте помощната програма Disk Cleanup (Почистване на диска). Вижте Изтриване на временните файлове с помощната програма Disk Cleanup (Windows 7 и Vista).

По подразбиране помощната програма Disk Cleanup (Почистване на диска) не изтрива файлове в папката Temp за конкретния акаунт, ако е бил правен достъп до нея през последните седем дни. Можете да извършите по-щателно премахване на временни файлове, като ръчно изтриете съдържанието на папката Temp.

Отказ от отговорност: При ръчно изтриване на съдържанието на папка Temp може да се появят неблагоприятни последици за приложенията от издатели, различни от Adobe. Бъдете внимателни, ако изберете да изпълните тази допълнителна задача. Adobe не предоставя поддръжка за проблеми, които възникват при ръчно изтриване на файлове в папката Temp.

За да изтриете ръчно съдържанието на папката Temp на акаунта, направете следното:

  1. Затворете всички приложения.

  2. Изберете Start > All Programs > Accessories (Старт > Всички програми > Аксесоари). Щракнете с десния бутон на мишката върху прозореца на командите и изберете Run As Administrator (Изпълни като администратор).

  3. В прозореца на командите въведете следната команда, точно както е показана по-долу, и натиснете Enter:

    del %temp%\*.* /s /q

    Забележка: del е команда за изтриване на файлове. %temp%\*.* е комбинация от "променливата на средата" за местоположението на папката Temp на акаунта, плюс заместващите символи, които показват всички файлове. /s разширява командата така, че да включва всички файлове във всички подпапки. /q предотвратява питането на Windows за потвърждение на всеки файл, който ще бъде изтрит.

  4. В прозореца на командите се показва списък на изтритите файлове. (Списъкът може да включва файлове, които не могат да бъдат изтрити. Вероятно е също така да видите съобщението "Access is denied“ (Достъпът е отказан) или "The process cannot access the file because it is being used by another process“ (Процесът няма достъп до файла, защото той се използва от друг процес). Това поведение е нормално.)

  5. Затворете прозореца на командите.

След като изтриете временните файлове, отворете приложението на Adobe и опитайте да възпроизведете проблема.

Ако проблемът все още се появява, преминете към следващата задача.

4. Отстранете проблемите в стартиращите елементи за конкретния акаунт.

Стартиращите елементи са приложения или документи, които се отварят автоматично, когато влезете в даден потребителски акаунт. Когато приложение на Adobe се държи неочаквано в даден акаунт, възможно е един от стартиращите елементи да работи неправилно, повреден е или е несъвместим с приложението.

За да определите дали някои от стартиращите елементи на потребителския акаунт причиняват проблема в приложението на Adobe, направете следното:

  1. В Windows Explorer отидете до C:\Users\[потребителско име]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

  2. Направете едно от следните неща:

    • Ако папката "Startup“ (Стартиране) е празна или ако няма такава папка, то този акаунт няма стартиращи елементи конкретно за него. Пропуснете останалите стъпки и продължете със Задача 4.
    • Ако в папката "Startup“ (Стартиране) има поне един елемент, тогава създайте папка на работния плот. Наречете новата папка „Временна папка“.
  3. Преместете всички елементи от папката "Startup“ (Стартиране) във временната папка, която създадохте.

  4. Изберете Start > Log Off (Старт > Излизане).

  5. Влезте в същия акаунт.

  6. Отворете приложението на Adobe и опитайте да възпроизведете проблема.

Ако проблемът все още се появява, тогава причината не е в стартиращ елемент на конкретния акаунт. Можете да преместите отново всички елементи, които са във временната папка, отново в C:\Users\[потребителско име]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup. Продължете със Задача 4.

Ако проблемът вече не се появява, тогава причината е в стартиращ елемент на конкретния акаунт. За да определите точния стартиращ елемент, който причинява проблема, направете следното:

  1. Затворете приложението на Adobe.

  2. Преместете един елемент от временната папка обратно в C:\Users\[потребителско име]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

  3. Изберете Start > Log Off (Старт > Излизане).

  4. Влезте в същия акаунт.

  5. Отворете приложението на Adobe и опитайте да възпроизведете проблема. След това направете едно от следните неща:

    • Ако проблемът все още възниква, повторете стъпки от 1 до 5.
    • Ако проблемът вече не възниква, причината е стартиращият елемент, който последно сте активирали отново. Премахнете го от папката "Startup“ (Стартиране) и се свържете с издателя на стартиращия елемент за информация относно наличието на актуализирана версия. Преместете всички оставащи елементи от временната папка обратно в C:\Users\[потребителско име]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

5. Върнете първоначалните настройки за достъп до папките с данни за приложенията на конкретния акаунт.

Завършете тази задача само ако акаунтът, в който отстранявате проблеми, е администраторски акаунт, a не евмрежов домейн.

Грешките, свързани с конкретен акаунт, могат да възникнат, ако акаунтът няма пълен достъп за четене и писане в папките с файлове с предпочитания за приложенията на Adobe и файловете с данни за конкретния акаунт. Можете да използватекомандата icaclsза да нулирате настройките за достъп. Направете следното:

  1. Затворете всички приложения.

  2. Изберете Start > All Programs > Accessories (Старт > Всички програми > Аксесоари). Щракнете с десния бутон на мишката върху прозореца на командите и изберете Run As Administrator (Изпълни като администратор). Отваря се прозорецът на командите.

  3. В прозореца на командите въведете всяка от следните команди, точно както са показани по-долу. Натискайте Enter след всяка команда. 

    Важно: Въвеждайте шпация преди и след всеки от ключовете -- /T, /E, /C и /grant -- във всяка команда.

    icacls "%userprofile%\AppData\Local" /T /C /grant "%username%":F

    icacls "%userprofile%\AppData\Roaming" /T /C /grant "%username%":F

    icacls "%userprofile%\AppData\Local" /T /C /grant system:F

    icacls "%userprofile%\AppData\Roaming" /T /C /grant system:F

  4. Затворете прозореца на командите.

  5. Отворете приложението на Adobe и опитайте да възпроизведете проблема.

Ако проблемът все още се появява, преминете към следващата задача.

6. Създайте отново ключ за конкретния акаунт на Adobe в системния регистър на Windows.

Отказ от отговорност: Тази задача изисква да направите промени в системния регистър на Windows. Системният регистър съдържа информация, свързана със системата, която е от критично значение за вашия компютър и приложенията. Преди да промените системния регистър, направете негово резервно копие. Adobe не осигурява поддръжка за проблеми, които възникват при неправилна промяна на системния регистър. За повече информация относно системния регистър на Windows или редактора на системния регистър вижте сайта за помощ и поддръжка на Microsoft на адрес http://support.microsoft.com.

  1. Затворете всички приложения.

  2. Щракнете върху „Start“(Старт) Въведете regedit в полето за търсене и натиснете Enter. Отваря се редакторът на системния регистър.

  3. В левия панел на редактора на системния регистър намерете и изберете следния ключ:

    HKEY_CURRENT_USER\Software\Adobe.

  4. Изберете File > Export (Файл > Експортиране)
    .

  5. В диалоговия прозорец „Export Registry File“ (Експортиране на файл на системния регистър) изберете Selected Branch (Избран клон) в „Export Range“ (Диапазон за експортиране). Въведете име и място за файла за архивиране на системния регистър, след което щракнете върху Save (Запиши).

  6. Щракнете с десния бутон на мишката върху ключа Adobe и изберете Delete (Изтриване).

  7. В диалоговия прозорец „Confirm Key Delete“ (Потвърждение за изтриване на ключ) щракнете върху OK.

  8. Затворете редактора на системния регистър.

  9. Отворете приложението на Adobe и опитайте да възпроизведете проблема.

Ако проблемът все още се появява, тогава причината не е в повреден ключ на системния регистър. Можете да възстановите ключа на Adobe от резервното копие, като направите следното:

  1. Затворете всички приложения.

  2. Щракнете върху „Start“(Старт) Въведете regedit в полето за търсене и натиснете Enter. Отваря се редакторът на системния регистър.

  3. В редактора на системния регистър изберете File > Import (Файл > Импортиране).

  4. В диалоговия прозорец "Import Registry File“ (Импортиране на файл на системния регистър) отидете до мястото на архивирания ключ, който сте записали в предишните стъпки. Изберете файла и щракнете върху Open (Отваряне).

7. Поправете твърдия диск на системата.

Повреждане на диска, което засяга само конкретен потребителски акаунт, може да доведе до неизправност на приложение на Adobe за този акаунт.

За да поправите твърдия диск на системата, вижте Поправяне и дефрагментиране на твърди дискове (Windows 7 и Vista).

След като поправите диска, отворете приложението на Adobe и опитайте да възпроизведете проблема. Ако проблемът все още се появява, преминете към следващата задача.

8. Използвайте нов потребителски акаунт.

Ако приложението все още се държи неочаквано в даден акаунт, тогава копирайте (или преместете) всички лични файлове в акаунт, в който това поведение не се проявява. Използвайте новия акаунт като ваш нормален акаунт.

За помощ при копиране на личните файлове в нов потребителски акаунт се свържете с производителя на вашия компютър. Или посетете сайта за помощ и поддръжка на Microsoft на адресhttp://support.microsoft.com.

Този материал е лицензиран под лиценз Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  Публикациите в Twitter™ и Facebook не попадат под клаузите на Creative Commons.

Правни бележки   |   Правила за онлайн поверителност