Saiba como executar linting de código em arquivos HTML, CSS e JS no Adobe Dreamweaver. Exiba os erros e avisos no painel Saída e vá para as linhas que contêm erros de código com um único clique.

Seja você um novato ou um programador experiente, sempre existe a chance de um erro se infiltrar em seu código inadvertidamente ou devido à falta de conhecimento. Quando a página da Web ou mesmo uma parte dela não tem a aparência esperada, você é forçado a depurar código para localizar erros lógicos ou de sintaxe. A depuração pode ser um processo extremamente árduo e demorado, especialmente em casos de implementações complexas.

O Dreamweaver simplifica e facilita a depuração de código para encontrar erros comuns com a ajuda de linting. Linting é o processo de análise de código que sinaliza erros potenciais ou uso suspeito de código. Erros de sintaxe de HTML, erros de análise em CSS ou avisos em arquivos JavaScript são alguns dos itens sinalizados pelo linting no Dreamweaver.

Os erros e avisos encontrados são relacionados em um painel (Saída) separado encaixado na parte inferior da área de trabalho. Cada linha no painel ajuda a saltar para a parte do código onde ocorreu o erro, o que torna mais fácil localizá-lo e corrigi-lo. Além disso, os números de linha do código que contém erro são destacados em vermelho para erros e em amarelo para avisos. Quando você passa o mouse sobre os números de linha destacados, aparece uma visualização do erro ou um aviso.

O Dreamweaver permite executar o linting em arquivos HTML (.htm e .html), CSS e JavaScript. Execute as seguintes etapas para executar o linting de código nesses arquivos:

  1. Especifique regras de linting editando os arquivos de configuração de HTML, CSS e JS. Consulte Especificar regras de linting para obter mais informações.

  2. Ative ou desative o linting de código. Você pode executar o linting de código nos arquivos ao carregá-los ou salvá-los. Você pode ativar/desativar o linting de código em Preferências > Linting. Consulte Ativar o linting e definir preferências para obter mais informações.

Erros e avisos encontrados nos arquivos são exibidos no painel Saída. Para obter mais informações, consulte Resultados do linting e o painel Saída.

Ativar o linting e especificar regras de linting

Clique em Editar > Preferências (Windows) ou Dreamweaver > Preferências (Mac). Selecione Linting na lista Categoria e, depois, selecione Ativar linting.

Especificar regras de linting

Você pode executar o linting de código em arquivos HTML, CSS e JS editando as regras de linting nos arquivos de configuração correspondentes:

  • HTML: DW.htmlhintrc
  • CSS: DW.csslintrc
  • JS: .eslintrc

Para acessar e editar esses arquivos, execute as seguintes etapas:

  1. Clique em Editar > Preferências (Win) ou Dreamweaver > Preferências (Mac). 

  2. Selecione Linting na lista Categoria.

  3. Na seção Editar Conjunto de Regras, clique no tipo de arquivo desejado e clique em Editar e Aplicar Alterações.

    O arquivo de configuração correspondente é aberto no Dreamweaver.

  4. Edite ou adicione regras de linting aos arquivos de configuração. Consulte a seguinte documentação para obter mais informações sobre regras de linting:

    Nesses arquivos de configuração, você também pode definir o tipo de erros ou avisos a serem exibidos. 

Observação:

O arquivo de configuração de regras de linting das versões anteriores do Dreamweaver CC 19.0 é o JS: DW.jshintrc. Você pode consultar http://jshint.com/docs/options/

Linting de código ECMAScript 6

O Dreamweaver oferece suporte à sintaxe ECMAScript 6. O Dreamweaver também oferece suporte a linting de código ECMAScript e tem o ESLint definido como o linter padrão de JavaScript.

  1. Clique em Site > Gerenciar sites.

    Caixa de diálogo Gerenciar sites
    Escolha o site na caixa de diálogo Gerenciar sites
  2. Selecione Configurações avançadas no painel esquerdo da caixa de diálogo Configuração do site. 

  3. Selecione JS Lint nas Configurações avançadas no painel esquerdo. 

    Você pode clicar na lista suspensa ao lado de Versão da ECMAScript e escolher 3, 5 ou 6. O Dreamweaver usará o conjunto de regras padrão da versão que você selecionar. 

    Escolha a versão da ECMAScript
    Escolha a versão da ECMAScript
  4. Para personalizar o conjunto de regras, selecione Arquivo de configuração na lista suspensa e clique em Editar arquivo de configuração

    Edite o arquivo de configuração do JS Lint
    Edite o arquivo de configuração do JS Lint

    As alterações que você fizer na Configuração do site serão salvas, e um arquivo .eslintrc.js será criado na raiz do site caso ainda não haja um arquivo.

    O arquivo .eslintrc.js será aberto para edição na raiz do site. Para obter mais informações, consulte Regras do ESLint

    Arquivo de configuração .eslintrc.js
    Arquivo de configuração .eslintrc.js

    Observação:

    • As configurações de versão do ECMAScript definidas na caixa de diálogo de configuração do site têm precedência sobre o arquivo .eslintrc.js usado na raiz do site. 
    • Se você não usa o arquivo .eslintrc.js nas configurações do site, o Dreamweaver procura o arquivo em todos os locais que levam ao diretório raiz. 

    Para obter mais informações sobre cascata e hierarquia do arquivo de configuração, consulte o site do ESLint.

Resultados do linting e o painel Saída

Os resultados do linting - erros e avisos - são relacionados no painel Saída. Esse painel está disponível no modo encaixado na parte inferior de todas as áreas de trabalho padrão. Se o painel Saída estiver fechado, abra-o executando uma destas ações:

  • Clique no ícone de status do linting na barra de status da janela Documento
  • Use o atalho de teclado Shift+F6
  • Use Janela > Resultados > Saída
O painel Saída e o ícone de linting
O painel Saída e o ícone de linting

O ícone de linting na barra de status indica os resultados do linting:

  • Ícone vermelho - o documento atual contém erros e avisos
  • Ícone amarelo - o documento atual só contém avisos
  • Ícone verde - o documento atual não contém erros

Observação:

Você também pode usar o ícone de linting na barra de status para alternar entre abrir e fechar o painel Saída se o ícone for vermelho ou amarelo (não verde).

As linhas que contêm os erros ou os avisos são realçadas em vermelho e amarelo, respectivamente. Você pode clicar duas vezes em uma mensagem no painel Saída para ir até a linha onde o erro ocorreu. Na Visualização de código, você pode passar o mouse sobre os números das linhas que contêm erro para visualizar o erro ou o aviso.

O painel Saída lista 50 mensagens por vez com os erros listados antes dos avisos. À medida que você corrige os erros, a lista no painel rola para exibir o próximo erro.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online