儲存或轉存圖稿時,Illustrator 會將圖稿資料寫入至檔案。資料的結構則視您所選取的檔案格式而定。

儲存圖稿的基本檔案格式有五種 — AI、PDF、EPS、FXG 和 SVG。這些格式都稱為原生格式,因為可以保留所有 Illustrator 資料,包含多個工作區域。(使用 PDF 和 SVG 格式時,必須選取「保留 Illustrator 編輯能力」選項才能保留所有 Illustrator 資料)。EPS 和 FXG 可以將個別工作區域另存為不同的檔案。SVG 僅會儲存作用中的工作區域;但是,會顯示所有工作區域的內容。

您也可以將圖稿轉存為各種檔案格式,運用於 Illustrator 以外的環境中。這些格式稱為非原生格式,因為如果在 Illustrator 中重新開啟檔案,Illustrator 將無法擷取所有資料。因此建議先將圖稿存成 AI 格式直到完成圖稿為止,然後再將圖稿轉存為所需的格式。

註解:

儲存的圖稿中含連結的 EPS 檔案時,如果檔案是以二進位格式儲存 (使用 Photoshop 的預設 EPS 格式),可能會接到錯誤訊息。在此情況下,請使用 ASCII 格式重新儲存 EPS 檔案,然後將連結的檔案嵌入 Illustrator 圖稿中,或將圖稿儲存為 AI 或 PDF 格式而不要使用 EPS 格式。

若要觀看儲存為網頁的影片,請參閱將圖稿儲存為網頁

儲存為 Illustrator 格式

如果您的文件包含一個以上的工作區域,且您想要將其儲存至舊版的 Illustrator 中,您可以選擇將每個工作區域儲存為不同的檔案,或是將所有工作區域的內容合併為單一檔案。

  1. 選擇「檔案 > 另存新檔」或「檔案 > 儲存拷貝」。

  2. 輸入檔名,並選擇檔案的位置。

  3. 選擇 Illustrator (*.AI) 做為檔案格式,然後按一下「儲存」。

  4. 在「Illustrator 選項」對話框中,設定所要的選項,並按一下「確定」:

    版本

    指定您要檔案相容的 Illustrator 版本。舊版格式不支援目前 Illustrator 版本中的所有功能。因此選取目前版本以外之版本時,儲存的某些選項無法使用,一些特定的資料也會改變。請務必要閱讀對話框下方顯示的警告訊息,清楚地了解資料將會如何改變。

    子集化內嵌字體時使用的字元百分比應低於

    依據文件中使用的字體字元數,指定何時要嵌入整個字體 (不只是文件中所使用的字元)。例如,如果字體中含有 1,000 個字元,但文件僅使用了其中 10 個,那麼您可能會決定不值得為了嵌入字體而增加額外的檔案大小。

    建立 PDF 相容檔案

    將 PDF 格式的文件存成 Illustrator 檔案。如果要讓 Illustrator 檔案與其他 Adobe 應用程式相容,請選取此選項。

    包含連結檔案

    嵌入連結至圖稿的檔案。

    嵌入 ICC 描述檔

    建立色彩管理的文件。

    使用壓縮

    壓縮 Illustrator 檔案中的 PDF 資料。使用壓縮功能會增加儲存文件所需的時間,所以如果覺得儲存時間太長 (8 至 15 分鐘),請取消選取這個選項。

    將每個工作區域儲存至不同的檔案

    將每個工作區域另存為不同的檔案。也會另外建立一個包含所有工作區域的主檔案。所有涉及工作區域的內容都會隨附於此工作區域的檔案中。如果圖稿需要調整以符合單一工作區域,則會顯示警告訊息讓您知道。如果您沒有選取這個選項,工作區域就會合併為單一文件,並轉換成物件參考線和 (在 Illustrator CS3 中) 裁切區域。用於儲存檔案的工作區域大小,是依據預設的文件啟動描述檔決定的。

    透明度選項

    決定當您選擇 9.0 版之前的 Illustrator 格式時,透明物件會發生什麼情況。選取「保留路徑」可放棄透明度效果,並將透明圖稿重設回 100 % 不透明度及「正常」漸變模式。選取「保留外觀」和「疊印」可保留沒有與透明物件互動的疊印。與透明物件互動的疊印會平面化。

    備註: 如果圖稿中含有複雜、重疊的區域,而您又需要高解析度的輸出,請按一下「取消」,先指定點陣化設定後再繼續。

以 EPS 格式儲存

幾乎所有的排版、文書處理及圖形應用程式,都可接受讀入或置入的壓縮式 PostScript (EPS)。EPS 格式可保留許多能以 Adobe Illustrator 建立的圖形元件,也就是說,EPS 檔案可以當作 Illustrator 檔案重新開啟和編輯。由於 EPS 檔案是以 PostScript 語言為基礎,可以同時包含向量及點陣圖形。若圖稿包含多個工具區域,則儲存至 EPS 格式時會保留這些工作區域。

  1. 如果圖稿包含透明度 (包括疊印),而又需要高解析度輸出,請選擇「視窗 > 平面化工具預視」,以預視平面化的效果。

  2. 選擇「檔案 > 另存新檔」或「檔案 > 儲存拷貝」

  3. 輸入檔名,並選擇檔案的位置。

  4. 選擇 Illustrator EPS (*.EPS) 做為檔案格式後,按一下「儲存」。

  5. 如果您要為每個工作區域建立不同的檔案,請按一下「使用工作區域」,然後選取「全部」或指定一個範圍。不同的檔案會以包含所有工作區域之主 EPS 檔案儲存。如果您取消選取這個選項,則會保留所有工作區域並建立單一 EPS 檔案。

  6. 在「EPS 選項」對話框中,設定所要的選項,並按一下「確定」:

    版本

    指定您要檔案相容的 Illustrator 版本。舊版格式不支援目前 Illustrator 版本中的所有功能。因此選取目前版本以外之版本時,儲存的某些選項無法使用,一些特定的資料也會改變。請務必要閱讀對話框下方顯示的警告訊息,清楚地了解資料將會如何改變。

    格式

    決定檔案中所儲存之預視影像的特性。預視影像會顯示在無法直接顯示 EPS 圖稿的應用程式中。如果不要建立預視影像,請從「格式」選單中選擇「無」。否則就選取黑白或彩色格式。

    如果選取 TIFF (8 位元色彩) 格式,請選取預視影像的背景選項:

    透明度

    產生透明背景。

    不透明

    產生實色背景。(如果 EPS 文件將用在 Microsoft Office 應用程式中,請選取「不透明」)。

    透明度選項

    決定透明物件和疊印的情況。可用的選項會依在對話框上方所選取的格式版本而改變。

    如果選擇 CS 格式,請指定要如何儲存設定為疊印的重疊色彩,並選取平面化透明度的預設集 (或選項集)。按一下「自訂」,自訂平面化工具設定。

    如果選擇 8.0 之前的「舊版」格式,請選取「保留路徑」,放棄透明度效果,並將透明圖稿重設回 100% 不透明度和「正常」漸變模式。選取「保留外觀」和「疊印」可保留沒有與透明物件互動的疊印。與透明物件互動的疊印會平面化。

    嵌入字體 (供其他應用程式使用)

    嵌入所有具字體供應商授權的字體。嵌入字體可確保將檔案置入其他應用程式 (例如 Adobe InDesign) 中時,能正確顯示和列印原始字體。不過,如果在沒有安裝該字體電腦上的 Illustrator 中開啟檔案,所使用的字體都會進行模擬或取代。如此可避免非法使用內嵌的字體。

    備註: 選取「內嵌字體」選項會增加儲存檔案的大小。

    包含連結檔案

    嵌入連結至圖稿的檔案。

    包含文件縮圖

    建立圖稿的縮圖影像。縮圖會顯示在 Illustrator 的「開啟」和「置入」對話框中。

    將 CMYK PostScript 併入 RGB 檔案

    允許從不支援 RGB 輸出的應用程式中印出 RGB 彩色文件。當 EPS 檔案在 Illustrator 中重新開啟時,會保留 RGB 色彩。

    相容漸層和漸層網格列印

    透過將漸層物件轉換為 JPEG 格式的方式,讓舊型印表機和 PostScript 設備列印漸層和漸層網格。選取此選項可能會降低本來沒有漸層問題的印表機列印速度。

    Adobe PostScript®

    決定用來儲存圖稿的 Postscript 層級。PostScript Language Level 2 可以表現彩色及灰階向量與點陣影像,並在向量及點陣影像上支援 RGB、CMYK 和 CIE 色彩模型。PostScript Language Level 3 可提供 Language Level 2 以外的其他功能,包括列印至 PostScript® 3™ 印表機時列印網格物件的功能。由於列印至 PostScript Language Level 2 裝置時會將漸層網格物件轉換成點陣影像,最好是將包含漸層網格物件的圖稿列印至 PostScript 3 印表機。

以 SVG 格式儲存

SVG 是一種向量格式,能產生高品質、互動式的網頁圖形。SVG 格式有兩種版本:SVG 和壓縮式 SVG (SVGZ)。SVGZ 可將檔案大小減少 50% 到 80%,但是不能使用文字編輯器編輯 SVGZ 檔案。

將圖稿儲存為 SVG 格式時,會將網格物件點陣化。此外,沒有 Alpha 色版的影像會轉換成 JPEG 格式。而具有 Alpha 色版的影像會轉換成 PNG 格式。如果您的文件包含多個工作區域,且您將其儲存為 SVG,則會保留作用中的工作區域。您無法將個別工作區域儲存為不同的 SVG 檔案。

  1. 如果圖稿中含有任何 SVG 效果,請選取套用 SVG 效果的每一個項目,然後將效果移至「外觀」面板底端 (就在「不透明度」項目上方)。若 SVG 效果之後還有其他效果,SVG 輸出將由點陣物件組成。此外,若圖稿包含多個工作區域,請選取想要轉存的工作區域。

  2. 選擇「檔案 > 另存新檔」或「檔案 > 儲存拷貝」

  3. 輸入檔案名稱,並選擇檔案的位置。

  4. 選擇 SVG (*.SVG) 或「SVG 已壓縮 (*.SVGZ)」作為檔案格式,然後按一下「儲存」。

  5. 在「SVG 選項」對話框中,設定所要的選項,並按一下「確定」:

    SVG 描述檔

    指定轉存檔案的 SVG XML 文件類型定義 (Document Type Definition)

    SVG 1.0 和 SVG 1.1

    適合將在桌上型電腦上檢視的 SVG 檔案。SVG 1.1 是完整版 SVG 規格,SVG Tiny 1.1、SVG Tiny 1.1 Plus 和 SVG Basic 1.1 組成它的子集。

    SVG Basic 1.1

    適合使用中型電源裝置 (如手持裝置) 檢視的 SVG 檔案。請牢記不是所手持設備都支援 SVG Basic 描述檔。因此,選取這個選項並不能保證 SVG 檔案可以在所有手持設備上檢視。SVG Basic 並不支援非矩形剪裁和一些 SVG 濾鏡效果。

    SVG Tiny 1.1 和 SVG Tiny 1.1+

    適合將在小型裝置 (如行動電話) 上檢視的 SVG 檔案。請牢記,不是所有行動電話都支援SVG TinySVG Tiny Plus 描述檔。因此,選取這兩個選項之一並不能保證 SVG 檔案可以在所有小型置上檢視。

    SVG Tiny 1.2

    適合在各種不同裝置 (從 PDA 和行動電話到膝上型電腦和桌上型電腦) 上檢視的 SVG 檔案。

    SVG Tiny 不支援漸層、透明度、剪裁、遮色片、符號、圖樣、加底線文字、加刪除線文字、垂直文字或 SVG 濾鏡效果。SVG Tiny Plus 包含顯示漸層和透明度的功能,但並不支援剪裁、遮色片、符號或 SVG 濾鏡效果。

    秘訣: 如需 SVG 描述檔的詳細資訊,請參閱 World Wide Web Consortium (W3C) 網站 (www.w3.org) 上的 SVG 規格。

    字體類型

    指定字體轉存的方式:

    Adobe CEF

    運用字體提示,取得更好的小型字體運算結果。這種字體類型是由 Adobe SVG 檢視器支援,但其他 SVG 檢視器並不一定支援

    SVG

    不使用字體提示。這種字體類型所有 SVG 檢視器都支援。

    轉換為外框

    將文字轉換為向量路徑。使用此選項,在所有 SVG 檢視器中保留文字的虛擬外觀。

    字體子集

    控制要嵌入轉存 SVG 檔中的字符 (特定字體的字元)。如果能夠確信使用者系統已安裝必要字體,請從「子集」選單中選擇「無」。選擇「僅使用的字符」,僅包含目前圖稿中現有的文字字符。當 SVG 檔案的文字內容是動態 (例如伺服器產生的文字或使用者互動式文字) 時,其他值 (「一般英文」、「使用一般英文和溝紋」、「一般羅馬文」、「使用一般羅馬文和溝紋」及「全部使用字符」) 就很有用

    影像位置

    決定點陣影像是直接嵌入檔案中,或是從原始 Illustrator 檔案連結至轉存的 JPEG 或 PNG 影像。嵌入影像會增加檔案的大小,但可確保點陣化影像一定可以使用。

    保留 Illustrator 編輯能力

    將 AI 檔案嵌入 SVG 檔案中,可以保留特定的 Illustrator 資料 (結果產生較大檔案大小)。如果計劃在 Illustrator 中重新開啟並編輯 SVG 檔案,請選取此選項。請注意,如果手動變更 SVG 資料,重新開啟檔案時可能無法反映出變更。這是因為 Illustrator 是讀取檔案的 AI 部份,而不是 SVG 部份。

    CSS 屬性

    決定樣式屬性儲存成 SVG 程式碼的方式。預設的方法為「簡報屬性」,會在階層的最高點套用內容,可針對特定編輯與轉換允許最大的靈活性。「樣式屬性」方法可建立最具可讀性的檔案,但可能會增加檔案大小。如果轉換時要使用 SVG 編碼,例如使用「延伸樣式語言轉換 (XSLT)」進行轉換,請選擇這個方法。「樣式屬性 <實體參照>」方法運算時間較快,並縮減 SVG 檔案大小。與 HTML 文件共用檔案時,使用的是「樣式元素」方法。選取「樣式元素」,您接著可以修改 SVG 檔案,將樣式元素移動到其他被 HTML 參照到的外部樣式表檔案中;不過「樣式元素」選項會導致演算速度變慢。

    小數位數

    指定 SVG 檔案中向量資料的精確度。小數位數可以設定為 1 到 7 之間的值。數值越高檔案越大,並提升影像品質。

    編碼

    決定 SVG 檔案中的字元編碼方式。所有 XML 處理器都支援「Unicode 轉換格式」(Unicode Transformation Format,UTF) 編碼。(UTF-8 是 8 位元格式;UTF-16 是 16 位元格式)。ISO 8859-1 和 UTF-16 編碼無法保留檔案中繼資料。

    Adobe SVG 檢視器最佳化

    維持最層次 Illustrator 資料,同時仍允許手動編輯 SVG 檔案。選取此選項,發揮例如 SVG 濾鏡效果之類的快速運算功能。

    包含 Adobe Graphics Server 資料

    包含 SVG 檔案中變數替代所需的全部資訊

    包含切片資料

    包含切片位置和最佳化設定。

    包含 XMP

    包含 SVG 檔案中的 XMP 中繼資料。選擇「檔案 > 資訊」或使用「Bridge 瀏覽器」,輸入中繼資料。

    輸出較少的 <tspan> 元素

    允許 Illustrator 在轉存時忽略自動字距,結果產生有較少 <tspan> 元素的檔案。選取此選項,建立更好編輯、更精簡的 SVG 檔案。如果自動字距文字的外觀很重要,請取消選取此選項。

    在路徑文字上使用 <textPath> 元素

    在路徑上將文字轉存為 <textPath> 元素。但是,請注意,文字在 SVG 檢視器中可能會與 Illustrator 中的外觀不同,因為此轉存模式不一定永遠都能維持視覺相似性。尤其是,SVG 檢視器中將會看到溢位文字。

    顯示 SVG 程式碼

    在瀏覽器視窗中顯示 SVG 檔案的程式碼。

    網頁預視

    在瀏覽器視窗中顯示 SVG 檔案。

    Device Central

    在 Device Central 中開啟檔案,以供在特定行動電話或裝置中預視。

儲存圖稿供 Microsoft Office 使用

「儲存供 Microsoft Office 使用」指令可讓您建立能用在 Microsoft Office 應用程式中的 PNG 檔案。

  1. 選擇「檔案 > 儲存供 Microsoft Office 使用」。

  2. 在「儲存供 Office 使用」對話框中,選取檔案的位置,然後輸入檔案名稱並按一下「儲存」。

    註解:

    如果要自訂 PNG 設定 (例如,解析度、透明度和背景色彩),請使用「轉存」指令而不要使用「儲存供 Microsoft Office 使用」指令。您也可以使用「儲存為網頁及裝置用」指令,以 PNG 格式儲存圖稿

轉換向量圖形為點陣影像

關於點陣化

點陣化」是由向量圖形變成點陣圖影像的處理過程。在點陣化處理過程中,Illustrator 將圖形路徑轉換成像素。您所設定的點陣化選項,決定所得出像素的大小和其他特性。

您可以使用「物件 > 點陣化」指令或「點陣化」效果將向量物件點陣化。您可以將文件轉存為點陣格式,例如 JPEG、GIF 或 TIFF 來點陣化整份文件。

將向量物件點陣化

  1. 選取一個或多個物件。

  2. 執行下列任一項作業:

    • 若要將物件永久點陣化,請選擇「物件 > 點陣化」。

    • 若要只產生物件的點陣化外觀,而不變更基礎結構,請選擇「效果 > 點陣化」。

  3. 設定點陣化選項,然後按一下「確定」。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策