Guía del usuario Cancelar

Generación de recursos de imagen a partir de capas

  1. Guía del usuario de Photoshop
  2. Introducción a Photoshop
    1. Suéñelo. Hágalo.
    2. Novedades de Photoshop
    3. Editar la primera fotografía
    4. Creación de documentos
    5. Photoshop | Preguntas frecuentes
    6. Requisitos del sistema de Photoshop
    7. Migración de ajustes, acciones y ajustes preestablecidos
    8. Familiarícese con Photoshop
  3. Servicios de Photoshop y Adobe
    1. Photoshop y Adobe Stock
    2. Bibliotecas de Creative Cloud
    3. Bibliotecas Creative Cloud en Photoshop
    4. Utilice Touch Bar con Photoshop
    5. Trabajar con ilustraciones de Illustrator en Photoshop
    6. Uso de la extensión en la aplicación Capture en Photoshop
    7. Cuadrícula y guías
    8. Creación de acciones
    9. Deshacer e historia
    10. Métodos abreviados de teclado predeterminados
    11. Capacidades táctiles y espacios de trabajo personalizables
  4. Photoshop en el iPad
    1. Photoshop en el iPad | Preguntas frecuentes
    2. Familiarícese con el espacio de trabajo
    3. Requisitos del sistema | Photoshop para iPad
    4. Crear, abrir y exportar documentos
    5. Añadir fotos
    6. Trabajar con capas
    7. Dibujar y pintar con pinceles
    8. Realización de selecciones y adición de máscaras
    9. Retoque de composiciones
    10. Trabajo con capas de ajuste
    11. Ajuste de la tonalidad del compuesto con curvas
    12. Aplicar operaciones de transformación
    13. Recorte y giro de composiciones
    14. Rotar, hacer panorámica, aplicar zoom y restablecer el lienzo
    15. Trabajar con tipos de capas
    16. Trabajo con Photoshop y Lightroom
    17. Obtener fuentes que faltan en Photoshop para iPad
    18. Texto japonés en Photoshop para iPad
    19. Administrar la configuración de la aplicación
    20. Métodos abreviados y gestos táctiles
    21. Métodos abreviados de teclado
    22. Edición del tamaño de imagen
    23. Emisión en directo de su trabajo mientras crea en Photoshop en el iPad
    24. Corrección de imperfecciones con el Pincel corrector
    25. Crear pinceles en Capture y utilizarlos en Photoshop
    26. Trabajar con archivos de Camera Raw
    27. Crear objetos inteligentes y trabajar con ellos
    28. Ajustar la exposición en las imágenes con Aclarar y Oscurecer
  5. Photoshop en la web (beta)
    1. Preguntas frecuentes | Photoshop en la web (beta)
    2. Introducción al espacio de trabajo
    3. Requisitos del sistema | Photoshop en la web beta
    4. Métodos abreviados de teclado | Photoshop en la web (beta)
    5. Tipos de archivo compatibles | Photoshop en la web (beta)
    6. Apertura y trabajo con documentos en la nube
    7. Colaboración con clientes
    8. Aplicación de ediciones limitadas a los documentos en la nube
  6. Documentos en la nube
    1. Documentos en la nube de Photoshop | Preguntas frecuentes
    2. Documentos en la nube de Photoshop | Preguntas sobre el flujo de trabajo
    3. Administración y trabajo con documentos en la nube en Photoshop
    4. Actualización de almacenamiento en la nube para Photoshop
    5. No se puede crear ni guardar un documento en la nube
    6. Solucionar errores de documentos en la nube de Photoshop
    7. Recopilar registros de sincronización de documentos en la nube
    8. Cómo compartir el acceso y editar los documentos en la nube
    9. Compartir archivos y comentar en la aplicación
  7. Espacio de trabajo
    1. Conceptos básicos del espacio de trabajo
    2. Creación de documentos
    3. Utilice Touch Bar con Photoshop
    4. Compatibilidad con Microsoft Dial en Photoshop
    5. Galerías de herramientas
    6. Preferencias de rendimiento
    7. Uso de herramientas
    8. Gestos táctiles
    9. Capacidades táctiles y espacios de trabajo personalizables
    10. Previsualizaciones de tecnología
    11. Metadatos y notas
    12. Compartir rápidamente creaciones
    13. Colocar imágenes de Photoshop en otras aplicaciones
    14. Preferencias
    15. Métodos abreviados de teclado predeterminados
    16. Reglas
    17. Visualización u ocultación de extras que no se pueden imprimir
    18. Especificación de columnas en una imagen
    19. Deshacer e historia
    20. Paneles y menús
    21. Colocación de archivos
    22. Colocación de elementos con el ajuste
    23. Colocación con la herramienta Regla
    24. Ajustes preestablecidos
    25. Personalización de los métodos abreviados de teclado
    26. Cuadrícula y guías
  8. Diseño web, diseño en pantalla y diseño de aplicaciones
    1. Photoshop para diseño
    2. Mesas de trabajo
    3. Vista previa del dispositivo
    4. Copia de CSS a partir de capas
    5. División de páginas web en sectores
    6. Opciones HTML para sectores
    7. Modificación del diseño de sectores
    8. Trabajo con gráficos web
    9. Creación de galerías de fotografías web
  9. Aspectos básicos de imagen y color
    1. Cómo cambiar el tamaño de las imágenes
    2. Trabajo con imágenes rasterizadas y vectoriales
    3. Tamaño y resolución de imágenes
    4. Adquisición de imágenes de cámaras y escáneres
    5. Creación, apertura e importación de imágenes
    6. Visualización de imágenes
    7. Error de marcador de JPEG no válido | Abrir imágenes
    8. Visualización de varias imágenes
    9. Personalización de los selectores y muestras de color
    10. Imágenes de alto rango dinámico
    11. Coincidencia de colores en la imagen
    12. Conversión entre modos de color
    13. Modos de color
    14. Borrar partes de una imagen
    15. Modos de fusión
    16. Selección de colores
    17. Personalización de las tablas de colores indexados
    18. Información de la imagen
    19. Los filtros de distorsión no están disponibles
    20. Acerca del color
    21. Ajustes de color y monocromo mediante canales
    22. Selección de colores en los paneles de color y muestras
    23. Muestra
    24. Modo de color o modo de imagen
    25. Tinte de color
    26. Adición de un cambio de modo condicional a una acción
    27. Adición de muestras desde HTML, CSS y SVG
    28. Profundidad de bits y preferencias
  10. Capas
    1. Conceptos básicos de las capas
    2. Edición no destructiva
    3. Creación y gestión de capas y grupos
    4. Selección, agrupación y enlace de capas
    5. Colocación de imágenes en marcos
    6. Opacidad y fusión de capas
    7. Máscaras de capas
    8. Aplicación de filtros inteligentes
    9. Composiciones de capas
    10. Movimiento, apilamiento y bloqueo de capas
    11. Creación de máscaras de capa con máscaras vectoriales
    12. Gestión de capas y grupos
    13. Estilos y efectos de capa
    14. Edición de máscaras de capa
    15. Extracción de recursos
    16. Visualización de capas con máscaras de recorte
    17. Generación de recursos de imagen a partir de capas
    18. Trabajo con objetos inteligentes
    19. Modos de fusión
    20. Combinación de varias imágenes en un retrato de grupo
    21. Combinación de imágenes con Fusionar capas automáticamente
    22. Alineación y distribución de capas
    23. Copia de CSS a partir de capas
    24. Carga de selecciones de una capa o de los límites de una máscara de capa
    25. Cobertura para mostrar el contenido de otras capas
    26. Capa
    27. Acoplado
    28. Compuesto
    29. Fondo
  11. Selecciones
    1. Espacio de trabajo Seleccionar y aplicar máscara
    2. Realización de selecciones rápidas
    3. Introducción a las selecciones
    4. Selección con las herramientas de marco
    5. Selección con las herramientas de lazo
    6. Selección de una gama de colores en una imagen
    7. Ajuste de selecciones de píxeles
    8. Conversión entre trazados y bordes de selección
    9. Conceptos básicos del canal
    10. Traslado, copia y eliminación de píxeles seleccionados
    11. Creación de una máscara rápida temporal
    12. Guardado de selecciones y máscaras de canales alfa
    13. Selección de las áreas enfocadas de una imagen
    14. Duplicación, división y combinación de canales
    15. Cálculo de canales
    16. Selección
    17. Cuadro delimitador
  12. Ajustes de imagen
    1. Deformación de perspectiva
    2. Estabilización del desenfoque de la imagen
    3. Ejemplos de pincel corrector
    4. Exportación de tablas de consulta de colores
    5. Ajuste del enfoque y desenfoque de la imagen
    6. Explicación de los ajustes de color
    7. Aplicación del ajuste Brillo/contraste
    8. Ajuste de los detalles de iluminación y sombra
    9. Ajuste de niveles
    10. Ajuste del tono y la saturación
    11. Ajuste de intensidad
    12. Ajuste de la saturación del color en las áreas de la imagen
    13. Realización de ajustes de tonos rápidos
    14. Aplicación de efectos de color especiales a las imágenes
    15. Mejora de imágenes con los ajustes de Equilibrio de color
    16. Imágenes de alto rango dinámico
    17. Visualización de histogramas y valores de píxeles
    18. Coincidencia de colores en la imagen
    19. Cómo recortar y enderezar fotografías
    20. Conversión de una imagen en color en una imagen en blanco y negro
    21. Capas de ajuste y de relleno
    22. Ajuste de curvas
    23. Modos de fusión
    24. Preparación de imágenes para la imprenta
    25. Ajuste del color y el tono con los cuentagotas de Niveles y Curvas
    26. Ajuste de los tonos y exposición HDR
    27. Filtro
    28. Desenfoque
    29. Sobreexposición o subexposición de áreas de la imagen
    30. Realización de ajustes de color selectivos
    31. Sustitución de colores de objeto
  13. Adobe Camera Raw
    1. Requisitos del sistema de Camera Raw
    2. Novedades de Camera Raw
    3. Introducción a Camera Raw
    4. Creación de panoramas
    5. Lentes compatibles
    6. Efectos de viñeta, granulado y Borrar neblina en Camera Raw
    7. Métodos abreviados de teclado predeterminados
    8. Corrección automática de la perspectiva en Camera Raw
    9. Cómo realizar ediciones no destructivas en Camera Raw
    10. Filtro radial de Camera Raw
    11. Gestión de los ajustes de Camera Raw
    12. Apertura, procesamiento y almacenamiento de imágenes en Camera Raw
    13. Reparación de imágenes con la herramienta Eliminación de tinta plana mejorada de Camera Raw
    14. Rotación, recorte y transformación de imágenes
    15. Ajuste de la representación del color en Camera Raw
    16. Resumen de funciones | Adobe Camera Raw | Versiones de 2018
    17. Resumen de las nuevas funciones
    18. Versiones del proceso en Camera Raw
    19. Realización de ajustes locales en Camera Raw
  14. Reparación y restauración de imágenes
    1. Quitar objetos de las fotografías con el espacio de trabajo Relleno según el contenido
    2. Movimiento y parche con detección de contenido
    3. Retoque y reparación de fotografías
    4. Corrección de la distorsión y el ruido de la imagen
    5. Pasos básicos para solucionar la mayoría de problemas
  15. Transformaciones de imágenes
    1. Transformación de objetos
    2. Ajuste de recorte, rotación y tamaño de lienzo
    3. Cómo recortar y enderezar fotografías
    4. Creación y edición de imágenes panorámicas
    5. Deformación de imágenes, formas y trazados
    6. Punto de fuga
    7. Utilice el filtro Licuar
    8. Escala según el contenido
    9. Transformación de imágenes, formas y trazados
    10. Deformar
    11. Transformar
    12. Panorama
  16. Dibujo y pintura
    1. Pintar patrones simétricos
    2. Dibujar rectángulos y modificar las opciones de trazo
    3. Acerca del dibujo
    4. Dibujar y editar formas
    5. Herramientas de pintura
    6. Creación y modificación de pinceles
    7. Modos de fusión
    8. Adición de color a trazados
    9. Edición de trazados
    10. Pintura con el Pincel mezclador
    11. Pinceles preestablecidos
    12. Degradados
    13. Interpolación de degradado
    14. Relleno y trazo de selecciones, capas y trazados
    15. Dibujo con las herramientas de pluma
    16. Creación de motivos
    17. Generación de motivos utilizando el Creador de motivos
    18. Gestión de trazados
    19. Gestión de los ajustes preestablecidos y las bibliotecas de motivos
    20. Dibujo o pintura con una tableta gráfica
    21. Creación de pinceles con textura
    22. Adición de elementos dinámicos a los pinceles
    23. Degradado
    24. Pintura de trazos estilizados con el Pincel histórico
    25. Pintura con motivos
    26. Sincronización de ajustes preestablecidos en varios dispositivos
  17. Texto
    1. Trabajo con fuentes OpenType SVG
    2. Aplicación de formato a caracteres
    3. Aplicación de formato a párrafos
    4. Creación de efectos de texto
    5. Edición de texto
    6. Espaciado entre líneas y caracteres
    7. Texto en árabe y hebreo
    8. Fuentes
    9. Solucione problemas de fuentes
    10. Texto asiático
    11. Creación de texto
    12. Error de motor de texto al usar la herramienta Tipo en Photoshop | Windows 8
    13. Modo de composición internacional de fuentes asiáticas
    14. Cómo añadir y editar el texto en Photoshop
  18. Vídeo y animación
    1. Edición de vídeo en Photoshop
    2. Edición de capas de vídeo y animación
    3. Descripción general de vídeo y animación
    4. Previsualización de vídeo y animaciones
    5. Pintado de cuadros en las capas de vídeo
    6. Importación de archivos de vídeo y secuencias de imágenes
    7. Creación de animaciones de cuadros
    8. Animación en 3D de Creative Cloud (previsualización)
    9. Creación de animaciones de línea de tiempo
    10. Creación de imágenes para vídeo
  19. Filtros y efectos
    1. Utilice el filtro Licuar
    2. Uso de la galería de efectos de desenfoque
    3. Conceptos básicos sobre los filtros
    4. Referencia de efectos de filtro
    5. Adición de efectos de iluminación
    6. Uso del filtro de ángulo ancho adaptable
    7. Uso del filtro Pintura al óleo
    8. Estilos y efectos de capa
    9. Aplicación de filtros específicos
    10. Uso de la herramienta Dedo en las áreas de la imagen
  20. Almacenamiento y exportación
    1. Guardado de archivos en Photoshop
    2. Exportar los archivos en Photoshop
    3. Formatos de archivo admitidos
    4. Guardado de archivos con formatos gráficos
    5. Mover diseños entre Photoshop e Illustrator
    6. Guardado y exportación de vídeo y animaciones
    7. Guardado de archivos PDF
    8. Protección por copyright Digimarc
  21. Impresión
    1. Impresión de objetos 3D
    2. Impresión en Photoshop
    3. Impresión con gestión de color
    4. Hojas de contactos y presentaciones en PDF
    5. Impresión de fotografías en un diseño de conjunto de imágenes
    6. Impresión con tintas planas
    7. Duotonos
    8. Impresión de imágenes en imprentas comerciales
    9. Mejora de las impresiones en color en Photoshop
    10. Solución de problemas de impresión | Photoshop
  22. Automatización
    1. Creación de acciones
    2. Crear gráficos de datos
    3. Creación de secuencias de comandos
    4. Procesamiento de un lote de archivos
    5. Reproducción y gestión de las acciones
    6. Adición de acciones condicionales
    7. Acerca de las acciones y el panel Acciones
    8. Grabación de herramientas en acciones
    9. Adición de un cambio de modo condicional a una acción
    10. Kit de herramientas de la IU de Photoshop para plugins y secuencias de comandos
  23. Gestión de color
    1. Explicación de la gestión de color
    2. Mantenimiento de la coherencia de los colores
    3. Ajustes de color
    4. Trabajo con perfiles de color
    5. Gestión de color de los documentos para la visualización en línea
    6. Gestión de color de los documentos al imprimir
    7. Gestión de color de imágenes importadas
    8. Pruebas de los colores
  24. Content Authenticity
    1. Más información sobre las credenciales de contenido
    2. Identidad y procedencia de los NFT
    3. Conexión de cuentas para atribución creativa
  25. Imágenes técnicas y tridimensionales
    1. Photoshop 3D | Preguntas frecuentes sobre las funciones 3D no disponibles
    2. Animación en 3D de Creative Cloud (previsualización)
    3. Impresión de objetos 3D
    4. Pintura 3D
    5. Mejoras del panel 3D | Photoshop
    6. Conceptos y herramientas 3D básicos
    7. Interpretación y almacenamiento 3D
    8. Creación de objetos y animaciones 3D
    9. Pilas de imágenes
    10. Flujo de trabajo 3D
    11. Medida
    12. Archivos DICOM
    13. Photoshop y MATLAB
    14. Recuento de objetos en las imágenes
    15. Combinación y conversión de objetos 3D
    16. Edición de textura en 3D
    17. Ajuste de los tonos y exposición HDR
    18. Configuración del panel 3D

Puede generar recursos de imagen con formato JPEG, PNG, GIF o SVG a partir del contenido de una capa o grupo de capas de un archivo PSD. Los recursos se generan automáticamente al añadir la extensión de un formato de imagen compatible a un nombre de capa o grupo de capas. También puede especificar parámetros de calidad y tamaño para los recursos de imagen generados.

Generar recursos de imagen a partir de un archivo PSD es de especial utilidad si se va a diseñar un sitio web para varios dispositivos.

Si desea aprender a crear y exportar gráficos web, consulte Cómo exportar archivos en varios formatos desde Photoshop.

Generación de recursos de imagen a partir de capas o grupos de capas

Para comprender mejor el funcionamiento del generador de recursos de imagen, imagine un archivo PSD sencillo (descárguelo a través de este enlace) con la siguiente jerarquía de capas:

Recursos de imagen generados de Photoshop
Ejemplo de un archivo PSD con su jerarquía de capas

En la jerarquía de capas de este archivo hay dos grupos de capas: Rounded_rectangles (rectángulos redondeados) y Ellipses (elipses). Cada uno de estos grupos de capas contiene cinco capas.

Siga estos pasos para generar recursos de imagen a partir de este archivo PSD:

  1. Con el archivo PSD abierto, seleccione Archivo > Generar > Recursos de imagen.
  2. Añada las extensiones de formato de archivo correspondientes (.jpg, .png o .gif o .svg) a los nombres de las capas o grupos de capas a partir de los que desee generar los recursos de imagen. Por ejemplo, puede cambiarle el nombre a los grupos de capas Rectángulos_redondeados y Elipses, a Rectángulos_redondeados.jpg y Elipses.png; y la capa Elipse_4 como Elipse_4.gif.
Nota:

Los nombres de capas no admiten los caracteres especiales : y *.

Photoshop genera los recursos de imagen y los guarda en una subcarpeta junto al archivo PSD. Si aún no se ha guardado el archivo PSD de origen, Photoshop guardará los recursos generados en una nueva carpeta en el escritorio.

Nombres de los recursos de imagen de Photoshop
Los nombres de los recursos de imagen se generan a partir de los nombres de las capas o grupos de capas.

Nota:

En el documento actual está activada la generación de recursos de imagen. En cuanto se activa la función, seguirá estándolo cada vez que se abra el documento. Para desactivar la generación de recursos de imagen del documento actual, basta con anular la siguiente selección: Archivo > Generar > Recursos de imagen.

Generación de varios recursos a partir de una capa o un grupo de capas

Para generar varios recursos a partir de una capa o grupo de capas, separe los nombres de los recursos con comas. Por ejemplo, en el siguiente nombre de capa se generan tres recursos:

Elipse_4.jpg, Elipse_4b.png, Elipse_4c.png

Guardado de recursos en una subcarpeta

Puede guardar los recursos de imagen generados a partir de capas o grupos de capas concretos en una subcarpeta un nivel inferior a la carpeta de los recursos del documento. Incluya el nombre de la subcarpeta en el nombre de la capa o grupo de capas como en el siguiente ejemplo:

[subcarpeta]/Ellipse_4.jpg 

Caso de uso de un diseño web

Generar recursos de imagen a partir de un archivo PSD es de especial utilidad si se va a diseñar un sitio web para varios dispositivos. Eche un vistazo al siguiente diseño web y su estructura de capas:

Diseño web con su jerarquía de capas

Vamos a extraer el icono de la parte superior y la primera fila de la cuadrícula de la imagen con zonas interactivas globales con formato de recursos de imagen:

  • Añada extensiones de formato de imagen a los nombres de capa correspondientes.
Cambie el nombre de las capas o grupos de capas correspondientes en Photoshop

Cambie el nombre de las capas o grupos de capas correspondientes en Photoshop

Cambie el nombre de las capas o grupos de capas correspondientes

Nota:

Un único recurso de imagen se genera a partir del contenido de una capa o grupo de capas. Por ejemplo, el grupo de capas AdventureCo Logo de la captura de pantalla de más arriba contiene una capa de forma y una capa de texto interactivo. Estas capas se acoplan cuando se genera un recurso de imagen a partir del grupo de capas.

Photoshop genera los recursos y los guarda en la misma ubicación que el archivo PSD de origen.

Recursos de imagen generados de Photoshop
Recursos de imagen generados

Especificación de los parámetros de calidad y tamaño

De forma predeterminada, los recursos JPEG se generan con una calidad del 90 %. Por su parte, los recursos PNG se generan como imágenes de 32 bits. Los recursos GIF se generan con transparencia alfa básica.

Conforme esté cambiando el nombre de las capas o grupos de capas para generar los recursos, podrá personalizar la calidad y el tamaño.

Parámetros de recursos JPEG

  • Añada la calidad deseada con formato de sufijo al nombre del recurso: .jpg (1-10) o .jpg (1-100 %). Por ejemplo:
    • Elipse_4.jpg5
    • Elipse_4.jpg50 %
  • Añada el tamaño de imagen deseado al nombre del recurso (relativo o con un formato compatible; es decir, px, pulg., cm y mm) en forma de prefijo. Photoshop redimensionará la imagen según corresponda. Por ejemplo:
    • 200 % Elipse_4.jpg
    • 300 x 200 Rectángulo_redondeado_3.jpg
    • 10pulg x 200mm Rectángulo_redondeado_3.jpg

Nota: No olvide añadir un espacio entre el prefijo y el nombre del recurso. Si especifica el tamaño en píxeles, puede omitir la unidad. Por ejemplo, 300 x 200.

Nota:

Como puede ver, puede mezclar diversas unidades y píxeles al especificar el tamaño de la imagen. Por ejemplo, 4pulg x 100 Rectángulo_redondeado_3.jpg es un nombre de capa válido para la generación de un recurso.

Parámetros de recursos PNG

  • Añada la calidad deseada con formato de sufijo al nombre del recurso: 8, 24 o 32. Por ejemplo:
    • Elipse_4.png24
  • Añada el tamaño de imagen deseado al nombre del recurso (relativo o con un formato compatible; es decir, px, pulg., cm y mm) en forma de prefijo. Photoshop redimensionará la imagen según corresponda. Por ejemplo:
    • 42 % Elipse_4.png
    • 300mm x 20cm Rectángulo_redondeado_3.png
    • 10pulg x 50cm Rectángulo_redondeado_3.png

Nota: No olvide añadir un espacio entre el prefijo y el nombre del recurso. Si especifica el tamaño en píxeles, puede omitir la unidad. Por ejemplo, 300 x 200.

Nota:

Como puede ver, puede mezclar diversas unidades y píxeles al especificar el tamaño de la imagen. Por ejemplo, 4pulg x 100 Rectángulo_redondeado_3.png es un nombre de capa válido para la generación de un recurso.

Parámetros de recursos GIF

  • Añada el tamaño de imagen deseado al nombre del recurso (relativo o con un formato compatible; es decir, px, pulg., cm y mm) en forma de prefijo. Por ejemplo:
    • 42 % Elipse_4.gif
    • 300mm x 20cm Rectángulo_redondeado_3.gif
    • 20pulg x 50cm Rectángulo_redondeado_3.gif

Nota: No olvide añadir un espacio entre el prefijo y el nombre del recurso. Si especifica el tamaño en píxeles, puede omitir la unidad. Por ejemplo, 300 x 200.

Nota:

Como puede ver, puede mezclar diversas unidades y píxeles al especificar el tamaño de la imagen. Por ejemplo, 4pulg x 100 Rectángulo_redondeado_3.gif es un nombre de capa válido para la generación de un recurso.

Los parámetros de calidad no están disponibles para los recursos GIF.

Creación de nombres de capa complejos

Puede especificar nombres de recursos con varios parámetros cuando vaya a ponerle un nombre a una capa durante la generación de recursos. Por ejemplo:

120 % Delicioso.jpg, 42 % Delicioso.png24, 100x100 Delicioso_2.jpg90 %, 250 % Delicioso.gif

Photoshop genera los siguientes recursos a partir de esta capa:

  • Delicioso.jpg (imagen JPG de 8 bits con una escala del 120 %)
  • Delicioso.png (imagen PNG de 24 bits con una escala del 42 %)
  • Delicioso_2.jpg (imagen JPG con una calidad del 90 % y un tamaño absoluto de 100 x 100 px)
  • Delicioso.gif (imagen GIF con una escala del 250 %)

Especifique la configuración predeterminada para los recursos

Puede especificar los ajustes predeterminados de documento para los recursos generados. Siga estos pasos:

  1. Cree una capa vacía en el documento.
  2. Inicie el nombre de la capa con la palabra clave default. Ahora, introduzca la configuración que desea aplicar a los recursos de imagen generados a partir del documento. Por ejemplo:

default hi-res/

Genera todos los recursos de imagen en una subcarpeta denominada hi-res. Por ejemplo, [carpeta_ recurso]/hi-res/Delicioso.jpg.

default hi-res/@2x

Genera todos los recursos de imagen en una subcarpeta denominada hi-res. Además, le añade el sufijo @2x a los nombres de recurso. Por ejemplo, [carpeta_recurso]/hi-res/Delicioso@2x.jpg.

default 50 % lo-res/

Guarda los recursos de imagen reducidos en un 50 % en la subcarpeta lo-res de la carpeta de recursos del documento 

default hi-res/@2x + 50 % lo-res/

Genera dos recursos de imagen a partir de una capa:

  • En la subcarpeta hi-res, un recurso de imagen cuyo nombre tiene como sufijo @2x
  • En la subcarpeta lo-res, un recurso de imagen reducido al 50 %
Nota:

Los factores de escala predeterminados se sustituyen con los factores de escala especificados en cada capa.

Desactivación de la generación de recursos de imagen en todos los documentos

Puede desactivar la generación de recursos de imagen de forma global en todos los documentos de Photoshop en las Preferencias.

  1. Seleccione Edición > Preferencias > Plugins.
  2. Anule la selección de Activar generador.
  3. Haga clic en OK.
Nota:

el comando de menú Archivo > Generar no estará disponible si desactiva la generación de recursos de imagen en las Preferencias. Solo podrá volver a activarla en el cuadro de diálogo Preferencias.

Preguntas frecuentes

En el nivel de documento, los nombres de recurso deben ser únicos.

De forma predeterminada, los recursos JPG se generan con una calidad del 90 %. Por su parte, los recursos PNG se generan como imágenes de 32 bits. Los recursos GIF se generan con transparencia alfa básica.

Sí. Si aplica transparencia u otros efectos a una capa, también se reflejarán en los recursos generados a partir de dicha capa. Sin embargo, los efectos pueden no apreciarse a la perfección en los recursos generados.

Los recursos se recortan a los límites del documento. Si una imagen no está dentro de los límites del documento, el generador no crea los recursos de imagen asociados.

Además de la coma (,) puede usar el símbolo más (+) como separador entre nombres de recursos de imagen. Por ejemplo:

42 % Rectángulo_redondeado_1.png24 + 100x100 Rectángulo_redondeado_1.jpg90 %

Equivale a:

42 % Rectángulo_redondeado_1.png24, 100x100 Rectángulo_redondeado_1.jpg90 %

Más contenido similar

Logotipo de Adobe

Inicia sesión en tu cuenta