Einzelbildanimation in Animate

Erstellen von Einzelbildanimationen

Bei der Einzelbildanimation wird der Inhalt der Bühne in jedem einzelnen Bild geändert. Dieses Verfahren eignet sich am besten für komplexe Animationen, bei denen sich eine Grafik nicht nur einfach über die Bühne bewegt, sondern Bild für Bild verändert. Die Einzelbildanimation führt zu einer rascheren Zunahme der Dateigröße als die Tween-Animation. Bei der Einzelbildanimation speichert Animate die Werte für jedes vollständige Bild.

Beim Erstellen einer Einzelbildanimation müssen Sie jedes der Einzelbilder als Schlüsselbild definieren und seinen Inhalt separat bearbeiten. Da jedes neue Schlüsselbild zunächst denselben Inhalt aufweist wie das vorhergehende Schlüsselbild, können Sie die Bilder der Animation schrittweise modifizieren.

  1. Klicken Sie auf den Namen der Ebene, die das zu animierende Objekt enthält, und wählen Sie in der Zeile dieser Ebene das Bild aus, mit dem die Animation beginnen soll.
  2. Falls es sich bei diesem Bild nicht bereits um ein Schlüsselbild handelt, wählen Sie „Einfügen“ > „Zeitleiste“ > „Schlüsselbild“.
  3. Erstellen Sie die Grafik für das erste Bilder der Sequenz. Nutzen Sie hierfür entweder die Zeichenwerkzeuge, fügen Sie das Bild aus der Zwischenablage ein oder importieren Sie eine externe Grafikdatei.
  4. Um ein Schlüsselbild mit dem gleichen Inhalt wie das erste Schlüsselbild hinzuzufügen, klicken Sie auf das nächste Bild rechts neben dem ersten Bild in der gleichen Zeile. Wählen Sie „Einfügen“ > „Zeitleiste“ > „Schlüsselbild“ oder klicken Sie mit der rechten Maustaste (Windows) bzw. drücken Sie die Control-Taste (Macintosh) und wählen Sie „Schlüsselbild einfügen“.

  5. Ändern Sie den Inhalt des neuen Bilds auf der Bühne, um den nächsten Animationsschritt darzustellen.
  6. Wiederholen Sie die Schritte 4 und 5, bis Sie die gewünschte Einzelbildanimation erstellt haben.
  7. Um die Animationssequenz zu testen, wählen Sie „Steuerung“ > „Abspielen“ oder klicken Sie auf den Button „Abspielen“ der Steuerung („Fenster“ > „Symbolleisten“ > „Steuerung“).

Erstellen von Einzelbildanimationen durch das Konvertieren von klassischen Tweens oder Bewegungs-Tweens

Sie können einen klassischen Tween oder einen Bewegungs-Tween-Bereich in eine Einzelbildanimation umwandeln. Jedes Bild einer Einzelbildanimation enthält separate Schlüsselbilder (nicht Eigenschaftenschlüsselbilder), die jeweils separate Instanzen des animierten Symbols enthalten. Eine Einzelbildanimation enthält keine interpolierten Eigenschaftenwerte.

  1. Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Macintosh) auf den Tween-Bereich, den Sie umwandeln möchten, und wählen Sie im Kontextmenü „In Einzelbildanimation konvertieren“.

Verwenden des Zwiebelschaleneffekts

Normalerweise wird jeweils immer nur ein Bild der Animationssequenz auf der Bühne angezeigt. Um das Zeichnen, Positionieren und Bearbeiten von Einzelbildanimationen zu erleichtern, bietet die Zwiebelschalenfunktion eine Referenz, indem der Inhalt des vorherigen und des folgenden Einzelbildes auf der Bühne angezeigt wird. Das Bild unter dem Abspielkopf wird in voller Farbe angezeigt. Farbe und Alpha werden angewendet, um zwischen vergangenen und zukünftigen Bildern zu unterscheiden. 

In der Zwiebelschalenfunktion haben das vorherige und das folgende Bild Standard-Farbtöne. Um diese Farben anzupassen, verwenden Sie die Option „Erweiterte Einstellungen“.

Aktivieren und Deaktivieren der Zwiebelschalenfunktion

  • Klicken Sie zum Aktivieren oder Deaktivieren der Zwiebelschalenfunktion auf den Button „Zwiebelschale“ .
  • Um Bilder auszuschließen oder einzuschließen, klicken Sie in der Kopfzeile der Timeline mit der rechten Maustaste auf ein beliebiges Zwiebelschalenbild innerhalb des Zwiebelschalenbereichs.
  • Klicken Sie mit der Maus auf den Button „Zwiebelschale“ und halten Sie ihn gedrückt, um diese Optionen anzuzeigen und auszuwählen.

Voreinstellungen bei der Zwiebelschalenfunktion

Klicken Sie mit der Maus auf den Button „Zwiebelschale“, halten Sie ihn gedrückt und wählen Sie Erweiterte Einstellungen.

Anpassungsbereich

Anpassen der Farben für die Zwiebelschalenanzeige

  1. Um die Farbe der Zwiebelschalenbilder anzupassen, wählen Sie Zwiebelschalenbild in der Timeline aus.
  2. Klicken Sie mit der Maus auf den Button „Zwiebelschale“, halten Sie ihn gedrückt und wählen Sie Erweiterte Einstellungen.
  3. Ändern Sie den Farbton der vorherigen und der folgenden Bilder.

Konturen- und Füllmodus

Anpassen der Deckkraft

  1. Um die Deckkraft des Zwiebelschalenbildes auf beiden Seiten des aktiven Bildes zu modulieren, klicken und ziehen Sie den Schieberegler für die Start-Deckkraft.

  2. Um das Delta jedes Zwiebelbildes prozentual zu verringern, ziehen Sie den Schieberegler Verringern um.

Nur Schlüsselbilder anzeigen

  1. Um die Farbe der Zwiebelschalenbilder anzupassen, wählen Sie Zwiebelschalenbild in der Zeitleiste aus.
  2. Wählen Sie Bearbeiten > Voreinstellungen.
  3. Wählen Sie unter der Option Zwiebelschalen-Farbe die Farbfeldbuttons zum Anpassen und Festlegen der Farben für vorhergehende, aktuelle und nachfolgende Bilder. 

Ankermarkierungen

Anzeigen von mehreren Bildern einer Animation gleichzeitig auf der Bühne

Klicken Sie auf den Button „Zwiebelschale“ . Alle Bilder zwischen den beiden Zwiebelschalenmarkierungen in der Kopfzeile der Zeitleiste werden im Dokumentfenster übereinander dargestellt.

Markierungen der Zwiebelschalenfunktion

Farbkodierung der Zwiebelschalenfunktion

Dank Farbcodierung können Sie bei Verwendung der Zwiebelschalenfunktion auf einen Blick zwischen bereits gezeigten, dem aktuellen und noch kommenden Bildern unterscheiden. Die Zwiebelschalenbilder, die sich vom aktuellen Bild wegbewegen, werden mit allmählich abnehmender Transparenz dargestellt.

Zwiebelschalenfunktion auf der Zeitleiste

Farbkodierung der Zwiebelschalenfunktion für vorhergehende, das aktuelle und nachfolgende Bilder

Konturmodus der Zwiebelschalenfunktion

Anpassen der Farben für die Zwiebelschalenanzeige

  1. Um die Farbe der Zwiebelschalenbilder anzupassen, wählen Sie Zwiebelschalenbild in der Zeitleiste aus.
  2. Wählen Sie Bearbeiten > Voreinstellungen.
  3. Wählen Sie unter der Option Zwiebelschalen-Farbe die Farbfeldbuttons zum Anpassen und Festlegen der Farben für vorhergehende, aktuelle und nachfolgende Bilder. 
Hinweis:

Der Farbcode kann auch im Konturmodus verwendet werden.

Zeitleistenmodus der Zwiebelschalenfunktion

Benutzerdefinierte Zwiebelschalenfunktion

  • Ändern Sie die Position der Zwiebelschalenmarkierungen, indem Sie die entsprechenden Zeiger verschieben. Normalerweise bewegen sich die Zwiebelschalenmarkierungen zusammen mit dem Bildzeiger. Mit der Strg-Taste/Befehlstaste + Ziehen können Sie die Position auf beiden Seiten erhöhen oder verringern.
  • Klicken Sie auf den Button „Mehrere Bilder bearbeiten“ , um alle Bilder zwischen den beiden Zwiebelschalenmarkierungen für die Bearbeitung freizugeben. Normalerweise kann bei aktivierter Zwiebelschalenfunktion immer nur das aktuelle Bild bearbeitet werden. Sie können den Inhalt sämtlicher Bilder zwischen den Zwiebelschalenmarkierungen einzeln anzeigen und bearbeiten.
  • Sie können den Schleifenbereich auf der Zeitleiste an jede beliebige Position verschieben, welche die Position des Abspielkopfs enthält. Dazu verwenden Sie die Markierungen in der Zeitleiste, halten die Umschalttaste gedrückt und ziehen den Bereich. 
  • Um die Bereichsmarkierungen festzulegen, verwenden Sie die Umschalttaste und ziehen Sie die Bereichsmarkierungen oder den Schleifenbereich mithilfe der Markierungen auf der Zeitleiste. 
Hinweis:

Bei aktivierter Zwiebelschalenfunktion werden gesperrte (mit einem Schlosssymbol gekennzeichnete) Ebenen nicht angezeigt. Um die Darstellung auf der Bühne übersichtlicher zu gestalten, können Sie Ebenen, die sie nicht als Zwiebelschale anzeigen möchten, sperren oder ausblenden.

Vorschau der Website anzeigen

Um zu überprüfen, wie die Zwiebelschalenfunktion funktioniert, bewegen Sie einfach den Mauszeiger über die gesamte Zeitleiste. Ihre Animation wird in farbigen Konturen abgespielt, wodurch Sie eine präzise Vorschau der Änderungen erhalten. 

Adobe-Logo

Bei Ihrem Konto anmelden