Formatieren von Code

Ihr Code kann während der Eingabe automatisch formatiert und eingerückt werden. Durch die dynamische Schriftartenersetzung wird sichergestellt, dass bei mehrsprachigen Texten die richtigen Schriftarten verwendet werden.

Festlegen von Auto-Format-Optionen

  1. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie aus dem Bedienfeldmenü  (rechts oben im Bedienfeld „Aktionen“) die Option „Voreinstellungen“.

    • Wählen Sie im Skriptfenster „Bearbeiten“ > „Voreinstellungen“ (Windows) bzw. „Animate“ > „Voreinstellungen“ (Macintosh).

  2. Wählen Sie im Dialogfeld „Voreinstellungen“ die Option „Auto-Format“ aus.
  3. Wählen Sie beliebige Auto-Format-Optionen aus.

    Nach dem Festlegen der Auto-Format-Optionen werden die Einstellungen automatisch auf den Code angewendet, den Sie schreiben. Auf bereits vorhandenen Code müssen die Einstellungen jedoch manuell angewendet werden.

Formatieren von Code gemäß den Auto-Format-Einstellungen

  • Klicken Sie auf „Auto-Format“  in der Symbolleiste des Bedienfelds „Aktionen“ oder des Skriptfensters.
  • Wählen Sie aus dem Bedienfeldmenü (rechts oben im Bedienfeld „Aktionen“) die Option „Auto-Format“.
  • Drücken Sie Strg-+Umschalt-+F (Windows) bzw. Befehlstaste+Umschalt+F (Macintosh).
  • Wählen Sie im Skriptfenster „Werkzeuge“ > „Auto-Format“ aus.

Verwenden der dynamischen Schriftartenersetzung

  1. Aktivieren oder deaktivieren Sie im Dialogfeld „Voreinstellungen“ das Kontrollkästchen „Dynamische Schriftartenersetzung verwenden“.

    Standardmäßig ist die dynamische Schriftartenersetzung deaktiviert, da sie die Skripterstellung verlangsamt. Wenn Sie mit mehrsprachigen Texten arbeiten, sollten Sie die dynamische Schriftartenersetzung aktivieren, da so sichergestellt wird, dass die richtigen Schriften verwendet werden.

Verwenden der automatischen Einrückung

  1. Aktivieren oder deaktivieren Sie im Dialogfeld „Voreinstellungen“ das Kontrollkästchen „Automatische Einrückung“.

    Wenn diese Option aktiviert ist, wird Text, den Sie nach der rechten runden Klammer „(“ oder der rechten geschweiften Klammer „{“ eingeben, automatisch entsprechend der ActionScript-Voreinstellung „Tabulatorgröße“ eingerückt.

    In Skripts können Sie eine Zeile einrücken, indem Sie sie auswählen und dann die Tabulatortaste drücken. Sie entfernen die Einrückung, indem Sie die Zeile auswählen und Umschalt+Tab drücken.

Kommentarabschnitte im Code

Codekommentare sind Teile des Codes, die vom ActionScript-Compiler ignoriert werden. Mit einer Kommentarzeile wird der Zweck des Codes erläutert oder Code, den Sie nicht löschen möchten, wird vorübergehend deaktiviert. Beginnen Sie den Kommentar zu einer Codezeile mit einem doppelten Schrägstrich (//). Der Compiler ignoriert sämtlichen Text in dieser Zeile nach dem doppelten Schrägstrich. Kommentare zu größeren Codeblöcken beginnen mit einem Schrägstrich und einem Sternchen (/*) und enden mit einem Sternchen und einem Schrägstrich (*/).

Diese Kommentarmarkierungen können Sie manuell eingeben oder mithilfe der Schaltflächen oben im Bedienfeld „Aktionen“ bzw. im Skriptfenster hinzufügen.

Kommentieren einer Codezeile

  1. Positionieren Sie die Einfügemarke am Anfang der Zeile oder dem Zeichen, an dem der Kommentar beginnen soll.
  2. Klicken Sie mit der rechten Maustaste und wählen Sie „Kommentar“. Sie können auch den Tastaturbefehl Strg+M (Windows) oder Befehl+M verwenden oder „Bearbeiten“ > „Auswahl auskommentieren“ wählen.

An der Einfügemarke wird ein doppelter Schrägstrich (//) eingefügt.

Kommentieren mehrerer Codezeilen

  1. Wählen Sie die Zeilen aus, die Sie kommentieren möchten. (Bei der ersten und letzten Zeile kann es sich um unvollständige Zeilen handeln.)
  2. Klicken Sie mit der rechten Maustaste und wählen Sie „Kommentar“. Sie können auch den Tastaturbefehl Strg+M (Windows) oder Befehl+M verwenden oder „Bearbeiten“ > „Auswahl auskommentieren“ wählen.

Die Markierungen für Blockkommentare werden am Anfang (/*) und Ende (*/) der Auswahl eingefügt.

Hinweis:

Wenn zwischen den ausgewählten Textzeilen Kommentare stehen, wird ein Zeilenkommentar auf alle ausgewählten Zeilen angewendet.

Entfernen von Kommentaren

  1. Platzieren Sie die Einfügemarke in der Zeile, die den Kommentar enthält, oder wählen Sie den kommentierten Codeblock aus.
  2. Klicken Sie mit der rechten Maustaste und wählen Sie „Auskommentierung aufheben“. Sie können auch den Tastaturbefehl Strg+Umschalt+M (Windows) oder Befehl+Umschalt+M verwenden oder „Bearbeiten“ > „Auskommentierung der Auswahl aufheben“ wählen.

Verwenden der Syntaxhervorhebung

In ActionScript gelten, ebenso wie in jeder anderen Sprache, bestimmte Syntaxregeln, die festlegen, auf welche Weise die einzelnen Sprachelemente zu sinnvollen Aussagen zusammengefügt werden können. Eine fehlerhafte ActionScript-Syntax bewirkt, dass Ihr Skript nicht funktioniert.

Zur Hervorhebung von Syntaxfehlern können die entsprechenden Teile des Skripts farblich markiert werden. Angenommen, Sie legen die Voreinstellung für die farbliche Syntaxhervorhebung so fest, dass Schlüsselwörter blau angezeigt werden. Wenn Sie var eingeben, wird das Wort var blau dargestellt. Wenn Sie hingegen unbeabsichtigt vae schreiben, bleibt das Wort vae schwarz. Hierdurch können Sie sofort Ihren Tippfehler erkennen.

Führen Sie einen der folgenden Schritte aus:

  • Wählen Sie „Bearbeiten“ > „Voreinstellungen“ (Windows) bzw. „Animate“ > „Voreinstellungen“ (Macintosh), klicken Sie in der Liste „Kategorie“ auf „Code-Editor“ und nehmen Sie unter „Syntaxhervorhebung“ die gewünschten Einstellungen vor.

  • Platzieren Sie die Einfügemarke im Skriptfenster und drücken Sie Strg+U (Windows) bzw. Befehltaste+U (Macintosh).

Hinweis:

Beim Schreiben von Skripts im Bedienfeld „Aktionen“ werden Befehle, die von der vorgesehenen Player-Version nicht unterstützt werden, in der Werkzeugleiste „Aktionen“ gelb dargestellt. Wenn beispielsweise die Flash Player SWF-Version auf Flash 7 eingestellt ist, werden in der Werkzeugleiste „Aktionen“ ActionScript-Befehle, die nur von Flash Player 8 unterstützt werden, gelb dargestellt.

Verwenden der Bezeichner- und Schlüsselwortliste zur Laufzeit

Beim Starten von Animate werden die Bezeichner- und Schlüsselwortlisten aus der Ressourcendatei gelesen und zwischengespeichert. Es werden nicht nur die Standardlisten aus der Ressourcendatei gelesen, sondern auch der Ordner „Voreinstellungen“ wird nach zusätzlichen Schlüsselwort- und Bezeichnerlisten durchsucht. Sie können zusätzliche Schlüsselwörter und Bezeichner hinzufügen, indem Sie in den folgenden Ordnern txt-Dateien hinzufügen:

  • C:\Benutzer\<Benutzername>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptKeywords]\

  • C:\Benutzer\<Benutzername>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptIdentifiers]\

  • C:\Benutzer\<Benutzername>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptKeywords]\

  • C:\Benutzer\<Benutzername>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptIdentifiers]\

Zeilennummern und Zeilenumbruch

Durch Zeilennummern lässt sich der Code bei der Bearbeitung einfacher durchblättern und analysieren. Bei Verwendung des Zeilenumbruchs erübrigt sich der horizontale Bildlauf in langen Codezeilen, besonders wenn Sie in der Authoring-Umgebung arbeiten oder eine niedrige Bildschirmauflösung verwenden

Aktivieren oder Deaktivieren von Zeilennummern

  • Wählen Sie im Skriptfenster „Ansicht“ > „Zeilennummern“.
  • Drücken Sie Strg+Umschalt+L (Windows) bzw. Befehlstaste+Umschalt+L (Macintosh).

Hervorheben einer bestimmten Zeile

  • Wählen Sie im Skriptfenster „Bearbeiten“ > „Gehe zu Zeile“.

Aktivieren oder Deaktivieren des Zeilenumbruchs

  • Wählen Sie im Skriptfenster „Ansicht“ > „Zeilenumbruch“.
  • Drücken Sie Strg+Umschalt+W (Windows) bzw. Befehlstaste+Umschalt+W (Macintosh).

Anzeigen versteckter Zeichen

Zeichen wie Leerzeichen, Tabulatorzeichen und Zeilenumbrüche werden in ActionScript-Code versteckt. Unter Umständen ist es erforderlich, diese Zeichen anzuzeigen, z. B. wenn Sie Doppelbyte-Leerzeichen suchen und entfernen müssen, die nicht zu einem Stringwert gehören, da sie Compiler-Fehler verursachen.

  • Drücken Sie Strg+Umschalt+8 (Windows) bzw. Befehlstaste+Umschalt+8 (Macintosh).

Mithilfe der folgenden Symbole werden versteckte Zeichen angezeigt.

Verstecktes Zeichen

Symbol

Einzelbyte-Leerzeichen

.

Doppelbyte-Leerzeichen

l

Tab

>>

Zeilenumbruch


Suchen von Text in einem Skript

Mit dem Befehl „Suchen“ können Sie Textstrings in Ihren Skripts suchen und ersetzen.

Hinweis:

Sie müssen den Film-Explorer verwenden, um den Text in allen Skripts eines Animate-Dokuments zu durchsuchen.

Suchen von Text

  1. Klicken Sie im Bedienfeld „Aktionen“ oder im Skriptfenster auf „Suchen“  oder drücken Sie Strg+F (Windows) bzw. Befehlstaste+F (Macintosh).
  2. Geben Sie den String ein, nach dem Sie suchen möchten.
  3. Klicken Sie auf „Weitersuchen“.

Suchen und Ersetzen von Text in einem Skript

  1. Klicken Sie im Bedienfeld „Aktionen“ oder im Skriptfenster auf „Suchen“  oder drücken Sie Strg+F (Windows) bzw. Befehlstaste+F (Macintosh).
  2. Geben Sie den String ein, nach dem Sie suchen möchten.
  3. Geben Sie in das Feld „Ersetzen durch“ den neuen String ein.
  4. Klicken Sie auf „Weitersuchen“.
  5. Klicken Sie auf „Ersetzen“, um den String zu ersetzen. Wenn Sie auf „Alle ersetzen“ klicken, werden alle Stellen ersetzt, an denen der String vorkommt.

(In Animate CC aufgegeben) Wiederholen einer Suche im Bedienfeld „Aktionen“

  1. Wählen Sie aus dem Bedienfeldmenü  (rechts oben im Bedienfeld „Aktionen“) die Option „Weitersuchen“.

(In Animate CC aufgegeben) Wiederholen einer Suche im Skriptfenster

  1. Wählen Sie „Bearbeiten“ > „Weitersuchen“.

(In Animate CC aufgegeben) Überprüfen von Syntax und Interpunktion

Sie können eine Schnellprüfung Ihres ActionScript-Codes durchführen, ohne die FLA-Datei zu veröffentlichen.

Wenn Sie die Syntax prüfen, wird das aktuelle Skript geprüft. Werden vom aktuellen Skript ActionScript-Klassen aufgerufen, dann werden diese Klassen ebenfalls geprüft. Andere Skripts, die sich in der FLA-Datei befinden können, werden nicht geprüft.

Bei ActionScript 2.0-Dateien wird der Code mit „Syntax überprüfen“ durch den Compiler ausgeführt, wobei Syntax- und Compiler-Fehler generiert werden.

Bei ActionScript 3.0-Dateien werden mit „Syntax überprüfen“ nur Syntaxfehler generiert. Compiler-Fehler, zum Beispiel Typabweichungen, falsche Rückgabewerte und falsch geschriebene Variablen- oder Methodennamen, können Sie mit „Steuerung“ > „Testen“ generieren.

Überprüfen der Syntax

Führen Sie einen der folgenden Schritte zum Überprüfen der Syntax aus:

  • Klicken Sie im Bedienfeld „Aktionen“ oder im Skriptfenster auf „Syntax überprüfen“ .
  • Klicken Sie im Skriptfenster und drücken Sie dann Strg+T (Windows) bzw. Befehlstaste+T (Macintosh). Wenn Sie in das Skriptfenster klicken oder darin tippen, erhält es den Fokus. Wenn ein Objekt auf der Bühne den Fokus hat, wird stattdessen das Bedienfeld „Transformieren“ geöffnet.

Die aufgetretenen Fehler werden im Bedienfeld „Compiler-Fehler“ aufgelistet.

Hinweis:

Bei einer externen ActionScript-Klassendatei im Skriptfenster wirkt sich der globale Klassenpfad (AS2) oder Quellpfad (AS3) auf die Syntaxüberprüfung aus. Manchmal werden trotz richtig eingestelltem Klassenpfad oder Quellpfad Fehler erzeugt, da dem Compiler nicht bekannt ist, dass diese Klasse kompiliert wird.

Suchen von fehlenden Klammern

  1. Klicken Sie in Ihrem Skript zwischen geschweiften {}, eckigen [] oder runden Klammern ().
  2. Drücken Sie in Windows Strg+' (einfaches Anführungszeichen) bzw. auf dem Macintosh Befehl+'. Der Text zwischen den runden, eckigen oder geschweiften Klammern wird hervorgehoben. Dadurch können Sie auf einen Blick feststellen, ob Sie eine geöffnete Klammer ordnungsgemäß wieder geschlossen haben.

(In Animate CC aufgegeben) Importieren und Exportieren von Skripts

Sie können Skripts in das Bedienfeld „Aktionen“ oder das Skriptfenster importieren. Außerdem können Sie Skripts vom Bedienfeld „Aktionen“ in externe ActionScript-Dateien exportieren. Bei Verwendung des Skriptfensters ist das Exportieren nicht erforderlich, da Sie stattdessen einfach die AS-Datei speichern können.

Wenn der Text in Skripts nach dem Öffnen oder Importieren einer Datei nicht wie erwartet aussieht, können Sie die Voreinstellung für die Importkodierung ändern.

Importieren von externen AS-Dateien

  1. Platzieren Sie die Einfügemarke an der Stelle im Skriptfenster, an der die erste Zeile des externen Skripts eingefügt werden soll.
  2. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie im Bedienfeldmenü des Bedienfelds „Aktionen“ den Befehl „Skript importieren“ aus oder drücken Sie Strg+Umschalt+l (Windows) bzw. Befehlstaste+Umschalt+l (Macintosh).

    • Wählen Sie im Skriptfenster „Datei“ > „Skript importieren“ aus oder drücken Sie Strg+Umschalt+l (Windows) bzw. Befehlstaste+Umschalt+l (Macintosh).

Exportieren von Skripts aus dem Bedienfeld „Aktionen“

  1. Wählen Sie das zu exportierende Skript aus. Wählen Sie dann im Menü des Bedienfelds „Aktionen“ den Befehl „Skript exportieren“ aus oder drücken Sie Strg+Umschalt+X (Windows) bzw. Befehlstaste+Umschalt+X (Macintosh).
  2. Speichern Sie die ActionScript-Datei (AS).

Festlegen der Textkodierungsoptionen

  1. Wählen Sie „Bearbeiten“ > „Voreinstellungen“ (Windows) bzw. „Animate“ > „Voreinstellungen“ (Macintosh) und klicken Sie in der Liste „Kategorie“ auf „ActionScript“.

  2. Wählen Sie die gewünschten Optionen aus:

    Öffnen/Importieren

    Wählen Sie „UTF-8-Kodierung“, um beim Öffnen oder Importieren die Unicode-Kodierung zu verwenden, oder wählen Sie „Standardkodierung“, um beim Öffnen oder Importieren die Kodierungsform der Sprache zu verwenden, die momentan in Ihrem System verwendet wird.

    Speichern/Exportieren

    Wählen Sie „UTF-8-Kodierung“, um beim Speichern oder Exportieren die Unicode-Kodierung zu verwenden, oder wählen Sie „Standardkodierung“, um beim Speichern oder Exportieren die Kodierungsform der Sprache zu verwenden, die momentan in Ihrem System verwendet wird.

Aktivieren oder Deaktivieren der Warnung zur Exportkodierung

  1. Wählen Sie „Bearbeiten“ > „Voreinstellungen“ (Windows) bzw. „Animate“ > „Voreinstellungen“ (Macintosh) und klicken Sie in der Liste „Kategorie“ auf „Warnungen“.

  2. Aktivieren oder deaktivieren Sie das Kontrollkästchen „Warnungen bei Kodierungskonflikten beim Export von ActionScript-Dateien“.

(In Animate CC aufgegeben) Codieren für importierte und exportierte Skripts

Sie können ActionScript-Voreinstellungen festlegen, um den zu verwendenden Kodierungstyp bei importierten oder exportierten ActionScript-Dateien anzugeben. Die UTF-8-Kodierung ist ein 8 Bit-Unicode-Format, das es ermöglicht, mehrsprachigen Text in eine Datei einzubeziehen; die Standardkodierung ist die Kodierung, die von der Sprache Ihres Systems unterstützt wird. Sie wird auch als traditionelle Codeseite bezeichnet.

Hinweis:

Wenn Sie auf einem englischen System eine Anwendung in einer anderen Sprache ausführen, schlägt der Befehl „Film testen“ fehl, wenn ein Teil des SWF-Dateipfades Zeichen enthält, die nicht mit dem Multibyte-Zeichensatz (MBCS) dargestellt werden können. Beispielsweise funktionieren japanische Pfade auf einem japanischen System aber nicht auf einem englischen System. Achten Sie darauf, nur englische Pfadnamen auf englischen Systemen zu verwenden. Diese Einschränkung gilt für alle Bereiche der Anwendung, die mit einem Player im Filmtestmodus arbeiten.

Fixieren von Skripts im Bedienfeld „Aktionen“

Mit der Funktion „Skript fixieren“ können Sie die Registerkarten von einzelnen Skripts im Skript-Bedienfeld fixieren und entsprechend verschieben. Diese Funktion ist hilfreich, wenn Sie den Code Ihrer FLA-Datei nicht an einem zentralen Ort organisiert haben oder mehrere Skripts verwenden.

Sie können Skripts fixieren, um den Platz des Codes im Bedienfeld „Aktionen“ freizuhalten und zwischen den verschiedenen offenen Skripts zu wechseln. Das kann besonders beim Debuggen nützlich sein. 

Sie können auch ein Skript oder alle Skripts lösen, um die Fixierung eines Skripts oder aller Skripts im Bedienfeld „Aktionen“ aufzuheben.

In der folgenden Abbildung befindet sich das Skript, das mit der aktuellen Position in der Zeitleiste verknüpft ist, in Bild 1 der Ebene „Cleanup“. (Die Registerkarte ganz links zeigt immer Ihre Position auf der Zeitleiste an.) Das Skript wird auch wie abgebildet auf der Registerkarte ganz rechts fixiert. Die folgenden beiden Skripts sind fixiert:

  • Auf Bild 1 
  • Auf Bild 15 auf der Ebene namens „Intro“

Verwenden Sie die Tastaturbefehle oder klicken Sie auf die Registerkarten, um zwischen den fixierten Skripts hin und her zu wechseln. Durch das Wechseln zwischen den verschiedenen fixierten Skripts wird Ihre aktuelle Position auf der Zeitleiste nicht geändert. Wenn ein neues Skript im Aktionsskript-Navigator ausgewählt ist, verschiebt sich der Fokus auf das erste Bild, d. h. Bild 1.

Hinweis:

Wenn der im Skriptfenster angezeigte Inhalt sich nicht mit der Position ändert, die Sie auf der Zeitleiste wählen, zeigt das Skriptfenster vermutlich ein fixiertes Skript. Klicken Sie links oben im Skriptfenster auf die linke Registerkarte für das aktuelle Bild, um das Skript anzuzeigen, das mit Ihrer Position auf der Zeitleiste verknüpft ist.

Ein fixiertes Skript

Fixieren eines Skripts

  1. Klicken Sie in die Zeitleiste, sodass das Skript auf einer Registerkarte für das aktuelle Bild links oben im Skriptbereich des Bedienfelds „Aktionen“ angezeigt wird.

  2. Führen Sie einen der folgenden Schritte aus:
    • Klicken Sie auf das Pinnwandnadel-Symbol rechts neben der Registerkarte.
    • Wählen Sie Ansicht > Skript fixieren, um das Skript zu fixieren.

     

Fixierung aller Skripts aufheben

  1. Wählen Sie das fixierte Skript im Bedienfeld „Aktionen“.

  2. Wählen Sie Ansicht > Fixierung eines Skripts aufheben, um das ausgewählte Skript vom Bedienfeld „Aktionen“ zu lösen.

  3. Wählen Sie Ansicht > Fixierung aller Skripts lösen, um alle Skripts vom Bedienfeld „Aktionen“ zu lösen.

Optionen für das Aufheben von Fixierungen

Tastaturbefehle für fixierte Skripts

Befindet sich die Einfügemarke im Skriptfenster, können Sie bei der Arbeit mit fixierten Skripts die folgenden Tastaturbefehle verwenden.

Aktion

Windows 

Macintosh

Skript fixieren

Strg+Umschalt+=

Befehl+Umschalt+=

Fixierung eines Skripts aufheben

Strg+Umschalt+- (Minuszeichen)

Befehl+Umschalt+-

Einfügen von Zielpfaden

Zahlreiche Skriptaktionen wirken sich auf Movieclips, Schaltflächen und andere Symbolinstanzen aus. Im Code können Sie auf Symbolinstanzen auf einer Zeitleiste durch Einfügen eines Zielpfades verweisen. Dabei handelt es sich um die Adresse der Instanz, die Sie als Ziel angeben möchten. Sie können entweder einen absoluten oder einen relativen Zielpfad festlegen. Ein absoluter Pfad enthält die vollständige Adresse der Instanz. Ein relativer Pfad enthält nur den Teil der Adresse, der sich von der Adresse des Skripts in der FLA-Datei unterscheidet; falls das Skript verschoben wird, funktioniert der Pfad nicht mehr.

  1. Klicken Sie im Bedienfeld „Aktionen“ auf eine Aktion im Skript.
  2. Klicken Sie auf „Zielpfad“
  3. Geben Sie den Pfad der Zielinstanz ein oder wählen Sie das Ziel in der Liste aus.
  4. Aktivieren Sie die Option „Absolut“ oder „Relativ“.

Verwenden von Codehinweisen

Wenn Sie mit dem Bedienfeld „Aktionen“ oder dem Skriptfenster arbeiten, kann die Software erkennen, welche Aktion Sie eingeben, und einen entsprechenden Codehinweis anzeigen. Dabei gibt es zwei Arten von Codehinweisen: Die QuickInfos mit der vollständigen Syntax für die jeweilige Aktion und ein Popupmenü, das die möglichen ActionScript-Elemente, also Methoden- oder Eigenschaftsnamen auflistet (wird auch mit Codevervollständigung bezeichnet).

Codehinweise sind standardmäßig aktiviert. Mithilfe von Voreistellungen können Sie Codehinweise deaktivieren oder angeben, nach welcher Verzögerung (in Sekunden) Codehinweise eingeblendet werden. Wenn Codehinweise in den Voreinstellungen deaktiviert werden, können Sie trotzdem einen Codehinweis für einen bestimmten Befehl anzeigen.

Hinweis:

Wenn Codehinweise für Variablen oder Objekte, die Sie in ActionScript 2.0 erstellt haben, nicht angezeigt werden können, obwohl Codehinweise in den ActionScript-Voreinstellungen aktiviert wurden, prüfen Sie, ob Sie die Variablen oder Objekte mit dem richtigen Suffix benannt oder strikt typisiert haben.

Aktivieren von Codehinweisen

Codehinweise lassen sich auf verschiedene Weise auslösen.

Strikte Typisierung von Objekten

Wenn Sie in ActionScript 2.0 eine Variable, die auf einer integrierten Klasse basiert, wie z. B. Button, Array usw., strikt typisieren, werden im Skriptfenster Codehinweise für die Variable angezeigt. Angenommen, Sie geben folgenden zweizeiligen Code ein:

var foo:Array = new Array(); 
foo.

Sobald Sie den Punkt (.) eingeben, zeigt Animate in einem Popup-Menü eine Liste von Methoden und Eigenschaften an, die für Array-Objekte verfügbar sind, da Sie die Variable als Array deklariert haben.

Suffixe und Codehinweise

Wenn Sie ActionScript 1.0 verwenden oder Codehinweise für Objekte ohne strikte Typisierung anzeigen möchten, müssen Sie jedem Objektnamen beim Erstellen ein spezielles Suffix hinzufügen. Das Suffix, das Codehinweise für die Camera-Klasse auslöst, ist beispielsweise _cam. Angenommen, Sie geben folgenden Code ein: var my_array = new Array(); var my_cam = Camera.get();

Wenn Sie dann my_cam gefolgt von einem Punkt eingeben, werden die Codehinweise für das Camera-Objekt angezeigt.

Verwenden Sie für Objekte, die auf der Bühne angezeigt werden, das Suffix im Feld „Instanzname“ des Eigenschafteninspektors. Um beispielsweise Codehinweise für MovieClip-Objekte anzuzeigen, weisen Sie im Eigenschafteninspektor allen MovieClip-Objekten Instanznamen mit dem Suffix _mc zu. Wann immer Sie dann später den Instanznamen gefolgt von einem Punkt eingeben, werden Codehinweise angezeigt.

var my_array = new Array(); 
var my_cam = Camera.get();

Hinweis:

Obgleich bei der strikten Typisierung von Objekten Suffixe nicht erforderlich sind, um Codehinweise auszulösen, wird Ihr Code durch eine einheitliche Verwendung von Suffixen verständlicher.

In der folgenden Tabelle werden die Suffixe aufgelistet, mit denen in ActionScript 2.0 Codehinweise ausgelöst werden:

Objekttyp

Variablensuffix

Array

_array

Button

_btn

Camera

_cam

Farbe

_color

ContextMenu

_cm

ContextMenuItem

_cmi

Date

_date

Error

_err

LoadVars

_lv

LocalConnection

_lc

Microphone

_mic

MovieClip

_mc

MovieClipLoader

_mcl

PrintJob

_pj

NetConnection

_nc

NetStream

_ns

SharedObject

_so

Sound

_sound

String

_str

TextField

_txt

TextFormat

_fmt

Video

_video

XML

_xml

XMLNode

_xmlnode

XMLSocket

_xmlsocket

Kommentare und Codehinweise

Mit ActionScript-Kommentaren können Sie die Klasse eines Objekts für Codehinweise angeben. Im folgenden Beispiel wird ActionScript mit dem Kommentar mitgeteilt, dass die Instanz theObject zur Object-Klasse gehört usw.

// Object theObject;// Array theArray;// MovieClip theMC;

Wenn Sie später mc gefolgt von einem Punkt eingeben, werden Codehinweise eingeblendet, die eine Liste der MovieClip-Methoden und -Eigenschaften zeigen. Wenn Sie theArray gefolgt von einem Punkt eingeben, werden Codehinweise eingeblendet, die eine Liste der Array-Methoden und -Eigenschaften zeigen usw.

Anstelle dieses Verfahrens wird jedoch die strikte Typisierung oder die Verwendung von Suffixen empfohlen, da bei diesen Techniken Codehinweise automatisch aktiviert werden und Ihr Code verständlicher wird.

Festlegen der Voreinstellungen für automatische Codehinweise

  • Wählen Sie im Bedienfeld „Aktionen“ oder im Skriptfenster „Bearbeiten“ > „Voreinstellungen“ (Windows) bzw. „Animate“ > „Voreinstellungen“ (Macintosh), klicken Sie in der Liste „Kategorie“ auf „Code-Editor“ und aktivieren oder deaktivieren Sie das Kontrollkästchen „Codehinweise“.

(In Animate CC aufgegeben) Festlegen einer Verzögerung für Codehinweise

  1. Wählen Sie im Bedienfeld „Aktionen“ oder im Skriptfenster „Bearbeiten“ > „Voreinstellungen“ (Windows) bzw. „Animate“ > „Voreinstellungen“ (Macintosh).

  2. Klicken Sie in der Liste „Kategorie“ auf „ActionScript“.
  3. Legen Sie die Verzögerung in Sekunden mit dem Schieberegler fest.

Verwenden von Codehinweisen in Form von QuickInfos

  1. Geben Sie nach Elementen, für die Klammern erforderlich sind, eine öffnende runde Klammer „(“ ein, z. B. nach Methodennamen, Befehlen wie if oder do..while und so weiter.
    Öffnende runde Klammern rufen Codehinweise auf

  2. Geben Sie einen Wert für den Parameter ein.

    Bei mehreren Parametern müssen Sie die Werte durch Kommas trennen. Für Funktionen und Anweisungen, wie die for-Schleife, müssen die Parameter durch Strichpunkte voneinander getrennt werden.

    Bei Befehlen mit Zusatzoptionen wie gotoAndPlay() oder for (d. h. Funktionen oder Methoden, die mit unterschiedlichen Parametergruppen aufgerufen werden können) wird eine Auswahl der entsprechenden Parameter angezeigt. Klicken Sie zum Auswählen des Parameters auf die kleinen Pfeilschaltflächen oder drücken Sie die Strg-+Nach-links-Taste bzw. die Strg-+Nach-rechts-Taste.

    Ein Codehinweis mit mehreren Parametern

  3. Um den Codehinweis auszublenden, führen Sie einen der folgenden Schritte aus:
    • Geben Sie eine schließende runde Klammer „)“ ein.

    • Klicken Sie außerhalb der Anweisung.

    • Drücken Sie die Esc-Taste.

Verwenden von Codehinweisen in Form von Popupmenüs

  1. Geben Sie nach dem Variablen- oder Objektnamen einen Punkt ein.
    Codehinweise in Form von Popupmenüs

  2. Um zwischen den Codehinweisen zu wechseln, drücken Sie die Nach-oben-Taste bzw. die Nach-unten-Taste.
  3. Um ein Element auszuwählen, drücken Sie die Eingabe- oder Tabulatortaste oder doppelklicken Sie auf das Element.
  4. Um den Codehinweis auszublenden, führen Sie einen der folgenden Schritte aus:
    • Wählen Sie eines der Menüelemente aus.

    • Klicken Sie über oder unter dem Menüfenster.

    • Geben Sie eine schließende runde Klammer „)“ ein, wenn Sie bereits eine öffnende runde Klammer „(“ eingegeben haben.

    • Drücken Sie die Esc-Taste.

Manuelles Anzeigen von Codehinweisen

  1. Klicken Sie an einer Stelle, an der Codehinweise angezeigt werden können, wie etwa den folgenden Stellen:
    • nach dem Punkt (.), der auf Anweisungen oder Befehle folgt, nach denen eine Eigenschaft oder Methode eingegeben werden muss

    • zwischen runden Klammern „()“ in einem Methodennamen

  2. Führen Sie einen der folgenden Schritte aus:
    • Um Codehinweise manuell zu aktivieren, wählen Sie „Ansicht“ > „Codehinweis anzeigen“.

    • Drücken Sie Strg+Leertaste (Windows) bzw. Befehlstaste+Leertaste (Macintosh).

Codehinweise für benutzerdefinierte Klassen

Wenn Sie benutzerdefinierte ActionScript 3.0-Klassen erstellen, analysiert Animate die Klassen und ermittelt die darin enthaltenen Objekte, Eigenschaften und Methoden. Animate kann dann Codehinweise bereitstellen, wenn Sie Code schreiben, der auf benutzerdefinierte Klassen verweist. Die Codevervollständigung für benutzerdefinierte Klassen erfolgt bei Klassen, die Sie über den Befehl Importieren mit anderem Code verknüpfen, automatisch.

Mit Codehinweisen können Entwickler schneller arbeiten, da sie sich nicht alle von der Klasse verwendeten Objekte, Methoden und Eigenschaften merken müssen. Designer können mit Klassen arbeiten, die sie nicht selbst geschrieben haben, da sie keine Kenntnisse über die Grundlagen der Arbeit mit diesen Klassen benötigen.

Codehinweise umfassen Folgendes:

  • Codehinweise für verschachtelte Klassenverweise

    Wenn Sie verschachtelte Verweise schreiben, ist die fortgesetzte Unterstützung durch Codehinweise hilfreich.

  • Codehinweise für „this“

    Wenn Sie in einer Klassendatei „this“ eingeben, erhalten Sie die Codehinweise für diese Klasse.

  • Codehinweise für „new+<space>“

    Wenn Sie „new+<space>“ tippen, zeigt Animate eine Liste der verfügbaren Klassen und Pakete an.

  • Codehinweise für „import“

    Wenn Sie „import+<space>“ tippen, zeigt Animate eine Liste aller integrierten Pakete und aller benutzerdefinierten Pakete an.

  • Codehinweise für SWC-Bibliotheken

    Wenn Sie dem Bibliothekspfad oder dem externen Bibliothekspfad eine SWC-Bibliothek hinzufügen, aktiviert Animate Codehinweise für alle in der SWC-Datei enthaltenen Klassen.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie