Erste Schritte mit ActionScript

ActionScript® ist die Flash-Skriptsprache, mit der Sie eine Anwendung um komplexe Interaktivität, Wiedergabesteuerung und Datenanzeige erweitern können. Sie können ActionScript innerhalb der Authoring-Umgebung mit dem Bedienfeld „Aktionen“, dem Skriptfenster oder einem externen Editor hinzufügen.

ActionScript verfügt über eigene Regeln zur Syntax und reservierten Schlüsselwörtern. Außerdem können Sie mithilfe von Variablen Informationen speichern und abrufen. ActionScript bietet eine umfangreiche Bibliothek integrierter Klassen, mit denen Sie Objekte zur Ausführung vieler nützlicher Aufgaben erstellen können. Weitere Informationen zu ActionScript finden Sie in den folgenden Hilfethemen:

Sie müssen nicht unbedingt jedes ActionScript-Element verstehen, bevor Sie mit der Skripterstellung beginnen; wenn Sie ein klares Ziel vor Augen haben, können Sie anfangen, Skripts mit einfachen Aktionen zu erstellen.

Sowohl ActionScript als auch JavaScript beruhen auf dem ECMA-262-Standard, dem internationalen Standard für die ECMAscript-Skriptsprache. Daher sollten Entwickler, die mit JavaScript vertraut sind, auch sehr schnell mit ActionScript vertraut sein. Weitere Informationen über ECMAScript finden Sie unter ecma-international.org.

Adobe empfiehlt...

Adobe empfiehlt...

Welche ActionScript-Version sollten Sie verwenden?

Animate bietet mehrere ActionScript-Versionen, um den Anforderungen von unterschiedlichen Entwicklern und Wiedergabegeräten zu entsprechen. ActionScript 3.0 und 2.0 sind nicht miteinander kompatibel.

 

  • ActionScript 3.0 wird extrem schnell ausgeführt. Bei dieser Version ist etwas mehr Vertrautheit mit objektorientierten Programmierkonzepten erforderlich als bei den anderen ActionScript-Versionen. ActionScript 3.0 ist vollständig kompatibel mit der ECMAScript-Spezifikation, bietet bessere XML-Verarbeitung, ein verbessertes Ereignismodell und eine verbesserte Architektur zur Arbeit mit Elementen auf dem Bildschirm. In FLA-Dateien, in denen ActionScript 3.0 verwendet wird, dürfen keine früheren Versionen von ActionScript enthalten sein.

  • (In Animate CC aufgegeben) ActionScript 2.0 ist einfacher zu erlernen als ActionScript 3.0. Obwohl kompilierter ActionScript 2.0-Code langsamer von Flash Player ausgeführt wird als kompilierter ActionScript 3.0-Code, eignet sich ActionScript 2.0 aber gut für zahlreiche Projekte, die keine allzu große Computerleistung erfordern, wie z. B. eher designorientierten Inhalt. ActionScript 2.0 basiert ebenfalls auf den ECMAScript-Spezifikationen, ist aber nicht völlig konform.

  • (In Animate CC aufgegeben) Bei ActionScript 1.0 handelt es sich um die einfachste Form von ActionScript, die noch von manchen Versionen von Flash Lite Player verwendet wird. ActionScript 1.0 und 2.0 können in derselben FLA-Datei vorkommen.

  • (In Animate CC aufgegeben) Bei Flash Lite 2.x ActionScript handelt es sich um eine Untergruppe von ActionScript 2.0. Es wird von dem auf Mobiltelefonen und anderen Geräten ausgeführten Flash Lite 2.x unterstützt.

  • (In Animate CC aufgegeben) Bei Flash Lite 1.x ActionScript handelt es sich um eine Untergruppe von ActionScript 1.0. Es wird von dem auf Mobiltelefonen und anderen Geräten ausgeführten Flash Lite 1.x unterstützt.

 

Verwenden der ActionScript-Dokumentation

Da es mehrere ActionScript-Versionen (2.0 and 3.0) und mehrere Möglichkeiten zur Einbindung von ActionScript-Code in FLA-Dateien gibt, können Sie ActionScript auf verschiedene Weise erlernen.

In diesem Kapitel wird die grafische Benutzeroberfläche für das Arbeiten mit ActionScript beschrieben. Diese Benutzeroberfläche umfasst das Skriptfenster, den Skripthilfemodus und die Bedienfelder „Aktionen“, „Verhalten“, „Ausgabe“ und „Compiler-Fehler“. Diese Themen beziehen sich auf alle ActionScript-Versionen.

In anderen ActionScript-Dokumentationen von Adobe erfahren Sie mehr zu den einzelnen Versionen von ActionScript.

Arbeiten mit ActionScript

Es gibt verschiedene Möglichkeiten, um mit ActionScript zu arbeiten.

  • (In Animate CC aufgegeben) Im Skripthilfemodus können Sie ActionScript-Code zu FLA-Dateien hinzufügen, ohne den Code selbst schreiben zu müssen. Sie wählen einfach die gewünschten Aktionen aus und die Software bietet eine Benutzeroberfläche, über die Sie die entsprechend benötigten Parameter eingeben können. Sie müssen ein wenig darüber wissen, welche Funktionen für die Ausführung bestimmter Aufgaben erforderlich sind, aber Sie brauchen nicht die Syntax zu erlernen. Dieser Modus wird von vielen Designern und nicht mit der Programmierung vertrauten Benutzern verwendet.

  • (In Animate CC aufgegeben) Mithilfe von Verhaltensweisen können Sie Ihrer Datei auch Code hinzufügen, ohne diesen selbst schreiben zu müssen. Bei Verhalten handelt es sich um vorgefertigte Skripts für häufige Aufgaben. Sie können ein Verhalten hinzufügen und es dann leicht im Bedienfeld „Verhalten“ konfigurieren. Verhalten stehen nur für ActionScript 2.0 und frühere Version zur Verfügung.

  • Sie haben die größte Flexibilität und Kontrolle über Ihr Dokument, wenn Sie selbst den ActionScript-Code schreiben, dafür müssen Sie sich jedoch zunächst mit der ActionScript-Sprache und ihren Konventionen vertraut machen.

  • Komponenten sind vorgefertigte Movieclips, die es gestatten, komplexe Funktionen schnell zu implementieren. Bei einer Komponente kann es sich um ein einfaches Steuerelement der Benutzeroberfläche (wie etwa ein Kontrollkästchen) oder um ein kompliziertes Steuerelement (wie etwa ein Bildlauffenster) handeln. Sie können die Funktion und das Erscheinungsbild einer Komponente anpassen und Komponenten anderer Entwickler herunterladen. Bei den meisten Komponenten ist es erforderlich, dass Sie selbst etwas ActionScript-Code schreiben, um eine Komponente auszulösen oder zu steuern. Weitere Informationen finden Sie unter Verwenden von ActionScript 3.0-Komponenten.

 

Schreiben von ActionScript

In der Authoring-Umgebung schreiben Sie ActionScript-Code im Bedienfeld „Aktionen“ oder im Skriptfenster. Das Bedienfeld „Aktionen“ und das Skriptfenster enthalten einen vielseitigen Code-Editor, der folgende Funktionen bietet: Codehinweise, Codeformatierung, farbige Codehervorhebung, Syntaxhervorhebung, Debugging, Zeilennummern, Zeilenumbruch und Unicode-Unterstützung.

  • Im Bedienfeld „Aktionen“ können Sie Skripts schreiben, die zum Animate-Dokument gehören (also Skripts, die in der FLA-Datei eingebettet sind). Das Bedienfeld „Aktionen“ bietet zum Beispiel die Werkzeugleiste „Aktionen“, über die Sie schnell und einfach auf die Hauptbestandteile der ActionScript-Sprache zugreifen können. Hier werden Sie darüber informiert, welche Elemente für die Erstellung von Skripts erforderlich sind.

  • Im Skriptfenster können Sie externe Skripts (Skripts oder Klassen, die in externen Dateien gespeichert sind) schreiben. (Auch mit einem Texteditor können Sie eine externe AS-Datei erstellen.) Das Skriptfenster enthält Codehilfefunktionen, wie Codehinweise, farbige Codehervorhebung, Syntaxprüfung und automatisches Formatieren.

Von Adobe empfohlene Community-Inhalte

In den folgenden Artikeln und Tutorials finden Sie weitere ausführliche Informationen über die Arbeit mit ActionScript:

Das Bedienfeld „Aktionen“

Sie suchen das Referenzhandbuch?

Um Referenzinformationen zu einem bestimmten Element der ActionScript-Sprache zu finden, haben Sie die folgenden Möglichkeiten:

  • Öffnen Sie das ActionScript 3.0-Referenzhandbuch und suchen Sie nach dem Sprachelement.

  • (In Animate CC aufgegeben) Öffnen Sie das ActionScript 2.0-Referenzhandbuch und suchen Sie nach dem Sprachelement.

  • Geben Sie den Namen des Sprachelements in das Bedienfeld „Aktionen“ ein, wählen Sie es aus und drücken Sie F1. (Sie müssen sofort F1 drücken, andernfalls öffnet sich dieses Hilfethema.)

Hinweis:

Wenn Sie die Hilfe in einem Webbrowser statt in der Community Help-Anwendung anzeigen möchten, lesen Sie diesen Artikel: http://kb2.adobe.com/community/publishing/916/cpsid_91609.html.

ActionScript – Arbeitshandbuch

Wenn Sie das Schreiben von ActionScript-Code erlernen möchten, nutzen Sie die folgenden Ressourcen:

Hinweis:

ActionScript 3.0 und 2.0 sind nicht miteinander kompatibel. Sie müssen sich für eine Version entscheiden, die Sie in der FLA-Datei, die Sie erstellen, verwenden.

Überblick über das Bedienfeld „Aktionen“

Um Skripts zu erstellen, die in eine FLA-Datei eingebettet sind, geben Sie ActionScript-Code direkt in das Bedienfeld „Aktionen“ ein („Fenster“ > „Aktionen“ oder F9 drücken).

actions-frame-view
Bedienfeld „Aktionen“

Das Bedienfeld „Aktionen“ ist in zwei Bereiche unterteilt:

Skriptfenster

Hier können Sie ActionScript-Code eingeben, der mit dem zurzeit ausgewählten Frame verknüpft ist.

Skript-Navigator

Hier werden die Skripts in Ihrem Animate-Dokument aufgelistet, sodass Sie schnell zwischen ihnen navigieren können. Klicken Sie auf ein Element im Skript-Navigator, um das Skript im Skriptfenster anzuzeigen.

Über das Bedienfeld „Aktionen“ können Sie Codehilfefunktionen aufrufen, die die Erstellung und Bearbeitung von ActionScript-Code vereinfachen und optimieren. Mit dieser Funktion können Sie nicht bildspezifische globale Skripts und Drittanbieterskripts hinzufügen, die Sie aus Animate auf die gesamte Animation anwenden können. Weitere Informationen hierzu finden Sie auf dieser Seite im Kapitel zum Hinzufügen von globalen Skrips und Drittanbieterskripts

  • Skript ausführen: Führt das Skript aus
  • Skript fixieren: Fixiert das Skript an den Fixierpunkten einzelner Skripts im Skriptfenster und verschiebt sie entsprechend. Diese Funktion ist hilfreich, wenn Sie den Code in Ihrer FLA-Datei nicht in einem zentralen Verzeichnis organisiert haben oder mehrere Skripts wiederverwenden. Sie können ein Skript fixieren, um das offene Verzeichnis des Codes im Bedienfeld „Aktionen“ beizubehalten und zwischen den verschiedenen geöffneten Skripts zu wechseln. Das kann besonders beim Debuggen nützlich sein.
  • Instanzpfad und -namen einfügen: Hier können Sie einen absoluten oder relativen Zielpfad für eine Aktion im Skript festlegen.
  • Suchen: Sucht und ersetzt Text innerhalb der Skripts.
  • Formatieren von Code: Unterstützt Sie beim Formatieren von Code.
  • Codefragmente: Öffnet das Bedienfeld „Codefragmente“, in dem Beispielcodefragmente angezeigt werden.
  • Hilfe: Zeigt Referenzinformationen für das im Skriptfenster ausgewählte ActionScript-Element aus. Wenn Sie beispielsweise auf eine Import-Anweisung und dann auf „Hilfe“ klicken, werden im Bedienfeld „Hilfe“ die Referenzinformationen für den Import angezeigt.

Überblick über das Bedienfeld „Ausgabe“

Wenn Sie einen beliebigen Dokumententyp testen, werden im Bedienfeld „Ausgabe“ Informationen oder Warnhinweise im Zusammenhang mit Vorgängen wie der Dokumentenkonvertierung, der Veröffentlichung usw. angezeigt. Um diese Informationen anzuzeigen, fügen Sie Ihrem Code die Anweisung trace() hinzu oder nutzen Sie die Befehle „Objekte auflisten“ und „Variablen auflisten“.

Wenn Sie in Ihren Skripts die Anweisung trace() verwenden, können Sie spezifische Informationen an das Bedienfeld „Ausgabe“ senden, während die SWF-Datei wiedergegeben wird, Dazu zählen auch Hinweise auf den Status der SWF-Datei oder den Wert eines Ausdrucks. 

Output_panel
Bedienfeld „Ausgabe“

Das Bedienfeld Ausgabe verfügt über die folgenden Menüoptionen:

  • Kopieren: Kopiert den gesamten Inhalt des Bedienfelds „Ausgabe“ in die Zwischenablage des Computers. Soll nur ein bestimmter Ausschnitt der Ausgabe kopiert werden, wählen Sie den gewünschten Ausschnitt aus und wählen dann „Kopieren“.
  • Löschen: Löscht den Inhalt aus dem Bedienfeld „Ausgabe“.
  • Ausgabe anzeigen: Zeigt den Inhalt des Bedienfelds „Ausgabe“ an.
  • Fixieren: Fixiert das Bedienfeld. Sie können das Bedienfeld lediglich in der Größe anpassen, jedoch nicht verschieben oder ziehen.
  • Hilfe: Ruft die Online-Hilfe für das Bedienfeld „Ausgabe“ auf.
  • Schließen: Schließt das Bedienfeld „Ausgabe“.
  • Gruppe schließen: Schließt die gesamte Bedienfeldgruppe. Sie können mehrere Bedienfelder wie die Zeitleiste, das Bedienfeld „Ausgabe“ und das Bedienfeld „Compiler-Fehler“ gleichzeitig andocken.

 

Ein- oder Ausblenden des Bedienfelds „Ausgabe“

  •  Wählen Sie Fenster > Ausgabe oder drücken Sie F2.

(In Animate CC aufgegeben) Drucken von ActionScript

  1. Wählen Sie im Optionsmenü (auch Bedienfeldmenü genannt) im Bedienfeld „Aktionen“ den Befehl „Drucken“ aus.
  2. Wählen Sie „Optionen“ und klicken Sie auf „Drucken“.

    Da der Ausdruck keine Informationen über die ursprüngliche Datei enthält, sollten Sie diese Informationen, zum Beispiel den Namen der FLA-Datei, mit einem Kommentar in das Skript einbinden.

Überblick über das Skriptfenster

Im Skriptfenster können Sie externe Skriptdateien erstellen, um sie dann in Ihre Anwendung zu importieren. Bei diesen Skripts kann es sich um ActionScript- oder Animate JavaScript-Dateien handeln.

Sie können auch globale und Drittanbieterskripts in HTML5 Canvas-Dokumenten hinzufügen. Weitere Informationen hierzu finden Sie im Abschnitt zu globalen Skripts und Drittanbieterskripts im Kapitel HTML5 Canvas-Dokumente in Animate CC erstellen und veröffentlichen.  

actions-add-script
Skriptfenster

Wenn Sie mehrere Dateien gleichzeitig geöffnet haben, werden die Dateinamen auf Registerkarten am oberen Rand des Skriptfensters angezeigt.

Im Skriptfenster können Sie die folgenden Funktionen verwenden: PinScript, Suchen und Ersetzen, Syntaxfarbcodierung, Code formatieren, Codehinweise, Code kommentieren, Code ausblenden, Debug-Optionen (nur ActionScript-Dateien) und Zeilenumbruch. Im Skriptfenster können auch Zeilennummern und versteckte Zeichen angezeigt werden.

Erstellen von externen Dateien im Skriptfenster

  1. Wählen Sie Datei > Neu.

  2. Wählen Sie den Typ der zu erstellenden externen Datei aus (ActionScript-Datei oder Animate-JavaScript-Datei).

Bearbeiten von vorhandenen Dateien im Skriptfenster

  • Um ein vorhandenes Skript zu öffnen, wählen Sie „Datei“ > „Öffnen“ und öffnen Sie eine vorhandene AS-Datei.

  • Um ein bereits geöffnetes Skript zu bearbeiten, klicken Sie auf die Dokumentregisterkarte, auf der der Skriptname angezeigt wird.

Werkzeuge im Bedienfeld „Aktionen“ und Skriptfenster

Über das Bedienfeld „Aktionen“ können Sie Codehilfefunktionen aufrufen, die die Erstellung und Bearbeitung von ActionScript-Code vereinfachen und optimieren.

Suchen 

Sucht und ersetzt Text innerhalb der Skripts.

Zielpfad einfügen 

(nur Bedienfeld „Aktionen“) Erleichtert das Einstellen eines absoluten oder relativen Zielpfades für eine Aktion im Skript.

Hilfe 

Zeigt Referenzinformationen für das im Skriptfenster ausgewählte ActionScript-Element aus. Wenn Sie beispielsweise auf eine import-Anweisung und dann auf „Hilfe“ klicken, werden im Bedienfeld „Hilfe“ die Referenzinformationen für import angezeigt.

Codefragmente

Öffnet das Bedienfeld „Codefragmente“, in dem Beispielcodefragmente angezeigt werden.

Zugreifen auf kontextabhängige Hilfeinformationen über das Bedienfeld „Aktionen“

  1. Wenn Sie Hilfeinformationen für ein Element anzeigen möchten, führen Sie einen der folgenden Schritte aus:
    • Wählen Sie einen ActionScript-Begriff im Werkzeugfenster des Bedienfelds „Aktionen“ aus (links im Bedienfeld „Aktionen“).

    • Wählen Sie im Skriptfenster des Bedienfelds „Aktionen“ einen ActionScript-Begriff aus.

    • Positionieren Sie die Einfügemarke im Skriptfenster des Bedienfelds „Aktionen“ vor einem ActionScript-Begriff.

  2. Führen Sie einen der folgenden Schritte aus, um die Hilfeseite für das ausgewählte Element anzuzeigen:
    • Drücken Sie F1.

    • Klicken Sie mit der rechten Maustaste auf das Element und wählen Sie „Hilfe anzeigen“.

    • Klicken Sie oberhalb des Skriptfensters auf „Hilfe“ .

ActionScript-Voreinstellungen festlegen

Sie können bestimmte Voreinstellungen festlegen und ändern, unabhängig davon, ob Sie den Code im Bedienfeld „Aktionen“ oder im Skriptfenster bearbeiten.

  1. Wählen Sie „Bearbeiten“ > „Voreinstellungen“ (Windows) oder „Animate“ > „Voreinstellungen“ (Macintosh) und klicken Sie dann in der Liste „Kategorie“ auf „Code-Editor“.

  2. Legen Sie eine oder mehrere dieser Voreinstellungen fest:

    Automatische Einrückung

    Wenn diese Option aktiviert ist, wird Text, den Sie nach der rechten runden Klammer „(“ oder der rechten geschweiften Klammer „{“ eingeben, automatisch entsprechend der Voreinstellung „Tabulatorgröße“ eingerückt.

    Tabulatorgröße

    Gibt die Anzahl der Zeichen an, um die eine neue Zeile eingerückt wird.

    Codehinweise

    Aktiviert die Anzeige von Codehinweisen im Skriptbereich.

    Verzögerung

    Bestimmt den Zeitraum (in Sekunden), nach dem Codehinweise eingeblendet werden. Beachten Sie, dass die Option in Animate CC aufgegeben wurde.

    Schriftart

    Bestimmt die im Skript verwendete Schriftart.

    Öffnen/Importieren

    Bestimmt die Zeichenkodierung, die beim Öffnen oder Importieren von ActionScript-Dateien verwendet wird.

    Speichern/Exportieren

    Bestimmt die Zeichenkodierung, die beim Speichern oder Exportieren von ActionScript-Dateien verwendet wird.

    Modifizierte Dateien neu laden

    Bestimmt was geschieht, wenn eine Skriptdatei geändert, verschoben oder gelöscht wird. Verfügbare Optionen sind „Immer“, „Nie“ und „Fragen“.

    Immer

    Es wird keine Warnung angezeigt und die Datei wird automatisch neu geladen.

    Nie

    Es wird keine Warnung angezeigt und die Datei verbleibt im aktuellen Status.

    Nachfragen

    (Standardeinstellung) Es wird eine Warnung angezeigt und Sie können wählen, ob die Datei neu geladen wird oder nicht.

    Wenn Sie Anwendungen mit externen Skriptdateien erstellen, kann durch diese Voreinstellung vermieden werden, dass Sie ein Skript überschreiben, das ein anderes Teammitglied geändert hat, seit Sie die Anwendung geöffnet haben. Auch lässt sich mithilfe dieser Option vermeiden, dass die Anwendung mit älteren Versionen der Skripts veröffentlicht wird. Die Warnungen ermöglichen es Ihnen, automatisch ein Skript zu schließen und die geänderte, neuere Version zu öffnen.

    Syntaxfarben

    Bestimmt die farbliche Codehervorhebung in Ihren Skripts.

    ActionScript 3.0-Einstellungen

    Diese Schaltflächen öffnen das Dialogfeld „ActionScript-Einstellungen“, in dem Sie einen Quellpfad, Bibliothekspfad oder einen Pfad zu einer externen Bibliothek für ActionScript 3.0 festlegen können.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™ und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie