Übersicht

Adobe Animate bietet zahlreiche Möglichkeiten, mit Sound zu arbeiten. Sie können Sound unabhängig von der Zeitleiste ständig abspielen oder über die Zeitleiste mit Animationen synchronisieren. Außerdem haben Sie die Möglichkeit, Schaltflächen durch Einbinden von Sounds interaktiver zu gestalten sowie den Soundtrack Ihrer Filme durch Ein- und Ausblenden von Sounds zu verfeinern.

Animate unterstützt zwei Arten von Sounds: Ereignis-Sounds und Streaming-Sounds. Ereignis-Sounds müssen vor dem Abspielen vollständig heruntergeladen werden und werden abgespielt, bis sie ausdrücklich angehalten werden. Streaming-Sounds werden abgespielt, sobald genügend Daten für die ersten Bilder heruntergeladen wurden. Streaming-Sounds werden außerdem für die Wiedergabe auf einer Website mit der Zeitleiste synchronisiert.

Wenn Sie Animate-Inhalte für mobile Geräte erstellen, bietet Ihnen Animate die Möglichkeit, Geräte-Sounds in die veröffentlichte SWF-Datei einzubinden. Geräte-Sounds werden in dem vom Gerät nativ unterstützten Audioformat, wie etwa MIDI, MFi oder SMAF, kodiert.

Mithilfe von gemeinsamen Bibliotheken können Sie einen Sound mit mehreren Dokumenten verknüpfen. Außerdem haben Sie die Möglichkeit, ein Ereignis mit dem ActionScript® 2.0 onSoundComplete-Ereignis oder dem ActionScript® 3.0 soundComplete-Ereignis nach Ablauf eines Sounds automatisch auszulösen.

Sie können Sounds laden und die Soundwiedergabe mithilfe von vorgefertigten Verhalten oder Medienkomponenten steuern; letztere enthalten zusätzlich eine Steuerung zum Stoppen, Anhalten, Zurückspulen etc. Sounds können auch mithilfe von ActionScript 2.0 oder 3.0 dynamisch geladen werden.

Weitere Informationen finden Sie unter attachSound (Sound.attachSound-Methode) und loadSound (Sound.loadSound-Methode) im ActionScript 2.0-Referenzhandbuch oder unter Sound-Klasse im Komponenten-Referenzhandbuch für ActionScript 3.0.

Hinweis:

ActionScript 2.0 und ActionScript 1.0 werden in Animate CC nicht unterstützt.

Informationen zum Importieren von Sounds

Sounddateien werden durch Importieren in die Bibliothek oder durch das direkte Importieren auf die Bühne in Animate platziert.

Mit der Option „Datei“ > „Importieren“ > „In Bibliothek importieren“ wird die Audiodatei lediglich in die Bibliothek und nicht in die Zeitleiste importiert.

Wenn Sie eine Audiodatei über die Option „Datei“ > „Importieren“ > „In Bühne importieren“ oder durch direktes Ziehen der Audiodatei per Drag & Drop in die Zeitleiste importieren, wird die Audiodatei in dem aktiven Bild der jeweils aktiven Ebene platziert. Wenn Sie mehrere Audiodateien per Drag & Drop ziehen, wird nur eine Audiodatei importiert, da in einem Bild jeweils nur eine Audiodatei enthalten sein darf. 

Gehen Sie wie folgt vor, um eine Audiodatei zu importieren:

  • Um eine Audiodatei in eine Bibliothek zu importieren, wählen Sie die Option „Datei“ > „Importieren“ > „In Bibliothek importieren“ aus, und navigieren Sie zu der Audiodatei, die Sie importieren möchten.
  • Um eine Audiodatei in eine Bühne zu importieren, wählen Sie die Option „Datei“ > „Importieren“ > „In Bühne importieren“ aus, und navigieren Sie zu der Audiodatei, die Sie importieren möchten. 
  • Sie können die Audiodatei auch direkt per Drag & Drop auf die Bühne ziehen und ablegen.
import-sounds

Hinweis:

Sie können auch einen Sound aus einer allgemeinen Bibliothek in die Bibliothek des aktuellen Dokuments ziehen.

Animate speichert Sounds zusammen mit Bitmaps und Symbolen in der Bibliothek. Sie benötigen nur eine Kopie einer Sounddatei, um diesen Sound beliebig oft auf verschiedene Weise in Ihrem Dokument zu verwenden.

Wenn Sie dieselben Sounds in verschiedenen Animate-Dokumenten einsetzen möchten, können Sie sie in einer gemeinsamen Bibliothek ablegen.

Animate enthält eine Sound-Bibliothek mit zahlreichen nützlichen Sounds, die Sie für Effekte verwenden können. Um die Sound-Bibliothek zu öffnen, wählen Sie „Fenster“ > „Allgemeine Bibliotheken“ > „Sounds“. Um einen Sound aus der Sound-Bibliothek in die Animate-Datei zu importieren, ziehen Sie den Sound aus der Sound-Bibliothek in das Bedienfeld „Bibliothek“ der Animate-Datei. Sie können Sounds aus der Sound-Bibliothek auch in andere gemeinsame Bibliotheken ziehen.

Sounds beanspruchen oftmals sehr viel Platz auf der Festplatte und im Arbeitsspeicher, wobei MP3-Sounddateien aufgrund der Komprimierung deutlich kleiner sind als Sounddateien im WAV- oder AIFF-Format. Im Allgemeinen sind für WAV- oder AIFF-Dateien Mono-Sounds mit 16‒22 kHz am besten geeignet (Stereo-Sounds benötigen doppelt so viele Daten wie Mono-Sounds). Animate ist in der Lage, 8- und 16-Bit-Sounds mit Abtastraten von 11, 22 oder 44 kHz zu importieren. Aufgezeichnete Sounds, deren Abtastrate kein Vielfaches von 11 kHz beträgt (z. B. 8, 32 oder 96 kHz), werden beim Importieren in Animate neu gesampelt. Außerdem kann Animate Sounds beim Exportieren in niedrigere Abtastraten konvertieren.

Möchten Sie einem Sound in Animate zusätzliche Effekte hinzufügen, so importieren Sie am besten einen 16-Bit-Sound. Wenn nur eine begrenzte Menge Arbeitsspeicher zur Verfügung steht, sollten Sie sich auf kurze Soundclips beschränken oder anstelle von 16-Bit-Sounds besser 8-Bit-Sounds verwenden.

Hinweis:

Für den Import oder die Wiedergabe von Sound in Animate muss QuickTime oder iTunes nicht installiert sein.

Unterstützte Sounddateiformate

Die folgenden Sounddateiformate können in Animate importiert werden:

  • Adobe Sound (.asnd). Dies ist das native Soundformat von Adobe® Soundbooth™.

  • Wave (.wav)

  • AIFF (.aif, .aifc)

  • mp3

    Sie können diese zusätzlichen Sounddateiformate importieren:

  • Sound Designer® II (.sd2)

  • Sun AU (.au, .snd)

  • FLAC (.flac)

  • Ogg Vorbis (.ogg, .oga)

Hinweis:

  • Das ASND-Format ist ein zerstörungsfreies Audiodateiformat, das nativ in Adobe Soundbooth verwendet wird. ASND-Dateien können Audiodaten mit Effekten enthalten, die später modifiziert werden können, sowie Soundbooth-Multitrack-Sitzungen und Snapshots, mit denen Sie einen früheren Zustand der ASND-Datei wiederherstellen können.
  • Die Dokumenttypen WebGL und HTML5 Canvas unterstützen lediglich die Formate MP3 und WAV.

Hinzufügen von Sounds in Animate

Hinzufügen eines Sounds direkt vom Computer in der Zeitleiste

Sie können Audiodateien direkt vom Computer in die Zeitleiste importieren, indem Sie wie folgt vorgehen:

  • Wählen Sie die Option Datei > Importieren > In Bühne importieren aus und navigieren Sie zur Audiodatei, die Sie importieren möchten.
  • Ziehen Sie die Audiodatei per Drag & Drop auf die Bühne/Zeitleiste. 

Beachten Sie, dass Audiodateien nur einzeln hinzugefügt werden können. Beim Verschieben mehrerer Audiodateien per Drag-and-Drop wird nur eine Audiodatei in die Zeitleiste importiert.

Hinzufügen eines Sounds aus der Bibliothek in der Zeitleiste

Sie können einen Sound aus der Bibliothek in ein Dokument übernehmen oder mithilfe der loadSound-Methode des Sound-Objekts zur Laufzeit einen Sound in eine SWF-Datei laden. Weitere Informationen finden Sie unter Sound-Klasse im ActionScript 3.0-Referenzhandbuch.

  1. Importieren Sie den Sound in die Bibliothek, sofern er dort noch nicht gespeichert ist.
  2. Wählen Sie Einfügen > Zeitleiste > Ebene aus.

    timeline-layer
  3. Wählen Sie die neue Soundebene aus und ziehen Sie den Sound aus dem Bedienfeld „Bibliothek“ auf die Bühne. Der Sound wird der aktuellen Ebene hinzugefügt.

    Sie haben auch die Möglichkeit, mehrere Sounds auf einer Ebene zu platzieren oder Sounds mit anderen Objekten auf einer Ebene zu kombinieren. Es wird jedoch empfohlen, jeden Sound auf einer eigenen Ebene zu platzieren. Jede Ebene stellt einen separaten Soundkanal dar, wobei die Sounds auf allen Ebenen beim Abspielen der SWF-Datei miteinander kombiniert werden.

  4. Wählen Sie in der Zeitleiste das erste Bild aus, das die Sounddatei enthält.
  5. Wählen Sie Fenster > Eigenschaften aus und klicken Sie auf den Pfeil in der rechten unteren Ecke des Eigenschafteninspektors, um ihn zu erweitern.

  6. Wählen Sie im Popupmenü „Sound“ des Eigenschafteninspektors die betreffende Sounddatei aus.
  7. Wählen Sie im Popupmenü „Effekt“ eine Effektoption aus:

    Keine

    Es werden keine Effekte auf die Sounddatei angewendet. Bei Auswahl dieser Option werden alle zuvor ausgewählten Effekte entfernt.

    Linker Kanal oder Rechter Kanal

    Gibt den Sound nur auf dem linken bzw. dem rechten Kanal wieder.

    Von links nach rechts/Von rechts nach links

    Verschiebt den Sound während der Wiedergabe vom einen auf den anderen Kanal.

    Einblenden

    Erhöht die Lautstärke eines Sounds während der Wiedergabe schrittweise.

    Verblassen

    Verringert die Lautstärke eines Sounds während der Wiedergabe schrittweise.

    Benutzerdefiniert

    Ermöglicht das Festlegen eigener Anfangs- und Endpunkte für den Sound im Dialogfeld „Hüllkurve bearbeiten“.

    Hinweis:

    Effekte werden in WebGL und HTML5 Canvas-Dokumenten nicht unterstützt.

  8. Wählen Sie im Popupmenü „Sync“ eine Synchronisierungsoption aus:

    Ereignis

    Synchronisiert den Sound mit dem Auftreten eines Ereignisses. Ein Ereignissound wird abgespielt, wenn sein Startschlüsselbild zum ersten Mal erscheint, und wird dann vollständig abgespielt, unabhängig vom Abspielkopf in der Zeitleiste, selbst wenn die SWF-Datei nicht mehr abgespielt wird. Ereignis-Sounds werden beim Abspielen der veröffentlichten SWF-Datei gemischt.

    Wenn ein Ereignissound abgespielt wird und der Sound dann erneut instanziiert wird (zum Beispiel wenn der Benutzer erneut auf eine Schaltfläche klickt, oder wenn der Abspielkopf das Startschlüsselbild des Sounds passiert), wird die erste Instanz des Sounds weiterhin abgespielt, während gleichzeitig die Wiedergabe einer zweiten Instanz desselben Sounds beginnt. Dies sollten Sie beachten, wenn Sie längere Sounds verwenden, da diese sich möglicherweise überlappen und unerwünschte Audioeffekte erzeugen.

    Anfang

    Funktioniert ähnlich wie die Option „Ereignis“, wobei jedoch keine zweite Soundinstanz gestartet wird, wenn der Sound bereits zu hören ist.

    Anhalten

    Beendet die Wiedergabe des angegebenen Sounds.

    Stream

    Synchronisiert den Sound für die Wiedergabe auf einer Website. Hierbei passt Animate den Ablauf der Animation an den Streaming-Sound an. Wenn Animate nicht in der Lage ist, die Bilder der Animation schnell genug anzuzeigen, werden einzelne Bilder übersprungen. Im Gegensatz zu Ereignis-Sounds werden Streaming-Sounds angehalten, wenn der Benutzer die SWF-Dateiwiedergabe abbricht. Außerdem wird ein Streaming-Sound stets nur so lange wiedergegeben wie die ihm zugeordneten Bilder. Streaming-Sounds werden beim Abspielen der veröffentlichten SWF-Datei gemischt.

    Ein Streaming-Sound ist beispielsweise die Stimme eines Darstellers in einer Animation, die in mehreren Bildern abgespielt wird.

    Animate speichert die Audio-Synchronisierungseinstellungen im Eigenschafteninspektor. Wenn Sie im Eigenschafteninspektor im Bereich „Sound“ einen Sound auswählen und dann in einem neuen Schlüsselbild versuchen, über den Eigenschafteninspektor einen anderen Sound festzulegen, merkt sich Animate die Synchronisierungsoptionen „Stream“ oder „Ereignis“ des vorherigen Sounds.

    Hinweis:

    Wenn Sie einen mp3-Sound als Streaming-Sound verwenden, müssen Sie ihn für den Export neu komprimieren. Hierbei haben Sie die Möglichkeit, den Sound als mp3-Datei mit denselben Komprimierungseinstellungen zu exportieren, mit denen er importiert wurde.

    Stream-Einstellungen werden in WebGL- und HTML5 Canvas-Dokumenten nicht unterstützt.

  9. Geben Sie einen Wert für die Wiederholung des Sounds an, oder wählen Sie die Option „Wiederholen“, damit der Sound in Schleife abgespielt wird.

    Wenn Sie den Sound über einen längeren Zeitraum hinweg abspielen möchten, tragen Sie in dieses Feld einen ausreichend hohen Wert ein. Soll ein Sound mit einer Dauer von 15 Sekunden beispielsweise 15 Minuten lang zu hören sein, so müssen Sie den Wert 60 eingeben. Streaming-Sounds sollten grundsätzlich nicht in Schleife abgespielt werden, da hierdurch zusätzliche Bilder in die Datei eingefügt werden und die Dateigröße zunimmt, je öfter sich der Sound wiederholt.

  10. Um den Sound zu testen, ziehen Sie einfach den Abspielkopf auf die Bilder, die den Sound enthalten, oder verwenden Sie die entsprechenden Befehle in der Steuerung bzw. im Steuerungsmenü.

Entfernen eines Sounds aus der Zeitleiste

  1. Wählen Sie in der Zeitleistenebene, die den Sound enthält, ein Bild aus, das den Sound ebenfalls enthält.
  2. Gehen Sie im Eigenschafteninspektor zum Abschnitt „Sound“ und wählen Sie im Menü „Name“ die Option „Ohne“.

    Animate löscht den Sound aus der Zeitleistenebene.

Hinzufügen eines Sounds zu einer Schaltfläche

Sie können den verschiedenen Zuständen einer Schaltfläche Sounds zuordnen. Da diese Sounds zusammen mit dem Symbol gespeichert werden, funktionieren sie bei allen Instanzen des Symbols.

  1. Wählen Sie im Bedienfeld „Bibliothek“ die gewünschte Schaltfläche aus.
  2. Wählen Sie im Menü „Bedienfeld“ in der rechten oberen Ecke des Bedienfelds die Option „Bearbeiten“ aus.
  3. Fügen Sie in der Zeitleiste der Schaltfläche eine Sound-Ebene hinzu (Einfügen > Zeitleiste > Ebene).

  4. Erstellen Sie in der Sound-Ebene ein normales oder leeres Schlüsselbild, das dem Zustand der Schaltfläche entspricht, der Sie einen Sound hinzufügen möchten.

    Klicken Sie auf Einfügen > Zeitleiste > Schlüsselbild oder auf Einfügen > Zeitleiste > Leeres Schlüsselbild.

    Wenn der Sound beispielsweise wiedergegeben werden soll, wenn der Benutzer auf die Schaltfläche klickt, erstellen Sie das Schlüsselbild in dem Bild mit der Bezeichnung „Gedrückt“.

    insert-keyframes
  5. Klicken Sie auf das neue Schlüsselbild.
  6. Wählen Sie Fenster > Eigenschaften aus.

  7. Wählen Sie im Popupmenü „Sound“ des Eigenschafteninspektors die gewünschte Sounddatei aus.
  8. Wählen Sie im Popupmenü „Sync“ die Einstellung „Ereignis“ aus.

    Wenn Sie den verschiedenen Schaltflächenzuständen unterschiedliche Sounds zuweisen möchten, erstellen Sie für jeden der Zustände ein leeres Schlüsselbild, und fügen Sie jedem Schlüsselbild die entsprechende Sounddatei hinzu. Sie haben auch die Möglichkeit, allen Schaltflächenschlüsselbildern dieselbe Sounddatei hinzuzufügen, aber jeweils unterschiedliche Soundeffekte zuzuweisen.

Synchronisieren von Sounds mit Animationen

Um Sounds mit Animationen zu synchronisieren, starten und stoppen Sie die Sounds in Schlüsselbildern.

  1. Fügen Sie der Zeitleiste in ihrer eigenen Ebene einen Sound hinzu (Anweisungen finden Sie weiter oben).
  2. Um diesen Sound mit einem Ereignis in der Szene zu synchronisieren, erstellen Sie ein Startschlüsselbild für den Sound, das dem Schlüsselbild des Ereignisses in der Szene entspricht, die den Sound auslösen soll. Sie können beliebige der weiter oben beschriebenen Synchronisierungsoptionen wählen (siehe „Hinzufügen eines Sounds zur Zeitleiste“).
  3. Erstellen Sie in der Zeitleiste der Soundebene ein Schlüsselbild in dem Bild, in dem der Sound enden soll. Die Sounddatei wird in der Zeitleiste dargestellt.
  4. Wählen Sie Fenster > Eigenschaften aus und klicken Sie auf den Pfeil in der rechten unteren Ecke des Eigenschafteninspektors, um ihn zu erweitern.

  5. Wählen Sie im Popupmenü „Sound“ des Eigenschafteninspektors denselben Sound aus.
  6. Wählen Sie im Eigenschafteninspektor im Popupmenü „Synchronisieren“ den Eintrag „Beenden“.

    Bei der SWF-Dateiwiedergabe wird der Sound angehalten, sobald das Endschlüsselbild erreicht ist.

  7. Um den Sound abzuspielen, ziehen Sie den Abspielkopf in der Zeitleiste.

Bearbeiten von Sounds

Bearbeiten eines Sounds in Animate

In Animate können Sie den Anfangspunkt eines Sounds festlegen und die Lautstärke bei der Wiedergabe steuern. Die Stelle, an der ein Sound während der Filmwiedergabe ein- oder ausgeblendet wird, lässt sich nach Belieben ändern, um beispielsweise eine Sounddatei durch Entfernen überflüssiger Abschnitte zu verkleinern.

  1. Fügen Sie einem Bild einen Sound hinzu oder wählen Sie ein Bild aus, das bereits einen Sound enthält.
  2. Wählen Sie Fenster > Eigenschaften aus.

    windows-properties
  3. Klicken Sie auf die Schaltfläche „Bearbeiten“ auf der rechten Seite des Eigenschafteninspektors.
  4. Führen Sie einen der folgenden Schritte aus:
    • Ziehen Sie Steuerungen für den Anfangs- und den Endpunkt im Bedienfeld „Hüllkurve bearbeiten“ an die gewünschten Positionen, um den Anfangs- und den Endpunkt des Sounds zu ändern.

    • Ziehen Sie die Hüllengriffe an die gewünschten Positionen, um die Klanghülle und damit die Lautstärke an verschiedenen Stellen im Sound zu verändern. Der Verlauf der Lautstärke während der Soundwiedergabe wird durch die Hüllenlinien angezeigt. Zum Hinzufügen weiterer Hüllengriffe klicken Sie auf die Hüllenlinien. Insgesamt stehen bis zu acht Hüllengriffe zur Verfügung. Zum Entfernen eines Hüllengriffs ziehen Sie ihn einfach aus dem Fenster heraus.

    • Klicken Sie auf die Schaltfläche „Vergrößern“ (+) oder „Verkleinern“ (-), um die Größe der Ansicht im Soundfenster zu ändern.

    • Klicken Sie auf die Schaltfläche „Sekunden“ oder „Bilder“, um zwischen diesen beiden Zeiteinheiten umzuschalten.

  5. Klicken Sie auf die Schaltfläche „Abspielen“, um den bearbeiteten Sound wiederzugeben.

Bearbeiten von Sounds in Soundbooth

Wenn auf Ihrem Computer Adobe Soundbooth installiert ist, können Sie Sounds, die Sie in die Animate-Datei importiert haben, mit Soundbooth bearbeiten. Nachdem Sie Änderungen in Soundbooth vorgenommen haben, werden die Änderungen automatisch in der Animate-Datei widergespiegelt, wenn Sie die Datei speichern und das Original überschreiben.

Wenn Sie den Dateinamen oder das Format des Sounds nach der Bearbeitung ändern, müssen Sie ihn erneut in Animate importieren.

Hinweis:

Soundbooth ist nur auf Windows-Computern und Intel®-basierten Macintosh-Rechnern verfügbar.

So bearbeiten Sie einen importierten Sound in Soundbooth:

  1. Klicken Sie mit der rechten Maustaste (Windows) oder bei gedrückter Ctrl-Taste (Macintosh) auf den Sound im Bedienfeld „Bibliothek“.
  2. Wählen Sie im Kontextmenü „Bearbeiten in Soundbooth“. Die Datei wird in Soundbooth geöffnet.
  3. Bearbeiten Sie die Datei in Soundbooth.
  4. Nachdem Sie die Änderungen vorgenommen haben, speichern Sie die Datei. Um die Änderungen in einem zerstörungsfreien Format zu speichern, wählen Sie das ASND-Format. Wenn Sie die Sounddatei in einem anderen als dem ursprünglichen Format speichern, müssen Sie sie erneut in Animate importieren.

  5. Kehren Sie zu Animate zurück, wo Sie die bearbeitete Version der Sounddatei im Bedienfeld Bibliothek sehen.

Hinweis:

Sie können keine Sounds aus der Soundbibliothek („Fenster“ > „Allgemeine Bibliotheken“ > Sounds) mit dem Befehl „Bearbeitung in Soundbooth“ bearbeiten. Um diese Sounds in Soundbooth zu bearbeiten, öffnen Sie Soundbooth und wählen Sie den Sound aus dem Bedienfeld „Resource Central“ aus. Bearbeiten Sie den Sound und importieren Sie ihn in Animate.

Teilen oder Wiederholen in Schleife eines Sounds in der Zeitleiste

Teilen eines Sounds in der Zeitleiste

Sie können den in der Zeitleiste eingebetteten Audio-Stream mithilfe des Kontextmenüs „Audio teilen“ teilen. Mit „Audio teilen“ können Sie das Audio bei Bedarf anhalten und dann die Audio-Wiedergabe an einem späteren Punkt in der Zeitleiste an der Stelle fortsetzen, an der sie angehalten wurde.

So teilen Sie einen Audio-Clip in der Zeitleiste:

  1. Wählen Sie Datei > Importieren > In Bibliothek importieren aus. 

  2. Wählen Sie den Audio-Clip aus und importieren Sie ihn in die Bibliothek.

  3. Erstellen Sie eine neue Ebene in der Zeitleiste und fügen Sie den Audio-Clip der Ebene hinzu. 

  4. Wählen Sie unter Eigenschaften > Sound den Typ „Synchronisation“ für das Streaming aus.

    sound-properties-stream
  5. Klicken Sie mit der rechten Maustaste auf das Bild, an dem Sie das Audio teilen möchten, und klicken Sie auf Audio teilen

    Split-audio

Loopsound auf der Zeitleiste

Audioschleifungsdurchschnitte kontinuierlich einen kleinen Abschnitt des Sounds auf eine Reihe von Bildern in der Zeitleiste. Wenn die „Loop“ OPTION in die Zeitleiste eingeschaltet ist, können Sie das Strömen von Audiodaten innerhalb eines Bildbereichs zusammen mit anderen Animationen schlingen.

Um eine Schleife zu erstellen, deaktivieren Sie einfach die Loopoption auf der Zeitleiste ein:

Audio
Die Audioschleifungsschaltfläche auf der Zeitleiste

Verwenden von Sounds in Flash Lite

Adobe® Flash® Lite unterstützt zwei Arten von Sound: standardmäßige Animate-Sounds, wie sie in Animate-Desktopanwendungen verwendet werden, und Geräte-Sounds. Flash Lite 1.0 unterstützt nur Geräte-Sounds; Flash Lite 1.1 und 2.x unterstützen sowohl Standard-Sounds als auch Geräte-Sounds.

Geräte-Sounds werden in der veröffentlichten SWF-Datei in ihrem nativen Audioformat gespeichert (wie etwa MIDI oder MFi). Bei der Wiedergabe gibt Flash Lite die Sounddaten an das Gerät weiter, das den Sound dekodiert und abspielt. Da die meisten Geräte-Audioformate nicht in Animate importiert werden können, wird stattdessen ein Proxy-Sound in einem unterstützten Format (wie etwa mp3 oder AIFF) importiert, der durch einen von Ihnen festgelegten externen Geräte-Sound ersetzt wird.

Sie können Geräte-Sounds nur als Ereignis-Sounds verwenden, d. h. im Gegensatz zu Standard-Sounds können Sie Geräte-Sounds nicht mit der Zeitleiste synchronisieren.

Die folgenden Funktionen, die in der Desktopversion vom Flash® Player verfügbar sind, werden von Flash Lite 1.0 und Flash Lite 1.1 nicht unterstützt:

  • ActionScript-Sound-Objekt

  • Laden externer mp3-Dateien

  • Komprimierungsoption „Sprache“

Weitere Informationen finden Sie unter „Mit Bildern, Audio und Video arbeiten“ in Flash Lite 2.x-Anwendungen entwickeln oder „Mit Sounds arbeiten“ in Flash Lite 1.x-Anwendungen entwickeln.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie