Benutzerhandbuch Abbrechen

FrameMaker-Dokumente in ein Projekt importieren

  1. Benutzerhandbuch zu RoboHelp
  2. Einführung
    1. Neue Funktionen in Adobe RoboHelp
    2. Neue Funktionen bei RoboHelp (2020 Release) Update 8
    3. Neue Funktionen bei RoboHelp (2020 Release) Update 7
    4. Neue Funktionen bei RoboHelp (2020 Release) Update 6
    5. Neue Funktionen bei RoboHelp (2020 Release) Update 5
    6. Neue Funktionen bei RoboHelp (2020 Release) Update 4
    7. Systemanforderungen für RoboHelp
    8. Häufig gestellte Fragen zu RoboHelp
    9. Herunterladen und Installieren Ihrer Adobe-App
    10. Herunterladen und Installieren von RoboHelp für macOS
    11. Erste Schritte im RoboHelp-Arbeitsbereich
    12. Behobene Probleme in RoboHelp
  3. Projekte
    1. Planen Ihres RoboHelp-Projekts
    2. Erstellen eines Projekts
    3. Arbeiten mit Themen und Ordnern
    4. Generieren von Berichten
    5. Arbeiten mit kontextsensitiver Hilfe
    6. Verwalten von Verweisen
    7. Festlegen von Einstellungen in RoboHelp
  4. Zusammenarbeit mit Autoren
    1. Zusammenarbeit mithilfe von Git
    2. Zusammenarbeit mithilfe von SharePoint Online
    3. Zusammenarbeit mithilfe von Azure DevOps (Team Foundation Server)
  5. Bearbeiten und Formatieren
    1. Formatieren Ihres Inhalts
    2. Erstellen und Verwalten von Querverweisen
    3. Erstellen und Verwalten von Verknüpfungen
    4. Snippets als Einzelquellenelemente
    5. Arbeiten mit Bildern und Multimedia
    6. Erstellen und Verwenden von Variablen für einfache Updates
    7. Arbeiten mit Variablensätzen
    8. Verwenden des Tools „Suchen und Ersetzen“
    9. Automatisches Speichern Ihrer Inhalte
    10. Bearbeitung nebeneinander in der geteilten Ansicht
    11. Verwenden der Rechtschreibprüfungsfunktion
    12. Erstellen und Bearbeiten von Lesezeichen
    13. Einfügen und Aktualisieren von Feldern
    14. Wechseln zwischen mehreren Ansichten
    15. Automatische Nummerierung in CSS
  6. Importieren und Verknüpfen
    1. Importieren von Markdown-Dateien in ein Projekt
    2. Importieren von Word-Dokumenten in ein Projekt
    3. Importieren von FrameMaker-Dokumenten in ein Projekt
  7. Inhaltsverzeichnisse, Indizes und Glossare
    1. Erstellen und Verwalten von Inhaltsverzeichnissen
    2. Erstellen und Verwalten von Indizes
    3. Erstellen und Verwalten eines Glossars
    4. Abfolgen erstellen und verwalten
    5. Arbeiten mit „Siehe auch“ und verwandten Themen
  8. Bedingter Inhalt
    1. Was ist bedingter Inhalt?
    2. Bedingungs-Tags erstellen und anwenden
    3. Konfigurieren von Ausgabevorgaben für bedingten Inhalt
    4. Bedingten Inhalt optimieren und verwalten
  9. Microcontent
    1. Microcontent
  10. Überprüfung und Zusammenarbeit
    1. Überprüfung und Zusammenarbeit
  11. Übersetzung
    1. Übersetzen von Inhalten in mehrere Sprachen
    2. Konfigurieren eines Übersetzungsframeworks für einen Dienstleister
  12. Skins und Masterseiten
    1. Arbeiten mit Skins
    2. Arbeiten mit Masterseiten
    3. Arbeiten mit Beschriftungen
    4. Anpassen von PDFs
    5. Einführung in den Frame-losen Skin-Editor
  13. Generieren der Ausgabe
    1. Generieren der Ausgabe
    2. Generieren einer Frame-los-Ausgabe
    3. Generieren der Wissensdatenbankausgabe
    4. Generieren von PDF-Ausgabe
    5. Generieren einer interaktiven HTML5-Ausgabe
    6. Generieren einer Worddokument-Ausgabe
    7. Generieren einer „Nur Inhalt“-Ausgabe
    8. Generieren einer E-Book-Ausgabe
    9. Generieren einer Microsoft HTML Help-Ausgabe in RoboHelp
    10. Generieren einer App-Ausgabe
  14. Ausgabe veröffentlichen
    1. Veröffentlichen auf einem RoboHelp-Server
    2. Veröffentlichen auf einem FTP-Server, einem sicheren FTP-Server oder einem Dateisystem
    3. Veröffentlichen in SharePoint Online
    4. Veröffentlichen im Zendesk-Hilfe-Center
    5. Veröffentlichen in der Salesforce-Wissensdatenbank
    6. Veröffentlichen in der ServiceNow-Wissensdatenbank
    7. Veröffentlichen in der Zoho-Wissensdatenbank
    8. Veröffentlichen in Adobe Experience Manager
  15. Anhang
    1. Adobe RoboHelp Scripting-Referenz
    2. RoboHelp-Tastaturbefehle

Erfahren Sie, wie Sie FrameMaker-Dokumente in RoboHelp importieren und verknüpfen.

Hinweis:

Für diese Funktion ist FrameMaker 2019 Update 2 oder höher erforderlich.

Sie können ein FrameMaker-Dokument schnell als ein oder mehrere Themen in RoboHelp importieren. Während des Imports können Sie auch mehrere Einstellungen konfigurieren, die RoboHelp zum Importieren und Anpassen der Themen entsprechend Ihren Anforderungen bereitstellt. Sie können FrameMaker-Dokumente auch in Ihr RoboHelp-Projekt einbinden. 

FrameMaker-Dokument importieren

Sie können FrameMaker-Bücher (.book) und Dokumente (.fm, .mif) in Ihr RoboHelp-Projekt importieren. Beim Importieren eines FrameMaker-Dokuments im Inhaltsbereich platziert RoboHelp die Themen am ausgewählten Ort (auf der Stammebene oder in einem Ordner). Alle Assets, auf die im importierten Dokument verwiesen wird, werden jedoch in dem entsprechenden Unterordner im Ordner Assetsabgelegt. Zum Beispiel werden Stylesheets im Unterordner css und Bilder in den Unterordner Bilder platziert.

Importieren eines FrameMaker-Dokuments:

  1. Führen Sie im Inhaltsbereich eine der folgenden Aktionen aus:

    • Führen Sie einen der folgenden Schritte aus, um ein FrameMaker-Dokument in einen Ordner zu importieren:
      • Wählen Sie den Ordner und wählen Sie Datei > Importieren > Framemaker-Dokument.
      • Klicken Sie mit der rechten Maustaste auf den Ordner bzw. klicken Sie darauf und wählen Sie Importieren > FrameMaker-Dokument.
    • Führen Sie einen der folgenden Schritte aus, um ein FrameMaker-Dokument auf Stammebene zu importieren:
      • Ohne einen Ordner auszuwählen, wählen Sie Datei > Importieren > FrameMaker-Dokument.
      • Klicken Sie mit der rechten Maustaste außerhalb der Ordner und wählen Sie Importieren > FrameMaker-Dokument.

    Das Dialogfeld  FrameMaker-Importeinstellungen wird geöffnet.

  2. Wählen Sie im Dialogfeld FrameMaker-Importeinstellungen das FrameMaker-Dokument aus, das Sie importieren möchten, und bearbeiten Sie die Einstellungen. Informationen zu den Optionen im Dialogfeld finden Sie unter FrameMaker-Importeinstellungen.

  3. Klicken Sie auf Importieren.

    Eine HTML-Version des ausgewählten FrameMaker-Dokuments wird mit den angegebenen Einstellungen generiert. Das Thema wird in der alphabetischen Reihenfolge der Themen an der ausgewählten Stelle im Bereich Inhalt angezeigt.

FrameMaker-Importeinstellungen

Wenn Sie Datei > Importieren > FrameMaker-Dokument auswählen, wird das Dialogfeld FrameMaker-Importeinstellungen geöffnet. Konfigurieren Sie die Einstellungen auf den folgenden Registerkarten in diesem Dialogfeld:

Hinweis:

Die Registerkarten ZeichenAbsatzTabelle und Querverweis sind nur aktiviert, wenn diese Formate im ausgewählten Word-Dokument angewendet werden.

Allgemein

Die Registerkarte Allgemein ist standardmäßig im Dialogfeld Word-Importeinstellungen ausgewählt. Auf dieser Registerkarte können Sie folgende Einstellungen vornehmen:

  • FrameMaker-Dokument Klicken Sie auf , um das FrameMaker-Dokument (.fm, .mif oder .book) auszuwählen, das Sie importieren möchten.

    Hinweis: Wenn Sie ein FrameMaker-Dokument auswählen, wird eine Instanz von FrameMaker gestartet, sofern sie noch nicht läuft.

    RoboHelp liest das ausgewählte Dokument und füllt die entsprechenden Registerkarten im Dialogfeld FrameMaker-Importeinstellungen aus.
  • CSS-Datei für Stilzuordnung Klicken Sie auf , um ein externes Stylesheet (.css-Datei) auszuwählen, das sich von Ihrem Projekt-Stylesheet unterscheidet, um FrameMaker-Styles mit RoboHelp-Styles zuzuordnen. Standardmäßig wählt RoboHelp das Standard-Stylesheet des Projekts aus.
  • Neues Thema aus Stil starten Verwenden Sie die folgenden Einstellungen, um mehrere Themen aus dem Inhalt zu erstellen, der aus dem Word-Dokument importiert wurde:
    • FrameMaker-Stil Wählen Sie im FrameMaker-Dokument einen Absatzstil aus, den RoboHelp zum Erstellen von Themen verwenden kann.Um beispielsweise für jede Überschrift auf der ersten Ebene ein Thema zu erstellen, wählen Sie Überschrift1

      Hinweis: In diesem Feld werden alle Absatzstile des im Feld FrameMaker-Dokument ausgewählten Dokuments angezeigt. Wenn Sie im Feld FrameMaker-Dokument kein Dokument ausgewählt haben , bleibt dieses Feld leer. 
    • Themen-Namensmuster Geben Sie das Benennungsmuster für neue Themen an. Sie können unter folgenden Optionen wählen:
      • <$filename_no_ext>-<n> Erstellt die Dateinamen ohne Erweiterung und fügt eine fortlaufende Nummer hinzu. Wenn beispielsweise ABC.fm das importierte FrameMaker-Dokument ist, werden die Dateinamen neuer Themen zu ABC1, ABC2.
      • <$filename_no_ext>-<$paratext> Erstellt die Dateinamen ohne Erweiterung und fügt den Anfangstext des ersten Absatzes hinzu.
      • <$paratext> Erstellt Dateinamen mit dem ursprünglichen Text des Elements, auf dem der ausgewählte Stil angewendet wird. Diese Option ist standardmäßig festgelegt.
    • Verwenden Sie nur ASCII-Zeichen in den generierten Dateinamen. Wählen Sie dieses Feld aus, um Nicht-ASCII-Zeichen in neuen Themennamen in ASCII-Zeichen zu konvertieren. Die Umwandlung folgt dem Punycode-Standard.
  • Einstellungen speichern Klicken Sie auf die Einstellungen des Dialogfelds FrameMaker-Importeinstellungen als Vorgaben (.fsf)-Datei. Wenn Sie die Einstellungen ändern und als neue Voreinstellungsdatei speichern, können Sie die Datei beim nächsten Öffnen des Dialogfelds aus dem Feld Einstellungen laden auswählen.
  • Einstellungen laden Klicken Sie auf , um eine andere Vorgabe(.fsf)-Datei zu wählen, in der Sie die Einstellungen des Dialogfelds FrameMaker-Importeinstellungen speichern möchten. Dieses Feld zeigt die voreingestellte Standarddatei default.fsf. Sie können auch auf klicken, um eine vor kurzem gespeicherte Datei mit den Vorgaben auszuwählen.

Zeichen

Wählen Sie die Registerkarte Zeichen, um Zeichenformatvorlagen für den importierten Inhalt anzugeben. Auf dieser Registerkarte können Sie die folgenden Spalten anzeigen:

  • FrameMaker-Stil Der Stil in dem Framemaker-Dokument, der im Feld Framemaker-Dokument auf der Registerkarte Allgemein ausgewählt ist.
  • In RoboHelp Stile, die aus der CSS-Datei gefüllt werden, die im Feld CSS-Datei für Stilzuordnung auf der Registerkarte Allgemein angegeben ist. 

Klicken Sie für jeden FrameMaker-Stil auf in In RoboHelp , um einen anderen Stil auszuwählen und ihn dem entsprechenden FrameMaker-Stil zuzuordnen. Wenn kein Stil mit dem entsprechenden FrameMaker-Stil übereinstimmt, bietet RoboHelp zwei Stiloptionen:

  • Importstil (Standard) importiert Stile aus dem ausgewählten FrameMaker-Dokument in RoboHelp. 
  • Inhalt verwerfen Verwirft alle Inhalte, auf die der ausgewählte Stil angewendet wird.  

Sie können eine Vorschau des ausgewählten FrameMaker-Stils und des zugeordneten Stils in den Abschnitten FrameMaker-Vorschau und RoboHelp-Vorschau anzeigen.

Absatz

Wählen Sie die Registerkarte Absatz, um Absatzformatvorlagen für den importierten Inhalt anzugeben. Auf dieser Registerkarte können Sie die folgenden Spalten anzeigen:

  • FrameMaker-Stil Der Stil in dem Framemaker-Dokument, der im Feld Framemaker-Dokument auf der Registerkarte Allgemein ausgewählt ist.
  • In RoboHelp Stile, die aus der CSS-Datei gefüllt werden, die im Feld CSS-Datei für Stilzuordnung auf der Registerkarte Allgemein angegeben ist. 

Klicken Sie für jeden FrameMaker-Stil auf in In RoboHelp , um einen anderen Stil auszuwählen und ihn dem entsprechenden FrameMaker-Stil zuzuordnen. Wenn kein Stil mit dem entsprechenden FrameMaker-Stil übereinstimmt, bietet RoboHelp zwei Stiloptionen:

  • Importstil (Standard) importiert Stile aus dem ausgewählten FrameMaker-Dokument in RoboHelp. 
  • Inhalt verwerfen Verwirft alle Inhalte, auf die der ausgewählte Stil angewendet wird. 

Sie können eine Vorschau des ausgewählten FrameMaker-Stils und des zugeordneten Stils in den Abschnitten FrameMaker-Vorschau und RoboHelp-Vorschau anzeigen.

Tabelle

Wählen Sie die Registerkarte Tabelle, um die Tabellenformatvorlagen für den importierten Inhalt anzugeben. Auf dieser Registerkarte können Sie die folgenden Spalten anzeigen:

  • FrameMaker-Stil Der Stil in dem Framemaker-Dokument, der im Feld Framemaker-Dokument auf der Registerkarte Allgemein ausgewählt ist.
  • In RoboHelp Stile, die aus der CSS-Datei gefüllt werden, die im Feld CSS-Datei für Stilzuordnung auf der Registerkarte Allgemein angegeben ist. 

Klicken Sie für jeden FrameMaker-Stil auf in In RoboHelp , um einen anderen Stil auszuwählen und ihn dem entsprechenden FrameMaker-Stil zuzuordnen. Wenn kein Stil mit dem entsprechenden FrameMaker-Stil übereinstimmt, bietet RoboHelp zwei Stiloptionen:

  • Importstil (Standard) importiert Stile aus dem ausgewählten FrameMaker-Dokument in RoboHelp. 
  • Inhalt verwerfen Verwirft alle Inhalte, auf die der ausgewählte Stil angewendet wird.

Sie können eine Vorschau des ausgewählten FrameMaker-Stils und des zugeordneten Stils in den Abschnitten FrameMaker-Vorschau und RoboHelp-Vorschau anzeigen.

Querverweis

Wählen Sie die Registerkarte Querverweis, um Querverweisstile für den importierten Inhalt festzulegen. Auf dieser Registerkarte können Sie die folgenden Spalten anzeigen:

  • FrameMaker-Stil Zeigt die Namen der Querverweisstile an, die in dem Framemaker-Dokument, das im Feld Framemaker-Dokument auf der Registerkarte Allgemein ausgewählt ist.
  • In RoboHelp Zeigt die aktuellen Definitionen der Stile an. Diese Spalte wird standardmäßig aus den Definitionen des importierten FrameMaker-Dokuments aufgefüllt. Sie können die Definitionen ändern, indem Sie Kombinationen von Konstanten und Variablen verwenden. Um eine Variable anzugeben, geben Sie < ein und wählen Sie eine Variable aus der Dropdown-Liste aus oder geben Sie den Variablennamen ein. 

Sie können eine Vorschau des ausgewählten FrameMaker-Stils und seine Definition in den Abschnitten FrameMaker-Vorschau und RoboHelp  -Vorschau anzeigen.

Bilder

Wählen Sie die Registerkarte Bilder, um Zeichenformatvorlagen für den importierten Inhalt anzugeben. Verwenden Sie auf dieser Registerkarte die folgenden Felder:

  • Bilder nicht neu erstellen Wählen Sie dieses Feld, wenn Sie FrameMaker-Dokumente neu importieren und die Bilder nicht im importierten Inhalt aktualisieren müssen.
  • Bilder für Referenzseiten importieren Wählen Sie dieses Feld, um Bilder aus der Referenzseite in das importierte Framemaker-Dokument zu importieren.
  • 3D-Bilder beibehalten Behält 3D-Bilder im ausgewählten FrameMaker-Dokument bei, d. h. 3D-Bilder werden nicht auf 2D-Bilder reduziert. Wenn die Ausgabe veröffentlicht wird, sind 3D-Informationen in Bildern im Browser sichtbar. Dieses Feld ist standardmäßig ausgewählt.
  • Bevorzugte Abmessungen
    • Breite und Höhe Legen Sie die bevorzugte Breite und Höhe der importierten Bilder fest.Standardmäßig sind die Breiten- und Höhen-Felder so miteinander verknüpft, dass dieselben Werte akzeptiert werden. Mit können Sie verschiedene Breiten- und Höhenwerte einstellen.
    • Skalieren Legen Sie einen Skalierungsfaktor zum Skalieren der importierten Bilder fest.

      Hinweis: Durch die Angabe einer Skalierung können sich die Breiten- oder Höhenwerte ändern.

    • Seitenverhältnis beibehalten Wählen Sie dieses Feld aus, um das Seitenverhältnis gemäß den Bildern des importierten FrameMaker-Dokuments beizubehalten. 

      Hinweis: Durch die Angabe einer Skalierung können sich die Breiten- oder Höhenwerte ändern.
  • Maximale Abmessungen
    Da die Bevorzugten Abmessungen von den Einstellungen Skalieren und Seitenverhältnis beibehalten überschrieben werden können, legen Sie in diesem Abschnitt eine Höchstgrenze für die Bildgröße im importierten Dokument fest.
    • Breite und Höhe Legen Sie die Breite und Höhe der importierten Bilder fest. Standardmäßig sind die Breiten- und Höhen-Felder so miteinander verknüpft, dass dieselben Werte akzeptiert werden. Mit können Sie verschiedene Breiten- und Höhenwerte einstellen.
  • Rand Geben Sie einen Wert für alle vier Ränder um Bilder an. Wechseln Sie , wenn Sie für jeden oberen, unteren, linken und rechten Rand einen anderen Wert festlegen möchten.
  • Rahmen Steuern Sie die Eigenschaften der Standard-HTML-Rahmen, die mit diesem Abschnitt auf die importierten Bilder angewendet werden.
    • Rahmenstil Wählen Sie einen Rahmenstil aus der Dropdown-Liste aus. Der Standardwert ist Keine.
    • Farbe Klicken Sie auf , um eine Rahmenfarbe auszuwählen. Der Standard ist schwarz. Oder klicken Sie auf , um eine Farbe auf dem Bildschirm auszuwählen.   
    • Breite Legen Sie die Rahmenbreite fest.
    • Wählen Sie aus den folgenden Optionen die Rahmen aus, die Sie anwenden möchten:
      • Alle (Standard)
      •  Oben
      •  Rechts
      •  Unten
      •  Links
  • Erweitert
    • Standardformat Wählen Sie das Standardbildformat aus, in das Sie alle importierten Bilder konvertieren möchten. 
    • Farbbittiefe Die Werte in diesem Feld ändern sich je nach ausgewähltem Standardbildformat. Sie können eine Tiefe aus den unterstützten Optionen auswählen.
    • JPG-Qualität Geben Sie einen Wert an, um die Qualität aller importierten JPG-Bilder festzulegen. Dieses Feld steuert die JPG-Komprimierung in Bezug auf Größe und Qualität. Der Standardwert 100 bedeutet beispielsweise die beste Qualität und minimale Komprimierung. 
    • Graustufen Wählen Sie diese Option aus, um alle importierten Bilder in Graustufen zu konvertieren.

Erweitert

Wählen Sie die Registerkarte Erweitert, um Zeichenformatvorlagen für den importierten Inhalt anzugeben. Verwenden Sie auf dieser Registerkarte die folgenden Felder:

  • Kontextsensitive Hilfemarkierung Wenn Sie kontextabhängige Hilfemarkierungen aus dem FrameMaker-Dokument importieren möchten, markieren Sie dieses Feld und geben Sie den Typ des kontextabhängigen „Help Makers“ an, der importiert werden soll.  
  • Mit Markierungen in Themen aufteilen Wenn Sie Themen erstellen möchten, basierend auf einem bestimmten Markertyp aus einem FrameMaker-Dokument, wählen Sie dieses Feld aus und geben Sie den Markertyp an. 
  • Alle Themen in einem Ordner aufbewahren Wenn ein FrameMaker-Buch importiert wird, wählen Sie dieses Feld aus, um alle Themen in dem Buch im gleichen Ordner zu behalten.
  • Alle Themen zu Inhaltsverzeichnis hinzufügen Wählen Sie dieses Feld aus, um alle aus dem ausgewählten FrameMaker-Dokument erstellten Themen zu der Inhaltsverzeichnisdatei hinzuzufügen, die erstellt wird. 
  • Inline-HTML-Stile bereinigen Wenn das importierte FrameMaker-Dokument Inline-Stile enthält, wählen Sie dieses Feld aus, um diese Stile zu verwerfen.
  • Glossardateien importieren Importiert alle Glossardaten aus dem ausgewählten FrameMaker-Dokument in eine neue Glossardatei. Diese Option ist standardmäßig aktiviert. 
  • Inhaltsverzeichnisdateien importieren Importiert alle Inhaltsverzeichnisdateien, auf die aus dem FrameMaker-Buch verwiesen wird, die in eine neue Inhaltsverzeichnisdatei importiert werden. Diese Option ist standardmäßig aktiviert.

Verknüpfen eines FrameMaker-Dokuments:

Sie können ein FrameMaker-Dokument aus Ihrem Robohelp-Projektordner verknüpfen.

Neben den Grundfunktionen für Themen und Ordner können Sie HTML-Themen aus dem verknüpften Framemaker-Dokument erstellen.

Adobe-Logo

Bei Ihrem Konto anmelden