- InDesign 使用者指南
- 了解 InDesign
- InDesign 簡介
- 工作區
- 生成式 AI (在中國大陸無法使用)
- InDesign 簡介
- 建立文件及編排版面
- 加入內容
- 文字
- 印刷樣式
- 設定文字格式
- 審核文字
- 拼字檢查和語言字典
- 新增參照
- 樣式
- 表格
- 互動性
- 圖形
- 顏色和透明度
- 尋找和取代
- 共用
- 轉存、讀入及發佈
- 延伸 InDesign
- 疑難排解
您是否在開啟或儲存 InDesign 檔案時遇到問題? 請繼續閱讀以瞭解可能的原因與解決方法。
系統層級問題可能造成錯誤及其他非預期的行為。在假定文件已受損前,請按照以下步驟進行:
-
請確保您的系統符合最低系統需求以執行最新版本的 InDesign。
-
InDesign 系統訊息會列出引發問題的情境,可協助您判斷當機的原因。以下提供幾種可能的情境與其解決方法:
遇到其他問題? 需要更多協助嗎?
當您的系統沒有足夠的記憶體 (RAM) 可讀取檔案時,InDesign 就無法開啟檔案。記憶體不足的原因之一,可能是您電腦上開啟了過多的應用程式。
解決方法
- 請執行磁碟清理以減少磁碟機中不必要檔案的數量,並確認 Windows 暫存檔案夾是空的。
- 結束部分應用程式以釋出系統的記憶體。
- 如果可能的話,請擴充系統的 RAM。
如果您遇到下列任一項檔案存取相關的問題,InDesign 將無法開啟檔案並會顯示錯誤訊息:
問題 |
解析度 |
未取得開啟此檔案的授權,或缺少所需的存取權限。 |
請向擁有者取得檔案的存取權限,然後嘗試再次登入。 提示:在處理共用檔案前,如果可行,請先建立本機副本。 |
該檔案早已開啟或由其他使用者鎖定 (使用中)。 |
從其他應用程式或使用者設定檔關閉檔案。 |
該檔案受密碼保護,或者檔案的登入資料或密碼無效。 |
確認輸入的登入憑證正確無誤。 |
該檔案置於某個網路中,但系統找不到該網路的位置。 |
檢查網路連線,並嘗試再次存取檔案。 |
若已在另一個版本的 InDesign 中開啟檔案,InDesign 便無法將其開啟或儲存。
解決方法
- 將開啟於另個 InDesign 版本中的檔案關閉。
- 如果您無法關閉該檔案,請強制關閉所有版本的 InDesign 或重新啟動電腦。
- 如果您在檔案儲存時遇到此問題,請嘗試變更檔案名稱和位置。
當讀取或寫入程序中斷,或者系統無法存取或是找不到檔案,InDesign 就會無法開啟或儲存檔案。
以下是幾種可能導致檔案讀取或寫入程序中斷的情況:
檔案位置 |
原因 |
解析度 |
---|---|---|
卸除式裝置 (USB 隨身碟、外接式硬碟、隨身碟等) |
裝置未安全地從電腦移除或退出 |
請確認在每次讀取或寫入作業後,都有安全地移除該裝置。 |
網路位置 |
網路連線中斷 |
請確定您的網路連線可用。 |
共用位置 |
共用檔案已無法使用 |
請確認共用位置可供存取。 |
發現檔案損壞、毀損或系統嘗試自動復原檔時,InDesign 會顯示錯誤訊息。請根據情況選取索引標籤,並按照疑難排解步驟,嘗試復原文件內容。
快速檢查外部因素
- 如果文件是從 Adobe PageMaker、QuarkXPress 或舊版 InDesign 轉換而來,請嘗試重新轉換該文件。如果問題再次發生,請先在其來源應用程式中疑難排解原始文件的損壞狀況,再重新轉換。轉換之後,受損的 PageMaker 或 QuarkXPress 文件可能依舊損毀。
- 如果您是透過電子郵件、FTP 或式卸除式媒體 (例如 CD) 接收該文件,請以不同方式取得副本。或者,請對方重新傳送文件。受損的媒體或電子郵件傳輸錯誤可能會損壞文件。如果文件是透過電子郵件傳送,則請寄件人先行壓縮文件 (例如使用 WinZip 或 Smith Micro 的 StuffIt),以保護資料。
- 請考慮從 InDesign 中解除安裝協力廠商的外掛程式。外掛程式有時可能造成檔案損毀。請參閱疑難排解 InDesign 協力廠商的外掛程式。
- 使用其他電腦,改以其他系統環境來開啟文件。您可以移除引發問題的變數。
- InDesign 會在偏好設定檔案 (InDesign SavedData 和 InDesign Defaults 檔案) 中儲存有關外掛程式、功能和應用程式的資訊。受損的 InDesign 偏好設定檔案可能會導致 InDesign 文件發生非預期的行為。透過還原或重新建立文件,您可以輕鬆判斷問題是否與偏好設定檔案有關。如需詳細資訊,請參閱還原所有偏好設定。
- 增加啟動磁碟的可用空間容量。InDesign 使用暫存檔來儲存及擷取資料,並會將這些暫存檔寫入啟動磁碟。原則上,啟動磁碟的可用空間應等於文件大小 (包括連結的影像) 的三到五倍,或是磁碟容量的 10%,取較大者。您可以刪除不需要的檔案,或將檔案儲存在個別分割區或磁碟上,釋出啟動磁碟的空間。若要查看啟動磁碟的可用空間容量:
- 選取桌面上的啟動磁碟圖示。
- 選擇「檔案 > 取得資訊 > 一般資訊」。
- 注意磁碟機的「容量」和「可用空間」。
解決方法:開啟文件複本,而非原始文件。
以複本開啟文件時,InDesign 會從原始檔案中讀取並開啟未命名的複本。如果可以開啟文件複本,請選擇「檔案 > 另存新檔」,以有別於原始文件的名稱儲存複本,並使用複本而非原始文件。
請按照以下步驟將文件開啟為副本:
問題
從 InDesign 19.2 版建立或儲存的少數 InDesign 文件無法在 InDesign 19.1 版中開啟
解決方案 1:在 InDesign 19.2 及更新版本中開啟文件,並將其轉存為 IDML,以便用 InDesign 19.1 及更舊版本處理。
解決方案 2:在 ID 19.3 中開啟並儲存文件,以便在所有版本中順暢地處理。
請先建立受損文件的備份副本,再開始進行疑難排解。下列部分作業會要求您變更或刪除文件的資訊。
文件備份副本可讓您快速復原資訊。如果文件位在網路磁碟區或卸除式媒體 (例如 CD 或隨身碟) 上,請將備份移至本機磁碟機。
請依序完成下列作業。
使用 macOS 上的 Cmd-Opt-/ 和 Windows 上的 Ctrl-Alt-/ 快速鍵,強制重新撰寫所有內文。
將頁面元素複製到新文件會造成結構 (內部) 的損害。如果您在將頁面元素複製到新文件後再次發生問題,請逐一刪除元素,看看問題是否為其中一個元素。
按照以下步驟將頁面元素複製到新文件:
您在 InDesign 中建立的樣式,或是您使用在其他應用程式中建立的檔案所轉存而成的樣式,都可能已經損壞。此外,可能還有一些空白頁面和不必要的元素。如果要了解這是否為問題所在,請刪除該樣式和頁面,然後重新儲存文件。
按照以下步驟刪除字元樣式:
按照以下步驟刪除段落樣式:
按照以下步驟刪除頁面:
如果在您刪除某些頁面後問題又再次發生,請刪除剩餘頁面的一半,然後以新名稱儲存該文件。嘗試重現該問題。
- 如果問題再次發生,表示剩餘頁面之一可能包含損壞的元素。繼續刪除頁面,直到找到造成問題的頁面為止。
- 如果問題沒有再次發生,表示刪除的頁面之一可能包含損壞的元素。請取代刪除的頁面,直到找到造成問題的頁面為止。
在您確定造成問題的頁面後,請移除及取代其中的元素,包括匯入的圖形、InDesign 繪製的物件,以及頁面上的文字框。
如果要判斷該問題是否與損壞的字體相關,請以標準字體 (例如 Arial 或 Times New Roman) 取代文件中使用的所有字體。如果變更字體後問題重複發生,則該問題與字體無關。如果問題未再次發生,表示原始字體或字體可能已損壞或過期。請嘗試重新安裝原始字體,或從字體製造商取得更新版本。
如果所有其他方法都失敗,請重新建立文件。請經常備份複本,並定期測試文件以確保匯入的元素不會造成問題。
除了上述各種情形外,InDesign 在以下狀況中也無法開啟與復原檔案:
- 發生意外錯誤或不明錯誤
- 檔案損壞且無法修復
- InDesign 不支援所要開啟的檔案副檔名
解決方法
我們建議您傳送檔案,並協助我們調查問題。
歡迎向我們尋求協助!
如果問題仍然無法解決,請透過以下電子郵件地址,與我們分享受影響的檔案:idfile@adobe.com。我們會深入調查問題,如果檔案能夠復原,我們會隨即通知您。
將檔案與我們分享不僅能讓 Adobe 團隊為您尋找問題的解決方法,也能協助我們識別及解決其他相似問題,進而改善整體的使用者體驗。
我們保證會嚴格維護您檔案的機密性,僅將檔案供調查使用。確認您分享的檔案未包含任何敏感的個人資訊。
我們會盡全力協助您,但是檔案恢復與否取決於許多因素,因此無法保證一定能解決問題。
相關資源
聯繫我們
我們很樂意聆聽您的意見。與 Adobe InDesign 社群分享您的想法。