建立動態 PDF 文件是一個建立互動式幻燈片的好方法。您可以建立具有按鈕、影片與聲音剪輯、超連結、書籤及頁面切換效果的互動式文件。您也可以在 InDesign 設定能夠轉換為 Acrobat 格式的文件。

建立 PDF 互動式文件

您可以轉存包含下列互動功能的 Adobe PDF 文件。

書籤

您在 InDesign 文件中建立的書籤會出現在 Adobe Acrobat 或 Adobe Reader 視窗左側的「書籤」索引標籤處。每一個書籤都會跳至轉存之 PDF 檔案中的頁面、文字或圖形。請參閱書籤

影片和聲音剪輯

您可以在文件中新增影片與聲音剪輯,或是連結至網際網路上的資料流視訊檔案。這些影片和聲音剪輯可以在轉存的 PDF 檔案中播放。請參閱影片和聲音

超連結

在轉存的 PDF 文件中,按一下超連結會跳至相同文件中的另一個位置,或是跳至另一份文件或網站。請參閱超連結

交互參照

交互參照指的是使用者在轉存的 PDF 檔案中從文件的某個部分參照至另一個部分。交互參照在使用手冊和參考手冊中特別實用。將具有交互參照的文件轉存為 PDF 時,交互參照會當做互動式超連結。請參閱交互參照

頁面切換效果

當您在全螢幕模式下於轉存的 PDF 中翻頁時,頁面切換效果會套用裝飾效果,例如溶解或划出。請參閱頁面切換效果

  1. 選擇「檔案 > 轉存」

  2. 指定檔案名稱與位置。

  3. 如果從下次轉存起,要讓轉存的 PDF 名稱與文件名稱相同,請選取「使用 InDesign 文件名稱做為輸出的檔案名稱」

  4. 「另存新檔類型」(Windows) 或「格式」(Mac OS) 中,選擇「Adobe PDF (互動式)」,然後按一下「儲存」

  5. 「轉存為互動式 PDF」對話框中指定選項,然後按一下「確定」

「轉存為互動式 PDF」選項

「轉存為互動式 PDF」對話框中會出現下列選項。

「一般」標籤

頁面

指出是否要包含文件中的所有頁面,或是某個頁面範圍。如果您選取「範圍」,請指定頁面範圍,例如指定 1-7, 9 即可列印第 1 到 7 頁和第 9 頁。請參閱指定列印頁面

轉存為

指定您要將文件轉存為頁面或試算表。

建立獨立的 PDF 檔案

選取此選項即可針對每個頁面或試算表建立獨立的 PDF。

檢視

開啟 PDF 時的初始檢視設定。

版面

開啟 PDF 時的初始版面。

簡報

選取「以全螢幕模式開啟」以在 Adobe Acrobat 或 Adobe Reader 中顯示 PDF,而不顯示選單或面板。若要讓頁面自動往前進,請選取「翻轉頁面頻率」並指定翻頁的間隔秒數。

轉存後檢視

在預設的 PDF 檢視程式中開啟新建立的 PDF 檔案。

頁面切換效果

指定一種頁面切換效果,即可在轉存期間套用至所有頁面。如果您使用「頁面切換效果」面板來指定切換效果,請選擇「從文件」選項以使用這些設定。

表單和媒體

選取「全部包含」,可讓影片、聲音及按鈕在轉存的 PDF 檔案中互動。選取「僅限外觀」,將正常狀態的按鈕與影片海報包含成為靜態元素。

內嵌頁面縮圖

內嵌 PDF 每個頁面的縮圖預視,會增加檔案大小。若 Acrobat 5.0 和更新版本的使用者將檢視和列印 PDF,請取消選取此設定;這些版本在您每次按一下 PDF 的「頁面」面板時,都會動態產生縮圖。

建立 Acrobat 圖層

將每個 InDesign 圖層儲存為 PDF 中的 Acrobat 圖層。這些圖層都可以完整導覽,讓 Acrobat 6.0 和更新版本的使用者從單一 PDF 檔案中產生不同的檔案版本。

建立標籤化 PDF

轉存期間,根據 InDesign 支援的 Acrobat 標籤子集,自動標記內文元素。這包含段落、基本文字格式、清單與表格的辨識(轉存為 PDF 之前,您也可以在文件中插入和調整標籤。請參閱新增結構至 PDF)。

使用跳位順序結構

轉存期間,使用透過「物件 > 互動 > 設定跳位順序」指定的跳位順序。此選項僅適用於標籤化 PDF。

「壓縮」標籤

壓縮

選擇「JPEG (失真)」會移除影像資料且可能會降低影像品質。不過,會以流失最少資訊的方式來降低檔案大小。選擇「JPEG 2000 (不失真)」可以在不造成失真的壓縮動作下轉存檔案。選擇「自動」可讓 InDesign 為彩色和灰階影像決定最佳品質。

JPEG 品質

指定轉存影像中的精細度。品質越高,檔案越大如果您在「壓縮」中選擇「JPEG 2000 (不失真)」,此選項就會變暗。

解析度

在轉存的 PDF 中指定點陣圖影像的解析度。在轉存的 PDF 中讓檢視者放大以像素為主的內容時,選擇高解析度特別重要。選擇高解析度會大幅增加檔案大小。

「進階」標籤

顯示標題

選擇當 Acrobat 開啟 PDF 時,標題列中要顯示的內容。可用的選項包括文件標題和檔案名稱。

語言

選擇 PDF 的文件語言。這會決定文件轉存成 PDF 後使用的預設語言。如果清單中沒有需要的語言,您也可以輸入標準的語言 ISO 代碼。

「安全性」標籤

要求密碼來開啟文件

選擇此選項要求使用者鍵入您指定的密碼才能開啟文件。

文件開啟密碼

指定使用者開啟 PDF 檔案時必須鍵入的密碼。

使用密碼限制文件的列印、編輯和其他工作

限制存取 PDF 檔案的保全設定。如果在 Adobe Acrobat 中開啟此檔案,則使用者可檢視檔案;但若要變更檔案的「保全」與「權限」設定,則必須輸入指定的「權限」密碼。如果在 Illustrator、Photoshop 或 InDesign 中開啟此檔案,則使用者必須輸入「權限」密碼,因為無法以只檢視模式開啟此檔案。

權限密碼

指定變更權限設定時所需的密碼。只有在上一個選項已選定之後,才可用此選項。

允許列印

指定使用者列印 PDF 文件時可允許使用的列印等級。

選擇這個選擇,可以防止使用者列印文件。

低解析度 (150 dpi)

允許使用者以不超過 150-dpi 的解析度列印。使用者列印時的速度也許會比較慢,因為每一頁都是以點陣影像的方式列印。

高解析度

讓使用者可以用任何解析度列印,並將高品質向量直接輸出到 PostScript 與其他支援進階高品質列印功能的印表機。

允許變更

定義允許對此 PDF 文件進行的編輯動作。

防止使用者變更在「允許變更」選單的清單中所列出文件,如填寫表格欄位和增加註解。

「插入、刪除和旋轉頁面」

允許使用者插入、刪除及旋轉頁面,並建立書籤和縮圖。

填寫表格欄位和簽署

允許使用者填寫表格和新增數位簽名。此選項並不會允許使用者加入注釋或建立表格欄位。

注釋、填寫表格欄位和簽署

允許使用者新增注釋和數位簽名,以及填寫表格。此選項不允許使用者移動頁面物件或建立表格欄位。

「所有,但不包括擷取頁面」

循序使用者編輯文件、建立並填寫表格欄位和增加注釋及數位簽名。

「啟用拷貝文字、影像和其他內容」

可讓使用者選取和拷貝 PDF 內容。

「為視力不佳者啟用螢幕閱讀程式裝置存取文字」

允許視力不佳的使用者使用螢幕閱讀程式閱讀文件,但不允許使用者拷貝或摘取文件內容。

啟用純文字中繼資料

允許使用者由 PDF 檔案中拷貝和擷取內容。選取此選項,可讓儲存或搜尋系統及搜尋引擎存取儲存於文件的中繼資料。 

建立 PDF 表單 (CS5.5 與 CS5)

雖然 InDesign 不提供新增表單欄位的工具,不過 Adobe Acrobat 會提供。您可以在 InDesign 中建立包含欄位預留位置的表單,例如選項按鈕、核取方塊及文字欄位。然後您可以轉存為 PDF,並使用 Acrobat 將這些預留位置轉換為表單欄位。

  1. 在 InDesign,請建立您要用於表單的文件。使用表格和文字方塊建立欄位的預留位置。

    您也可以在 InDesign 加入互動式按鈕。

  2. 轉存檔案為 Adobe PDF。

  3. 啟動表格精靈將預留位置轉換為表格欄位。使用表單工具來新增和編輯表單。如需詳細資訊,請參閱 Adobe Acrobat 說明文件。

    • 在 Acrobat X 中,請選擇「工具 > 表格 > 建立」以啟動表格精靈。

    • 在 Adobe Acrobat 9 中,請選擇「表格 > 啟動表格精靈」。

其他資源

Acrobat 團隊提供了一篇有關在 Adobe Acrobat 中設計自動欄位偵測表格的文章。

Michael Murphy 在 Acrobat 友善表單設計中,提供有關建立表單的教學課程影片。

Bob Bringhurst 於在 InDesign 中建立 PDF 表單中,提供有關設計表單的文章。

預視互動式文件

使用「預視」面板可預視目前選取範圍、目前跨頁或整個文件的互動性和動畫。您可以調整「預視」面板的大小、固定或浮動該面板,或將其移至第二個螢幕。

  1. 選擇「視窗 > 互動 > 預視」。

  2. 若要預視互動性和動畫,請執行下列任一項作業:

    • 按一下「設定預視選取範圍模式」按鈕 即可預視目前選取範圍。

    • 按一下「設定預視跨頁模式」按鈕 即可預視目前跨頁。

    • 按一下「設定預視文件模式」按鈕 即可預視目前文件。

  3. 按一下「播放預視」按鈕 來預視選取範圍、跨頁或文件。必要時,按一下「預視」面板中的互動項目 (例如按鈕) 可測試這些項目。

    如果您要預視文件,可以按一下面板底部的「跳至上一頁」和「跳至下一頁」箭頭來移動至不同的頁面。

註解:

如果您要編輯文件,可以透過按一下「預視」面板中的「播放預視」按鈕來重新整理預視。

在網頁瀏覽器中預視文件

  1. 從「預視」面板選單中選擇「在瀏覽器中測試」。

  2. 按一下文件中的互動項目即可測試這些項目。

編輯預視設定

  1. 從「預視」面板選單中選擇「編輯預視設定」。

    「預視設定」對話框會顯示「轉存 SWF」對話框的目前設定。

  2. 視需要編輯設定。請參閱 SWF 轉存選項

使用呈現方式模式

「簡報模式」會將作用中的 InDesign 文件顯示為簡報。在「簡報模式」中,會隱藏應用程式選單、面板、參考線和框架邊緣。依預設,如果文件大小與目前的螢幕尺寸的比例不同,則背景區域會顯示為深色。

「簡報模式」是 Adobe Connect 功能隨附之相當有用的功能。您可以使用「檔案 > 共用螢幕」指令來啟動網路會議。啟動螢幕共用後,您可以將 InDesign 文件進入「簡報模式」。

  1. 選擇「檢視 > 螢幕模式 > 簡報」。

  2. 使用下列任一個按鍵。

    動作

    作用

    滑鼠點選、向右鍵或 Page Down 鍵

    下一個跨頁

    按住 Shift 鍵並按一下、按一下滑鼠右鍵、向左鍵或 Page Up 鍵

    上一個跨頁

    Esc

    結束簡報模式

    首頁

    第一個跨頁

    終點

    最後一個跨頁

    B

    將背景顏色變更為黑色

    W

    將背景顏色變更為白色

    G

    將背景顏色變更為灰色

註解:

您無法在「簡報模式」中編輯文件。但是,使用雙螢幕,您便可以在相同的文件上開啟兩個視窗,並將其中一個視窗進入「簡報模式」。此方法可讓您在設定為「正常」檢視的視窗中編輯文件,並立即在設為「簡報模式」的視窗中查看結果。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策