變形面板概觀

使用「變形」面板可檢視或指定任何已選取物件的幾何資訊,包括位置、大小、旋轉及傾斜的數值。 「變形」面板選單中的指令會提供額外的選項,以及旋轉或反射物件的快速方法。

註解:

在「控制」面板中也會提供「變形」面板中的按鈕與面板選單指令。

「變形」面板
「變形」面板

A. 參考點定位器 B. 強制等比例圖示 C. 面板選單 

顯示變形面板

  1. 選擇「視窗 > 物件與版面 > 變形」。

檢視關於物件的幾何資訊

選取物件時,「變形」與「控制」面板中會出現其幾何資訊。 如果選取多重物件,此資訊會以一個單位表示所有已選取的物件。

  1. 選取一或多個物件,並且顯示「變形」面板 (「視窗 > 物件與版面 > 變形」)。

    位置資訊是相對於尺標原點和物件的參考點。 角度資訊會相對於作業範圍,其水平線的角度為 0 度。

變更變形設定

「變形」面板包含數個選項,可決定物件變形方式,以及「變形」和「控制」面板中變形的顯示方式。

變更選取物件的參考點

所有變形都源自物件上或附近的固定點,稱為參考點。 當變形工具 (如「縮放」工具) 使用中時,在參考點會顯示圖示

參考點移至中心 (左) 與物件縮放 (右)
參考點移至中心 (左) 與物件縮放 (右)

  1. 執行下列任一項作業:
    • 如果要為選取的物件指定不同參考點,請在「變形」或「控制」面板的參考點定位器 上按一下九個參考點的任何一個點。


      按一下「變形」或「控制」面板的不同參考點時 (左上方與右上方),所選物件的參考點會隨之改變 (左下方與右下方)。

       

    • 如果要將所選物件的參考點移至特定位置,請選取「旋轉」工具 、「縮放」工具 或「傾斜」工具 ,接著將工具置於參考點圖示上方,然後將其拖移至新位置。 或者選取其中一個工具,再按一下物件或頁面上的任何位置。 參考點便會移至該位置。

註解:

已選取變形工具時,在物件之外按一下,不會取消選取物件,而會移動參考點。選擇「編輯 > 全部取消選取」,取消選取物件。

參考點定位器上最後一個選取的參考點會成為所有工具和物件新的預設參考點。 如果將物件的參考點圖示拖移到自訂位置 (不在錨點上),不再選取目前所選的物件時,面板參考點就會恢復到預設位置。 InDesign 會保留新文件的預設參考點位置,因此您並不需要重設。

變更巢狀物件顯示的資訊

「變形」面板會根據跨頁的作業範圍方向旋轉物件,其水平線的旋轉角度為 0 度。 依預設,即使物件以巢狀方式位於變形的容器物件之內 (也就是即使物件屬於某個變形的群組或是貼在已變形的框架內部),其狀況也會如此。 舉例來說,假如您將未旋轉的圖形貼在框架內,讓圖形在內部將框架旋轉 10 度,然後使用「直接選取」工具選取圖形,「變形」面板會顯示圖形旋轉角度為 10 度。

物件所顯示相對於作業範圍的旋轉角度
物件所顯示相對於作業範圍的旋轉角度

如果喜歡,可以取消選取「全面變形」指令,即可看見相對於巢狀物件的容器的同樣資訊。在以上的範例中,如果取消選取「全面變形」,「變形」面板就會顯示圖形的旋轉角度為零 (相對於旋轉容器的角度)。

物件所顯示相對於容器物件的旋轉角度
物件所顯示相對於容器物件的旋轉角度

  1. 開啟「變形」面板或「控制」面板。
  2. 在「變形」或「控制」面板選單中,執行下列任一項動作:
    • 讓「全面變形」保持選取 (預設) 以顯示巢狀物件相對於作業範圍的變形值。

    • 取消選取「全面變形」即可顯示巢狀物件相對於容器物件的旋轉、縮放及傾斜值。

度量所選物件的位置

「顯示內容偏移量」指令會判斷以「直接選取」工具 選取的巢狀物件在「變形」面板中出現的 X 值與 Y 值。以「變形」與「控制」面板之參考點定位器中選取的參考點,會決定所選物件上九個參考點中的哪一個會與文件的零點或容器框架的零點比較。 容器框架的零點恆為其左上角。

所選物件的位置會從三個位置加以度量:

  • 容器框架相對於文件零點的位置。 「顯示內容偏移量」可以開啟或關閉,使用「選取」工具來選取物件框。

  • 巢狀物件相對於文件零點的位置。 關閉「顯示內容偏移量」,然後使用「直接選取」工具選取巢狀物件。

  • 巢狀物件相對於其容器框架零點 (左上角) 的位置。 開啟「顯示內容偏移量」,然後使用「直接選取」工具選取巢狀物件。

父框架所顯示相對於文件零點的位置
父框架所顯示相對於文件零點的位置

巢狀物件所顯示相對於文件零點的位置
巢狀物件所顯示相對於文件零點的位置

巢狀物件所顯示相對於容器框架的位置
巢狀物件所顯示相對於容器框架的位置

如果已選取「顯示內容偏移量」,內嵌物件就會顯示相對於容器物件的 X 值與 Y 值,而「變形」面板中的 X/Y 圖示也會變更為 X+/Y+。如果取消選取了這個指令,就會出現相對於尺標的巢狀物件值。

  1. 在「變形」或「控制」面板選單上,選取或取消選取「顯示內容偏移量」。

在度量值中包含或排除線條寬度

線條寬度可能會影響物件的大小與位置。 您可以變更線條的對齊方式,然後選擇「變形」面板是否要從線條的中心或邊緣度量物件的大小與位置。 如需有關變更線條對齊方式的詳細資訊,請參閱線條面板選項

註解:

縮放框架時,這個選項不會變更線條寬度受影響的程度,只會變更是否有任何變更會影響度量。

  1. 在「變形」或「控制」面板選單中,執行下列任一項動作:
    • 如果您希望面板度量表示物件的線條外緣,請選取「尺寸包含線條寬度」。 舉例來說,如果有一個框架比另一個框架短兩點,但短框架的線條粗了兩點,這個設定就會造成兩個框架在「變形」與「控制」面板中顯示同樣的高度值。

    • 如果您希望面板度量表示物件的路徑或框架而不管其線條寬度,請取消選取「尺寸包含線條寬度」。 例如,兩個高度相同的框架,在「變形」與「控制」面板中會顯示同樣的高度值,無論其線條寬度是否有差異。

變形物件

您可以使用工具與指令來修改物件的大小或形狀,也可以變更物件在作業範圍上的方向。 工具箱包含四種變形工具:「旋轉」、「縮放」、「傾斜」和「任意變形」工具。 此外,您可以使用「選取」工具將物件變形。所有的變形 (再加上反射) 都可以在「變形」與「控制」面板中使用,您可以在此指定精確的變形。

變形工具 (上) 與變形面板 (下) 的比較
變形工具 (上) 與變形面板 (下) 的比較

A. 旋轉選項 B. 傾斜選項 C. 縮放選項 

變形物件時,請注意下列事項:

  • 變形的結果可能會因為選取的物件而大有不同。例如,旋轉影像時,會視您先選取影像、框架,或框架然後影像,來決定旋轉的物件。使用「選取」工具 會將整個路徑及其內容變形 (旋轉、縮放或傾斜),使用「直接選取」工具 則會將路徑變形而不影響其內容,或是只將內容變形而不影響其路徑。如果要將內容變形而不影響路徑,請確認已選取所有錨點。

註解:

如果要同時調整框架和內容的大小,請使用「X 縮放百分比」和「Y 縮放百分比」欄位,而不是「W」和「H」欄位。「W」和「H」欄位只會變更選取的框架或內容,不會同時變更。請記住,縮放欄位中並不限於只能指定百分比。您可以加上度量單位 (例如「6p」) 來輸入尺寸。

  • 變形會影響所有選取的物件,就像一個單元。 舉例來說,如果選取多重物件並且旋轉 30 度,這些物件都會繞著一個參考點旋轉。 如果要將各個選定物件繞著本身的參考點旋轉 30 度,就必須分別選取並旋轉這些物件。

  • 將文字變形有兩種選取方法,您可以使用其中任何一種:使用「選取」或「直接選取」工具選取整個文字框架,或是已轉換成外框的文字,然後使用變形工具;或是使用「文字」工具來選取文字,或按一下文字框架中的某個插入點,然後在「變形」面板、「控制」面板或是在連按兩下某個工具時出現的對話框中指定變形。 在兩種情況下,變形都會影響整個文字框架。

  • 旋轉、傾斜或縮放群組時,這些設定會套用到整個群組,也會套用到群組中的個別物件。 舉例來說,如果將群組旋轉 30 度,無論您選取群組本身,或是直接選取群組中的某個物件,「變形」或「控制」面板中的旋轉值都是 30 度。

使用變形面板將物件變形

使用選取工具以決定將內容和框架一併或個別變形。

  1. 選取要變形的物件。
    • 如果要將框架及其內容一併變形,請使用「選取」工具選取框架。

    • 若要將內容變形,但不變形其框架,請使用「直接選取」工具 直接選取物件,或使用「選取」工具並按一下影像的內容抓取工具。

    • 如果要將框架變形但不將內容變形,請直接選取框架,然後選取所有錨點。

  2. 在「變形」面板或「控制」面板中,指定變形的參考點。

    面板中的所有數值,都會參照物件的邊界方框。 X 與 Y 值指的是邊界方框上相對於尺標原點的已選取參考點。

  3. 執行下列任一項作業:
    • 在文字方塊內輸入新值。
    • 在可用的彈出式選單中選擇數值。
    • 從面板選單選擇指令

    註解:

    在使用「X 縮放百分比」與「Y 縮放百分比」選項時,若要維護物件的比例,請按一下面板中的「強制等比例」圖示 。 如果並未選取選項,圖示的兩邊都會出現虛線 (像是中斷的連結)。您也可以指定度量單位 (例如 6p),以指定尺寸而非百分比。

  4. 按 Tab、Enter (Windows) 或 Return 鍵 (Mac OS) 即可套用變更。

使用選取工具變形物件

使用「選取」工具可移動物件、調整物件大小和旋轉物件。

  1. 使用「選取」工具 選取物件。若要變形框架內的影像,請在指標停留在影像上時,按一下顯示的內容抓取工具。
  2. 執行下列任一項作業:
    • 如果要移動物件,請在邊界方框內的任何地方按一下,然後拖移即可。

    • 若要縮放物件,請按住 Ctrl (Windows) 或 Command (Mac OS) 鍵,然後拖移任何邊界方框控點直到物件變成想要的大小。加入 Shift 鍵可保留選取範圍的比例。加入 Alt (Windows) 或 Option (Mac OS) 鍵可從中心縮放物件。

    • 若要旋轉物件,請將指標放置在邊界方框控點外面的任何位置。指標變成 時,請拖移直到選取項目達到所需的旋轉角度。

    • 如果要反射物件,請將邊界方框的一個控點拖移越過對邊或對面的控點,直到物件達到所需的鏡射程度。

使用任意變形工具將物件變形

「任意變形」工具的運作就像在 Adobe Photoshop 與 Adobe Illustrator 中一樣,提供只利用一項工具就能執行任何變形的方法。在「任意變形」工具啟用之後,可以結合不同的變形,例如旋轉與縮放。

註解:

您可以使用鍵盤快速鍵,立即切換「任意變形」工具 (按 E)、「選取」工具 (V) 和「直接選取」工具 (A)。

  1. 使用適當的選取工具,選取要變形的物件。
  2. 選取「任意變形」工具
    • 如果要移動物件,請在邊界方框內的任何位置按一下,然後拖移即可。

    • 如果要縮放物件,請拖移任何邊界方框控點,直到物件成為需要的大小。 按 Shift 鍵並拖移控點,可以保持選取範圍的比例。

    • 如果要從邊界方框的中心縮放物件,請按 Alt 鍵並拖移 (Windows),或按 Option 鍵並拖移 (Mac OS)。

    • 如果要旋轉物件,請將指標放置在邊界方框外面的任何位置。 指標變成 時,請拖移直到選取項目達到所需的旋轉角度。

    • 如果要反射物件,請將邊界方框的一個控點拖移越過對邊或對面的控點,直到物件達到所需的鏡射程度。

    • 如果要將物件傾斜,請先拖移控點,然後按住 Ctrl 鍵 (Windows) 或 Command 鍵 (Mac OS)。 按住 Alt+Ctrl (Windows) 或 Command+Option (Mac OS),向物件兩側傾斜。

旋轉物件

您可以透過數種方法旋轉物件。

使用旋轉工具旋轉物件

  1. 選取要旋轉的物件。如果要旋轉框架及其內容,請使用「選取」工具選取框架。若要旋轉內容而不旋轉其框架,請按一下「內容抓取工具」或使用「直接選取」工具來選取物件。如果要旋轉框架但不旋轉內容,請直接選取框架,然後選取所有錨點。
  2. 選取「旋轉」工具
  3. 如果旋轉時要使用不同的參考點,請按一下您希望參考點出現的位置。
  4. 將工具放在參考點之外的地方,然後繞著參考點拖移。 如果要將工具限制在 45 度的倍數,請在拖移時按住 Shift 鍵。 如需更精細的控制,請拖移遠離物件的參考點。

您也可以使用「任意變形」工具旋轉。

如果啟動「智慧型參考線」(以及「智慧型尺寸」),視覺提示就會在您以相同於鄰近旋轉物件的角度旋轉物件時出現。 例如,如果您在頁面上將物件旋轉 24 度,當您將另一個物件旋轉接近 24 度時,就會出現一個旋轉圖示。

使用選取工具旋轉物件

  1. 使用「選取」工具,將指標放置在選取範圍控制點以外的任何地方。指標變成 時,請拖移直到選取項目達到所需的旋轉角度。

使用變形或控制面板旋轉物件

  1. 選取要旋轉的物件。 若要旋轉框架及其內容,請使用「選取」工具 選取框架。若要旋轉內容而不旋轉其框架,請按一下「內容抓取工具」或使用「直接選取」工具來選取物件。如果要旋轉框架但不旋轉內容,請直接選取框架,然後選取所有錨點。
  2. 執行下列任一項作業:
    • 如果要以 90 度增量順時針或逆時針旋轉,請按一下「控制」面板上任一個「旋轉」按鈕。

    • 如果要以預設角度旋轉,請在「變形」或「控制」面板的「旋轉角度」 彈出式選單中選擇一個角度。

    • 在「變形」或「控制」面板的「旋轉角度」 方框中,輸入正值角度即可將選定物件逆時針旋轉,或是輸入負值角度將選定物件順時針旋轉,然後按 Enter 鍵 (Windows) 或 Return 鍵 (Mac OS)。

    • 如果要建立物件的拷貝,並對該份拷貝套用新的旋轉,請在「變形」面板的「旋轉角度」方框內輸入值,然後按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS) 並按下 Enter。

旋轉單一物件時,指定的值仍然會顯示在「變形」或「控制」面板上。 旋轉多個物件時,即使物件已旋轉,「旋轉角度」也會重設為 0 度。

使用旋轉指令旋轉物件

您可以使用「旋轉」指令來指定旋轉物件的量。 這個指令也會旋轉所選物件的拷貝,並保持原始物件原地不動。

  1. 選取要旋轉的物件。 如果要旋轉框架及其內容,請使用「選取」工具選取框架。 如果要旋轉內容但不旋轉其框架,請直接選取物件。 如果要旋轉框架但不旋轉內容,請直接選取框架,然後選取所有錨點。
  2. 執行下列任一項步驟,開啟「旋轉」對話框:
    • 選擇「物件 > 變形 > 旋轉」。

    • 按兩下「旋轉」工具

    • 選取「旋轉」工具,然後按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS),同時在物件上或附近按一下,以選取新參考點。

  3. 在「角度」方框中,以度為單位,輸入旋轉角度。 若輸入負數,則會順時針旋轉物件;輸入正數則會逆時針旋轉物件。
  4. 執行下列任一項作業:
    • 如果要在套用之前先預視效果,請選取「預視」。

    • 若要旋轉物件,請按一下「確定」。

    • 若要旋轉物件的拷貝,請按一下「拷貝」。

移動物件

如果要移動物件,您可以將物件從一個地方剪下並貼到另一個地方、輸入新的水平與垂直座標,或是利用拖移的方式。 拖移也可以讓您將物件拷貝移至別處,或是在不同的軟體應用程式之間拷貝物件。

「智慧型參考線」功能可讓您輕鬆將物件移到版面中的精確位置。當您拖移物件時,畫面上會出現暫時的參考線,指出所移動的物件是對齊頁面的邊緣或中央,或是對齊其他頁面項目。

移動物件

如果要獲得最佳結果,請使用「選取」工具移動多個物件。 如果使用「直接選取」工具移動多個物件或路徑,拖移時只會移動所選取的圖形、路徑或錨點。

  1. 選取要移動的物件。 若要移動框架及其內容,請使用「選取」工具 選取框架。若要移動內容而不移動其框架,請直接選取物件,或在滑鼠移過影像時按一下內容抓取工具。如果要移動框架但不移動內容,請直接選取框架,然後選取所有錨點。
  2. 執行下列任一項作業:
    • 如果要將物件 (或是其拷貝) 貼入新的位置,請選擇「編輯 > 剪下」或「編輯 > 拷貝」。 將目標指向目的地跨頁,然後選擇「編輯 > 貼上」。 物件會出現在目標跨頁的中心。
    • 如果要將拷貝貼在和原始物件一樣的位置,請選擇「編輯 > 拷貝」。 然後選擇「編輯 > 原地貼上」。(如果要將拷貝偏移原件,請使用方向鍵輕推)。

    註解:

    如果您希望物件出現在許多頁面上的同一個位置,可以考慮建立一個主版頁面,然後將物件貼到上面。

    • 如果要將物件移至某個特定的數值位置,請在「變形」或「控制」面板中,為每個 X (水平) 或 Y (垂直) 位置選項輸入數值。 然後,按下 Enter 鍵 (Windows) 或 Return 鍵 (Mac OS)。

    • 若要將物件往某個方向輕推,請按下或按住方向鍵;若要將物件輕推十倍距離,請按住 Shift 鍵,同時按下方向鍵。

    • 如果要利用拖移方式移動物件,請將物件拖移到新的位置。 按住 Shift 鍵並拖移滑鼠,即可限制物件只能水平、垂直或對角移動 (45 度角的倍數)。

    註解:

    拖移內容抓取工具,以在影像的框架內移動影像。

精確指定物件移動的量

您可以使用「移動」指令來指定移動物件的量。 這個指令也會移動所選物件的拷貝,並保持原始物件原地不動。

  1. 選取要移動的物件。 如果要移動框架及其內容,請使用「選取」工具選取框架。 如果要移動內容但不移動其框架,請直接選取物件。 如果要移動框架但不移動內容,請直接選取框架,然後選取所有錨點。
  2. 選擇「物件 > 變形 > 移動」,或是在工具箱中連按兩下「選取」或「直接選取」工具的圖示。
  3. 在「移動」對話框中,執行下列任一項動作:
    • 輸入希望物件移動的水平和垂直距離。 正值會將物件向下移到 x 軸右邊;負值會將物件向上移到左邊。

    • 如果要將物件移動精確的距離與角度,請輸入移動的距離與角度。 您輸入的角度會以相對於 x 軸的角度計算。 正的角度指定反時針移動;負的角度指定順時針移動。 您也可以輸入 180 度和 360 度之間的值,這些值會轉換成對應的負值 (例如 270 度會轉換成 –90 度)。

  4. 執行下列任一項作業:
    • 如果要在套用之前先預視效果,請選取「預視」。

    • 若要移動物件,請按一下「確定」。

    • 若要移動物件的拷貝,請按一下「拷貝」。

將物件移至精確位置

  1. 選取要移動的物件。
  2. 如果移動時要使用不同的參考點,請按一下您想要參考點顯示的位置。

    例如,如果要將物件移至頁面左上角,請選取左上角的參考點。

  3. 在「變形」面板的「X」和「Y」欄位中,輸入您要移動選取範圍的目標座標。

指定物件受到輕推時移動的距離

  1. 選擇「編輯 > 偏好設定 > 單位與增量」(Windows) 或「InDesign > 偏好設定 > 單位與增量」(Mac OS)。
  2. 針對「方向鍵」,請指定要每按一次鍵時要移動所選物件的距離,然後按一下「確定」。

註解:

如果按住 Shift 鍵同時移動選取範圍,此選取範圍就會移動您在此指定距離的十倍。

縮放物件與調整物件大小

調整大小和縮放在 InDesign 中是不同的動作。調整大小只是變更物件的「寬度」和「高度」值。縮放則涉及使用相對於框架原始縮放比例 (100%) 的百分比值。

調整大小和縮放的差異有時候並不明顯。有一個了解差異的好方法,就是對已套用線條的文字框進行調整大小和縮放。將文字框大小調整為兩倍大時,文字大小和線條寬度會保持相同。 將文字框放大兩倍時,文字大小和線條寬度也會放大兩倍。

調整框架大小

根據預設,如果選取的是框架 (而不是框架內容),則不論使用中的選取工具是哪一個,變更「寬度」和「高度」欄位的值都只會變更框架,不會變更其內容。

縮放框架及其內容

使用「選取」工具選取框架後,變更「X 縮放百分比」和「Y 縮放百分比」欄位的值會變更框架及其內容。如果選取「自動符合」,則會一起調整框架和其內容的大小。

調整框架內容大小和縮放框架內容

如果您只要變更框架的內容 (調整大小或縮放),請按一下「內容抓取工具」或使用「直接選取」工具來選取內容。之後,您可以視喜好使用「寬度」和「高度」欄位或「縮放」欄位。

取代預設值

如果要依某個百分比縮放框架及其內容,而且要以目前的度量系統傳回結果,您可以輸入數字加上百分比符號,以取代預設的度量系統。例如,如果目前寬度是 12p,而且希望新寬度是目前值的 75%,您可以在「寬度」欄位中輸入 75%。按 Enter 之後,「寬度」的新值就會顯示為 9p。

同樣地,如果要按照特定增量進行縮放,但要用原本的百分比顯示結果,您可以使用其他度量系統值。例如,您可以用 9p 取代 100%,InDesign 就會算出要達到該寬度/高度所需的百分比。

調整物件大小

拖移包含內容 (例如讀入的圖形) 的框架控點,並不會依預設調整內容大小。重要的是,內容和容器框架是個別項目,各有其邊界方框。 只要拖移已讀入圖形的框架,根據拖移方向,可能會裁切圖形或在圖形外保留空白。 將框架與內容分開修改,會增加彈性,但您需要時間習慣這種作法。

「智慧型參考線」功能可讓您輕鬆根據版面中的其他項目調整物件的大小。當您調整物件大小時,畫面上會出現暫時的參考線,指出物件是對齊頁面的邊緣或中央,或是與其他頁面項目等高或等寬。

調整已讀入圖形的大小
調整已讀入圖形的大小

A. 使用選取工具選取框架 B. 調整框架的大小 C. 已縮放的框架和內容 
  • 如果要調整框架大小,請使用「選取」工具拖移任何控點。 如果拖移時按住 Ctrl 鍵 (Windows) 或 Command 鍵 (Mac OS),便會縮放框架和內容。 再按住 Shift 鍵則會等比例縮放。

註解:

如果選取「自動符合」,則框架內影像的大小會隨其框架大小而重新調整。

  • 若要調整圖形框內容的大小,請使用「選取」工具並按一下內容抓取工具或直接選取圖形,然後拖移任何圖形框架控制點。
  • 若要精確地調整框架或其內容的大小,請選取物件,然後在「控制」面板的寬度 (W) 或高度 (H) 欄位中輸入大小。

註解:

若要在使用「控制」面板時要維持物件的原始比例,請確定已選取「強制等比例」 圖示。

  • 如果要同時調整框架和內容的大小,請使用「X 縮放百分比」和「Y 縮放百分比」欄位,而不是「W」和「H」欄位。「W」和「H」欄位只會變更選取的框架或內容,不會同時變更。您可以不指定百分比,改為加上度量單位 (例如「6p」) 來輸入尺寸。
  • 如果要將框架或其內容的大小調整為目前大小的百分比,請選取物件,然後在「變形」面板的寬度或高度欄位中輸入百分比。
  • 如果要建立所選物件的拷貝,並對拷貝套用新的大小,請在「變形」面板的寬度或高度欄位中輸入值,然後按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS) 並按下 Enter。

註解:

調整框架或物件大小之後,您可以使用符合選項 (「物件 > 符合」),使內容符合框架大小或使框架符合內容大小。

縮放物件

縮放物件會按照您所指定的參考點,水平 (沿著 x 軸) 或垂直 (沿著 y 軸) 或同時水平及垂直放大或縮小物件。

依預設,InDesign 會縮放線條。 例如,如果對具有 4 點線條的選取物件放大 200%,「線條」面板會指出 8 點線條,並且線條會明顯放大兩倍。 您可以在「變形」或「控制」面板選單中取消選取「在縮放時調整線條寬度」,變更預設的線條行為。

使用選取工具縮放物件

  1. 若要同時縮放內容和框架,請使用「選取」工具,並按住 Ctrl 鍵 (Windows) 或 Command 鍵 (Mac OS) 選取物件。再按住 Shift 鍵,等比例調整物件大小。

使用縮放工具縮放物件

  1. 選取要縮放的物件。 如果要縮放框架及其內容,請使用「選取」工具選取框架。 若要縮放內容而不縮放其框架,請按一下「內容抓取工具」以直接選取物件。如果要縮放框架但不縮放內容,請直接選取框架,然後選取所有錨點。
  2. 選取「縮放」工具
  3. 將「縮放」工具放在參考點之外的地方再拖移。 如果只要縮放 x 軸或 y 軸,請只沿著一個軸開始拖移「縮放」工具。 如果要等比例縮放,請按住 Shift 鍵,同時拖移「縮放」工具。 如需更精細的控制,請在遠離物件參考點的地方開始拖移。

    註解:

    您也可以使用「任意變形」工具縮放。

使用變形面板縮放物件

如果在使用「變形」面板時要維持物件的原始比例,請務必選取「強制等比例」圖示

  1. 選取要縮放的物件。 如果要縮放框架及其內容,請使用「選取」工具選取框架。 如果要縮放內容但不縮放其框架,請直接選取物件。 如果要縮放框架但不縮放內容,請直接選取框架,然後選取所有錨點。
  2. 在「變形」或「控制」面板中,執行下列任一項動作:
    • 在「X 縮放百分比」 或「Y 縮放百分比」 彈出式選單中選擇預設百分比值。

    • 在「X 縮放百分比」或「Y 縮放百分比」方框中輸入百分比值 (例如 120%),或特定距離 (例如 10p),然後按下 Enter 鍵或 Return 鍵。

使用方向鍵縮放物件

  1. 選取或直接選取物件或框架。
  2. 在「變形」面板中,按一下「X 縮放百分比」 或「Y 縮放百分比」 方框。
  3. 按向上鍵或向下鍵,可以按照 1% 的增量縮放物件。只要同時按住 Shift 鍵與方向鍵,就能以 10% 的增量單位縮放物件。

如果您用這種方法放大物件,再以相同的百分比縮小物件,且選取「一般」偏好設定的「調整縮放百分比」時,物件會還原成原始的縮放值。例如,如果將 20 公釐的圓圈放大 10%,再縮小 10%,圓圈會變回 20 公釐 (不是 19.8 公釐)。

使用縮放指令縮放物件

  1. 選取要縮放的物件。 如果要縮放框架及其內容,請使用「選取」工具選取框架。 如果要縮放內容但不縮放其框架,請直接選取物件。 如果要縮放框架但不縮放內容,請直接選取框架,然後選取所有錨點。
  2. 執行下列任一項步驟,開啟「縮放」對話框:
    • 選擇「物件 > 變形 > 縮放」。

    • 按兩下「縮放」工具

    • 選取「縮放」工具,然後按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS),同時在物件上或附近按一下,以選取新參考點。

  3. 在「X 縮放」或「Y 縮放」方框中輸入百分比值。

    註解:

    如果在使用「變形」面板時要維持物件的原始比例,請務必選取「強制等比例」圖示

  4. 執行下列任一項作業:
    • 如果要在套用之前先預視效果,請選取「預視」。

    • 若要縮放物件,請按一下「確定」。

    • 若要縮放物件的拷貝,請按一下「拷貝」。

決定縮放的追蹤方式

您可以決定介面中追蹤縮放的方式。如果在「一般」偏好設定中已選取「套用至內容」偏好設定選項,縮放物件後,「變形」面板中的縮放值會重設為 100%。如果已選取「調整縮放百分比」,縮放值會保持指定的狀態 (例如 125%)。

選取多個物件後,縮放值一定會顯示為 100%,但如果已選取「調整縮放百分比」,則可以個別選取物件,查看已套用的變形效果 (例如 125%)。

  1. 選擇「編輯 > 偏好設定 > 一般」(Windows) 或「InDesign > 偏好設定 > 一般」(Mac OS)。
  2. 在「縮放時」底下,選取「套用至內容」或「調整縮放百分比」,然後按一下「確定」。

註解:

如果選取「調整縮放百分比」後,再選取物件,您可以在「變形」或「控制」面板選單中選擇「重新定義縮放為 100%」,將縮放百分比重設回 100%。

縮放物件時調整線條寬度

  1. 在「變形」或「控制」面板選單中選取「在縮放時調整線條寬度」選項。

例如,在開啟這個選項的狀況下,如果將 4 點的線條放大 200%,線條寬度會變成 8 點。如果關閉這個選項,物件會放大兩倍,但其線條寬度仍然保持 4 點。

如果開啟這個選項並且以不等比例方式縮放物件,InDesign 會將最小線條寬度套用至所有四邊。 例如,假設對具有 4 點線條的選取物件進行縮放,則只會在 X 方向放大 200%。 InDesign 會對所有四邊都套用較小值 (4 點),而非 X 方向套用 8 點線條、Y 方向套用 4 點線條。

效果縮放功能

如果您建立物件,接著套用效果,則該效果也會一直隨著物件的縮放等比例地縮放。效果會依縮放物件的比例,等比例地縮放。

在偏好設定中,「一般 > 套用至內容 > 包含效果」。如果您只要縮放物件,而不縮放效果,請取消選取這個選項。

「偏好設定 - 包含效果」
「偏好設定 - 包含效果」

或者

「視窗 > 物件與版面 > 變形」。從彈出式選單,選取「縮放時調整效果」,即可開啟或關閉效果縮放功能。

調整縮放
調整縮放

這跟線條效果作用的方式類似。所以您可以像縮放線條一樣來縮放效果。

將縮放值重設為 100%

在某些狀況下,您可能想要將物件的「X 縮放」和「Y 縮放」值重設為 100%,而不調整物件大小。 例如,您可能開啟來自舊版 InDesign、具有非 100% 縮放值的文件,或在已選取「調整縮放百分比」偏好設定的情況下縮放物件。 選擇這個指令時,所有選取框架的縮放值都會重設為 100%, 但物件大小或外觀則保持不變。

  1. 選取一或多個具有非 100% 縮放值的物件。

    如果直接選取讀入的影像,或物件有 100% 縮放值,這個指令會變成灰色。

  2. 從「變形」或「控制」面板選單中選擇「重新定義縮放為 100%」。

註解:

選擇這個指令可能會對變形群組中的物件造成非預期的行為。

反射 (翻轉) 物件

反射物件會將物件在指定的參考點跨過一個隱形軸加以翻轉 (請參閱變更變形設定)。

原始物件 (上) 使用水平翻轉進行反射 (中) 使用垂直翻轉進行反射 (下)
原始物件 (上) 使用水平翻轉進行反射 (中) 使用垂直翻轉進行反射 (下)

「控制」面板中央的翻轉/旋轉指示符 (P) 會在已翻轉物件時變成白色並具有黑色外框。 如果未翻轉物件,指示符是純黑色。

  1. 選取要翻轉的物件。 如果要翻轉框架及其內容,請使用「選取」工具選取框架。 如果要翻轉內容但不翻轉其框架,請直接選取物件。 如果要翻轉框架但不翻轉其內容,請直接選取框架,然後選取所有錨點。
  2. 執行下列任一項作業:
    • 如果要將參考點做為水平軸進行反射,請按一下「控制」面板上的「水平翻轉」按鈕。

    • 如果要使用參考點做為垂直軸進行反射,請按一下「控制」面板上的「垂直翻轉」按鈕。

    註解:

    如果要反射物件,也可以使用「選取」工具或「任意變形」工具,將物件的邊界方框的一邊拉到超過對面邊界之外,或是在「變形」或「控制」面板中,在「X 縮放百分比」或「Y 縮放百分比」選項中輸入負值。

傾斜物件

傾斜會將物件沿著水平軸或垂直軸偏轉,也可以將物件的兩個軸都轉動。 傾斜適用於:

  • 模擬某些類型的透視,例如等角投影。

  • 傾斜文字框架。

  • 將物件的拷貝傾斜時,就會產生投射陰影。

傾斜物件

  1. 選取要傾斜的物件。 如果要傾斜框架及其內容,請使用「選取」工具選取框架。 若要傾斜內容而不傾斜其框架,請按一下「內容抓取工具」以直接選取物件。如果要傾斜框架但不傾斜內容,請直接選取框架,然後選取所有錨點。
  2. 執行下列任一項作業:
    • 如果要利用拖移方式傾斜選定物件,請選取「傾斜」工具 。 然後,將「傾斜」工具放在參考點之外的地方再拖移。 按住 Shift 鍵並拖移滑鼠,限制只在垂直軸或水平軸傾斜。 如果先以非垂直角度拖移,然後按住 Shift 鍵,則會限制傾斜為該角度。


      參考點置於中心並拖移傾斜工具而傾斜的物件

    註解:

    如果傾斜時要使用不同的參考點,請按一下您想要參考點顯示的位置。

    • 如果要使用預設值進行傾斜,請在「變形」或「控制」面板中,從「傾斜」 彈出式選單中選擇角度。
    • 如果要使用特定值進行傾斜,請在「變形」或「控制」面板的「傾斜」 方框中輸入正或負的角度,然後按下 Enter 或 Return。
    • 如果要建立物件的拷貝,並對該份拷貝套用新的傾斜,請在「變形」面板的「傾斜」方框中輸入值,然後按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS) 並按下 Enter。

傾斜單一物件時,指定的值仍然會顯示在「變形」或「控制」面板上。 傾斜多個物件時,即使物件已傾斜,「傾斜角度」值也會重設為 0 度。

註解:

您也可以使用「任意變形」工具進行傾斜。

使用傾斜指令傾斜物件

您可以使用「傾斜」指令來指定傾斜物件的量。 這個指令也會傾斜所選物件的拷貝,並保持原始物件原地不動。

  1. 選取要傾斜的物件。 如果要傾斜框架及其內容,請使用「選取」工具選取框架。 若要傾斜內容而不傾斜其框架,請按一下「內容抓取工具」以直接選取物件。如果要傾斜框架但不傾斜內容,請直接選取框架,然後選取所有錨點。
  2. 執行下列任一項步驟,開啟「傾斜」對話框:
    • 選取「物件 > 變形 > 傾斜」。

    • 按兩下「傾斜」工具

    • 選取「傾斜」工具,然後按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS),同時按一下滑鼠,以選取新參考點。

  3. 輸入新傾斜角度。

    傾斜角度是套用至物件的歪斜量,是相對於一條與傾斜軸成直角的線 (傾斜角是從目前的軸以順時針計算)。

  4. 指定物件要於其上傾斜的軸。 您可沿著水平軸或垂直軸來傾斜物件。
  5. 執行下列任一項作業:
    • 如果要在套用之前先預視效果,請選取「預視」。

    • 若要傾斜物件,請按一下「確定」。

    • 若要傾斜物件的拷貝,請按一下「拷貝」。

重複變形

您可以重複變形動作,例如移動、縮放、旋轉、調整大小、反射、傾斜及符合。 您可以重複單一變形,或是一系列變形,也可以一次將這些變形套用到不只一個物件。 InDesign 會記住所有的變形,直到您選取不同的物件或是執行不同的工作。

註解:

不是所有變形都會被記錄下來。 例如,修改路徑或該路徑的點,便不會記錄為變形。

  1. 選取一或多個物件,然後執行要重複的所有變形。
  2. 選取一或多個要套用相同變形的物件。
  3. 選擇「物件 > 再次變形」,然後選取下列任一選項:

    再次變形

    將最後一個變形操作套用到選取範圍。

    分別再次變形

    將最後一個變形操作個別套用到每個選定物件,而不是整個群組套用。

    再次變形順序

    將最後一系列變形操作順序套用到選取範圍。

    分別再次進行變形順序

    將最後一系列變形操作順序分別套用到每個選定物件。

清除變形

  1. 選取一或多個已變形的物件。
  2. 從「變形」或「控制」面板選單中選擇「清除變形」。

    除非所有值都是預設值,否則清除變形會造成物件外觀的改變。

    註解:

    如果「縮放」值已重設為 100%,則清除變形便不會變更縮放。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策