Character Animator 내의 [퍼펫] 패널에서 퍼펫의 구조와 모양을 편집합니다. 여기서 퍼펫을 변경하면 장면에 추가되는 모든 퍼펫 인스턴스에 변경 내용이 적용됩니다.

퍼펫을 편집하려면 다음 중 하나를 수행합니다.
  • [프로젝트] 패널에서 퍼펫을 두 번 클릭합니다.
  • [퍼펫] 패널 왼쪽의 세로 막대에서 [퍼펫] 레이어를 두 번 클릭합니다.
  • [타임라인] 패널에서 퍼펫의 트랙 항목 또는 퍼펫 헤더(왼쪽)를 두 번 클릭합니다.

[퍼펫] 패널에서 퍼펫이 열립니다. 이 패널의 왼쪽(세로 막대)에는 레이어 구조가 표시되고 오른쪽에는 레이어 및 연결된 핸들의 모양이 표시됩니다. 패널 하단에는 레이어 및 핸들 사용을 위한 명령과 툴이 있습니다. [속성] 패널에도 선택한 레이어의 설정이 있습니다.

탐색

[퍼펫] 패널에는 [장면] 패널에 있는 것과 동일한 대부분의 컨트롤이 포함되어 있습니다. 이러한 컨트롤을 사용하여 패널 컨텐츠를 팬 및 확대/축소하고 배경 색상을 변경합니다. 또한 객체 선택(선택 툴), 팬(손 툴) 및 확대/축소(확대/축소 툴)용 툴도 있습니다.

퍼펫 패널 컨트롤
퍼펫 패널 컨트롤

퍼펫 메쉬 윤곽선

퍼펫 패널에서 레이어를 선택하면 메쉬에 노란색 윤곽선이 표시됩니다. 노란색 윤곽선은 메쉬 모양메쉬 확장 설정과 함께 레이어 목록에서 노란색 세로 선이 있는 레이어를 통해 식별되는 메쉬를 나타냅니다. 윤곽선을 통해 메쉬가 원하는 모양이며 겹치지 않는 레이어로 인해 예상치 않은 모양이 되지 않았음을 확인할 수 있습니다.

퍼펫 메쉬 윤곽선
퍼펫 메쉬 윤곽선

메쉬 윤곽선과 자동 연결 핸들을 표시하거나 숨기려면 퍼펫 패널 왼쪽 아래 모서리에 있는 메쉬 윤곽선 표시자동 핸들 버튼()을 전환합니다.

퍼펫 레이어 복제

퍼펫 패널에서 레이어와 그룹을 복제할 수 있습니다. 복제를 하려면 편집 > 복제 메뉴를 선택합니다. 원본에 영향을 주지 않고 복제 레이어나 그룹을 수정할 수 있습니다.

레이어 선택 또는 선택 취소

  • 왼쪽 세로 막대에서 레이어를 클릭합니다. 선택한 컨텐츠가 회색으로 강조 표시됩니다.
  • 선택 영역을 레이어 범위로 확장하려면 Shift 키를 누른 상태로 레이어를 클릭합니다.
  • 레이어 선택을 전환하려면 Cmd/Ctrl 키를 누른 상태로왼쪽 세로 막대에서 레이어를 클릭하거나 Shift 키를 누른 상태로 레이어를 클릭합니다. 
  • 모든 레이어를 선택하려면 Cmd/Ctrl+A를 누릅니다.
  • 모든 레이어를 선택 취소하려면 Shift+Cmd/Ctrl+A를 누르거나 왼쪽 사이드바에서 레이어 바깥쪽을 클릭합니다.

교체 세트의 트리거에 대한 그룹의 다른 레이어 숨기기 레이어

키보드로 트리거되는 여러 개의 겹치는 레이어를 그룹의 다른 레이어 숨기기로 설정하면 [퍼펫] 패널에서 레이어 중 하나에 더 쉽게 초점을 맞출 수 있습니다. 교체 세트의 트리거와 연결된 레이어에 대해 눈 모양 스위치를 설정하면 동일한 교체 세트의 다른 트리거와 연결된 레이어의 눈 모양 스위치는 해제됩니다.

참고:

여러 [그룹의 다른 레이어 숨기기] 레이어를 선택하여 해당 레이어 중 하나의 눈 모양 스위치를 선택하는 경우에는 [그룹의 다른 레이어 숨기기] 레이어를 단독으로 설정할 수 없습니다. [그룹의 다른 레이어 숨기기]로 설정되지 않은 레이어를 선택할 때와 마찬가지로 선택한 모든 레이어가 설정되거나 해제됩니다.

[그룹의 다른 레이어 숨기기] 눈 모양 스위치를 클릭하더라도 선택한 모든 레이어가 설정되어 있도록 하려면 Option/Alt 키를 누른 상태로 눈 모양 스위치를 클릭합니다.

[그룹의 다른 레이어 숨기기]는 트리거 키가 할당된 레이어만이 아니라 모든 레이어에 사용할 수 있습니다. 함께 사용할 수 없으며 트리거 키가 없는 다른 형제 레이어의 경우에는 단독 설정 기능을 사용할 수 있습니다. [입] 그룹의 형제 레이어나 [머리 회전]을 통해 제어되는 형제 레이어를 예로 들 수 있습니다.

컨트롤 패널: 퍼펫 트리거 및 비헤이비어 매개 변수용 사용자 정의 레이아웃 

컨트롤 패널을 사용하여 퍼펫에 대해 지원되는 비헤이비어 매개 변수 또는 트리거에 액세스할 수 있는 대시보드나 시각적 인터페이스를 표시할 수 있습니다. 손쉽게 액세스하려는 트리거 및 비헤이비어 매개 변수(숫자 및 각도 값)를 선택한 다음 한 곳에서 제어할 수 있습니다. 그러면 이러한 사용자 정의 컨트롤이 퍼펫에 연결됩니다. 이러한 컨트롤을 내보낸 퍼펫의 일부분으로 다른 사용자와 공유할 수도 있습니다.

컨트롤 패널은 기본적으로 기록 및 스트림 작업 영역에서 열리지만 창 > 컨트롤 메뉴 명령을 사용하여 열 수도 있습니다. [컨트롤] 패널에는 프로젝트 또는 타임라인 패널에서 선택한 퍼펫이나 퍼펫 패널에서 연 퍼펫과 연결된 컨트롤이 표시됩니다.

제어판에는 두 가지 모드가 있습니다:

  • 레이아웃 모드: 이 모드에서는 컨트롤의 컨텐츠와 모양을 사용자 정의할 수 있습니다.
레이아웃 모드
레이아웃 모드
  • 수행 모드: 패널 상단의 링크를 클릭해 여러 컨트롤을 사용하려는 경우 이 모드를 사용합니다.
수행 모드
수행 모드

레이아웃 모드

퍼펫의 트리거는 각 트리거용 작품을 사용하여 클릭 가능한 버튼으로 시각화할 수 있습니다. 트리거에는 키 또는 MIDI 노트도 연결되어 있습니다. 퍼펫의 [비헤이비어] 매개 변수는 조정 가능한 슬라이더 또는 각도 컨트롤로 시각화할 수 있습니다. 이러한 컨트롤에는 모든 MIDI 노트를 연결할 수 있습니다. 레이아웃은 .puppet 파일로 내보낼 때를 포함하여 퍼펫을 저장할 때 퍼펫과 함께 저장되므로 다른 사용자와 트리거 레이아웃을 공유할 수 있습니다.

[레이아웃] 모드에서 사용 가능한 컨트롤은 다음과 같습니다.

패널에 컨트롤 추가: 퍼펫을 선택한 후 다음 중 하나를 선택합니다. 

  • 패널이 비어 있으면 패널에서 "퍼펫 이름"용 컨트롤 생성 링크를 클릭하여 퍼펫의 트리거를 기준으로 버튼 컨트롤을 만듭니다.
  • 트리거를 트리거 패널에서 최근에 추가했거나 이전에 일부 트리거 컨트롤을 삭제한 경우 컨트롤 새로 고침 버튼을클릭합니다. 이렇게 하면추가 트리거 또는 이전에 삭제한 트리거 컨트롤에 해당하는 버튼이 추가됩니다.
  • 타임라인 패널에서 퍼펫 트랙이 선택되어 있으면 숫자 비헤이비어 매개 변수의 이름을 속성 패널에서 컨트롤 패널로 드래그합니다. 이러한 매개 변수 이름 위를 마우스 오른쪽 버튼으로클릭하고컨트롤 패널에 추가를 선택할 수도 있습니다.

여러 컨트롤 선택 또는 선택 취소: 다음 중 원하는 작업을 수행합니다. 

  • Shift 또는 Cmd/Ctrl 키를 누른 상태로 컨트롤을 클릭합니다. 
  • 컨트롤 주위를 드래그(움직이는 텍스트)하여 컨트롤을 선택합니다. Shift 또는 Cmd/Ctrl 키를 누른 상태로 움직이는 텍스트를 통해 선택한 컨트롤 선택을 전환합니다. 
  • Cmd/Ctrl+A를 눌러 모든 컨트롤을 선택합니다.
  • Shift+Cmd/Ctrl+A를 눌러 모든 컨트롤을 선택 취소합니다.

컨트롤 다시 배열: 다음 중 원하는 작업을 수행합니다

  • 패널에서 선택한 컨트롤을 드래그합니다. 드래그한 컨트롤을 격자 레이아웃으로 스냅할 수 있습니다. 
  • Option/Alt 키를 누른 상태로 [레이아웃 새로 고침] 버튼을 클릭하여 패널의 현재 크기를 기준으로 현재 컨트롤의 순서를 조정합니다.

특정 트리거용 컨트롤을 만들려면 다음 중 하나를 수행합니다.

  • [트리거] 패널에서 트리거나 교체 세트를 선택하여 [컨트롤] 패널로 드래그합니다.
  • 트리거나 교체 세트 위를 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 컨트롤 패널에 추가를 선택합니다.

다른 키 또는 MIDI 컨트롤 할당: 컨트롤을 선택한 다음 사용하려는 MIDI 컨트롤(버튼, 슬라이더, 노브)을 터치하거나 키를 누릅니다. 이 컨트롤은 [트리거] 패널에서 키 또는 MIDI 노트를 변경하는 것과 같은 기능을 합니다. MIDI 컨트롤과 연결된 컨트롤은 [레이아웃] 모드에서 녹색 오버레이에 표시됩니다.

속성 패널에서 컨트롤을 찾지 않고도 매개 변수를 쉽게 준비하거나 준비를 취소하려면 비헤이비어 매개 변수용 슬라이더 및 노브 컨트롤을 통해 기록을 위해 준비 버튼을 사용합니다.

참고: 퍼펫 트랙을 선택해야 컨트롤을 사용할 수 있습니다.

컨트롤에 대한 키 또는 MIDI 노트/컨트롤러 할당 취소: 다음 중 하나를 수행합니다.

  • 컨트롤을 마우스 오른쪽 버튼으로 클릭하고 트리거 키 제거, MIDI 노트 제거, MIDI 컨트롤러 제거(비헤이비어 매개 변수 컨트롤의 경우 사용 가능) 중 하나를 선택합니다. 
  • 트리거 패널에서 [MIDI 노트] 필드의 컨텐츠를 삭제합니다. 

여러 퍼펫 레이어와 연결된 트리거용 버튼의 작품 변경: 버튼 컨트롤을 마우스 오른쪽 버튼으로 클릭한 다음 레이어 이름을 클릭합니다.

컨트롤의 배경색 변경(진한 색 작품의 대비 개선): 컨트롤을 마우스 오른쪽 버튼으로 클릭하고 [밝음] 또는 [어두움]을 선택합니다. 

슬라이더 또는 각도 매개 변수 컨트롤의 값 범위 변경: 컨트롤에서 파란색 최소값(왼쪽) 및 최대값(오른쪽) 값을 클릭하거나 마우스를 움직입니다. 예를 들어 변형 > 배율 매개 변수를 추가했는데 음수로 배율을 조정할 필요는 없는 경우에는 최소값을 0으로 설정합니다. 

컨트롤 제거: 컨트롤을 선택한 다음 [편집] > [삭제](Delete 또는 백스페이스 키)를 선택하거나 패널 하단에서 [선택한 컨트롤 삭제] 버튼을 클릭합니다. 

 

버튼 컨트롤용 사용자 정의 작품

퍼펫의 작품 파일 내 아무 위치에서나 사용자 정의 작품을 만들어 버튼 컨트롤용으로 사용할 수 있습니다. 트리거에 레이어가 여러 개 할당된 버튼용으로 다른 작품을 선택하려면 버튼을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴 상단에서 레이어 이름을 선택합니다.

이 작업 수행 시 퍼펫의 모양이 바뀌는 경우에는 해당 눈 모양 스위치를 해제합니다.

  • 버튼에 사용자 정의 작품을 할당하려면 퍼펫 패널에서 레이어를 드래그하여 버튼 컨트롤에 놓습니다.

[레이아웃] 모드에서 [수행] 모드로 전환

[수행] 모드로 다시 전환하려면 [레이아웃] 모드의 컨트롤 바깥쪽을 두 번 클릭합니다.
단축키를 할당하여 [레이아웃] 모드와 [수행] 모드 간을 빠르게 전환할 수도 있습니다. 단축키를 할당하려면 [키보드 단축키 편집기]에서 컨트롤 패널 레이아웃 모드 전환 명령에 대해 창 범주를 사용합니다.

수행 모드

컨트롤을 사용하려는 경우 [수행] 모드로 전환하려면 수행을 클릭합니다. 버튼을 클릭하거나 할당된 키를 누르거나 할당된 MIDI 컨트롤을 터치하여 동작을 수행할 수 있습니다. 

컨텐츠 팬

[컨트롤] 패널의 컨텐츠를 팬하여 보기 가능 영역 외부에 있는 컨트롤을 확인할 수 있습니다.
컨트롤 패널에서 팬하려면 다음 작업 중 하나를 수행합니다.

  • 세로 또는 가로 스크롤 막대를 사용합니다.
  • Option/Alt 키나 가운데 마우스 버튼을 누른 상태로 패널에서 드래그합니다.
  • 가로로 스크롤하려면 마우스 휠을 돌려 세로로 스크롤하거나 Shift 키를 누른 상태로 마우스 휠을 돌립니다.

비헤이비어 매개 변수 컨트롤 이름 바꾸기

[컨트롤] 패널에서 비헤이비어 매개 변수의 컨트롤 이름은 매개 변수 이름으로 지정됩니다. 이러한 컨트롤의 이름을 바꿀 수 있습니다. 이름을 바꾸려면 다음 단계를 수행합니다.

  1. 컨트롤 패널을 레이아웃 모드로 전환합니다.

  2. 비헤이비어 매개 변수 컨트롤을 선택한 다음 Return(macOS) 또는 Enter(Windows) 키를 누르거나 비헤이비어 매개 변수 컨트롤 위를 마우스 오른쪽 버튼으로 클릭하고 이름 바꾸기를 선택할 수 있습니다.

  3. 지정할 이름을 입력하고 Return/Enter 키를 누르거나 편집 필드 바깥을 클릭합니다.

트리거 비헤이비어 및 트리거 패널

[트리거] 비헤이비어는 새 퍼펫에 기본적으로 적용됩니다. 이 비헤이비어를 통해 다른 그룹의 레이어를 참조할 수 있는 사용자 정의 이름이 지정된 트리거를 설정하고 작품을 트리거할 수 있습니다. 이와 같은 이름이 지정된 트리거는 [트리거] 패널에 나열됩니다. 이 패널에서 트리거에 키를 할당하고, 트리거를 통해 제어되는 레이어 목록을 확인하고, MIDI 노트를 연결한 다음 연결된 MIDI 디바이스를 사용하여 작품을 트리거할 수 있습니다. 

참고:

[트리거] 비헤이비어는 [키보드 트리거] 비헤이비어를 대체합니다.

트리거 패널
트리거 패널

트리거에는 두 가지 유형이 있습니다. 
• 개별 트리거 - 기본적으로는 레이어를 숨기지만 키를 누르거나 MIDI 노트/컨트롤러를 실행할 때는 레이어를 표시합니다. H 키를 눌러 캐릭터의 모자를 표시하는 등의 경우를 예로 들 수 있습니다. 
• 교체 세트 – 트리거를 한 번에 하나만 표시합니다(예: 다양한 손 제스처의 경우). 해당 트리거 세트는 퍼펫의 레이어 그룹과 연결됩니다. 세트 내의 각 트리거에는 고유한 트리거 키 또는 MIDI 노트가 있으며, 트리거 중 하나를 기본 트리거로 설정할 수 있습니다.

트리거와 연결된 레이어의 이름을 클릭하면 [퍼펫] 패널에서 해당 레이어가 표시됩니다. 다른 레이어나 그룹에는 영향을 주지 않고 퍼펫의 특정 레이어나 그룹을 표시하려면 개별 트리거를 사용합니다. [눈동자] 및 [안구] 레이어도 포함된 그룹에서 B를 눌러 [깜박임] 레이어를 표시하는 경우와 같이 해당 레이어나 그룹이 다른 레이어나 그룹을 숨기도록 하려는 경우에는 교체 세트를 사용합니다.

참고: 더 이상 사용되지 않는 [키보드 트리거] 비헤이비어도 계속 작동하기는 하지만, 보관하려는 이전 [키보드 트리거] 기록이 없으며 새로운 [트리거] 패널을 사용하려는 경우 해당 비헤이비어를 [트리거]로 바꾸십시오.

트리거 만들기 및 편집

[트리거] 패널은 기본적으로 [리그] 작업 영역에서 열립니다. 창 > 트리거 메뉴 명령을 사용하여 해당 패널을 열거나 닫을 수도 있습니다.

퍼펫 레이어를 표시하는 개별 트리거 만들기

다음 중 하나를 수행하십시오.
• 아직 트리거가 할당되지 않은(해당 열에 아이콘이 없음) 퍼펫 레이어의 트리거 열(  )을 클릭한다음트리거 만들기를 선택합니다.

• [퍼펫] 패널에서 레이어를 마우스 오른쪽 버튼으로다음트리거 만들기를 선택합니다.

• 레이어를 [퍼펫] 패널에서 드래그하여 [트리거] 패널에 드롭합니다.

레이어를 교체 세트에 드롭하여 해당 교체 세트에 추가합니다. 다른 곳에 드롭하여 개별 트리거를 만듭니다.

• [트리거] 패널에서 추가(+) 버튼을 클릭한다음트리거 만들기를 선택하여 빈 트리거를 만듭니다. 그런 다음 퍼펫 레이어를 해당 트리거에 드래그하거나 추가합니다.

키가 충돌하거나 레이어가 없는 등의 문제가 있는 트리거는 주황색으로 표시됩니다. 트리거를 마우스로 가리켜 세부 사항을 봅니다. 도구 설명에도 레이어가 없다는 설명이 표시됩니다.

트리거의 교체 세트 만들기

다음 중 하나를 수행하십시오.
• 아직 레이어에 트리거 교체 세트가 할당되지 않은(해당 열에 아이콘이 없음) 퍼펫 그룹의 트리거 열(  )을 클릭한 다음 교체 세트 만들기를 선택합니다. 

• [퍼펫] 패널에서 레이어 그룹을 마우스 오른쪽 버튼으로 클릭한 후 교체 세트 만들기를 선택합니다.

• [트리거] 패널에서 추가(+) 버튼을 클릭하고 교체 세트 만들기를 선택한 후 개별 트리거 또는 개별 트리거로 지정하려는 퍼펫 레이어를 드래그하여 가져옵니다.

각각 선택한 레이어의 이름이 지정된 세로운 트리거 세트가 [트리거] 패널에 만들어집니다. 그룹의 퍼펫 레이어가 표시되는 경우 맨 위의 레이어가 교체 세트의 기본 트리거로 지정됩니다. 교체 세트의 이름을 바꿀 수 있으며 기본 트리거가 없도록 선택할 수 있습니다.

트리거 및 교체 세트 만들기
트리거 및 교체 세트 만들기

기본 트리거 설정

교체 세트의 특정 트리거를 기본값으로 지정하려면 다음 중 원하는 작업을 수행합니다.
• 트리거를 선택하고 패널 하단에서 기본값 옵션을 선택합니다.
• 트리거 이름 옆에 있는 트리거 아이콘을 클릭합니다.
• 트리거 이름을 두 번 클릭합니다.
기본 트리거에는 안이 채워진 더 밝은 색의 아이콘이 표시되며, 트리거 이름도 더 밝게 표시됩니다. 기본적으로 트리거되는 레이어가 없도록 하려면 위의 단계를 반복하여 기본값 옵션을 전환합니다.

기존 트리거에 레이어 또는 그룹 할당

기존 트리거에 레이어 또는 그룹을 할당하려면 다음의 두 가지 작업 중 하나를 수행합니다.
• [퍼펫] 패널에서 레이어나 그룹을 마우스 오른쪽 버튼으로 클릭한다음 트리거에추가를 선택하고 컨텍스트 메뉴에서 특정 트리거를 선택합니다.
• 레이어나 그룹을 [트리거] 패널의 트리거로 드래그합니다.

트리거 호출 설정 구성

트리거를 시작하는 방법을 변경하려면 [트리거] 패널에서 트리거를 선택하고 다음 중 원하는 작업을 수행합니다.

  • [키보드] 열에 키를 입력합니다.
  • MIDI 노트 필드를 클릭하고 MIDI 디바이스에서 키를 누르거나 해당 MIDI 노트 번호를 입력합니다.
  • 트리거 상태를 유지하기 위해 키보드 또는 MIDI 키를 계속 누르고 있지 않아도 되도록 트리거 래치를 설정하려면 패널 하단에서 래치 옵션을 활성화합니다.
  • 레이어를 추가하거나 기존 트리거를 다시 재생하면 이제 [트리거] 패널에서 대상 트리거가 선택됩니다.

[컨트롤] 패널의 [레이아웃] 모드에서 트리거에 키와 MIDI 노트를 보다 직접적인 방식으로 할당할 수 있습니다. 자세한 내용은 레이아웃 모드를 참조하십시오.

트리거 또는 교체 세트 이름 바꾸기, 다시 정렬 또는 결합

트리거 또는 교체 세트의 이름을 바꾸려면 [트리거] 패널에서 해당 트리거 또는 교체 세트를 선택하고 숫자 키패드가 아닌 기본 키보드에서 Enter 키를 누른 후에 새 이름을 입력합니다. 변경 내용을 적용하려면 Enter 키를 누르거나 텍스트 필드 바깥쪽을 클릭합니다. 편집 내용을 취소하려면 Esc 키를 대신 누릅니다.

트리거를 다시 정렬하고 교체 세트 내에서 또는 교체 세트 안이나 바깥으로 이동하려면 트리거를 하나 이상 선택하여 패널에서 드래그합니다. 교체 세트를 다른 교체 세트로 드래그하면 해당 트리거가 단일 교체 세트로 결합됩니다. 나열된 순서에 따라 트리거 우선 순위를 설정하려는 경우에도 교체 세트에서 트리거를 다시 정렬하면 유용합니다.

트리거된 레이어를 결합하려면 트리거를 다른 트리거로 드래그합니다. 드롭한 트리거의 레이어가 대상 트리거에 다시 할당됩니다. 그런 후에 드롭한 트리거는 삭제됩니다.

특정 교체 세트의 트리거를 다른 교체 세트에 결합하려면 해당 교체 세트를 다른 교체 세트 위나 안으로 드래그합니다. 드롭한 교체 세트의 트리거가 대상 교체 세트에 추가됩니다. 대상 교체 세트의 기본 트리거는 기본값으로 계속 유지됩니다.

 

참고:

공유 가능한 퍼펫 그룹을 만들 경우 그룹의 레이어에 할당된 트리거가 공유 퍼펫으로 이동됩니다. 해당 트리거에 대해 [컨트롤] 패널에 표시되는 모든 컨트롤은 부모퍼펫에계속 연결되어 있으며 공유 퍼펫과는 연결되지 않습니다. 공유 퍼펫의 트리거에 대해 컨트롤을 생성할 수 있습니다.

트리거 보기 또는 표시

퍼펫의 트리거에 연결된 트리거를 보거나 표시하려면 다음 중 원하는 작업을 수행합니다.

• [퍼펫] 패널의 레이어 행에 있는 트리거 아이콘을 가리킵니다. 레이어를 보여 주는 트리거 및 트리거 키의 목록이도구 설명에나타납니다.
• 레이어 행에서 트리거 아이콘을 클릭하여 [트리거] 패널에 트리거를 표시합니다.
• 레이어가 여러 트리거에 할당되어 있으면 레이어 행에서화살표가있는 트리거 아이콘을 클릭한 다음 특정 트리거를 선택하여 [트리거] 패널에 표시합니다.

팁: [퍼펫] 패널에서 교체 세트의 트리거에 연결된 레이어의 눈 모양 아이콘을 클릭하면 해당 교체 세트에 있는 다른 트리거된 레이어에 대해 눈 모양 아이콘이 자동으로 해제됩니다. Option/Alt 키를 누른 상태로 클릭하면 눈 모양 아이콘의 자동 전환을 재정의할 수 있습니다.

여러 트리거 호출 시의 트리거 비헤이비어 구성

여러 트리거를 동시에 호출할 때 교체 세트의 트리거가 작동하는 방식을 변경하려면 교체 세트를 선택하고 우선 순위가장 최근(최근에 사용한 트리거가 우선적으로 동작하도록 설정하려는 경우) 또는 나열된 순서([트리거] 패널의 목록에서 맨 위에 있는 트리거가 우선적으로 동작하도록 설정하려는 경우)로 설정합니다. 우선적으로 동작하도록 설정한 트리거의 레이어가 표시됩니다.

레이어 제거

트리거와 연결된 레이어를 제거하려면 [트리거] 패널에서 트리거를 선택한 다음 패널 하단에서 제거할 레이어 옆의 'x'를 클릭합니다.

참고: 트리거와 연결된 모든 레이어를 제거하더라도 트리거가 자동으로 삭제되지는 않습니다.

트리거 또는 교체 세트 삭제

트리거 또는 교체 세트를 삭제하려면 해당 트리거나 교체 세트를 선택하고 편집 > 삭제를 선택합니다.

참고:

머리 회전, 립싱크, 동작 트리거, 얼굴(눈 깜박임) 같은 비헤이비어는 트리거 비헤이비어와 별개의 레이어를 트리거합니다. 동일한 퍼펫 그룹에서 이러한 네 가지 비헤이비어를 트리거를 통해 트리거된 레이어와 함께 사용하려는 경우 [그룹의 다른 레이어 숨기기] 옵션을 이러한 네 가지 비헤이비어를 통해 트리거되지 않는 레이어로 설정합니다. 이 옵션을 사용하는 경우 레이어 순서에 따라 우선 순위가 결정됩니다. 그렇지 않은 경우에는 작품 파일에서 구조를 변경합니다.

퍼펫 간에 트리거 복사

참고:

특정 퍼펫에서 트리거를 복사한 다음 이름이 일치하는 교체 세트 및 트리거와 함께 다른 퍼펫에 붙여넣을 수 있습니다. 해당 트리거의 테이크가 기록되기 전에 원본 퍼펫에서 이러한 교체 세트와 트리거를 복사해야 합니다. 이렇게 하지 않으면 붙여넣은 트리거가 작동하지 않습니다.

퍼펫 간의 트리거 호환성을 설정하려면 다음 단계를 수행합니다.

  1. 복사할 트리거가 있는 퍼펫을 선택합니다. 트리거 패널에서 복사할 교체 세트와 트리거를 선택합니다.

  2. 트리거를 복사하려면 편집 > 복사를 선택합니다. 퍼펫 간에 교체 세트나 트리거를 이동하려면 편집 > 잘라내기를 선택합니다.

  3. 이러한 교체 세트나 트리거를 복사하려는퍼펫을선택합니다.

  4. [트리거] 패널에 포커스가 설정된 상태로 편집 > 붙여넣기를 선택합니다.

붙여넣은 교체 세트 및 트리거는 트리거 목록 아래쪽에 표시됩니다. 원하는 경우 이러한 교체 세트와 트리거를 이동할 수 있습니다. 이제 이 두 퍼펫 간에 트리거 기록을 복사할 수 있습니다.

오래되었거나 사용하지 않는 키보드 트리거를 트리거로 변환

2017년 10월 이전 버전에서 키보드 트리거를 만든 경우 보다 유동적인 트리거 기능을 활용하고 [컨트롤] 패널을 사용하기 위해 키보드 트리거를 트리거로 변환할 수 있습니다. [키보드 트리거] 비헤이비어를 사용하는 기존 프로젝트 및 .puppet 파일은 계속 작동합니다.

트리거기반 퍼펫의 경우에는 [트리거] 또는 [컨트롤] 패널을 사용하여 퍼펫에 할당된 모든 트리거 키를 확인할 수 있습니다.

참고:

[퍼펫] 패널에는 이전의 키보드 열이 더 이상 포함되어 있지 않습니다. [속성] 패널의 "키보드 트리거(오래됨)" 섹션에서 오래된 트리거의 키를 편집하십시오. [래치] 및 [그룹의 다른 레이어 숨기기] 설정도 변경할 수 있습니다. [트리거] 비헤이비어에 사용되는 트리거 키에 대해 [그룹의 다른 레이어 숨기기] 설정을 계속 사용할 수 있습니다.

퍼펫의 비헤이비어를 [키보드 트리거]에서 [트리거]로 변환하려면 다음 단계를 수행합니다.

중요: 다음 절차를 수행하면 기존의 [키보드 트리거] 기록이 제거됩니다.

  1. [프로젝트] 패널에서 퍼펫을 선택합니다.

  2. 퍼펫 > 오래된 트리거 키 변환을 선택합니다.

    [키보드 트리거] 비헤이비어가 [트리거] 비헤이비어로 바뀝니다. 기존 트리거 키는 [트리거] 패널의 동일 트리거로 변환됩니다.

  3. (선택 사항) 트리거를 다른 트리거 위로 드래그하여 [트리거] 패널에서 기본 트리거가 아닌 트리거를 통합합니다.

    가져온 .puppet 파일을 변환한 경우 이러한 변경 내용을 유지하려면 퍼펫을 새 .puppet 파일로 내보냅니다.

페이더: 트리거를 통해 그룹 페이드 설정 및 해제

키보드 트리거를 사용하여 퍼펫의 불투명도를 제어할 수 있습니다. 해당 비헤이비어를 사용하면 키보드 트리거 등의 트리거를 통해 퍼펫에서 특정 부분(그룹)의 불투명도 페이드를 설정하거나 해제함으로써 해당 부분을 표시하거나 숨길 수 있습니다.

설정

페이드 인/아웃하려는 퍼펫의 특정 그룹에 비헤이비어를 추가합니다. 비헤이비어는 퍼펫에 기본적으로 적용되지 않습니다. 최상의 결과를 얻으려면 페이더변형을 같은 그룹에서 사용하지 마십시오. 그룹에 대해 트리거 키를 할당할 수도 있습니다. 키를 계속 누르고 있는 대신 한 번 눌러 페이드 인과 페이드 아웃을 전환하려는 경우 키를 래치로 설정합니다. 

참고:

겹치는 레이어가 포함된 그룹이 표준 혼합 모드로 설정되어 있고 퍼펫이 그룹 불투명도를 사용하는 경우 최종 불투명도 레벨까지 레이어가 개별적으로 페이드됩니다. 이 문제를 해결하려면 그룹 불투명도를 99.9%로 설정합니다.

컨트롤

지속 시간 매개 변수를 사용하여 불투명도 증가 또는 감소 속도(초 단위)를 제어합니다.

트리거 테이크 편집

트리거를 시작하여 기록한 테이크는 타임라인 패널에 트리거 바로 표시됩니다. 따라서비짐바를 편집하는 방식을 쉽게 편집할 수 있습니다.

트리거 및 비짐용 테이크 바에 사용되는타임라인패널에서세로 공간을줄이면사용자 인터페이스를 더 간단하게 표시할 수 있습니다.

편집 가능한 트리거 테이크
편집 가능한 트리거 테이크

아래 목록에는 다양한 매개 변수가 나와 있습니다.

  • 트리거 바 택: 바의 가운데나 가장자리를 클릭합니다. 여러 바를 선택하려면 Shift, Cmd/Ctrl 키를 누른 상태로 클릭하거나 여러 바를 포함하도록 움직이는 텍스트를 드래그합니다. 
  • 트리거 바의 타이밍 변경: 트리거 바의 왼쪽 가장자리를 가로로 드래그하여 시작 시간을 조정하거나 오른쪽 가장자리를 드래그하여 종료 시간을 조정합니다. 왼쪽 가장자리는 테이크 바의재생 헤드, 시작 시간 또는 종료시간으로스냅됩니다. 
  • 교체 집합에서 다른 트리거로 전환: 트리거 바 위쪽을 마우스 오른쪽 버튼으로 클릭한 후 집합의 다른 트리거 중에서 원하는 트리거를 선택합니다. 

팁: 트리거 바 위에재생 헤드가 파킹되어 있는 경우 퍼펫 또는 해당 [트리거] 비헤이비어의 준비를 해제하면 트리거의 변경 내용을 확인할 수 있습니다. 시간에서재생 헤드를 스크러빙하여 변경 내용을 확인할 수도 있습니다.

  • 트리거 테이크 삽입: 트리거 바 앞이나 뒤 또는 두 트리거 바 사이의 간격 위쪽을 마우스 오른쪽 버튼으로 클릭하고 사용 가능한 트리거 중에서 원하는 트리거를 선택합니다. 새 트리거 바는 클릭한 위치에 해당하는 시간에 시작됩니다. 
  • 트리거 바 하나를 두 개로 분할: 트리거 바를 선택하고 편집 > 분할(Cmd/Ctrl+Shift+D)을 선택합니다. 그러면 트리거 바가재생 헤드에서 분할됩니다.에서 트리거 바가 분할됩니다. 또는 정방향 슬래시(/)를 누르면 트리거 바가 절반으로 분할됩니다. 
  • 트리거 바 삭제: 트리거 바를 선택하고 편집 > 삭제(Delete 또는 백스페이스 키)를 선택하거나 트리거 바 중 하나의 위쪽을 마우스 오른쪽 버튼으로 클릭하고 삭제를 선택합니다.
     

트리거와 비짐의 테이크 바를 숨기려면 트리거비짐 테이크 바 표시 메뉴 명령 선택을 취소합니다.

다시 재생: 재사용 및 트리거 가능한 기록

다시 재생 기능을 사용하여 퍼펫에 대해 기록된 테이크를 라이브로 또는 다시 기록하기 위해 트리거합니다. 예를 들어 재사용할 수 있는 이러한 테이크를 만들면 라이브 스트림 중에 서로 다른 여러 퍼포먼스를 반복하거나 기록 중에 특정 시선 또는 팔 제스처를 반복할 수 있습니다. 경우에 따라서는 순환 퍼펫을 사용하는 대신 기록된 퍼포먼스를 다시 재생할 수 있습니다. 

다시 재생 시에는 구체적으로 선택한테이크가 재생됩니다.키나 MIDI 노트를 할당하여 호출할 수 있는 트리거가 다시 재생에 연결됩니다. 퍼펫을 내보낼 때도 다시 재생이 포함되므로 다른 사용자가 트리거할 수 있는 기록된 퍼포먼스를 공유할 수 있습니다. 

Character Animator CC의 리플레이

다시 재생 만들기 및 편집

다시 재생 및 트리거를 만들려면 다음 단계를 수행합니다.

  1. [타임라인] 패널에서 테이크 막대를 하나 이상 선택합니다.

  2. 선택한 테이크를 마우스 오른쪽 버튼으로 클릭한 다음, 다시 재생을 만들어 트리거(새 트리거, 기존 교체 세트의 새 트리거 또는 기존 트리거)와 연결하는 명령을 선택합니다.

퍼펫에 대해 만들어진 다시 재생이 [속성] 패널의 다시 재생 섹션에 나타나며 다시 재생 지속 시간이 표시됩니다. 만들어진 다시 재생과 해당 트리거의 이름은 기본적으로 해당 테이크의 비헤이비어 이름으로 지정됩니다. 다시 재생에 특정 비헤이비어에 대한 테이크가 여러 개 있으면 비헤이비어 이름 뒤의 괄호 안에 테이크 수가 표시됩니다.

만들어진 다시 재생
만들어진 다시 재생

다시 재생의 트리거는 퍼펫의 레이어를 표시하는 트리거와 마찬가지로 [트리거] 패널에 표시됩니다. 트리거를 선택하면 패널 아래쪽 섹션의 [레이어] 및 [다시 재생]섹션에연결된 퍼펫 레이어와 다시 재생이 나열됩니다. 다시 재생 이름을 클릭하면 [속성] 패널에 해당 다시 재생이 표시됩니다. 

다시 재생에는 해당 다시 재생을 만드는 데 사용된 테이크의 복사본이 포함되어 있으므로 필요한 경우에는 원본 테이크를 삭제할 수 있습니다. 

문제가 있는 다시 재생은 주황색으로 표시됩니다. 주황색 아이콘이나 이름을 마우스로 가리켜 툴팁에서 자세한 정보를 확인합니다.

다시 재생 선택 또는 선택 취소

  • 다시 재생 하나를 선택하려면 해당 항목을 클릭합니다.
  • 다시 재생 범위를 선택하려면 범위의 첫 번째 다시 재생을 클릭한 다음 Shift 키를 누른 상태로 범위의 마지막 다시 재생을 클릭합니다.
  • 개별 다시 재생을 선택하거나 선택 취소하려면 Command(macOS) 또는 Ctrl(Windows) 키를 누른 상태로 다시 재생을 클릭합니다.
  • 다시 재생을 모두 선택하려면 Command+A(macOS) 또는 Ctrl+A(Windows)를 누릅니다.
  • 다시 재생을 모두 선택 취소하려면 Command+Shift+A(macOS) 또는 Ctrl+Shift+A(Windows)를 누릅니다.

다시 재생 이름 바꾸기/순서 변경/삭제/트리거에 다시 재생 추가

  • 다시 재생 이름을 바꾸려면 속성 패널에서 다시 재생을 선택하고 Return(macOS) 또는 Enter(Windows) 키를 누르거나, 컨텍스트 메뉴에서 [이름 바꾸기]를 선택하고 이름을 변경한 다음 Return/Enter 키를 누르거나 텍스트 필드 바깥을 클릭합니다.
  • [다시 재생] 목록 내에서 다시 재생 순서를 변경하려면 다시 재생을 선택하여 세로로 드래그합니다. 
  • 다시 재생을 삭제하려면 [속성] 패널에서 다시 재생을 선택하고 Delete 키를 누릅니다. 선택한 다시 재생에 포함된 원본 테이크는 삭제되지 않습니다.
  • 트리거에 다시 재생을 추가하려면 [속성] 패널에서 다시 재생을 선택한 다음 드래그하여 [트리거] 패널에 드롭합니다. 다시 재생은 기존 트리거에 드롭하거나, 특정 트리거 바깥에 드롭하여 선택한 각 다시 재생에 대해 새 트리거를 만들거나, 교체 세트에 드롭하여 교체 세트에 트리거로 추가할 수 있습니다.

다시 재생 기록 및 재생

다시 재생은 대개 연결된 트리거(키, MIDI 노트 또는 버튼 컨트롤을 통해 호출 가능함)를 사용하여 만들지만 다시 재생을 직접 사용할 수도 있습니다.

다시 재생을 재생하려면 다음 중 하나를 수행합니다.

• [컨트롤] 패널에서 다시 재생의 트리거와 연결된 키, MIDI 노트 또는 버튼 컨트롤을 누릅니다.

• [속성] 패널에서 다시 재생 이름 옆에 있는 [재생] 버튼을 클릭합니다.

다시 재생에서 기록된 테이크는 재생되지만재생 헤드는이동하지 않습니다. [속성] 패널에서 다시 재생 이름 옆에 있는 작은 미터에 진행률이 표시됩니다.

팁: 다시 재생의 재생을 취소하려면재생 헤드를다른 시간으로 이동합니다.

다시 실행을 기록하려면 기록 시작 전이나 후에 다시 재생을 호출하고 기록이 완료되면 중지합니다. 

참고:

[1 프레임 테이크 기록] 및 [2 프레임 테이크 기록] 명령을 사용할 때는 다시 재생이 무시됩니다. 
[속성] 패널에서 선택한 다시 재생을 복사한 후 타임라인에 붙여넣으면 됩니다.

교체 세트에서 다시 재생 트리거 사용

교체 세트의 트리거를 비롯하여 어떤 트리거에나 다시 재생을 연결할 수 있습니다. 교체 세트의 기본 트리거와 연결한 다시 재생은 즉시 재생됩니다.

다시 재생 중지 및 유지

다시 재생에서는 기본적으로 기록된 테이크의 전체 지속 시간이 재생됩니다. 하지만 다시 재생을 트리거하는 시간만큼 재생이 진행되도록 제어할 수 있습니다.

참고:

이는 Cmd+1, 2 또는 3을 사용하여 만들어졌으며 편집된비짐/trigger 값이 없는 테이크에는 적용되지 않습니다. 이러한 상수에는 기본값인 중지/유지가 사용됩니다.

다시 재생이 재생되는 방식을 제어하려면 다시 재생을 선택한 다음 트리거가 종료될 때 옵션을 다음 중 하나로 설정합니다.

다시 재생 완료: 다시 재생을 트리거하는 시간에 관계없이다시 재생의기록된 테이크 전체 지속 시간이 재생됩니다.

다시 재생 중지/유지: 다시 재생의 테이크가 다시 재생 트리거를 중지할 때까지 재생됩니다. 다시 재생 지속 시간이 지난 후에도 트리거를 계속하면 블렌드 아웃 시간이 가장 최근인 테이크가 자동으로 확장됩니다. 블렌드 아웃되는 테이크 중에 다시 재생을 중지하는 경우 트리거가 중지되면 테이크가 블렌드 아웃됩니다.

퍼펫 레이어 정보

[퍼펫] 패널 왼쪽 세로 막대의 레이어 목록에는 다음 항목이 표시됩니다.

  • 키보드 트리거와 연결된 문자(레이어에 대해 키보드 트리거를 지정한 경우)
  • 퍼펫 레이어의 소스 퍼펫에 적용된 비헤이비어 수와 포함된 핸들 수

이러한 세부 정보를 확인하면 퍼펫 계층에서 비헤이비어 및 핸들이 있는 위치와, 다양한 동작(예: 레이어 표시/숨기기, 레이어 순환 등)을 트리거하기 위해 누를 수 있는 문자를 파악할 수 있습니다.

퍼펫 레이어 정보
퍼펫 레이어 정보

레이어 및 핸들 일치 개수

[프로젝트] 또는 [퍼펫] 패널에서 퍼펫을 선택하면 [속성] 패널에서 비헤이비어의 레이어 또는 핸들 매개 변수에 일치하는 항목의 수가 표시되며, 매개 변수를 돌려서 열면 구체적인 일치 항목이 표시됩니다. 

[얼굴] 비헤이비어에 대한 [보기] 매개 변수와 같이 레이어 및 핸들 매개 변수에 일치하는 값이 여러 개이면 매개 변수 툴팁의 개별 줄에 각 값이 표시됩니다.

레이어 숨기기 또는 표시

레이어의 눈 모양 아이콘을 클릭합니다. 숨겨진 레이어의 경우 눈 모양 아이콘이 흐리게 표시되며 렌더링되지 않습니다.

레이어 이름 바꾸기

왼쪽 세로 막대에서 레이어를 선택하고 숫자 키패드가 아닌 기본 키보드에서 Enter 키를 누른 후에 새 이름을 입력하고 Enter 키를 누르거나 텍스트 필드 바깥쪽을 클릭하여 변경 내용을 적용합니다. 편집 내용을 취소하려면 Esc 키를 대신 누릅니다. 레이어에 사용자 정의 이름이 있으면 레이어 이름 오른쪽에 흐린 색상으로 나타나는 원본/소스 이름을 확인할 수 있습니다.

참고:

[프로젝트] 패널의 프로젝트 항목과 달리, 계층에서 같은 레벨의 레이어는 이름이 같아도 됩니다.

퍼펫에 컨텐츠 추가

[프로젝트] 패널의 퍼펫이나 레이어를 [퍼펫] 패널에 열려 있는 퍼펫으로 드래그합니다. 열려 있는 퍼펫이 없으면 드롭한 항목이 새 퍼펫에 추가됩니다.

왼쪽 세로 막대에 항목을 드롭하는 경우 항목이 추가되는 계층 내 위치를 제어할 수 있습니다. 패널 오른쪽에 드롭하는 항목은 항상 퍼펫의 최상위 레벨에 추가됩니다. 드롭한 항목은 레이어가 되며 선택됩니다. 퍼펫 레이어와 달리 레이어는 해당 컨텐츠의 "평면화된" 표현입니다.

참고:

퍼펫을 레이어로 추가할 때는 레이어를 돌려서 열어 추가한 퍼펫 내의 레이어를 표시하고 현재 퍼펫의 컨텍스트 내에서 해당 퍼펫의 레이어를 수정할 수 있습니다. 이와 같이 수정하면 추가한 퍼펫의 마스터 정의가 수정되므로 주의하십시오.

혼합 모드

혼합 모드에서는 레이어와 하위 레이어 간의 상호 작용 방식을 제어합니다. Character Animator에서는 퍼펫의 레이어나 그룹에 적용할 수 있는 혼합 모드 집합을 제공합니다. 불투명도를 설정하고 다양한 혼합 모드를 적용하여 여러 가지 결과를 확인해 볼 수 있습니다.

혼합 모드를 조정하려면 다음 단계를 따르십시오.

  1. 퍼펫 패널에서 레이어나 그룹을 선택합니다.

  2. 속성 패널에서 레이어 섹션을 선택하고 불투명도 혼합 모드를 조정합니다.

     

    아래의 설명에서는 다음과 같은 용어가 사용됩니다.

    • 소스 색상은 혼합 모드를 적용할 레이어의 색상입니다.
    • 기본 색상은 소스 레이어 아래에 있는 합성된 레이어의 색상입니다.
    • 결과 색상은 혼합 작업의 출력, 즉 컴포지션의 색상입니다.

    참고:

    Photoshop 또는 Illustrator에서 만든 퍼펫의 혼합 모드 및 불투명도 설정을 편집할 수 있습니다. Character Animator에서는 Illustrator 작품 파일의 혼합 모드 및 불투명도를 변경할 수 없습니다. 작품 파일에서 지원되지 않는 혼합 모드는 퍼펫 패널에서 표준 모드로 기본 설정됩니다.

    혼합 모드 설명
    통과 그룹에한해 그룹 내의 레이어 혼합 모드와 불투명도를 조정하여 해당 그룹 하위의 레이어에도 조정 내용을 적용할 수 있습니다.
    표준 혼합 및 불투명도가 그룹의 레이어가 아닌 레이어에 적용되지 않도록 제한하려면 그룹의 혼합 모드를 [표준]으로 변경합니다.
    표준 특정 혼합 모드가 적용되지 않습니다. 결과색상은소스 색상입니다. [표준]은 기본 모드입니다.
    어둡게 각 채널의 색상 정보를 읽어 소스 색상과 기본 색상 중에 더 어두운 색상을 확인합니다. 더 어두운 색상이결과색상입니다.
    곱하기 각 채널의 색상 정보를 읽어 소스 색상에 기본 색상을 곱합니다. 결과색상은더 어두운 색상입니다. 어떤 색상이든 검정과 곱하면 더 어두운 색상이 되고 흰색과 곱하면 색상이 변경되지 않습니다. 조명 앞에 젤을 여러 개 놓는 경우를 예로 들 수 있습니다.
    색상 번 각 채널의 색상 정보를 읽은 다음 대비를 높여 기본 색상을 반영하도록 소스 레이어를 어둡게 변경합니다. 흰색과 혼합하면 색상 변화가 없습니다. 
    선형 번 채널의 색상 정보를 읽은 다음 명도를 줄여 기본 색상을 반영하도록 소스 색상을 어둡게 변경합니다. 흰색과 혼합하면 색상 변화가 없습니다.
    더 어두운 색상 [더 어두운 색상]은 [어둡게]와 비슷하지만 개별 RGB 색상 채널이 아닌 합성 색상 채널을 읽습니다. 이 혼합 모드에서는 소스 색상과 기본 색상에서 값이 가장 작은 색상을 추출하여 결과 색상을 만듭니다. 
    밝게 하기 각 채널의 색상 정보를 읽어 소스 색상과 기본 색상 중에 더 밝은 색상을 확인합니다. 더 밝은 색상이결과색상입니다.

    화면 각 채널의 색상 정보를 읽고소스색상의 보색을 기본 색상과 곱합니다. 결과색상은더 밝은 색상입니다. [화면] 모드를 사용하는 것은 단일 화면에 여러 사진 슬라이드를 동시에 투영하는 것과 비슷합니다. 
    색상 닷지 채널의 색상 정보를 읽은 다음 대비를 줄여 기본 색상을 반영하도록 소스 색상을 밝게 변경합니다. 소스 색상이순수한 검정인경우결과색상은 기본 색상입니다. 
    선형 닷지(추가) 채널의 색상 정보를 읽은 다음 명도를 높여 기본 색상을 반영하도록 소스 색상을 밝게 변경합니다. 검정과 혼합하면 색상 변화가 없습니다. 
    더 밝은 색상 [더 밝은 색상]은 [밝게 하기]와 비슷하지만 개별 RGB 색상 채널이 아닌 합성 색상 채널을 읽습니다. 이 혼합 모드에서는 소스 색상과 기본 색상에서 값이 가장 큰 색상을 추출하여 결과 색상을 만듭니다.

    오버레이  소스 색상이 기본 색상보다 어두우면 두 색상을 곱하고, 소스 색상이 기본 색상보다 밝으면 [화면] 모드를 적용합니다. 고채도 색상을 생성합니다. 50% 회색과 혼합하면 색상 변화가 없습니다.
    소프트 라이트 소스 색상에 따라 기본 레이어의 색상 채널 값을 어둡게 하거나 밝게 합니다. 결과는 기본 레이어에서 확산된 집중 조명을 비추는 것과 비슷합니다. 소스 색상이 50% 회색보다 밝으면결과색상은 닷지된 것처럼 기본 색상보다 밝아집니다. 소스 색상이 50% 회색보다 어두우면결과색상은 번된 것처럼 기본 색상보다 어두워집니다.
    하드 라이트 기본 색상이 50% 회색보다 어두우면 색상을 곱하고, 50% 회색보다 밝으면 [화면] 모드를 적용합니다. 결과는 레이어에서 강한 집중 조명을 비추는 것과 비슷합니다.  
    생생한 라이트 기본 색상에 따라 대비를 증가 또는 감소시켜 색상을 번하거나 닷지합니다. 기본 색상이 50% 회색보다 밝으면 대비가 감소하므로 레이어가 밝아지고, 기본 색상이 50% 회색보다 어두우면 대비가 증가하므로 레이어가 어두워집니다.

    선형 라이트 기본 색상에 따라 명도를 증가 또는 감소시켜 색상을 번하거나 닷지합니다. 기본 색상이 50% 회색보다 밝으면 명도가 증가하므로 레이어가 밝아지고, 기본 색상이 50% 회색보다 어두우면 명도가 감소하므로 레이어가 어두워집니다.
    핀 라이트 기본 색상에 따라 색상을 바꿉니다. 기본 색상이 50% 회색보다 밝으면 기본 색상보다 어두운 픽셀은 바뀌고 기본 색상보다 밝은 픽셀은 변경되지 않습니다. 기본 색상이 50% 회색보다 어두우면 기본 색상보다 밝은 픽셀은 바뀌고 기본 색상보다 어두운 픽셀은변경되지않습니다.
    차이 각 색상 채널에서 색상 정보를 확인하여 더 어두운 색상에서 더 밝은 색상을 뺍니다. 흰색과 혼합하면 배경 색상이 반전되고 검정과 혼합하면 색상 변화가 없습니다.
    제외
    [차이] 혼합 모드와 유사하지만 대비가 더 낮은 결과를 만듭니다. 소스 색상이 흰색이면결과색상은 기본 색상의 보색입니다. 소스 색상이 검정이면결과색상은 기본 색상입니다.
    빼기 기본 색상에서 소스 색상을 뺍니다. 소스 색상이 검정이면결과색상은 기본 색상입니다.
    나누기 기본 색상을 소스 색상으로 나눕니다. 소스 색상이 흰색이면결과색상은 기본
    색상입니다.

그룹 재사용

  1. [퍼펫] 패널의 레이어 목록(왼쪽)에 있는 그룹을 컨텍스트(마우스 오른쪽 버튼) 클릭한 다음 [공유 가능 항목으로 지정]을 선택합니다. 레이어의 소스 그룹 항목이 표시되어 [프로젝트] 패널에서 선택됩니다. 소스 항목이 [퍼펫] 패널에 이미 표시되어 있으면 메뉴 명령이 비활성화됩니다.
  2. [퍼펫] 패널에서 다른 퍼펫을 엽니다.

참고:

Photoshop 또는 Illustrator 작품을 가져와서 대상 퍼펫을 만든 경우, 작품의 구조적 컨텐츠 변경으로 인해 [퍼펫] 패널에서 수행한 레이어 수정 내용이 손실되는 현상을 방지하기 위해 퍼펫의 [속성] 패널에서 "작품과 자동 동기화" 옵션을 해제할 수 있습니다. 또는 [비어 있는 새 퍼펫]을 만들어서 대신 엽니다.

  1. 표시된 소스 항목을 [퍼펫] 패널로 드래그합니다.

레이어의 순서 변경

레이어의 순서를 변경하려면 세로 막대 내의 형제 레이어를 기준으로 하여 레이어를 세로로 드래그합니다.

참고:

레이어를 퍼펫 외부나 다른 그룹 안으로 드래그할 수는 없습니다.

레이어 속성 수정

위치, 배율, 회전 등의 레이어 속성을 변경하려면 다음을 수행하십시오. 
  1. 왼쪽 세로 막대에서 레이어를 선택합니다.
  2. [속성] 패널에서 다음과 같은 레이어별 속성을 조정합니다.
    • 원본 변형을 기준으로 하는 레이어의[X] 및 [Y](위치),[X 배율] 및 [Y 배율](크기), 불투명도, [회전](회전). 선택한 레이어를 회색으로 강조 표시된 영역 안쪽으로 드래그하는 방식으로 재배치할 수도 있습니다.
    • 개별적으로 뒤틀기: 그룹이 퍼펫의 다른 레이어와 동일한 고무 시트에서 뒤틀리는지 여부를 제어합니다.
    • 연결 대상: 팔과 함께 이동하려는 손 그룹이 있는 등의 경우 핸들이 연결된 상태로 유지되도록 제어합니다.
    • 트리거 섹션: 레이어를 표시하거나 레이어 순환을 시작하는 데 사용할 트리거 키를 지정합니다. 자세한 내용은 키보드 트리거 편집 섹션을 참조하십시오.
  3. 레이어와 연관된 뒤틀기 메쉬를 수정하려면 [레이어 메쉬] 섹션에서 다음 속성을 조정합니다.
    • [메쉬 모양]: 소스 퍼펫의 뒤틀기 메쉬 형태를 제어합니다. [직사각형]은 컨텐츠의 직사각형 테두리 상자를 사용하며 [윤곽선]은 컨텐츠의 윤곽선을 따릅니다. [자동](기본값)은 대부분의 경우 [윤곽선]을 자동으로 사용하거나, 연결이 끊긴 컨텐츠가 감지되면[직사각형]을사용합니다.
    • [메쉬 확장]은 레이어의 경계(윤곽선 또는 직사각형)에서 메쉬를 확장할 픽셀 수를 지정합니다. 확장 값이 클수록 곡선 가장자리가 잘려서 표시될 가능성을 줄일 수 있지만, 캐릭터의 다리와 같이 개별적으로 뒤틀어야 하는 영역이 함께 뒤틀릴 수 있습니다.
  4. 퍼펫 레이어를 선택하는 경우 [비헤이비어] 섹션에서 소스(마스터) 퍼펫에 대해 적용되는 비헤이비어를 조정합니다. [프로젝트] 패널에서 퍼펫 항목을 선택한 것처럼 비헤이비어를 추가/제거하거나 비헤이비어 매개 변수 값을 조정할 수 있습니다. 자세한 내용은 비헤이비어를 사용하여 퍼펫 제어를 참조하십시오.

참고:

이 경우 소스가 변경되므로 장면에서 해당 퍼펫의 모든 인스턴스 및 다른 퍼펫에 변경 내용이 적용됩니다.

  1. 레이어를 선택하는 경우 작품의 보다 정확한 표현을 사용하려면 [벡터로 렌더링] 옵션을 활성화합니다.

참고:

이 경우 소스 항목이 변경되므로 다른 퍼펫에 있는 해당 레이어의 모든 인스턴스에 변경 내용이 적용됩니다.

퍼펫에서 레이어 제거

퍼펫을 선택한 다음 Delete 또는 백스페이스 키를 누르거나 [편집] > [삭제]를 선택합니다.

참고:

레이어를 제거해도 디스크의 원본 작품에는 영향이 없습니다.

퍼펫 내에서 뒤틀기를 수행하면 해당 레이어에 영향을 주는 반면 키 트리거 대체와 같은 기능을 사용하려면 그룹이 필요합니다. 원하는 수의 레이어를 그룹으로 조합할 수 있습니다.

클리핑 마스크를 사용하여 레이어 마스킹

클리핑 마스크를 사용하면 레이어의 컨텐츠로 위쪽의 레이어를 마스킹할 수 있습니다. 하위 레이어(기본 레이어)의 컨텐츠에 따라 마스킹이 결정됩니다. 기본 레이어의 투명하지 않은 컨텐츠가 클리핑 마스크에서 위에 있는 레이어의 컨텐츠를 클리핑(표시)합니다. 클리핑된 레이어의 기타 모든 컨텐츠는 마스킹 처리됩니다.

클리핑 마스크에서 여러 레이어를 사용할 수는 있지만 이 경우에는 해당 레이어가 연속해야 합니다. 마스크의 기본 레이어 이름에는 밑줄이 표시되며, 그 위에 있는 레이어의 이름은 들여쓰기됩니다. 기본 레이어 위에 있는 레이어에는 클리핑 마스크 아이콘이 표시됩니다.

클리핑 마스크를 만들려면 다음 단계를 수행합니다.

  1. 퍼펫 패널에서 마스크를 포함하는 레이어가 마스킹할 레이어 아래에 배치되도록 레이어를 정렬합니다.

  2. 마스킹할 레이어를 선택하고 퍼펫 > 클리핑 마스크 만들기(Cmd+Option+G(Mac) 또는 Ctrl+Alt+G(Windows)를 선택합니다. 여러 레이어를 선택한 경우 레이어 목록에서 인접해 있으며 그룹의 마지막 레이어를 포함하지 않는다면 마스킹이 가능합니다.

    참고:

    클리핑 마스크에서 레이어 사이에 삽입하는 레이어는 위에 있는 레이어의 기본 레이어가 되며 클리핑되지 않습니다.

    퍼펫 패널에서 마스크의 기본 레이어 이름에는 밑줄이 표시되며, 그 위에 있는 레이어의 이름은 들여쓰기됩니다. 기본 레이어 위에 있는 레이어에는 클리핑 마스크 아이콘도 표시됩니다.

    클리핑 마스크를 사용하여 레이어 마스킹
    클리핑 마스크를 사용하여 레이어 마스킹

클리핑 마스크의 레이어 해제

레이어에서 클리핑 마스크를 해제하려면 다음 단계를 수행합니다.

  1. 기본 레이어 위에 있는 연속하는 클리핑 마스크 레이어( 아이콘이 있는 레이어)를 모두 선택합니다.

  2. 퍼펫 > 클리핑 마스크 해제(Cmd+Option+G(Mac) 또는 Ctrl+Alt+G(Windows)를 선택합니다.

참고:

Photoshop 작품에서 만들어 Character Animator로 가져오는 클리핑 마스크는 [퍼펫] 패널에서 변환됩니다. Illustrator 작품(<클립 그룹>)을 사용하여 만드는 클리핑 마스크는 [퍼펫] 패널에서 클리핑 마스크로 변환되지 않습니다. 그러나 [퍼펫] 패널에서 Illustrator에서 가져온 레이어에서 클리핑 마스크를 만들 수는 있습니다.

레이어 집합 그룹화

  1. 레이어를 선택하고 퍼펫 > 그룹 레이어(Cmd/Ctrl+G)를 선택합니다.
  2. (권장) 새 그룹의 이름을 보다 자세한 설명이 포함된 이름으로 바꿉니다. 하위 퍼펫은 장면에서 개별 퍼펫으로 바로 사용할 수 있습니다. 새 퍼펫 레이어가 기본적으로 새 이름을사용하도록만들어진 "그룹" 프로젝트 항목의 이름을 바꾸는 것이 가장 좋습니다. 퍼펫 레이어의 이름을 직접 바꿔도 소스 퍼펫 항목의 이름이 업데이트되지는 않습니다.

개별 그룹 자동 첨부

캐릭터의 몸통이나 다른 부분과 겹치는 팔, 다리 또는 기타 부위와 같은 개별 그룹을 부모에 자동으로 첨부하면 이러한 개별 부분으로 퍼펫을 원활하게 리깅할 수 있습니다. 새로 가져온 작품의 경우 그룹을 첨부할 위치에 그룹 원점을 배치합니다. 즉, 그룹을 수동으로 고정하거나 추가 고정 핸들을 사용할 필요가 없습니다. [퍼펫] 패널에는 이러한 개별 그룹이 부모 그룹의 메쉬에 첨부되는 방식을 표시하는 데 도움이 되는 시각화도 있습니다.

개별 그룹을 퍼펫 부모 그룹의 메쉬에 자동으로 첨부하려면 다음 단계를 수행합니다.

  1. 퍼펫 패널에서 개별 그룹을 선택합니다.

  2. [속성] 패널의 레이어 섹션 아래에서 연결 대상자동으로 설정합니다.

    [자동]은 작품 파일에 특정 연결 대상 설정이 없는 새로 가져온 작품의 기본 설정입니다. 또한 이제 기본 첨부 스타일 설정은 퍼펫에 최상위 레벨 개별 그룹(예: 작품 파일의 "+캐릭터")만 있는 경우를 제외하고는 용접입니다. 퍼펫에 최상위 레벨 개별 그룹만 있는 경우 최상위 레벨 그룹은 무료로 설정됩니다.
    팁: 퍼펫에서 사용 가능한 모든 연결 점을 일시적으로 표시하려면 [연결 대상] 드롭다운 목록을 가리킵니다.

  3. 부모 그룹의 메쉬와 겹치도록 그룹 위치를 조정한 다음 부모에 그룹을 첨부할 위치로 그룹의 원점 핸들을 이동합니다.

    그룹 자동 첨부
    그룹 자동 첨부
  4. 이제 부모에 첨부할 그룹을 배치할 위치로 그룹 원점 핸들을 이동합니다.

  5. 그룹이 부모 그룹에 자동으로 첨부됩니다.

    참고:

    베타 6 이하 버전 프로젝트와 .puppet 파일은 변환되지 않습니다. [매달기] 핸들이 포함된 개별 그룹을 무료 첨부 스타일을 사용하여 첨부하는 경우 장면에 퍼펫이 처음 표시될 때 해당 그룹에서오류가발생합니다. 이러한 경우에는 필요에 따라 경첩 또는 용접으로 전환합니다.

클리핑 마스크의 레이어 해제

레이어에서 클리핑 마스크를 해제하려면 다음 단계를 수행합니다.

  1. 기본 레이어 위에 있는 연속하는 클리핑 마스크 레이어(아이콘이 있는 레이어)를 모두 선택합니다.

  2. 퍼펫 > 클리핑 마스크 해제(Cmd+Option+G(Mac) 또는 Ctrl+Alt+G(Windows)를 선택합니다.

참고:

Photoshop 작품에서 만들어 Character Animator로 가져오는 클리핑 마스크는 [퍼펫] 패널에서 변환됩니다. Illustrator 작품()을 사용하여 만드는 클리핑 마스크는 [퍼펫] 패널에서 클리핑 마스크로 변환되지 않습니다. 그러나 [퍼펫] 패널에서 Illustrator에서 가져온 레이어로 클리핑 마스크를 만들 수는 있습니다.

레이어 첨부 스타일 옵션

[퍼펫] 패널에서 레이어를 선택하고 [개별적으로 뒤틀기] 옵션을 선택하면 새 [첨부 스타일] 컨트롤과 함께 [연결 대상] 컨트롤이 활성화됩니다. 다음 첨부 스타일을 사용할 수 있습니다.

  • [용접]: 원점을 중심으로 레이어를 이동/회전하거나 배율을 조정할 수 없습니다.
  • [경첩]: 레이어를 회전할 수는 있지만 원점을 중심으로 이동하거나 배율을 조정할 수는 없습니다.
  • [무료]: 원점을 중심으로 레이어를 자유롭게 이동/회전하고 배율을 조정할 수 있습니다.

첨부 스타일

첨부 스타일

레이어 핸들

[퍼펫] 패널의 툴을 사용하여 핸들을 만들 수 있습니다. 핸들의 비헤이비어를 제어하면 퍼펫을 조작할 수 있습니다.

퍼펫의 핸들 보기

모든 레이어를 선택 취소하거나([퍼펫] 패널 왼쪽의 최상위 제목을 선택해도 됨) 그룹 레이어를 선택합니다. 뒤틀기 가능한 동일한 메쉬에 참여하며, 열려 있거나 선택한 그룹에 있는핸들은노란색 원으로 나타납니다.

[퍼펫] 패널에서 만든 핸들의 경우 원 가운데에 점이 있습니다. 이러한 핸들은 삭제/이동할 수 있으며 이름을 바꿀 수 있습니다. 작품 파일에 지정된 핸들의 경우 점이 없으며 이동하거나 이름을 바꿀 수 없습니다. 윤곽선이 실선인 핸들은 삭제할 수 있습니다. 윤곽선이 파선인 핸들은 원점 핸들을 나타내며 삭제할 수 없습니다.

핸들 태그

[퍼펫] 패널에서 퍼펫의 오른쪽에는 핸들 태그가 표시되고 [속성] 패널에는 텍스트 기반 태그가 표시됩니다. 핸들 태그는 핸들 오른쪽에 큰 텍스트로 표시됩니다. 핸들 아래쪽 가운데의 작은 텍스트가 핸들 이름입니다. 태그와 비슷한 이름이 지정된 작품 가이드의 경우 기본적으로 [퍼펫] 패널에서 이름이 지정되지 않습니다.

핸들 선택 또는 선택 취소

핸들을 선택하거나 선택 취소하려면 [선택] 툴로 전환하여 다음 중 하나를 수행합니다.
  • 핸들을 클릭하여 선택합니다.
  • Shift 키를 누른 상태로 핸들을 클릭하여 선택 영역을 확장합니다.
  • 핸들 주위로 선택(움직이는 텍스트) 상자를 드래그합니다. 선택 영역을 확장하려면 Shift 키를 누른 상태로 드래그합니다.
  • 핸들 바깥쪽을 클릭하여 모든 핸들의 선택을 취소합니다.

핸들 다시 배치

핸들을 다시 배치하려면 핸들을 선택한 다음 원하는 위치로 드래그합니다.

참고:

작품 파일에서 제공되며 원 가운데에 노란색 점이 없는 읽기 전용 위치는 이동할 수 없습니다.

퍼펫의 원점 핸들을 다시 배치하려면 기본적으로 파선 원으로 표시되며 퍼펫 이름이 지정된 핸들을 선택한 다음 원하는 위치로 드래그합니다. Photoshop 또는 Illustrator 작품 파일의 원점 위치는 업데이트하지 않아도 됩니다. 그룹에 대해 [용접] 또는 [경첩] 첨부 스타일을 사용할 때는 원하는 기준 또는 피벗 위치에 그룹의 원점을 배치할 수 있습니다.

참고: 원점 핸들 위치를 퍼펫의 경계 중심이나 작품 파일의 특정 위치로 재설정하려면 핸들을 선택하고 Delete 키를 누릅니다.

핸들 이름 바꾸기

핸들 이름을 바꾸려면 해당 핸들을 선택하고 숫자 키패드가 아닌 기본 키보드에서 Enter 키를 누른 후에 새 이름을 입력하고 Enter 키를 누르거나 텍스트 필드 바깥쪽을 클릭하여 변경 내용을 적용합니다. 편집 내용을 취소하려면 Esc 키를 대신 누릅니다.

[퍼펫] 패널의 툴 사용

[퍼펫] 패널에서 핸들을 만들려면 다음 툴 중 하나를 사용합니다.

  • [핸들] 툴: 원하는 위치에서 클릭합니다. 특정 비헤이비어에서 사용하거나 그룹의 연결 점으로 사용하기 위해 핸들의 태그를 변경할 수 있습니다.
  • 고정 툴: 레이어를 클릭하여 고정의 한쪽 끝을 지정한 다음 원하는 고정의 반대쪽 끝으로 드래그합니다. 그러면 "고정" 태그가 있는 고정 핸들이 만들어집니다. 팔이나 다리를 구부리는 경우를 예로 들 수 있습니다. 고정을 가로지르도록 시트를 변형해서는 안 됩니다.
  • 고정 툴: 레이어 위쪽의 위치를 클릭하여 핸들이 뒤틀리지 않도록 제한합니다. 그러면 "고정" 태그가 있는 핸들이 만들어집니다.
  • 드래거 툴: 뒤틀기 가능 레이어 위쪽을 클릭하여 [드래거] 비헤이비어 사용을 제어합니다. 그러면 "드래그 가능" 태그가 있는 핸들이 만들어집니다.
  • 매달기 툴: 뒤틀기 가능 레이어 위쪽을 클릭하여 [매달기] 비헤이비어를 사용해 핸들을 좌우로 흔듭니다. 그러면 "매달기" 태그가 있는 핸들이 만들어집니다.

[고정], [드래거], [매달기] 및 [고정] 툴은 [핸들] 툴이 수행하는 작업을 수행하며 특정 용도에 사용할 수 있도록 만들어진 핸들에 태그도 추가하는 특수 툴입니다.

핸들에 태그 적용

원점 핸들에 태그를 적용할 수 있습니다. 예를 들어 마우스나 손가락(터치 스크린)으로 퍼펫을 드래그할 수 있도록 하려면 원점 핸들을 선택하고 [드래그 가능] 핸들 태그를 할당합니다. 

레이어 또는 핸들의 태그를 편집하려면 다음을 수행하십시오.

  1. [퍼펫] 패널에서 레이어나 핸들을 선택합니다.
  2. [속성] 패널의 [태그] 섹션에서 선택 영역과 연관시킬 기능을 선택하거나 선택 취소합니다.

참고:

  • 태그를 선택할 때는 이전과 마찬가지로 이러한 태그를 사용하는 해당 비헤이비어를 퍼펫 계층의 동급 이상 레벨에 적용해야 합니다. 예를 들어 핸들에 대해 [가슴] 태그를 선택하는 경우 부모 퍼펫에 [숨쉬기]도 적용해야 작업이 수행됩니다.
  • 작품 파일의 계층 구조 및 레이어 이름이 변경되면 해당하는 레이어와 연결된 모든 태그가 재설정됩니다. 그러나 레이어 컨텐츠를 변경하는 경우에는 [퍼펫] 패널에서 변경된 모든 태그가 유지됩니다.

레이어를 선택할 때는 레이어 또는 핸들 태그를 둘 다 적용할 수 있으며, 핸들 태그는 선택한 그룹의 원점 핸들이나 레이어의 부모 퍼펫에 적용할 수 있습니다. 핸들을 선택할 때는 핸들 태그만 적용할 수 있습니다.

태그를 텍스트로 표시할 때 적용된 레이어 태그는 파란색으로, 핸들 태그는 노란색으로 나타납니다. 태그를 사진으로 표시할 때 적용된 태그는 파란색으로 나타납니다.

참고:

고정 핸들은 [드래그 가능] 핸들을 지정하여 다른 핸들처럼 수정할 수 있습니다.

핸들 제거

핸들을 제거하려면 해당 핸들을 선택하고 Delete 또는 백스페이스 키를 누르거나 편집 > 삭제를 선택합니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책