Character Animator의 다양한 내보내기 옵션

장면을 취합한 후에는 After Effects 또는 Premiere Pro 등의 다른 애플리케이션에서 사용하기 위해 내보낼 수 있습니다. 또한 Adobe Media Encoder를 통해 모니터링하는 감시 폴더로 장면을 내보내 장면 렌더링 프로세스를 자동화할 수 있으며, Adobe Media Encoder에서 지원하는 모든 포맷으로 장면을 내보낼 수 있습니다. 기본 내보내기 포맷은 소스 일치 - 높은 비트 전송률 사전 설정을 사용하는 H.264입니다. 아래 내용을 읽고 내보낸 장면을 다른 애플리케이션으로 가져오는 방법, 다른 사용자와 함께 퍼펫을 내보내고 공유하는 방법, After Effects로 립싱크 내보내기를 수행하는 방법에 대해 자세히 알아보십시오.

Dynamic Link를 사용하면 After Effects 또는 Premiere Pro에서 장면을 직접 열고 Character Animator의 원본 장면에 대한 라이브 연결을 유지할 수 있습니다. Character Animator에서 장면을 변경한 내용은 After Effects 또는 Premiere Pro로 다시 전환할 때 자동으로 반영됩니다.

Dynamic Link를 통해 After Effects 또는 Premiere Pro에서 장면을 가져오려면 다음 작업 중 하나를 수행합니다.

  • Character Animator의 [프로젝트] 패널에 있는 장면을 After Effects 또는 Premiere Pro의 [프로젝트] 패널로 드래그합니다. Character Animator에서 장면 드래그를 시작하고 Alt/Command+Tab을 눌러 After Effects 또는 Premiere Pro로 전환한 다음 [프로젝트] 패널에 장면을 드롭해도 됩니다.
  • 다음과 같이 .chproj 파일에서 장면을 가져옵니다.
  1. After Effects에서 파일 > 가져오기 > 파일을 선택하거나, Premiere Pro에서 파일 > 가져오기를 선택하거나, 두 애플리케이션 중 하나에서 미디어 브라우저를 사용하여 가져올 Character Animator 프로젝트의 .chproj 파일을 선택합니다.

  2. 프로젝트 내에서 가져올 장면을 선택합니다.

    장면은 다른 비디오 푸티지와 마찬가지로 컴포지션이나 시퀀스에 추가할 수 있는 Dynamic Link 비디오 푸티지로 [프로젝트] 패널에 나타납니다. After Effects 또는 Premiere Pro에서 장면을 사용하는 동안 Character Animator를 실행할 필요가 없습니다.

Dynamic Link를 사용하여 내보내기

Dynamic Link를 사용하여 내보내기
Dynamic Link 사용하여 프로젝트를 내보내는 방법 알아보기

다른 애플리케이션으로 가져올 수 있는 파일 포맷으로 내보내기

Adobe Media Encoder를 통해 동영상 포맷(H.264)으로 직접 내보내거나 PNG 시퀀스 및 WAV 파일로 내보낼 수 있습니다. 내보낸 동영상 파일은 즉시 재생할 수도 있고, PNG/WAV 파일과 같이 나중에 사용하기 위해 다른 애플리케이션으로 가져올 수도 있습니다. After Effects 및 Premiere Pro에서 사용하는 경우에는 PNG 이미지 시퀀스 및 개별 오디오 파일보다 단일 동영상 파일을 더 쉽게 가져오고 관리할 수 있습니다. 장면 프레임을 PNG로 내보내도록 선택할 수도 있습니다.

Adobe Media Encoder를 통해 동영상 파일로 장면 내보내기

Adobe Media Encoder를 통해 장면을 Character Animator에서 동영상 포맷으로 직접 내보낼 수 있습니다. 기본 동영상 포맷은 H.264입니다.

  1. 장면을 선택하거나 연 다음 [속성] 패널에서 장면의 지속 시간을 조정하여 내보낼 프레임을 제한합니다.

    장면 지속 시간은 [타임라인] 패널에서 더 밝은 배경으로 표시됩니다.

  2. 파일 > 내보내기 > Adobe Media Encoder를 통해 비디오를 선택하고 파일의 위치와 파일 이름을 지정합니다.

    Adobe Media Encoder가 시작되고 장면의 항목이 대기열에 추가됩니다. Adobe Media Encoder를 처음 시작하는 경우 몇 초 정도 걸릴 수 있습니다. 또한 Adobe Media Encoder 창이 맨 앞으로 이동하지 않을 수 있어 해당 창으로 직접 전환해야 할 수도 있습니다.

  3. Adobe Media Encoder에서 대기열에 추가된 항목의 설정을 조정한 다음 [대기열 시작](녹색 재생) 버튼을 클릭합니다.

    기본 내보내기 포맷은 "소스 일치 - 높은 비트 전송률" 사전 설정을 사용하는 H.264이지만 필요한 경우 포맷을 변경할 수 있습니다.

    렌더링된 동영상 파일은 즉시 재생할 수도 있고 나중에 사용하기 위해 다른 애플리케이션으로 가져올 수도 있습니다.

PNG 시퀀스 및 WAV 파일로 장면 내보내기

  1. 장면을 선택하거나 엽니다.

  2. 파일 > 내보내기 > PNG 시퀀스 및 WAV (Command+Option+M / Ctrl+Alt+M)을 선택하고 기록된 장면이 저장될 위치와 기본 파일 이름을 지정합니다. 기본 파일 이름은 장면 이름으로 기본 지정됩니다.

    Mac에서 기존 하위 폴더의 이름을 지정하는 경우 해당 이름을 바꾸라는 메시지가 표시됩니다. Windows에서는 기존 하위 폴더 이름을 지정하면 해당 하위 폴더로 이동하게 됩니다. 

    내보내기를 수행하는 동안에는 카메라 및 마이크 입력을 사용할 수 없습니다.

    지정한 이름에 따라 하위 폴더가 자동으로 만들어지며 파일(PNG 시퀀스 및 스테레오 48kHz WAV 파일)이 해당 폴더에 저장됩니다. 그리고 하위 폴더가 자동으로 열립니다.하위 폴더 옆에만들어지는.xml 파일을 사용하면이러한 파일을 가져올 수 있는 애플리케이션으로 하위 폴더의 컨텐츠를 가져올 수 있습니다.

장면 프레임 내보내기

장면 패널에서 현재 시간의 장면 컨텐츠를 PNG 이미지 파일로 내보낼 수 있습니다.
현재 장면 프레임을 내보내려면 파일 > 내보내기 > 프레임(Command+Option+S/Ctrl+Alt+S)을 선택합니다. PNG파일의위치와 이름을 지정할 수 있습니다.

참고:

장면 패널의 배경색은 저장되지 않으며 PNG 파일에는 투명한 배경이 적용됩니다. 또한 퍼펫 메쉬(표시되는 경우)는 파일에 나타나지 않습니다.

내보낸 장면을 다른 애플리케이션으로 가져오기

After Effects로 장면 가져오기

수동으로 PNG 파일과 WAV 파일을 Character Animator에서 After Effects로 가져와야 합니다. PNG 시퀀스를 가져올 때는 Character Animator 장면의 프레임 속도와 일치하도록 푸티지를 해석합니다.

Premiere Pro로 장면 가져오기

내보낸 .xml 파일을 [프로젝트] 패널로 가져옵니다. PNG 시퀀스와 WAV 파일이 포함된 시퀀스가 만들어집니다.

Adobe Media Encoder로 장면 가져오기

내보낸 .xml 파일을 [대기열] 패널에 추가한 다음 포맷 설정과 출력 파일을 조정합니다.

참고:

내보낸 .xml 파일의 PNG 시퀀스 및 WAV 파일을 자동으로 동영상 또는 스틸 이미지 포맷으로 인코딩하는 감시 폴더를 설정할 수도 있습니다.

퍼펫을 내보내 다른 사용자와 공유

다른 Character Animator 사용자에게 퍼펫을 보내거나 다른 프로젝트에서 다시 사용하기 위해 퍼펫 구조를 보관하려는 경우 공유 가능한 퍼펫, 즉 필요한 모든 작품이 들어 있는 자체 포함 파일을 만듭니다.

퍼펫을 공유하려면 다음 단계를 수행합니다.

  1. [프로젝트] 패널에서 퍼펫을 선택하거나 [퍼펫] 패널에서 [프로젝트] 패널의 퍼펫을 엽니다.
  2. 파일 > 내보내기 > 퍼펫을 선택하고 .puppet 파일의 이름을 지정하거나 프로젝트 패널에서 퍼펫을 마우스 오른쪽 버튼으로 클릭하고 퍼펫 내보내기를 선택합니다.
  3. 공유 링크 또는 다른 방법을 통해 다른 사용자에게.puppet파일을보냅니다.
  4. 공유 퍼펫을 열려면 파일 > 가져오기를 선택하거나 .puppet 파일을 [프로젝트] 패널로 드래그하여 가져옵니다.

참고: 공유 가능한 퍼펫은 연결된 작품이 들어 있는 자체 포함 파일입니다. 필요한 경우 퍼펫을 작품의 공유 인스턴스에 다시 연결할 수 있습니다. 타임라인에서 선택한 퍼펫의 매개 변수를 변경한 내용이나 퍼펫 트랙에 대해 기록된 테이크는 .puppet 파일에 포함되지 않습니다. 또한 가져온 퍼펫의 비헤이비어는 현재 프로젝트에서 사용 가능한 비헤이비어 버전을 사용하도록 업데이트됩니다. 

다른 디바이스 또는 애플리케이션으로 장면 라이브 스트리밍

외부 모니터 또는 서드 파티 비디오 디바이스에 화면을 표시하려면 [라이브 스트리밍] 옵션을 사용합니다. Facebook Live, YouTube 등의 다른 애플리케이션으로 장면을 보내 라이브 스트리밍을 사용하여 라이브 애니메이션을 브로드캐스트할 수도 있습니다. 스트리밍에 대한 자세한 내용은 라이브로 장면 스트리밍을 참조하십시오. 스트리밍과 관련된 팁, 기법 및 해결 방법을 찾으려면 스트리밍 팁 및 기법을 참조하십시오.

립싱크: After Effects용으로 테이크 내보내기

Character Animator비짐을다른 캐릭터에 사용하기 위해 After Effects로 가져오려면 다음 단계를 수행합니다.

  1. 타임라인 패널에서 립싱크 테이크 를 마우스 오른쪽 버튼으로 클릭하고 After Effects용으로 비짐 복사를 선택합니다. 모든비짐데이터가 After Effects에서 사용할 수 있도록 시간 다시 매핑 키프레임 데이터로 시스템 클립보드에 복사됩니다.

  2. After Effects에서 서로 다른 여러 비짐이 포함된 컴포지션을 설정합니다. 비짐은 1초 간격으로 [비짐] 컨텍스트 메뉴 내 비짐의 알파벳 순서(Aa, D, Ee, F, L, M, A, R, S, Uh, W-Oo)와 일치하게 설정합니다. 0초에는 [중립] 입 모양(비짐 없음)이어야 하고 1초 위치에서는 Aa 비짐이어야 하며 2초에서는 D 비짐이어야 합니다.

  3. 이제 컴포지션을 캐릭터의 얼굴이 포함된 다른 컴포지션에 중첩합니다. Character Animator 프로젝트의 장면과 같은 프레임 속도로 컴포지션을 설정해야 합니다.

  4. 1단계에서 복사한 시간 다시 매핑 키프레임을 중첩된비짐컴포지션에 붙여넣으려면 편집 > 붙여넣기를 선택합니다.

  5. 이제 모든 시간 다시 매핑 키프레임을 선택한 다음 해당 키프레임 보간을 홀드로 설정합니다.

    : 스프레드시트 프로그램에서 데이터를 복사하여 값을 필요한 대로 조정한 다음 데이터를 After Effects에 붙여넣을 수 있도록 시스템 클립보드에 다시 복사할 수도 있습니다.

알파 채널이 있는 비디오 포맷으로 장면 내보내기

장면을 동영상 파일로 내보내려고 하지만 장면에 알파 채널이 포함되어 있어 After Effects나 다른 애플리케이션에서 다른 푸티지에 합성할 경우 장면의 투명하거나 반투명한 영역에 배경이 나타날 수 있는 경우에는 별도의 메뉴 명령을 사용하여 장면을 Adobe Media Encoder로 보낼 수 있습니다.

  • 알파 채널이 있는 비디오 포맷으로 내보내려면 장면을 선택한 다음 파일 > 내보내기 > 알파가 있는 비디오를 Adobe Media Encoder를 통해 를 선택합니다.

장면이 Adobe Media Encoder대기열에 추가되고알파 사전 설정이 포함된 GoPro CineForm RGB 12비트의 QuickTime 포맷을 사용하도록 설정됩니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책