퍼펫은 Photoshop이나 Illustrator 작품에서 만든객체/캐릭터이며객체/캐릭터를 제어해 퍼포먼스를 만들 수 있습니다. 언제든지 Photoshop 또는 Illustrator로 전환하여 작품을 변경하거나 Character Animator에서 태깅을 사용하여 비헤이비어를 제어할 수 있습니다.

퍼펫에 있는 레이어 중 일부가 그룹입니다. 아래쪽 나선형 화살표가 있는 레이어를 그룹이라고 합니다. 레이어를 선택하여 속성을 수정하고, [프로젝트] 패널에 있는 부분(여러 퍼펫이나 작품 파일의 부분 포함)에서 퍼펫을 취합하고, 레이어를 다시 정렬/다시 배치하고 표시하거나 숨길 수 있습니다.

적절하게 구조화된 아트웍 파일로부터 퍼펫을 만들거나, 빈 퍼펫으로 시작하여 다른 퍼펫이나 가져온 아트웍 파일의 조각을 사용함으로써 퍼펫을 만들 수 있습니다. 추가 작업의 다른 버전을 만들기 위해 퍼펫을 복제할 수도 있습니다.

그런 다음에 레이어와 핸들을 선택하고 비헤이비어를 제어하기 위한 태그를 할당할 수 있습니다. 태그 할당에 대한 자세한 내용은 작품 준비를 참조하십시오.

Adobe Sensei 기반 Characterizer는 세련된 Character Animator 퍼펫을 단 몇 초 만에 생성합니다. 웹캠으로 캡처된 사용자 이미지와 참조 아트가 퍼펫을 생성하는 데 사용됩니다. 자세한 내용은 Characterizer를 사용하여 퍼펫 만들기를 참조하십시오.

Character Animator에서 아트웍으로부터 퍼펫 만들기

PSD 또는 AI 파일로부터 퍼펫을 만들려면 다음과 같이 하십시오.
  1. 파일 > 가져오기(Cmd/Ctrl+I)를 선택합니다.

  2. 하나 이상의 .ai 또는 .psd 파일을 선택한 후에 열기를 클릭합니다.

    선택한 각 아트웍 파일에 대해 [프로젝트] 패널에서 퍼펫(아트웍의 파일 이름을 따라 명명됨)이 만들어집니다.

템플릿으로부터 퍼펫 만들기

PSD 템플릿 AI 파일의 퍼핏 만들려면 시작 작업 영역에서 클로에 [퍼핏] 링크를 사용하십시오. 템플릿 PSD 또는 AI 파일의 복사본이 프로젝트 폴더에 복사되고, 프로젝트로 이동하고, 새 장면에 추가되고, 변경이 가능하도록 Photoshop이나 Illustrator에서 PSD 또는 AI 파일이 열립니다. 변경 내용을 파일에 저장한 후 Character Animator로 전환합니다. 일치하도록 퍼펫이 업데이트됩니다.

빈 퍼펫 만들기

빈 퍼펫을 만들려면 퍼펫 > 새로운 빈 퍼펫을 선택한 후에 퍼펫 항목의 이름을 지정하십시오.

참고:

빈 퍼펫에는 기본 비헤이비어가 적용되어 있지 않습니다.

퍼펫 복제

퍼펫을 복제하려면 선택한 후에 편집 > 복제(Cmd/Ctrl+D)를 선택하십시오.

[프로젝트] 패널에서 퍼펫 항목을 복제하면 퍼펫에 포함된 모든 그룹 및 레이어의 개별 복사본이 만들어집니다. 따라서 특정 퍼펫의 변경 내용이 복제 퍼펫에 영향을 주지 않습니다.

퍼펫 공유

퍼펫을 .puppet 파일로 내보내서 다른 Character Animator 사용자들과 공유하십시오. 퍼펫 파일은 가져오기가 가능한 자체 포함 파일로서, 퍼펫과 관련된 모든 아트웍을 포함하고 있습니다.

  1. [프로젝트] 패널에서 퍼펫을 선택하거나 엽니다.

  2. 파일 > 내보내기 > 퍼펫을 선택하고 .puppet 파일의 이름을 지정합니다.

  3. 공유 링크나 다른 공유 방법을 통해 .puppet 파일을 다른 사용자에게 보냅니다.

  4. 공유된 퍼펫을 열려면 파일 > 가져오기를 통해 또는 [프로젝트] 패널로 드래그하여 .puppet 파일을 가져옵니다.

    참고:

    • 아트웍의 공유 인스턴스에 퍼펫을 다시 연결할 수 있습니다.
    • 타임라인에서 선택했을 때 퍼펫에서 변경된 내용이나 퍼펫 트랙에 대해 녹화된 테이크는 .puppet 파일에 포함되지 않습니다.
    • 가져온 퍼펫에 있는 비헤이비어는 현재 프로젝트에서 사용 가능한 비헤이비어 버전을 사용하도록 업데이트됩니다.

사이클 퍼펫

[순환 레이어] 비헤이비어와 함께 사용할 이미지(PNG 포맷) 시퀀스로부터 순환 지원 퍼펫을 만듭니다. 이 비헤이비어는 퍼펫의 각 레이어를 패턴을 반복하는 데 적합한 순서로 표시합니다.

순환 퍼펫 만들기

  1. [퍼펫] 패널에서 퍼펫을 열고 순환 추가를 클릭하거나 파일 > 순환 가져오기를 선택합니다. 

  2. 순환 추가 옵션을 사용하여 순환 퍼펫을 만드는 경우에는 시퀀스에서 PNG 또는 JPEG 파일을 선택합니다.

    참고:

    시퀀스는 Flap001.png, Flap002.png 등과 같이 같은 기본 이름과 숫자 접미사를 사용하는 PNG 파일입니다.

    [순환 레이어]가 적용되고 PNG 또는 JPEG 시퀀스를 따라 명명된 퍼펫이 [프로젝트] 패널에서 만들어진 후에 [퍼펫] 패널에서 현재 선택된 레이어 위에 추가됩니다.

  3. PNG 순환 가져오기 옵션을 사용하여 순환 퍼펫을 만드는 경우에는 생성된 순환 퍼펫을 [프로젝트] 패널에서 [퍼펫] 패널에 있는 퍼펫으로 드래그하십시오.

    참고:

    • 순환 가져오기 메뉴 명령을 사용하여 만든 순환 퍼펫은 [순환 레이어] 비헤이비어의 시작 매개 변수가 즉시로 설정되기 때문에 장면에 퍼펫을 추가하면 순환이 자동으로 표시됩니다. 
    • 순환 추가 버튼을 사용하여 만든 순환 퍼펫은 시작 매개 변수가 트리거될 때로 설정됩니다.이것은키를 눌러서순환을 트리거할 때유용합니다.
    • 순환 퍼펫의 첫 레이어를 제외한 모든 레이어는 기본적으로 비활성화되고, 레이어의 아이볼을 클릭할 때 이전에 표시된 레이어가 자동으로 숨겨지도록 모든 레이어는 그룹의 다른 레이어 숨기기로 설정됩니다.

장면에 퍼펫 배치

먼저 장면에 퍼펫을 배치하여 보고 제어하십시오. 장면에 여러 개의 퍼펫을 배치할 수 있습니다.

장면의 퍼펫을 배치하려면 다음 중 하나를 수행하십시오.

  • [프로젝트] 패널에서 퍼펫을 선택한 후에 새 장면에 추가를 클릭하거나 객체 > 새 장면에 추가를 선택합니다.
  • [프로젝트] 패널에서 [장면] 또는 [타임라인] 패널에 열려 있는 장면으로 퍼펫을 드래그합니다.
  • [장면] 및 [타임라인] 패널이 비어 있는 경우(즉, 장면이 열려 있지 않은 경우) 드래그한 퍼펫은 새 장면에 추가됩니다.
  • [프로젝트] 패널에 나열된 기존 장면으로 퍼펫을 드래그합니다.

퍼펫이장면에나타나고, 퍼펫의 트랙 항목이 [타임라인] 패널에 나타나고 선택됩니다. 이 트랙 항목을 통해 이 퍼펫 인스턴스 고유의 매개 변수를 조정할 수 있습니다.

참고: 가져온 퍼펫은 기본적으로 장면의 중앙에 위치합니다. 변환 비헤이비어 옵션을 사용하여 장면에 있는 퍼펫을 재배치하십시오.

퍼펫의 원본 아트웍 편집

퍼펫과 연관된 작품은 퍼펫, 그리고 변경된 비헤이비어 및 비헤이비어 매개 변수를 새로 만들 필요 없이 업데이트할 수 있습니다.

퍼펫의 작품을 편집하려면 다음 단계를 수행합니다.

  1. [프로젝트] 패널에서 퍼펫을 선택하거나 [퍼펫] 패널에서 퍼펫 레이어를 선택한 후에 편집 > 원본 편집(Cmd/Ctrl+E)을 선택합니다. Photoshop 또는 Illustrator에서 퍼펫 파일을 열어 둔 경우 해당 애플리케이션으로 직접 이동하여 파일을 편집하면 변경 내용이 자동으로 동기화됩니다. 퍼펫의 아트웍과 연관된 기본 애플리케이션(예: .psd 파일의 경우 Photoshop, .ai 파일의 경우 Illustrator)이 시작됩니다. 아트웍을 엽니다.

  2. 아트웍을 원하는 대로 수정한 후에 변경 사항을 저장합니다. 작품 파일에서 수행한 변경 내용을 저장해야 Character Animator에 변경 내용이 표시됩니다.

  3. Character Animator로 전환합니다. 수정된 파일은 자동으로 감지되어 업데이트됩니다.

  4. Character Animator에서 업데이트된 작품을 감지하지 못할 경우 잠시 기다리십시오.

비디오: 퍼펫을 처음부터 새로 만들기

비디오: 퍼펫을 처음부터 새로 만들기
Dave Werner

참고: 퍼펫을 처음부터 새로 만들기 튜토리얼 비디오는 Photoshop에서 퍼펫을 처음부터 새로 만들어서 Adobe Character Animator에서 구현하는 방법을 배우는 데 도움이 됩니다.

[프로젝트]에서 퍼펫을 선택하거나 [퍼펫] 패널에서 퍼펫을 열면 [속성] 패널의 [퍼펫] 섹션에 소스 아트웍의 경로가 표시됩니다. 툴팁에는 전체 경로가 표시됩니다. 작품 파일을 찾을 수 없는 경우에는 파일 이름이 노란색으로 표시되고 없음이라는 도구 설명 접두사가 붙습니다.

소스 작품을 다시 연결하거나 바꾸려면 [속성] 패널에서 파일 이름을 클릭한 후에 사용할 작품 파일을 선택하십시오.

퍼펫 트랙의 소스 퍼펫 바꾸기

퍼펫용으로 테이크를 기록한 후에도 타임라인에서 퍼펫을 업데이트하거나 바꿀 수 있습니다. 그러므로 일반 퍼펫 구조만 유지한다면 퍼펫에 새 컨텐츠를 추가하면서 기존 기록을 유지할 수 있습니다.

퍼펫 트랙의 소스 퍼펫을 바꾸려면 다음 작업 중 하나를 수행합니다.

  • 타임라인에서 퍼펫 트랙을 선택합니다. 그런 다음 Option(Mac) 또는 Alt(Windows) 키를 누른 상태로 해당 퍼펫을 타임라인 패널에서 선택한 퍼펫 트랙으로 드래그합니다.
  • 프로젝트 패널에서 대체 퍼펫을 선택합니다. 그런 다음퍼펫 트랙의트랙 헤더(왼쪽) 영역을 마우스 오른쪽 버튼으로클릭하고프로젝트 패널에서 선택한 퍼펫으로 바꾸기를 선택합니다.

원본 소스 퍼펫 부분에 대해 기록된 테이크 중 대체 퍼펫에 더 이상 없는 테이크는 제거됩니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책