General workflow in After Effects

Overview of general workflow in After Effects

Whether you use Adobe After Effects to animate a simple title, create complex motion graphics, or composite realistic visual effects, you generally follow the same basic workflow, though you may repeat or skip some steps. For example, you may repeat the cycle of modifying layer properties, animating, and previewing until everything looks right. You may skip the step of importing footage if you intend to create graphical elements entirely in After Effects.

1. Import and organize footage

After you create a project, import your footage into the project in the Project panel. After Effects automatically interprets many common media formats, but you can also specify how you want After Effects to interpret attributes such as frame rate and pixel aspect ratio. You can view each item in a Footage panel and set its start and end times to fit your composition. For more information, see Importing and interpreting footage items.

2. Create, arrange, and composite layers in a composition

Create one or more compositions. Any footage item can be the source for one or more layers in a composition. You can arrange the layers spatially in the Composition panel or arrange them in time using the Timeline panel. You can stack layers in two dimensions or arrange them in three dimensions. You can use masks, blending modes, and keying tools to composite (combine), the images of multiple layers. You can even use shape layers, text layers, and paint tools to create your own visual elements. For more information, see Composition basics, Creating layers, Transparency, opacity, and compositing, Overview of shape layers, paths, and vector graphics, and Creating and editing text layers.

3. Modify and animate layer properties

You can modify any property of a layer, such as size, position, and opacity. You can make any combination of layer properties change over time, using keyframes and expressions. Use motion tracking to stabilize motion or to animate one layer so that it follows the motion in another layer. For more information, see Animation basics, Expression basics, and Tracking and stabilizing motion.

4. Add effects and modify effect properties

You can add any combination of effects to alter the appearance or sound of a layer, and even generate visual elements from scratch. You can apply any of the hundreds of effects, animation presets, and layer styles. You can even create and save your own animation presets. You can animate effect properties, too, which are simply layer properties within an effect property group. For more information, see Effects and animation presets overview.

5. Preview

Previewing compositions on your computer monitor or an external video monitor is fast and convenient, even for complex projects. You can change the speed and quality of previews by specifying their resolution and frame rate, and by limiting the area and duration of the composition that you preview. You can use color management features to preview how your movie will look on another output device. For more information, see Previewing and Color management.

6. Render and export

Add one or more compositions to the render queue to render them at the quality settings you choose and to create movies in the formats that you specify. You can use File > Export or Composition > Add to Render Queue.

For more information, see Basics of rendering and exporting section in Adobe Media Encoder.

Online resources for general workflow in After Effects

Read a basic step-by-step introduction to the general workflow in an excerpt from After Effects Classroom in a Book.

Read Trish and Chris Meyer’s step-by-step introduction to creating a basic animation in a PDF excerpt from their book, The After Effects Apprentice.

For an overview of After Effects project navigtion, see the video tutorial, “Walking Through A Mini Project,” by Jeff Sengstack and Infinite Skills.

Basic workflow tutorial: Create a simple movie

This tutorial assumes that you have already started After Effects and have not modified the empty default project. This example skips the step of importing footage and shows you instead how to create your own synthetic visual elements. After you have rendered a final movie, you can import it into After Effects to view it and use it as you would any other footage item.

Some people prefer to use the mouse and menus to interact with After Effects, whereas others prefer to use keyboard shortcuts for common tasks. For several steps in this example, two alternative commands are shown that produce the same result—the first demonstrating the discoverability of menu commands and the second demonstrating the speed and convenience of keyboard shortcuts. You’ll likely find that you use some combination of keyboard shortcuts and menu commands in your work.

  1. Create a new composition:
    • Choose Composition > New Composition.

    • Press Ctrl+N (Windows) or Command+N (Mac OS).

  2. Change the Duration value in the Composition Settings dialog box by entering 5.00 (5 seconds), choose Web Video from the Preset menu, and click OK.
  3. Create a new text layer:
    • Choose Layer > New > Text.

    • Press Ctrl+Alt+Shift+T (Windows) or Command+Option+Shift+T (Mac OS).

  4. Type your name. Press Enter on the numeric keypad or press Ctrl+Enter (Windows) or Command+Return (Mac OS) on the main keyboard to exit text-editing mode.
  5. Set an initial keyframe for the Position property:
    • Click the triangle to the left of the layer name in the Timeline panel, click the triangle to the left of the Transform group name, and then click the stopwatch button to the left of the Position property name.

    • Press Alt+Shift+P (Windows) or Option+Shift+P (Mac OS).

  6. Activate the Selection tool:
    • Click the Selection Tool button in the Tools panel.

    • Press V.

  7. Using the Selection tool, drag your text to the bottom-left corner of the frame in the Composition panel.
  8. Move the current-time indicator to the last frame of the composition:
    • Drag the current-time indicator in the Timeline panel to the far right of the timeline.

    • Press End.

  9. Using the Selection tool, drag your text to the top-right corner of the frame in the Composition panel.

    A new keyframe is created at this time for the Position property. Motion is interpolated between keyframe values.

  10. Preview your animation using preview:

    • Click the Play button in the Preview panel. Click Play again to stop the preview.

    • Press the spacebar. Press the spacebar again to stop the preview.

  11. Apply the Glow effect:
    • Choose Effect > Stylize > Glow.

    • Type glow in the search field at the top of the Effects & Presets panel to find the Glow effect. Double-click the effect name.

  12. In the Render Queue panel, click the underlined text to the right of Output To. In the Output Movie To dialog box, choose a name and location for the output movie file, and then click Save. For the location, choose something easy to find, like your desktop.
  13. Click the Render button to process all items in the render queue. The Render Queue panel shows the progress of the rendering operation. A sound is generated when rendering is complete.

You’ve created, rendered, and exported a movie.

You can import the movie that you’ve created and preview it in After Effects, or you can navigate to the movie and play it using a movie player such as QuickTime Player or Windows Media Player.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy