Rendering and exporting overview

What is rendering?

Rendering is the creation of the frames of a movie from a composition. The rendering of a frame is the creation of a composited two-dimensional image from all of the layers, settings, and other information in a composition that makes up the model for that image. The rendering of a movie is the frame-by-frame rendering of each of the frames that make up the movie. For more information on how each frame is rendered, see Render order and collapsing transformations.

It is common to speak of rendering as if this term only applies to final output. However, the processes of creating previews for the Footage, Layer, and Composition panels are also kinds of rendering. In fact, it is possible to save a preview as a movie and use that as your final output. (See Preview video and audio.)

After a composition is rendered for final output, it is processed by one or more output modules that encode the rendered frames into one or more output files. This process of encoding rendered frames into files for output is one kind of exporting.

Note:

  • See Project settings for more information about project settings that determine how time is displayed in the project, how color data is treated in the project, and what sampling rate to use for audio.
  • See Composition settings to learn how you can specify composition settings such as resolution, frame size, and pixel aspect ratio for your final rendered output.

After you have completed a composition, you can output a movie file. There are two different methods of outputting a movie file. Choose the one based on your needs.

You might need a movie file for the following reasons:

  • You need a high-quality movie (with or without an alpha channel) or image sequence that will be placed in a Premiere Pro sequence, or used in another video editing, compositing, or 3D graphics application.

    To create a high-quality movie file, render it with the Render Queue. See Render and export with the Render Queue panel.

  • You need a compressed movie that will be played on the web, or used for DVD or Blu-ray disc.

    To create a high-quality movie file that is compressed for the web, DVD, or Blu-ray disc, encode it using the Adobe Media Encoder. See The Adobe Media Encoder.

Note:

Some kinds of exporting don’t involve rendering and are for intermediate stages in a workflow, not for final output. For example, you can export a project as an Adobe Premiere Pro project by choosing File > Export > Adobe Premiere Pro Project. The project information is saved without rendering. In general, data transferred through Dynamic Link is not rendered.

A movie can be made into a single output file that contains all of the rendered frames, or it can be made into a sequence of still images (as you would do when creating output for a film recorder).

To generate output, you can either render your compositions using the After Effects render queue or add your compositions to the Adobe Media Encoder queue with the render settings that you have chosen in the Render Queue panel.

For the Render Queue, After Effects uses an embedded version of the Adobe Media Encoder to encode most movie formats through the Render Queue panel. When you manage render and export operations with the Render Queue panel, the embedded version of the Adobe Media Encoder is called automatically. The Adobe Media Encoder appears only in the form of the export settings dialog boxes with which you specify some encoding and output settings. (See Encoding and compression options for movies.)

Note:

The embedded version of the Adobe Media Encoder used to manage export settings within After Effects output modules does not provide all of the features of the full, stand-alone Adobe Media Encoder application.

From an expert: Using the Render Queue to export files

From an expert: Using the Render Queue to export files
Ian Robinson

Render and export with the Render Queue panel

The primary way of rendering and exporting movies from After Effects is through the Render Queue panel. 

When you place a composition into the Render Queue panel, it becomes a render item. You can add many render items to the render queue, and After Effects can render multiple items in a batch, unattended. When you click the Render button in the upper-right corner of the Render Queue panel, all items with the status of Queued are rendered and output in the order in which they are listed in the Render Queue panel.

Note:

You do not need to render a movie multiple times to export it to multiple formats with the same render settings. You can export multiple versions of the same rendered movie by adding output modules to a render item in the Render Queue panel.

When working with multiple render items, it is often useful to add comments in the Comment column in the Render Queue panel. If the Comment column is not visible, right-click (Windows) or Control-click (Mac OS) a column heading, and choose Columns > Comment.

Manage render items

In the Render Queue panel, you can manage several render items at once, each with its own render settings and output module settings.

Render settings determine the following characteristics:

  • Output frame rate
  • Duration
  • Resolution
  • Layer quality

Output module settings—which are applied after render settings—determine post-rendering characteristics such as the following:

  • Output format
  • Compression options
  • Cropping
  • Whether to embed a link to the project in the output file

You can create templates that contain commonly used render settings and output module settings.

Using the Render Queue panel, you can render the same composition to different formats or with different settings, all with one click of the Render button:

  • You can output to a sequence of still images, such as a Cineon sequence, which you can then transfer to film for cinema projection.

  • You can output using lossless compression (or no compression) to a QuickTime container for transfer to a non-linear editing (NLE) system for video editing.

You can select, duplicate, and reorder render items using many of the same keyboard shortcuts that you use for working with layers and other items. See General (keyboard shortcuts).

Note:

To transfer the output rendered from After Effects to film or video, you must have the proper hardware for film or video transfer, or have access to a service bureau that can provide transfer services.

Render and export a movie using the render queue

  1. Select the composition from which to make a movie in the Project panel, and then do one of the following to add the composition to the render queue:
    • Choose Composition > Add To Render Queue.

    • Drag the composition to the Render Queue panel.

    Note:

    To create a composition from a footage item and immediately add that composition to the render queue, drag the footage item from the Project panel to the Render Queue panel. It is a convenient way to convert a footage item from one format to another.

  2. Click the triangle next to the Output To heading in the Render Queue panel to choose a name for the output file based on a naming convention, and then choose a location; or click the text next to the Output To heading to enter any name. (See Specify filenames and locations for rendered output.)
  3. Click the triangle to the right of the Render Settings heading to choose a render settings template, or click the underlined text to the right of the Render Settings heading to customize the settings. (See Render settings.)
  4. Choose a Log type from the Log menu.

    When a log file has been written, the path to the log file appears under the Render Settings heading and Log menu.

  5. Click the triangle to the right of the Output Module heading to choose an output module settings template, or click the underlined text to the right of the Output Module heading to customize the settings. You use the output module settings to specify the file format of the output movie. In some cases, a format-specific dialog box opens after you choose a format, in which you can choose format-specific settings. (See Output modules and output module settings and Encoding and compression options for movies.)

    When an output name and location have been set, and render settings and an output module have been selected, the entry in the Render column automatically becomes selected (shown by a check mark) and the status changes to Queued. The status Queued means that the render item is in the render queue.

    Note:

    Press Caps Lock before you start rendering to prevent the Composition panel from displaying rendered frames. By not updating the Composition panel, After Effects requires less time to process simple render items with many frames.

  6. Click the Render button in the upper-right corner of the Render Queue panel.

Rendering a composition into a movie can take a few seconds or many hours, depending on the composition’s frame size, quality, complexity, and compression method. As After Effects renders the item, you are unable to work in the program. An audio alert indicates when rendering is complete.

See this tutorial to learn how to use the render queue to export files.

When rendering of a render item is complete, it remains in the Render Queue panel with its status changed to Done until you remove the item from the Render Queue panel. You cannot rerender a completed item, but you can duplicate it to create a new item in the queue with the same settings or with new settings.

Note:

After an item has been rendered, you can import the finished movie as a footage item by dragging its output module from the Render Queue panel into the Project panel. (See Import footage items.)

Render item statuses

Each render item has a status, which appears in the Status column in the Render Queue panel:

Unqueued

The render item is listed in the Render Queue panel but is not ready to render. Confirm that you have selected the desired render settings and output module settings, and then select the Render option to queue the render item.

Queued

The render item is ready to render.

Needs Output

An output filename has not been specified. Choose a value from the Output To menu, or click the underlined Not Yet Specified text next to the Output To heading to specify a filename and path.

Failed

After Effects was unsuccessful in rendering the render item. Use a text editor to view the log file for specific information on why the rendering was unsuccessful. When a log file has been written, the path to the log file appears under the Render Settings heading and Log menu.

User Stopped

The rendering process was stopped.

Done

The rendering process for the item is complete.

Manage render items and change render statuses

  • Select the source composition for a render item in the Project panel: Right-click (Windows) or Control-click (Mac OS) the render item and choose Reveal Composition In Project from the context menu.
  • Remove a render item from the render queue (change its status from Queued to Unqueued): Deselect the item entry in the Render column. The item remains in the Render Queue panel.
  • Change the status of a render item from Unqueued to Queued: Select the item in the Render column.
  • Remove a render item from the Render Queue panel: Select the item and press Delete, or choose Edit > Clear.
  • Rearrange items in the Render Queue panel: Drag an item up or down the queue. A heavy black line appears between render items, indicating where the item will be placed. You can also reorder selected render items by choosing Layer > Arrange, and then choosing Bring Render Item Forward, Send Render Item Backward, Bring Render Item To Front, or Send Render Item To Back
  • Move selected render items up (earlier) in the render queue: Press Ctrl+Alt+Up Arrow (Windows) or Command+Option+Up Arrow (Mac OS).
  • Move selected render items down (later): Press Ctrl+Alt+Down Arrow (Windows) or Command+Option+Down Arrow (Mac OS).
  • Move selected render items to the top of the render queue: Press Ctrl+Alt+Shift+Up Arrow (Windows) or Command+Option+Shift+Up Arrow (Mac OS).
  • Move selected render items to the bottom (end) of the render queue: Press Ctrl+Alt+Shift+Down Arrow (Windows) or Command+Option+Shift+Down Arrow (Mac OS).
  • Duplicate a render item: Right-click (Windows) or Control-click (Mac OS) the render item and choose a command from the context menu:
    • Render with the same filename: Choose Duplicate With File Name.
    • Render with a new filename: Choose Duplicate, click the underlined filename next to Output To, enter a new filename, and click Save.

Pause or stop rendering

If the disk (to which an output module is writing) runs out of space, After Effects pauses the render operation. You can clear additional disk space and then resume rendering and exporting.

  • To pause rendering, click Pause. To resume rendering, click Continue.

    While rendering is paused, you cannot change settings or use After Effects in any other way.

  • To stop rendering with the purpose of starting the same render over again, Alt-click (Windows) or Option-click (Mac OS) Stop.

    The render item for which rendering was stopped is assigned the status User Stopped, and a new item with the status of Queued is added to the Render Queue panel. The new item uses the same output filename and has the same duration as the original render item.

  • To stop rendering with the purpose of resuming the same render, click Stop.

    The render item for which rendering was stopped is assigned the status User Stopped, and a new item with the status of Unqueued is added to the Render Queue panel. The new item uses an incremented output filename and resumes rendering at the before frame at which rendering was stopped—so the first frame of the new item is the last successfully rendered frame of the stopped item.

Information shown for current render operations

Basic information about the current batch of renders is shown at the bottom of the Render Queue panel:

Message

A status message. For example, Rendering 1 of 4.

RAM

Memory available for the rendering process.

Renders Started

The date and time at which the current batch of renders was started.

Total Time Elapsed

The rendering time elapsed (not counting pauses) since the current batch of renders was started.

Most Recent Error

The path where the log files are located.

Note:

To view more information about the current render operation, click the triangle to the left of the Current Render heading. The Current Render pane collapses (closes) after a short time. To prevent it from collapsing after a time-out period, Alt-click (Windows) or Option-click (Mac OS) the triangle next to the Current Render heading. To view details of a completed render, review the log file. When a log file has been written, the path to the log file appears under the Render Settings heading and Log menu.

Change the render-complete sounds

A chime plays when all items in the render queue have been rendered and exported; a different sound plays if a render operation fails. You can change the render-complete sounds by replacing files named rnd_okay.wav and rnd_fail.wav in the sounds folder. The sounds folder is in the following location:

  • Program Files\Adobe\Adobe After Effects CC 2015\Support Files (Windows)

  • Applications/Adobe After Effects CC/Contents/Resources (Mac OS)

Online resources for rendering and exporting with the render queue

Lloyd Alvarez provides a script on his After Effects Scripts website that takes items that are ready to render in the render queue and sends them to render in the background using aerender.

Jeff Almasol provides a script on his redefinery website that renders and exports each of the selected layers separately. You might find this script useful if layers represent different versions of an effect or different parts of an effect that you want to render as separate “passes” for flexibility in how they get composited.

Christopher Green provides a script (Queue_Comp_Sections.jsx) on his website with which you can use multiple guide layers to designate multiple time spans to be rendered and exported separately through the render queue.

Render and export with Adobe Media Encoder

From an expert: Export a composition from After Effects to Adobe Media Encoder

From an expert: Export a composition from After Effects to Adobe Media Encoder
Jeff Sengstack

You can also export After Effects compositions directly into Adobe Media Encoder, which offers the flexibility to continue working in After Effects while files are being processed. When you use Adobe Media Encoder, you can also use additional presets and options that are not available in the After Effects Render Queue. 

You can add your composition to the Adobe Media Encoder Queue using one of the following methods:

  • Add to Adobe Media Encoder Queue (Composition > Add to Adobe Media Encoder Queue or File > Export > Add to Adobe Media Encoder Queue) for final rendering using presets and settings specified in Adobe Media Encoder.
  • Queue in AME button in the render queue (Window > Render Queue) for rendering a draft copy of your composition using the render settings specified in the rendering queue, while you continue to work on the composition. 

For information about using Adobe Media Encoder for rendering, see Encode video or audio items in Adobe Media Encoder.

Note:

The output module settings, such as format settings or color channel selection, are not transferred to Adobe Media Encoder when you choose the Queue in AME option. The output filename and location are transferred, however, Adobe Media Encoder does not use the filename and location templates, which may result in image sequence numbering mismatch.

Add a composition directly to Adobe Media Encoder

To add a composition to Adobe Media Encoder, do the following:

  1. Drag the After Effects project containing the composition you want to encode into the Encoding Queue in Adobe Media Encoder.

    You can add a composition to Adobe Media Encoder from After Effects. Do one of the following:

    • Choose Composition > Add To Adobe Media Encoder Queue

    • Choose File > Export > Add to Adobe Media Encoder Queue

    • Press Ctrl+Alt+M (Windows) or Command+Option+M (Mac OS)

  2. The Import After Effects Composition dialog box opens. Choose the composition you want to encode.

  3. Encode the file as you normally would by choosing presets and an output location in Adobe Media Encoder.

Add a composition from render queue to Adobe Media Encoder

To add a composition to the Adobe Media Encoder with render settings for draft rendering:

  1. Choose Composition > Add to Render Queue or press the keyboard shortcut Control + M (Windows) or Command + M (Mac).

  2. In the Render Queue panel, click the Queue in AME button. 

Choosing formats and output settings

After Effects provides various formats and compression options for output. Which format and compression options you choose depends on how your output will be used. For example, if the movie that you render from After Effects is the final product that will be played directly to an audience, then you need to consider the medium from which you’ll play the movie and what limitations you have on file size and data rate. By contrast, if the movie that you create from After Effects is an intermediate product that will be used as input to a video editing system, then you should output without compression to a format compatible with the video editing system. (See Planning your work.)

Aharon Rabinowitz provides an article on the Creative COW website about planning your project and deciding what formats and settings to use for final output.

Keep in mind the fact that you can use different encoding and compression schemes for different phases of your workflow. For example, you may choose to export a few frames as full-resolution still images (for example, TIFF files) when you need approval from a customer about the colors in a shot; whereas you may export the movie using a lossy encoding scheme (for example, H.264) when you need approval for the timing of the animation.

Supported output formats

You can add the ability to export other kinds of data by installing plug-ins or scripts provided by parties other than Adobe. For example, Paul Tuersley provides a script on the AE Enhancers forum with which you export After Effects composition data as Cinema 4D project data. Mark Christiansen provides an article on the ProVideo Coalition website that links to scripts and plug-ins for exporting from After Effects for use in Cinema 4D, Maya, Lightwave, and other 3D applications. (See Plug-ins.)

Unless otherwise noted, all image file formats are exported at 8 bits per channel (bpc).

Video and animation formats

  • QuickTime (MOV)

  • Video for Windows (AVI; Windows only)

Note:

To create an animated GIF movie, first render and export a QuickTime movie from After Effects. Then import the QuickTime movie into Photoshop and export the movie to animated GIF.

Video project formats

  • Adobe Premiere Pro project (PRPROJ)

Still-image formats

  • Adobe Photoshop (PSD)

  • Cineon (CIN, DPX)

  • Maya IFF (IFF)

  • JPEG (JPG, JPE)

  • OpenEXR (EXR)

  • PNG (PNG)

  • Radiance (HDR, RGBE, XYZE)

  • SGI (SGI, BW, RGB)

  • Targa (TGA, VBA, ICB, VST)

  • TIFF (TIF)

Audio-only formats

  • Audio Interchange File Format (AIFF)

  • MP3

  • WAV

Collect files in one location

The Collect Files command gathers copies of all of the files in a project or composition into a single location. Use this command before rendering, for archiving, or for moving a project to a different computer system or user account.

When you use the Collect Files command, After Effects creates a new folder and the following information is saved in the new folder:

  • A new copy of the project
  • Copies of the footage files
  • Proxy files as specified
  • A report describing the files, effects, and fonts necessary to re-create the project and render the compositions.

After you collect files, you can continue making changes to a project, but be aware that those changes are stored with the original project and not with the newly collected version.

  1. Choose File > Dependencies > Collect Files.

  2. In the Collect Files dialog box, choose an appropriate option for Collect Source Files.

    All

    Collects all footage files, including unused footage and proxies.

    For All Comps

    Collects all footage files and proxies used in any composition in the project.

    For Selected Comps

    Collects all footage files and proxies used in compositions currently selected in the Project panel.

    For Queued Comps

    Collects all footage files and proxies used directly or indirectly in any of the compositions with a Queued status in the Render Queue panel.

    None (Project Only)

    Copies the project to a new location without collecting any source footage.

  3. Select other options, as appropriate:

    Generate Report Only

    Selecting this option does not copy the files and proxies.

    Obey Proxy Settings

    Use this option with compositions that include proxies to specify whether you want the copy to include the current proxy settings. If this option is selected, only the files used in the composition are copied. If this option is not selected, the copy contains both proxies and source files, so you can later change proxy settings in the collected version.

    Note:

    If you choose For Queued Comps in the Collect Source Files dialog box, After Effects uses the proxy settings from the render settings, not the composition.

    Reduce Project

    Removes all unused footage items and compositions from the collected files when the following options are chosen in the Collect Source Files menu: For All Comps, For Selected Comps, and For Queued Comps.

    Change Render Output To

    Use to redirect the output modules to render files to a named folder in the collected files folder. This option ensures that you have access to your rendered files when you’re rendering the project from another computer. Rendering status must be valid (Queued, Unqueued, or Will Continue) for the output modules to render files to this folder.

    Enable ‘Watch Folder’ Render

    You can use the Collect Files command to save projects to a specified watch folder and then initiate watch-folder rendering over a network. After Effects also includes a render control file called [project name]_RCF.txt, which signals to watching computers that the project is available for rendering. After Effects and any installed render engines can then render the project together across a network. (See Set up watch-folder rendering.)

    Maximum Number Of Machines

    Use to specify the number of render engines or licensed copies of After Effects that you want to allocate to render the collected project. Below this option, After Effects reports how many items in the project will be rendered using more than one computer.

    Note:

    If rendering time is unusually long, you may have set Maximum Number Of Machines too high, and the network overhead required to track rendering progress among all computers is out of proportion to the time spent actually rendering frames. The optimal number depends on many variables related to the network configuration and the computers on it; experiment to determine the optimal number for your network.

  4. To add your own information to the report that will be generated, click Comments, enter your notes, and click OK. The comments appear at the end of the report.
  5. Click Collect. Name the folder and specify a location for your collected files.

    Once you start the file collection, After Effects creates the folder and copies the specified files to it. The folder hierarchy is the same as the hierarchy of folders and footage items in your project. The new folder includes a (Footage) folder and may include an output folder (if you selected Change Render Output To).

The names of these folders appear in parentheses to signal to any attending render engines that they should not search these folders for projects.

Carl Larsen demonstrates the use of the Collect Files command and the Consolidate All Footage command in a video tutorial on the Creative COW website that shows how to organize, consolidate, and archive project files and footage.

David Torno provides a script on the After Effects Scripts website that exports specified information about a project.

Specify filenames and locations for rendered output

Note:

You can locate a previously rendered item or check the destination of a queued render item by expanding the Output Module group in the Render Queue panel and clicking the underlined file path, or by right-clicking (Windows) or Control-clicking (Mac OS) the Output Module heading.

Specify the filename and location for a single render item

  • To manually enter a filename and destination folder, click the underlined text next to the Output To heading.
  • To name a file using a file naming template, click the triangle next to the Output To heading, and choose a template from the menu.

Create and use a custom file naming template

You can use custom templates to name the output according to properties of the composition and project.

Note:

To make a file naming template the default template, hold down Ctrl (Windows) or Command (Mac OS) as you choose the template from the Output To menu.

  1. In the Render Queue panel, choose Custom from the Output To menu.
  2. If you want to base the new file-naming template on an existing template, choose the existing template from the Preset menu.

  3. Click in the Template box where you want to insert a file-naming rule, and do any of the following:

    • To add a preset property to the filename, choose the property from the Add Property menu.

    • Enter text in the Template box.

    Note:

    Make sure that the insertion point is outside the square brackets [ ] of preset properties.

  4. Do any of the following:
    • To save the file-naming template as a preset for future use in the Output To menu, click the Save button . In the Choose Name dialog box, enter a name for the file-naming template, and click OK.

    • To always use the selected file-naming template, select Default.

    • To apply the selected file-naming template to the current Output Module, click OK.

Name output files automatically

The Use Default File Name And Folder preference ensures that all compositions added to the render queue are automatically assigned a unique output filename (except for files created by saving previews, which still use the composition name). When this option is selected, each render item is assigned the same folder name as the previous render item until you change the path. If a composition is rendered more than once, After Effects adds a number to the filename (for example, composition_name_1).

Note:

Avoid using high-ASCII or other extended characters in filenames for projects to be used on different platforms or rendered using a watch folder.

  1. Choose Edit > Preferences > Output (Windows) or After Effects > Preferences > Output (Mac OS).
  2. Select Use Default File Name And Folder.

Support for paths in templates

You can add paths to templates. Absolute paths can be defined in a template. For example, you can define and save a template that always places rendered files in E:\Output\[compName].[extension]. See the File Name and Location templates section in What's New in After Effects CC 12.2 for information about the new templates in After Effects CC 12.2 release.

Render settings

Render settings apply to each render item and determine how the composition is rendered for that specific render item. By default, the render settings for a render item are based on the current project settings, composition settings, and switch settings for the composition on which the render item is based. However, you can modify the render settings for each render item to override some of these settings.

Render settings apply to the root composition for a render item, as well as all nested compositions.

Note:

Render settings only affect the output of the render item with which they’re associated; the composition itself is not affected.

Render settings
Render settings

Change render settings

  • To change render settings for a render item, click the render settings template name next to the Render Settings heading in the Render Queue panel, and choose settings in the Render Settings dialog box.
  • To apply a render settings template to selected render items, click the triangle next to the Render Settings heading in the Render Queue panel, and choose a template from the menu. You can choose a custom render settings template or one of the preset render settings templates:

    Best Settings: Often used for rendering to final output.

    Draft Settings: Often appropriate for reviewing or testing motion.

    DV Settings: Similar to Best Settings, but with Field Rendering turned on, set to Lower Field First.

    Multi-Machine Settings: Similar to Best Settings, but with Skip Existing Files selected to enable multi-machine rendering.

Note:

The default render settings template is assigned to a render item when it is created. To change which render settings template is the default, hold down Ctrl (Windows) or Command (Mac OS) as you choose a render settings template from the menu.

Create, edit, and manage render settings templates

You perform the following tasks in the Render Settings Templates dialog box. To open the Render Settings Templates dialog box, choose Edit > Templates > Render Settings, or click the triangle next to the Render Settings heading in the Render Queue panel and choose Make Template.

  • To make a new render settings template, click New, specify render settings, and click OK. Enter a name for the new template.
  • To edit an existing render settings template, choose a template from the Settings Name menu, click Edit, and specify render settings.

Note:

Changes to an existing template do not affect render items that are already in the render queue.

  • To specify a default render settings template to be used when rendering movies, individual frames, pre-rendered movies, or proxies, choose a template from a menu in the Defaults area of the Render Settings Templates dialog box.
  • To save all currently loaded render settings templates to a file, click Save All.
  • To load a saved render settings template file, click Load, select the render settings template file, and then click Open.

Render settings reference

Each of these settings overrides composition settings, project settings, or layer switch settings.

Log

You can choose how much information After Effects writes to a render log file. If you choose Errors Only, After Effects only creates the file if errors are encountered during rendering. If you choose Plus Settings, a log file is created that lists the current render settings. If you choose Plus Per Frame Info, a log file is created that lists the current render settings and information about the rendering of each frame. When a log file has been written, the path to the log file appears under the Render Settings heading and Log menu.

Quality

The quality setting to use for all layers. (See Layer image quality and subpixel positioning.)

Resolution

Resolution of the rendered composition, relative to the original composition dimensions. (See Resolution.)

Note:

If you render at reduced resolution, set the Quality option to Draft. Rendering at Best quality when reducing resolution produces an unclear image and takes longer than Draft quality.

Disk Cache

Determines whether the disk cache preferences are used during rendering. Read Only writes no new frames to the disk cache while After Effects renders. Current Settings (default) uses the disk cache settings defined in the Media & Disk Cache preferences. (See Disk cache.)

Proxy Use

Determines whether to use proxies when rendering. Current Settings uses the settings for each footage item. (See Placeholders and proxies.)

Effects

Current Settings (default) uses the current settings for Effect switches . All On renders all applied effects. All Off renders no effects.

Solo Switches

Current Settings (default) uses the current settings for Solo switches for each layer. All Off renders as if all Solo switches are off. (See Solo a layer.)

Guide Layers

Current Settings renders guide layers in the top-level composition. All Off (the default setting) does not render guide layers. Guide layers in nested compositions are never rendered. (See Guide layers.)

Color Depth

Current Settings (default) uses the project bit depth. (See Color depth and high dynamic range color.)

Frame Blending

On For Checked Layers renders frame blending only for layers with the Frame Blending switch set, regardless of the Enable Frame Blending setting for the composition. (See Frame blending.)

Field Render

Determines the field-rendering technique used for the rendered composition. Choose Off if you are rendering for film or for display on a computer screen. (See Interlaced video and separating fields.)

3:2 Pulldown

Specifies the phase of 3:2 pulldown. (See Introduce 3:2 pulldown.)

Motion Blur

Current Settings uses the current settings for the Motion Blur layer switch and the Enable Motion Blur composition switch. On For Checked Layers renders motion blur only for layers with the Motion Blur layer switch set, regardless of the Enable Motion Blur setting for the composition. Off For All Layers renders all layers without motion blur regardless of the layer switch and composition switch settings. (See Motion blur.)

Time Span

How much of the composition to render. To render the entire composition, choose Length Of Comp. To render only the part of the composition indicated by the work area markers, choose Work Area Only. To render a custom time span, choose Custom. (See Work area.)

Frame Rate

The sampling frame rate to use when rendering the movie. Select Use Comp’s Frame Rate to use the frame rate specified in the Composition Settings dialog box, or select Use This Frame Rate to use a different frame rate. The actual frame rate of the composition is unchanged. The frame rate of the final encoded movie is determined by the output module settings. (See Frame rate.)

Skip Existing Files

Lets you rerender part of a sequence of files without wasting time on previously rendered frames. When rendering a sequence of files, After Effects locates files that are part of the current sequence, identifies the missing frames, and then renders only those frames, inserting them where they belong in the sequence. You can also use this option to render an image sequence on multiple computers. (See Render a still-image sequence with multiple computers.)

Note:

The current image sequence must have the same name as the existing image sequence, and the starting frame number, frame rate, and time span must be the same. You must render to the folder that contains the previously rendered frames.

Output modules and output module settings

Output module settings apply to each render item and determine how the rendered movie is processed for final output. Use output module settings to specify file format, output color profile, compression options, and other encoding options for final output.

You can also use output module settings to crop, stretch, or shrink a rendered movie; doing this after rendering is often useful when you are generating multiple kinds of output from a single composition.

Output module settings are applied to the rendered output that is generated according to the render settings.

For some formats, an additional dialog box opens when you choose the format in the Output Module Settings dialog box. You can modify these settings and use settings presets to specify format-specific options, such as compression options.

You can apply multiple output modules to each render item, which is useful when you want to make more than one version of a movie from one render. For example, you can automate the creation of a movie and its alpha matte, or you can create high-resolution and low-resolution versions of a movie.

Note:

Before rendering, check the Audio Output settings in the Output Module Settings dialog box to ensure that they are correct. To render audio, Audio Output must be selected. If your composition does not include audio, do not select Audio Output, so that the size of the rendered file does not increase needlessly.

Render settings

You can set the output module of multiple render queue items at the same time. Select the render queue items, and then choose an output module template from the Output Module Settings menu for one of the items.

You can drag an output module to the Project panel to import the finished movie or a placeholder into the project for use as a footage item. (See Import footage items.)

Andrew Kramer provides a video tutorial with tips for working with proxies, output modules, and output module templates on the Video Copilot website.

Change output module settings

  • To change output module settings for a render item, click the underlined output module settings template name next to the Output Module heading in the Render Queue panel, and choose settings in the Output Module Settings dialog box.
  • To apply an output module settings template to selected render items, click the triangle next to the Output Module heading in the Render Queue panel, and choose a template from the menu.

    You can choose a custom output module settings template or one of the preset output module settings templates. Several templates are provided, including the Lossless template for creating movies for transfer to video, film, or an NLE system.

Note:

The default output module settings template is assigned to a render item when it is created. To change which output module template is the default, hold down Ctrl (Windows) or Command (Mac OS) as you choose an output module template from the menu.

Note:

To change output module settings for multiple output modules at once, select the output modules and then choose an output module template. The template is applied to all selected output modules.

Create, manage, and edit output module templates

You perform the following tasks in the Output Module Templates dialog box. To open the Output Module Templates dialog box, choose Edit > Templates > Output Module, or click the triangle next to the Output Module heading in the Render Queue panel and choose Make Template.

  • To make a new output module settings template, click New, specify output module settings, and click OK. Enter a name for the new template.
  • To edit an existing output module settings template, choose a template from the Settings Name menu, click Edit, and specify output module settings.

Note:

Changes to an existing template do not affect render items that are already in the render queue.

  • To specify a default output module settings template to be used when processing movies, individual frames, previews, pre-rendered movies, or proxies, choose a template from a menu in the Defaults area of the Output Module Templates dialog box.
  • To save all currently loaded output module templates to a file, click Save All.
  • To load a saved output module template file, click Load, select the output module template file, and then click Open.

Add output modules to and remove output modules from render items

  • To add a new output module with default settings to a single render item, click the plus (+) sign to the left of the Output To heading of the last output module for the render item.
  • To remove an output module from a render item, click the minus (-) sign to the left of the Output To heading of the output module.
  • To add a new output module with default settings to selected render items, choose Composition > Add Output Module.
  • To duplicate selected output modules, press Ctrl+D (Windows) or Command+D (Mac OS).

Output module settings

For information on using controls in the Color Management area of the Output Module Settings dialog box, see Assign an output color profile.

Format

Specifies the format for the output file or sequence of files.

Include Project Link

Specifies whether to include information in the output file that links to the source After Effects project. When you open the output file in another application, such as Adobe Premiere Pro, you can use the Edit Original command to edit the source project in After Effects.

Include Source XMP Metadata

Specifies whether to include XMP metadata in the output file from the files used as sources for the rendered composition. XMP metadata can travel all the way through After Effects from source files, to footage items, to compositions, to rendered and exported files. For all default output module templates, Include Source XMP Metadata is deselected by default. (See Exporting XMP metadata from After Effects.)

Post-Render Action

Specifies an action for After Effects to perform after the composition is rendered. (See Post-render actions.)

Format Options

Opens a dialog box in which you specify format-specific options.

Channels

The output channels contained in the output movie. After Effects creates a movie with an alpha channel if you choose RGB+Alpha, implying a depth of Millions of Colors+. Not all codecs support alpha channels.

Note:

All files created with a color depth of Millions of Colors+, Trillions of Colors+, or Floating Point + have labeled alpha channels; information describing the alpha channel is stored in the file. Therefore, you do not have to specify an alpha interpretation each time you import an item created in After Effects.

Depth

Specifies the color depth of the output movie. Certain formats may limit depth and color settings.

Color

Specifies how colors are created with the alpha channel. Choose from either Premultiplied (Matted) or Straight (Unmatted). (See Alpha channel interpretation: premultiplied or straight.)

Starting #

Specifies the number for the starting frame of a sequence. For example, if this option is set to 38, After Effects names the first frame [file_name]_00038. The Use Comp Frame Number option adds the starting frame number in the work area to the starting frame of the sequence.

Resize

Specifies the size of your output movie. Select Lock Aspect Ratio To if you want to retain the existing frame aspect ratio when resizing the frame. Select Low Resize Quality when rendering tests, and select High Resize Quality when creating a final movie. (See Scaling a movie down and Scaling a movie up.)

Crop

Used to subtract or add rows or columns of pixels to the edges of the output movie. You can specify the number of rows or columns of pixels to be added or subtracted from the top, left, bottom, and right sides of the movie. Use positive values to crop, and use negative values to add rows or columns of pixels. Select Region Of Interest to export only the region of interest selected in the Composition or Layer panel. (See Region of interest (ROI).)

Note:

By adding one row of pixels to the top and subtracting one row from the bottom of a movie, you can change the field order.

Audio Output

Specifies the sample rate, sample depth (8 Bits or 16 Bits), and playback format (Mono or Stereo). Choose a sample rate that corresponds to the capability of the output format. Choose an 8-bit sample depth for playback on the computer, and a 16-bit sample depth for CD and digital audio playback or for hardware that supports 16-bit playback.

Note:

The specifications for some formats impose limits on audio parameters. In such cases, audio options may be unavailable for modification in the Output Module Settings dialog box. Also, audio options for some formats are set in the export settings dialog box for that format. For example, to set audio output options for Windows Media, click Format Options in the Output Module Settings dialog box.

Warning for mismatch in frame rate or dimensions

Some formats enforce constraints on frame dimensions and frame rate.

If you choose such a constrained output format, and your composition, its render settings, or its output module settings don’t match the constraints, then After Effects shows a yellow warning icon and the message “Settings mismatch” at the bottom of the Output Module Settings dialog box.

Click the warning icon to see a detailed message that describes how the output file will be modified to meet the format constraints. You can go back and change composition settings, render settings, and output module settings if you don't want After Effects to make the changes automatically in the output module.

For more information about output module constraints and the warnings for mismatches in frame rate, dimensions, and pixel aspect ratio, see the Adobe website.

Encoding and compression options for movies

Compression is essential for reducing the size of movies so that they can be stored, transmitted, and played back effectively. Compression is achieved by an encoder; decompression is achieved by a decoder. Encoders and decoders are known by the common term codec. No single codec or set of settings is best for all situations. For example, the best codec for compressing cartoon animation is generally not efficient for compressing live-action video. Similarly, the best codec for playback over a slow network connection is generally not the best codec for an intermediate stage in a production workflow. For information on planning your work with final output in mind, see Planning your work.

After Effects uses an embedded version of the Adobe Media Encoder to encode most movie formats through the Render Queue panel. When you manage render and export operations with the Render Queue panel, the embedded version of the Adobe Media Encoder is called automatically. The Adobe Media Encoder appears only in the form of the export settings dialog boxes with which you specify some encoding and output settings.

Note:

The embedded version of the Adobe Media Encoder used to manage export settings within After Effects output modules does not provide all of the features of the full, stand-alone Adobe Media Encoder application. For information about the full, stand-alone Adobe Media Encoder application, see Adobe Media Encoder Help.

For most output formats, you can specify format-specific encoding and compression options. In many cases, a dialog box opens and presents these options when you choose a format to export to or click the Format Options button in the Output Module settings dialog box. (See Output modules and output module settings.)

QuickTime (MOV) encoding and compression settings

  1. In the Render Queue panel, click the underlined name of the output module.
  2. Choose QuickTime from the Format menu.
  3. Click Format Options in the Video Output section.
  4. In the QuickTime Options dialog box, choose a codec and set options according to the specific codec and your needs:

    Quality

    A higher Quality setting produces better image quality but results in a bigger movie file.

    Key Frame Every

    In QuickTime terminology, the term key frames refers to something different from the change-over-time keyframes placed in the After Effects Timeline panel. In QuickTime, key frames are frames that occur at regular intervals in the movie. During compression, they are stored as complete frames. Each intermediate frame that separates them is compared to the previous frame, and only changed data is stored. Using key frames greatly reduces movie size and greatly increases the memory required to edit and render a movie. Shorter intervals between key frames enable faster seeking and reverse playback, but can significantly increase the size of the file.

    Frame Reordering

    Some codecs allow for frames to be encoded and decoded out of order for more efficient storage.

    Note: For more information on QuickTime, see the Apple website.

     

  5. Click OK.
  6. Specify other settings in the Output Module Settings dialog box.

Post-render actions

You can use post-render actions to automate simple tasks that occur after a composition is rendered.

A common example of the use of post-render actions is with pre-rendering: Choosing Composition > Pre-render adds the selected composition to the render queue and sets the Post-Render Action option to Import & Replace Usage.

Note:

You choose Post-Render Action options in the Output Module group, so be aware that changing the Output Module template could also change the Post-Render Action option. (See Output modules and output module settings.)

  1. Expand the Output Module group in the Render Queue panel by clicking the arrow to the left of the Output Module heading.
  2. Choose one of the following from the Post-Render Action menu:

    None

    Performs no post-render action. This option is the default.

    Import

    Imports the rendered file into the project as a footage item when the rendering is complete.

    Import & Replace Usage

    Imports the rendered file into the project and substitutes it for the specified item. Drag the pick whip to the item to replace in the Project panel to specify it.

    Note:

    Use the Import & Replace Usage option to create a chain of dependent render items. For example, you can set one render item to use a watch folder and multiple computers to create a still-image sequence, and then the next render item can render a single movie file from that still-image sequence. (See Network rendering with watch folders and render engines.)

    Set Proxy

    Sets the rendered file as a proxy for the specified item. Drag the pick whip to the item in the Project panel item to specify it.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy