User Guide Cancel

After Effects Composition basics | Adobe

  1. After Effects User Guide
  2. Beta releases
    1. Beta Program Overview
    2. After Effects Beta Home
    3. Features in Beta
      1. Properties panel (Beta)
      2. Selectable Track Matte Layers (Beta)
      3. Native H.264 Encoding (Beta)
  3. Getting started
    1. Get started with After Effects
    2. What's new in After Effects 
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Supported File formats | After Effects
    7. Hardware recommendations
    8. After Effects for Apple silicon
    9. Planning and setup
    10. Setup and installation
  4. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  5. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. View detailed performance information with the Composition Profiler
    5. CINEMA 4D Composition Renderer
  6. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. Detect edit points using Scene Edit Detection
    8. XMP metadata
  7. Text and Graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
  8. Drawing, Painting, and Paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. Taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  9. Layers, Markers, and Camera
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  10. Animation, Keyframes, Motion Tracking, and Keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  11. Transparency and Compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels and masks
  12. Adjusting color
    1. Color basics
    2. Color management
    3. Color Correction effects
  13. Effects and Animation Presets
    1. Effects and animation presets overview
    2. Effect list
    3. Simulation effects
    4. Stylize effects
    5. Audio effects
    6. Distort effects
    7. Perspective effects
    8. Channel effects
    9. Generate effects
    10. Transition effects
    11. The Rolling Shutter Repair effect
    12. Blur and Sharpen effects
    13. 3D Channel effects
    14. Utility effects
    15. Matte effects
    16. Noise and Grain effects
    17. Detail-preserving Upscale effect
    18. Obsolete effects
  14. Expressions and Automation
    1. Expression
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  15. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. 3D Transform Gizmos
    7. Do more with 3D animation
    8. Preview changes to 3D designs real time with the Real-Time Engine
    9. Add responsive design to your graphics 
  16. Views and Previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  17. Rendering and Exporting
    1. Basics of rendering and exporting
    2. Export an After Effects project as an Adobe Premiere Pro project
    3. Converting movies
    4. Multi-frame rendering
    5. Automated rendering and network rendering
    6. Rendering and exporting still images and still-image sequences
    7. Using the GoPro CineForm codec in After Effects
  18. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Creative Cloud Libraries in After Effects
    5. Plug-ins
    6. CINEMA 4D and Cineware
  19. Collaboration: Frame.io, and Team Projects
    1. Collaboration in Premiere Pro and After Effects
    2. Frame.io
      1. Install and activate Frame.io
      2. Use Frame.io with Premiere Pro and After Effects
      3. Frequently asked questions
    3. Team Projects
      1. Get Started with Team Projects
      2. Create a Team Project
      3. Collaborate with Team Projects
  20. Memory, storage, performance
    1. Memory and storage
    2. How After Effects handles low memory issues while previewing    
    3. Improve performance
    4. Preferences
    5. GPU and GPU driver requirements for After Effects

Use this document to learn the Composition basics in After Effects. Create one or multiple compositions, learn more about time panel.

Composition basics

A composition is the framework for a movie. Each composition has its own timeline. A typical composition includes multiple layers that represent components such as video and audio footage items, animated text and vector graphics, still images, and lights. You add a footage item to a composition by creating a layer for which the footage item is the source. You then arrange layers within a composition in space and time, and composite using transparency features to determine which parts of underlying layers show through the layers stacked on top of them. (See Layers and properties and Transparency and compositing.)

A composition in After Effects is similar to a movie clip in Flash Professional or a sequence in Premiere Pro.

You render a composition to create the frames of a final output movie, which is encoded and exported to any number of formats. (See Basics of rendering and exporting.)

Simple projects may include only one composition; complex projects may include hundreds of compositions to organize large amounts of footage or many effects.

In some places in the After Effects user interface, composition is abbreviated as comp.

Each composition has an entry in the Project panel. Double-click a composition entry in the Project panel to open the composition in its own Timeline panel. To select a composition in the Project panel, right-click (Windows) or Control-click (Mac OS) in the Composition panel or Timeline panel for the composition and choose Reveal Composition In Project from the context menu.

Use the Composition panel to preview a composition and modify its contents manually. The Composition panel contains the composition frame and a pasteboard area outside the frame that you can use to move layers into and out of the composition frame. The offstage extents of layers—the portions not in the composition frame—are shown as rectangular outlines. Only the area inside the composition frame is rendered for previews and final output.

The composition frame in the Composition panel in After Effects is similar to the Stage in Flash Professional.

When working with a complex project, you may find it easiest to organize the project by nesting compositions—putting one or more compositions into another composition. You can create a composition from any number of layers by precomposing them. After modifying some layers of your composition, you can precompose those layers and then pre-render the precomposition, replacing it with a rendered movie. (See Precomposing, nesting, and pre-rendering.)

You can navigate within a hierarchy of nested compositions using the Composition Navigator and Composition Mini-Flowchart. (See Opening and navigating nested compositions.)

Use the Flowchart panel to see the structure of a complex composition or network of compositions.

Timeline button

 Click this button at the bottom of the Composition panel to activate the Timeline panel for the current composition.

Note:

Press the backslash (\) key to switch activation between the Composition panel and Timeline panel for the current composition.

Comp button

 Click this button in the upper-right corner of the Timeline panel to activate the Composition panel for the current composition.

Flowchart button

 Click this button at the bottom of the Composition panel to activate the Flowchart panel for the current composition.

Create a composition

You can change composition settings at any time. However, it’s best to specify settings such as frame aspect ratio and frame size when you create the composition, with your final output in mind. Because After Effects bases certain calculations on these composition settings, changing them late in your workflow can affect your final output.

Note:

You can override some composition settings when rendering to final output. For example, you can use different frame sizes for the same movie. For more information, see Render settings and Output modules and output module settings.

When you create a composition without changing settings in the Composition Settings dialog box, the new composition uses the settings from the previous time that composition settings were set.

Note:

New compositions do not inherit the previous Preserve Frame Rate When Nested Or In Render Queue and Preserve Resolution When Nested settings.

Jeff Almasol provides a script on his redefinery website that creates and saves a new project for each selected composition in the current project. If a folder is selected in the Project panel when you create a new composition, the new composition is placed in the selected folder.

Create a composition and manually set composition settings

  1. Choose Composition > New Composition, or press Ctrl+N (Windows) or Command+N (Mac OS).

Create a composition from a single footage item

  1. Drag the footage item to the Create A New Composition button at the bottom of the Project panel or choose File > New Comp From Selection.

    Composition settings, including frame size (width and height) and pixel aspect ratio, are automatically set to match the characteristics of the footage item.

Create a single composition from multiple footage items

  1. Select footage items in the Project panel.
  2. Drag the selected footage items to the Create A New Composition button at the bottom of the Project panel, or choose File > New Comp From Selection.
  3. Select Single Composition and other settings in the New Composition From Selection dialog box:

    Use Dimensions From

    Choose the footage item from which the new composition gets composition settings, including frame size (width and height) and pixel aspect ratio.

    Still Duration

    The duration for the still images being added.

    Add To Render Queue

    Add the new composition to the render queue.

    Sequence Layers, Overlap, Duration, and Transition

    Arrange the layers in a sequence, optionally overlap them in time, set the duration of the transitions, and choose a transition type.

Create multiple compositions from multiple footage items

  1. Select footage items in the Project panel.
  2. Drag the selected footage items to the Create A New Composition button at the bottom of the Project panel, or choose File > New Comp From Selection.
  3. Select Multiple Compositions and other settings in the New Composition From Selection dialog box:

    Still Duration

    The duration of the compositions created from still images.

    Add To Render Queue

    Add the new compositions to the render queue.

Note:

If you select multiple footage items, the New Composition From Selection dialog is displayed. You can choose whether to create a single composition with all footage items or multiple compositions for each individual footage item.

Duplicate a composition

  1. Select the composition in the Project panel.
  2. Choose Edit > Duplicate or press Ctrl+D (Windows) or Command+D (Mac OS).

Timeline panel

Each composition has its own Timeline panel. You use the Timeline panel to perform many tasks, such as animating layer properties, arranging layers in time, and setting blending modes. The layers at the bottom of the layer stacking order in the Timeline panel are rendered first and—in the case of 2D image layers— appear farthest back in the Composition panel and in the final composite.

Note:

To cycle forward through Timeline panels, press Alt+Shift+period (.) (Windows) or Option+Shift+period (.) (Mac OS). To cycle backward through Timeline panels, press Alt+Shift+comma (,) (Windows) or Option+Shift+comma (,) (Mac OS).

The current time for a composition is indicated by the current-time indicator (CTI), the vertical red line in the time graph. The current time for a composition also appears in the current time display in the upper-left corner of the Timeline panel. For more information on moving the current-time indicator, see Move the current-time indicator.

The left side of the Timeline panel consists of columns of controls for layers. The right side of the Timeline panel—the time graph—contains a time ruler, markers, keyframes, expressions, duration bars for layers (in layer bar mode), and the Graph Editor (in Graph Editor mode).

Note:

Press the backslash (\) key to switch activation between the Composition panel and Timeline panel for the current composition.

Composition settings

You can enter composition settings manually, or you can use composition settings presets to automatically set frame size (width and height), pixel aspect ratio, and frame rate for many common output formats. You can also create and save your own custom composition settings presets for later use. Resolution, Start Timecode (or Start Frame), Duration, and Advanced composition settings are not saved with composition settings presets.

Note:

The limit for composition duration is three hours. You can use footage items longer than three hours, but time after three hours does not display correctly. The maximum composition size is 30,000x30,000 pixels. A 30,000x30,000 8-bpc image requires approximately 3.5 GB; your maximum composition size may be less, depending on your operating system and available RAM.

Working with composition settings

  • To open the Composition Settings dialog box to change composition settings, do one of the following:

    • Select a composition in the Project panel or activate the Timeline or Composition panel for a composition, and choose Composition > Composition Settings, or press Ctrl+K (Windows) or Command+K (Mac OS).

    • Right-click (Windows) or Control-click (Mac OS) a composition in the Project panel or Composition panel (not on a layer), and choose Composition Settings from the context menu.

  • To save a custom composition settings preset, set Width, Height, Pixel Aspect Ratio, and Frame Rate values in the Composition Settings dialog box, and then click the Save button .

  • To delete a composition settings preset, choose it from the Preset menu in the Composition Settings dialog box, and click the Delete button .

  • To restore default composition settings presets, Alt-click (Windows) or Option-click (Mac OS) the Delete button or the Save button in the Composition Settings dialog box.

Note:

You cannot move custom composition settings presets from one system to another, as they are embedded into the preferences file.

  • To scale an entire composition, choose File > Scripts > Scale Composition.jsx.
Note:

Ensure that all layers are unlocked in the selected composition or the script fails.

Jeff Almasol provides a script on his redefinery website to set the frame rate and duration of the current composition and all compositions nested within it.

Christopher Green provides a script (Selected_Comps_Changer.jsx) on his website with which you can change the composition settings for compositions selected in the Project panel.

Basic composition settings

Start Timecode or Start Frame

Timecode or frame number assigned to the first frame of the composition. This value does not affect rendering; it merely specifies where to start counting from.

Background Color

Use the color swatch or eyedropper to pick a composition background color. (See Select a color or edit a gradient.)

note: When you add one composition to another (nesting), the background color of the containing composition is preserved, and the background of the nested composition becomes transparent. To preserve the background color of the nested composition, create a solid-color layer to use as a background layer in the nested composition.

For information on specific Basic composition settings not listed here, see the related sections:

Advanced composition settings

Anchor

Click an arrow button to anchor layers to a corner or edge of the composition as it is resized.

Preserve resolution when nested and Preserve frame rate when nested or in render queue

For a composition to retain its own resolution or frame rate, and not inherit those settings from the containing composition. For example, if you have deliberately used a low frame rate in a composition to create a jerky, hand-animated result, you must preserve the frame rate for that composition when it is nested. Similarly, the results of rotoscoping may look wrong when converted to a different frame rate or resolution. Use this setting instead of the Posterize Time effect, which is less efficient.

Motion Blur settings

  • Shutter angle: The shutter angle is measured in degrees, simulating the exposure allowed by a rotating shutter. The shutter angle uses the footage frame rate to determine the simulated exposure, which affects the amount of motion blur. For example, entering 90° (25% of 360°) for 24-fps footage creates an effective exposure of 1/96 of a second (25% of 1/24 of a second). Entering 1° applies almost no motion blur, and entering 720° applies a large amount of blur.
  • Shutter phase: The shutter phase is also measured in degrees. It defines an offset that determines when the shutter opens relative to the beginning of a frame. Adjusting this value can help if an object with motion blur applied appears to lag behind the position of the object without motion blur applied.
  • Samples per frame: The minimum number of samples. This minimum is the number of samples used for frames for which After Effects is not able to determine an adaptive sampling rate based on layer motion. This sample rate is used for 3D layers and shape layers.
  • Adaptive sample limit: The maximum number of samples.

For information on specific Advanced composition settings not listed here, see the related sections:

3D renderer settings

You can use the options in the 3D renderer tab to choose the right 3D renderer for your composition. You can choose from the following renderers in the Renderer menu:

  • Classic 3D
  • CINEMA 4D
  • Ray-traced 3D

The 3D functionality of the CINEMA 4D Composition Renderer and the Ray-traced 3D renderer is nearly identical with the extrusion of 3D text and shape layers and bending of other 3D layers (solids, footage, and so on) into curved planes. However, the rendered results can be different because they generate results using different renderers and support different sets of features. For example, there are differences in the 3D layer material options and other layer behaviors. 

The CINEMA 4D Composition Renderer renders 3D layers including extruded text and shapes and curved 2D planes to make the process of animating 3D text and logos from scratch easier. The performance of the CINEMA 4D renderer is much faster than the CPU-only performance of the Ray-traced 3D renderer.

3D renderer tab
3D renderer tab

Classic 3D renderer

Classic 3D is the traditional, default renderer. Layers are positioned as planes in 3D space.

CINEMA 4D Composition Renderer options

Quality: The Quality level that you set on the slider affects the parameters that determine how the CINEMA 4D Composition Renderer draws the 3D layers. You can see the resultant renderer parameters in the Options, Anti-aliasing, and Reflectance boxes. The single Quality setting makes it easy for you to choose a balanced combination of rendering speed and acceptable 3D rendering quality without understanding and modifying the various rendering quality parameters.

The following parameters are modified when you adjust the Quality slider:

  • Ray Threshold: This value helps to optimize render time. 
  • Ray Depth: The Ray Depth determines how many transparent objects (or areas made invisible using the alpha channel) can be penetrated by the renderer. 
  • Reflection Depth: When a ray is sent into the scene, it can be reflected by reflective surfaces. The higher the Reflection Depth, the further rays are followed into the scene and the results rendered.
  • Shadow Depth: Shadow Depth behaves analogous to the Reflection Depth. The Shadow Depth setting defines the shadow depth with which visible shadow rays are calculated. 

Anti-Aliasing: Geometry is the default anti-aliasing setting that smooths all object edges (automatically with 16x16 sub-pixels).

Reflectance: Layer sampling is the default Reflectance setting that defines the quality of matte reflections.

When you select CINEMA 4D in the Renderer drop-down box, the Enabled column displays the 3D options that are enabled and the Disabled column displays the 3D options that are not available.

CINEMA 4D Render options
CINEMA 4D Render options

To choose a quality level for your 3D rendering, click the Options button after selecting CINEMA 4D as the renderer and set the quality level using the Quality slider. The values of Ray Threshold, Ray Depth, Reflection Depth, Shadow Depth, Anti-Aliasing, and Reflectance change acccordingly.

After Effects installs a default Renderer on your machine. You can change the Renderer to a full retail version of CINEMA 4D, if you have it installed.

The default Editor is the latest installed version of CINEMA 4D or CINEMA 4D Lite.

To select another CINEMA 4D installation, click Choose Installation and select the path to the installer in the Rendering and Editing boxes.

Choose CINEMA 4D Installation
Choose CINEMA 4D Installation

Ray-traced 3D render options

Click the Options button to launch the Ray-traced 3D Renderer Options dialog box. You can also Ctrl-click (Windows) or Command-click (Mac OS) the Current Renderer Indicator button in the upper-right of the Composition panel to launch the dialog box.

Here you can choose:

  • Ray-tracing quality: Click the Ray-tracing quality setting to change it according to your workflow.
    • Higher values for ray-tracing quality decrease noise but greatly increase render time.
      Ray-tracing quality controls the number of rays fired per pixel (for example, a value of 4 fires 16 or 4x4 rays, and 8 fires 64 rays).
    • A larger number produces a more accurate pixel at the expense of computation time.
    • A value of 1 provides better performance, but there won't be any reflection blur (for example, it is always sharp), soft shadow, depth of field, or motion blur.

Increasing the Ray-tracing Quality value does not increase the sharpness. Instead it decreases the noise inherent in point sampling. Use the lowest value that produces an acceptable amount of noise or no noise.

  • Anti-aliasing Filter: Controls the method of averaging the fired rays for a pixel. None fires all rays within the bounds of a pixel, whereas the others spread the grid of fired rays partially across adjacent pixels to produce a better average. Box, Tent, and Cubic (which is not bicubic) are listed in the order of better quality.
    • None
    • Box
    • Tent
    • Cubic

The anti-aliasing filter controls the amount of blurriness. None gives the sharpest result but the edges of the projection catcher may look aliased, with Box blur, Triangle, and Cubic giving blurrier results.

Note:

Ray-traced 3D layers use Ray-tracing Quality to control the appearance of motion blur.

Depth of field calculations in Ray-traced 3D are more accurate than they are in Classic 3D (and previously in Advanced 3D).

Improved composition toolbar for 3D designing

With the improved composition panel toolbar, work faster and without distraction when creating and designing 3D scenes within After Effects. The UI and placement are the same as the default composition toolbar at the bottom of the Composition panel when you work with 2D assets. Once you add 3D content to your scene, the composition panel containing the 3D menu is displayed. After Effects adds more 3D controls to the composition panel toolbar, and controls that are not needed for your current workflow move out into the Composition menu. For more information, see the 3D Design space.

How is this composition toolbar different from the old composition toolbar?

Placement of controls

  • The most used controls are reorganized and are on the left side of the toolbar.
  • 3D controls are on the right side of the toolbar and only appear when there is at least one 3D layer in the comp.
  • Controls with low usage such as Adobe Immersive Environment, Show Timeline, and Show Composition Flowchart are removed.

New 3D controls

  • There are the following 3D controls in the improved composition panel toolbar:
    • Draft 3D 
    • Ground Plane
  • You can enable/disbale these by clicking the buttons assigned for each of these controls.

Streamlined controls

  • The Select View Layout menu has been streamlined. 
  • The Fast Previews is streamlined. Fast Draft is named Draft 3D and is controlled by the button on the right side of the toolbar. Draft mode is removed and is no longer applicable. The Renderer Options command is in the 3D Renderer menu on the right side of the toolbar.

Controls enabled by default

  • 3D Reference Axes are enabled by default. You can disable them from the Grids and Guides Options menu, on the left side of the toolbar.
  • Pixel Aspect Ratio correction is enabled by default.

Placement of controls

  • You can open the Timeline and Flowchart panels from the Window menu, if not currently open in your workspace.
  • Controls that don’t need to be within easy reach have been moved to commands in the Composition panel’s menu (the three-bar menu button on the panel’s tab): Always Preview This View, Primary Viewer, and Pixel Aspect Ratio Correction.

Composition thumbnail images

You can choose which frame of a composition to show as a thumbnail image (poster frame) for the composition in the Project panel. By default, the thumbnail image is the first frame of the composition, with transparent portions shown as black.

  • To set the thumbnail image for a composition, move the current-time indicator to the desired frame of the composition in the Timeline panel, and choose Composition > Set Poster Time.
  • To add a transparency grid to the thumbnail view, choose Thumbnail Transparency Grid from the Project panel menu.
  • To hide the thumbnail images in the Project panel, choose Edit > Preferences > Display (Windows) or After Effects > Preferences > Display (Mac OS) and select Disable Thumbnails In Project Panel.
Adobe logo

Sign in to your account