About imported files and footage items

You import source files into a project as the basis for footage items and use them as sources for layers. The same file can be the source for multiple footage items, each with its own interpretation settings. Each footage item can be used as the source for one or more layers. You work with collections of layers in a composition.

You primarily work with footage items in the Project panel. You can use the Footage panel to evaluate footage and perform simple editing tasks, such as trimming the duration of a footage item.

You can import many different kinds of files, collections of files, or components of files as sources for individual footage items, including moving image files, still-image files, still-image sequences, and audio files. You can even create footage items yourself within After Effects, such as solids and precompositions. You can import footage items into a project at any time.

When you import files, After Effects does not copy the image data itself into your project but creates a reference link to the source of the footage item, which keeps project files relatively small.

If you delete, rename, or move an imported source file, you break the reference link to that file. When a link is broken, the name of the source file appears in italics in the Project panel, and the File Path column lists it as missing. If the footage item is available, you can reestablish the link—usually just by double-clicking the item and selecting the file again.

Note:

You can find footage items for which the source items are missing by typing missing in the search field in the Project panel. See Search and filter in the Timeline, Project, and Effects & Presets panels.

To reduce rendering time and increase performance, it is often best to prepare footage before you import it into After Effects. For example, it is often better to scale or crop a still image in Photoshop before you bring it into After Effects, rather than scaling and cropping the image in After Effects. It is better to perform an operation once in Photoshop than to force After Effects to perform the same action many times per second—once for each frame in which the image appears.

To save time and minimize the size and complexity of a project, import a source item as a single footage item and then use it multiple times in a composition. It is occasionally useful, however, to duplicate a footage item and interpret each differently. For example, you can use the same footage at two different frame rates.

If you use another application to modify a footage item that is used in a project, the changes appear in After Effects the next time that you open the project or select the footage item and choose File > Reload Footage.

Note:

To replace the source footage item for a layer with another footage item, without affecting changes made to the layer properties, select the layer and then Alt-drag (Windows) or Option-drag (Mac OS) the new footage item onto the layer in the Timeline panel.

Note:

To replace all uses of selected footage items with another footage item, select footage items in the Project panel, and then Alt-drag (Windows) or Option-drag (Mac OS) the new footage item onto a selected footage item in the Project panel.

When After Effects imports video and audio in some formats, it processes and caches versions of these items that it can readily access when generating previews. This caching greatly improves performance for previews, because the video and audio items do not need to be reprocessed for each preview. 

For more information about importing assets, see this video tutorial on the Creative COW website by Andrew Devis.

Native encoding and decoding of QuickTime files

After Effects can natively decode and encode QuickTime (.mov) files using the GoPro CineForm codecs on Mac OS and Windows. This means that you do not need to install additional codecs to use and create such files.

In MOV, After Effects has native import support for the following uncompressed formats:

  • DV, IMX, MPEG2, XDCAM, h264, JPEG, Avid DNxHD, Avid DNxHR, Apple ProRes, AVCI, and GoPro CineForm

Native export support is available for the following uncompressed formats:

  • Avid DNxHD, Avid DNxHR, DV, and GoPro CineForm

Note:

Because After Effects can natively import and export many codecs (listed above), QuickTime is not required on Windows. For more details about compatibility issues, read the blog post QuickTime on Windows

Supported import formats

Some filename extensions—such as MOV, AVI, MXF, FLV, and F4V—denote container file formats rather than denoting a specific audio, video, or image data format. Container files can contain data encoded using various compression and encoding schemes. After Effects can import these container files, but the ability to import the data that they contain is dependent on which codecs (specifically, decoders) are installed.

By installing additional codecs, you can extend the ability of After Effects to import additional file types. Many codecs must be installed into the operating system (Windows or Mac OS) and work as a component inside the QuickTime or Video for Windows formats. Contact the manufacturer of your hardware or software for more information about codecs that work with the files that your specific devices or applications create.

Importing and using some files requires the installation of additional import plug-ins. (See Plug-ins.)

Adobe Premiere Pro can capture and import many formats that After Effects can’t import natively. You can bring data from Adobe Premiere Pro into After Effects in many ways. (See Working with Adobe Premiere Pro and After Effects.)

For workflow guides and updates for P2, RED, XDCAM, AVCCAM, and DSLR cameras and footage, see the Adobe website.

Audio formats

  • Adobe Sound Document (ASND; multi-track files imported as merged single track)

  • Advanced Audio Coding (AAC, M4A)

  • Audio Interchange File Format (AIF, AIFF)

  • MP3 (MP3, MPEG, MPG, MPA, MPE)

  • Video for Windows (AVI; requires QuickTime on Mac OS)

  • Waveform (WAV)

Still-image formats

  • Adobe Illustrator (AI, AI4, AI5, EPS, PS; continuously rasterized)
  • Adobe PDF (PDF; first page only; continuously rasterized)
  • Adobe Photoshop (PSD)
  • Bitmap (BMP, RLE, DIB)
  • Camera Raw (TIF, CRW, NEF, RAF, ORF, MRW, DCR, MOS, RAW, PEF, SRF, DNG, X3F, CR2, ERF)
  • Cineon/DPX (CIN, DPX with 8-, 10-, 12-, and 16-bpc DPX files, including those with an alpha channel and timecode)
  • Discreet RLA/RPF (RLA, RPF; 16 bpc; imports camera data)
  • EPS
  • GIF
  • JPEG (JPG, JPE)
  • Maya camera data (MA)
  • Maya IFF (IFF, TDI; 16 bpc)
  • OpenEXR (EXR, SXR, MXR; 32 bpc)
  • PICT (PCT)
  • Portable Network Graphics (PNG; 16 bpc)
  • Radiance (HDR, RGBE, XYZE; 32 bpc)
  • SGI (SGI, BW, RGB; 16 bpc)
  • Softimage (PIC)

Note:

3D Channel effect plug-ins from fnord software are included with After Effects to provide access to multiple layers and channels of OpenEXR files. (See Using channels in OpenEXR files.)

Note:

After Effects can also read ZPIC files corresponding to imported PIC files. See Importing and using 3D files from other applications.)

  • Targa (TGA, VDA, ICB, VST)

  • TIFF (TIF)

Note:

You can import files of any still-image format as a sequence. See Preparing and importing still images.

Video and animation formats

  • Animated GIF (GIF)
  • Avid DNxHR
  • HEVC (H.265) MPEG-4
  • Support for ARRIRAW files from the ARRI ALEXA, or ARRIFLEX D-21 cameras
    For more information on ARRIRAW files, see the ARRIRAW FAQ on the ARRI Group website.
  • CinemaDNG

Note: CinemaDNG is a subset of Camera Raw. A subset of Camera Raw settings can be accessed via More Options in the Interpret Footage dialog box. Color management for CinemaDNG includes the same color spaces as After Effects existing Camera Raw: Adobe RGB, sRGB IEC619662.1, ColorMatch RGB, and ProPhoto RGB.

  • DV (in MOV or AVI container, or as containerless DV stream)
  • Electric Image (IMG, EI)
  • FLV, F4V
  • QuickTime (MOV; 16 bpc, only for codecs that do not have any native decoders)
  • Video for Windows (AVI, WAV; requires QuickTime on Mac OS)

  • Windows Media File (WMV, WMA, ASF; Windows only)

  • XDCAM HD and XDCAM EX

  • RED (R3D)
  • Media eXchange Format (MXF)

MXF is a container format. After Effects can only import some kinds of data contained within MXF files. After Effects can import the Op-Atom variety of MXF files used by Panasonic video cameras to record to Panasonic P2 media. After Effects can import video from these MXF files using the AVC-Intra 50, AVC-Intra 100, DV, DVCPRO, DVCPRO50, and DVCPRO HD codecs. After Effects can also import XDCAM HD files in MXF format, the MXF OP1format, which contains MPEG-2 video that complies with the XDCAM HD format.

  • MPEG-1, MPEG-2, and MPEG-4 formats: MPEG, MPE, MPG, M2V, MPA, MP2, M2A, MPV, M2P, M2T, M2TS (AVCHD), AC3, MP4, M4V, M4A
  • SWF (continuously rasterized)

Project formats

  • Adobe Premiere Pro 1.0, 1.5, 2.0, CS3, CS4, CS5, CS6, and CC (PRPROJ; 1.0, 1.5, and 2.0 Windows only), and later projects

  • Adobe After Effects 6.0 and later binary projects in After Effects CS5 (AEP, AET)

  • After Effects 7 can open projects from After Effects 3.0 through After Effects 7.

  • Adobe After Effects CS4 and later XML projects (AEPX)

The Automatic Duck Pro Import AE plug-in is now bundled with the application, and called Pro Import After Effects. With it, you can import AAF and OMF files from an Avid system, XML files from Final Cut Pro 7, or earlier, and project files from Motion 4, or earlier. For more information on using Pro Import After Effects, see its User Guide, accessible by choosing File > Import > Pro Import After Effects, then clicking the Help button.

You can also import Final Cut Pro projects into Premiere Pro and then bring that project's components into After Effects.

In this video by Todd Kopriva and video2brain, learn how to import projects using Pro Import After Effects. We demonstrate using a Final Cut Pro project, but the same procedure works for other formats, such as XML, AAF, and OMF.


Note:

 

  • After Effects can also read EIZ files corresponding to imported EI files. See Importing and using 3D files from other applications.)
  • Some MPEG data formats are stored in container formats with filename extensions that are not recognized by After Effects; examples include .vob and .mod. In some cases, you can import these files into After Effects after changing the filename extension to one of the recognized filename extensions. Because of variations in implementation in these container formats, compatibility is not guaranteed.
  • For information about MPEG formats, see the MPEG website and the MPEG page on the Wikipedia website.
  • Before working with QuickTime, read the alert issued by United States Computer Emergency Readiness Team in April 2016, which recommends Windows users uninstall Apple QuickTime from their computers.
  • R3D files are interpreted as containing 32-bpc colors in a non-linear HDTV (Rec. 709) color space. The RED R3D Source Settings color adjustments don't preserve overbright values. Color adjustments done within After Effects do preserve overbright colors when you work in 32-bpc (bits per channel) color. To avoid clipping, manipulate exposure in After Effects, rather than in the footage interpretation stage in the RED R3D Source Settings dialog box. (For more information on using R3D files, see the RED website and the Adobe website.)
  • After Effects can import Sony XDCAM HD assets if they were recorded to MXF files. After Effects cannot import XDCAM HD assets in IMX format. After Effects can import Sony XDCAM EX assets stored as essence files with the .mp4 filename extension in a BPAV directory. For information about the XDCAM format, see this PDF document on the Sony website.
  • SWF files are imported with an alpha channel. Audio is not retained. Interactive content and scripted animation are not retained. Animation defined by keyframes in the main, top-level movie is retained.

Import footage items

You can import media files into your project either by using the Import dialog box or by dragging. The imported footage items appear in the Project panel.

If the Interpret Footage dialog box appears after you import a footage item, it contains an unlabeled alpha channel, and you must select an alpha channel interpretation method or click Guess to let After Effects determine how to interpret the alpha channel. (See Alpha channel interpretation: premultiplied or straight.)

Import footage items using the Import dialog box

  1. Choose File > Import > File, choose File > Import > Multiple Files, or double-click an empty area of the Project panel.

    If you choose Import Multiple Files, then you can perform the next step more than once without needing to choose an Import command multiple times.

    Note:

    To display only supported footage files (excluding project files), choose All Footage Files from the Files Of Type (Windows) or Enable (Mac OS) menu.

  2. Do one of the following:
    • Select a file, and then click Open.

    • Ctrl-click (Windows) or Command-click (Mac OS) multiple files to select them, and then click Open.

    • Click a file and then Shift-click another file to select a range of files, and then click Open.

    • (Windows only) Select an entire folder, and then click Import Folder.

    Note:

    If the Sequence option is selected, multiple files from the folder are imported as a sequence of still images.  

Import footage items by dragging

Note:

If you always want the layered still-image files that you drag into After Effects to be imported as a composition, choose Edit > Preferences > Import (Windows) or After Effects > Preferences > Import (Mac OS), and choose Composition or Composition - Retain Layer Sizes from the Drag Import Multiple Items As menu. (See Import a still-image sequence as a composition.)

  • To import a single file, drag it from Windows Explorer (Windows) or the Finder (Mac OS) into the Project panel.
  • To import the contents of a folder as a sequence of still images that appear in the Project panel as a single footage item, drag a folder from Windows Explorer (Windows) or the Finder (Mac OS) into the Project panel.
  • To import the contents of the folder as individual footage items that appear in the Project panel in a folder, Alt-drag a folder from Windows Explorer (Windows) or Option-drag a folder from the Finder (Mac OS) into the Project panel.
  • To import a rendered output file from the Render Queue panel, drag the corresponding output module from the Render Queue panel into the Project panel.

Note:

If you drag an output module from the Render Queue panel into the Project panel before rendering, After Effects creates a placeholder footage item. References to the placeholder footage item are automatically replaced when the output module is rendered; the placeholder footage item itself is not replaced.

Interpret footage items

After Effects uses a set of internal rules to interpret each footage item that you import according to its best guess for the source file’s pixel aspect ratio, frame rate, color profile, and alpha channel type. If After Effects guesses wrong, or if you want to use the footage differently, you can modify these rules for all footage items of a particular kind by editing the interpretation rules file (interpretation rules.txt), or you can modify the interpretation of a specific footage item using the Interpret Footage dialog box.

The interpretation settings tell After Effects the following about each footage item:

Note:

In all of these cases, the information is used to make decisions about how to interpret data in the imported footage item—to tell After Effects about the input footage. The interpretation settings in the Interpret Footage dialog box should match the settings used to create the source footage file. Do not use the interpretation settings to try to specify settings for your final rendered output.

Generally, you don’t need to change interpretation settings. However, if a footage item isn’t of a common kind, After Effects may need additional information from you to interpret it correctly.

You can use the controls in the Color Management section of the Interpret Footage dialog box to tell After Effects how to interpret the color information in a footage item. This step is usually only necessary when the footage item does not contain an embedded color profile.

When you preview in the Footage panel, you see the results of the footage interpretation operations.

Jeff Almasol provides a script on his redefinery website that you can use to make guessing the 3:2 pulldown, 24Pa pulldown, or alpha channel interpretation more convenient.

Note:

Select Preview in the Interpret Footage dialog box to preview the results of the settings made in this dialog box before you accept the changes.

Interpret a single footage item using the Interpret Footage dialog box

  • Select a footage item in the Project panel and do one of the following:
    • Click the Interpret Footage button at the bottom of the Project panel.

    • Drag the footage item to the Interpret Footage button.

    • Choose File > Interpret Footage > Main.

    • Press Ctrl+Alt+G (Windows) or Command+Option+G (Mac OS).

Interpret a proxy using the Interpret Footage dialog box

  • Select the original footage item in the Project panel and do one of the following:
    • Alt-click (Windows) or Option-click (Mac OS) the Interpret Footage button at the bottom of the Project panel.

    • Alt-drag (Windows) or Option-drag (Mac OS) the footage item to the Interpret Footage button.

    • Choose File > Interpret Footage > Proxy.

Apply Interpret Footage settings to multiple footage items

You can ensure that different footage items use the same settings by copying interpretation settings from one item and applying them to others.

  1. In the Project panel, select the item with the interpretation settings that you want to apply.
  2. Choose File > Interpret Footage > Remember Interpretation.
  3. Select one or more footage items in the Project panel.
  4. Choose File > Interpret Footage > Apply Interpretation.

Edit interpretation rules for all items of a specific kind

The interpretation rules file contains the rules that specify how After Effects interprets footage items. In most cases, you don’t need to customize the interpretation rules file. When you import a footage item, After Effects looks for a match in the interpretation rules file, and then determines interpretation settings for the footage item. You can override these settings after importing, using the Interpret Footage dialog box.

In most cases, the name of the interpretation rules file is interpretation rules.txt; however, some updates to After Effects install a new interpretation rules file with a name that indicates the updated version number, and the updated application uses this new file. If you’ve made changes to the old interpretation rules file, you may need to apply those changes to the new file, too.

Locations of the interpretation rules file in After Effects CC:

  • (Windows) <drive>\Users\<username>\AppData\Roaming\Adobe\After Effects <13.0>
  • (Mac OS) <drive>/Users/<username>/Library/Preferences/Adobe/After Effects <13.0>

Locations of the interpretation rules file in previous versions of After Effects CC:

  • (Windows) <drive>\Users\<username>\AppData\Roaming\Adobe\After Effects <12.x>
  • (Mac OS) <drive>/Users/<username>/Library/Preferences/Adobe/After Effects <12.x>
  1. Quit After Effects.
  2. As a precaution, make a backup copy of the interpretation rules file. By default, this file is in the same location as the After Effects application.
  3. Open the interpretation rules file in a text editor.
  4. Modify the settings according to the instructions in the file.

    Note:

    You must supply a four-character file-type code for each footage type or codec. If you don’t know the code for a file or codec in a project, press Alt (Windows) or Option (Mac OS) as you select the file in the Project panel. The file-type code and codec code (if the file is compressed) appear in the last line of the file description at the top of the Project panel.

  5. Save interpretation rules.txt.

Alpha channel interpretation: premultiplied or straight

Image files with alpha channels store transparency information in one of two ways: straight or premultiplied. Although the alpha channels are the same, the color channels differ.

With straight (or unmatted) channels, transparency information is stored only in the alpha channel, not in any of the visible color channels. With straight channels, the results of transparency aren’t visible until the image is displayed in an application that supports straight channels.

With premultiplied (or matted) channels, transparency information is stored in the alpha channel and also in the visible RGB channels, which are multiplied with a background color. Premultiplied channels are sometimes said to be matted with color. The colors of semitransparent areas, such as feathered edges, are shifted toward the background color in proportion to their degree of transparency.

Some software lets you specify the background color with which the channels are premultiplied; otherwise, the background color is usually black or white.

Straight channels retain more accurate color information than premultiplied channels. Premultiplied channels are compatible with a wider range of programs, such as Apple QuickTime Player. Often, the choice of whether to use images with straight or premultiplied channels has been made before you receive the assets to edit and composite. Adobe Premiere Pro and After Effects recognize both straight and premultiplied channels, but only the first alpha channel they encounter in a file containing multiple alpha channels.

Setting the alpha channel interpretation correctly can prevent problems when you import a file, such as undesirable colors at the edge of an image or a loss of image quality at the edges of the alpha channel. For example, if channels are interpreted as straight when they are actually premultiplied, semitransparent areas retain some of the background color. If a color inaccuracy, such as a halo, appears along the semitransparent edges in a composition, try changing the interpretation method.

Premultiplied channels
A footage item with premultiplied channels (top) appears with a black halo when interpreted as Straight-Unmatted (lower-left). When the footage item is interpreted as Premultiplied-Matted With Color and the background color is specified as black, the halo does not appear (lower-right).

You can use the Remove Color Matting effect to remove the fringes from the semi-transparent areas of a layer by unmultiplying it.

Set the alpha channel interpretation for a footage item

  1. In the Project panel, select a footage item.
  2. Choose File > Interpret Footage > Main.
  3. If you want to switch the opaque and transparent areas of the image, select Invert Alpha.
  4. In the Alpha section, select an interpretation method:

    Guess

    Attempts to determine the type of channels used in the image. If After Effects cannot guess confidently, it beeps.

    Ignore

    Disregards transparency information contained in the alpha channel.

    Straight - Unmatted

    Interprets the channels as straight.

    Premultiplied - Matted With Color

    Interprets channels as premultiplied. Use the eyedropper or color picker to specify the color of the background with which the channels were premultiplied.

Set the default alpha channel preferences

  1. Choose Edit > Preferences > Import (Windows) or After Effects > Preferences > Import (Mac OS).
  2. Choose options from the Interpret Unlabeled Alpha As menu. The options in this menu are similar to the options in the Interpret Footage dialog box. Ask User specifies that the Interpret Footage dialog box opens each time a footage item with an unlabeled alpha channel is imported.

Frame rate

The composition frame rate determines the number of frames displayed per second, and how time is divided into frames in the time ruler and time display. In other words, the composition frame rate specifies how many times per second images are sampled from the source footage items, and it specifies the time divisions at which keyframes can be set.

Note:

After Effects contains a menu for drop-frame or non-drop-frame timecode in the Composition Settings dialog box. In previous releases, this option was a global setting per project.

Composition frame rate is usually determined by the type of output that you are targeting. NTSC video has a frame rate of 29.97 frames per second (fps), PAL video has a frame rate of 25 fps, and motion picture film typically has a frame rate of 24 fps. Depending on the broadcast system, DVD video can have the same frame rate as NTSC video or PAL video, or a frame rate of 23.976. Cartoons and video intended for CD-ROM or the web are often 10–15 fps.

Note:

Setting the composition frame rate to twice the rate of the output format causes After Effects to display each field of interlaced source footage as its own, separate frame in the Composition panel. This process lets you set keyframes on individual fields and gain precision when animating masks.

When you render a movie for final output, you can choose to use the composition frame rate or another frame rate. The ability to set the frame rate for each output module is useful when you are using the same composition to create output for multiple media.

Each motion-footage item in a composition can also have its own frame rate. The relationship between the footage-item frame rate and the composition frame rate determines how smoothly the layer plays. For example, if the footage-item frame rate is 30 fps and the composition frame rate is 30 fps, then whenever the composition advances one frame, the next frame from the footage item is displayed. If the footage-item frame rate is 15 fps and the composition frame rate is 30 fps, then each frame of the footage item appears in two successive frames of the composition. (This assumes, of course, the simple case in which no time stretching or frame blending has been applied to the layer.)

Ideally, use source footage that matches the final output frame rate. This way, After Effects renders each frame, and the final output does not omit, duplicate, or interpolate frames. If, however, the source footage has a frame rate slightly different from what you want to output to (for example, 30-fps footage and 29.97-fps final output), you can make the footage frame rate match the composition frame rate by conforming it.

Conforming the frame rate of a footage item does not alter the original file, only the reference that After Effects uses. When conforming, After Effects changes the internal duration of frames but not the frame content. Afterward, the footage plays back at a different speed. For example, if you conform the frame rate from 15 fps to 30 fps, the footage plays back twice as fast. In most cases, conform the frame rate only when the difference between the footage frame rate and the output frame rate is small.

Note:

Conforming can change the synchronization of visual footage that has an audio track, because changing the frame rate changes the duration of the video but leaves the audio unchanged. If you want to stretch both audio and video, use the Time Stretch command. (See Time-stretch a layer.) Keyframes applied to the source footage remain at their original locations (which retains their synchronization within the composition but not the visual content of the layer). You may need to adjust keyframe locations after conforming a footage item.

You can change the frame rate for any movie or sequence of still images. For example, you can import a sequence of ten still images and specify a frame rate for that footage item of 5 frames per second (fps); this sequence would then have a duration of two seconds when used in a composition.

Note:

When you import a sequence of still images, it assumes the frame rate specified by the Sequence Footage preference in the Import category. The default rate is 30 frames per second (fps). You can change the frame rate after importing by reinterpreting the footage item. (See Interpret footage items.)

Lower frame rates tend to give the impression of unreality, so many people prefer to work at a lower frame rate such as 24 frames per second for creative work instead of working at the 29.97 frames per second that is standard for NTSC video.

Note:

If you remove 3:2 pulldown from interlaced video footage, After Effects automatically sets the frame rate of the resulting footage item to four-fifths of the original frame rate. When removing 3:2 pulldown from NTSC video, the resulting frame rate is 24 fps.

The frame rate of the composition should match the frame rate of the final output format. In most cases, you can simply choose a composition settings preset. In contrast, set the frame rate for each footage item to the frame rate of the original source footage.

Trish and Chris Meyer provide tips and tricks regarding conforming footage items to a specific frame rate in an article (PDF) on Artbeats website.

Change frame rate for a footage item

  1. Select the footage item in the Project panel.
  2. Choose File > Interpret Footage > Main.
  3. Select Conform To Frame Rate, enter a new frame rate for Frames Per Second, and then click OK.

Note:

Instead of using Interpret Footage to change a footage item’s frame rate, you can time-stretch a layer based on the footage item. For example, time-stretch a layer by 100.1% to convert between 30fps and 29.97fps. Time-stretching modifies the speed of audio as well as video. (See Time-stretch a layer.)

Change frame rate for a composition

  1. Choose Composition > Composition Settings.
  2. Do one of the following:
    • Choose a composition settings preset from the Preset menu.

    • Set the Frame Rate value.

Note:

Jeff Almasol provides a script on is redefinery website to set the frame rate and duration of the current composition and all compositions nested within it.

Pixel aspect ratio and frame aspect ratio

Pixel aspect ratio (PAR) is the ratio of width to height of one pixel in an image. Frame aspect ratio (sometimes called image aspect ratio or IAR) is the ratio of width to height of the image frame.

Frame aspect ratio
A 4:3 frame aspect ratio (left), and a wider 16:9 frame aspect ratio (right)

Most computer monitors use square pixels, but many video formats—including ITU-R 601 (D1) and DV—use non-square rectangular pixels.

Some video formats output the same frame aspect ratio but use a different pixel aspect ratio. For example, some NTSC digitizers produce a 4:3 frame aspect ratio, with square pixels (1.0 pixel aspect ratio), and a frame with pixel dimensions of 640x480. D1 NTSC produces the same 4:3 frame aspect ratio but uses nonsquare pixels (0.91 pixel aspect ratio) and a frame with pixel dimensions of 720x486. D1 pixels, which are always nonsquare, are vertically oriented in systems producing NTSC video and horizontally oriented in systems producing PAL video.

If you display nonsquare pixels on a square-pixel monitor without alteration, images and motion appear distorted; for example, circles distort into ellipses. However, when displayed on a video monitor, the images are correct. When you import D1 NTSC or DV source footage into After Effects, the image looks slightly wider than it does on a D1 or DV system. (D1 PAL footage looks slightly narrower.) The opposite occurs when you import anamorphic footage using D1/DV NTSC Widescreen or D1/DV PAL Widescreen. Widescreen video formats have a frame aspect ratio of 16:9.

Note:

To preview non-square pixels on a computer monitor, click the Toggle Pixel Aspect Ratio Correction button  at the bottom of the Composition panel. The quality of the pixel aspect ratio correction for previews is affected by the Zoom Quality preference in the Previews category. (See Viewer Quality preferences.)

Square and nonsquare pixels
Square and nonsquare pixels

A. Square pixels and 4:3 frame aspect ratio B. Nonsquare pixels and 4:3 frame aspect ratio C. Nonsquare pixels displayed on a square-pixel monitor 

If a footage item uses nonsquare pixels, After Effects displays the pixel aspect ratio next to the thumbnail image for the footage item in the Project panel. You can change the pixel aspect ratio interpretation for individual footage items in the Interpret Footage dialog box. By ensuring that all footage items are interpreted correctly, you can combine footage items with different pixel aspect ratios in the same composition.

After Effects reads and writes pixel aspect ratios directly from QuickTime movies. For example, if you import a movie captured as widescreen (16:9 DV), After Effects automatically tags it correctly. Similarly, AVI and PSD files contain information that explicitly indicates the pixel aspect ratio of the images.

If a footage item does not contain information that explicitly indicates the pixel aspect ratio of the image, After Effects uses the pixel dimensions of the footage item frame to make a guess. When you import a footage item with either the D1 pixel dimensions of 720x486 or the DV pixel dimensions of 720x480, After Effects automatically interprets that footage item as D1/DV NTSC. When you import a footage item with the D1 or DV pixel dimensions of 720x576, After Effects automatically interprets that footage item as D1/DV PAL. However, you can make sure that all files are interpreted correctly by looking in the Project panel or the Interpret Footage dialog box.

Note:

Make sure to reset the pixel aspect ratio to Square Pixels when you import a square-pixel file that happens to have a D1 or DV pixel dimensions—for example, a non-DV image that happens to have pixel dimensions of 720x480.

The pixel aspect ratio setting of the composition should match the pixel aspect ratio of the final output format. In most cases, you can simply choose a composition settings preset. In contrast, set the pixel aspect ratio for each footage item to the pixel aspect ratio of the original source footage.

Trish and Chris Meyer provide tips and tricks regarding pixel aspect ratio in two PDF documents on the Artbeats website:

Chris Pirazzi provides technical details about aspect ratios on his Lurker's Guide to Video website.

Upgrade pixel aspect ratios to correct values

After Effects CS3 and earlier used pixel aspect ratios for standard-definition video formats that ignore the concept of clean aperture. By not accounting for the fact that clean aperture differs from production aperture in standard-definition video, the pixel aspect ratios used by After Effects CS3 and earlier were slightly inaccurate. The incorrect pixel aspect ratios cause some images to appear subtly distorted.

Note:

The clean aperture is the portion of the image that is free from artifacts and distortions that appear at the edges of an image. The production aperture is the entire image.

Todd Kopriva summarizes information about the corrected pixel aspect ratios in a post on the Adobe website.

The following table provides details about pixel aspect ratio values in After Effects:

format

value in After Effects CS4 and later

previous value

D1/DV NTSC

0.91

0.9

D1/DV NTSC Widescreen

1.21

1.2

D1/DV PAL

1.09

1.07

D1/DV PAL Widescreen

1.46

1.42

This discrepancy is limited to these older, standard-definition formats for which clean aperture differs from production aperture. This discrepancy doesn’t exist in newer formats.

New projects and compositions created in After Effects CS4 and later use the correct pixel aspect ratio values by default.

Projects and compositions created in After Effects CS3 or earlier are upgraded to use the correct pixel aspect ratios when these projects are opened in After Effects CS4 and later.

Note:

If you have a custom interpretation rules file, then you should update it with the correct pixel aspect ratio values.

If you use square-pixel footage items that are designed to fill the frame in a composition with non-square pixels, you may find that the change in pixel aspect ratios causes a difference in behavior. For example, if you previously created 768x576 square-pixel footage items to use in a PAL D1/DV composition, you should now create those items with square-pixel dimensions of 788x576.

Composition settings presets for square-pixel equivalents of standard definition formats have changed as follows:

format

pixel dimensions in After Effects CS4 and later

previous pixel dimensions

NTSC D1 square-pixel equivalent

720x534

720x540

NTSC D1 Widescreen square-pixel equivalent

872x486

864x486

PAL D1/DV square-pixel equivalent

788x576

768x576

PAL D1/DV Widescreen square-pixel equivalent

1050x576

1024x576

Change pixel aspect ratio interpretation for a footage item

  1. Select a footage item in the Project panel.
  2. Choose File > Interpret Footage > Main.
  3. Choose a ratio from the Pixel Aspect Ratio menu and click OK.

Change pixel aspect ratio for a composition

  1. Choose Composition > Composition Settings.
  2. Do one of the following:
    • Choose a composition settings preset from the Preset menu.

    • Choose a value from the Pixel Aspect Ratio menu.

Common pixel aspect ratios

Pixel aspect ratio

When to use

Square pixels

1.0

Footage has a 640x480 or 648x486 frame size, is 1920x1080 HD (not HDV or DVCPRO HD), is 1280x720 HD or HDV, or was exported from an application that doesn’t support nonsquare pixels. This setting can also be appropriate for footage that was transferred from film or for customized projects.

D1/DV NTSC

0.91

Footage has a 720x486 or 720x480 frame size, and the desired result is a 4:3 frame aspect ratio. This setting can also be appropriate for footage that was exported from an application that works with nonsquare pixels, such as a 3D animation application.

D1/DV NTSC Widescreen

1.21

Footage has a 720x486 or 720x480 frame size, and the desired result is a 16:9 frame aspect ratio.

D1/DV PAL

1.09

Footage has a 720x576 frame size, and the desired result is a 4:3 frame aspect ratio.

D1/DV PAL Widescreen

1.46

Footage has a 720x576 frame size, and the desired result is a 16:9 frame aspect ratio.

Anamorphic 2:1

2.0

Footage was shot using an anamorphic film lens, or it was anamorphically transferred from a film frame with a 2:1 aspect ratio.

HDV 1080/DVCPRO HD 720, HD Anamorphic 1080

1.33

Footage has a 1440x1080 or 960x720 frame size, and the desired result is a 16:9 frame aspect ratio.

DVCPRO HD 1080

1.5

Footage has a 1280x1080 frame size, and the desired result is a 16:9 frame aspect ratio.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy