问题

PDFMaker 图标(“转换为 Adobe PDF”)和 Acrobat 菜单在 Microsoft Office 2003、XP 或 2000 应用程序(例如,Access、Excel、Word)中丢失。

解决方案

执行以下一个或多个解决方案:

解决方案 1:将 Adobe PDF 从 Microsoft Office 应用程序的“禁用项目”列表中删除。

  1. 打开 Microsoft Office 程序(Word、Excel、Publisher 或 Excel)。
  2. 转到“帮助”>“关于 [程序名称]”。
  3. 单击“禁用项目”。
  4. 从列表中选择“Adobe PDF”,然后单击“启用”。
  5. 退出 Microsoft Office 程序,然后重新启动。

注意:如果 Microsoft Office 应用程序提前结束(例如,系统非正常关闭或应用程序崩溃),Microsoft Office 应用程序会以禁用加载项作为故障保护手段。

解决方案 2:确保安装 PDFMaker 组件。

  1. 选择“开始”>“运行”,在“打开”文本框中键入 appwiz.cpl,然后单击“确定”以打开“添加或删除程序”对话框。
  2. 找到并选择 Adobe Acrobat 7 或 Adobe Acrobat 8,然后单击“更改/删除”。
  3. 出现“向导”后单击“下一步”。
  4. 选择“修改”,然后再次单击“下一步”。
  5. 展开“创建 Adobe PDF”树状图,然后单击“Acrobat PDFMaker”对象上的下拉箭头。
  6. 选择“此功能将安装在本地硬盘驱动器上”,单击“下一步”,然后单击“更新”。

解决方案 3:在 Office 应用程序中启用 COM 加载项文件。

  1. 启动 Office 应用程序。
  2. 选择“帮助”>“关于 [应用程序]”。
  3. 单击“禁用项目”。
  4. 查看 PDFMakerOfficeAddin 是否列出:
    • 如果已经列出,则选择此项目,然后单击“启用”。关闭所有对话框,然后重新启动 Office 应用程序。
    • 如果没有列出,则请确保 PDFMOfficeAddin.dll 位于 Acrobat 7.0/PDFMaker/Office(Acrobat 7,Acrobat 3D)或 Acrobat 8.0/PDFMaker/Office (Acrobat 8) 文件夹中。如果文件丢失,则请重新安装 Acrobat。

解决方案 4:重命名 Normal.dot 文件。

要防止全局模板 (Normal.dot) 中存储的格式、自动图文集和宏影响 Microsoft Word 和其他应用程序的行为,请重命名全局模板 (Normal.dot)。执行此操作后,就可以快速确定全局模板是否是导致问题的原因。

重要:重命名 Normal.dot 模板时会将若干选项重置为默认设置,其中包括自定义样式、自定义工具栏、宏和自动图文集输入。因此,Microsoft 强烈建议请勿删除 Normal.dot 文件。

某些配置可能会创建多个 Normal.dot 文件。例如,如果计算机运行 Word 的多个版本,或者如果同一台计算机上存在多个工作站安装,则可能会出现此问题。

要重命名 Normal.dot 文件,请执行以下操作:

注意:以下步骤针对于 Microsoft Word,但是稍加改动也可用于其他 Microsoft Office 应用程序。完成此步骤后,请勿使用 /a 开关重新启动 Word 或其他应用程序。

在 Windows 2000 上:

  1. 退出所有 Word 实例,如果是将 Word 作为电子邮件编辑器,则还要退出 Outlook。
  2. 选择“开始”>“搜索”>“搜索文件或文件夹”。
  3. 在“要搜索的文件或文件夹名为”方框中,键入 Normal.dot
  4. 在“在这里寻找”方框中,选择本地硬盘。
  5. 单击“立即搜索”以搜索文件。
  6. 对“搜索结果”对话框中出现的每一个 Normal.dot 文件执行以下操作:
    • 右键单击文件,然后选择“重命名”。
    • 重新命名文件(例如,OldNormal.dot 或 Normal-1.dot),然后按 Enter 键。
  7. 在“文件”菜单中,单击“关闭”以退出“搜索”,然后重新启动 Word。

在 Windows XP 上:

  1. 退出所有 Word 实例,如果是将 Word 作为电子邮件编辑器,则还要退出 Outlook。
  2. 选择“开始”>“搜索”。
  3. 在“您要查找什么”下面,选择“所有文件和文件夹”。
  4. 在“完整或部分文件名”方框中,键入:Normal.dot
  5. 在“在这里寻找”方框中,选择本地硬盘(如果您是从网络服务器运行 Word,则选择其他用户模板位置)。
  6. 单击“搜索”。
  7. 对“搜索结果”对话框中出现的每一个 Normal.dot 文件执行以下操作:
    • 右键单击文件,然后选择“重命名”。
    • 重新命名文件(例如,OldNormal.dot 或 Normal-1.dot),然后按 Enter 键。
  8. 在“文件”菜单中,单击“关闭”,然后重新启动 Word。

如果重命名全局模板后问题得以解决,则表明损坏的 Normal.dot 模板是问题所在。

解决方案 5:在 Office 应用程序中更改宏的安全性级别。

要将 COM 加载项文件载入 Windows,必须满足以下任一条件:在“受信任的发布者”选项卡中列出 Adobe Inc.,或者更改安全性设置。

在 Office 2000、XP 或 2003 应用程序中,执行以下操作:

  1. 从“工具”菜单中,选择“宏”>“安全性”。
  2. 单击“受信任的发布者”选项卡:
    1. 如果 Adobe Inc. 已经列出,则无需执行任何更改。

    2. 如果 Adobe Inc. 没有列出,则继续执行第 3 步操作。

  3. 选择以下任一设置:
    • 在“安全性”选项卡中,将安全级设置为“非常高”;在“受信任的发布者”选项卡中,选择“信任所有安装的加载项和模板”。
    • 在“安全性”选项卡中,将安全级设置为“高”;在“受信任的发布者”选项卡中,取消选择“信任所有安装的加载项和模板”。
  4. 关闭所有对话框,然后重新启动应用程序。

解决方案 6:将 COM 加载项文件添加至 Windows 注册表。

  1. 在“Windows 资源管理器”中,找到 COM 加载项文件 (PDFMOfficeAddin.dll) 并记录下具体路径,其中可能包含空格。
  2. 选择“开始”>“运行”。
  3. 键入 regsvr32 并在后面键入空格,然后键入您在第 1 步操作中记录的路径,并将路径放在引号内。例如:

    regsvr32 "C:\Program Files\Adobe\Acrobat 8.0\PDFMaker\Office"
  4. 单击“确定”,然后启动 Office 应用程序。

解决方案 7:在没有运行其他应用程序的时候,运行“检测和修复”。

  1. 退出所有应用程序,然后重新启动 Windows。
  2. 启动 Acrobat。
  3. 选择“帮助”>“检测和修复”,然后按照屏幕上的指示操作。
  4. 修复完成后,重新启动计算机。

解决方案 8:删除 Acrobat,然后在简化模式下重新安装 Acrobat。

随 Windows 自动加载的设备驱动程序和软件(例如,屏幕保护程序和病毒防护实用工具)可能会与 Acrobat 安装程序冲突并导致问题。要避免冲突,请在 Windows 简化模式下重新安装 Acrobat。在简化模式下,非标准设备驱动程序和启动软件会被禁用。

要删除 Acrobat,请执行以下操作:

  1. 将所有个人文件移出 Acrobat 应用程序文件夹及其子文件夹。
  2. 选择“开始”>“设置”>“控制面板”,然后双击“添加或删除程序”。
  3. 选择 Adobe [Acrobat 产品],然后单击“删除”。按照屏幕上的指示删除应用程序。
  4. 重新启动计算机。

要在简化模式下重新安装 Acrobat,请执行以下操作:

  1. 退出打开的应用程序。
  2. 在“Windows 资源管理器”中,将以下文件夹中的所有图标和快捷方式移到另一个文件夹:
    • Documents and Settings/All Users/「开始」菜单/程序/启动
    • Documents and Settings/ [用户配置文件] /「开始」菜单/程序/启动
  3. 重新启动 Windows。
  4. 右键单击任务栏,然后选择“任务管理器”。
  5. 单击“应用程序”选项卡。
  6. 选择所有正在运行的应用程序,然后单击“结束任务”。
  7. 在安装媒介中双击 Setup.exe 文件,按照屏幕上的指示完成安装。
  8. 要在安装完成后重新启用启动项,请将第 2 步操作中移动的图标和快捷方式移回相应的“启动”文件夹。

解决方案 9:从 Word 中删除宏。

  1. 选择“工具”>“模板和加载项”。
  2. 选择各个项目,然后单击“删除”。
  3. 退出并重新启动 Word。



    注意:
    如果“转换为 PDF”图标仍然丢失,请选择“工具”>“模板和加载项”,然后确保删除的项目不再出现。如果删除的项目仍然出现,请从 Word 中删除宏,或者删除将宏安装到 Word 的应用程序。

解决方案 10:从 Word 中删除其他 COM 加载项文件。

  1. 启动 Word。
  2. 选择“工具”>“自定义”。
  3. 单击“命令”选项卡,然后在“类别”列表中选择“工具”。
  4. 选择 COM 加载项,然后将其拖动到 Word 工具栏。
  5. 单击 Word 工具栏上的“COM 加载项”菜单。
  6. 选择并删除“网页向导”和“Microsoft Word 字体工具”之外的所有加载项。
  7. 退出并重新启动 Word。

解决方案 11:修复 Access(仅限 Access)。

如果您安装 Office XP 或 Office 2003 之后安装了 Access 2000,则必须先进行 Office 修复,然后 PDFMaker 菜单才会出现。

  1. 选择“开始”>“设置”>“控制面板”>“添加/删除程序”(Windows 2000) 或者“开始”>“控制面板”>“添加或删除程序”(Windows XP)。
  2. 选择“Microsoft Office”,然后单击“更改”。
  3. 在“设置”对话框中,选择“重新安装”(Office 2003) 或“修复”(Office XP),然后单击“下一步”。
  4. 选择“检测并修复 Office 安装中的错误”,然后单击“安装”。

解决方案 12:自定义“工具栏”选项(仅限 Access)。

  1. 选择“查看”>“工具栏”>“自定义”。
  2. 在“工具栏”选项卡中,选择“实用工具 1”和“菜单栏”选项。
  3. 单击“属性”。
  4. 选择“允许显示/隐藏”。

解决方案 13:从系统中删除早期版本的 PDFMaker 文件。

  1. 选择“开始”>“搜索”。
  2. 选择“所有文件和文件夹”。
  3. 在标有“完整或部分文件名:”的文本框中键入 PDFMaker.*
  4. 单击“搜索”。

    注意:此搜索可能会持续几分钟,具体视系统速度而定。
  5. 将搜索结果中的所有系统文件(例如,PDFMaker.DOT 或 PDFMaker.XLA)删除。不需要删除您创建的名为 PDFMaker 的文档(例如,PDFMaker.doc 或 PDFMaker.pdf)。

解决方案 14:删除 Microsoft Works。

Adobe 已经确认 Microsoft Works 会与 Microsoft Word 冲突,因此会阻止“转换为 Adobe PDF”菜单出现在 Word 中。许多计算机上都预安装了 Microsoft Works。

要删除 Microsoft Works,请执行以下操作:

  1. 选择“开始”>“运行”,在“打开”文本框中键入 appwiz.cpl,然后单击“确定”以打开“添加或删除程序”对话框。
  2. 找到并选择 Microsoft Works,然后单击“更改/删除”。
  3. 出现“向导”后单击“下一步”。
  4. 选择“删除”,单击“下一步”,然后按照屏幕上剩余的提示操作。

其他信息

Acrobat 7.0-8.0 会将一个 COM 加载项文件安装到 Acrobat 7.0/PDFMaker/Office 或 Acrobat 8.0/PDFMaker/Office 文件夹。此文件提供适用于 Word、Excel、PowerPoint、Access、Publisher 和 Project 的 PDFMaker 图标和菜单命令。COM 加载项文件必须先登记到 Windows 注册表,才会出现在应用程序中。

如果 Office 应用程序崩溃且禁用了 COM 加载项文件,PDFMaker 图标不会出现在工具栏中。

其他 COM 加载项文件和宏可能会与 PDFMaker 的 COM 加载项文件冲突,因此可能会阻止“转换为 PDF”图标显示在工具栏中。

在 Access 中,如果无法看到“实用工具 1 工具栏”,则 PDFMaker 图标将不会出现。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略