Løs Generator-fejlen, når du starter Adobe Photoshop

Sidst opdateret den 29. okt. 2026

Lær, hvordan du løser Generator-fejlen i Adobe Photoshop ved at kontrollere sikkerhedsindstillinger, fjerne modstridende plug-ins og gennemgå logfiler.

Generator er en Node.js-app, der håndterer kommunikationen mellem Photoshop og Generator-plugins.Den indeholder logikken til oprettelse af aktiver til Eksportér som og Billedaktiver.

Når du starter Photoshop eller vælger Arkiv > Eksportér > Eksportér som, vises der en dialog, hvor der står: "Der er et problem med Generator. Afslut Photoshop, og prøv igen. Hvis problemet fortsætter, skal du fjerne eventuelle tredjepartsplugins eller forsøge at geninstallere Photoshop."

Prøv følgende løsninger i rækkefølge.

Sikkerhedssoftware blokerer Generator

Sikkerheds- eller antivirussoftware kan blokere kommunikationen fra Generator på port 8010 eller forhindre node-processen i at køre.

Åbn dine sikkerheds- eller antivirusindstillinger.

Tilføj Photoshop til listen over tilladte apps.

Sørg for, at port 8010 er åben for Generator.

Tilføj node.exe til listen over tilladte apps på C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe i Windows.

På macOS skal du tillade node-processen på /Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node.

I Windows skal du give Photoshop adgang til kontrollerede mapper.

Genstart Photoshop, og vælg derefter Filer > Eksportér > Eksportér som for at teste Generator.

Et tredjepartsplugin er i konflikt med Generator

Tredjepartsplugins i mappen Photoshop Generator kan være uforenelige med din nuværende version eller være i konflikt med standardpluginet Billedaktiver.

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

Opret en midlertidig mappe på skrivebordet med navnet Disabled Generator Plug-ins.

Flyt mapperne med tredjepartsplugins til den midlertidige mappe. Lad standardpluginnet Billedaktiver blive i mappen Generator.

Start Photoshop, og vælg Arkiv > Eksportér > Eksportér som.

Hvis fejlen er væk, skal du tilføje pluginsene igen én for én og genstarte Photoshop efter hver tilføjelse, indtil fejlen vender tilbage.

Lad standardplugin'et Billedelementer blive i Generator-mappen.Flyt kun plugins, som du har installeret separat.

Generator kan ikke starte, og du har ikke brug for den

Hvis du ikke bruger Eksporter som eller Billedelementer, kan du slå Generator fra som en løsning.

Start Photoshop.

I Windows skal du vælge Rediger > Indstillinger > Plug-ins.På macOS skal du vælge Photoshop > Indstillinger > Plug-ins.

Fjern markeringen ved Aktivér Generator.

Vælg OK, og genstart derefter Photoshop.

Hvis du vælger Filer > Eksporter > Eksporter som, slås Generator til igen.Hvis du har brug for Eksporter som, skal du løse Generator-fejlen i stedet for at lade Generator være slået fra.

Generator-logfiler viser opstartsfejl

Generator-logfiler kan indeholde oplysninger om plugins, der ikke kan indlæses, eller systemproblemer, der forhindrer Generator i at starte.

I Windows skal du navigere til C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator.

På macOS skal du navigere til /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator.

Åbn den nyeste Generator-logfil, og se efter fejlmeddelelser.

Hvis mappen Generator ikke findes, skal du kontrollere, at du har skriverettigheder til den overordnede mappe.

Hvis du har brug for yderligere hjælp, kan du bruge Adobe Log Collector Tool til at indsamle diagnostiske logfiler.

Mapperne AppData i Windows og Library på macOS er skjulte som standard.Instruktioner til at vise skjulte filer og mapper i Windows kan hjælpe dig med at finde Windows-logfilerne.

Generator-fejl forekommer på Apple Silicon

Hvis generator fortsat ikke fungerer på en Mac med Apple silicon, kan du køre Photoshop med Rosetta for at afgøre, om kompatibilitet i native-tilstand er årsagen til problemet.

Afslut Photoshop.

Åbn Programmer i Finder, og find Adobe Photoshop.

Kontrol-klik på Adobe Photoshop, og vælg derefter Vis info.

Vælg Åbn med Rosetta, start derefter Photoshop, og test generatoren.

Hvis fejlen fortsætter, skal du angive Generator-logfilerne, når du kontakter Adobe Support for at få hjælp.Ved problemer med Eksporter som, der ikke er relateret til Generator, kan du bruge fejlfindingsvejledningen til eksport- og lagringshandlinger.