内容 (What's Covered)

多数ご報告をいただいている問題と解決策について

A. トラブルシューティング/初級編

B. トラブルシューティング/中級編

C. トラブルシューティング/上級編

この文書は、Macintosh 版 Adobe Illustrator CS3 の使用中に発生するステムエラーを解決します。システムエラーは、多くの異なる状況(以下を含むがこれに限らず)で発生します。

  • 空白のダイアログボックスや画面のちらつき
  • カーソルや画面のフリーズ
  • 以下のようなエラー

    「The application 'Adobe Illustrator<バージョン>' has unexpectedly quit. The system and other applications have not been affected.(アプリケーション"Adobe Illustrator<バージョン>"は予期しない理由で終了しました。システムおよびその他のアプリケーションには影響はありません。)」

システムエラーはデバイスドライバ、ソフトウェア、およびハードウェア間のコンフリクト、特定のファイルの破損など、さまざまな要因で発生します。Illustrator で作業しているときにシステムエラーが発生しても、必ずしも Illustrator が原因とは限りません。Illustrator は多くのメモリやプロセッサパワーを消費するため、潜在的なシステムの問題が現れただけかもしれません。

文書を最大限に活用するために、以下の作業を順序どおりに行ってください。また作業とその結果を、エラーやその他のトラブルも含めて記録しておきます。こういった情報があれば、弊社テクニカルサポートにお問い合わせの際に、さらに適切なサポートを提供できます。

多数ご報告をいただいている問題と解決策について

Adobe Illustrator が突然終了してしまう原因のひとつに長期間にわたり編集を繰り返して利用している Illustrator 書類があります。多くの場合にこのような Illustrator 書類は複数のバージョンにわたり使われ続けています。

  • 過去のバージョンで作成された Illustrator 書類
  • 保存と編集を繰り返している Illustrator 書類

解決策

こちらにつきましては Illustrator CS3 の新規書類にて再作成することで問題を回避できる可能性がありますので以下の方法を試し下さい。

  1. Illustrator 書類を開きます(ファイル / 開く...)
  2. ロックを解除します(オブジェクト / すべてをロック解除)
  3. レイヤーパネルのパネルメニューから[コピー元のレイヤーにペースト]を選択します(選択するとチェックマークが表示されます)
  4. すべてのオブジェクトを選択します(選択 / すべてを選択)
  5. コピーします(編集 / コピー)
  6. 新規書類を作成します。用紙のサイズと方向を元の Illustrator 書類に合わせます(ファイル / 新規...)
  7. 定規を表示して原点の位置を元の Illustrator 書類に合わせます(表示 / 定規を表示)
  8. ペーストします(編集 / ペースト)

 お願い1 : 使わないサンプルの削除

Illustrator にはサンプルとしてスウオッチ、ブラシ、シンボル、グラフィックスタイルが付属しています。これらはサンプルであるためお客様が作成されている作品には必要がないかもしれません。そのような場合には削除することで Illustrator 書類の容量が少なくなり、開く、保存などの作業時間が短縮できます。

  1. アクションパネルを開きます(ウィンドウ / アクション)
  2. 初期設定アクション(フォルダ)を開きます
  3. [未使用項目のパネル項目を削除]を選択します。
  4. 実行します(アクションパネルの下部にある右向の三角形をクリックします)
  5. 保存します(ファイル / [保存]または[別名で保存])

 お願い2 : 余分なアンカーポイントの検索と削除

余分なアンカーポイントとは、他のアンカーポイントに接続されていない孤立したアンカーポイントで、印刷や保存に悪い影響を与えることがあります。余分なアンカーポイントは、検索して削除することをお勧めします。

  1. すべてのオブジェクトの選択を解除します。
  2. 選択/オブジェクト/余分なポイントを選択します。
  3. 編集/カットまたは編集/消去を選択するか、キーボードの Delete キーまたは Backspace キーを押します。

A. トラブルシューティング/初級編

A-1. 必要システム構成

A-2. 管理者権限でのログイン

A-3. 新規ユーザーアカウント

A-4. 最新バージョンを Illustrator をインストール

A-5. ソフトウェアアップデート

A-6. 環境設定ファイルの再作成

A-7. 仮想記憶ディスク

A-8. Illustrator を単独で起動

A-9. ビデオカードドライバーのアップデート

A-10. セーフブート

A-11. 最新のプリンタードライバーおよび PPD ファイル

このセクションの作業は、もっとも一般的なシステムエラーの解決に役立ちます。以下の作業を行う前に、すべての個人用のファイル(作成した Illustrator ファイル、サードパーティ製のプラグインなど)のバックアップを作成してください。システムエラーが発生した場合は、必ずコンピュータを再起動してメモリをリフレッシュしてください。再起動ずに作業を続行すると、問題が複雑になることがあります。

A-1. 必要システム構成

以下の文書を参照し、コンピューターが Illustrator CS3 の必要システムを満たしているか確認してください。必要システムを満たしていない場合、Illustrator が正しく動作しない可能性があります。

文書番号 6372 必要システム構成: Illustrator CS3 日本語版

文書番号 cpsid_89346 必要システム構成を満たしているか確認する方法

A-2. 管理者権限でのログイン

コンピュータにログインしているユーザの権限が十分でない場合、Illustrator が必要なファイルにアクセスできず問題が発生する可能性があります。アクセス権の制限が問題の原因となっているかどうかを確認するには、管理者権限のあるユーザでログインして問題を再現します。問題が再現しない場合、以前に使用したアカウントのアクセス権が十分ではありません。システム管理者に連絡して、アクセス権を取得してください。

管理者権限のあるユーザとしてログインするには、操作を行います。

  1. [アップル] メニューから [<ユーザアカウント名>のログアウト] を選択します。
  2. 「すべてのアプリケーションを終了して今すぐログアウトしてもよろしいですか?」と表示されたら [ログアウト] をクリックします。



  3. ログイン画面が表示されたら、管理者権限のあるユーザを選択します。
  4. 適切なパスワードを入力して、Return キーを押します。

A-3. 新規ユーザアカウント

ユーザアカウントの情報が破損していることによって、Illustrator が必要なファイルやフォルダへのアクセスできない、あるいはファイルの作成などの操作が妨げられることがあります。この場合、管理者権限を持った新規ユーザアカウントを作成し、そのアカウントでログインしてアプリケーションのインストールを行います。

管理者権限のある新規ユーザアカウントを作成する方法については、文書番号 cpsid_83227 新規ユーザーアカウントの作成方法を参照してください。

A-4. 最新バージョンの Illustrator をインストール

最新バージョンの Illustrator は、オペレーティングシステムやドライバとの互換性が向上している場合があります。アップデートを行う前に、コンピュータが必要システム構成を満たしているか確認してください。

Illustrator の無償アップデートは、以下の弊社 Web サイトからダウンロードするか、[ヘルプ] メニューから [アップデート] を選択します。

URL : http://www.adobe.com/jp/downloads/updates/

A-5. ソフトウェアアップデート

Mac OS X のアップデートを行うことにより、パフォーマンスやアプリケーションの互換性の問題が改善される場合があります。Mac OS X をアップデートするには、以下のApple 社 Web サイトからアップデータを入手するか、[アップル] メニューから [ソフトウェアアップデート] を選択します。

URL : http://www.apple.com/jp/downloads/macosx/

 重要 : システムアップデートをインストールする前に、Illustrator、および使用するその他のソフトウェアやハードウェアの必要システム要件を確認し、互換性に問題が無いか確認してください。インストールするアップデートが存在しない場合は、サードパーティ製ソフトウェア、ハードウェアの製造元へアップデートについてお問い合わせください。

A-6. 環境設定ファイルの再作成

 llustrator の環境設定ファイルを再作成することによって、環境設定ファイルの破損によるエラーを改善することができます。

 注意 : 環境設定ファイルを再作成すると、アプリケーションの設定が初期状態に戻ります。

  1. Illustrator を終了します。
  2. 以下の場所に保存されている「Adobe Illustrator CS3 Settings」フォルダをデスクトップへドラッグ&ドロップします。



    Macintosh HD/ユーザ/<ユーザ名>/ライブラリ/Preferences
  3. Illustrator を起動します。

Illustrator の環境設定ファイルを再作成後も問題が発生する場合、問題の原因は環境設定ファイルではありません。カスタマイズした設定を復元するには、Illustrator を終了し、新しく作成された環境設定ファイルを削除して手順 2 で移動したフォルダを元の場所に戻します。

A-7. 仮想記憶ディスク

Illustrator での作業に十分なメモリがない場合、Illustrator は仮想記憶ディスク(データの保存や処理作業のための一時的なディスクスペース)を使用します。一次仮想記憶ディスクとして指定したハードディスクのパーティションは、配置されたイメージファイルの平均サイズの 3 倍~ 5 倍のスペースを必要とします。ほかにもハードディスクまたはパーティションがある場合、そのボリュームを二次仮想記憶ディスクとして指定できます。ディスクの空き容量が少ない場合は、不要なファイルをハードディスクから削除します。

Illustrator の仮想記憶ディスクを指定するには、以下の操作を行います。

  1. [Illustrator] メニューから [環境設定] - [プラグイン・仮想記憶ディスク] を選択します。
  2. [仮想記憶ディスク] セクションの [ディスク 1] ポップアップメニューから一次仮想記憶ディスクとして使用するディスクを選択します。



    ※ ハードディスクが複数ある場合は [ディスク 2] ポップアップメニューから 2 つめの仮想記憶ディスクとして使用するディスクを選択することも可能です。



  3. [OK] をクリックします。
  4. Illustrator を再起動します。

A-8. Illustrator を単独で起動

十分な RAM 容量を確保し、他のアプリケーションとのコンフリクトを避けるために、起動しているアプリケーションを終了してから Illustrator を再起動します。起動しているアプリケーションを終了できない場合は、強制終了します。

アプリケーションを強制終了するには、以下の操作を行います。

  1. [アップル] メニューから [強制終了] を選択します。
  2. [アプリケーションの強制終了] ダイアログボックスが表示されます。終了させるアプリケーションを 1 つ選択し [強制終了] をクリックします。



     注意 : Finder は、Mac OS の基本コンポーネントです。Finder は選択しないでください。



  3. 「"<アプリケーション>"を強制終了してもよろしいですか?」というメッセージが表示されたら、[強制終了] をクリックします。
  4. Illustrator を再起動し、問題を再現します。

問題が再現しない場合 :

手順 2. で選択したアプリケーションが Illustrator とコンフリクトを起こしています。

問題が再現する場合 :

手順 1. ~ 3. を繰り返します。コンフリクトを起こしているアプリケーションを特定します。すべてのアプリケーションを終了しても問題が再現する場合は、次の手順へ進みます。

A-9. ビデオカードドライバのアップデート

ビデオカードの製造元の多くはソフトウェアドライバを頻繁に更新しています。ビデオカードドライバのアップデートを行っていない場合は、ビデオカードの製造元へドライバの更新について問い合わせるか、製造元の Web サイトからアップデータをダウンロードしてください。

A-10. セーフブート

ユーザアカウントのログイン項目に設定されている項目や、起動時に読み込まれるアプリケーションやサービスなど必ずしも必要ではない拡張機能を無効にした状態で Illustrator を実行します。Macintosh をセーフブートで起動することにより、起動時やログイン時に読み込まれる項目がすべて無効になります。セーフブートモードで問題が発生しない場合、起動項目のいずれかがシステムエラーまたはフリーズの原因となっていることが考えられます。

 Macintosh をセーフブートで起動する方法については、文書番号 cpsid_83225 セーフブートで起動する方法(Macintosh)を参照してください。

A-11. 最新のプリンタドライバおよび PPD ファイル

印刷時に問題が発生する場合、プリンタドライバまたは PPD ファイルが最新の状態にアップデートされているか確認します。製造メーカーの Web サイトから最新のドライバまたは PPD ファイルをダウンロードし、インストールします。

B. トラブルシューティング/中級編

B-1. デスクトップからのインストール

デバイスドライバ、ウイルス対策ソフトウェアなど、いくつかのシステムコンポーネントがインストーラとコンフリクトを起こし、Illustrator が正しくインストールされない場合があります。これらのコンフリクトを回避するため、インストーラファイルをデスクトップにコピーしてインストールを行います。

Illustrator をデスクトップからインストールするには、以下の操作を行います。

  1. すべてのアプリケーションを終了します。
  2. 以下のフォルダに個人用データが保存されている場合は、あらかじめ別の場所へ移動します。



    Macintosh HD/アプリケーション/Adobe Illustrator CS3



    ※ 初期設定では、「Macintosh HD/アプリケーション」フォルダにインストールされます。
  3. Finder の [移動] メニューから [ユーティリティ] を選択します。
  4. 「Adobe Installers」フォルダを開き、「Adobe Illustrator CS3 を追加または削除」エイリアスアイコンをダブルクリックします。



  5. 「認証」画面が表示されたら、管理者の名前とパスワードを入力し、[OK] をクリックします。
  6. 「Adobe Illustrator CS3 コンポーネントの管理」画面で [Adobe Illustrator CS3 コンポーネントを削除] を選択して [次へ] をクリックします。



  7. 画面の指示に従い、Illustrator のアンインストールを完了します。
  8. Illustrator CS3 アプリケーション DVD をコンピュータの DVD-ROM ドライブに挿入します。
  9. [Adobe Illustrator CS3] ウインドウが表示されます。

    ※ ウインドウが自動的に表示されない場合は、デスクトップにマウントされた「Adobe Illustrator CS3」ディスクアイコンをダブルクリックします。
  10. 「Adobe Illustrator CS3」アイコンをデスクトップにドラッグ&ドロップしてコピーします。



  11. コピー完了後、アプリケーション DVD をコンピュータから取り出します。
  12. A-10. の手順を参照し、コンピュータをセーフブートで起動します。
  13. デスクトップにコピーした「Adobe Illustrator CS3」アイコンをダブルクリックします。
  14. 「Setup.app」アイコンをダブルクリックします。



  15. 画面の指示に従い、インストールを完了します。インストール手順の詳細については、文書番号 231199 インストール手順(Macintosh 版 Illustrator CS3)を参照してください。

B-2. ディスクのアクセス権を修復

管理者アカウントでログインしているにもかかわらず問題が発生する場合、ディスクのアクセス権が破損している可能性があります。「ディスクユーティリティ」を使用して、ディスクアクセス権の検証および修復を行います。

アクセス権を修復するには、ディスクユーティリティを使用します。以下の操作を行います。

  1. Finder の [移動] メニューから [ユーティリティ] を選択します。
  2. 「ディスクユーティリティ」をダブルクリックします。



  3. [First Aid] タブをクリックして表示します。
  4. チェックするボリュームを選択して、[ディスクのアクセス権を検証] ボタンをクリックし、検証します。
  5. 不正なアクセス権が設定されていた場合には、[ディスクのアクセス権を修復] ボタンをクリックし、修復します。

B-3. サードパーティ製プラグイン

サードパーティ製プラグインを別の場所に移動して Illustrator を再起動します。以下の操作を行います。

  1. Illustrator を終了します。
  2. デスクトップに新規フォルダを作成します。
  3. 以下のフォルダから手順 2. で作成したフォルダへサードパーティ製プラグインをドラッグ&ドロップして移動します。



    Macintosh HD/アプリケーション/Adobe Illustrator CS3/プラグイン
  4. Illustrator を起動し、問題を再現します。

問題が再現する場合 :

プラグインが問題の原因ではありません。手順 3. で移動したプラグインを元のフォルダに戻します。

問題が再現しない場合 :

移動したプラグインのいずれかが問題の原因となっている可能性があります。サードパーティ製プラグインが複数インストールされている場合は、移動したプラグインを 1 つずつ元のフォルダに戻し、そのつど問題が再現するか確認して原因となっているプラグインを特定します。問題の原因となるプラグインが特定できた場合は、使用している Illustrator のバージョンにプラグインが対応しているか、修正版またはアップデータがリリースされているかについて、プラグインの開発元にお問い合わせください。

B-4. フォントの検証

Illustrator から破損しているフォントにアクセスすると、システムエラー、フリーズ、または表示に関する問題が発生する可能性があります。フォントのトラブルシューティングを行い、破損しているフォントを特定します。

以下の操作を行います。

  1. Adobe Type Manager や Extensis Suitcase などのフォント管理ユーティリティをすべて無効にします。
  2. Finder の [移動] メニューから [アプリケーション] を選択します。
  3. 「Font Book」をダブルクリックします。
  4. Font Book 左側の [コレクション] に表示されているリストから [コンピュータ] を選択します。
  5. [フォント] セクションで任意のフォントを選択し、[編集] メニューから [すべてを選択] を選択します。
  6. [フォント] セクション下部の、チェックボックスが描かれている [選択したフォントを使用停止にします] ボタンをクリックします。



  7. 「選択したフォントを使用停止してもよろしいですか?」と表示されたら [使用停止] ボタンをクリックします。

    ※ [使用停止] ボタンをクリックした後も、システムフォントは停止されません。
  8. Finder の [ファイル] メニューから [検索] を選択します。
  9. 「AdobeFnt11.lst」と入力して [ボリューム"<ハードディスク名>"] を選択します。
  10. 検索したすべての「AdobeFnt11.lst」ファイルを削除します。
  11. Mac OS X 10.4以降では、検索されない以下の場所にAdobeFntxx.lstがあります。フォルダを開き、AdobeFntxx.lst(xxには数字が入ります。)をゴミ箱に捨てます。

    - ユーザ/[ユーザ名]/ライブラリ/Caches/Adobe/Fonts/

    - ユーザ/[ユーザ名]/ライブラリ/Caches/Adobe/TypeSpt/

    - ユーザ/[ユーザ名]/ライブラリ/Caches/Adobe/TypeSupport/

    - ユーザ/[ユーザ名]/ライブラリ/Caches/Adobe/TypeSupport/CMaps
  12. 問題を再現します。

問題が再現する場合 :

フォントの破損が問題の原因ではありません。手順 7. で停止したフォントをすべて使用可能にします。

問題が再現しない場合 :

停止したフォントのいずれかが破損している可能性があります。停止したフォントを 1 つずつ使用可能にして、そのつど問題が再現するか確認し、破損しているフォントを特定します。問題の原因となるフォントファイルを特定したら、オリジナルメディアから問題のフォントを再インストールします。

停止したフォントを使用可能にするには、以下の操作を行います。

  1. [コレクション] セクションで [コンピュータ] を選択し、以下のいずれかの操作を行います。

    - 1 つのフォントを使用可能にする場合

    使用可能にするフォントを選択します。

    - すべてのフォントを使用可能にする場合

    [フォント] セクションで任意のフォントを選択し、[編集] メニューから [すべてを選択] を選択します。
  2. [フォント] セクション下部の、空欄のチェックボックスが描かれている [選択したフォントを使用可能にします] ボタンをクリックします。



B-5. ハードディスクの修復と最適化

ハードディスクの断片化や破損が原因で、Illustrator や他のアプリケーション実行時に問題が発生する場合があります。Apple ディスクユーティリティ、Symantecs 社の Norton Utilities、または Micromat Drive 10 などのディスクユーティリティを使用して、断片化したハードディスクのデフラグおよび破損の検証と修復を行います。

 警告 : この情報はサービスの一環として提供するもので、弊社ではサードパーティ製ディスクユーティリティのサポートは行っておりません。詳細についてはディスクユーティリティの開発元にお問い合わせください。

Apple ディスクユーティリティ(OS のインストールディスクに含まれています)を使用して破損を検証するには、以下の操作を行います。

  1. コンピュータに付属のインストールディスク、または Mac OS X 10.4 のインストールディスクをドライブに挿入します。
  2. インストーラを起動し、コンピュータを再起動します。
  3. [ユーティリティ] メニューから [ディスクユーティリティ] を選択します。
  4. 検証するディスクを選択し、[First Aid] タブをクリックします。
  5. [ディスクを検証] ボタンをクリックして検証を行います。必要であれば、選択したディスクを修復します。

B-6. ウイルススキャン

McAfee Virex や Symantec Norton AntiVirs などウイルス対策ソフトウェアを使用して、システムのウイルスチェックを行います。ウイルスチェックを行う前に、ウイルス定義ファイルが最新のものであるかを確認してください。ウイルスによる影響は稀ですが、インストールエラーなどの予期しないシステムエラーの原因となる可能性があります。定期的にウイルスチェックを行い、システム上のソフトウェアを保護してください。ウイルスチェックの実行方法や、定義ファイルの入手方法については、ソフトウェアに付属のヘルプやマニュアルを参照してください。

B-7. ICC プロファイル

Illustrator が破損した ICC プロファイルにアクセスすると、システムエラーが発生する可能性があります。ICC プロファイルのトラブルシューティングを行い、問題の原因となっているか確認します。

破損した ICC プロファイルを特定するには、以下の操作を行います。

  1. すべてのアプリケーションを終了します。
  2. デスクトップに新規フォルダを 3 つ作成し、それぞれ「Profiles 1」、「Profiles 2」、「Profiles 3」などわかりやすい名前を付けます。
  3. 以下のフォルダ内に保存されているすべてのファイル、フォルダまたはエイリアスを、手順 2. で作成したフォルダ内にそれぞれドラッグ&ドロップして移動します。



    - Macintosh HD/ライブラリ/ColorSync/Profiles

    - Macintosh HD/ライブラリ/Application Support/Adobe/Color/Profiles

    - Macintosh HD/システム/ライブラリ/ColorSync/Profiles
  4. Illustrator を再起動し、問題が再現するか確認します。

問題が再現する場合 :

移動したファイルおよびフォルダを元の場所に戻し、引き続き以下のトラブルシューティングを行います。

問題が再現しない場合 :

移動したファイルを 1 つずつ元の場所に戻し、そのつど問題が再現するか確認して問題の原因となっているプロファイルを特定します。

C. トラブルシューティング/上級編

C-1. システムリソースを消費するプロセスを停止

Illustrator に十分なシステムリソースを割り当てられるようにするため、システムリソースの 30 % 以上を消費しているプロセスを終了します。

以下の操作を行います。

  1. Finder の [移動] メニューから [ユーティリティ] を選択します。
  2. 「アクティビティモニタ」をダブルクリックします。



  3. [表示] メニューから [更新の頻度] - [少なく (5 秒ごと)] を選択します。
  4. CPU の 30 % 以上を消費しているプロセスを選択して、[プロセスを終了] ボタンをクリックします。

C-2. 起動ディスクとして指定された別のハードディスクにインストール

異なるハードディスク(同じハードディスク内のパーティションではありません)に Illustrator をインストールします。コンピュータに複数のハードディスクが搭載されている場合、システムではない方のハードディスクに Illustrator をインストールします。Illustrator をインストールしたハードディスクを起動ディスクに指定して再起動し、問題を再現します。

起動ディスクを変更するには、以下の操作を行います。

  1. [アップル] メニューから [システム環境設定] を選択します。
  2. [起動ディスク] をクリックします。
  3. 起動ディスクとして使用するハードディスクドライブを選択して [再起動] ボタンをクリックします。
  4. 「コンピュータを再起動してもよろしいですか?」と表示されたら [再起動] ボタンをクリックします。

C-3. 外部周辺機器の取り外し

コンピュータに接続している外部の周辺機器を 1 つずつ取り外します。外部の周辺機器には、FireWire、USB、Serial ATA、IDE あるいは SCSI によって接続される機器などが含まれます。これらの機器を取り外した状態で問題が改善する場合、それまで接続していた外部の周辺機器、ケーブル、または接続に問題があった可能性が考えられます。外部の周辺機器のトラブルシューティングの詳細については、周辺機器の製造元にお問い合わせください。

C-4. 異なるハードディスクまたはコンピュータへのインストール

異なるコンピュータに取り付け可能な同じハードディスク、または同じコンピュータに取り付け可能な異なるハードディスクに Illustrator をインストールして問題を再現します。問題が再現しない場合、以前使用していたハードディスク、またはマザーボードが原因の可能性があります。詳細については、製造元にお問い合わせください。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー