Workflows

  1. After Effects User Guide
  2. Beta releases
    1. Beta Program Overview
    2. After Effects Beta Home
  3. Getting started
    1. Get started with After Effects
    2. What's new in After Effects 
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Supported File formats | After Effects
    7. Hardware recommendations
    8. Planning and setup
    9. Setup and installation
  4. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  5. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. View detailed performance information with the Composition Profiler
    5. CINEMA 4D Composition Renderer
  6. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. XMP metadata
  7. Working with text and graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
  8. Drawing, painting, and paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. How to taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  9. Working with layers
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  10. Animation, keyframing, motion tracking, and keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  11. Transparency and compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels, masks, and mattes
  12. Adjusting color
    1. Color basics
    2. Use the Adobe Color Themes extension
    3. Color management
    4. Color Correction effects
  13. Effects and animation presets
    1. Effects and animation presets overview
    2. Effect list
    3. Simulation effects
    4. Stylize effects
    5. Audio effects
    6. Distort effects
    7. Perspective effects
    8. Channel effects
    9. Generate effects
    10. Transition effects
    11. The Rolling Shutter Repair effect
    12. Blur and Sharpen effects
    13. 3D Channel effects
    14. Utility effects
    15. Matte effects
    16. Noise and Grain effects
    17. Detail-preserving Upscale effect
    18. Obsolete effects
  14. Expressions and automation
    1. Expression
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  15. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. Preview changes to 3D designs real time with the Real-Time Engine
    7. Add responsive design to your graphics 
  16. Views and previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  17. Rendering and exporting
    1. Basics of rendering and exporting
    2. Export an After Effects project as an Adobe Premiere Pro project
    3. Converting movies
    4. Multi-frame rendering
    5. Automated rendering and network rendering
    6. Rendering and exporting still images and still-image sequences
    7. Using the GoPro CineForm codec in After Effects
  18. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Collaborate with Team Projects
    5. Share and manage changes with Team Project collaborators
    6. Creative Cloud Libraries in After Effects
    7. Plug-ins
    8. CINEMA 4D and Cineware
  19. Memory, storage, performance
    1. Memory and storage
    2. Improve performance
    3. Preferences
    4. GPU and GPU driver requirements for After Effects

General workflow in After Effects

Overview of general workflow in After Effects

Whether you use Adobe After Effects to animate a simple title, create complex motion graphics, or composite realistic visual effects, you generally follow the same basic workflow, though you may repeat or skip some steps. For example, you may repeat the cycle of modifying layer properties, animating, and previewing until everything looks right. You may skip the step of importing footage if you intend to create graphical elements entirely in After Effects.

1. Import and organize footage

After you create a project, import your footage into the project in the Project panel. After Effects automatically interprets many common media formats, but you can also specify how you want After Effects to interpret attributes such as frame rate and pixel aspect ratio. You can view each item in a Footage panel and set its start and end times to fit your composition. For more information, see Importing and interpreting footage items.

2. Create, arrange, and composite layers in a composition

Create one or more compositions. Any footage item can be the source for one or more layers in a composition. You can arrange the layers spatially in the Composition panel or arrange them in time using the Timeline panel. You can stack layers in two dimensions or arrange them in three dimensions. You can use masks, blending modes, and keying tools to composite (combine), the images of multiple layers. You can even use shape layers, text layers, and paint tools to create your own visual elements. For more information, see Composition basics, Creating layers, Transparency, opacity, and compositing, Overview of shape layers, paths, and vector graphics, and Creating and editing text layers.

3. Modify and animate layer properties

You can modify any property of a layer, such as size, position, and opacity. You can make any combination of layer properties change over time, using keyframes and expressions. Use motion tracking to stabilize motion or to animate one layer so that it follows the motion in another layer. For more information, see Animation basics, Expression basics, and Tracking and stabilizing motion.

4. Add effects and modify effect properties

You can add any combination of effects to alter the appearance or sound of a layer, and even generate visual elements from scratch. You can apply any of the hundreds of effects, animation presets, and layer styles. You can even create and save your own animation presets. You can animate effect properties, too, which are simply layer properties within an effect property group. For more information, see Effects and animation presets overview.

5. Preview

Previewing compositions on your computer monitor or an external video monitor is fast and convenient, even for complex projects. You can change the speed and quality of previews by specifying their resolution and frame rate, and by limiting the area and duration of the composition that you preview. You can use color management features to preview how your movie will look on another output device. For more information, see Previewing and Color management.

6. Render and export

Add one or more compositions to the render queue to render them at the quality settings you choose and to create movies in the formats that you specify. You can use File > Export or Composition > Add to Render Queue.

For more information, see Basics of rendering and exporting section in Adobe Media Encoder.

Online resources for general workflow in After Effects

Read a basic step-by-step introduction to the general workflow in an excerpt from After Effects Classroom in a Book.

Read Trish and Chris Meyer’s step-by-step introduction to creating a basic animation in a PDF excerpt from their book, The After Effects Apprentice.

For an overview of After Effects project navigtion, see the video tutorial, “Walking Through A Mini Project,” by Jeff Sengstack and Infinite Skills.

Basic workflow tutorial: Create a simple movie

This tutorial assumes that you have already started After Effects and have not modified the empty default project. This example skips the step of importing footage and shows you instead how to create your own synthetic visual elements. After you have rendered a final movie, you can import it into After Effects to view it and use it as you would any other footage item.

Some people prefer to use the mouse and menus to interact with After Effects, whereas others prefer to use keyboard shortcuts for common tasks. For several steps in this example, two alternative commands are shown that produce the same result—the first demonstrating the discoverability of menu commands and the second demonstrating the speed and convenience of keyboard shortcuts. You’ll likely find that you use some combination of keyboard shortcuts and menu commands in your work.

  1. Create a new composition:
    • Choose Composition > New Composition.

    • Press Ctrl+N (Windows) or Command+N (Mac OS).

  2. Change the Duration value in the Composition Settings dialog box by entering 5.00 (5 seconds), choose Web Video from the Preset menu, and click OK.
  3. Create a new text layer:
    • Choose Layer > New > Text.

    • Press Ctrl+Alt+Shift+T (Windows) or Command+Option+Shift+T (Mac OS).

  4. Type your name. Press Enter on the numeric keypad or press Ctrl+Enter (Windows) or Command+Return (Mac OS) on the main keyboard to exit text-editing mode.
  5. Set an initial keyframe for the Position property:
    • Click the triangle to the left of the layer name in the Timeline panel, click the triangle to the left of the Transform group name, and then click the stopwatch button to the left of the Position property name.

    • Press Alt+Shift+P (Windows) or Option+Shift+P (Mac OS).

  6. Activate the Selection tool:
    • Click the Selection Tool button in the Tools panel.

    • Press V.

  7. Using the Selection tool, drag your text to the bottom-left corner of the frame in the Composition panel.
  8. Move the current-time indicator to the last frame of the composition:
    • Drag the current-time indicator in the Timeline panel to the far right of the timeline.

    • Press End.

  9. Using the Selection tool, drag your text to the top-right corner of the frame in the Composition panel.

    A new keyframe is created at this time for the Position property. Motion is interpolated between keyframe values.

  10. Preview your animation using preview:

    • Click the Play button in the Preview panel. Click Play again to stop the preview.

    • Press the spacebar. Press the spacebar again to stop the preview.

  11. Apply the Glow effect:
    • Choose Effect > Stylize > Glow.

    • Type glow in the search field at the top of the Effects & Presets panel to find the Glow effect. Double-click the effect name.

  12. In the Render Queue panel, click the underlined text to the right of Output To. In the Output Movie To dialog box, choose a name and location for the output movie file, and then click Save. For the location, choose something easy to find, like your desktop.
  13. Click the Render button to process all items in the render queue. The Render Queue panel shows the progress of the rendering operation. A sound is generated when rendering is complete.

You’ve created, rendered, and exported a movie.

You can import the movie that you’ve created and preview it in After Effects, or you can navigate to the movie and play it using a movie player such as QuickTime Player or Windows Media Player.

Adobe logo

Sign in to your account