Riešenie

Po prihlásení sa do konkrétneho používateľského účtu na počítači so systémom Macintosh, Windows 7 alebo novším, príp. Windows Vista vykazuje aplikácia Adobe neočakávané správanie. Aplikácia sa napríklad sa nespustí, nesprávne vykoná príkaz, vykáže chybu alebo sa neočakávane zavrie. Chyby sa neobjavujú po prihlásení sa do iného alebo nového používateľského účtu.

Skôr než začnete

Pred vykonávaním úloh v tomto dokumente si urobte záložnú kópiu spúšťacieho disku.

Po vykonaní určitých krokov uvedených v tomto dokumente nástroj Finder zobrazí okno s overením. Po zobrazení okna s overením zadajte používateľské meno a heslo účtu správcu a potom kliknite na možnosť OK.

Neočakávané správanie účtov môžu spôsobovať viaceré príčiny. Tento dokument sa venuje len tým najčastejším. Ďalšiu pomoc pri riešení problémov s účtami používateľov vám poskytne podpora spoločnosti Apple.

Pred vykonávaním úloh v tomto dokumente si urobte úplnú zálohu systému.

Tieto úlohy niekedy spustia dialógové okno riadenia účtu so žiadosťou o udelenie oprávnenia. Prečítajte si podrobnosti uvedené v dialógovom okne a rozhodnite sa, či chcete pokračovať. Ak dialógové okno zrušíte, nebudete môcť v úlohe pokračovať.

Niektoré z úloh v tomto dokumente zmieňujú skryté priečinky. Predvolene sa v prieskumníkovi Windows nezobrazujú skryté priečinky. Ak chcete zobraziť skryté priečinky, pozrite si časť Zobrazenie skrytých súborov, priečinkov, prípon názvov súborov | Windows XP, Vista, Windows 7.

Neočakávané správanie účtov môžu spôsobovať viaceré príčiny. Tento dokument sa venuje len tým najčastejším. Ďalšiu pomoc pri riešení problémov s používateľskými účtami vám poskytne výrobca vášho počítača. Môžete tiež prejsť na lokalitu pomocníka a podpory spoločnosti Microsoft na adrese http://support.microsoft.com.

Riešenia

Prihláste sa do používateľského účtu, pri ktorom aplikácia Adobe vykazuje neočakávané správanie. Následne vykonajte tieto úlohy:

Mac OS

Skontrolujte, že používateľský účet má oprávnenia na čítanie a zápis nasledujúcich priečinkov:

  • /Applications/Adobe
  • /Applications/.AdobePatchFiles (ak je skrytý, použite príkaz Go > Go to Folder)
  • /Applications/Utilities/Adobe
  • /Library/Application Support/Adobe
  • /Library/Preferences/com.adobe
  • /Users/[používateľ]/Library/Application Support/Adobe
  • /Users/[používateľ]/Library/Caches/Adobe
  • /Users/[používateľ]/Library/Caches/com.adobe
  • /Users/[používateľ]/Library/Preferences/Adobe
  • /Users/[používateľ]/Library/Preferences/com.adobe

Po udelení oprávnení je na prejavenie zmien potrebné odhlásenie a opätovné prihlásenie používateľa alebo reštartovať počítač.

Aplikácie Adobe ukladajú nastavenia používateľov v súboroch preferencií. Každý účet má vlastnú sériu preferenčných súborov.

V prípade, ak aplikácia Adobe vykazuje neočakávané správanie iba pri niektorom z používateľských účtov, môže ísť o poškodenie niektorého z preferenčných súborov aplikácie. Aplikáciu Adobe môžete prinútiť vytvoriť nepoškodené súbory preferencií pomocou premenovania priečinku s aktuálnymi súbormi preferencií. Niektoré aplikácie Adobe si do priečinku ukladajú viaceré preferenčné súbory. Pri týchto aplikáciách možno premenovať priečinok.

Niektoré aplikácie Adobe ukladajú preferencie do priečinkov aj samostatných súborov. Adobe Photoshop CS4 napríklad využíva aj súbor preferencií s názvom com.adobe.Photoshop.plist aj priečinok preferencií s názvom Adobe Photoshop CS4 Settings. Ak chcete, aby Photoshop CS4 vytvoril nepoškodené preferenčné súbory, premenujte obidve tieto položky. Môžete ich premenovať napríklad na Old com.adobe.Photoshop.plist a Old Adobe Photoshop CS4 Settings.

Vo všeobecnosti aplikácie Adobe ukladajú svoje preferenčné súbory a priečinky na jednom alebo viacerých z týchto umiestnení:

  • /Users/[používateľské meno]/Library/Preferences
  • /Users/[používateľské meno]/Library/Preferences/Adobe
  • /Users/[používateľské meno]/Library/Application Support/Adobe

Dôležité: Spoločnosť Apple od vydania Mac OS X 10.7 predvolene skryla priečinok s knižnicou používateľa. Ak potrebujete získať prístup k súborom v skrytej knižnici s cieľom riešenia problémov vo vzťahu k produktom Adobe, prečítajte si časť Ako získať prístup k skrytým súborom User Library.

Niektoré aplikácie Adobe ukladajú ďalšie súbory preferencií aj na iných miestach. Adobe Premiere Pro CS4 napríklad ukladá ďalšie súbory preferencií v priečinkoch s názvom Layouts, Settings a Styles. Tieto súbory sa nachádzajú v umiestnení /Users/[používateľské meno]/Documents/Adobe/Premiere Pro/4.0.

Ak potrebujete zistiť presné názvy a umiestnenia priečinkov a súborov s preferenciami problémových aplikácií Adobe, prejdite na adresu www.adobe.com/sk/support. Prejdite na databázu poznatkov podpory, kde vyhľadajte termín „preferences“ spolu s názvom a verziou aplikácie. Následne si prečítajte „Systémové chyby alebo zamrznutia“, prípadne iný dokument, ktorý nájdete medzi výsledkami vyhľadávania.

Pri opätovnom vytvorení súboru preferencií aplikácie Adobe postupujte nasledovne:

  1. Ukončite aplikáciu Adobe.
  2. Premenujte priečinky a súbory s preferenciami Aplikácie Adobe.
  3. Otvorte aplikáciu Adobe. Aplikácia vytvorí súbory preferencií.

Po opätovnom vytvorení preferenčných súborov a priečinkov sa pokúste o zopakovanie chyby.

Ak problém pretrváva, nebude ho spôsobovať poškodený preferenčný súbor. Na obnovenie vlastných nastavení používateľského účtu vymažte nové preferenčné priečinky a súbory. Následne obnovte pôvodné názvy všetkých premenovaných priečinkov a súborov.

Ak problém zmizne, jeho príčinou bol poškodený preferenčný súbor. Vlastné nastavenia prepojené s predošlými preferenčnými súbormi sa vymažú.

V systéme Mac OS možno typy písma nainštalovať buď pre všetky používateľské účty, alebo iba pre konkrétny používateľský účet. Súbory typov písma vzťahujúcich sa na účet nájdete v umiestnení /Users/[používateľské meno]/Library/Fonts.

Ak sa aplikácia Adobe správa neočakávane iba na konkrétnom účte, môže to spôsobovať poškodený súbor typu písma, ktorý je nainštalovaný iba na predmetnom účte.

Na dočasné vypnutie všetkých typov písma vzťahujúcich sa na účty použite aplikáciu Font Book, ktorá je súčasťou Mac OS X. Po vypnutí typov písma vzťahujúcich sa na účty vyhľadajte a vymažte súbory vyrovnávacej pamäte typov písma Adobe. Postupujte takto:

  1. Zatvorte všetky otvorené aplikácie.
  2. Ak obyčajne na zapínanie a vypínanie typov písma využívate nástroj na správu typov písma od tretej strany, dočasne ju vypnite. Pokyny nájdete v príslušnej dokumentácii.
  3. Otvorte nástroj Font Book. (Predvolene sa Font Book nachádza v priečinku aplikácií.)
  4. V stĺpci Collection zvoľte možnosť User. Potom vykonajte jeden z týchto úkonov:

    • Ak je stĺpik Font prázdny, neexistuje pre tento používateľský účet žiadny typ písma vzťahujúci sa na účet. Preskočte zvyšok tejto úlohy a prejdite na úlohu 3.
    • Ak sa v stĺpci Font zobrazuje aspoň jeden typ písma, kliknite na možnosť Edit > Disable "User."
  5. V nástroji Finder kliknite na File > Find. Možnosti vyhľadávania sa nachádzajú na úplne prvom okne nástroja Finder.

  6. Súbory vyrovnávacej pamäte Adobe vyhľadajte nastavením nasledovných možností vyhľadávania:

    • Mac OS X v.10.4.x: V hornom riadku možností vyhľadávania označte možnosť Home. V druhom riadku zvoľte vo vyskakovacích ponukách možnosti Name a Begins With Do textového poľa napravo od položky Begins With zadajte výraz AdobeFnt.
    • Mac OS X v.10.5.x a novší: V hornom riadku možností vyhľadávania zvoľte názov používateľského účtu (zobrazuje sa v úvodzovkách). V druhom riadku zvoľte vo vyskakovacích ponukách možnosti Name a Begins With Do textového poľa napravo od položky Begins With zadajte výraz AdobeFnt.
  7. Vo výsledkoch vyhľadávania vymažte všetky súbory, ktorých názov začína na AdobeFnt a končí lst.

  8. Otvorte aplikáciu Adobe a skúste chybu reprodukovať.

Ak problém pretrváva, nie je spôsobený typom písma súvisiacim s účtom. Otvorením nástroja Font Book možno výberom používateľa v stĺpci Collection a následným kliknutím na možnosti Edit > Enable typy písma vzťahujúce sa na účet opäť zapnúť. Pokračujte na úlohu 3.

Ak problém zmizne, spôsoboval ho typ písma vzťahujúci sa na účet. Konkrétny problematický typ písma zistíte nasledovne:

  1. Otvorte nástroj Font Book.

  2. V stĺpci Collection zvoľte možnosť User.

  3. V stĺpci Font označte niektorý z vypnutých typov písma.

  4. Kliknite na možnosť Edit > Enable [Font Name].

  5. Otvorte aplikáciu Adobe a skúste chybu reprodukovať. Potom vykonajte jeden z týchto úkonov:

    • Ak problém pretrváva, ukončite aplikáciu Adobe a zopakujte kroky 3 až 5.
    • Ak problém zmizne, jeho príčinou bol typ písma, ktorý ste opätovne povolili ako posledný. Typ písma ponechajte vypnutý, prípadne vymažte typ písma a obráťte sa na jeho vydavateľa, ktorý by vám mal poskytnúť náhradný súbor.

Niektoré aplikácie Adobe vytvárajú dočasné súbore údajov, ktoré sú známe pod pojmom súbory vo vyrovnávacej pamäti. Nadmerné alebo poškodené súbory vyrovnávacej pamäti používateľského účtu môžu spôsobiť, že aplikácia Adobe bude vykazovať neobvyklé správanie.

Postupujte takto:

  1. Ukončite všetky aplikácie Adobe.

  2. V nástroji Finder prejdite na /Users/[používateľské meno]/Library/Caches.

  3. V priečinku Caches vymažte priečinok Adobe.

  4. Vymažte všetky ostatné priečinky v priečinku Caches, ktoré sú pomenované podľa aplikácie Adobe, ktorej problémy sa pokúšate vyriešiť.

  5. Vymažte všetky ostatné priečinky v priečinku Caches, ktoré sú pomenované podľa komponentov aplikácie Adobe, ktorej problémy sa pokúšate vyriešiť. Ak napríklad riešite problémy s aplikáciou Photoshop CS4, vymažte aj priečinok Adobe Camera Raw nachádzajúci sa v priečinku Caches.

  6. Otvorte aplikáciu Adobe a skúste chybu reprodukovať.

Ak sa problém neodstránil, pokračujte s ďalšou úlohou.

Položky prihlasovania predstavujú aplikácie alebo dokumenty, ktoré sa otvárajú automaticky pri prihlásení sa do účtu používateľa. (Automaticky sa otvárajú aj po zapnutí počítača za predpokladu, že máte zapnutú funkciu automatického prihlasovania.) Niektoré položky prihlásenia sa po otvorení skryjú. V prípade, že sa aplikácia Adobe správa neočakávane na jednom účte, je možné, že sú položky prihlasovania jedného účtu chybné, poškodené alebo nekompatibilné s aplikáciou Adobe.

Pri zisťovaní, či problém s aplikáciou Adobe spôsobuje niektorá z položiek prihlasovania účtu používateľa, postupujte nasledovne:

  1. Kliknite na ponuku Apple Menu > Log Out [Používateľské meno].

  2. V dialógovom okne s potvrdením kliknite na možnosť Log Out. Po chvíli sa zobrazí okno s prihlásením.

  3. V okne s prihlásením označte názov používateľského účtu, ktorého problém sa snažíte vyriešiť.

  4. Do textového poľa s heslom zadajte heslo k účtu.; aleNestláčajte Enter, ani zatiaľ neklikajte na možnosť Log In.

  5. Podržte stlačený kláves Shift a až potom kliknite na prihlásenie. Po zobrazení Docku uvoľnite kláves Shift. Položky prihlásenia sa vypnú až do odhlásenia (alebo reštartovania počítača).

  6. Otvorte aplikáciu Adobe a skúste chybu reprodukovať.

Ak problém pretrváva, nebude ho spôsobovať položka prihlásenia. Pomocou odhlásenia opätovne zapnite položky prihlasovania (cez ponuku Apple Menu > Log Out [Používateľské meno]). Následne sa prihláste späť do rovnakého účtu bez toho, aby ste držali stlačený kláves Shift. Pokračujte na úlohu 5.

Ak problém zmizne, jeho príčinou bola položka prihlasovania. Pri zisťovaní konkrétnej položky prihlasovania, ktorá problém spôsobuje, postupujte nasledovne:

Ak problém pretrváva, nie je spôsobený typom písma súvisiacim s účtom. Otvorením nástroja Font Book možno výberom používateľa v stĺpci Collection a následným kliknutím na možnostiEdit > Enable typy písma vzťahujúce sa na účet opäť zapnúť. Pokračujte na úlohu 3.

Ak problém zmizne, spôsoboval ho typ písma vzťahujúci sa na účet. Konkrétny problematický typ písma zistíte nasledovne:

  1. Kliknite na ponuku Apple Menu > Log Out [Používateľské meno].

  2. Opätovné prihláseniedorovnakom konte. Nedržte stlačený kláves Shift.

  3. Kliknite na ponuku Apple Menu > System Preferences.

  4. V okne systémových preferencií kliknite na možnosť Accounts
    .

  5. Ak sa v spodnom rohu obrazovky zobrazí ikona zámky, kliknutím na ňu vykonajte overenie.

  6. Zvoľte si účet používateľa, ktorého problém sa snažíte vyriešiť.

  7. Kliknite na kartu položiek prihlásenia.

  8. Vytvorte si zoznam aktuálnych položiek prihlásenia.

  9. Označte položku prihlásenia a stlačte kláves Delete.

  10. Otvorte aplikáciu Adobe a skúste chybu reprodukovať. Potom vykonajte jeden z týchto úkonov:

    • Ak problém pretrváva, ukončite aplikáciu Adobe a zopakujte kroky 9 až 10.
    • Ak problém zmizne, jeho príčinou bola položka prihlasovania, ktorú ste vymazali ako poslednú. Obráťte sa na zverejňovateľa príslušnej položky prihlasovania a spýtajte sa ho na dostupnosť aktualizovanej verzie. Obnovte ostatné položky prihlásenia presunutím ich ikon do oblasti položiek prihlásenia v systémových preferenciách. Prípadne môžete preinštalovať aplikáciou, s ktorou je položka prihlasovanai prepojená.

Túto úlohu absolvujte iba v prípade, ak je účet, ktorého problémy riešite, účtom správcu a súčasne obsahuje aj heslo.

Každý súbor a priečinok v oddieli Mac OS X obsahuje nastavenia vlastníctva a oprávnenia Unix-style. Tieto nastavenia určujú, ktorý používateľský účet získa prístup k súborom alebo priečinkom, a ktoré účty ho nezískajú.

Aplikácia Adobe môže vykazovať neobvyklé správanie na určitom účte za predpokladu, ak sú nastavenia prístupu do priečinku knižnice (alebo vedľajšieho priečinku) poškodené alebo nesprávne obmedzené. Na opravu týchto nastavení môžete použiť príkazy Unix chmod a chown. Postupujte takto:

  1. V aplikácii Finder vyberte položky Go > Home. Úplne prvé okno nástroja Finder prechádza do domovského priečinku používateľského účtu. Poznačte si názov tohto okna nástroja Finder. Ide o skráteniepoužívateľského menapoužívateľského účtu. (Toto skráteniepoužívateľského menaje nevyhnutné pre dokončenie kroku 3.)

  2. Otvorte si aplikáciu Terminal, ktorú predvolene nájdete v /Applications/Utilities.

  3. Pomocou niektorého z nižšie uvedených príkazov zadajte do okna Terminal príslušný príkaz a stlačte možnosť Return. (Po stlačení možnosti Return na konci príkazu sa zobrazí výzva na zadanie hesla). Zadajte heslo používateľského účtu a potom opäť stlačte možnosť Return. Pri písaní jednotlivých znakov hesla sa nezobrazuje žiadna spätná väzba (napríklad hviezdičky). Ide o bežné správanie.

    Dôležité: Každý z nižšie uvedených príkazov predstavuje šablónu a nie skutočne zadávaný príkaz. V zadávanom príkaze nahraďte username krátkym názvom používateľa, ktorý ste si zistili v kroku 1. Krátky názov používateľa zadávajte malými písmenami. (V systéme Mac OS X v10.4.x zadávajte krátky názov používateľa dvakrát, pričom ich oddeľte dvojbodkou. V Mac OS X v.10.5.x zadajte krátky názov používateľa nasledovaný dvojbodkou a slovom staff.)

    Príkaz šablóny pre Mac OS X v.10.4.x:


    sudo chown-R username:username~/Library

    Príkaz šablóny pre Mac OS X v.10.5.x:

    sudo chown-R username:staff~/Library

  4. Príkaz zadajte presne tak, ako je uvedený a potom stlačte Return.

    sudo chmod -R 700 ~/Library

  5. Ukončite terminál.

  6. Otvorte aplikáciu Adobe a skúste chybu reprodukovať.

Ak sa problém neodstránil, pokračujte s ďalšou úlohou.

Vykazovanie zvláštneho správania aplikácie Adobe v rámci účtu môže spôsobiť poškodenie disku, ktoré má vplyv len na účet konkrétneho používateľa.

Ak máte inštalačný disk Mac OS X, ktorý vám prišiel spolu s PC, vykonajte nižšie uvedené kroky. Ak disk k dispozícii nemáte, môžete na opravu spúšťacieho disku využiť príkaz nástroja Terminál v znení fsck . Prípadne môžete použiť nástroj na opravu diskov od tretích strán. Pokyny o použití príkazu fsck nájdete v článku TS1417 na webovej stránke podpory spoločnosti Apple. Pokyny o používaní nástroja na opravu diskov od tretej strany nájdete v príslušnej dokumentácii k nástroju.

  1. Do optickej jednotky počítač vložte inštalačný disk Mac OS X.
  2. Kliknite na ponuku Apple Menu > Restart.
  3. Po zaznení zvuku spúšťania podržte na klávesnici stlačený kláves C.
  4. Po zobrazení okna spúšťania s riadkom postupu kláves C môžete uvoľniť.
  5. Ak vás inštalátor Mac OS X vyzve na výber jazyku, zvoľte si preferovanú možnosť.
  6. Po zobrazení ponuky inštalátora (v ľavej hornej časti obrazovky) zvoľte možnosť Installer > Disk Utility.
  7. V nástroji disk Utility označte spúšťací disk na ľavej strane.
  8. Kliknite na možnosť First Aidnapravej strane.

  9. Kliknite na možnosť Repair Disk.

  10. V prípade, že sa proces opravy dokončí so signalizáciou o oprave chýb disku, zopakujte krok 9. V prípade, že postup skončí bez toho, aby ohlásil akékoľvek chyby, otvorte aplikáciu Adobe a pokúste sa chybu reprodukovať.

Ak sa problém neodstránil, pokračujte s ďalšou úlohou.

Ak sa aplikácia aj naďalej správa neočakávane pri konkrétnom účte, Adobe odporúča skopírovať (alebo presunúť) všetky osobné súbory do nového používateľského účtu. Nový účet začnite používať ako svoj bežný účet.

Pomoc pri kopírovaní osobných súborov do nového používateľského účtu dostanete od oddelenia podpory spoločnosti Apple.

Windows

Skontrolujte, že používateľský účet má oprávnenia na čítanie a zápis nasledujúcich priečinkov:

  • C:\Program Files\Adobe
  • C:\Program Files\Common Files\Adobe
  • C:\Program Files (x86)\Adobe
  • C:\Program Files (x86)\Common Files\Adobe
  • C:\ProgramData\Adobe
  • C:\Users\\AppData\Roaming\Adobe
  • C:\Users\\AppData\Roaming\com.adobe.
  • C:\Users\\AppData\Local\Adobe
  • C:\Users\\AppData\LocalLow\Adobe
  • C:\Users\\AppData\Local\VirtualStore\Program Files\Common Files\Adobe

Aplikácie Adobe ukladajú nastavenia používateľov v súboroch preferencií. Každý účet má vlastnú sériu preferenčných súborov.

V prípade, ak aplikácia Adobe vykazuje neočakávané správanie iba pri niektorom z používateľských účtov, môže za to poškodenie niektorého z preferenčných súborov. Aplikáciu Adobe môžete prinútiť vytvoriť nepoškodené súbory preferencií pomocou premenovania priečinku, ktorý ich obsahuje.

Adobe Premiere Pro CS4 si napríklad súbory preferencií ukladá v priečinku s názvom 4.0, ktorý nájdete na ceste C:\Users\[používateľské meno]\AppData\Roaming\Adobe\Premiere Pro. Premenovaním priečinku 4.0 prinútite Adobe Premiere Pro CS4 opätovne vytvoriť preferenčné súbory (napríklad ho premenujte na Staršie 4.0).

Vo všeobecnosti aplikácie Adobe ukladajú svoje preferenčné súbory a priečinky na jednej z týchto ciest:

  • C:\Users\[používateľské meno]\AppData\Roaming\Adobe
  • C:\Users\[používateľské meno]\AppData\Local\Adobe

Niektoré aplikácie Adobe ukladajú ďalšie súbory preferencií aj na iných miestach. Adobe Premiere Pro CS4 napríklad ukladá ďalšie súbory preferencií v priečinkoch s názvom Styles a Layouts, ktoré nájdete pomocou cesty C:\Users\[používateľské meno]\Documents\Adobe\Premiere Pro\4.0.

Ak potrebujete zistiť presné názvy a umiestnenia priečinkov s preferenciami problémových aplikácií Adobe, prejdite na adresu www.adobe.com/support.Prejdite na databázu poznatkov podpory, kde vyhľadajte termín „preferences“ spolu s názvom a verziou aplikácie. Potom sa pozritenana časť „Systémové chyby alebo zamrznutia“, prípadne iný dokument, ktorý nájdete medzi výsledkami vyhľadávania.

Pri opätovnom vytvorení súboru preferencií aplikácie Adobe postupujte nasledovne:

  1. Zatvorte aplikáciu Adobe.

  2. Premenujte priečinok s preferenciami Aplikácie Adobe.

  3. Spustite aplikáciu Adobe. Aplikácia vytvorí nepoškodené súbory preferencií.

Po opätovnom vytvorení preferenčných súborov sa pokúste o zopakovanie chyby.

Ak problém pretrváva, nebude ho spôsobovať poškodený preferenčný súbor. Na obnovenie vlastných nastavení používateľského účtu aplikácie Adobe vymažte nové preferenčné priečinky. Následne obnovte pôvodné názvy premenovaných priečinkov.

Ak problém zmizne, jeho príčinou bol poškodený preferenčný súbor. (Používateľský účet si neponechá vlastné nastavenia prepojené s predošlými preferenčnými súbormi.)

Niektoré aplikácie Adobe si ukladajú dočasné súbory. Aplikácia Adobe môže vykazovať neočakávané správanie v prípade, že dočasné súbory účty sú nadmerné, zastarané alebo poškodené.

Na vymazanie dočasných súborov použite nástroj na čistenie disku. Prečítajte si časť Vymazanie dočasných súborov pomocou nástroja na čistenie disku (Windows 7 a Vista).

Predvolene nástroj na čistenie disku nevymazáva súbory v priečinku s dočasnými súbormi účtu, ktoré boli použité za posledných sedem dní. Dôkladnejšie odstránenie dočasných súborov môžete docieliť manuálnym vymazaním obsahu priečinku s dočasnými súbormi.

Upozornenie: Manuálne vymazanie obsahu priečinku s dočasnými súbormi môže výrazne ovplyvniť funkčnosť aplikácií, ktoré nevyvinula spoločnosť Adobe. Ak sa rozhodnete pre tento nepovinný krok, postupujte opatrne. Spoločnosť Adobe neposkytuje podporu pri problémoch, ktoré vzniknú z manuálneho vymazania súborov v priečinku s dočasnými súbormi.

Pri manuálnom vymazávaní obsahu priečinku s dočasnými súbormi účtu používateľa postupujte nasledovne:

  1. Zatvorte všetky aplikácie.

  2. Vyberte položky Štart > Všetky programy > Príslušenstvo. Kliknite pravým tlačidlom myši na položku Príkazový riadok a vyberte možnosť Spustiť ako správca.

  3. Do okna príkazového riadku napíšte presne nižšie uvedený reťazec a potom stlačte Enter:

    del %temp%\*.* /s /q

    Poznámka: del je príkaz na vymazanie súborov. %temp%\*.* predstavuje kombináciu „premenných prostredia“ pre umiestnenie priečinku s dočasnými súbormi účtu plus zástupné znaky, ktoré označujú všetky súbory. /s príkaz rozširuje, aby zahrnul všetky súbory nachádzajúce sa vo všetkých vedľajších súboroch. /q bráni systému Windows v zobrazení výzvy na potvrdenie vymazania každého zo súborov.

  4. V okne príkazového riadku sa zobrazí zoznam vymazaných súborov. (Zoznam môže obsahovať aj súbory, ktoré nemožno vymazať. Pravdepodobne sa vám zobrazí hlásenie „Prístup zamietnutý“ alebo „Proces nedokáže získať prístup k súboru, pretože ho využíva iný proces.“ Toto správanie je bežné.)

  5. Zatvorte okno Príkazový riadok.

Po vymazaní dočasných súborov otvorte aplikáciu Adobe a pokúste sa chybu reprodukovať.

Ak sa problém neodstránil, pokračujte s ďalšou úlohou.

Položky spúšťania predstavujú aplikácie alebo dokumenty, ktoré sa otvárajú automaticky pri prihlásení sa do účtu používateľa. V prípade, že sa aplikácia Adobe správa neočakávane na jednom účte, je možné, že sú položky spúšťania účtu chybné, poškodené alebo nekompatibilné s aplikáciou.

Pri zisťovaní, či problém s aplikáciou Adobe spôsobuje niektorá z položiek spúšťania účtu používateľa, postupujte nasledovne:

  1. V prieskumníkovi Windows prejdite na C:\Users\[ používateľské meno]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

  2. Vykonajte jeden z týchto úkonov:

    • Ak je priečinok Startup prázdny, alebo tam žiadny nie je, účet nemá vytvorené žiadne položky spúšťania, ktoré sa naň vzťahujú. Preskočte zvyšok týchto krokov a prejdite na krok 4.
    • Ak sa v priečinku Startup nachádza aspoň jedna položka, vytvorte na ploche nový priečinok. Nový priečinok pomenujte názvom Holding Folder.
  3. Všetky súbory z priečinku Startup presuňte do priečinku Holding Folder.

  4. Stlačte položku Štart > Odhlásiť sa.

  5. Prihláste sa do rovnakého účtu.

  6. Otvorte aplikáciu Adobe a skúste chybu reprodukovať.

Ak problém pretrváva, jeho príčinou nebola položka spúšťania účtu. Všetky položky z priečinku Holding Folder tak môžete presunúť späť do C:\Users\[používateľské meno]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup. Pokračujte na úlohu 4.

Ak problém zmizne, jeho príčinou bola položka spúšťania účtu. Pri zisťovaní konkrétnej položky spúšťania, ktorá problém spôsobuje, postupujte nasledovne:

  1. Zatvorte aplikáciu Adobe.

  2. Presuňte jednu položku z priečinku Holding Folder späť do C:\Users\[používateľské meno]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

  3. Stlačte položku Štart > Odhlásiť sa.

  4. Prihláste sa do rovnakého účtu.

  5. Otvorte aplikáciu Adobe a skúste chybu reprodukovať. Potom vykonajte jeden z týchto úkonov:

    • Ak problém pretrváva, zopakujte kroky 1 až 5.
    • Ak problém zmizne, jeho príčinou bola položka spúšťania, ktorú ste opätovne povolili ako poslednú. Odstráňte ju z priečinku Startup, obráťte sa na zverejňovateľa príslušnej položky spúšťania a spýtajte sa ho na dostupnosť aktualizovanej verzie. Presuňte všetky zostávajúce položky z priečinku Holding Folder späť do C:\Users\[používateľské meno]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

Túto úlohu absolvujte iba v prípade, ak je účet, ktorého problémy riešite, účtom správcu a súčasne nie jenasieťovej doméne.

Chyby spojené s účtom sa môžu objaviť sa predpokladu, že účet nemá úplný prístup na čítanie/zápis priečinkov s preferenčnými súbormi a súbormi údajov aplikácie Adobe. Príkazicaclsmôžete použiť na obnovenie nastavení prístupu. Postupujte takto:

  1. Zatvorte všetky aplikácie.

  2. Vyberte položky Štart > Všetky programy > Príslušenstvo. Kliknite pravým tlačidlom myši na položku Príkazový riadok a vyberte možnosť Spustiť ako správca. Zobrazí sa okno s príkazovým riadkom.

  3. Do okna príkazového riadku zadajte jednotlivé príkazy v presnom znení, akom sú uvedené nižšie. Po každom príkaze stlačte Enter. 

    Dôležitá informácia: Medzeru použite pred aj po každom spínači -- /T, /C, a /grant -- v každom príkaze.

    icacls "%userprofile%\AppData\Local" /T /C /grant "%username%":F

    icacls "%userprofile%\AppData\Roaming" /T /C /grant "%username%":F

    icacls "%userprofile%\AppData\Local" /T /C /grant system:F

    icacls "%userprofile%\AppData\Roaming" /T /C /grant system:F

  4. Zatvorte okno s príkazovým riadkom.

  5. Otvorte aplikáciu Adobe a skúste chybu reprodukovať.

Ak sa problém neodstránil, pokračujte s ďalšou úlohou.

Upozornenie: Pri tejto úlohe je potrebná úprava registrov systému Windows. Databáza Registry obsahuje informácie týkajúce sa systému, ktoré sú pre váš počítač a aplikácie kritické. Pred upravovaním databázy Registry vytvorte jej záložnú kópiu. Spoločnosť Adobe neposkytuje podporu pre problémy spôsobené nesprávnou úpravou databázou registrov. Informácie o registroch systému Windows a editore registrov si možno prečítať v pomocníku Microsoft a na lokalite podpory na adrese http://support.microsoft.com.

  1. Zatvorte všetky aplikácie.

  2. Kliknite na tlačidlo Štart. Typ regedit Do vyhľadávacieho poľa v ponuke Štart zadajte text  a stlačte kláves Enter. Otvorí sa Editor databázy Registry.

  3. Na ľavej table editora registrov vyhľadajte a označte kľúč registra s názvom:

    HKEY_CURRENT_USER\Software\Adobe.

  4. Stlačte položky Súbor > Export.

  5. V dialógovom okne exportovania súboru registrov kliknite v položke rozsahu exportu na možnosť Vetva. Zadajte názov a umiestnenie záložného kľúču registrov a potom kliknite na možnosť Uložiť.

  6. Kliknite pravým tlačidlom na kľúč Adobe a stlačte možnosť Vymazať.

  7. V dialógovom okne potvrdenia vymazania kľúča kliknite na možnosť OK.

  8. Zatvorte Editor databázy Registry.

  9. Otvorte aplikáciu Adobe a skúste chybu reprodukovať.

Ak problém pretrváva, nebude ho spôsobovať poškodený záznam registru. Záložnú kópiu kľúču Adobe možno obnoviť nasledovne:

  1. Zatvorte všetky aplikácie.

  2. Kliknite na tlačidlo Štart. Typ regedit Do vyhľadávacieho poľa v ponuke Štart zadajte text  a stlačte kláves Enter. Otvorí sa Editor databázy Registry.

  3. V editore registrov kliknite na Súbor > Import.

  4. V dialógovom okne importovania súboru registrov prejdite na umiestnenie záložného kľúča, ktorý ste si uložili v predošlom kroku. Vyberte súbor a kliknite na možnosť Otvoriť.

Nefunkčnosť aplikácie Adobe v rámci účtu môže spôsobiť poškodenie disku, ktoré má vplyv len na účet konkrétneho používateľa.

Informácie o oprave systémového pevného disku nájdete v časti Oprava a defragmentácia pevných diskov (Windows 7 a Vista).

Po dokončení opravy disku otvorte aplikáciu Adobe a pokúste sa chybu reprodukovať. Ak sa problém neodstránil, pokračujte s ďalšou úlohou.

Ak sa aplikácia správa neočakávane pri konkrétnom účte, skopírujte (alebo presuňte) všetky osobné informácie do účtu, pri ktorom sa takéto správanie neobjavuje. Nový účet začnite používať ako svoj bežný účet.

Pomoc pri kopírovaní osobných súborov do nového používateľského účtu dostanete od výrobcu svojho počítača. Môžete si tiež prečítať informácie pomocníka Microsoft alebo informácie zo stránok podpory na adresehttp://support.microsoft.com.

Licencia na používanie tohto diela sa poskytuje v súlade s podmienkami licencie Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Na príspevky v sociálnych sieťach Twitter™ a Facebook sa nevzťahujú podmienky licencií Creative Commons.

Právne upozornenia   |   Zásady ochrany osobných údajov online