大量使用者 CSV 上傳疑難排解 | Adobe Admin Console

總覽

在使用者頁面上的「以 CSV 新增使用者」功能可讓管理員在 Admin Console 中使用 CSV 檔案建立多個使用者帳戶。使用者帳戶建立程序的狀態和進度會在「大量作業結果」頁面上顯示。您可以隨時取消使用者帳戶建立的處理。

註解:

本文所述程序所使用的 CSV 檔案可以使用逗號 (,) 或分號 (;) 作為分隔符號。

如需在 Admin Console 中搭配使用者使用的詳細資訊,請參閱管理使用者

檔案需求

以下為管理員在上傳檔案前必須滿足的處理需求:

  • 檔案格式和標題
  • 檔案資料或列需求

檔案格式和標題

  • 檔案採用逗號或分號分隔值格式,且尾碼為 .csv。每筆記錄都在不同的一行上,以分行符號 (CRLF) 分隔。例如,aaa,bbb,ccc CRLF。如需詳細資訊,請參閱「RFC 4180 (CSV 檔案規格)」。
  • 欄標題有效。標題列是必要欄位。如需必要或選用欄位和檔案格式的詳細資訊,請參閱「管理使用者」中的 CSV 檔案格式表格。

因應措施

注意:

如下所述的變更會影響其他應用程式和試算表。因此,請在 CSV 中進行所需的變更,然後還原這些設定。 

Windows 10

  1. 前往 Windows 設定

  2. 瀏覽至「時間與語言 > 地區及語言 > 其他日期、時間及區域設定 > 變更日期、時間或數字格式」。

  3. 在「格式」下拉式清單中,選擇「英文 (英國)」。

Windows 7

  1. 瀏覽至「控制台 > 所有控制台項目 > 地區及語言」。

  2. 在「格式」下拉式清單中,選擇「英文 (英國)」。

資料或列需求

確定每個資料列皆符合以下需求:

  • 它由有效的電子郵件地址組成。
  • 如果存在,產品描述檔 (或設定) 有效。
註解:

如果您是 Teams 客戶,請將「產品設定」欄標題變更成「Team 產品」。此外,對於此欄中的資料,請輸入產品名稱 (而非產品描述檔名稱)。

  • 如果存在,選項有效。
註解:

國家/地區代碼必須是雙字母 ISO 3166 (alpha-2) 代碼。

檔案大小需求

您的 CSV 檔案最多可以包含 25,000 列 (5,000 列以下可達最佳效能)。如果檔案超過 5000 列,當在 Admin Console 上處理檔案時,您會遇到效能問題 (請參閱下節檔案處理)。不過,我們將拒絕超過 25,000 列的任何 CSV 檔案。

如果您需要上傳 25,000 名以上使用者,我們建議執行下列其中一項作業:

  1. 將您的 CSV 分割成多個檔案,每個檔案最大 25,000 列。  為達到最佳效能,請使用 5000 列或以下。
  2. 使用 Adobe 的使用者同步工具。 這個命令列工具會將使用者及群組資訊從組織的企業目錄系統 (例如 Active Directory 或其他 LDAP 系統) 移到組織在 Adobe Admin Console 中的目錄。
  3. 使用 Adobe 的使用者管理 REST API。 您可以將這個 API 整合到組織的系統管理應用程式及程序。
  4. 如果您已使用 Microsoft Azure 或 Google Google 聯盟在 Admin Console 上設定 Federated ID,請使用 Admin Console 連接器。請參閱「透過 Adobe 為 SSO 設定 Google 聯盟」或「使用 Azure AD Connector 設定 SSO」。
  5. 如果您無法使用上述任一種方法大量上傳使用者,請登入 Admin Console、瀏覽至「支援」,然後聯絡 Adobe 客戶服務。

檔案處理

處理檔案時,每個項目都會根據特定網域,如下表所述個別處理。

所有處理完成後,便會以電子郵件將摘要傳送至啟動的管理員。如果取消匯入作業,則會停止處理。不過,不會回復已處理的列。

註解:

我們正在將組織 (團隊或企業) 更新到企業儲存模型,以便為 Adobe ID 用戶啟用企業儲存空間和其他企業級功能。

您的組織排定進行這項更新時,您會收到通知。更新後,Adobe ID 用戶會被移到企業儲存空間,組織直接控制他們的企業設定檔

身分類型

動作

例外

Federated ID

  • 使用者記錄是以指定的使用者名稱建立。
  • 帳戶會新增至指定的產品描述檔。
  • 除了判斷網域以外,不會使用電子郵件地址。
  • 如果啟用產品描述檔通知設定,則會向使用者傳送電子郵件。

  • 使用者名稱存在
  • 如果存在,國家/地區不會對 Adobe 業務開放*
  • 視組織或合約類型而定,如果未能透過指定的產品描述檔使用足夠的授權,則會出現以下其中一種情況:
    • 團隊:「無足夠授權」錯誤發生
    • VIP:帳戶會新增至指定的產品描述檔。不過,由於超過授權配額,因此使用者無法使用產品
    • ETLA:帳戶會新增至指定的產品描述檔。使用者可以存取指定的產品。續約後依 True-up 向您收費。

Enterprise ID

  • 使用指定的電子郵件地址建立帳戶。
  • 帳戶會新增至指定的產品設定。
  • 系統就會傳送歡迎電子郵件給使用者。

  • 已有邀請正在進行中或存在具有指定電子郵件的帳戶
  • 如果存在,國家/地區不會對 Adobe 業務開放*
  • 視組織或合約類型而定,如果未能透過指定的產品描述檔使用足夠的授權,則會出現以下其中一種情況:
    • 團隊:「無足夠授權」錯誤發生
    • VIP:帳戶會新增至指定的產品描述檔。不過,由於超過授權配額,因此使用者無法使用產品
    • ETLA:帳戶會新增至指定的產品描述檔。使用者可以存取指定的產品。續約後依 True-up 向您收費。

Adobe ID

  • 使用指定的電子郵件地址建立帳戶。
  • 帳戶會新增至指定的產品設定。
  • 如果您啟用「編輯產品設定檔」中的「使用電子郵件通知使用者」,則會向使用者寄送一封歡迎使用電子郵件。

 

  • 已有邀請正在進行中或存在具有指定電子郵件的帳戶。
  • 如果存在,國家/地區不會對 Adobe 業務開放*
  • 視組織或合約類型而定,如果未能透過指定的產品描述檔使用足夠的授權,則會出現以下其中一種情況:
    • 團隊:「無足夠授權」錯誤發生
    • VIP:帳戶會新增至指定的產品描述檔。不過,由於超過授權配額,因此使用者無法使用產品
    • ETLA:帳戶會新增至指定的產品描述檔。使用者可以存取指定的產品。續約後依 True-up 向您收費。

 

通知:

Adobe 服務和軟體受美國出口法律管制。該法律限制在某些地區中出口和使用 Adobe 服務和軟體,包括但不限於古巴、伊朗、北韓、蘇丹、敘利亞和烏克蘭的克里米亞地區。

註解:

「匯入使用者」功能不支援含有特殊字元的使用者暱稱,例如逗號 (,) 或分號 (;)。

效能詳細資訊

為避免超載,66.6% 工作週期規則是處理的一部分。 如果處理項目的時間與移動平均的差異超過 10%,則會調整節流,使請求處理僅消耗 2/3 的實際時間。

此外,由營運團隊管理的節流控制也會限制處理速率。 如果明確設定節流控制,則會停用工作週期控制。有個 API 呼叫可用於切回工作週期。

它會顯示每秒處理的請求數目,以提供有關效能的意見回饋。

建立 1000 個帳戶、每個帳戶都新增至 2 個產品設定的目標速率為每秒 1 個帳戶,而非計算 66.6% 工作週期,因此顯著處理速率可以是每秒 0.66 個帳戶或每分鐘約 40 個帳戶。 在此速率下,建立 1000 個帳戶需要花費 25 分鐘的時間。 在此速率下,建立 5000 個帳戶需要花費 2 小時又 5 分鐘的時間。

疑難排解

疑難排解章節有助於您在使用 Adobe Admin Console 的大量匯入功能時解決出現的錯誤狀況或其他問題。

上傳錯誤

如果未滿足滿些條件,有時檔案上傳會失敗。

錯誤訊息會在以下狀況顯示:

  • 檔案不是 CSV 格式。
  • 必要的欄標題 (例如,電子郵件) 無效或遺失。
  • 必要的欄遺失。

請執行下列動作:

  • 僅使用 .csv 檔案件格式。
  • 確保欄標題有效。
  • 確保欄值有效。

如需必要或選用欄位和檔案格式的詳細資訊,請參閱「管理使用者」中的 CSV 檔案格式表格。

若要修正 CSV 檔案的資料格式化問題:

  1. Microsoft Excel 中開啟 CSV 檔案。

  2. 選取 (反白) 包含工作表中資料的任一欄。

  3. 前往「資料」標籤,然後按一下「資料剖析」。

  4. 在顯示的對話方塊中,持續按一下「下一步」,直至「下一步」按鈕停用和「完成」按鈕啟用為止。

  5. 按一下「完成」,然後儲存並關閉檔案。

  6. 將更新後的 CSV 檔案上傳到 Admin Console。

錯誤訊息會在以下狀況顯示:

  • 當必要的欄標題 (例如,電子郵件) 存在,但對應的列值遺失時。

確保您為每列輸入對應的值。

處理錯誤

如果系統無法處理上傳檔案中的資料列,則會發生處理錯誤。若要查看詳細資訊,請參閱大量作業結果

原因

INTERNAL_SERVER_ERROR 錯誤是因閘道逾時所引起。它會在錯誤結果畫面上的「狀態」欄中顯示 INTERNAL_SERVER_ERROR

解決方法

您可以稍後再試。

原因

如果您未進行任何變更就再次上傳現有的使用者,則會在錯誤結果畫面上的「狀態」欄中顯示「已新增使用者

已新增使用者

解決方法

確保您不會再次上傳現有使用者。請移除包含現有使用者詳細資訊的列。

原因

此錯誤發生在 Azure SyncGoogle 同步關聯目錄中。使用者在身分提供者端進行管理。

解決方法

建議您在身分提供者入口網站上編輯並管理同步資料,並且允許變更透過同步散播。除非絕對必要,否則切勿在 Admin Console 中以手動方式變更資料。

原因

如果必要的欄標題 (例如,電子郵件) 存在,但對應的列值遺失,「剖析資料時發生錯誤」訊息會在結果畫面的「狀態」欄中顯示。

錯誤剖析

解決方法

確保您為每列輸入對應的值。

原因

如果網域不符合以下標準,則 Enterprise ID Federated ID  使用者會碰到此錯誤:

  • 網域」欄中的有效網域名稱
  • 具有有效網域名稱的電子郵件 ID
  • 具有有效網域名稱的使用者名稱

在貴組織中找不到網域」訊息出現在結果畫面的「狀態」欄。

註解:

當您在使用無效的網域時出現此錯誤,換言之,貴組織並未申請或信任該網域。

解決方法

請執行下列動作:

  • 請在「網域」欄中輸入有效的網域名稱
  • 請根據身分類型輸入有效的電子郵件 ID
  • 請根據身分類型輸入有效的使用者名稱

原因

如果您的組織未擁有使用者所要新增的網域,就會出現此錯誤。

解決方法

若要新增使用者至網域中,請執行以下其中一個動作:

原因

如果「國家/地區代碼標題」或資料值或兩者都遺失,Enterprise ID 或 Federated ID 使用者會碰到此錯誤。

國家/地區代碼必須是雙字元 ISO-3166 值」訊息出現在結果畫面的「狀態」欄。

國家/地區代碼錯誤

解決方法

確保您輸入國家/地區代碼欄標題和對應的有效列值。

原因

當貴組織已更新為企業儲存模型,但在 CSV 中輸入 Adobe ID 身分類型,就會發生此錯誤。

解決方法

您必須選擇 Enterprise ID 或 Federated ID 類型使用者。

原因

此錯誤通常發生在以下情況:CSV 檔案中的使用者名稱無法對應到組織 Admin Console 中的任何使用者。它是在操作對象為 Adobe Admin Console 中現有可用的使用者時觸發。

使用者不在組織中

解決方法

管理員應驗證 CSV 欄位中提供的「使用者名稱」值是否存在於 Adobe Admin Console 的使用者資訊中。

原因

只有在切換使用者身分時才會發生此錯誤。在 CSV 檔案中,給定的使用者名稱相符,但電子郵件與 Admin Console 目錄中的電子郵件不相符。

電子郵件必須相符

解決方法

確保電子郵件與 Admin Console 上為目錄定義的網域相符。

如果您仍遇到大量上傳使用者的問題並是系統或支援管理員,請從「Admin Console 支援」標籤建立案例、開始聊天或管理現有案例。

如需更多協助,請參閱「建立支援案例」。

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