3D 模型默认视图允许您在与模型交互时随时快速恢复到起点。默认视图决定 3D 模型未被激活时的外观,与预览不同。3D 模型可用的所有视图列表将在 3D 工具栏的“视图”菜单上和“模型树”的“视图”窗格中显示。

您也可以在 Acrobat 中创建 3D 模型的其它视图,以便根据需要快速导览 3D 内容(如顶部、底部、左边、右边、里面、外面、扩展或集中)。视图可包括光源、相机位置、渲染模式、“模型树”状态、透明度和横截面设置。自定义视图可包含精确的相机属性。

您可以在“书签”面板中将视图链接到书签,也可以使用“跳至 3D 视图”动作将视图链接到您在页面上创建的按钮和链接。

默认视图

当从 3D 模型创建 PDF 或将 3D 文件添加到现有 PDF 中时,Acrobat 将创建初始默认视图。无论是否创建其它默认视图,或 3D 文件中是否存在视图,都将创建此默认视图。

生成的默认视图具有以下特征:

  • 使用透视投影。

  • 视点放置在远离对象的位置,这样所有可见节点就会填充域视图的大部分区域。

  • 方向为主要沿着 X 轴的负轴方向,并沿着 Y 轴的负轴方向和 Z 轴的正轴方向各有相对较小的极小的偏移。

  • 相机聚焦到可见节点的中心,相机方向会使 Z 轴在显示的批注中垂直且向上方向为正轴。

通过选中“插入 3D”对话框中的“显示高级选项”框,然后选择“3D”标签并调整显示的参数,可设置默认视图的背景颜色、渲染模式和光源。

创建自定义视图

  1. 使用手形工具,单击 3D 模型将其启用。
  2. 请使用 3D 工具栏上的“旋转”、“平移”和“缩放”工具来更改视图。
  3. 在“视图属性”对话框中,选择要包含在视图中的显示设置。

    未选择的属性将使用上次显示的设置。例如,如果未选择“背景颜色”,则视图的背景颜色将保持与以前显示的背景颜色一样。

    该视图将在“模型树”的“视图”窗格中以“新建视图”列出。选择该视图将其重命名。

显示视图

  1. 请使用合适的方法来更改视图:
    • 请从 3D 工具栏的“视图”弹出菜单中选择视图。

    • 在“模型树”中单击视图名称。

    • 单击“默认视图”图标 

更改默认视图

  1. 在“模型树”的“视图”窗格中,执行以下任一操作:
    • 选择一个视图,然后从“选项”菜单中选择“设置为默认视图”。

    • 请右键单击视图,然后选择“设置为默认视图”。

注意:

要创建新视图,请从 3D 工具栏或上下文菜单中选择“视图”>“管理视图”。在随后显示的“管理视图”对话框中,单击“新建视图”按钮。

更改海报以匹配默认视图

  1. 使用“选择对象”工具(“工具”>“交互对象”>“选择对象”)双击 3D 模型。
  2. 在“编辑 3D”对话框中,单击“启动设置”标签。
  3. 在“海报图像”区域下,选择“从默认视图中检索海报”。
  4. 单击“确定”,然后保存 PDF。

本过程要求有一个或多个定义视图的 3D 模型,您可以创建这些视图。您可以将视图与已存在的书签和链接相关联,或者您可以为此创建新的视图。

  1. 执行以下任一操作:
    • 要创建新书签,请单击“书签”面板顶部的“新建书签”按钮 ,然后键入书签的新名称。然后,请右键单击它,然后选择“属性”。

    • 要创建新链接,请选择“工具”>“内容编辑”>“添加或编辑链接”,然后在页面上的任何位置拖动以创建链接矩形。然后,在“链接动作”下方的“创建链接”对话框中,选择“自定义链接”,然后单击“下一步”。

    • 要将视图链接到现有的书签或链接,请右键单击书签或链接,然后选择“属性”。

  2. 请在“属性”对话框中,单击“动作”标签。
  3. 从“选择动作”菜单中,选择“跳至 3D/多媒体视图”,然后单击“添加”。
  4. 请在“选择一个 3D 视图”对话框中,从左边的列表中选择 3D 模型的 3D 注释,然后从右边选择视图选项:

    当前视图

    在创建链接或书签时,匹配文档中处于活动状态的 3D 旋转、平移和缩放特性,无论该视图是否作为已定义视图列在“模型树”中。

    第一个视图

    更改为显示在“模型树”列表顶端的视图。

    最后一个视图

    更改为显示在“模型树”列表底部的视图。

    上一视图

    在已定义视图的“模型树”视图中上移,一次上移一个视图。

    下一视图

    在已定义视图的“模型树”视图中下移,一次下移一个视图。

    命名视图

    更改您从显示在本选项下的列表选择的定义视图。

  5. (可选)要使书签或链接也跳至特定页面和页面视图,请从“选择动作”菜单中选择“跳至页面视图”,然后单击“添加”。然后在您单击“设置链接”按钮之前使用滚动条和缩放工具来调整页面视图。完成后,请单击“属性”对话框中的“关闭”。

删除 3D 视图

  1. 执行以下任一操作:
    • 在 3D 工具栏上,打开“视图”弹出式菜单并选择“管理视图”。选择要删除的视图,并单击“删除视图”。

    • 在“模型树”面板的“视图”窗格中,选择要删除的视图。从“视图”窗格中,单击“删除”按钮  或单击“选项”按钮并选择“删除视图”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略