Find current information on Creative Cloud support for various Mac OS X versions here. And learn how to install previous versions of Creative Cloud apps if needed.

For information on the most current version of Creative Cloud, see What's new in Creative Cloud.

For details about supported software and hardware, see Creative Cloud system requirements.

What version of Mac OS X do I need for the 2015 release of Creative Cloud?

The 2015 release of Creative Cloud requires Mac OS X 10.9 or later. If you have an older version of Mac OS X, upgrade your operating system.

For answers to questions about compatibility between Mac OS X 10.11 and Creative Cloud applications, see Mac OS X El Capitan compatibility FAQ.

What version of Mac OS X do I have?

To find the version of Mac OS X you have installed, do the following:

  • From the Apple menu, choose About This Mac. The version number of the Mac OS you're using appears directly below the words "OS X."
Mac OS version

Upgrade to latest Mac OS X version

Visit the Mac App Store to upgrade to the latest version of Mac OS X. Follow the onscreen instructions to begin your upgrade. If you don’t have broadband access, you can also upgrade your Mac at any Apple Retail Store.

Upgrade to Mac OS X El Capitan

Install previous versions of Creative Cloud apps

If you ever need access to previous versions of apps, you can download and install them using the Creative Cloud desktop app. For more information, refer to Download and install Creative Cloud apps.

Install previous versions of Creative Cloud apps

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy