Info zu mehrsprachigem Text

Sie können eine FLA-Datei so konfigurieren, dass Text je nach dem Betriebssystem, das den Animate-Inhalt abspielt, in einer von mehreren Sprachen angezeigt wird.

Hinweis:

Die vollständige, aktualisierte Hilfe finden Sie im Internet. Die Anwendung hat keine Internetverbindung erkannt. Um eine vollständige Fassung dieses Themas anzuzeigen, klicken Sie auf den Link unten oder durchsuchen Sie die vollständige Hilfe unter http://helpx.adobe.com/support.html.

Sie können eine FLA-Datei so konfigurieren, dass Text je nach dem Betriebssystem, das den Animate-Inhalt abspielt, in einer von mehreren Sprachen angezeigt wird.

Lesen Sie die Beiträge zu mehrsprachigem Text in der Webhilfe, um sich über die Arbeit mit mehrsprachigem Text in Animate zu informieren.

Mehrsprachiger Text in Animate

Sie haben mehrere Möglichkeiten, Text in mehreren Sprachen in ein Dokument einzubinden:

  • (In Animate CC aufgegeben) Mit dem Bedienfeld „Strings“ können Übersetzer Strings an einem zentralen Ort in Animate oder in externen XML-Dateien mit der Software oder dem Translation Memory ihrer Wahl bearbeiten. Animate unterstützt mehrzeilige Strings im Bedienfeld „Strings“ und in den XML-Dateien.

  • Sie können die Zeichensätze wählen, die Sie in Ihre Anwendungen einbetten möchten, und damit die Anzahl der Glyphen in der veröffentlichten SWF-Datei begrenzen und die Dateigröße reduzieren.

  • Sie können eine westliche Tastatur verwenden, um auf der Bühne Text in Chinesisch, Japanisch und Koreanisch zu erstellen.

  • Wenn auf Ihrem System Unicode-Schriftarten installiert sind, können Sie Text direkt in ein Textfeld eingeben. Da diese Schriftarten nicht eingebettet sind, müssen auch Ihre Benutzer über Unicode-Schriftarten verfügen.

    Mehrsprachiger Text kann auch wie folgt in Animate-Dokumente integriert werden:

  • Sie können externe Textdateien in ein dynamisches Textfeld oder ein Eingabetextfeld einschließen, indem Sie die #include-Aktion verwenden.

  • Sie können externe Text- oder XML-Dateien zur Laufzeit in eine Animate-Anwendung laden, und zwar mit den Aktionen loadVariables oder getURL oder den Objekten LoadVars oder XML.

  • Sie können Unicode-Escape-Zeichen in den Stringwert für dynamische oder Eingabetextfeldvariablen eingeben.

  • In der Bibliothek können Sie eine eingebettete Schrift als Symbol erstellen.

    Benutzer müssen Zugriff auf die Schriftarten mit den im Text verwendeten Glyphen haben, damit der Unicode-kodierte Text richtig angezeigt wird.

Ein Beispiel für mehrsprachigen Inhalt finden Sie auf der Webseite mit Animate-Beispielen unter www.adobe.com/go/learn_fl_samples_de. Laden Sie die komprimierte Samples-Datei herunter, dekomprimieren Sie sie und wechseln Sie in den Ordner Text\MultilingualContent, um auf das Beispiel zuzugreifen.

Schriftarten für Unicode-kodierten Text

Wenn Sie externe Dateien verwenden, die in Unicode kodiert sind, müssen Ihre Benutzer auf die Schriftarten zugreifen können, die die in Ihren Textdateien verwendeten Glyphen enthalten. Standardmäßig speichert Animate die Namen der verwendeten Schriftarten in dynamischen Textfeldern oder Eingabetextfeldern. Während der Wiedergabe der SWF-Datei suchen Flash Player 7 und frühere Versionen nach den Schriftarten auf dem Betriebssystem, unter dem der Player läuft.

Wenn der Text in einer SWF-Datei Glyphen enthält, die von der angegebenen Schriftart nicht unterstützt werden, versuchen Flash Player 7 und Flash Player 8, auf dem System des Benutzers eine Schriftart zu finden, die diese Glyphen unterstützt. Nicht immer gelingt es dem Player, eine geeignete Schriftart zu finden. Das Verhalten dieser Funktion hängt von den auf dem System des Benutzers verfügbaren Schriftarten sowie vom Betriebssystem ab, unter dem der Flash Player läuft.

XML-Tabelle zur Schriftarteinbettung

Wenn Sie Schriftartenbereiche auswählen, die in eine FLA-Datei eingebettet werden sollen, verwendet Animate die Datei UnicodeTable.xml, um festzustellen, welche Zeichen einzubetten sind. Die Datei UnicodeTable.xml enthält Zeichen, die für verschiedene Sprache erforderlich sind, und befindet sich im Benutzerkonfigurationsordner des Computers. Die Datei befindet sich in den folgenden Verzeichnissen:

  • Windows: <Startlaufwerk>\Dokumente und Einstellungen\<Benutzer>\Lokale Einstellungen\Anwendungsdaten\Adobe\Flash<Version>\<Sprache>\Configuration\FontEmbedding\

  • Macintosh: <Benutzer>/Library/Application Support/Adobe/Flash <Version>/<Sprache>/Configuration/FontEmbedding/

Die Gruppierungen der Schriftsätze basieren auf den vom Unicode-Konsortium festgelegten Unicode-Blöcken. Um den Arbeitsablauf bei der Auswahl einer bestimmten Sprache zu vereinfachen, werden alle verwandten Glyphenbereiche eingebettet, selbst wenn sie in getrennten Gruppierungen verteilt sind.

Wenn Sie z. B. Koreanisch auswählen, werden die folgenden Unicode-Zeichenbereiche eingebettet:

3131-318E Hangul-Symbole

3200-321C Hangul-Sonderzeichen

3260-327B Hangul-Sonderzeichen

327F-327F Koreanisch-Symbole

AC00-D7A3 Hangul-Symbole

Wenn Sie Koreanisch und CJK auswählen, wird ein größerer Schriftsatz eingebettet:

3131-318E Hangul-Symbole

3200-321C Hangul-Sonderzeichen

3260-327B Hangul-Sonderzeichen

327F-327F Koreanisch-Symbole

4E00-9FA5 CJK-Symbole

AC00-D7A3 Hangul-Symbole

F900-FA2D CJK-Symbole

Weitere Informationen zu bestimmten Unicode-Bereichen für verschiedene Schriftsysteme finden Sie unter Unicode 5.2.0 specification.

Die folgende Tabelle enthält ausführlichere Informationen zu den Schriftartauswahlen für eingebettete Schriftarten:

Bereich

Beschreibung

Großbuchstaben [A–Z]

Standardlateinische Großbuchstabenglyphen sowie das Leerzeichen 0x0020.

Kleinbuchstaben [a–z]

Standardlateinische Kleinbuchstabenglyphen sowie das Leerzeichen 0x0020.

Ziffern [0–9]

Standardlateinische Ziffernglyphen

Interpunktion [!@#%...]

Standardlateinische Interpunktion

Standardlateinisch

Standardlateinische Glyphen im Unicode-Bereich 0x0020 bis 0x007E.

Japanische Kana

Hiragana- und Katakana-Glyphen (einschließlich halbbreite Formen)

Japanische Kanji - Stufe 1

Japanische Kanji-Zeichen

Japanisch (alle)

Japanische Kana und Kanji (einschließlich Interpunktion und Sonderzeichen)

Standard-Hangul

Am häufigsten verwendete koreanische Zeichen, lateinische Zeichen, Interpunktion und Sonderzeichen/Symbole

Hangul (alle)

11.720 koreanische Zeichen (nach Hangul-Silben sortiert), lateinische Zeichen, Interpunktion und Sonderzeichen/Symbole

Traditionelles Chinesisch - Stufe 1

Die 5000 am häufigsten verwendeten Zeichen des traditionellen Chinesisch, die in Taiwan verwendet werden

Traditionelles Chinesisch (alle)

Alle in Taiwan und Hongkong verwendeten Chinesisch-Zeichen sowie die Interpunktion

Vereinfachtes Chinesisch - Stufe 1

Die 6000 am häufigsten verwendeten Zeichen des vereinfachten Chinesisch, die in der Volksrepublik China verwendet werden, sowie die Interpunktion

Chinesisch (alle)

Alle Chinesisch-Zeichen (traditionell und vereinfacht) und die Interpunktion

Thai

Alle Thai-Glyphen

Devanagari

Alle Devanagari-Glyphen

Lateinisch I

Lateinisch – 1. Ergänzung Bereich von 0x00A1 bis 0x00FF (einschließlich Interpunktion, hoch- und tiefgestellte Zeichen, Währungssymbole und buchstabenähnliche Symbole)

Erweitertes Lateinisch-A

Erweitertes Lateinisch-A Bereich von 0x0100 bis 0x01FF (einschließlich Interpunktion, hoch- und tiefgestellte Zeichen, Währungssymbole und buchstabenähnliche Symbole)

Erweitertes Lateinisch-B

Erweitertes Lateinisch-B Bereich von 0x0180 bis 0x024F (einschließlich Interpunktion, hoch- und tiefgestellte Zeichen, Währungssymbole und buchstabenähnliche Symbole)

Zusätzliches erweitertes Lateinisch

Zusätzliches erweitertes Lateinisch Bereich von 0x1E00 bis 0x1EFF (einschließlich Interpunktion, hoch- und tiefgestellte Zeichen, Währungssymbole und buchstabenähnliche Symbole)

Griechisch

Griechisch und Koptisch sowie erweitertes Griechisch (einschließlich Interpunktion, hoch- und tiefgestellte Zeichen, Währungssymbole und buchstabenähnliche Symbole)

Kyrillisch

Kyrillisch (einschließlich Interpunktion, hoch- und tiefgestellte Zeichen, Währungssymbole und buchstabenähnliche Symbole)

Armenisch

Armenisch und Ligaturen

Arabisch

Arabisch und Präsentationsformen-A und Präsentationsformen-B

Hebräisch

Hebräisch und Präsentationsformen (einschließlich Interpunktion, hoch- und tiefgestellte Zeichen, Währungssymbole und buchstabenähnliche Symbole)

Nicht Unicode-kodierte externe Dateien

Wenn Sie externe Text- oder XML-Dateien, die nicht in Unicode kodiert sind, in eine Flash Player 7-Anwendung laden, wird der Text in den externen Dateien nicht korrekt angezeigt, wenn der Flash Player versucht, sie als Unicode anzuzeigen. Sie können den Flash Player so einstellen, dass er die herkömmliche Codepage des Betriebssystems, unter dem der Player läuft, verwendet. Geben Sie dazu den folgenden Code als erste Codezeile im ersten Bild der Animate-Anwendung ein, die die Dateien lädt.

system.useCodepage = true;

Stellen Sie die system.useCodepage-Eigenschaft in einem Dokument nur einmal ein; verwenden Sie sie nicht mehrfach in einem Dokument, damit der Player einige externe Dateien als Unicode und andere als eine andere Kodierung interpretiert. Dies kann zu unerwarteten Ergebnissen führen.

Wenn Sie die system.useCodepage-Eigenschaft auf true setzen, muss die herkömmliche Codepage des Betriebssystems, unter dem Flash Player ausgeführt wird, die Glyphen der externen Textdatei verwenden, damit der Text angezeigt werden kann. Wenn Sie beispielsweise eine externe Textdatei laden, die chinesische Zeichen verwendet, werden die Zeichen unter einem System, das die Codepage CP1252 verwendet, nicht angezeigt, denn in dieser Codepage sind keine chinesischen Zeichen enthalten. Sie können sicherstellen, dass die externen Textdateien in den Animate-Anwendungen auf allen Plattformen angezeigt werden, indem Sie alle externen Textdateien als Unicode kodieren und die system.useCodepage-Eigenschaft bei der Standardeinstellung false belassen. Dadurch interpretiert Flash Player den Text als Unicode. Weitere Informationen finden Sie unter „useCodepage (System.useCodepage property)“ im ActionScript 2.0-Referenzhandbuch.

Textkodierung

Jeder Text in einem Computer wird als eine Bytefolge kodiert. Text wird durch viele verschiedene Kodierungsformate (und daher auch verschiedene Bytefolgen) dargestellt. Je nach Betriebssystem wird Text unterschiedlich kodiert. Beispielsweise verwenden westliche Windows-Betriebssysteme in der Regel die CP1252-Kodierung, westliche Macintosh-Betriebssysteme die MacRoman-Kodierung und japanische Windows- und Macintosh-Betriebssysteme die Unicode-Kodierung.

Mit Unicode können die meisten Sprachen und Zeichen, die auf der Welt verwendet werden, kodiert werden. Bei den anderen von Computern verwendeten Textkodierungsformaten handelt es sich um Teilmengen des Unicode-Zeichensatzes, die auf bestimmte Regionen der Welt zugeschnitten sind. Einige dieser Formate sind in bestimmten Bereichen kompatibel und in anderen Bereichen nicht kompatibel. Die Verwendung der richtigen Kodierung ist also von entscheidender Bedeutung.

Es gibt mehrere Unicode-Formate. Die Flash Player Versionen 6 und 7 und höher unterstützen Text bzw. externe Dateien im 8-Bit-Format UTF8 und in den 16-Bit-Formaten UTF-16 BE (Big Endian) und UTF-16 LE (Little Endian).

Unicode und Flash Player

Flash Player ab Version 6 unterstützt die Unicode-Textkodierung. Mehrsprachiger Text kann von jedem Benutzer angezeigt werden, der über Macromedia Flash Player ab Version 6 verfügt, und zwar unabhängig von der Sprache des Betriebssystems, unter dem der Player läuft, wenn die richtigen Schriftarten installiert sind.

Flash Player geht davon aus, dass alle mit einer Flash Player-Anwendung verknüpften externen Textdateien in Unicode kodiert sind, wenn Sie nichts anderes festlegen.

Bei Animate-Anwendungen in Flash Player bis Version 5, die in Flash MX oder früheren Versionen erstellt werden, zeigt der Flash Player bis Version 6 den Text mithilfe der herkömmlichen Codepage des Betriebssystems an, unter dem der Player läuft.

Hintergrundinformationen zu Unicode finden Sie unter Unicode.org.

Textkodierung in Flash Player

Standardmäßig geht Flash Player 7 davon aus, dass jeder Text in Unicode kodiert ist. Wenn Ihr Dokument externe Text- oder XML-Dateien lädt, sollte der Text in diesen Dateien in UTF 8 kodiert sein. Sie können diese Dateien mit dem Bedienfeld „Strings“ oder in einem Text- oder HTML-Editor erstellen, der die Dateien im Unicode-Format speichern kann.

Von Flash Player unterstützte Unicode-Kodierformate

Beim Lesen von Textdaten in Animate erkennt Flash Player anhand der ersten zwei Byte in der Datei ein Byte Order Mark (BOM), eine Standardformatierungskonvention zur Identifikation des Unicode-Formats. Wird kein BOM erkannt, wird die Textkodierung als UTF-8 (ein 8-Bit-Kodierungsformat) interpretiert. Es empfiehlt sich, in den Anwendungen die UTF-8-Kodierung zu verwenden.

Wenn der Flash Player einen der folgenden BOMs erkennt, wird das Textkodierungsformat wie folgt interpretiert:

  • Wenn das erste Byte der Datei OxFE und das zweite OxFF ist, wird die Kodierung als UTF-16 BE (Big Endian) interpretiert. Diese Kodierung wird bei Macintosh-Betriebssystemen verwendet.

  • Wenn das erste Byte der Datei OxFF und das zweite OxFE ist, wird die Kodierung als UTF-16 LE (Little Endian) interpretiert. Diese Kodierung wird bei Windows-Betriebssystemen verwendet.

    Die meisten Texteditoren, die Dateien in UTF-16 BE oder LE speichern können, fügen die BOMs automatisch den Dateien hinzu.

    Hinweis: Wenn Sie die system.useCodepage-Eigenschaft auf true einstellen, wird der Text mithilfe der herkömmlichen Codepage des Betriebssystems interpretiert, unter dem der Player läuft. Er wird nicht als Unicode interpretiert.

Kodieren in externen XML-Dateien

Die Kodierung einer XML-Datei kann nicht durch Ändern des Kodierungs-Tags geändert werden. Der Flash Player verwendet zur Erkennung der Kodierung einer externen XML-Datei dieselben Regeln wie bei allen anderen externen Dateien: Wenn am Anfang der Datei kein BOM steht, wird davon ausgegangen, dass die Datei in UTF-8 kodiert ist. Wird ein BOM erkannt, wird die Datei als UTF-16 BE oder LE interpretiert.

Erstellen von mehrsprachigem Text

Sie können eine FLA-Datei so konfigurieren, dass Text je nach dem Betriebssystem, das den Animate-Inhalt abspielt, in einer von mehreren Sprachen angezeigt wird.

Hinweis:

Die vollständige, aktualisierte Hilfe finden Sie im Internet. Die Anwendung hat keine Internetverbindung erkannt. Um eine vollständige Fassung dieses Themas anzuzeigen, klicken Sie auf den Link unten oder durchsuchen Sie die vollständige Hilfe unter http://helpx.adobe.com/support.html.

Sie können eine FLA-Datei so konfigurieren, dass Text je nach dem Betriebssystem, das den Animate-Inhalt abspielt, in einer von mehreren Sprachen angezeigt wird.

Lesen Sie die Beiträge zum Erstellen von mehrsprachigem Text in der Webhilfe, um sich über das Hinzufügen von mehrsprachigem Text zu FLA-Dateien zu informieren.

Erstellen von mehrsprachigem Text mit dem Bedienfeld „Strings“

Mit dem Bedienfeld „Strings“ können Sie mehrsprachige Inhalte erstellen und aktualisieren. Nachdem Sie in Textfeldern Inhalt in mehreren Sprachen eingegeben haben, erkennt Animate automatisch anhand der Sprache des Computers, auf dem Flash Player ausgeführt wird, welche Inhalte in einer bestimmten Sprache angezeigt werden sollen.

Die folgenden Schritte beschreiben den allgemeinen Arbeitsablauf:

Erstellen Sie eine FLA-Datei in einer Sprache.

Text, den Sie in einer anderen Sprache eingeben möchten, muss sich in einem dynamischen Textfeld oder einem Eingabetextfeld befinden.

Wählen Sie im Dialogfeld „Einstellungen“ des Bedienfelds „Strings“ die Sprachen aus, die Sie verwenden möchten, und legen Sie dann eine dieser Sprachen als Standardsprache fest.

Im Bedienfeld „Strings“ wird eine Spalte für jede gewählte Sprache angezeigt. Wenn Sie die Anwendung speichern, testen oder veröffentlichen, wird für jede Sprache ein Ordner mit einer XML-Datei erstellt.

Kodieren Sie jeden Textstring im Bedienfeld „Strings“ mit einer ID.

Veröffentlichen Sie die Anwendung.

Für jede Sprache, die Sie ausgewählt haben, wird ein Ordner erstellt, der eine XML-Datei für die jeweilige Sprache enthält.

Senden Sie die veröffentlichte FLA-Datei und die XML-Ordner und -Dateien an Ihre Übersetzer.

Sie können Ihre Anwendung in Ihrer Muttersprache erstellen und die Übersetzung den Übersetzern überlassen. Diese können die XML-Dateien oder die FLA-Datei mit Übersetzungssoftware direkt bearbeiten.

Wenn Sie die Übersetzungen von Ihren Übersetzern zurückerhalten, müssen Sie die übersetzten XML-Dateien in die FLA-Datei zurückimportieren.

Hinweis:

Flash Pro CS4-Dateien mit klassischen dynamischen Textfeldern, für die die Anti-Alias-Funktion verwendet wurde und die aus dem Bedienfeld „Strings“ ausgefüllt werden, können unter Umständen nicht korrekt angezeigt werden, wenn Sie auf Flash Pro CS5 aktualisieren. Dies liegt an Änderungen an der Schriftarteinbettung in Flash Pro CS5. Um dieses Problem zu lösen, betten Sie die von den Textfeldern verwendeten Schriftarten manuell ein. Anweisungen hierzu finden Sie unter Einbetten von Schriftarten, um ein konsistentes Textbild zu erhalten.

Auswählen und Entfernen von Sprachen zur Übersetzung

Sie können bis zu 100 verschiedene Sprachen wählen, die auf der Bühne und im Bedienfeld „Strings“ zur Übersetzung angezeigt werden. Für jede Sprache, die Sie wählen, wird im Bedienfeld „Strings“ eine Spalte erstellt. Sie können die Sprache des auf der Bühne angezeigten Textes in jede von Ihnen gewählte Sprache ändern. Die gewählte Sprache wird angezeigt, wenn Sie die Datei veröffentlichen oder testen.

Sie können jede beliebige im Menü enthaltene Sprache sowie jede andere von Unicode unterstützte Sprache wählen.

Auswählen einer Sprache

  1. Wählen Sie „Fenster“ > „Andere Bedienfelder“ > „Strings“ und klicken Sie auf „Einstellungen“.
  2. So fügen Sie eine Sprache hinzu:
    • Markieren Sie im Textfeld „Sprachen“ die gewünschte Sprache und klicken Sie dann auf „Hinzufügen“.

    • Wenn die Sprache nicht im Textfeld „Sprachen“ angezeigt wird, geben Sie in das leere Feld unter dem Textfeld „Sprachen“ einen Sprachencode ein, und zwar im Format xx. (Sprachcode aus der ISO 639-1.) Klicken Sie auf „Hinzufügen“.

  3. Wiederholen Sie den vorherigen Schritt, bis Sie alle gewünschten Sprachen hinzugefügt haben.
  4. Wählen Sie im Menü „Standardsprache für Laufzeit“ eine Standardsprache aus. Diese Sprache wird auf Systemen angezeigt, die über keine der von Ihnen ausgewählten aktiven Sprachen verfügen.
  5. Wenn Sie zur Laufzeit eine XML-Datei für die Sprachen von einem anderen URL laden möchten, müssen Sie den URL in das Textfeld „URL“ eingeben und auf „OK“ klicken.

    Im Bedienfeld „Strings“ wird eine Spalte für jede gewählte Sprache angezeigt. Die Spalten werden in alphabetischer Reihenfolge angezeigt.

  6. Speichern Sie die FLA-Datei. Beim Speichern der FLA-Datei wird innerhalb des als SWF-Veröffentlichungspfad angegebenen Ordners jeweils ein Ordner für jede ausgewählte Sprache erstellt. Ist kein SWF-Veröffentlichungspfad ausgewählt, wird dieser innerhalb des Ordners mit der FLA-Datei erstellt. In jedem Sprachordner wird eine XML-Datei erstellt, die den zu ladenden übersetzten Text enthält.

Entfernen einer Sprache

  1. Wählen Sie „Fenster“ > „Andere Bedienfelder“ > „Strings“ und klicken Sie auf „Einstellungen“.
  2. Markieren Sie im Textfeld „Aktive Sprachen“ die zu entfernende Sprache und klicken Sie dann auf „Entfernen“.
  3. Wiederholen Sie Schritt 3, bis Sie alle unerwünschten Sprachen entfernt haben.
  4. Klicken Sie anschließend auf „OK“.

    Im Bedienfeld „Strings“ wird die Spalte für die entfernte Sprache nicht mehr angezeigt.

Hinweis:

Durch das Löschen einer Sprache aus dem Bedienfeld „Strings“ wird die XML-Sprachdatei nicht aus dem lokalen Dateisystem gelöscht. Bei Bedarf kann die Sprache daher unter Verwendung der vorherigen XML-Datei wieder zum Bedienfeld „Strings“ hinzugefügt werden. Zudem wird verhindert, dass die Sprache versehentlich gelöscht wird. Wenn Sie die Sprache vollständig löschen möchten, müssen Sie die XML-Sprachdatei löschen oder ersetzen.

Hinzufügen von Strings zum Bedienfeld „Strings“

Es gibt mehrere Möglichkeiten, im Bedienfeld „Strings“ Strings hinzuzufügen:

  • einem dynamischen Textfeld oder einem Eingabetextfeld eine String-ID zuordnen

  • dem Bedienfeld „Strings“ einen String hinzufügen, ohne ihn einem Textfeld zuzuordnen

  • eine vorhandene String-ID einem vorhandenen dynamischen Textfeld oder Eingabetextfeld zuordnen

Zuordnen einer String-ID zu einem Textfeld

  1. Wählen Sie „Fenster“ > „Andere Bedienfelder“ > „Strings“.
  2. Wählen Sie das Textwerkzeug aus. Erstellen Sie auf der Bühne ein Eingabetextfeld oder ein dynamisches Textfeld.
  3. Markieren Sie das Textfeld, und geben Sie im ID-Feld des Bedienfelds „Strings“ eine eindeutige ID ein.
  4. Klicken Sie auf die Schaltfläche „Einstellungen“ und wählen Sie im Dialogfeld „Einstellungen“ aus der entsprechenden Liste eine oder mehrere Sprachen aus. Wählen Sie neben der Sprache, die Sie als Standardsprache verwenden möchten, alle anderen Sprachen aus, in denen Sie Ihre Arbeit veröffentlichen möchten.
  5. Klicken Sie auf „Anwenden“.

Hinweis:

Wenn auf der Bühne ein statisches Textfeld ausgewählt wird, wird im Abschnitt „Bühnentext-Auswahl“ des Bedienfelds „Strings“ folgende Meldung angezeigt: „Statischem Text kann keine ID zugeordnet werden“. Wenn ein Nichttext-Element oder mehrere Elemente ausgewählt werden, wird die Meldung „Der aktuellen Auswahl kann keine ID zugeordnet werden.“ angezeigt.

Hinzufügen einer String-ID zum Bedienfeld „Strings“, ohne sie einem Textfeld zuzuordnen

  1. Wählen Sie „Fenster“ > „Andere Bedienfelder“ > „Strings“.
  2. Klicken Sie auf die Schaltfläche „Einstellungen“ und wählen Sie im Dialogfeld „Einstellungen“ aus der entsprechenden Liste eine oder mehrere Sprachen aus. Wählen Sie neben der Sprache, die Sie als Standardsprache verwenden möchten, alle anderen Sprachen aus, in denen Sie Ihre Arbeit veröffentlichen möchten.
  3. Geben Sie im Bedienfeld „Strings“ eine neue String-ID und einen neuen String ein und klicken Sie dann auf „Anwenden“.

Zuordnen einer vorhandenen ID zu einem Textfeld

  1. Wählen Sie das Textwerkzeug aus. Erstellen Sie auf der Bühne ein Eingabetextfeld oder ein dynamisches Textfeld.
  2. Geben Sie den Namen einer vorhandenen ID im ID-Abschnitt des Bedienfelds „Strings“ ein, und klicken Sie auf „Anwenden“.

Hinweis:

Sie können die ID mit Umschalt-+Eingabetaste oder, wenn das ID-Feld den Fokus hat, nur mit der Eingabetaste in das Textfeld übernehmen.

Bearbeiten von Strings im Bedienfeld „Strings“

Nachdem Sie im Bedienfeld „Strings“ Textstrings eingegeben haben, können Sie diese wie folgt bearbeiten:

  • direkt in den Zellen des Bedienfelds „Strings“

  • auf der Bühne in der als Bühnensprache gewählten Sprache, wobei Sie Funktionen wie Suchen und Ersetzen und die Rechtschreibprüfung verwenden. Text, der mit diesen Funktionen geändert wird, wird auf der Bühne und im Bedienfeld „Strings“ geändert.

  • die XML-Datei direkt bearbeiten

Ändern der auf der Bühne angezeigten Sprache

  1. Wählen Sie „Fenster“ > „Andere Bedienfelder“ > „Strings“.
  2. Wählen Sie im Menü „Bühnensprache“ die Sprache aus, die Sie als Bühnensprache verwenden möchten. Es muss eine Sprache sein, die Sie als verfügbare Sprache hinzugefügt haben.

    Nachdem Sie die Bühnensprache geändert haben, wird jeder neue Text, den Sie auf der Bühne eingeben, in dieser Sprache angezeigt. Wenn Sie zuvor im Bedienfeld „Strings“ Textstrings für die Sprache eingegeben haben, wird der Text auf der Bühne in der gewählten Sprache angezeigt. Andernfalls sind die auf der Bühne bereits vorhandenen Textfelder leer.

Eingeben von asiatischen Zeichen auf einer westlichen Tastatur

In Animate können Sie mithilfe eines Eingabemethodeneditors (IME) mit einer westlichen Tastatur asiatische Zeichen auf der Bühne eingeben. Animate unterstützt mehr als zwei Dutzend verschiedene IMEs.

Wenn Sie beispielsweise eine Website erstellen möchten, die von vielen asiatischen Benutzern aufgerufen werden kann, können Sie bei einer westlichen Tastatur den IME ändern und Text in Chinesisch, Japanisch und Koreanisch erstellen.

Hinweis:

Dies wirkt sich nur auf Texteingaben auf der Bühne aus, nicht jedoch auf Text, der im Bedienfeld „Aktionen“ eingegeben wird. Diese Funktion steht für alle unterstützten Windows-Betriebssysteme und für Macintosh OS X zur Verfügung.

  1. Wählen Sie „Bearbeiten“ > „Voreinstellungen“ (Windows) bzw. „Animate“ > „Voreinstellungen“ (Macintosh) und klicken Sie in der Liste „Kategorie“ auf „Text“.

  2. Wählen Sie unter „Eingabemethode“ eine der Optionen aus, um Zeichen über eine westliche Tastatur einzugeben. Die Vorgabe ist „Japanisch und Chinesisch“, und sie sollte auch für westliche Sprachen ausgewählt werden.

Veröffentlichen von mehrsprachigen FLA-Dateien

Wenn Sie die FLA-Datei speichern, veröffentlichen oder testen, wird für jede verfügbare Sprache, die Sie im Bedienfeld „Strings“ ausgewählt haben, ein Ordner mit einer XML-Datei erstellt. Der standardmäßige Speicherort für die XML-Ordner und -Dateien ist der als SWF-Veröffentlichungspfad angegebene Ordner. Ist kein SWF-Veröffentlichungspfad ausgewählt, werden der XML-Ordner und die XML-Dateien innerhalb des Ordners gespeichert, in dem sich die FLA-Datei befindet. Beispiel: Wenn Sie die Datei „Test“ im Ordner „Eigene Dateien“ gespeichert haben und Englisch (EN), Deutsch (DE) und Spanisch (ES) als aktive Sprachen gewählt haben, ohne zuvor einen SWF-Veröffentlichungspfad anzugeben, wird beim Speichern der FLA-Datei die folgende Ordnerstruktur erstellt:

\mystuff\Test.fla 
\mystuff\de\Test_de.xml 
\mystuff\en\Test_en.xml 
\mystuff\es\Test_es.xml

Wenn Sie eine SWF-Datei veröffentlichen, müssen Sie auch die zugehörigen XML-Dateien mit den String-Übersetzungen auf dem Webserver veröffentlichen. Das erste Bild, das Text enthält, kann erst angezeigt werden, wenn die gesamte XML-Datei geladen wurde.

Manuelles Ersetzen von Strings bei der Veröffentlichung

Sie haben die Möglichkeit, Strings bei der Veröffentlichung der Animate-SWF-Datei mit der Bühnensprache manuell zu ersetzen. Dabei werden mithilfe der Bühnensprache alle Instanzen von Eingabetext und dynamischem Text durch eine zugeordnete String-ID ersetzt. In diesem Fall werden Textstrings nur bei der Veröffentlichung der SWF-Datei aktualisiert. Die Spracherkennung ist nicht automatisch, und Sie müssen eine SWF-Datei für jede Sprache, die Sie unterstützen möchten, veröffentlichen.

  1. Wählen Sie „Fenster“ > „Andere Bedienfelder“ > „Strings“ und klicken Sie auf „Einstellungen“.
  2. Aktivieren Sie das Kontrollkästchen „Strings automatisch zur Laufzeit ersetzen“.

Verwenden der automatischem Spracherkennung für die Standardsprache

Sie können die Standardsprache für die Laufzeit in jede beliebige Sprache ändern, die Sie als verfügbare Sprache ausgewählt haben. Wenn die automatische Spracherkennung aktiviert ist und die SWF-Datei auf dem die Sprache verwendenden System angezeigt wird, wird die Standardsprache auf allen Systemen verwendet, deren Sprache nicht auf eine der aktiven Sprachen eingestellt ist. Wenn Sie z. B. als Standardsprache Englisch eingestellt und JP, EN und FR als aktive Sprachen gewählt haben, sehen Benutzer, die die Sprache ihres Systems auf Japanisch, Englisch oder Französisch eingestellt haben, Textstrings automatisch in ihrer Sprache. Dagegen sehen Benutzer, deren Systemsprache auf Schwedisch eingestellt ist, d. h. auf eine Sprache, die Sie nicht ausgewählt haben, Textstrings automatisch in der von Ihnen gewählten Standardsprache – in diesem Fall Englisch.

  1. Wählen Sie „Fenster“ > „Andere Bedienfelder“ > „Strings“ und klicken Sie auf „Einstellungen“.
  2. Wählen Sie im Menü „Standardsprache“ die gewünschte Standardsprache aus. Es muss eine Sprache sein, die Sie als verfügbare Sprache hinzugefügt haben.
  3. Wenn Sie die automatische Spracherkennung aktivieren möchten, müssen Sie das Kontrollkästchen „Strings automatisch zur Laufzeit ersetzen“ aktivieren und auf „OK“ klicken.

Animate generiert das folgende ActionScript®, in dem die XML-Sprachdateipfade gespeichert werden. Sie können dieses Skript als Ausgangspunkt für Ihr eigenes Spracherkennungsskript verwenden.

import mx.lang.Locale; 
Locale.setFlaName("<flaFileName>"); 
Locale.setDefaultLang("langcode"); 
Locale.addXMLPath("langcode", "url/langcode/flaname_langcode.xml");

Hinweis:

Der vom Bedienfeld „Strings“ erzeugte ActionScript-Code verwendet die Locale.initialize-Funktion nicht. Sie müssen basierend auf den für Ihr Projekt erforderlichen Spracherkennungsanpassungen entscheiden, wie diese Funktion aufgerufen werden soll.

Verwenden der benutzerdefinierten Spracherkennung

Sie können selbst den Zeitpunkt festlegen, an dem Text ersetzt wird. Dazu erstellen Sie entweder eine benutzerdefinierte Komponente oder Sie greifen mit ActionScript auf die XML-Sprachdateien zu. Sie können z. B. ein Popupmenü erstellen, in dem Benutzer die gewünschte Sprache für die Inhaltsanzeige auswählen können.

Informationen zum Schreiben von ActionScript-Code zum Erstellen der benutzerdefinierten Sprachenerkennung finden Sie im Abschnitt zum Bedienfeld „Strings“ im ActionScript 2.0 – Arbeitshandbuch.

  1. Wählen Sie „Fenster“ > „Andere Bedienfelder“ > „Strings“ und klicken Sie auf „Einstellungen“.
  2. Wählen Sie im Menü „Standardsprache“ die gewünschte Standardsprache aus.

    Es muss eine Sprache sein, die Sie als verfügbare Sprache hinzugefügt haben.

  3. Aktivieren Sie das Kontrollkästchen „Strings mithilfe von ActionScript zur Laufzeit ersetzen“ und klicken Sie auf „OK“.

    Animate generiert den folgenden ActionScript-Code, in dem die XML-Sprachdateipfade gespeichert werden. Sie können dieses Skript als Ausgangspunkt für Ihr eigenes Spracherkennungsskript verwenden.

    import mx.lang.Locale; 
    Locale.setFlaName("<flaFileName>"); 
    Locale.setDefaultLang("langcode"); 
    Locale.addXMLPath("langcode", "url/langcode/flaname_langcode.xml");

Hinweis:

Der vom Bedienfeld „Strings“ erzeugte ActionScript-Code verwendet die Locale.initialize-Funktion nicht. Sie müssen basierend auf den für Ihr Projekt erforderlichen Spracherkennungsanpassungen entscheiden, wie diese Funktion aufgerufen werden soll.

Zusätzliche Ressourcen

XML-Dateiformat für mehrsprachigen Text

Wenn Sie in Animate mehrsprachigen Text verwenden, wird der Text in XML-Dateien gespeichert.

Hinweis:

Die vollständige, aktualisierte Hilfe finden Sie im Internet. Die Anwendung hat keine Internetverbindung erkannt. Um eine vollständige Fassung dieses Themas anzuzeigen, klicken Sie auf den Link unten oder durchsuchen Sie die vollständige Hilfe unter http://helpx.adobe.com/support.html.

Wenn Sie in Animate mehrsprachigen Text verwenden, wird der Text in XML-Dateien gespeichert.

Lesen Sie die Beiträge zum XML-Dateiformat in der Webhilfe, um sich über die Arbeit mit XML-Dateien und deren Import in FLA-Dateien zu informieren.

Einführung in das XML-Dateiformat

Exportierte XML-Dateien haben das Format UTF-8 und entsprechen dem XLIFF-Standard 1.0 (XML Localization Interchange File Format). Mit XLIFF wird eine Spezifikation für ein erweiterbares Format zum Austausch von Lokalisierungsinformationen festgelegt, mit dem Softwarehersteller ein einziges Austauschformat erstellen können, das von allen Lokalisierungsanbietern verwendet werden kann. Weitere Informationen zu XLIFF finden Sie unter www.oasis-open.org/committees/xliff/.

XLIFF-Beispiele

Wenn eines der folgenden Zeichen in das Bedienfeld „Strings“ eingegeben wird, wird es beim Schreiben in XML-Dateien durch den entsprechenden Entitätsverweis ersetzt:

Zeichen

Ersetzt durch

& (Et-Zeichen)

& amp;

'

&apos;

"

&quot;

<

&lt;

>

&gt;

Beispiel für eine exportierte XML-Datei

Die folgenden Beispiele zeigen, wie eine vom Bedienfeld „Strings“ erzeugte XML-Datei in der Quellsprache (Englisch) und in einer anderen Sprache (Französisch) aussieht.

Beispiel für Englisch als Quellsprache:

<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE xliff PUBLIC "-//XLIFF//DTD XLIFF//EN" 
"http://www.oasis-open.org/committees/xliff/documents/xliff.dtd" > 
<xliff version="1.0" xml:lang="en"> 
<file datatype="plaintext" original="MultiLingualContent.fla" source-language="EN"> 
        <header></header> 
        <body> 
            <trans-unit id="001" resname="IDS_GREETINGS"> 
                <source>welcome to our web site!</source> 
            </trans-unit> 
            <trans-unit id="002" resname="IDS_MAILING LIST"> 
                <source>Would you like to be on our mailing list?</source> 
            </trans-unit> 
            <trans-unit id="003" resname="IDS_SEE YOU"> 
                <source>see you soon!</source> 
            </trans-unit> 
            <trans-unit id="004" resname="IDS_TEST"> 
                <source></source> 
            </trans-unit> 
        </body> 
    </file> 
</xliff>

Beispiel für Französisch als Quellsprache:

<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE xliff PUBLIC "-//XLIFF//DTD XLIFF//EN" 
"http://www.oasis-open.org/committees/xliff/documents/xliff.dtd" > 
<xliff version="1.0" xml:lang="fr"> 
<file datatype="plaintext" original="MultiLingualContent.fla" source-language="EN"> 
        <header></header> 
        <body> 
            <trans-unit id="001" resname="IDS_GREETINGS"> 
                <source>Bienvenue sur notre site web!</source> 
            </trans-unit> 
            <trans-unit id="002" resname="IDS_MAILING LIST"> 
                <source>Voudriez-vous être sur notre liste de diffusion?</source> 
            </trans-unit> 
            <trans-unit id="003" resname="IDS_SEE YOU"> 
                <source>A bientôt!</source> 
            </trans-unit> 
            <trans-unit id="004" resname="IDS_TEST"> 
                <source></source> 
            </trans-unit> 
        </body> 
    </file> 
</xliff>

Übersetzen von Text im Bedienfeld „Strings“ oder in XML-Dateien

Schicken Sie den Übersetzern nicht nur die FLA-Datei, sondern auch die Ordner für die XML-Dateien sowie die XML-Datei für jede Sprache.

Die Übersetzer können entweder direkt in den Sprachspalten des Bedienfelds „Strings“ oder in den XML-Dateien für jede Sprache arbeiten, um die FLA-Datei in die ausgewählten Sprachen zu übersetzen. Wenn Sie direkt in der XML-Datei übersetzen, müssen Sie die XML-Datei entweder in das Bedienfeld „Strings“ importieren oder im Standardverzeichnis für die jeweilige Sprache speichern.

Übersetzen von Text im Bedienfeld „Strings“

  1. Wählen Sie „Fenster“ > „Andere Bedienfelder“ > „Strings“.
  2. Wählen Sie für jede Sprache, die übersetzt werden soll, die entsprechende Sprachspalte aus, und geben Sie dann den übersetzten Text für die Sprache ein, der der String-ID zugeordnet werden soll.
  3. Um den Text auf der Bühne in der gewählten Sprache anzuzeigen, müssen Sie die Sprache im Feld „Bühnensprache“ auswählen.
  4. Anschließend können Sie die Datei speichern, veröffentlichen oder testen.

    Alle XML-Dateien für alle Sprachen werden mit den Informationen im Bedienfeld „Strings“ überschrieben.

    Hinweis:

    Wenn Sie die Übersetzung in einer XML-Datei beibehalten möchten, müssen Sie sie in einem anderen Ordner speichern.

Übersetzen von Text in einer XML-Datei

  1. Öffnen Sie den Ordner für die gewünschte Sprache und dann die XML-Datei für diese Sprache mit einem XML-Editor oder einer Übersetzungssoftware. Die XML-Datei wird mit IDs für jeden Textstring aufgefüllt.
  2. Geben Sie den Textstring für die Sprache neben der ID ein.
  3. Importieren Sie ggf. die übersetzte XML-Datei in das Bedienfeld „Strings“.

Importieren von XML-Dateien in das Bedienfeld „Strings“

Wenn Sie eine XML-Datei nach dem Ändern in dem im Bedienfeld „Strings“ für die entsprechende Sprache festgelegten Ordner speichern, wird die XML-Datei in das Animate-Dokument (die FLA-Datei) geladen, wenn sie geöffnet wird.

Es spielt keine Rolle, wo die importierte XML-Datei gespeichert war. Wenn Sie die FLA-Datei speichern, testen oder veröffentlichen, werden in dem als SWF-Veröffentlichungspfad ausgewählten Ordner je ein Ordner für jede Sprache im Bedienfeld „Strings“ und eine XML-Datei für jede Sprache erstellt. Wenn kein Veröffentlichungspfad angegeben wurde, werden der XML-Ordner und die XML-Dateien innerhalb des Ordners gespeichert, in dem sich die FLA-Datei befindet. Alle vom Bedienfeld „Strings“ erzeugten XML-Dateien enthalten immer die im Bedienfeld „Strings“ enthaltenen Informationen.

Sie können XML-Dateien auch von einem anderen Ort aus in das Bedienfeld „Strings“ importieren. Nachdem Sie sie importiert haben, wird die XML-Datei in dem für die Sprache festgelegten Ordner beim Speichern, Testen oder Veröffentlichen überschrieben. Sie können eine XML-Datei für eine Sprache erst importieren, wenn die Sprache im Bedienfeld „Strings“ bereits als verfügbare Sprache ausgewählt wurde. Sie haben auch die Möglichkeit, eine Sprache hinzuzufügen und eine XML-Datei mit der Übersetzung für diese Sprache zu importieren.

  1. Wählen Sie „Fenster“ > „Andere Bedienfelder“ > „Strings“ und klicken Sie auf „XML importieren“.
  2. Wählen Sie im Menü „Sprache auswählen“ die Sprache der XML-Datei aus, die Sie importieren, und klicken Sie dann auf „OK“.
  3. Wechseln Sie zu dem Ordner, der die zu importierende XML-Datei enthält.

    Die XML-Informationen werden im Bedienfeld „Strings“ in die Spalte für die in Schritt 3 gewählte Sprache geladen.

Hinweis:

Wählen Sie dieselbe Sprache in den Schritten 2 und 3 aus. Andernfalls könnte es passieren, dass Sie z. B. eine französische XML-Datei in die Spalte für Deutsch importieren.

Mehrsprachiger Text und ActionScript

Sie können mehrsprachigen Text erstellen und mehrsprachige XML-Dateien importieren, indem Sie ActionScript® verwenden.

Hinweis:

Die vollständige, aktualisierte Hilfe finden Sie im Internet. Die Anwendung hat keine Internetverbindung erkannt. Um eine vollständige Fassung dieses Themas anzuzeigen, klicken Sie auf den Link unten oder durchsuchen Sie http://helpx.adobe.com/support.html.

Sie können mehrsprachigen Text erstellen und mehrsprachige XML-Dateien importieren, indem Sie ActionScript® verwenden.

Lesen Sie die Beiträge zum Erstellen von mehrsprachigem Text in der Webhilfe, um sich über die Arbeit mit mehrsprachigem Text in ActionScript zu informieren.

Laden von externen Dateien mit ActionScript

Wenn Sie vorhandene XML-Dateien laden möchten oder die XML-Datei gerne in einem anderen Format hätten, können Sie mithilfe der loadVariables-Aktion, der getURL-Aktion, dem LoadVars-Objekt oder dem XML-Objekt ein Dokument mit mehrsprachigem Text erstellen, indem Sie den Text in einer externen Text- oder XML-Datei platzieren und die Datei zur Laufzeit in den Film laden.

Die externe Datei sollte im Format UTF-8 (empfohlen), UTF-16 BE oder UTF-16 LE gespeichert werden. Wenn Sie das Format UTF-16 BE oder UTF-16 LE verwenden, muss die Datei mit einem BOM beginnen, damit Flash Player das Kodierungsformat identifizieren kann. Die folgende Tabelle enthält eine Liste der BOMs, die zum Identifizieren der Kodierung verwendet werden sollten:

Hinweis: Die meisten Texteditoren, die Dateien in UTF-16 BE oder LE speichern können, fügen die BOMs automatisch den Dateien hinzu.

UTF-Format

Erstes Byte

Zweites Byte

UTF-16 BE

OxFE

OxFF

UTF-16 LE

OxFF

OxFE

Hinweis:

Handelt es sich bei der externen Datei um eine XML-Datei, können Sie die Kodierung der Datei nicht mit einem XML-Kodierungstag ändern. Sie sollten die Datei in einem unterstützten Unicode-Format speichern.

  1. Erstellen Sie in der Animate-Authoring-Anwendung ein dynamisches Textfeld oder ein Eingabetextfeld, um den Text im Dokument anzuzeigen.

  2. Wählen Sie das Textfeld aus und ordnen Sie dem Textfeld im Eigenschafteninspektor einen Instanznamen zu.
  3. Erstellen Sie außerhalb von Animate eine Text- oder XML-Datei, die den Wert für die Textfeldvariable festlegt.

  4. Speichern Sie die XML-Datei im Format UTF-8 (empfohlen), UTF-16 BE oder UTF-16 LE.
  5. Verweisen Sie mit einer der folgenden ActionScript-Prozeduren auf die externe Datei und laden Sie sie in das dynamische bzw. Eingabetextfeld:
    • Laden Sie eine externe Datei mit der Aktion loadVariables.

    • Laden Sie mit der Aktion getURL eine externe Datei von der angegebenen URL herunter.

    • Laden Sie mit dem LoadVars-Objekt (einem vordefiniertem Client-Server-Objekt) eine externe Textdatei von der angegebenen URL herunter.

    • Laden Sie mit dem XML-Objekt (einem vordefiniertem Client-Server-Objekt) eine externe XML-Datei von der angegebenen URL herunter. Weitere Informationen finden Sie unter „XML“ im ActionScript-Referenzhandbuch.

Erstellen von mehrsprachigen Dokumenten mit der #include-Aktion

Zum Erstellen eines Dokuments, das mehrere Sprachen enthält, verwenden Sie die #include-Aktion.

Um die Datei im UTF-8-Format zu speichern, müssen Sie Anwendung verwenden, die die UTF8-Kodierung unterstützt, wie z. B. Dreamweaver.

Die Datei muss als erste Zeile die folgende Kopfzeile haben, damit sie vom Animate-Authoring-Tool als Unicode identifiziert wird:

//!-- UTF8

Hinweis:

Achten Sie darauf, dass hinter dem zweiten Bindestrich (-) ein Leerzeichen steht.

Standardmäßig geht die Animate-Authoring-Anwendung davon aus, dass die externen Dateien, die die #include-Aktion verwenden, in der herkömmlichen Codepage des Betriebssystems, unter dem das Authoring-Tool läuft, kodiert sind. Wenn eine Datei die Kopfzeile //!-- UTF8 enthält, erkennt das Authoring-Tool, dass die externe Datei als UTF-8 kodiert ist.

  1. Erstellen Sie im Animate-Authoring-Tool ein dynamisches Textfeld oder ein Eingabetextfeld, um den Text im Dokument anzuzeigen.

  2. Wählen Sie das Textfeld aus und ordnen Sie dem Textfeld im Eigenschafteninspektor einen Instanznamen zu.
  3. Erstellen Sie außerhalb von Animate eine Textdatei, die den Wert für die Textfeldvariable festlegt. Fügen Sie die Kopfzeile //!-- UTF8 am Dateianfang hinzu.

  4. Speichern Sie die Textdatei im Format UTF-8.
  5. Fügen Sie die externe Datei mithilfe der #include-Direktive in das dynamische oder Eingabetextfeld ein. Weitere Informationen finden Sie im Abschnitt zur Direktive #include im ActionScript-Referenzhandbuch.

Erstellen von mehrsprachigen Dokumenten mit Textvariablen

Mit der Syntax \uXXXX können Sie in Unicode kodierten Inhalt in Textvariablen aufnehmen. Dabei ist XXXX der vierstellige hexadezimale Codepunkt bzw. das Escape-Zeichen für das Unicode-Zeichen. Das Animate-Authoring-Tool unterstützt Escape-Zeichen in Unicode bis zu \uFFFF. Die Codepunkte für Unicode-Zeichen finden Sie im Unicode-Standard unter Unicode.org.

Escape-Zeichen in Unicode können Sie nur in Textfeldvariablen verwenden. In externen Text- oder XML-Dateien können Sie sie nicht aufnehmen; in externen Dateien erkennt Flash Player 6 keine Unicode-Escape-Zeichen.

Um z. B. ein dynamisches Textfeld (mit dem Instanznamen myTextVar) festzulegen, das japanische, koreanische, chinesische, englische, hebräische und griechische Zeichen sowie das Euro-Zeichen enthält, können Sie Folgendes eingeben:

myTextVar.text = "\u304B\uD55C\u6C49hello\u03BB\u20AC";

Bei der Wiedergabe der SWF-Datei wird im Textfeld Folgendes angezeigt:

Beim Erstellen von Textfeldern, die mehrere Sprachen enthalten, erzielen Sie die besten Ergebnisse, wenn Sie eine Schriftart verwenden, die alle für Ihren Text benötigten Glyphen umfasst.

Kommunizieren mit externen XML-Dateien über die XMLConnector-Komponente

Über die XMLConnector-Komponente der Version 2 können Sie mit externen XML-Dateien kommunizieren, um Bindungen an Eigenschaften im Dokument zu erstellen. Diese Komponente hat den Zweck, über die HTTP-Operationen GET bzw. POST XML-Dokumente zu lesen oder zu schreiben. Sie dient als Verbindung zwischen anderen Komponenten und externen XML-Dateien. Die XMLConnector-Komponente kommuniziert entweder über Datenbindungsfunktionen in der Animate-Authoring-Umgebung oder über ActionScript-Code mit Komponenten in Ihrer Anwendung. Weitere Informationen finden Sie im Abschnitt zur Komponente „XMLConnector“ im ActionScript-Referenzhandbuch.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie