Erstellen und Organisieren von Ebenen

Ebenen dienen zum Strukturieren und Anordnen der Grafiken in einem Dokument. Beim Zeichnen und Bearbeiten von Objekten, die sich auf einer Ebene befinden, werden die Objekte auf den anderen Ebenen des Dokuments nicht verändert. Überall dort, wo eine Ebene keine Elemente enthält, können Sie durch diese Ebene auf die darunterliegenden Ebenen sehen.

Wenn Sie auf einer Ebene zeichnen, malen oder eine Ebene oder einen Ordner auf andere Weise bearbeiten möchten, müssen Sie diese Ebene in der Zeitleiste auswählen, um sie zu aktivieren. Die jeweils aktive Ebene bzw. der aktive Ordner in der Zeitleiste ist mit einem Stiftsymbol neben dem Ebenen- oder Ordnernamen gekennzeichnet. Sie haben zwar die Möglichkeit, mehrere Ebenen gleichzeitig auszuwählen, können aber jeweils immer nur eine Ebene aktivieren.

Ein in Animate CC (früher Flash Professional CC) neu erstelltes Dokument enthält nur eine Ebene. Sie können anschließend weitere Ebenen hinzufügen, um Grafiken, Animationen und andere Elemente in Ihrem Dokument zu organisieren. Ebenen können auch ausgeblendet, gesperrt und neu angeordnet werden. Die Anzahl der Ebenen ist hierbei lediglich durch den verfügbaren Speicher Ihres Computers begrenzt und wirkt sich in keiner Weise auf die Größe der veröffentlichten SWF-Datei aus. Nur die in Ebenen platzierten Objekte wirken sich auf die Dateigröße aus.

Außerdem haben Sie die Möglichkeit, verschiedene Ebenen in Ebenenordnern zusammenzufassen. Auf diese Weise können Sie Ebenenordner in der Zeitleiste gezielt ein- und ausblenden, ohne die Darstellung der Inhalte auf der Bühne zu verändern. Es empfiehlt sich, für Sounddateien, ActionScript, Bildbezeichnungen und Bildkommentare separate Ebenen oder Ordner zu verwenden, Verwenden Sie separate Ebenen, damit Sie diese Elemente bei Bedarf rasch auffinden und bearbeiten können.

Um anspruchsvolle Effekte zu erzielen, können Sie darüber hinaus spezielle Führungsebenen verwenden, um das Zeichnen und Bearbeiten zu vereinfachen und Maskenebenen hinzuzufügen.

Es gibt fünf Ebenentypen, die Sie in Animate verwenden können:

  • Normale Ebenen enthalten den Großteil der Grafiken einer FLA-Datei.

  • Maskenebenen enthalten Objekte, mit denen ausgewählte Teile der darunter liegenden Ebenen maskiert werden. Weitere Informationen finden Sie unter Verwenden von Maskenebenen.

  • Bei maskierten Ebenen handelt es sich um die Ebenen, die unter einer zugeordneten Maskenebene liegen. Sichtbar ist nur der Teil der maskierten Ebene, der von der Maske freigelassen wird. Weitere Informationen finden Sie unter Verwenden von Maskenebenen.

  • Führungsebenen enthalten Striche, mit denen die Anordnung der Objekte auf anderen Ebenen festgelegt werden kann. Außerdem können Sie sie verwenden, um die Bewegungen klassischer Tween-Animationen auf anderen Ebenen festzulegen. Weitere Informationen finden Sie unter Führungsebenen und Erstellen von klassischen Bewegungs-Tweens entlang eines Pfades.

  • Bei ausgerichteten Ebenen handelt es sich um Ebenen, die einer Führungsebene zugeordnet sind. Die auf der ausgerichteten Ebene befindlichen Objekte können entlang der Striche auf der Führungsebene angeordnet oder animiert werden. Ausgerichtete Ebenen können statische Grafiken und klassische Tweens, aber keine Bewegungs-Tweens enthalten.

  • Bewegungs-Tween-Ebenen enthalten durch Bewegungs-Tweens animierte Objekte. Weitere Informationen finden Sie unter Info zu getweenter Animation.

  • Skelettebenen enthalten Objekte, denen Inverse Kinematics-Bones angehängt wurden. Weitere Informationen finden Sie unter Verwenden des Bone-Werkzeugs für Animationen mit Inverse Kinematics.

Normale und maskierte Ebenen sowie Masken- und Führungsebenen können Bewegungs-Tweens oder Inverse-Kinematics-Bones enthalten. Sind diese Elemente in einer der Ebenen vorhanden, dann sind die Arten des Inhalts, die den Ebenen hinzugefügt werden können, eingeschränkt. Weitere Informationen finden Sie unter Bewegungs-Tweens und Verwenden des Bone-Werkzeugs für Animationen mit Inverse Kinematics.

Erstellen einer Ebene

Neu erstellte Ebenen werden oberhalb der ausgewählten Ebene angezeigt. Die neu erstellte Ebene wird automatisch zur aktiven Ebene.

  1. Führen Sie einen der folgenden Schritte aus:
    • Klicken Sie am unteren Rand der Zeitleiste auf die Schaltfläche „Neue Ebene“ .

    • Wählen Sie Einfügen > Zeitleiste > Ebene aus.

    • Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Macintosh) auf einen Ebenennamen in der Zeitleiste und wählen Sie im Kontextmenü den Befehl Ebene einfügen.

Erstellen von Ebenenordnern

  1. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie in der Zeitleiste eine Ebene oder einen Ordner aus und wählen Sie dann Einfügen > Zeitleiste > Ebenenordner.

    • Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Macintosh) auf einen Ebenennamen in der Zeitleiste und wählen Sie im Kontextmenü den Befehl „Ordner einfügen“. Der neue Ordner erscheint in der Zeitleiste oberhalb der ausgewählten Ebene bzw. des ausgewählten Ordners.

    • Klicken Sie am unteren Rand der Zeitleiste auf das Symbol „Neuer Ordner“ . Der neue Ordner erscheint in der Zeitleiste oberhalb der ausgewählten Ebene bzw. des ausgewählten Ordners.

Organisieren von Ebenen und Ebenenordnern

Sie können Ebenen und Ordner beliebig in der Zeitleiste anordnen, um Ihr Dokument zu strukturieren.

Mithilfe von Ebenenordnern können Sie Ebenen hierarchisch gliedern und Ihren Arbeitsablauf vereinfachen. Durch Ein- und Ausblenden der Ordnerinhalte lassen sich einzelne Ebenengruppen gezielt anzeigen, ohne die Darstellung der Ebenen auf der Bühne zu verändern. Ordner können sowohl Ebenen als auch weitere Ordner enthalten. Dadurch ist es möglich, Ebenen in ähnlicher Weise zu verwalten wie die auf einem Computer gespeicherten Dateien.

Die Ebenensteuerungen in einer Ordnerzeile der Zeitleiste gelten für alle in dem jeweiligen Ordner enthaltenen Ebenen. Wenn Sie beispielsweise einen Ebenenordner sperren, sperren Sie zugleich auch alle Ebenen, die in ihm enthalten sind.

  • Sie können eine Ebene oder einen Ebenenordner in einen Ebenenordner verschieben, indem Sie den Namen der Ebene oder des Ebenenordners auf den Namen des gewünschten Zielordners ziehen.
  • Sie können die Reihenfolge der Ebenen oder Ordner ändern, indem Sie eine oder mehrere Ebenen bzw. einen oder mehrere Ordner in der Zeitleiste an die gewünschte Position verschieben.
  • Klicken Sie auf das Dreieck links neben dem Ordnernamen, um den Inhalt eines Ordners ein- oder auszublenden.
  • Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Macintosh) auf den linken Bereich der Zeitleiste, in dem die Ebenen- und Ordnernamen aufgeführt sind, und wählen Sie im Kontextmenü den Befehl Alle Ordnerinhalte einblenden oder Alle Ordnerinhalte ausblenden.

Umbenennen von Ebenen oder Ordnern

Standardmäßig weist Animate neuen Ebenen Namen in der Reihenfolge zu, in der sie erstellt werden: Ebene 1, Ebene 2 usw. Sie können die neuen Ebenen jedoch umbenennen und ihnen aussagekräftigere Namen zuweisen, die auf ihren jeweiligen Inhalt schließen lassen.

  1. Führen Sie einen der folgenden Schritte aus:
    • Doppelklicken Sie auf den Namen einer Ebene oder eines Ordners in der Zeitleiste und geben Sie einen neuen Namen ein.

    • Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Macintosh) auf den Namen der Ebene oder des Ordners und wählen Sie im Kontextmenü die Option „Eigenschaften“ aus. Tragen Sie den neuen Namen in das Feld „Name“ ein und klicken Sie auf „OK“.

    • Klicken Sie in der Zeitleiste auf die Ebene oder den Ordner und wählen Sie Modifizieren > Zeitleiste > Ebeneneigenschaften. Tragen Sie den neuen Namen in das Feld Name ein und klicken Sie auf OK.

Auswählen von Ebenen oder Ordnern

  1. Führen Sie einen der folgenden Schritte aus:
    • Klicken Sie in der Zeitleiste auf den Namen der gewünschten Ebene oder des gewünschten Ordners.

    • Klicken Sie auf ein Bild in der Zeitleistenzeile der Ebene, die Sie auswählen möchten.

    • Klicken Sie auf der Bühne auf ein Objekt, das sich auf der gewünschten Ebene befindet.

    • Wenn Sie mehrere benachbarte Ebenen oder Ordner in der Zeitleiste auswählen möchten, klicken Sie bei gedrückter Umschalttaste auf die gewünschten Einträge in der Ebenenliste.

    • Wenn die gewünschten Ebenen oder Ordner in der Zeitleiste nicht unmittelbar untereinander aufgeführt sind, halten Sie beim Auswählen der Einträge die Strg-Taste (Windows) bzw. die Befehlstaste (Macintosh) gedrückt.

Kopieren von Bildern aus einer bestimmten Ebene

  1. Wählen Sie einen Bildbereich in einer Ebene aus. Klicken Sie auf den Namen einer Ebene in der Zeitleiste, um die gesamte Ebene auszuwählen.
  2. Wählen Sie Bearbeiten > Zeitleiste > Bilder kopieren.

  3. Klicken Sie auf das Bild, ab dem die kopierten Bilder eingefügt werden sollen, und wählen Sie Bearbeiten > Zeitleiste > Bilder einfügen. Um die exakte Anzahl kopierter Bilder in der Ziel-Zeitleiste durch Einfügen zu ersetzen, verwenden Sie die Option Einfügen und Bilder überschreiben.

    Overwrite_frames_process_1
    Arbeitsablauf zum Einfügen und Überschreiben von Bildern

    A. Wählen Sie Bilder aus, und kopieren Sie sie. B. Klicken Sie mit der rechten Maustaste auf das Bild, ab dem Sie einfügen möchten, und wählen Sie die Option „Einfügen und Bilder überschreiben“ aus. C. Daraufhin wird auf der Zeitleiste die exakt gleiche Anzahl an Bildern mit den neuen Bildern überschrieben. 

Kopieren von Bildern aus einem Ebenenordner

  1. Um den gesamten Ordner auszuwählen, reduzieren Sie den Ordner (klicken Sie auf das Dreieck links neben dem Ordnernamen in der Zeitleiste) und klicken Sie auf den Ordnernamen. 

  2. Wählen Sie Bearbeiten > Zeitleiste > Bilder kopieren.

  3. Wählen Sie Einfügen > Zeitleiste > Ebenenordner, um einen Ordner zu erstellen.

  4. Klicken Sie auf den neuen Ordner und wählen Sie Bearbeiten > Zeitleiste > Bilder einfügen.

Löschen von Ebenen oder Ordnern

  1. Wählen Sie die Ebene oder den Ordner aus, indem Sie in der Zeitleiste auf den Namen oder auf ein Bild der Ebene klicken.
  2. Führen Sie einen der folgenden Schritte aus:
    • Klicken Sie in der Zeitleiste auf die Schaltfläche „Ebene löschen“.

    • Ziehen Sie die Ebene oder den Ordner auf die Schaltfläche „Ebene löschen“.

    • Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Macintosh) auf den Ebenen- oder Ordnernamen und wählen Sie im Kontextmenü den Befehl Ebenen löschen.

    Hinweis:

    Wenn Sie einen Ebenenordner löschen, werden alle in ihm enthaltenen Ebenen sowie deren Inhalte ebenfalls gelöscht.

Sperren von Ebenen oder Ordnern oder Aufheben der Sperre

  • Um eine Ebene oder einen Ordner zu sperren, klicken Sie rechts neben dem Namen auf die Spalte mit dem Schlosssymbol. Klicken Sie erneut auf diese Spalte, um die Sperre der Ebene bzw. des Ordners wieder aufzuheben.

  • Klicken Sie auf das Schlosssymbol, um alle Ebenen und Ordner zu sperren. Klicken Sie erneut auf dieses Symbol, um die Sperre aller Ebenen und Ordner wieder aufzuheben.

  • Halten Sie die linke Maustaste gedrückt und bewegen Sie den Mauszeiger in der mit dem Schlosssymbol gekennzeichneten Spalte über mehrere Zeilen, um die entsprechenden Ebenen oder Ordner zu sperren oder deren Sperre wieder aufzuheben.

  • Um alle anderen Ebenen und Ordner zu sperren, klicken Sie bei gedrückter Alt-Taste (Windows) bzw. bei gedrückter Wahltaste (Macintosh) auf die Spalte mit dem Schlosssymbol. Um alle Ebenen und Ordner zu entsperren, klicken Sie bei gedrückter Alt-Taste (Windows) oder bei gedrückter Wahltaste (Macintosh) erneut auf die Spalte mit dem Schlosssymbol.

Kopieren und Einfügen von Ebenen (nur in CS5.5)

Sie können ganze Ebenen und Ebenenordner in der Zeitleiste kopieren und in dieselbe Zeitleiste oder in andere Zeitleisten einfügen. Jede Art von Ebene kann kopiert werden.

Wenn Sie Ebenen kopieren und einfügen, bleibt die Struktur der Ordner der kopierten Ebenen erhalten.

  1. Wählen Sie in der Zeitleiste eine oder mehrere Ebenen aus, indem Sie auf den Ebenennamen klicken. Um mehrere aufeinander folgende Ebenen auswählen, klicken Sie bei gedrückter Umschalttaste auf die betreffenden Ebenen. Um mehrere nicht aufeinander folgende Ebenen auswählen, klicken Sie bei gedrückter Strg-Taste (Windows) bzw. bei gedrückter Befehlstaste (Macintosh) auf die betreffenden Ebenen.

  2. Wählen Sie Bearbeiten > Zeitleiste > Ebenen kopieren oder Ebenen ausschneiden. Sie können auch per Rechtsklick im Kontextmenü die Option Ebenen kopieren bzw. Ebenen ausschneiden wählen.

  3. Wählen Sie in der Zeitleiste, in die Sie die Ebenen einfügen wollen, die Ebene aus, die direkt unter den neu eingefügten liegen soll.

  4. Wählen Sie Bearbeiten > Zeitleiste > Ebenen einfügen.

Die neuen Ebenen werden in der Zeitleiste über der ausgewählten Ebene angezeigt. Haben Sie einen Ebenenordner ausgewählt, erscheinen die eingefügten Ebenen innerhalb des betreffenden Ordners.

Um eine Ebene in eine Masken- oder Führungsebene einzufügen, müssen Sie erst eine Ebene unter der Masken- oder Führungsebene auswählen und dann die kopierte Ebene einfügen. Eine Masken-, Führungs- oder Ordnerebene kann nicht unter einer Masken- oder Führungsebene eingefügt werden.

Sie können Ebenen auch duplizieren, indem Sie sie auswählen und dann Bearbeiten > Zeitleiste > Ebenen duplizieren wählen. An den Namen der neuen Ebenen wird das Wort „Kopie“ angehängt.

Festlegen von Eigenschaften für mehrere Ebenen

  1. Erstellen Sie in Animate CC eine FLA-Datei oder öffnen Sie eine vorhandene Datei.

  2. Wählen Sie die Ebenen aus, deren Eigenschaften Sie ändern möchten, klicken Sie mit der rechten Maustaste darauf und wählen Sie Eigenschaften.

  3. Ändern Sie im Dialogfeld Ebeneneigenschaften die Eigenschaften.

  4. Klicken Sie auf OK.

Ein- oder Ausblenden von Ebenen oder Ordnern

Die Namen der ausgeblendeten Ebenen und Ordner sind in der Zeitleiste mit einem roten X gekennzeichnet. In den Einstellungen für Veröffentlichungen können Sie angeben, ob ausgeblendete Ebenen beim Veröffentlichen einer SWF-Datei einbezogen werden sollen.

  • Um eine Ebene oder einen Ordner auszublenden, klicken Sie in der Zeitleiste rechts neben der Ebene oder dem Ordner auf die Spalte mit dem Augensymbol. Klicken Sie erneut auf diese Spalte, um die Ebene bzw. den Ordner wieder einzublenden.

  • Klicken Sie auf das Augensymbol, um alle Ebenen und Ordner in der Zeitleiste auszublenden. Klicken Sie erneut auf dieses Symbol, um alle Ebenen und Ordner einzublenden.

  • Um mehrere Ebenen oder Ordner aus- oder einzublenden, halten Sie die linke Maustaste gedrückt und bewegen Sie den Mauszeiger über die Spalte mit dem Augensymbol.

  • Klicken Sie bei gedrückter Alt-Taste (Windows) bzw. Wahltaste (Macintosh) auf die Spalte mit dem Augensymbol, um alle Ebenen und Ordner mit Ausnahme der aktuellen Ebene bzw. des aktuellen Ordners auszublenden. Wiederholen Sie diesen Vorgang, um die ausgeblendeten Ebenen und Ordner wieder einzublenden.

Anzeigen des Inhalts einer Ebene als Konturen

Sie können die Konturen aller Objekte, die zu einer bestimmten Ebene gehören, farbig hervorheben, damit sie sich auf einen Blick ihrer jeweiligen Ebene zuordnen lassen.

  • Klicken Sie in der Zeitleistenzeile einer Ebene auf die mit dem Konturensymbol gekennzeichnete Spalte, um die Konturen aller Objekte auf dieser Ebene hervorzuheben. Klicken Sie erneut auf diese Spalte, um die Hervorhebung der Konturen wieder auszuschalten.

  • Klicken Sie auf das Konturensymbol, um die Konturen der Objekte auf allen Ebenen hervorzuheben. Klicken Sie erneut auf das Konturensymbol, um die Hervorhebung der Konturen wieder auszuschalten.

  • Um Objekte auf allen anderen Ebenen als der aktuellen Ebene als Konturen anzuzeigen, klicken Sie bei gedrückter Alt-Taste (Windows) bzw. Wahltaste (Macintosh) auf die Spalte mit dem Konturensymbol. Wiederholen Sie diesen Vorgang, um die Hervorhebung der Konturen wieder zu deaktivieren.

Hinweis:

Bewegungspfade auf der Ebene können auch die Konturfarbe der Ebene verwenden.

Ändern der Konturfarbe einer Ebene

  1. Führen Sie einen der folgenden Schritte aus:
    • Doppelklicken Sie in der Zeitleiste auf das Symbol der Ebene links neben dem Ebenennamen.

    • Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Macintosh) auf den Ebenennamen und wählen Sie im Kontextmenü die Option Eigenschaften.

    • Klicken Sie in der Zeitleiste auf die Ebene und wählen Sie Modifizieren > Zeitleiste > Ebeneneigenschaften.

  2. Klicken Sie im Dialogfeld Ebeneneigenschaften auf das Feld Konturfarbe, wählen Sie eine neue Farbe aus und klicken Sie auf OK.

Anzeigen von Ebenen und Ebenenordnern

Ein- oder Ausblenden von Ebenen oder Ordnern

Die Namen der ausgeblendeten Ebenen und Ordner sind in der Zeitleiste mit einem roten X gekennzeichnet. In den Einstellungen für Veröffentlichungen können Sie angeben, ob ausgeblendete Ebenen beim Veröffentlichen einer SWF-Datei einbezogen werden sollen.

  • Um eine Ebene oder einen Ordner auszublenden, klicken Sie in der Zeitleiste rechts neben der Ebene oder dem Ordner auf die Spalte mit dem Augensymbol. Klicken Sie erneut auf diese Spalte, um die Ebene bzw. den Ordner wieder einzublenden.

  • Klicken Sie auf das Augensymbol, um alle Ebenen und Ordner in der Zeitleiste auszublenden. Klicken Sie erneut auf dieses Symbol, um alle Ebenen und Ordner einzublenden.

  • Um mehrere Ebenen oder Ordner aus- oder einzublenden, halten Sie die linke Maustaste gedrückt und bewegen Sie den Mauszeiger über die Spalte mit dem Augensymbol.

  • Klicken Sie bei gedrückter Alt-Taste (Windows) bzw. Wahltaste (Macintosh) auf die Spalte mit dem Augensymbol, um alle Ebenen und Ordner mit Ausnahme der aktuellen Ebene bzw. des aktuellen Ordners auszublenden. Wiederholen Sie diesen Vorgang, um die ausgeblendeten Ebenen und Ordner wieder einzublenden.

Anzeigen des Inhalts einer Ebene als Konturen

Sie können die Konturen aller Objekte, die zu einer bestimmten Ebene gehören, farbig hervorheben, damit sie sich auf einen Blick ihrer jeweiligen Ebene zuordnen lassen.

  • Klicken Sie in der Zeitleistenzeile einer Ebene auf die mit dem Konturensymbol gekennzeichnete Spalte, um die Konturen aller Objekte auf dieser Ebene hervorzuheben. Klicken Sie erneut auf diese Spalte, um die Hervorhebung der Konturen wieder auszuschalten.

  • Klicken Sie auf das Konturensymbol, um die Konturen der Objekte auf allen Ebenen hervorzuheben. Klicken Sie erneut auf das Konturensymbol, um die Hervorhebung der Konturen wieder auszuschalten.

  • Um Objekte auf allen anderen Ebenen anzuzeigen, klicken Sie bei gedrückter Alt-Taste (Windows) bzw. Wahltaste (Macintosh) auf die Spalte mit dem Konturensymbol. Wiederholen Sie diesen Vorgang, um die Hervorhebung der Konturen wieder zu deaktivieren.

Ändern der Konturfarbe einer Ebene

  1. Führen Sie einen der folgenden Schritte aus:
    • Doppelklicken Sie in der Zeitleiste auf das Symbol der Ebene links neben dem Ebenennamen.

    • Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Macintosh) auf den Ebenennamen und wählen Sie im Kontextmenü die Option Eigenschaften.

    • Klicken Sie in der Zeitleiste auf die Ebene und wählen Sie Modifizieren > Zeitleiste > Ebeneneigenschaften.

  2. Klicken Sie im Dialogfeld Ebeneneigenschaften auf das Feld Konturfarbe, wählen Sie eine neue Farbe und klicken Sie auf OK.

Hinweis:

Bewegungspfade auf der Ebene können auch die Konturfarbe der Ebene verwenden.

Ebenentransparenz festlegen

  1. Erstellen Sie in Animate CC eine FLA-Datei oder öffnen Sie eine vorhandene.

  2. Klicken Sie bei gedrückter Umschalttaste in der Zeitleiste auf die Spalte mit dem Auge, um die Sichtbarkeit auf transparent einzustellen.

    Hinweis:

    Ein Mausklick bei gedrückter Umschalttaste hat keine Auswirkung auf ausgeblendete Ebenen.

    Ebenentransparenz festlegen
    Ebenentransparenz festlegen
  3. Verwenden Sie eine der folgenden Optionen, um die Ebenentransparenz festzulegen:

    • Klicken Sie mit der rechten Maustaste auf eine Ebene und wählen Sie aus dem Kontextmenü Eigenschaften aus. Wählen Sie im Dialogfeld Ebeneneigenschaften die Option Sichtbarkeit > Transparent.
    • Klicken Sie mit der rechten Maustaste auf eine beliebige Ebene und wählen Sie Andere transparent anzeigen aus.
    Ebeneneigenschaften
    Ebeneneigenschaften
  4. Klicken Sie auf OK.

Hinweis:

Die Ebenentransparenz hat keine Auswirkungen auf ausgeblendete Ebenen. 

Verwenden erweiterter Ebenen

In Animate CC werden im Modus „Erweiterte Ebenen“ alle Ebenen in der Zeitleiste als Symbole veröffentlicht. Mit dem Modus „Erweiterte Ebenen“ haben Sie Zugriff auf die folgenden Funktionen:

Der Modus Erweiterte Ebenen ist standardmäßig aktiviert. Sie können den Modus „Erweiterte Ebenen“ über die Einstellungen Modif. > Dokument aktivieren oder deaktivieren. Klicken Sie nach dem Anwenden der Änderungen auf Als Standard, um die aktuelle Einstellung für die nachfolgenden Dokumente und über mehrere Animate-Sitzungen hinweg beizubehalten. 

Modus „Erweiterte Ebenen“
Modus „Erweiterte Ebenen“

Wenn Sie mithilfe eines Skripts in Animate auf diese Symbole zugreifen, müssen Sie sie mithilfe der Ebene als Objekt aufrufen. Beispiel: Wenn Sie keine erweiterten Ebenen verwenden, können Sie direkt mithilfe eines Skripts wie dem folgenden auf ein Symbol zugreifen:

getchildbyname("symbol1");

Wenn Sie jedoch erweiterte Ebenen verwenden, können Sie nur dann über eine Ebene auf das Symbol zugreifen, wenn Sie ein Skript wie das folgende verwenden:

Layer=getchildbyname("L1");

Layer.getchildbyname("symbol1");

Beispielcode für den Zugriff auf Symbole mithilfe der erweiterten Ebenen für den Dokumenttyp AS3:

Var Layer:MovieClip =MovieClip(getchildbyname("L1"));
Layer.getchildbyname("symbol1");

Beispielcode für den Zugriff auf Symbole mithilfe der erweiterten Ebenen für den Dokumenttyp HTML5 Canvas:

Layer=this.getchildbyname("L1");
Layer.getchildbyname("symbol1");

In der folgenden Abbildung wird gezeigt, wie Sie mit erweiterten Ebenen und ohne erweiterte Ebenen mithilfe eines Skripts auf ein Symbol zugreifen können. 

Illustration dazu, wie Sie mit und ohne erweiterte Ebenen auf ein Symbol zugreifen
Illustration dazu, wie Sie mit und ohne erweiterte Ebenen auf ein Symbol zugreifen

Hinweis:

Die Größe der veröffentlichten Animationsprojekte kann sich erhöhen, wenn Sie erweiterte Ebenen in Animate verwenden. Sollten Probleme beim Zugreifen auf Funktionen für die Kamera oder Ebenentiefe auftreten, überprüfen Sie, ob der Modus „Erweiterte Ebenen“ aktiviert ist. Falls er deaktiviert ist, aktivieren Sie ihn, um das erwartete Verhalten hervorzurufen. 

Anwenden von Ebeneneffekten

Filter und Farbeffekte waren bislang nur auf Movieclips anwendbar. Mit erweiterten Ebenen können Sie Filter und Farbeffekte nun auf ausgewählte Bilder anwenden, die dann wiederum für alle zugehörigen Inhalte gelten, einschließlich Formen, Zeichenobjekten, Grafiksymbolen usw. Ebeneneffekte können zudem über klassische, Form- und IK-Tweens bildübergreifend getweent werden.

Sie können Ebeneneffekte auf einzelne oder mehrere Bilder anwenden, indem Sie die gewünschten Bilder auswählen. Sie können Ebeneneffekte auch auf alle Bilder der Ebene anwenden, indem Sie die gesamte Ebene auswählen. Ebeneneffekte können auch auf die Zeitleiste des Symbols angewendet werden, z. B. Movieclips und Grafiksymbole, sowie über alle Szenen hinweg.

Hinweis:

Ebeneneffekte können nur angewendet werden, wenn der Modus „Erweiterte Ebenen“ aktiviert ist. Sie müssen den Modus „Erweiterte Ebenen“ ggf. ausdrücklich für Dateien aktivieren, um diese Funktion verwenden zu können.

Verwenden von Filtern für Bilder

Um Filter auf einem bestimmten Bild hinzuzufügen, wählen Sie zunächst das Bild aus. Das Bedienfeld „Eigenschafteninspektor“ lädt die bildspezifischen Eigenschaften. Klicken Sie auf das Symbol + in der Dropdownliste Filter

Bildfilter
Bildfilter

Wenn Sie Filter auf Bildern hinzufügen, wird der Eigenschafteninspektor angezeigt (siehe Screenshot unten). 

Sie können die Eigenschaften für jeden Filter nach Bedarf einstellen und diese auf Bildebene anwenden. Tweening ist bei allen Bildfiltern anwendbar. 

Bildfiltereigenschaften im Eigenschafteninspektor
Bildfiltereigenschaften im Eigenschafteninspektor

Hinweis:

Ebeneneffekte werden nur beim Dokumenttyp ActionScript 3 unterstützt. Bewegungs-Tween- und Kameraebenen unterstützen keine Ebeneneffekte. 

Verwenden von Farbeffekten

Um Farbeffekte auf einem bestimmten Bild hinzuzufügen, wählen Sie zunächst das Bild aus. Das Bedienfeld „Eigenschafteninspektor“ lädt die bildspezifischen Eigenschaften. Wählen Sie eine gewünschte Farbeigenschaft aus dem Bedienfeld „Eigenschafteninspektor“.

Farbeffekte
Farbeffekte

Anwenden von Ebenentiefe

Als Animator können Sie die Ebenen in verschiedenen Schichten der 2D-Animation platzieren und so die Illusion von Tiefe kreieren. 

Sie können die Tiefe von Ebenen mithilfe des Bedienfelds Ebenentiefe dynamisch ändern. Um das Bedienfeld „Ebenentiefe“ zu öffnen, klicken Sie auf Fenster > Ebenentiefe.

Ebenentiefe der einzelnen Ebene
Ebenentiefe der einzelnen Ebene

Hinweis:

Sie können die Minimal- und Maximalwerte der Ebenentiefe auf einen Bereich zwischen -5000 und 10000 einstellen.

Wie im obigen Screenshot gezeigt, werden die Werte für die Ebenentiefe neben dem jeweiligen Ebenennamen für ein Bild angezeigt.

  • Verschieben Sie den Mauszeiger auf die einzelnen Werte, klicken Sie und ziehen Sie den Schieberegler nach rechts oder links.
  • Um die Tiefe zur reduzieren, ziehen Sie den Regler nach links. Um die Tiefe zur erhöhen, ziehen Sie den Regler nach rechts. 
  • Sie können niedrige positive Werte zur Darstellung näher gelegener Objekte und hohe positive Werte zur Darstellung weit entfernter Objekte verwenden.

Sie können in einer beliebigen Tween-Spanne Tweens von Ebenentiefenwerten für die Animation erstellen: 

Jede Ebene wird mit eindeutigen farbigen Linien im Bedienfeld „Ebenentiefe“ dargestellt. Sie können die Farben für die einzelnen Ebenen in der Zeitleiste anzeigen. 

Darüber hinaus können Sie die Tiefe von Objekten in den einzelnen Ebenen erhöhen oder reduzieren, indem Sie die mehrfarbigen Linien nach oben oder unten verschieben.

  • Um die Tiefe der Objekte in einer Ebene zu reduzieren, klicken und ziehen Sie die Linie nach oben.
  • Um die Tiefe der Objekte in einer Ebene zu erhöhen, klicken und ziehen Sie die Linie nach unten.

Abbildung der Illustration von Animationen mit und ohne Ebenentiefe:

Inhalt ohne Ebenentiefe
Inhalt ohne Ebenentiefe
Inhalt mit Ebenentiefe
Inhalt mit Ebenentiefe

Abbildung der Illustration einer Animation mit angewendeter Ebenentiefe:

Sie können die Kamera auf mehreren Ebenen verwenden, um einen Parallaxeffekt zu erzeugen oder den Inhalt auf einer Ebene zu vergrößern. Sie können die Kamera auf einer bestimmten Ebene auch sperren oder Kameraeffekte zur Laufzeit mithilfe von interaktiven APIs anwenden. Weitere Informationen finden Sie unter Erzeugen von Parallaxeffekten mit Kamera und Ebenentiefe.

Hinweis:

Die Ebenentiefe ist nur auf die Hauptzeitleiste anwendbar.

Beibehalten der Größe bei der Ebenentiefe

Sie können die Ebenentiefe von Objekten ändern, ohne die Größe und die Position von Objekten zu beeinflussen. Um die Funktion zur Beibehaltung der Größe zu verwenden, klicken Sie oben rechts im Bedienfeld Ebenentiefe auf Größe beibehalten.

Sie können die Option zur Beibehaltung der Größe auf zwei Arten nutzen:

  • Klicken Sie auf die Schaltfläche Größe beibehalten und passen Sie die Ebenentiefe der gewünschten Ebene an. Die Schaltfläche Größe beibehalten verändert sich automatisch.
  • Halten Sie die Alt-Taste gedrückt, um die Option Größe beibehalten vorübergehend zu aktivieren, während Sie die Werte für die Ebenentiefe ziehen.
Beibehalten der Größe bei der Ebenentiefe
Beibehalten der Größe bei der Ebenentiefe

Anwenden der Ebenentiefe zur Laufzeit

Sie können zur Laufzeit auch die Kamera auf Objekte richten und mithilfe der Kamera-APIs Effekte anwenden. Weitere Informationen finden Sie unter Verwenden der interaktiven Kamera zur Laufzeit.

Ebenentiefe-API für AS3

Sie können die Ebenen mithilfe von APIs zur Laufzeit verwalten, zum Beispiel eine zusätzliche Ebene in die Animation einfügen oder die Tiefe einer der Animationsebenen verringern. 

Methode Prototyp Beispiel Beschreibung
setLayerZDepth fl.Layer.setLayerZDepth(timeline,
layerName,zDepth)
fl.Layer.setLayerZDepth("layerName", 100); Legt den Z-Tiefenwert einer bestimmten Ebene fest.
getLayerZDepth fl.Layer.getLayerZDepth(layerName) : zDepth fl.Layer.getLayerZDepth("layerName"); Gibt den Z-Tiefenwert einer bestimmten Ebene zurück.
addNewLayer fl.Layer.addNewLayer(layerName,
zDepth=0)
fl.Layer.addNewLayer("layerName",-80); Fügt der Zeitleiste eine neue Ebene hinzu und legt die Z-Tiefe fest.
removeLayer fl.Layer.removeLayer(layerName) fl.Layer.removeLayer("layerName"); Entfernt eine bestimmte Ebene aus der Zeitleiste.

Ebenentiefe-API für HTML Canvas

Methode Prototyp Beispiel Beschreibung
setLayerZDepth AdobeAn.Layer.setLayerZDepth(layerName,
zDepth)
console.log(fl.Layer.setLayerZDepth
("layerName", 100));
Legt den Z-Tiefenwert einer bestimmten Ebene fest.
getLayerZDepth AdobeAn.Layer.getLayerZDepth(layerName)
:zDepth
console.log(fl.Layer.getLayerZDepth
("layerName"));
Gibt den Z-Tiefenwert einer bestimmten Ebene zurück.

Überordnen von Ebenen

Animate ermöglicht es Ihnen, eine Ebene einer anderen überzuordnen. Durch das Überordnen von Ebenen lässt sich ohne großen Aufwand mit einer Ebene/einem Objekt Ihrer Animation eine andere Ebene/ein anderes Objekt steuern. Als Animations- oder Spieledesigner können Sie den Zeitaufwand für Ihre Animationen verringern, da Sie die Bewegungen verschiedener Teile einer Figur leichter steuern können.

Um die Ansicht zum Überordnen von Ebenen verwenden zu können, müssen Sie die Option Erweiterte Ebenen aktivieren. Für neue Dateien ist die Option Erweiterte Ebenen standardmäßig aktiviert. Sie können die Ansicht zum Überordnen von Ebenen aktivieren, indem Sie auf das Hierarchiesymbol rechts oben in der Zeitleiste klicken.

Überordnen von Ebenen anzeigen
Überordnen von Ebenen anzeigen

Hinweis:

Das Überordnen von verzerrten Objekten funktioniert nur, wenn sich der Transformationspunkt des Objekts der untergeordneten Ebene auf dem Objekt der übergeordneten Ebene befindet.

Über- und untergeordnete Ebenen

Wenn Sie in der Ansicht zum Überordnen von Ebenen die Ebene 1 in die Ebene 2 ziehen, wird die Ebene 1 zum untergeordneten Element der übergeordneten Ebene 2. Das Objekt auf der untergeordneten Ebene erbt die Position und Drehung des Objekts auf der übergeordneten Ebene, es dann zusätzlich zu seinen eigenen Eigenschaften aufweist. Wenn Sie also das übergeordnete Element verschieben oder drehen, wird das untergeordnete Element wie das übergeordnete Element verschoben oder gedreht. Sie können mehrere Beziehungen mit über- und untergeordneten Ebenen festlegen, um eine Hierarchie zu erstellen.

Hierarchisches Anordnen von Ebenen

Sie können eine Ebene mit einer anderen verbinden, indem Sie auf den Ebenengriffpunkt (farbige Kennzeichnung) klicken und ihn auf die andere Ebene ziehen. Alternativ dazu können Sie auf eine beliebige Stelle im horizontalen rechteckigen Bereich neben dem Ebenennamen klicken und diesen über die andere Ebene ziehen. Sie können auch auf eine beliebige Ebene klicken und die übergeordnete Ebene für diese aus der Popupliste auswählen. 

Sobald Sie auf den Griffpunkt klicken und ziehen, erscheint ausgehend von der farbigen Kennzeichnung für die Ebene eine gepunktete Linie. Wenn Sie die Maustaste loslassen und so die Drag-and-Drop-Aktion beenden, wird eine hierarchische Verbindung zwischen den beiden Ebenen hergestellt.

Übergeordnete Ebene festlegen
Übergeordnete Ebene festlegen

Die ganz links stehende farbige Kennzeichnung in der Ansichtshierarchie steht für das übergeordnete Element. Die Hierarchie wird von links nach rechts erweitert.

Sie können die Verbindung entfernen, indem Sie auf die farbige Kennzeichnung einer Ebene klicken, die gepunktete Linie ziehen und dann loslassen. Alternativ dazu können Sie auf den horizontalen Bereich klicken und dann Übergeordnetes Element entfernen wählen (siehe Screenshot unten). 

Übergeordnetes Element entfernen
Übergeordnetes Element entfernen

Die folgenden Screenshots zeigen die Ansichten der Ebenenhierarchie und -positionen vor und nach dem Überordnen von Ebenen.

Vor und nach dem Überordnen von Ebenen
Vor und nach dem Überordnen von Ebenen

Die folgende Illustration veranschaulicht das Überordnen von Ebenen für menschliche Körperteile.

Beispielillustration von Körperteilen mit Überordnen von Ebenen
Beispielillustration von Körperteilen mit Überordnen von Ebenen

In der obigen Illustration

  • ist „Torso“ das allen Körperteilen übergeordnete Element.
  • „Legs_thigh“ ist das übergeordnete Element verschiedener Teile eines Beins wie „Sneaker“, „Leg_lower“ und „Ankle“.
  • Bei „Head“ handelt es sich um ein untergeordnetes Element des übergeordneten Elements „Neck“. „Torso“ ist das übergeordnete Element von „Neck“. Wenn Sie also den Hals vom Körper wegziehen, bewegt sich der Kopf mit dem Hals mit.

Hinweis:

Das Überordnen ist eine Bildeigenschaft, die Sie für jedes Schlüsselbild auf der untergeordneten Ebene festlegen müssen. In einem Schlüsselbild können Sie die untergeordnete Ebene entfernen oder einer anderen übergeordneten Ebene zuordnen.

Tutorial zum Überordnen von Ebenen

Tutorial zum Überordnen von Ebenen
Erfahren Sie, wie Sie eine Hierarchie mit über- und untergeordneten Ebenen erstellen und Kompositionen ganz einfach bearbeiten.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie