Optimieren von Animate-Dokumenten

Je größer die Dokumentdatei wird, desto länger dauern der Download und die Wiedergabe. Sie können verschiedene Maßnahmen ergreifen, um Ihr Dokument für die Wiedergabe zu optimieren. Beim Veröffentlichen führt Animate bereits einige Optimierungsschritte automatisch an den Dokumenten durch. Vor dem Exportieren können Sie ein Dokument weiter optimieren, indem Sie die Dateigröße mit einer der verfügbaren Methoden reduzieren. Sie können eine SWF-Datei außerdem beim Veröffentlichen komprimieren. Während Sie Änderungen vornehmen, sollten Sie Ihr Dokument testen, indem Sie es auf einer Reihe unterschiedlicher Computer, Betriebssysteme und Internet-Verbindungen ausführen.

Optimieren von Dokumenten

  • Verwenden Sie für jedes Element, das mehrmals angezeigt wird, immer animierte oder sonstige Symbole.

  • Verwenden Sie beim Erstellen von Animationssequenzen soweit wie möglich getweente Animationen. Getweente Animationen benötigen weniger Speicher als eine Reihe von Schlüsselbildern.

  • Benutzen Sie für Animationssequenzen Movieclips statt Grafiksymbole.

  • Begrenzen Sie den sich ändernden Bereich in einem Schlüsselbild und beschränken Sie Animationen auf einen möglichst kleinen Bereich.

  • Vermeiden Sie animierte Bitmapelemente. Verwenden Sie Bitmapbilder als Hintergrund bzw. statische Elemente.

  • Verwenden Sie für Sounds möglichst mp3, das kompakteste unterstützte Dateiformat.

Optimieren von Elementen und Linien

  • Gruppieren Sie Elemente.

  • Stellen Sie Objekte, die sich im Laufe der Animation verändern, auf separate Ebenen, getrennt von den Objekten, die sich nicht ändern.

  • Minimieren Sie mithilfe von „Modifizieren“ > „Form“ > „Optimieren“ die Anzahl der einzelnen Linien, die für Formen verwendet werden.

  • Begrenzen Sie die Anzahl spezieller Linientypen, wie z. B. gestrichelte, gepunktete oder gezackte Linien. Durchgehende Linien erfordern weniger Speicher. Außerdem benötigen mit dem Stiftwerkzeug gezogene Linien weniger Speicherplatz als Pinselstriche.

Optimieren von Text und Schriftarten

  • Begrenzen Sie die Anzahl von Schriftarten und -stilen. Benutzen Sie eingebettete Schriftarten sparsam, da sie die Datei vergrößern.

  • Wählen Sie unter „Schriftarten einbetten“ nur die benötigten Zeichen aus, statt den gesamten Zeichensatz einzubetten.

Optimieren von Farben

  • Erstellen Sie über das Menü „Farbe“ im Eigenschafteninspektor für Symbole zahlreiche verschiedenfarbige Instanzen eines einzelnen Symbols.

  • Gleichen Sie mithilfe des Bedienfelds „Farbe“ („Fenster“ > „Farbe“) die Farbpalette des Dokuments an eine browserspezifische Palette an.

  • Setzen Sie Farbverläufe nur gelegentlich ein. Das Füllen einer Fläche mit einem Farbverlauf belegt ca. 50 Byte mehr Speicherplatz als eine einfarbige Füllung.

  • Benutzen Sie Alpha-Effekte (Transparenz) sparsam, da sie die Wiedergabe verlangsamen können.

Beschleunigen der Dokumentanzeige

Mithilfe der Befehle im Menü „Ansicht“ können Sie die Dokumentanzeige beschleunigen, indem Sie Funktionen zur Verbesserung der Wiedergabequalität deaktivieren, die besonders viel Rechenleistung erfordern und die Dokumentanzeige verlangsamen.

Diese Befehle haben keinerlei Einfluss darauf, wie Animate ein Dokument exportiert. Zum Angeben der Anzeigequalität von Animate-Dokumenten in einem Webbrowser verwenden Sie die Parameter object und embed. Dies kann mithilfe des Befehls „Veröffentlichen“ automatisch vorgenommen werden.

  1. Wählen Sie „Ansicht“ > „Vorschaumodus“ und anschließend eine der folgenden Optionen:

    Konturen

    Wählen Sie diese Option, um die Anzeige der Formen in Ihrer Szene auf ihre Umrisslinien zu beschränken und diese als dünne Linien darzustellen. Auf diese Weise wird die Umformung Ihrer Grafikelemente und somit auch die Darstellung komplexer Szenen beschleunigt.

    Schnell

    Wählen Sie diese Option, um das Anti-Aliasing zu deaktivieren und alle Farben und Linientypen Ihrer Zeichnung anzuzeigen.

    Glätten

    Bei Auswahl dieser Option wird das Anti-Aliasing für Linien, Formen und Bitmaps aktiviert, und sie bewirkt, dass die Kanten der Formen und Linien auf dem Bildschirm geglättet dargestellt werden. Allerdings werden Ihre Grafiken nicht so rasch dargestellt wie bei Auswahl der Option „Schnell“. Am besten funktioniert das Anti-Aliasing in Verbindung mit Grafikkarten, die den 16-Bit- (Tausende von Farben) oder 24-Bit-Farbmodus (Millionen von Farben) unterstützen. Im 16- oder 256-Farben-Modus werden schwarze Linien geglättet, die Farben sehen im Schnellmodus jedoch möglicherweise besser aus.

    Anti-Alias-Text

    Wählen Sie diese Option, um alle Textränder zu glätten. Dieser Vorgang funktioniert am besten mit großen Schriftarten und kann bei großen Textmengen eine geraume Zeit in Anspruch nehmen. Dieser Modus wird beim Arbeiten in Flash am häufigsten verwendet.

    Vollbildmodus

    Bei Auswahl dieser Option wird der gesamte Inhalt auf der Bühne vollständig wiedergegeben. Diese Einstellung kann die Anzeige verlangsamen.

Optimieren von Grafiken und Animationen

Umreißen und planen Sie Ihr Projekt, bevor Sie optimierte und vereinfachte Animationen oder Grafiken erstellen. Legen Sie ein Maximum für Dateigröße und Animationsdauer fest, und prüfen Sie daraufhin wiederholt während des Entwicklungsprozesses.

Beachten Sie die folgenden Richtlinien, um Grafiken und Animationen zu optimieren:

  • Vermeiden Sie Farbverläufe, da viele Farben erforderlich sind und viele Berechnungen ausgeführt werden müssen, wodurch die Wiedergabe schwieriger wird.

  • Aus dem gleichen Grund sollten Sie möglichst wenig Alpha- und Transparenzeinstellungen in einer SWF-Datei verwenden.

    Die Animation von Objekten, die Transparenz enthalten, erfordert viel Prozessorleistung und sollte möglichst wenig verwendet werden. Die Animation von transparenten Grafiken mithilfe von Bitmaps erfordert besonders viel Prozessorleistung und sollte möglichst wenig oder gar nicht verwendet werden.

    Hinweis: PNG ist das am besten für das Importieren in Animate geeignete Bitmapformat. Es ist außerdem das native Dateiformat von Macromedia Fireworks von Adobe. PNG-Dateien enthalten RGB- und Alphadaten für jedes Pixel. Wenn Sie eine Fireworks PNG-Datei in Animate importieren, bleibt ein gewisses Maß zum Bearbeiten der Grafikobjekte in der FLA-Datei erhalten.

  • Komprimieren Sie Bitmaps beim Optimieren nicht zu sehr. Eine Auflösung von 72 dpi ist optimal für das Web. Durch das Komprimieren eines Bitmapbilds wird die Dateigröße reduziert, aber durch ein zu starkes Komprimieren wird die Qualität der Grafik beeinträchtigt. Prüfen Sie, ob das Bild durch die Einstellungen für die JPEG-Qualität im Dialogfeld „Einstellungen für Veröffentlichungen“ nicht zu stark komprimiert wird. In den meisten Fällen ist es besser, ein Bild als Vektorgrafik darzustellen. Durch Vektorgrafiken wird die Dateigröße reduziert, da die Bilder aus Berechnungen anstelle von vielen Pixeln erstellt werden. Begrenzen Sie die Anzahl von Farben, und behalten Sie die Bildqualität bei.

    Hinweis: Vermeiden Sie es nach Möglichkeit, Bitmaps größer als ihre ursprünglichen Abmessungen zu skalieren, da dies die Bildqualität beeinträchtigt und viel Prozessorleistung beansprucht.

  • Stellen Sie die _visible-Eigenschaft auf false ein, statt die _alpha-Stufe in einer SWF-Datei in 0 oder 1 zu ändern. Die Berechnung der _alpha-Stufe einer Instanz auf der Bühne beansprucht viel Prozessorleistung. Wenn Sie die Sichtbarkeit der Instanz deaktivieren, werden weniger CPU-Durchläufe und Speicher benötigt, was zu geschmeidigeren Animationen der SWF-Dateien führen kann. Statt Elemente zu entladen und möglicherweise neu zu laden, sollten Sie die _visible-Eigenschaft auf false setzen, da dies weniger Prozessorleistung beansprucht.

  • Reduzieren Sie die Anzahl der in einer SWF-Datei verwendeten Linien und Punkte. Mit dem Dialogfeld „Kurven optimieren“ („Modifizieren“ > „Form“ > „Optimieren“) können Sie die Anzahl von Vektoren in einer Zeichnung reduzieren. Wählen Sie die Option „Mehrmals durchführen“, um eine stärkere Optimierung zu erzielen. Durch das Optimieren einer Grafik wird die Dateigröße reduziert, aber durch ein zu starkes Komprimieren wird ihre Qualität beeinträchtigt. Durch das Optimieren von Kurven wird die Dateigröße reduziert und die Leistung der SWF-Datei verbessert. Für eine spezialisierte Optimierung von Kurven und Punkten sind Optionen von Drittanbietern erhältlich, mit denen unterschiedliche Ergebnisse erzielt werden können.

 

Es empfiehlt sich daher, den zu animierenden Inhalt mit den verschiedenen Optionen zu testen, um das beste Resultat zu erhalten.

Eine höhere Bildrate, gemessen in Bildern pro Sekunde oder BpS (frames per second), ergibt eine geschmeidige Animation in einer SWF-Datei, kann aber insbesondere auf alten Computern viel Prozessorleistung beanspruchen. Testen Sie Animationen mit verschiedenen Bildraten, um die niedrigste Bildrate zu ermitteln.

Ein Beispiel für ein Animationsskript finden Sie auf der Webseite mit Animate-Beispielen unter www.adobe.com/go/learn_fl_samples_de. Laden Sie die komprimierte Samples-Datei herunter, dekomprimieren Sie sie und wechseln Sie in den Ordner ActionScript2.0/Animation, um auf das Beispiel zuzugreifen.

Bildrate und Leistung von Animationen

Wenn Sie einer Anwendung eine Animation hinzufügen, sollten Sie auch die Bildrate berücksichtigen, die Sie für die FLA-Datei einstellen. Die Bildrate kann die Leistung Ihrer SWF-Datei und des Computers, auf dem sie wiedergegeben wird, beeinflussen. Eine zu hohe Bildrate kann insbesondere bei zahlreichen Elementen oder beim Erstellen von Animationen mit ActionScript zu Prozessorproblemen führen.

Sie müssen jedoch auch die Einstellung der Bildrate berücksichtigen, da sie sich auf die Wiedergabeglätte einer Animation auswirkt. Eine auf 12 Bilder pro Sekunde (BpS) eingestellte Animation im Eigenschafteninspektor spielt beispielsweise in jeder Sekunde 12 Bilder ab. Beträgt die Bildrate des Dokuments 24 BpS, wird die Animation glatter ausgeführt als bei 12 BpS. Bei 24 BpS wird die Animation jedoch wesentlich schneller wiedergegeben als bei 12 BpS, sodass sie (in Sekunden gemessen) kürzer ist. Wenn Sie eine 5 Sekunden lange Animation mit einer höheren Bildrate erstellen müssen, bedeutet dies daher, dass Sie zusätzliche Bilder hinzufügen müssen, um diese 5 Sekunden zu füllen (dies resultiert in einer größeren Animationsdatei). Die Datei einer 5 Sekunden langen Animation mit 24 BpS ist in der Regel größer als die Datei einer 5 Sekunden langen Animation mit 12 BpS.

Hinweis:

Wenn Sie Animationsskripts mit einer onEnterFrame-Ereignisprozedur erstellen, wird die Animation ähnlich wie bei der Erstellung eines Bewegungs-Tweens auf einer Zeitleiste mit der Bildrate des Dokuments ausgeführt. Eine Alternative zur onEnterFrame-Ereignisprozedur ist die setInterval-Funktion (weitere Informationen finden Sie im ActionScript 2.0-Referenzhandbuch). Anstatt sich auf die Bildrate zu verlassen, können Sie in bestimmten Intervallen Funktionen aufrufen. Wie auch bei onEnterFrame gilt, dass die Animation umso mehr Prozessorressourcen benötigt, je häufiger Sie mit setInterval eine Funktion aufrufen.

Wählen Sie die niedrigste Bildrate, mit der die Animation zur Laufzeit glatt wiedergegeben werden kann, um den Prozessor des Endbenutzers zu entlasten. Hohe Bildraten (über 30 bis 40 BpS) führen zu einer hohen Prozessorbelastung, ohne dass das Erscheinungsbild der Animation zur Laufzeit wesentlich verbessert wird.

Wählen Sie so früh wie möglich in der Entwicklungsphase eine Bildrate für die Animation aus. Überprüfen Sie beim Testen der SWF-Datei die Dauer der Animation und die Größe der SWF-Datei. Die Bildrate hat deutliche Auswirkungen auf die Geschwindigkeit der Animation

Filter und Leistung der SWF-Datei

Beim Verwenden einer zu großen Anzahl von Filtern in einer Anwendung entsteht ein hoher Speicherbedarf und die Leistung von Flash Player wird beeinträchtigt. Da ein Movieclip mit Filtern über zwei Bitmaps mit je 32 Bit verfügt, können zahlreiche Bitmaps beträchtlichen Speicherplatz einnehmen. Eine Fehlermeldung informiert Sie daraufhin u. U. über zu wenig Speicher im System. Auf modernen Computer treten Fehlermeldungen über zu wenig Speicher relativ selten aus, solange Sie Filtereffekte nicht zu häufig in einer Anwendung verwenden (und es z. B. auf der Bühne nicht Tausende von Bitmaps gibt).

Sollte tatsächlich ein Fehler über zu wenig Speicher auftreten, geschieht Folgendes:

  • Das Filter-Array wird ignoriert.

  • Der Movieclip wird mit dem regulären Vektorrenderer gezeichnet.

  • Für den Movieclip werden keine Bitmaps zwischengespeichert.

    Wenn ein Fehler über zu wenig Speicher auftritt, wird von einem Movieclip nie versucht, ein Filter-Array oder eine Bitmap-Zwischenspeicherung zu verwenden. Ein weiterer Faktor, der die Playerleistung beeinträchtigt, ist der für jeden angewendeten Filter verwendete quality-Parameter. Bei höheren Werten ist zum Wiedergeben des Effekts eine größere CPU-Nutzung und mehr Speicher erforderlich. Wenn Sie den quality-Parameter dagegen auf einen geringeren Wert setzen, werden weniger Computerressourcen benötigt. Vermeiden Sie eine übermäßig große Anzahl von Filtern und verwenden Sie nach Möglichkeit eine niedrigere quality-Einstellung.

    Hinweis: Wenn ein 100 x 100 Pixel großes Objekt einmal vergrößert wird, beansprucht es den vierfachen Speicher, da es nun 200 x 200 Pixel groß ist. Wenn Sie es zwei weitere Male vergrößern, wird die Form als 800 Pixel mal 800 Pixel großes Objekt gezeichnet, das das 64-fache an Speicher benötigt wie das ursprüngliche 100 Pixel mal 100 Pixel große Objekt. Beim Verwenden von Filtern in einer SWF-Datei empfiehlt es sich, immer die Zoom-Menüoptionen im Kontextmenü der Datei zu deaktivieren.

    Auch bei ungültigen Parametertypen können Fehler auftreten. Für einige Filterparameter gilt ferner ein bestimmter gültiger Bereich. Wenn Sie einen Wert außerhalb des gültigen Bereichs festlegen, wird der Wert in einen Wert innerhalb des gültigen Bereichs geändert. Der quality-Parameter muss beispielsweise für den Standardbetrieb zwischen 1 und 3 liegen und kann nur in einem Bereich zwischen 0 und 15 festgelegt werden. Werte über 15 werden automatisch auf 15 gesetzt.

    Bei einige Konstruktoren gibt es Beschränkungen bei der Länge von Arrays, die als Eingabeparameter erforderlich sind. Wenn ein Convolution- oder ein Farbmatrixfilter mit einem ungültigen Array (das die falsche Größe hat) erstellt wird, schlägt der Konstruktor fehl, und der Filter wird nicht erfolgreich erstellt. Wenn das Filterobjekt dann als Eintrag im Filter-Array eines Movieclips verwendet wird, wird es ignoriert.

    Tipp: Beim Verwenden eines Weichzeichnen-Filters können Werte für „blurX“ und „blurY“, die Zweierpotenzen (also 2, 4, 8, 16, 32 usw.) sind, schneller berechnet werden und führen zu einer Leistungssteigerung zwischen 20 % und 30 %.

Bitmap-Zwischenspeicherung und Leistung der SWF-Datei

Mit der Bitmap-Zwischenspeicherung können Sie die Leistung sich nicht ändernder Movieclips in Ihren Anwendungen verbessern. Wenn Sie die MovieClip.cacheAsBitmap- oder Button.cacheAsBitmap-Eigenschaft auf true setzen, schreibt Flash Player eine interne Bitmap-Darstellung der Movieclip- oder Schaltflächeninstanz in den Zwischenspeicher. Dies erhöht bei Movieclips mit komplexen Vektorgrafiken möglicherweise die Leistung. Alle Vektordaten eines Movieclips, der eine zwischengespeicherte Bitmap besitzt, werden anstelle der Hauptbühne in eine Bitmap gezeichnet.

Hinweis:

Die Bitmap wird in ihrer ursprünglichen Größe auf die Hauptbühne kopiert. Nicht gedrehte Pixel rasten an den nächstgelegenen Pixelgrenzen ein. Die Pixel werden dem übergeordneten Objekt 1 zu 1 zugeordnet. Ändern sich die Grenzen der Bitmap, wird diese nicht gedehnt, sondern neu erstellt.

Ausführliche Informationen zum Zwischenspeichern von Schaltflächen- oder Movieclip-Instanzen finden Sie unter den folgenden Themen:

  • „Movieclips mit ActionScript zwischenspeichern und durchblättern“ im ActionScript 2.0 – Arbeitshandbuch

  • „Movieclip zwischenspeichern“ im ActionScript 2.0 – Arbeitshandbuch

    Die Eigenschaft cacheAsBitmap wird am besten mit Movieclips verwendet, die vorwiegend statischen Inhalt haben und nicht viel skalieren und drehen. Bei solchen Movieclips kann die Verwendung der cacheAsBitmap-Eigenschaft beim Übersetzen des Movieclips (d. h., wenn sich seine x- und y-Position ändern) zu Leistungsverbesserungen führen.

    Wenn Sie das Zwischenspeichern für einen Movieclip aktivieren, wird eine Oberfläche erstellt. Dies bietet unter anderem den Vorteil, dass komplexe Vektoranimationen schneller gerendert werden. Das Zwischenspeichern führt jedoch nicht immer zu einer Leistungssteigerung, sondern kann in manchen Fällen die Leistung sogar beeinträchtigen.

    Die Gesamtleistung der zwischengespeicherten Daten richtet sich nach den folgenden Faktoren: Komplexität der Vektordaten in den Instanzen, Menge der zu ändernden Daten und Einstellung der Eigenschaft „opaqueBackground“. Wenn Sie nur kleine Bereiche ändern, ist der Unterschied bei Verwendung einer Oberfläche im Vergleich mit Vektordaten möglicherweise kaum wahrnehmbar. Testen Sie beide Szenarios, bevor Sie die Anwendung bereitstellen.

Szenarien für die Bitmap-Zwischenspeicherung

Im Folgenden werden einige typische Szenarios aufgelistet, bei denen die Bitmap-Zwischenspeicherung durch das Optimieren von Vektorgrafiken deutliche Vorteile bieten kann.

Komplexe Hintergrundbilder

Eine Anwendung, die ein detailliertes und komplexes Hintergrundbild von Vektordaten enthält. Zur Leistungssteigerung können Sie den Inhalt auswählen, ihn in einem Movieclip speichern und die Eigenschaft „opaqueBackground“ auf „true“ einstellen. Der Hintergrund wird als Bitmap dargestellt und kann schnell neu gezeichnet werden, sodass die Animation schneller abgespielt wird.

Scrollbares Textfeld

Eine Anwendung, die viel Text in einem scrollbaren Textfeld anzeigt. Platzieren Sie das Textfeld in einem Movieclip, den Sie als scrollbar mit scrollbaren Begrenzungen festlegen (die Eigenschaft „scrollRect“). Dies aktiviert schnelles Pixelscrolling für diese Instanz. Wenn ein Benutzer die Movieclip-Instanz scrollt, werden die gescrollten Pixel nach oben verlagert und der neue, freie Bereich und nicht das ganze Textfeld wird erstellt.

Windowing-System

Eine Anwendung mit komplexen, überlappenden Fenstern. Jedes Fenster kann geöffnet oder geschlossen werden (z. B. Webbrowserfenster). Wenn Sie jedes Fenster als Oberfläche markieren (stellen Sie die Eigenschaft „cacheAsBitmap“ auf „true“ ein), wird jedes Fenster isoliert und zwischengespeichert. Benutzer können die Fenster ziehen, sodass sie überlappen, und jedes Fenster muss den Vektorinhalt nicht neu erstellen.

Nicht geeignete Szenarien für die Bitmap-Zwischenspeicherung

Eine fehlerhafte Verwendung der Bitmap-Zwischenspeicherung kann sich nachteilig auf SWF-Dateien auswirken. Bei der Entwicklung einer FLA-Datei, die Oberflächen verwendet, sollten Sie die folgenden Richtlinien beachten:

  • Verwenden Sie nicht zu viele Oberflächen (Movieclips, für die das Zwischenspeichern aktiviert ist). Da jede Oberfläche etwas mehr Arbeitsspeicher belegt als ein regulärer Movieclip, sollten Sie Oberflächen nur aktivieren, um die Leistung beim Rendern zu steigern.

  • Eine zwischengespeicherte Bitmap kann wesentlich mehr Speicher als eine reguläre Movieclip-Instanz belegen. Wenn der Movieclip auf der Bühne beispielsweise eine Größe von 250 x 250 Pixel hat, belegt der zwischengespeicherte Movieclip 250 KB und die reguläre Movieclip-Instanz 1 KB.

  • Vermeiden Sie ein Vergrößern von zwischengespeicherten Oberflächen. Wenn Sie die Bitmap-Zwischenspeicherung zu häufig einsetzen, wird viel Speicher verbraucht (siehe vorherigen Punkt), besonders wenn Sie den Inhalt vergrößern.

  • Verwenden Sie Oberflächen für Movieclip-Instanzen, die im Wesentlichen statisch sind (also keine Animationen enthalten). Sie können die Instanz ziehen oder verschieben, doch der Inhalt der Instanz sollte nicht animiert sein und keine großen Änderungen aufweisen. Wenn Sie beispielsweise eine Instanz drehen oder transformieren, wechselt die Instanz zwischen der Oberfläche und Vektordaten. Dies ist schwer zu verarbeiten und wirkt sich negativ auf die SWF-Datei aus.

  • Bei einer Kombination aus Oberflächen und Vektordaten ist der Verarbeitungsaufwand für Flash Player und oft auch für den Computer höher. Sie sollten die Oberflächen so weit wie möglich gruppieren, zum Beispiel bei der Erstellung von Windowing-Anwendungen.

Arbeiten mit Komponenten in Flash Player

Die Komponentenarchitektur erlaubt es, den Komponenten Funktionen hinzuzufügen, gleichzeitig kann dadurch aber auch die Dateigröße einer Anwendung enorm vergrößert werden. Komponenten übernehmen Funktionen voneinander. Ihr Animate-Dokument wird durch eine Komponente vergrößert, aber nachfolgende Komponenten, die dieselbe Architektur verwenden, vergrößern das Dokument nicht unbedingt. Durch das Hinzufügen von Komponenten zur Bühne wird die Dateigröße erhöht. Ab einem gewissen Punkt flacht die Zunahme aber ab, da Komponenten denselben Klassen angehören und keine neuen Kopien dieser Klassen geladen werden.

Wenn Sie mehrere Komponenten hinzufügen, die keine gemeinsame Architektur verwenden, kann dadurch die Größe der SWF-Datei beträchtlich erhöht werden. Beispielsweise fügt die XMLConnector-Komponente 17 KB zur SWF-Datei, und die TextInput-Komponenten fügen 24 KB zum Dokument hinzu. Mit der ComboBox-Komponente fügen Sie weitere 28 KB hinzu, da sie zu keiner der Architekturen oder vorherigen Komponente gehört. Da die XMLConnector-Komponente die Datenbindung verwendet, fügen die Klassen 6 KB zur SWF-Datei hinzu. Ein Dokument, das all diese Komponenten verwendet, hat also bereits eine Dateigröße von 77 KB, noch bevor Sie etwas anderes zur Datei hinzufügen. Berücksichtigen Sie also unbedingt die Größe der SWF-Datei, wenn Sie dem Dokument neue Komponenten hinzufügen.

Die Komponenten müssen sich in der übergeordneten Bibliothek der SWF-Datei befinden. So müssen in der Bibliothek einer Anwendung Kopien der von ihr verwendeten Komponenten enthalten sein, selbst wenn diese Komponenten nur von untergeordneten, zur Laufzeit geladenen SWF-Dateien benötigt werden. Dies ist notwendig, um die korrekte Funktion der Komponenten sicherzustellen, und erhöht ein wenig die Downloadzeit der übergeordneten SWF-Datei. Die übergeordnete Bibliothek wird jedoch nicht von den SWF-Dateien, die in die übergeordnete SWF-Datei geladen werden, übernommen oder gemeinsam genutzt. Jede untergeordnete SWF-Datei muss mit einer eigenen Kopie derselben Komponente in die Anwendung heruntergeladen werden.

Wenn Sie beabsichtigen, eine rückwärtskompatible SWF-Datei zu veröffentlichen, müssen Sie wissen, welche Komponenten diese Möglichkeit bieten. Die folgende Tabelle enthält Informationen zur Verfügbarkeit von Komponenten in verschiedenen Flash Player-Versionen:

Komponenten

Flash Player bis Version 6 (6.0.65.0)

Flash Player 6 (6.0.65.0)

Flash Player 7 und 8

Flash Player 9

ActionScript 3.0

Nicht unterstützt

Nicht unterstützt

Nicht unterstützt

Unterstützt

ActionScript 2.0

Unterstützt

Unterstützt

Unterstützt

Unterstützt

V2-UI-Komponentensatz

Nicht unterstützt

Unterstützt

Unterstützt

Unterstützt

Medienkomponenten

Nicht unterstützt

Nicht unterstützt

Unterstützt

Unterstützt

Datenkomponenten

Nicht unterstützt

Nicht unterstützt

Unterstützt

Unterstützt

Deaktivieren Sie im Dialogfeld „Einstellungen für Veröffentlichungen“ die Option „Für Flash Player ab Version 6 r65 optimieren“, damit die V2-UI-Komponenten funktionieren.

Optimieren von Komponentenstilen und Leistung

In ActionScript 2.0 gehört der Aufruf von setStyle zu den am meisten Prozessorleistung beanspruchenden Aufrufen in einer Komponentenarchitektur. Der Aufruf von setStyle wird effizient ausgeführt, beansprucht aber aufgrund seiner Implementierung viel Prozessorleistung. Der Aufruf von setStyle ist nicht immer in allen Anwendungen erforderlich, aber wenn Sie ihn verwenden, sollten Sie seine Auswirkung auf die Leistung berücksichtigen.

Um die Leistung zu steigern, können Sie Stile ändern, bevor sie geladen, berechnet und auf die Objekte in der SWF-Datei angewendet werden. Wenn Sie Stile vor dem Laden und der Berechnung ändern, müssen Sie setStyle nicht aufrufen.

Um beim Verwenden von Stilen die Leistung zu verbessern, wird empfohlen, Eigenschaften für die einzelnen Objekte festzulegen, da Objekte instanziiert werden. Wenn Sie Instanzen dynamisch mit der Bühne verknüpfen, stellen Sie Eigenschaften in initObj im Aufruf von createClassObject() ein, wie im folgenden ActionScript-Code gezeigt:

createClassObject(ComponentClass, "myInstance", 0, {styleName:"myStyle", color:0x99CCFF});

Für jede direkt auf der Bühne platzierte Instanz können Sie onClipEvent() oder Unterklassen (empfohlen) verwenden. Informationen zu Unterklassen finden Sie unter „Unterklassen schreiben“ im ActionScript 2.0 – Arbeitshandbuch.

Wenn Sie den Stil Ihrer Komponenten ändern müssen, können Sie mithilfe der Loader-Komponente die Effizienz in der Anwendung verbessern. Um mehrere Stile in verschiedenen Komponenten zu implementieren, müssen Sie jede Komponente in einer separaten SWF-Datei speichern. Wenn Sie Stile in der Loader-Komponente ändern und die SWF-Datei erneut laden, werden die in der SWF-Datei enthaltenen Komponenten neu erstellt. Durch das Neuerstellen der Komponente wird der Stilzwischenspeicher geleert, der Stil der Komponente wird zurückgesetzt und wieder referenziert.

Hinweis:

Um allen Instanzen einer Komponente in Ihrer SWF-Datei einen Stil zuzuweisen, ändern Sie den Stil global mithilfe von _global.styles.ComponentName.

Verwenden von Runtime Shared Libraries

Mithilfe von Runtime Shared Libraries kann manchmal die Downloadzeit verbessert werden. Im Allgemeinen sind diese Bibliotheken erforderlich, wenn es sich um größere Anwendungen handelt oder zahlreiche Anwendungen auf einer Site dieselben Komponenten oder Symbole verwenden. Durch das Externalisieren der allgemeinen Elemente Ihrer SWF-Dateien müssen Klassen nicht wiederholt heruntergeladen werden. Bei der ersten SWF-Datei, die eine Shared Library verwendet, dauert der Download länger, weil sowohl die SWF-Datei als auch die Bibliothek geladen werden. Die Bibliothek wird auf dem Computer des Benutzers zwischengespeichert, und alle folgenden SWF-Dateien verwenden dann diese Bibliothek. Bei großen Anwendungen kann dies zu stark verkürzten Downloadzeiten führen.

Anzeigen von Sonderzeichen

Computerbetriebssysteme arbeiten mit spezifischen, regionalen Codepages. Beispielsweise arbeitet ein Computer in Japan mit einer anderen Codepage als ein Computer in England. Flash Player bis Version 5 verwendete die Codepages, um Text anzuzeigen; Flash Player ab Version 6 verwendet Unicode zur Textanzeige. Da es sich bei Unicode um einen universellen Zeichensatz handelt, der Zeichen für alle Sprachen enthält, ist er zuverlässiger und bietet eine standardisierte Textanzeige. Die meisten aktuellen Anwendungen verwenden Unicode.

Mithilfe von Unicode-Escape-Zeichenstrings können Sie in Flash Player 6 und höheren Versionen Sonderzeichen anzeigen. Es werden jedoch nicht alle Zeichen korrekt angezeigt, wenn der geladene Text nicht UTF-8- oder UTF-16-kodiert (Unicode) ist oder kein Unicode-Escape-String zur Anzeige von Sonderzeichen verwendet wird. Unicode-Codetabellen finden Sie auf der Unicode-Website unter unicode.org. Eine Liste häufig verwendeter Escape-Strings finden Sie in der folgenden Tabelle.

Eine nicht auf Unicode basierte Anwendung verwendet die Codepage des Betriebssystems, um die Zeichen auf einer Seite zu rendern. In diesem Fall bestimmt die Codepage, welches Zeichen angezeigt wird, d. h. die Zeichen werden nur korrekt wiedergegeben, wenn die Codepage des Betriebssystems mit der der Anwendung übereinstimmt. Die Codepage, die bei der Erstellung der SWF-Datei verwendet wurde, muss mit der Codepage auf dem Computer des Benutzers übereinstimmen. Bei Anwendungen, die an ein internationales Publikum gerichtet sind, empfiehlt es sich, Unicode zu verwenden.

Durch Eingabe von System.useCodepage in Ihren Code zwingen Sie die SWF-Datei, die Codepage des Systems anstelle von Unicode zu verwenden.

Gehen Sie nur dann so vor, wenn Text, der nicht Unicode-kodiert ist, von einem externen Standort geladen wird und wenn dieser Text mit derselben Codepage kodiert wurde, die auch vom Computer des Benutzers verwendet wird. Wenn diese beiden Bedingungen erfüllt werden, wird der Text problemlos angezeigt. Andernfalls sollten Sie Unicode und einen Unicode-Escape-String verwenden, um den Text zu formatieren. Um einen Escape-String zu verwenden, fügen Sie im Bild 1 der Zeitleiste den folgenden ActionScript 2.0-Code ein:

this.createTextField("myText_txt", 99, 10, 10, 200, 25); 
myText_txt.text = "this is my text, \u00A9 2004";

Mit diesem ActionScript-Code wird ein Textfeld erstellt und Text in das Textfeld eingegeben, u. a. das Copyright-Symbol (©).

Sie können eine SWF-Datei zwingen, die Codepage des Betriebssystems zu verwenden, die durch die Eigenschaft useCodepage gesteuert wird. Wenn eine SWF-Datei von Animate exportiert wird, wird standardmäßig Unicode-Text exportiert und System.useCodepage wurde auf false gesetzt. Bei der Anzeige von speziellem Text oder von Text auf internationalen Systemen können Probleme auftreten, und dieses Problem kann möglicherweise mit der Codepage des Systems behoben werden. System.useCodePage sollte aber nur als letzter Ausweg verwendet werden.

Um die Codepage des Systems zu verwenden, geben Sie die folgende ActionScript 2.0-Codezeile in Bild 1 der Zeitleiste ein:

System.useCodepage = true;
<< need an AS3 example here as well. See
dev/qa. >>

Hinweis:

Ein Sonderzeichen kann nur angezeigt werden, wenn die auf dem Computer des Benutzers verwendete Schriftart dieses Zeichen enthält. Wenn Sie nicht sicher sind, empfiehlt es sich, das Zeichen oder die Schriftart in die SWF-Datei einzubetten.

Die folgende Tabelle enthält einige häufig verwendete Unicode-Escape-Strings.

Zeichenbeschreibung

Unicode-Escape-String

Gedankenstrich ()

\u2014

eingetragene Marke (®)

\u00AE

Copyright (©)

\u00A9

Marke (™)

\u2122

Euro ()

\u20AC

umgekehrter Schrägstrich (\)

\u005C

Schrägstrich (/)

\u002F

offene geschweifte Klammer ({)

\u007B

geschlossene geschweifte Klammer (})

\u007D

größer als (<)

\u003C

kleiner als (>)

\u003E

Sternchen (*)

\u002A

Testen der Downloadleistung eines Dokuments

Flash Player versucht, der festgelegten Bildrate zu entsprechen; die tatsächliche Bildrate kann sich von Computer zu Computer unterscheiden. Wenn ein Dokument beim Herunterladen ein bestimmtes Bild erreicht, dessen Daten aber noch nicht heruntergeladen sind, wird das Dokument so lange angehalten, bis die Daten zur Verfügung stehen.

Im Bandbreiten-Profiler wird die Downloadleistung grafisch dargestellt. Sie sehen, welche Datenmenge je nach der angegebenen Modemgeschwindigkeit für jedes einzelne Bild gesendet wird.

Hinweis: (Nur Animate CC) Der Bandbreiten-Profiler ist in Animate CC nicht verfügbar. Stattdessen können Sie Adobe Scout mit Animate verwenden. Weitere Informationen finden Sie unter Verwenden von Animate mit Adobe Scout.

Beim Simulieren der Downloadgeschwindigkeit verwendet Animate Schätzwerte, die der typischen Internet-Leistung entsprechen, und nicht die genaue Geschwindigkeit des Modems. Zum Simulieren der Modemgeschwindigkeit 28,8 KB/Sek. wird die tatsächliche Übertragungsrate von Animate beispielsweise auf 2,3 KB/Sek. gesetzt, da dies die typische Leistung des Internets realistischer widerspiegelt. Dabei berechnet der Profiler auch die Komprimierungsunterstützung für SWF-Dateien, die die Dateigröße reduziert und die Streaming-Leistung verbessert.

Wenn externe SWF-, GIF- und XML-Dateien sowie Variablen in einen Player mithilfe von ActionScript-Aufrufen wie loadMovie und getUrl gestreamt werden, entspricht der Datenfluss der für das Streaming festgelegten Rate. Die Streaming-Rate der Haupt-SWF-Datei wird entsprechend der durch weitere Datenanfragen verminderten Bandbreite reduziert. Es empfiehlt sich, das Dokument bei jeder Geschwindigkeit und auf jedem Computer, die bzw. den Sie unterstützen möchten, zu testen. Auf diese Weise lässt sich leichter sicherstellen, dass das Dokument selbst bei langsamen Verbindungen und auf leistungsschwachen Computern zufrieden stellend funktioniert.

Sie können außerdem einen Bericht erstellen, in dem die Bilder aufgelistet sind, die die Wiedergabe verlangsamen, und dann den Inhalt dieser Bilder optimieren oder teilweise löschen.

Wählen Sie „Datei“ > „Einstellungen für Veröffentlichungen“, um die Einstellungen für die mit den Befehlen „Film testen“ und „Szene testen“ erstellte SWF-Datei zu ändern.

Testen der Downloadleistung

  1. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie „Steuerung“ > „Szene testen“ oder „Steuerung“ > „Testen“.

      Zum Testen einer Szene oder eines Dokuments veröffentlicht Animate die aktuelle Auswahl als SWF-Datei anhand der Einstellungen im Dialogfeld „Einstellungen für Veröffentlichungen“. Die SWF-Datei wird in einem neuen Fenster geöffnet und sofort wiedergegeben.

    • Wählen Sie „Datei“ > „Öffnen“ und wählen Sie eine SWF-Datei aus.

  2. Wählen Sie „Ansicht“ > „Download-Einstellungen“ und wählen Sie eine Downloadgeschwindigkeit, um die von Animate simulierte Streaming-Geschwindigkeit festzulegen: Wählen Sie „Anpassen“, um eine benutzerdefinierte Einstellung einzugeben.

  3. Wählen Sie bei angezeigter SWF-Datei den Befehl „Ansicht“ > „Bandbreiten-Profiler“, um die Downloadleistung grafisch darzustellen.

    Auf der linken Seite des Profilers sehen Sie Informationen zum Dokument, seinen Einstellungen, seinem Zustand und den Streams, falls das Dokument Streams enthält.

    Rechts im Profiler werden die Kopfzeile der Zeitleiste sowie eine Grafik angezeigt. In dieser Grafik ist jedes Bild im Dokument durch einen Balken dargestellt. Die Größe eines Balkens entspricht der Bildgröße in Byte. Die rote Linie unter der Kopfzeile der Zeitleiste gibt an, ob ein Bild bei der im Menü „Steuerung“ ausgewählten Modemgeschwindigkeit in Echtzeit gestreamt wird. Wenn ein Balken über die rote Linie hinausreicht, wird das Dokument angehalten, bis das Bild geladen ist.

    Hinweis: (Nur Animate CC) Der Bandbreiten-Profiler ist in Animate CC nicht verfügbar. Stattdessen können Sie Adobe Scout mit Animate verwenden. Weitere Informationen finden Sie unter Verwenden von Animate mit Adobe Scout.

     

  4. Wählen Sie „Ansicht“ > „Download simulieren“, um das Streaming zu aktivieren bzw. zu deaktivieren.

    Wenn Sie das Streaming deaktivieren, wird das Dokument neu gestartet, ohne eine Webverbindung zu simulieren.

    Hinweis: (Nur Animate CC) Die Option „Download simulieren“ ist in Animate CC nicht verfügbar.

     

  5. Klicken Sie auf einen Balken in der Grafik, um die Einstellungen des zugehörigen Bilds im linken Fenster anzuzeigen und das Dokument anzuhalten.
  6. Passen Sie die Anzeige der Grafik bei Bedarf wie folgt an:
    • Wählen Sie „Ansicht“ > „Streaming-Grafik“, um anzuzeigen, welche Bilder Verzögerungen verursachen.

      In dieser Standardansicht erscheinen für die einzelnen Bilder abwechselnd hell- und dunkelgraue Balken. Die Länge jedes Balkens entspricht der relativen Größe in Byte. Das erste Bild enthält Symbolinhalte und ist deshalb häufig größer als andere Bilder.

    • Wählen Sie „Ansicht“ > „Bild-für-Bild-Grafik“, um die Größe jedes Bilds anzuzeigen.

      In dieser Ansicht können Sie gut erkennen, welche Bilder Verzögerungen verursachen. Wenn ein Balken die rote Linie in der Grafik überschreitet, stoppt der Flash Player die Wiedergabe, bis das gesamte Bild übertragen wurde.

  7. Schließen Sie das Testfenster, um zur Authoring-Umgebung zurückzukehren.

    Nachdem Sie eine Testumgebung mit dem Bandbreiten-Profiler eingerichtet haben, können Sie jede SWF-Datei direkt in der Testumgebung öffnen. Die Datei wird in einem Flash Player-Fenster geöffnet, und Sie sehen den Bandbreiten-Profiler und alle anderen ausgewählten Ansichtsoptionen.

    Hinweis: (Nur Animate CC) Der Bandbreiten-Profiler ist in Animate CC nicht verfügbar. Stattdessen können Sie Adobe Scout mit Animate verwenden. Weitere Informationen finden Sie unter Verwenden von Animate mit Adobe Scout.

     

Erstellen eines abschließenden Berichts

  1. Wählen Sie „Datei“ > „Einstellungen für Veröffentlichungen“ und klicken Sie auf die Registerkarte „Animate“.

  2. Wählen Sie „Größenbericht erstellen“.
  3. Klicken Sie auf „Veröffentlichen“.

    Animate erstellt eine Textdatei mit der Erweiterung .txt. (Wenn es sich bei der Dokumentdatei um „myMovie.fla“ handelt, handelt es sich bei der Textdatei um „myMovie Report.txt“.) Der Bericht enthält die Größe jedes Bilds, jeder Form, jedes Texts, jedes Sounds und ActionScripts für jedes Bild.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie