Guide d'utilisation Annuler

Modifier, déplacer et copier des images clés

  1. Guide de lʼutilisateur dʼAfter Effects
  2. Versions Beta
    1. Présentation du programme Beta
    2. Accueil After Effects Beta
    3. Fonctionnalités de la version Beta
      1. Panneau Propriétés (Beta)
      2. Calques cache de piste sélectionnables (Bêta)
      3. Codage H.264 natif (Bêta)
  3. Prise en main
    1. Prise en main dʼAfter Effects
    2. Nouveautés dʼAfter Effects
    3. Notes de mise à jour | After Effects
    4. Configuration requise pour After Effects
    5. Raccourcis clavier dans After Effects
    6. Formats de fichier pris en charge | After Effects
    7. Recommandations matérielles
    8. After Effects pour puce Apple
    9. Planification et configuration
    10. Configuration et installation
  4. Espaces de travail
    1. Eléments généraux de lʼinterface utilisateur
    2. Familiarisation avec lʼinterface dʼAfter Effects
    3. Workflows
    4. Espaces de travail, panneaux et visualiseurs
  5. Projets et compositions
    1. Projets
    2. Notions de base relatives aux compositions
    3. Précomposition, imbrication et prérendu
    4. Affichage dʼinformations détaillées sur les performances avec le Profileur de composition
    5. Moteur de rendu de composition CINEMA 4D
  6. Importation de métrage
    1. Préparation et importation dʼimages fixes
    2. Importation à partir dʼAfter Effects et dʼAdobe Premiere Pro
    3. Importation et interprétation vidéo et audio
    4. Préparation et importation de fichiers images 3D
    5. Importation et interprétation de métrages
    6. Utilisation des métrages
    7. Détecter les points de montage à l’aide de la détection de montage de scène
    8. Métadonnées XMP
  7. Texte et images
    1. Texte
      1. Mise en forme des caractères et panneau Caractère
      2. Effets de texte
      3. Création et modification des calques de texte
      4. Mise en forme des paragraphes et panneau Paragraphe
      5. Extrusion de calques de texte et de forme
      6. Animation de texte
      7. Exemples et ressources dʼanimation de texte
      8. Modèles Live Text
    2. Animations graphiques
      1. Utilisation de modèles dʼanimations graphiques dans After Effects
      2. Utilisation des expressions pour créer des listes déroulantes dans les modèles dʼanimations graphiques
      3. Utilisation des propriétés essentielles pour créer des modèles dʼanimations graphiques
      4. Remplacement d’images et de vidéos dans les modèles dʼanimations graphiques et les propriétés essentielles
  8. Dessin, peinture et tracés
    1. Présentation des calques de forme, des tracés et des images vectorielles
    2. Outils de peinture : Pinceau, Cloner et Gomme
    3. Effilage des contours de forme
    4. Attributs de forme, opérations de peinture et opérations de tracé pour les calques de forme
    5. Utilisation de lʼeffet de forme Décaler les tracés pour modifier des formes
    6. Création de formes
    7. Création de masques
    8. Suppression dʼobjets de vos vidéos avec le panneau Remplissage dʼaprès le contenu
    9. Roto-pinceau et Améliorer le cache
  9. Calques, marqueurs et caméra
    1. Sélection et disposition de calques
    2. Modes de fusion et styles de calques
    3. Calques 3D
    4. Propriétés du calque
    5. Création de calques
    6. Gestion des calques
    7. Repères de calque et repères de composition
    8. Caméras, lumières et points ciblés
  10. Animation, images clés, suivi de cible et incrustations
    1. Animation
      1. Principes de base de l’animation
      2. Animation avec les outils Marionnette
      3. Gestion et animation de tracés de forme et de masques
      4. Animation de formes Sketch et Capture à lʼaide dʼAfter Effects
      5. Outils dʼanimation divers
      6. Utilisation dʼanimations orientées données
    2. Image clé
      1. Interpolation des images clés
      2. Définition, sélection et suppression dʼimages clés
      3. Modification, déplacement et copie dʼimages clés
    3. Suivi de cible
      1. Suivi et stabilisation du mouvement
      2. Suivi du visage
      3. Suivi de masque
      4. Référence de masque
      5. Vitesse
      6. Extension temporelle et remappage temporel
      7. Code temporel et unités temporelles
    4. Masquage
      1. Incrustations
      2. Effets de masquage
  11. Transparence et montage
    1. Présentation et ressources du montage et de la transparence
    2. Couches alpha et masques
  12. Réglage de la couleur
    1. Principes de base de la couleur
    2. Gestion des couleurs
    3. Effets de correction colorimétrique
  13. Effets et animations prédéfinies
    1. Présentation des effets et animations prédéfinies
    2. Liste dʼeffets
    3. Effets de simulation
    4. Effets esthétiques
    5. Effets audio
    6. Effets de déformation
    7. Effets de perspective
    8. Effets de couches
    9. Effets de rendu
    10. Effets de transition
    11. Effet Réparation dʼobturateur déroulant
    12. Effets de flou et de netteté
    13. Effets de couches 3D
    14. Effets Utilité
    15. Effets de cache
    16. Effets de bruit et de grain
    17. Effet Conservation des détails-Amélioration
    18. Effets obsolètes
  14. Expressions et automatisation
    1. Expression
      1. Principes de base des expressions
      2. Compréhension du langage dʼexpression
      3. Utilisation des options pour expressions
      4. Différences de syntaxe entre le moteur dʼexpressions JavaScript et lʼancien moteur dʼexpressions ExtendScript
      5. Modification des expressions
      6. Erreurs dans les expressions
      7. Utilisation de lʼéditeur dʼexpressions
      8. Utilisation d’expressions pour accéder aux propriétés du texte et les modifier
      9. Référence au langage dʼexpression
      10. Exemples dʼexpressions
    2. Automatisation
      1. Automatisation
      2. Scripts
  15. Vidéo immersive, VR et 3D
    1. Création dʼenvironnements VR dans After Effects
    2. Application d’effets de vidéo immersive
    3. Outils de composition pour les vidéos VR/360
    4. Suivi du mouvement de la caméra 3D
    5. Utilisation de lʼespace de conception 3D
    6. Widgets de transformation 3D
    7. En faire plus avec l’animation 3D
    8. Aperçu des modifications apportées aux conceptions 3D en temps réel avec le moteur en temps réel
    9. Ajout de Responsive Design à vos images
  16. Vues et prévisualisations
    1. Prévisualisation
    2. Prévisualisation vidéo à lʼaide de Mercury Transmit
    3. Modification et utilisation des vues
  17. Rendu et exportation
    1. Notions de base relatives au rendu et à lʼexportation
    2. Exportation dʼun projet After Effects en tant que projet Adobe Premiere Pro
    3. Conversion de films
    4. Rendu multi-images
    5. Rendu automatisé et rendu en réseau
    6. Rendu et exportation dʼimages fixes et de séquences dʼimages fixes
    7. Utilisation du codec GoPro CineForm dans After Effects
  18. Utilisation dʼautres applications
    1. Dynamic Link et After Effects
    2. Utilisation dʼAfter Effects et dʼautres applications
    3. Synchronisation des paramètres dans After Effects
    4. Bibliothèques Creative Cloud dans After Effects
    5. Plug-ins
    6. CINEMA 4D et Cineware
  19. Collaboration : Frame.io et Projets d’équipe
    1. Collaboration dans Premiere Pro et After Effects
    2. Frame.io
      1. Installer et activer Frame.io
      2. Utiliser Frame.io avec Premiere Pro et After Effects
      3. Foire aux questions
    3. Projets dʼéquipe
      1. Prise en main des projets d’équipe
      2. Créer un projet d’équipe
      3. Collaborer sur les projets d’équipe
  20. Mémoire, stockage et performances
    1. Mémoire et stockage
    2. Comment After Effects gère les problèmes de mémoire insuffisante lors de la prévisualisation    
    3. Amélioration des performances
    4. Préférences
    5. Configuration requise du GPU et du pilote GPU pour After Effects

Affichage et modification de la valeur d’une image clé

Avant de modifier une image clé, assurez-vous que le repère d’instant courant se trouve sur une image clé existante. Sinon, After Effects ajoute une nouvelle image clé lorsque vous modifiez la valeur d’une propriété. Toutefois, lorsque vous cliquez deux fois sur une image clé pour la modifier ou lorsque vous modifiez sa méthode d’interpolation, la position du repère d’instant courant n’a pas d’importance.

  • Déplacez le repère d’instant courant sur l’instant de l’image clé. Vous pouvez modifier la valeur de la propriété qui s’affiche en regard du nom.
  • Cliquez sur l’image clé à l’aide du bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Mac OS). La valeur de l’image clé apparaît en haut du menu contextuel qui s’affiche. Choisissez Modifier la valeur, si nécessaire.
  • Placez le pointeur sur une image clé en mode d’affichage des bandes de durée des calques pour voir l’heure et la valeur de l’image clé.
  • Placez le pointeur sur une image clé en mode Éditeur de graphiques afin d’afficher le nom de calque, le nom de propriété, l’heure et la valeur de l’image clé. Placez le pointeur sur un segment situé entre des images clés pour afficher les informations correspondantes à tout moment.
  • Cliquez sur une image clé dans le mode Barre du calque pour afficher l’heure et la méthode d’interpolation de cette image dans le panneau Info.
  • Cliquez sur une image clé ou un segment entre des images clés en mode Éditeur de graphiques pour afficher les valeurs maximale et minimale d’une propriété, ainsi que la valeur au niveau de l’instant présent dans le panneau Info.
  • En maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée, cliquez sur deux images clés en mode Barre du calque pour afficher la durée qui les sépare dans le panneau Info.

Sur son site web redefinery, Jeff Almasol propose un script qui crée des repères de calque (soit sur le calque sélectionné, soit sur un nouveau calque nul) accompagnés de commentaires informatifs sur les images clés situées aux mêmes instants.

Copier et coller des images clés

Vous pouvez copier les images clés d’un seul calque à la fois. Lorsque vous collez des images clés dans un autre calque, elles s’affichent dans la propriété correspondante dans le calque de destination. La première image clé s’affiche à l’instant courant et les autres images clés suivent dans un ordre relatif. Une fois collées, les images clés restent sélectionnées, pour vous permettre de les déplacer immédiatement dans le calque de destination.

Vous pouvez copier des images clés d’un calque à un autre pour une même propriété (par exemple, Position) ou entre deux propriétés qui utilisent le même type de données (entre la position et le point d’ancrage, par exemple).

Remarque :

lorsque vous effectuez un copier-coller entre des propriétés similaires, vous pouvez utiliser plusieurs propriétés source et destination. En revanche, lorsque l’opération concerne des propriétés différentes, elle doit s’effectuer depuis et vers une seule propriété à la fois.

  1. Dans le panneau Montage, affichez la propriété de calque contenant les images clés que vous voulez copier.
  2. Sélectionnez une ou plusieurs images clés.
  3. Choisissez Edition > Copier.
  4. Dans le panneau Montage contenant le calque de destination, déplacez le repère d’instant courant à l’endroit où les images clés doivent s’afficher.
  5. Effectuez l’une des opérations suivantes :
    • Pour coller les images clés dans la même propriété que celles des images clés copiées, sélectionnez le calque de destination.

    • Pour les coller dans une autre propriété, sélectionnez la propriété de destination.

  6. Choisissez Édition > Coller.

Éditer les valeurs d’images clés à l’aide d’un tableur ou d’un éditeur de texte

Vous pouvez copier et coller les données des images clés sous la forme d’un texte délimité par des tabulations pour être utilisées dans un tableur (comme Microsoft Excel) ou tout autre programme d’édition de texte. Vous pouvez utiliser un tableur pour effectuer une analyse numérique sur des données d’images clés, ou créer ou modifier des valeurs d’images clés.

Vous pouvez copier et coller la plupart des propriétés, y compris les propriétés de transformation (comme la position et l’opacité), les propriétés des options de surface et le suivi des mouvements.

Remarque :

Vous pouvez appliquer les outils de suivi des mouvements aux objets d’un calque, puis coller les données de suivi dans une feuille de calcul pour effectuer une analyse numérique des données.

Certains utilitaires, tels que Imagineer Systems Mocha pour After Effects (Mocha AE), copient les données d’images clés dans le Presse-papiers afin de pouvoir les coller dans le calque approprié dans After Effects.

Vous pouvez copier les images clés d’un seul calque à la fois sous la forme d’un texte délimité par des tabulations.

  1. Dans le panneau Montage, sélectionnez des images clés pour une ou plusieurs propriétés sur le même calque. Pour sélectionner toutes les images clés d’une propriété, cliquez sur le nom de la propriété.
  2. Déplacez le repère d’instant courant sur la première image clé sélectionnée.
    Remarque :

    Placez un repère de composition au niveau de la première image clé sélectionnée, de manière à savoir où coller les images clés modifiées au cours de la dernière étape. (consultez la section Repères de calque et repères de composition).

  3. Une fois les images clés sélectionnées, cliquez sur Edition > Copier.
  4. Collez les données de l’image clé dans la feuille de calcul. Si la première colonne de la feuille de calcul est nommée A et la première ligne 1, vous devez coller les données dans la cellule A1. Le nombre d’images s’affiche dans la colonne B. Les valeurs de propriété s’affichent dans les colonnes C, D et E, en fonction des dimensions de la propriété (la propriété Position dans un calque 3D possède des valeurs dans les trois colonnes ; la propriété Opacité ne possède qu’une seule valeur dans la colonne C).
  5. Modifiez les informations numériques des images clés. Ne modifiez aucun texte autre que le nombre d’images et les valeurs de propriété.
  6. Sélectionnez les cellules qui contiennent les données. La cellule en haut à gauche de la sélection doit être A1. La ligne du bas de la sélection doit être la ligne qui contient le texte Fin des données d’image clé.

  7. Copiez les données de la feuille de calcul.
  8. Dans After Effects, déplacez le repère d’instant courant à l’endroit où vous souhaitez coller les données de l’image clé suivante. Cet instant est généralement l’instant de la première image clé que vous avez sélectionnée et copiée au début de cette procédure.
  9. Choisissez Edition > Coller.

Déplacement d’images clés dans le temps

Vous pouvez déplacer des images clés dans le temps, individuellement ou par groupe.

Jeff Almasol propose, sur son site web redefinery, un script polyvalent qui crée un panneau dont les commandes permettent de déplacer dans le temps des combinaisons variées d’éléments (point d’entrée ou de sortie d’un calque, images sources d’un calque, images clés et repères).

Déplacer des images clés vers un autre point temporel

Vous pouvez copier ou supprimer simultanément plusieurs images clés sélectionnées, ou les déplacer globalement sans modifier leur position relative.

  1. Sélectionnez une ou plusieurs images clés.
  2. Faites glisser une des icônes des images clés sélectionnées vers le point approprié dans le temps. Si vous avez sélectionné plusieurs images clés, toutes les autres images clés sélectionnées conservent la même distance par rapport à l’image clé déplacée.
Remarque :

Vous pouvez également déplacer les images clés sélectionnées dans le temps (une image plus tôt ou plus tard) en appuyant sur la touche Alt (Windows) ou Option (Mac OS) et sur la touche fléchée gauche ou droite.

Déplacer une image clé vers un point spécifique dans le temps

  1. Déplacez le repère d’instant courant vers le point approprié dans le temps.
  2. Effectuez l’une des opérations suivantes :
    • Lorsque les bandes de durée des calques sont affichées, maintenez la touche Maj enfoncée, tandis que vous commencez à faire glisser une icône d’image clé vers le repère d’instant courant.

    • Lorsque l’éditeur de graphiques est affiché, faites glisser une image clé sur le repère d’instant courant.

    Lorsque l’icône se trouve sur le repère d’instant courant, l’image clé s’aligne sur celui-ci.

Développer ou réduire un groupe d’images clés lorsque les bandes de durée des calques sont affichées

  1. Sélectionnez au moins trois images clés.
  2. Maintenez la touche Alt (Windows) ou Option (Mac OS) enfoncée et faites glisser la première ou la dernière image clé sélectionnée vers le point approprié dans le temps.

Déplacer la bande de durée d’un calque sans ses images clés

  1. Placez un repère de composition au niveau du point où apparaît la première image clé (Consultez la section Repères de composition).
  2. Dans la liste de calques, cliquez sur le nom d’une ou plusieurs propriétés contenant les images clés dont vous souhaitez conserver la position dans le temps.
  3. Sélectionnez Édition > Couper.
  4. Déplacez ou étirez la bande de durée du calque vers ses nouveaux points d’entrée et de sortie.
  5. Déplacez le repère d’instant courant sur le repère de composition, sur l’instant auquel la première image clé apparaissait avant l’opération Couper.
  6. Choisissez Édition > Coller.

Modifier simultanément plusieurs valeurs d’images clés

Vous pouvez modifier la valeur de plusieurs images clés de différents calques en une seule opération ; toutes les images clés sélectionnées doivent néanmoins appartenir à la même propriété de calque. La modification des valeurs sélectionnées varie en fonction de la méthode utilisée :

  • En cas de modification numérique de la valeur, toutes les images clés sélectionnées utilisent exactement la nouvelle valeur. En d’autres termes, il s’agit d’une modification absolue. Par exemple, si vous sélectionnez plusieurs images clés Position sur une trajectoire, puis spécifiez la valeur Position de l’une d’entre elles à l’aide d’une valeur numérique, toutes les images clés sélectionnées adoptent la même valeur de position.

  • Si vous modifiez une valeur soulignée en la déplaçant, toutes les images clés sélectionnées subissent la même modification. En d’autres termes, vous effectuez une modification relative. Par exemple, si vous sélectionnez plusieurs images clés Position sur une trajectoire, puis déplacez la valeur soulignée de l’une d’entre elles, toutes les images clés sélectionnées sont modifiées de la même façon.

  • Si vous modifiez graphiquement une valeur dans le panneau Composition ou Calque, la valeur des images clés sélectionnées change, en fonction de la différence entre les nouvelles et les anciennes valeurs, et non des valeurs proprement dites. En d’autres termes, vous effectuez une modification relative. Par exemple, si vous sélectionnez plusieurs images clés Position sur une trajectoire, puis déplacez l’une d’elles de 10 pixels vers la gauche, toutes les images clés sélectionnées sont déplacées de 10 pixels vers la gauche par rapport à leur position d’origine.

Il est également possible de modifier simultanément la valeur de plusieurs calques lorsque les bandes de durée des calques sont affichées en les apparentant.

Mathias Möhl propose le script KeyTweak (disponible sur la page Extension After Effects) qui vous permet de modifier de nombreuses images clés en même temps sur une propriété. Avec KeyTweak, vous modifiez quelques images clés manuellement et le script se charge de modifier, en conséquence, les images clés intermédiaires. Ce script se révèle particulièrement utile pour les images clés de tracé de masque dans un flux de rotoscopie. (voir la section Présentation de la rotoscopie et ressources associées).

Déplacer ou modifier des images clés dans l’éditeur de graphiques

Un graphique de valeurs dans l’éditeur de graphiques affiche les valeurs de chaque image clé et les valeurs interpolées entre les images clés. Lorsque le graphique de valeurs d’une propriété de calque est régulier, la valeur de cette propriété est stable entre les images clés. Lorsque le graphique de valeurs est irrégulier, la valeur de la propriété de calque augmente ou diminue entre les images clés.

Déplacement ou modification d’images clés dans l’éditeur de graphiques
Graphique de valeurs

A. Image clé. B. Un graphique de valeurs régulier indique des valeurs stables. C. Un graphique ascendant indique des valeurs croissantes. D. Un graphique descendant indique des valeurs décroissantes. 

Vous pouvez modifier les valeurs des propriétés de calque en déplaçant les points (images clés) du graphique de valeurs vers le haut ou vers le bas. Par exemple, vous pouvez accroître la valeur d’une image clé de rotation en faisant glisser son repère sur la valeur de la propriété Rotation plus haut sur le graphique.

Remarque :

les valeurs des propriétés Point d’ancrage, Tracé du masque, Contrôle des points d’effet, Orientation 3D et Position sont des valeurs spatiales et utilisent donc par défaut des graphiques de vitesse et non des graphiques de valeurs.

Modifier une seule image clé dans l’éditeur de graphiques

  1. Dans le panneau Montage, affichez une propriété temporelle d’un calque.
  2. Si nécessaire, cliquez sur le bouton Éditeur de graphiques ou appuyez sur les touches Maj + F3 pour activer ce mode d’affichage.
  3. Au besoin, ajoutez une image clé au point temporel auquel vous souhaitez que le changement se produise.
  4. Faites glisser l’image clé vers le haut ou vers le bas pour définir une nouvelle valeur pour la propriété de calque.

Modifier plusieurs images clés dans l’éditeur de graphiques

Vous pouvez modifier et déplacer simultanément plusieurs images clés en utilisant l’éditeur de graphiques. Lorsque vous sélectionnez plusieurs images clés après avoir activé le bouton Afficher la fenêtre de transformation, un cadre de sélection entoure les images clés sélectionnées et un point d’ancrage s’affiche au centre du cadre. Ce point représente le point d’effet de la transformation en cours. Vous pouvez déplacer les images clés sélectionnées dans le temps ou sur l’échelle de valeurs en faisant glisser le cadre de sélection ou ses poignées. Vous êtes également libre de modifier la position du point d’ancrage.

L’ajustement d’un cadre de sélection de transformation libre dans un graphique de valeurs déplace les images clés sélectionnées dans le temps et sur l’échelle de valeurs. L’ajustement d’un cadre de sélection de transformation libre dans un graphique de vitesse déplace les images clés sélectionnées dans le temps uniquement.

Modification de plusieurs images clés dans l’éditeur de graphiques
Lorsque plusieurs images clés sont sélectionnées dans l’éditeur de graphiques, un cadre de sélection de transformation libre apparaît.

  1. Activez la vue de l’éditeur de graphiques et affichez les images clés que vous souhaitez ajuster.
  2. A l’aide de l’outil Sélection, procédez de l’une des façons suivantes :
    • Pour sélectionner des images clés, cliquez sur ces dernières en maintenant la touche Maj enfoncée ou tracez un cadre de sélection autour des images clés.

    • Pour sélectionner toutes les images clés d’une propriété, cliquez sur un segment entre deux images clés tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée.

  3. Utilisez l’une des méthodes suivantes :
    • Pour déplacer des images clés dans le temps ou sur l’échelle de valeurs, placez le pointeur à l’intérieur du cadre de sélection et faites glisser la souris. Faites glisser la souris en maintenant la touche Maj enfoncée afin de diriger le déplacement horizontalement ou verticalement.

    • Pour déplacer des images clés dans le temps ou sur l’échelle de valeurs en redimensionnant le cadre de sélection, placez le pointeur sur une poignée du cadre de sélection. Lorsque le pointeur prend la forme d’une flèche droite bidirectionnelle , faites glisser la souris pour redimensionner le cadre de sélection. Faites glisser la souris tout en maintenant la touche Maj enfoncée pour conserver le rapport largeur/hauteur. Maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée et faites glisser le point d’ancrage du cadre de sélection pour le dimensionner. Pour faire glisser uniquement cette poignée, appuyez sur la touche Alt (Windows) ou Option (Mac OS).

    Remarque :

    Effectuez une mise à l’échelle avec des valeurs négatives afin d’inverser les images clés dans le temps.

    Pour évaser verticalement les valeurs d’images clés, faites glisser la souris tout en maintenant les touches Ctrl + Alt (Windows) ou Commande + Option (Mac OS) enfoncées. Cette modification des valeurs d’images clés permet de réduire ou d’étendre l’amplitude d’une animation répétée.

    Pour déplacer vers le haut ou vers le bas un côté du cadre de sélection, faites glisser la souris tout en maintenant les touches Ctrl + Alt + Maj (Windows) ou Commande + Option + Maj (Mac OS) enfoncées.

    Pour déplacer le point d’ancrage du cadre de sélection, placez l’outil Sélection au-dessus du point d’ancrage jusqu’à ce qu’il se transforme en outil Déplacement du point d’ancrage , puis faites-le glisser.

Logo Adobe

Accéder à votre compte