Guide d'utilisation Annuler

Rendu automatisé et rendu en réseau

  1. Guide de lʼutilisateur dʼAfter Effects
  2. Versions Beta
    1. Présentation du programme Beta
    2. Accueil After Effects Beta
    3. Fonctionnalités de la version Beta
      1. Panneau Propriétés (Beta)
      2. Calques cache de piste sélectionnables (Bêta)
      3. Codage H.264 natif (Bêta)
  3. Prise en main
    1. Prise en main dʼAfter Effects
    2. Nouveautés dʼAfter Effects
    3. Notes de mise à jour | After Effects
    4. Configuration requise pour After Effects
    5. Raccourcis clavier dans After Effects
    6. Formats de fichier pris en charge | After Effects
    7. Recommandations matérielles
    8. After Effects pour puce Apple
    9. Planification et configuration
    10. Configuration et installation
  4. Espaces de travail
    1. Eléments généraux de lʼinterface utilisateur
    2. Familiarisation avec lʼinterface dʼAfter Effects
    3. Workflows
    4. Espaces de travail, panneaux et visualiseurs
  5. Projets et compositions
    1. Projets
    2. Notions de base relatives aux compositions
    3. Précomposition, imbrication et prérendu
    4. Affichage dʼinformations détaillées sur les performances avec le Profileur de composition
    5. Moteur de rendu de composition CINEMA 4D
  6. Importation de métrage
    1. Préparation et importation dʼimages fixes
    2. Importation à partir dʼAfter Effects et dʼAdobe Premiere Pro
    3. Importation et interprétation vidéo et audio
    4. Préparation et importation de fichiers images 3D
    5. Importation et interprétation de métrages
    6. Utilisation des métrages
    7. Détecter les points de montage à l’aide de la détection de montage de scène
    8. Métadonnées XMP
  7. Texte et images
    1. Texte
      1. Mise en forme des caractères et panneau Caractère
      2. Effets de texte
      3. Création et modification des calques de texte
      4. Mise en forme des paragraphes et panneau Paragraphe
      5. Extrusion de calques de texte et de forme
      6. Animation de texte
      7. Exemples et ressources dʼanimation de texte
      8. Modèles Live Text
    2. Animations graphiques
      1. Utilisation de modèles dʼanimations graphiques dans After Effects
      2. Utilisation des expressions pour créer des listes déroulantes dans les modèles dʼanimations graphiques
      3. Utilisation des propriétés essentielles pour créer des modèles dʼanimations graphiques
      4. Remplacement d’images et de vidéos dans les modèles dʼanimations graphiques et les propriétés essentielles
  8. Dessin, peinture et tracés
    1. Présentation des calques de forme, des tracés et des images vectorielles
    2. Outils de peinture : Pinceau, Cloner et Gomme
    3. Effilage des contours de forme
    4. Attributs de forme, opérations de peinture et opérations de tracé pour les calques de forme
    5. Utilisation de lʼeffet de forme Décaler les tracés pour modifier des formes
    6. Création de formes
    7. Création de masques
    8. Suppression dʼobjets de vos vidéos avec le panneau Remplissage dʼaprès le contenu
    9. Roto-pinceau et Améliorer le cache
  9. Calques, marqueurs et caméra
    1. Sélection et disposition de calques
    2. Modes de fusion et styles de calques
    3. Calques 3D
    4. Propriétés du calque
    5. Création de calques
    6. Gestion des calques
    7. Repères de calque et repères de composition
    8. Caméras, lumières et points ciblés
  10. Animation, images clés, suivi de cible et incrustations
    1. Animation
      1. Principes de base de l’animation
      2. Animation avec les outils Marionnette
      3. Gestion et animation de tracés de forme et de masques
      4. Animation de formes Sketch et Capture à lʼaide dʼAfter Effects
      5. Outils dʼanimation divers
      6. Utilisation dʼanimations orientées données
    2. Image clé
      1. Interpolation des images clés
      2. Définition, sélection et suppression dʼimages clés
      3. Modification, déplacement et copie dʼimages clés
    3. Suivi de cible
      1. Suivi et stabilisation du mouvement
      2. Suivi du visage
      3. Suivi de masque
      4. Référence de masque
      5. Vitesse
      6. Extension temporelle et remappage temporel
      7. Code temporel et unités temporelles
    4. Masquage
      1. Incrustations
      2. Effets de masquage
  11. Transparence et montage
    1. Présentation et ressources du montage et de la transparence
    2. Couches alpha et masques
  12. Réglage de la couleur
    1. Principes de base de la couleur
    2. Gestion des couleurs
    3. Effets de correction colorimétrique
  13. Effets et animations prédéfinies
    1. Présentation des effets et animations prédéfinies
    2. Liste dʼeffets
    3. Effets de simulation
    4. Effets esthétiques
    5. Effets audio
    6. Effets de déformation
    7. Effets de perspective
    8. Effets de couches
    9. Effets de rendu
    10. Effets de transition
    11. Effet Réparation dʼobturateur déroulant
    12. Effets de flou et de netteté
    13. Effets de couches 3D
    14. Effets Utilité
    15. Effets de cache
    16. Effets de bruit et de grain
    17. Effet Conservation des détails-Amélioration
    18. Effets obsolètes
  14. Expressions et automatisation
    1. Expression
      1. Principes de base des expressions
      2. Compréhension du langage dʼexpression
      3. Utilisation des options pour expressions
      4. Différences de syntaxe entre le moteur dʼexpressions JavaScript et lʼancien moteur dʼexpressions ExtendScript
      5. Modification des expressions
      6. Erreurs dans les expressions
      7. Utilisation de lʼéditeur dʼexpressions
      8. Utilisation d’expressions pour accéder aux propriétés du texte et les modifier
      9. Référence au langage dʼexpression
      10. Exemples dʼexpressions
    2. Automatisation
      1. Automatisation
      2. Scripts
  15. Vidéo immersive, VR et 3D
    1. Création dʼenvironnements VR dans After Effects
    2. Application d’effets de vidéo immersive
    3. Outils de composition pour les vidéos VR/360
    4. Suivi du mouvement de la caméra 3D
    5. Utilisation de lʼespace de conception 3D
    6. Widgets de transformation 3D
    7. En faire plus avec l’animation 3D
    8. Aperçu des modifications apportées aux conceptions 3D en temps réel avec le moteur en temps réel
    9. Ajout de Responsive Design à vos images
  16. Vues et prévisualisations
    1. Prévisualisation
    2. Prévisualisation vidéo à lʼaide de Mercury Transmit
    3. Modification et utilisation des vues
  17. Rendu et exportation
    1. Notions de base relatives au rendu et à lʼexportation
    2. Exportation dʼun projet After Effects en tant que projet Adobe Premiere Pro
    3. Conversion de films
    4. Rendu multi-images
    5. Rendu automatisé et rendu en réseau
    6. Rendu et exportation dʼimages fixes et de séquences dʼimages fixes
    7. Utilisation du codec GoPro CineForm dans After Effects
  18. Utilisation dʼautres applications
    1. Dynamic Link et After Effects
    2. Utilisation dʼAfter Effects et dʼautres applications
    3. Synchronisation des paramètres dans After Effects
    4. Bibliothèques Creative Cloud dans After Effects
    5. Plug-ins
    6. CINEMA 4D et Cineware
  19. Collaboration : Frame.io et Projets d’équipe
    1. Collaboration dans Premiere Pro et After Effects
    2. Frame.io
      1. Installer et activer Frame.io
      2. Utiliser Frame.io avec Premiere Pro et After Effects
      3. Foire aux questions
    3. Projets dʼéquipe
      1. Prise en main des projets d’équipe
      2. Créer un projet d’équipe
      3. Collaborer sur les projets d’équipe
  20. Mémoire, stockage et performances
    1. Mémoire et stockage
    2. Comment After Effects gère les problèmes de mémoire insuffisante lors de la prévisualisation    
    3. Amélioration des performances
    4. Préférences
    5. Configuration requise du GPU et du pilote GPU pour After Effects

Rendu automatisé avec le fichier exécutable aerender

Le fichier exécutable aerender.exe est un programme équipé d’une interface de ligne de commande permettant d’automatiser le rendu. Le fichier exécutable réside dans le même dossier que l’application primaire After Effects. Les emplacements par défaut pour ce fichier sont les suivants :

  • Windows : \Program Files\Adobe\Adobe After Effects CC\Support Files

  • Mac OS : /Applications/Adobe After Effects CC

Vous pouvez utiliser lʼapplication aerender pour exécuter des opérations de rendu sur plusieurs ordinateurs membres dʼune ferme de rendu. Cette application est également utilisable sur un seul ordinateur dans le cadre dʼune opération par lots.

Pour utiliser le programme, vous devez saisir la commande aerender sur la ligne de commande (ou dans un script de commandes) suivie d’une série d’arguments facultatifs. Certains de ces arguments sont de simples options qui ne nécessitent pas d’arguments propres (par exemple, -reuse), tandis que d’autres en nécessitent (par exemple, -project project_path).

Remarque :

Saisissez la commande aerender -help pour afficher des informations sur lʼutilisation.

La version et le numéro de version de lʼapplication sont écrits en sortie standard (stdout).

Le rendu peut être réalisé soit par une instance After Effects en cours d’exécution soit par une instance nouvellement démarrée. Par défaut, aerender démarre une nouvelle instance d’After Effects, même s’il y en a déjà une en cours d’exécution. Pour utiliser l’instance en cours d’exécution, utilisez l’argument –reuse.

Cet exemple de commande demande à After Effects dʼeffectuer le rendu des images 1 à 10 de Composition_1 de project_1.aep en une séquence numérotée de fichiers Photoshop à lʼaide dʼun rendu multi-ordinateur :

aerender -project c:\projects\project_1.aep -comp "Composition_1" -s 1 -e 10
-RStemplate "Multi-Machine Settings" -OMtemplate "Multi-Machine Sequence"
-output c:\output\project_1\frames[####].psd

Pour nʼeffectuer que le rendu de Composition_1 vers un fichier défini, saisissez cette commande :

aerender -project c:\projects\project_1.aep -comp "Composition_1" -output c :\output\project_1\project_1.avi

Pour effectuer le rendu de tous les éléments présents dans la file dʼattente avec les paramètres sélectionnés dans le fichier de projet, saisissez cette commande :

aerender -project c:\projects\project_1.aep

Argument

Description

"-h"

"–help"

Imprime un message dʼutilisation.

"–version"

Affiche le numéro de version dʼaerender sur la console. Nʼeffectue pas de rendu

"–v verbose_flag"

dans lequel verbose_flag indique le type de messages signalés. Les valeurs possibles sont ERRORS (affiche uniquement les erreurs fatales et les problèmes) ou ERRORS_AND_PROGRESS (affiche également la progression du rendu).

–reuse

Utilisez cet indicateur si vous souhaitez réutiliser une instance dʼAE déjà en cours dʼexécution afin dʼeffectuer le rendu. Par défaut, aerender démarrera une nouvelle instance dʼAfter Effects, même sʼil y en a déjà une en cours dʼexécution. Toutefois, si AE est déjà en cours dʼexécution et que lʼindicateur "-reuse" est fourni, aerender demandera à lʼinstance dʼAE déjà en cours dʼexécution dʼeffectuer le rendu. Chaque fois quʼaerender lance une nouvelle instance dʼAE, il demande à AE de sʼarrêter une fois le rendu terminé ; sinon, il nʼarrête pas AE. De plus, les préférences seront écrites dans le fichier lors de lʼarrêt lorsque lʼindicateur "-reuse" sera spécifié ; sinon, il ne sera pas écrit.

"–mem_usage image_cache_percentmax_mem_percent"

dans lequel image_cache_percent spécifie le pourcentage maximal de mémoire utilisé pour la mise en cache des images/métrages déjà rendus et max_mem_percent indique le pourcentage total de mémoire pouvant être utilisé par After Effects.

« -mfr mfr_flag max_cpu_percent » mfr_flag (« ON »| « OFF ») spécifie si le rendu multi-images doit être utilisé et max_cpu_percent (1-100) spécifie le pourcentage de puissance CPU maximal souhaité à utiliser pendant le rendu.Étant donné que le rendu multi-images a la capacité d’utiliser 100 % de la puissance de votre processeur, vous pouvez choisir de limiter la puissance du processeur afin que d’autres applications puissent être utilisées. max_cpu_percent sera ignoré lorsque mfr_flag est défini sur « OFF ».

"–project project_path"

dans lequel project_path est un chemin dʼaccès ou une URI spécifiant un fichier de projet à ouvrir. Si aucun nʼest fourni, aerender utilisera le projet actuellement ouvert. Si aucun projet nʼest ouvert et quʼaucun projet nʼest fourni, une erreur se produit.

"–comp comp_name"

dans lequel comp_name indique une composition dont le rendu doit être effectué. Si la composition se trouve déjà dans la file dʼattente de rendu, et dans un état de mise en file dʼattente, alors (seule) la première instance en file dʼattente de cette composition dans la file dʼattente de rendu sera rendue. Si la composition est dans le projet, mais pas dans la file dʼattente de rendu, alors elle sera ajoutée à la file dʼattente, puis rendue.Si aucun argument -comp nʼest fourni, aerender effectuera le rendu de lʼintégralité de la file dʼattente de rendu en lʼétat. Dans ce cas (pas de -comp), les seuls autres arguments utilisés seront -project, -log, -v, -mem_usage et -close ; les arguments -RStemplate, -OMtemplate, -output, -s, -e et -i seront ignorés.

"–s start_frame"

start_frame est la première image traitée pour le rendu. La valeur par défaut est lʼimage de départ du fichier.

"–e end_frame"

end_frame est la dernière image traitée pour le rendu.Notez que ceci est « inclusif » ; la dernière image sera rendue.

"–i increment"

dans lequel increment correspond au nombre dʼimages à parcourir avant dʼeffectuer le rendu dʼune nouvelle image. Une valeur de 1 (par défaut) entraîne le rendu normal de toutes les images. Des incréments plus élevés répéteront le même (incrément dʼimage-1) plusieurs fois, puis en rendront un nouveau, recommençant le cycle. Des valeurs supérieures entraînent des rendus plus rapides, mais un mouvement plus saccadé. La valeur par défaut est 1.

"–OMtemplate output_module_template"

dans lequel output_module_template correspond au nom du modèle à appliquer au module de sortie. Si le modèle nʼexiste pas, il sʼagit dʼune erreur.La valeur par défaut consiste à utiliser le modèle déjà défini pour le module de sortie.

"–RStemplate render_sett ings_template"

dans lequel render_settings_template est le nom dʼun modèle à appliquer à lʼélément dans la file dʼattente de rendu. Si le modèle nʼexiste pas, une erreur se produit.La valeur par défaut consiste à utiliser le modèle de rendu déjà défini pour lʼélément.

"–output output_path"

dans lequel output_path est un chemin dʼaccès de fichier ou une URI spécifiant le fichier de rendu de destination. La valeur par défaut est le chemin dʼaccès déjà présent dans le fichier de projet.

"–log log_file_path"

ici, log_file_path correspond à un chemin dʼaccès ou à une URI spécifiant lʼemplacement du fichier journal. La valeur par défaut est stdout.

"–sound sound_flag"

dans lequel sound_flag spécifie sʼil faut ou non lire un son lorsque le rendu est terminé. Les valeurs possibles sont « ON » ou « OFF ». La valeur par défaut est « OFF ».

"–close close_flag"

dans lequel close_flag spécifie si le projet doit être fermé une fois le rendu terminé, et si les modifications doivent être enregistrées. Si la valeur de close_flag est DO_NOT_SAVE_CHANGES, le projet sera fermé sans enregistrer les modifications. Si la valeur de close_flag est SAVE_CHANGES, le projet sera fermé et les modifications seront enregistrées. Si la valeur de close_flag est DO_NOT_CLOSE, le projet sera laissé ouvert. Mais le projet nʼest laissé ouvert que sʼil utilise une instance dʼAE déjà en cours dʼexécution, car les nouvelles invocations dʼAE doivent toujours se fermer quand elles sont terminées. La valeur par défaut est DO_NOT_SAVE_CHANGES.

"-rqindex index_in_render_queue"

dans lequel index_in_render_queue spécifie un élément dans la file dʼattente dont le rendu doit être efffectué. Les options qui sont utiles lors du rendu dʼun seul élément de la file dʼattente de rendu sont disponibles avec lʼindicateur -comp.

"-continueOnMissingFootage"

Nʼarrête pas le rendu en cas de métrages manquants. Enregistrement et rendu avec des barres de couleur dʼespace réservé.

Sur son site Web After Effects Scripts, Lloyd Alvarez propose un script qui prend les éléments prêts pour le rendu dans la file dʼattente de rendu et les envoie au rendu en arrière-plan à lʼaide dʼaerender.

Rendu réseau avec dossiers de contrôle et moteurs de rendu

Vous pouvez effectuer le rendu d’une ou plusieurs compositions d’un projet à l’aide de plusieurs ordinateurs en réseau. Le rendu en réseau permet d’obtenir des résultats bien plus rapides que sur un seul ordinateur. Le rendu en réseau implique la copie du projet et des fichiers source vers un dossier du réseau, puis le rendu du projet. Le terme « ferme de rendu » est parfois utilisé pour désigner un réseau dʼordinateurs utilisés collectivement pour procéder au rendu dʼune seule composition.

On parle de ferme de rendu lorsquʼun réseau dʼordinateurs est utilisé pour procéder au rendu dʼune seule composition. Vous pouvez le paramétrer pour quʼil puisse fonctionner avec des versions dʼAfter Effects limitées aux activités de rendu, appelées moteurs de rendu.

Vous pouvez installer des moteurs de rendu de la même manière que la version complète de l’application. Le moteur de rendu s’exécute à l’aide du raccourci Moteur de rendu Adobe After Effects situé dans le dossier Adobe After Effects CC. Pour plus dʼinformations, voir Configuration et installation.

Il n’est pas possible d’utiliser un dossier de contrôle et plusieurs moteurs de rendu pour effectuer simultanément le rendu d’un seul fichier de film. En revanche, dans le cas d’une ferme de rendu, il est possible d’utiliser plusieurs moteurs pour effectuer le rendu d’un film sous la forme d’une séquence de fichiers d’images fixes. Vous pouvez alors utiliser une action de post-rendu pour créer un seul fichier de film à partir d’une séquence d’images fixes. Pour plus dʼinformations, voir Actions de post-rendu.

Remarques relatives aux réseaux

Lors de lʼutilisation de plusieurs moteurs de rendu sur plusieurs ordinateurs, tenez compte des recommandations suivantes :

  • Si possible, identifiez les dossiers à l’aide des chemins d’accès absolus pour que ces chemins d’accès soient correctement identifiés par tous les moteurs de rendu. Si vous optez pour les chemins d’accès absolus, vous devrez sans doute associer les lecteurs de réseau à une même lettre d’unité sur tous les ordinateurs (par exemple, H:\renders\watch\). Évitez l’utilisation de chemins d’accès relatifs (par exemple, \\renders\watch).

  • Chaque ordinateur Macintosh gérant le dossier de contrôle doit porter un nom unique. Pensez à renommer vos ordinateurs de sorte qu’ils n’utilisent pas le nom par défaut, ce nom étant souvent le même pour tous.

  • Assurez-vous que tous les serveurs et tous les clients (ordinateurs gérant le dossier de contrôle) possèdent des disques durs dotés de noms uniques.

  • N’utilisez pas le même ordinateur pour tenir le rôle de dossier de contrôle et pour exécuter After Effects en mode Dossier de contrôle. Utilisez un serveur spécifiquement dédié au dossier de contrôle, auquel tous les moteurs de rendu auront accès.

  • N’effectuez pas de rendu en mode Dossier de contrôle et ne lancez pas ce mode sur la racine d’un volume ou d’un dossier partagé qui s’affiche comme racine à partir d’un autre ordinateur. Spécifiez plutôt un sous-dossier. Évitez également d’utiliser des caractères ASCII hauts, des caractères étendus ou des barres obliques dans les noms de fichiers. Dans le cadre de rendus sur plusieurs ordinateurs, After Effects propose un modèle type de gestion des environnements à plusieurs ordinateurs pouvant vous servir de point de départ.

Remarque :

Pour les rendus en réseau faisant appel à des volumes utilisant différents réseaux ou systèmes dʼexploitation (Windows, Mac OS, Novell et UNIX), assurez-vous que les fichiers de rendu respectent des conventions de dénomination compatibles avec tous les volumes de rendu ou de destination.

Remarques relatives aux projets

Assurez-vous d’avoir installé toutes les polices, tous les effets et tous les décodeurs (compresseurs) utilisés dans le projet sur tous les ordinateurs gérant le dossier de contrôle. Si un des ordinateurs gérant le dossier de contrôle ne trouve pas les polices, effets ou décodeurs utilisés dans un projet, le rendu ne peut être réalisé.

Lorsque vous installez un moteur de rendu After Effects sur un ordinateur, il contient tous les modules inclus dans After Effects. Lorsqu’une composition fait appel à des modules tiers, ceux-ci doivent être installés sur tous les ordinateurs participant au rendu de la composition. La prise en charge du rendu en réseau varie en fonction des éditeurs de ces modules. Par conséquent, avant de paramétrer un réseau pour effectuer le rendu d’effets générés par un module tiers, reportez-vous à sa documentation ou contactez son éditeur afin d’obtenir des réponses aux questions suivantes :

  • La licence dʼutilisation du module autorise-t-elle lʼinstallation de plusieurs copies en réseau à des fins de rendu ?

  • Existe-t-il des limitations ou des astuces qui sʼappliquent en cas dʼutilisation du module pour effectuer un rendu en réseau ?

Remarques relatives au dossier Rassembler les fichiers

Lorsque vous utilisez la commande Fichier > Rassembler les fichiers, les fichiers relatifs à un projet sont copiés dans un seul dossier. Ce dossier comprend une copie du fichier de projet, un fichier de contrôle de rendu (RCF) et d’autres fichiers, selon les options sélectionnées dans la boîte de dialogue Rassembler les fichiers. Si vous enregistrez le dossier Rassembler les fichiers sur un ordinateur du réseau autre qu’un serveur, n’exécutez pas le moteur de rendu sur cet ordinateur. Évitez d’enregistrer le dossier Rassembler les fichiers sur un disque local, à la racine d’un disque (comme sous C: sous Windows ou le Macintosh HD sous Mac OS) ou sur un dossier partagé, tous trois pouvant indiquer des endroits différents à chaque moteur de rendu. Tous les moteurs de rendu doivent interpréter le chemin de la même façon.

Remarque :

Lorsque tous les fichiers rassemblés figurent dans le dossier de contrôle, tous les moteurs de rendu débutent automatiquement leurs traitements. Si vous préférez, vous pouvez utiliser la commande Rassembler les fichiers pour enregistrer des compositions et leurs métrages source dans un emplacement particulier et lancer ultérieurement la procédure de rendu du dossier de contrôle. Cette technique conduit à un rendu par ordre alphabétique (et non selon l’ordre d’enregistrement).

Suivi des dépendances de rendu d’un dossier de contrôle

Les options Action postrendu vous permettent de suivre les dépendances de rendu lors du rendu en réseau. Lorsque vous définissez ces options, After Effects confirme que tous les éléments dont le rendu doit être effectué sont prêts et disponibles. Si, par exemple, un élément dépend dʼun autre pour le rendu, et que ce premier élément est encore en cours de rendu ou a enregistré une erreur, lʼélément dépendant nʼest pas rendu.

Vous pouvez utiliser cette procédure pour le rendu dʼun film simple QuickTime ou AVI en mode Dossier de contrôle. Le film est généré sur un seul ordinateur.

Remarque :

Cette procédure suppose que vous ayez préalablement créé un dossier de contrôle multiordinateur.

  1. Dans le panneau File d’attente de rendu, faites glisser le module de rendu sur le panneau Projet. After Effects crée un pseudo-élément pour la sortie de cet élément.
  2. Faites glisser ce pseudo-élément sur le panneau File d’attente de rendu.
  3. Définissez les paramètres de rendu et de module de rendu à appliquer à ce pseudo-élément, puis cliquez sur le bouton Rendu.

Démarrage en mode Dossier de contrôle

Le mode Dossier de contrôle s’applique uniquement au rendu à partir d’un dossier situé sur un ordinateur local.

  • Pour lancer After Effects automatiquement en mode Dossier de contrôle, enregistrez un projet sous le nom de fichier Surveiller ce dossier.aep. Ainsi, After Effects surveille le dossier contenant le projet si vous ouvrez ce dernier.
  • Pour lancer After Effects en mode Dossier de contrôle au démarrage de votre ordinateur, créez un raccourci (Windows) ou un alias (Mac OS) vers le projet Surveiller ce dossier.aep et déplacez-le dans le dossier Démarrage (Windows) ou dans le dossier Ouverture au démarrage (Mac OS). Ainsi, After Effects surveille le dossier contenant le projet si vous ouvrez ce dernier.
  • (Windows uniquement) Pour lancer After Effects en mode Dossier de contrôle à partir de la ligne de commande, sélectionnez Démarrer > Exécuter, puis saisissez la commande suivante, en remplaçant le chemin de lʼapplication par le nom exact du dossier dans lequel est installé After Effects, et en remplaçant C:\[temp] par le chemin dʼaccès à votre dossier de contrôle : "C:\Program Files\Adobe\Adobe After Effects CC\Support Files\afterfx.exe" -wf C:\[temp]
Remarque :

Pour lancer le moteur de rendu After Effects plutôt que la version complète dʼAfter Effects, utilisez lʼoption -re avec la commande.

Remarque :

Vous pouvez également utiliser cette ligne de commande pour les lots de fichiers.

Ferme de rendu : rendu d’une séquence d’images fixes à l’aide de plusieurs ordinateurs

On parle de ferme de rendu lorsqu’une grappe d’ordinateurs est utilisée pour procéder au rendu d’une seule composition. Vous pouvez la paramétrer pour qu’elle puisse fonctionner avec des versions d’After Effects limitées aux activités de rendu, appelées moteurs de rendu. Une ferme de rendu permet de réduire le temps nécessaire à une seule machine pour exporter une composition. Vous pouvez utiliser plusieurs ordinateurs et plusieurs copies dʼAfter Effects pour effectuer le rendu dʼune composition sur un réseau. Vous pouvez utiliser plusieurs ordinateurs pour effectuer uniquement le rendu de séquences dʼimages fixes, mais pas pour effectuer le rendu dʼun seul film.

Aharon Rabinowitz, dans un tutoriel vidéo disponible sur le site Web Creative COW, présente et explique la procédure de rendu dʼune séquence dʼimages fixes avec plusieurs ordinateurs.

Configuration du réseau

Suivez la procédure illustrée ci-dessous pour comprendre les exigences relatives à la configuration du réseau.

Configuration du rendu en réseau

A. L’ordinateur sur lequel est installée la version complète d’After Effects B. Enregistrez un projet et tous les fichiers source dans un dossier sur un serveur C. Les ordinateurs sur lesquels le moteur de rendu est installé D. Ouvrez le projet et effectuez le rendu d’une séquence d’images fixes dans un dossier de sortie désigné sur le serveur 

Vous pouvez effectuer le rendu à l’aide d’un nombre quelconque d’ordinateurs. En général, plus ils sont nombreux, plus l’opération est rapide. Toutefois, si vous utilisez un trop grand nombre d’ordinateurs sur un réseau déjà surchargé, le volume du trafic réseau peut induire un ralentissement significatif des traitements. Pour détecter ces ralentissements, vérifiez le temps écoulé au cours de lʼétape de Compression et dʼécriture dans la section Rendu en cours du panneau File dʼattente de rendu.

Remarque :

Adobe nʼassure pas de support technique relatif aux problèmes généraux de configuration réseau. Veuillez consulter votre administrateur réseau.

Rendu dʼune séquence dʼimages fixes sur plusieurs ordinateurs

Facteurs importants dans le cadre du rendu dʼune séquence dʼimages fixes avec plusieurs ordinateurs :

  • Pour effectuer ce type de rendu, vous pouvez utiliser un nombre illimité dʼordinateurs. 
  • Lorsque vous effectuez le rendu dʼune séquence dʼimages fixes sur plusieurs ordinateurs, le rendu dans chacune des copies dʼAfter Effects démarre approximativement au même moment. 
  • Si lʼoption Ignorer les fichiers existants (sous Paramètres de rendu) est définie pour les éléments de rendu en file dʼattente, le processus de rendu ignore les images existantes ou en cours de traitement.
  • Plusieurs ordinateurs peuvent procéder simultanément au rendu du projet, la séquence dʼimages fixes étant alors écrite dans un seul dossier.

Pour effectuer le rendu dʼune séquence dʼimages fixes, procédez comme suit :

  1. Installez After Effects sur chacun des ordinateurs qui participera au rendu du projet. Assurez-vous que tous les ordinateurs disposent des mêmes polices.

    Remarque :

    Les modules externes ne peuvent pas être partagés en réseau. Assurez-vous que tous les ordinateurs exécutant After Effects disposent d’une copie du dossier de modules externes. Si vous utilisez des modules tiers, assurez-vous également qu’ils sont installés sur tous les ordinateurs et que vous disposez d’un nombre suffisant de licences.

  2. Ouvrez le projet sur un ordinateur et sélectionnez ensuite Composition > Ajouter à la file dʼattente de rendu.

  3. Dans le panneau File dʼattente de rendu, indiquez un format dans la section Module de sortie et un dossier dans la section Destin. Ce dossier doit être accessible à tous les ordinateurs participant au rendu.

  4. Dans le panneau File dʼattente de rendu, sélectionnez lʼoption Ignorer les fichiers existants (permet le rendu machines multiples) dans la section Paramètres de rendu, de sorte que plusieurs ordinateurs nʼeffectuent pas le rendu de la même image. Nʼutilisez pas plusieurs modules de sortie pour un seul élément de rendu avec lʼoption Ignorer les fichiers existants.

  5. Enregistrez le projet sur l’ordinateur à partir duquel vous l’avez ouvert à l’étape 2.
  6. Ouvrez et enregistrez le projet sur chacun des ordinateurs participant au rendu, afin de vous assurer qu’After Effects enregistre les nouveaux chemins d’accès relatifs à chaque ordinateur au cours des étapes suivantes.
  7. Copiez le fichier du projet et tous ses métrages source sur l’ensemble des ordinateurs participant au rendu (sauf si votre réseau assure des échanges rapides de gros fichiers).
  8. Ouvrez le panneau File d’attente de rendu sur tous les ordinateurs et cliquez ensuite sur le bouton Rendu. Il n’est pas nécessaire de débuter le rendu simultanément sur tous les ordinateurs, mais cela contribue à répartir plus équitablement la charge de travail. Lorsquʼun ordinateur a achevé le rendu dʼune image, After Effects parcourt le dossier Sortie à la recherche de la prochaine image à traiter, puis relance la procédure.

  9. Les ordinateurs peuvent être arrêtés ou relancés à tout moment. Néanmoins, si un ordinateur est arrêté sans être relancé, l’image dont il effectuait le rendu peut ne pas être terminée. Si un ou plusieurs ordinateurs sont arrêtés en cours de rendu, le redémarrage de l’un d’entre eux garantit que toutes les images d’une séquence seront traitées.

Exécution d’aerender en mode non soumis aux droits d’auteur

After Effects CS5.5 devait être sérialisé sur des machines destinées exclusivement au rendu en raison de problèmes de licence. Dans After Effects CS6 et versions ultérieures, vous pouvez désormais exécuter aerender ou utiliser Dossier de contrôle dans un mode non soumis aux droits dʼauteur, de sorte que la sérialisation ne soit pas nécessaire.

Pour vous assurer quʼAfter Effects sʼexécute en mode non soumis aux droits dʼauteur, placez un fichier vide nommé ae_render_only_node.txt à lʼemplacement suivant :

  1. Installez After Effects sur la machine destinée au rendu.

    • Emplacements Mac :

      /Users/<username>/Documents/

      /Users/Shared/Adobe/

    • Emplacements Windows :

      C:\Users\<username>\Documents

      C:\Users\Public\Documents\Adobe

Paramètres des segments

Les paramètres des segments se trouvent dans la catégorie des préférences de sortie.

Remarque :

Sélectionnez Édition > Préférences > Sortie (Windows) ou After Effects > Préférences > Sortie (Mac OS).

After Effects est en mesure d’effectuer le rendu de séquences et de fichiers vidéo dans des segments limités à un nombre défini de fichiers ou selon la taille de fichier. Cela s’avère utile lors de la préparation d’une vidéo pour un support, tel qu’un CD-ROM, dont la taille de fichier ou de dossier peut être limitée à des segments de 650 Mo, voire moins. Utilisez la valeur Segmenter les fichiers contenant uniquement de la vidéo à pour définir la taille maximale des segments en mégaoctets. Utilisez la valeur Segmenter les séquences à pour définir le nombre maximal de fichiers d’images fixes dans un dossier.

Si vous exportez un film dont la taille est supérieure à la taille maximale de votre schéma de formatage de disque, vous pouvez définir une valeur inférieure à ce seuil pour l’option Segmenter les fichiers contenant uniquement de la vidéo à. Les disques durs formatés pour Windows peuvent être formatés selon le schéma FAT, FAT32 ou NTFS. La taille maximale du schéma FAT est de 2 Go, et celle du schéma FAT32 est de 4 Go. La taille maximale dʼun fichier en NTFS est très importante (environ 16 téraoctets). Il est peu probable que vous réussissiez à atteindre cette taille avec un seul et unique film.

Seuls les films qui ne contiennent pas d’audio peuvent être segmentés. Si un module de rendu inclut de l’audio, la préférence Segmenter les fichiers contenant uniquement de la vidéo à est ignorée pour cet élément.

La préférence Segmenter les séquences à est ignorée pour les éléments de rendu pour lesquels lʼoption Ignorer les fichiers existants est sélectionnée dans les paramètres de rendu. (voir Référence des paramètres de rendu).

Remarque :

After Effects n’effectue pas le rendu ni n’exporte un film segmenté dans le répertoire racine (C:\, par exemple). Pour effectuer le rendu et exporter un film segmenté, sélectionnez un répertoire de sortie autre que le répertoire racine. (Voir Définition des noms et des emplacements des fichiers pour la version rendue).

Logo Adobe

Accéder à votre compte