Sélection de calques

Les calques sélectionnés dont les propriétés sont également sélectionnées sont indiqués par une mise en surbrillance creuse dans le panneau Montage. Un calque sélectionné dont les propriétés ne sont pas sélectionnées est indiqué par une mise en surbrillance solide.

Sélection du calque supérieur, mais aucune propriété sélectionnée ; sélection du cadre inférieur et de propriétés
Sélection du calque supérieur, mais aucune propriété sélectionnée ; sélection du cadre inférieur et de propriétés.

Remarque :

Pour placer le calque le plus élevé de la sélection en haut du panneau Montage, appuyez sur la touche X.

  • Pour sélectionner un calque, cliquez sur ce dernier dans le panneau Composition, cliquez sur son nom ou sa bande de durée dans le panneau Montage ou cliquez sur son nom dans le panneau Organigramme.
  • Pour sélectionner un calque caché dans le panneau Composition, cliquez sur le calque dans le panneau Composition avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle (Mac OS) enfoncée, puis choisissez Sélectionner > [nom du calque].
  • Pour sélectionner un calque ouvert dans son propre panneau Calque, choisissez le nom du calque dans le menu Fenêtre ou le menu du visualiseur du panneau Calque.
  • Pour sélectionner un calque selon sa position, tapez son numéro sur le pavé numérique. Si le numéro de calque comporte plusieurs chiffres, tapez-les rapidement, afin qu’After Effects les interprète comme un seul numéro.
  • Pour sélectionner le calque suivant dans l’ordre d’empilement, appuyez sur les touches Ctrl + Flèche bas (Windows) ou Commande + Flèche bas (Mac OS). Pour sélectionner le calque précédent, appuyez sur les touches Ctrl + Flèche haut (Windows) ou Commande + Flèche haut (Mac OS).
  • Pour élargir la sélection au calque suivant dans l’ordre d’empilement, appuyez sur les touches Ctrl + Maj + Flèche bas (Windows) ou Commande + Maj + Flèche bas (Mac OS). Pour élargir la sélection au calque précédent dans l’ordre d’empilement, appuyez sur les touches Ctrl + Maj + Flèche haut (Windows) ou Commande + Maj + Flèche haut (Mac OS).
  • Pour sélectionner tous les calques, choisissez Edition > Sélectionner tout lorsque le panneau Montage ou Composition est activé. Pour désélectionner tous les calques, choisissez la commande Edition > Tout désélectionner. Si l’option Masquer calques discrets de la composition est sélectionnée, l’utilisation de la commande Sélectionner tout lorsque la panneau Montage est actif ne permet pas de sélectionner les calques discrets (voir Affichage et masquage des calques dans le panneau Montage).
  • Pour désélectionner les calques sélectionnés et sélectionnez tous les autres, avec au moins un calque sélectionné, choisissez Inverser la sélection dans le menu contextuel du panneau Composition ou Montage.
  • Pour sélectionner tous les calques utilisant la même couleur de libellé, cliquez sur la couleur de libellé du calque dans le panneau Montage, puis choisissez Sélectionner un groupe de libellés, ou sélectionnez un calque avec cette couleur de libellé et choisissez Edition > Libellé > Sélectionner un groupe de libellés.
  • Pour sélectionner tous les calques enfants assignés à un calque parent, sélectionnez le calque parent et choisissez Sélectionner les enfants dans le menu contextuel du panneau Composition ou Montage. Les calques enfants sont ajoutés à la sélection existante.
  • Vous pouvez sélectionner plusieurs calques dans le panneau Composition. Faites glisser l’outil Sélection afin de créer un rectangle de sélection autour des calques pour les sélectionner. Tout en maintenant la touche Maj enfoncée, cliquez ou faites glisser pour sélectionner des calques supplémentaires ou pour désélectionner les calques.

Sur son site Web After Effects Scripts, Lloyd Alvarez propose un script grâce auquel vous pouvez marquer des calques, puis les sélectionner, les rendre discrets et les isoler en fonction de leur marquage. Le marquage est ajouté aux commentaires dans le champ Commentaires du panneau Montage.

Modification de l’ordre d’empilement des calques sélectionnés

Le classement vertical de calques dans le panneau Montage correspond à l’ordre d’empilement des calques, qui est directement lié à l’ordre de rendu. Vous pouvez changer l’ordre de composition des calques en modifiant leur ordre d’empilement.

Remarque :

en raison des propriétés de profondeur, l’ordre d’empilement des Calques 3D dans le panneau Montage ne reflète pas nécessairement leur position spatiale dans la composition.

  • Dans le panneau Montage, faites glisser le nom des calques vers un nouvel emplacement dans l’ordre d’empilement.
  • Pour déplacer les calques sélectionnés d’un rang vers le haut dans l’ordre d’empilement, appuyez sur les touches Ctrl + Alt + Flèche haut (Windows) ou Commande + Option + Flèche haut (Mac OS) ; pour les déplacer d’un rang vers le bas, appuyez sur les touches Ctrl + Alt + Flèche bas (Windows) ou Commande + Option + Flèche bas (Mac OS).
  • Pour déplacer les calques sélectionnés en haut de l’ordre d’empilement, appuyez sur les touches Ctrl + Alt + Maj + Flèche haut (Windows) ou Commande + Option + Maj + Flèche haut (Mac OS) ; pour les déplacer tout en bas, appuyez sur les touches Ctrl + Alt + Maj + Flèche bas (Windows) ou Commande + Option + Maj + Flèche bas (Mac OS).
  • Choisissez Calque > Réorganiser puis Amener le calque en avant, Envoyer le calque en arrière, Amener le calque au premier plan ou Envoyer le calque vers l’arrière-plan.

Remarque :

Lorsque vous copiez (ou coupez) et collez des calques, ceux-ci sont collés de sorte qu’ils apparaissent de haut en bas dans le panneau Montage, en tenant compte de l’ordre dans lequel ils ont été sélectionnés avant de les copier (ou couper). Vous pouvez maintenir la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée et cliquer sur des calques pour les sélectionner dans un ordre arbitraire, les couper puis les coller immédiatement dans l’ordre dans lequel ils ont été sélectionnés.

Jeff Almasol propose, sur son site Web redefinery, un script permettant de changer l’ordre d’empilement des calques dans une composition en les triant par point d’entrée, point de sortie, ordre de sélection, nom de calque ou de manière aléatoire.

Systèmes de coordonnées : espace de la composition et espace du calque

Le système de coordonnées de chaque calque est son espace calque. Le système de coordonnées de chaque composition est son espace composition. Les valeurs de propriétés pour les éléments qui existent à l’intérieur d’un calque (par exemple les points de contrôle et les points d’ancrage) existent dans l’espace calque et sont mesurés à partir de l’origine de l’espace calque de ce calque. La propriété Position d’un calque décrit toutefois où se trouve le calque à l’intérieur d’une composition et est donc mesurée dans l’espace composition de cette composition.

Lorsque vous déplacez le pointeur sur l’image du calque dans le panneau Calque, le panneau Info affiche les coordonnées du pixel situé sous le pointeur dans l’espace calque. La coordonnée X représente la position sur l’axe horizontal, tandis que la coordonnée Y représente celle sur l’axe vertical. Les valeurs de ces coordonnées s’expriment en pixels. Les coordonnées X et Y se rapportent à l’origine (0,0), dans l’angle supérieur gauche du calque.

Vous pouvez modifier le point zéro des règles, mais vous ne pouvez pas modifier l’origine de l’espace calque. Lorsque le point zéro ne correspond pas à l’origine, les coordonnées X’ et Y’ s’affichent dans le panneau Info en dessous des coordonnées X et Y. Elles sont basées sur le point zéro des règles.

Lorsque vous déplacez le pointeur sur l’image de la composition dans le panneau Composition, le panneau Info affiche les coordonnées dans l’espace de la composition. Lorsque vous faites glisser un calque, les coordonnées du point d’ancrage du calque s’affichent dans la partie inférieure du panneau Info.

Déplacement de calques dans l’espace

Lorsque vous déplacez un calque dans l’espace, vous modifiez sa propriété Position.

Vous pouvez séparer les composants d’une propriété Position en propriétés individuelles (Position X, Position Y et (pour les calques 3D) Position Z) afin de pouvoir les modifier ou les animer chacun indépendamment (voir Séparation des dimensions d’une propriété Position pour animer des composants individuellement).

Jeff Almasol propose, sur son site Web redefinery, un script permettant de placer un nouveau calque nul sur la ligne qui sépare les points d’ancrage de deux calques sélectionnés ; un paramètre glissière vous permet de repositionner le calque nul le long de cette ligne.

Remarque :

Pour déplacer des calques sélectionnés de sorte que leurs points d’ancrage se trouvent au centre de la vue actuelle, choisissez Calque > Géométrie > Centrer dans la vue ou appuyez sur Ctrl + Origine (Windows) ou Commande + Origine (Mac OS).

Remarque :

Pour déplacer un calque de manière à centrer son point d’ancrage dans la composition, cliquez sur la propriété Position avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Mac OS), choisissez la commande Modifier la valeur, sélectionnez l’option % de la composition dans le menu Unités, puis saisissez la valeur 50 pour chacun des composants de la propriété Position.

Pour éviter l’atténuation d’une image immobile, assurez-vous que les valeurs Position d’un calque ne sont pas des fractions. Vous éviterez ainsi le rééchantillonnage appliqué lors du placement, sur des sous-pixels, d’un calque dont la qualité d’image est définie sur Optimale.

Déplacement de calques par glissement vers le panneau Composition

Remarque :

Pour aligner le bord d’un calque sur les repères ou la grille pendant le glissement, choisissez Affichage > Aligner sur la grille ou Affichage > Aligner sur les repères.

  • Sélectionnez un ou plusieurs calques, puis faites-les glisser à l’aide de l’outil Sélection .

    Lorsque vous déplacez un calque en le faisant glisser dans le panneau Composition, le panneau Info affiche la propriété Position, qui change au fil du déplacement.

Déplacement de calques par modification directe de la propriété Position

  1. Sélectionnez un ou plusieurs calques.
  2. Appuyez sur la touche P pour afficher la propriété Position dans le panneau Montage.
  3. Modifiez la propriété Position dans le panneau Montage.

Déplacement de calques à l’aide des touches fléchées

  1. Sélectionnez un ou plusieurs calques.
  2. Pour déplacer les calques sélectionnés d’un pixel vers la gauche, la droite, le haut ou le bas, appuyez sur l’une des flèches du clavier. Pour les déplacer de 10 pixels, appuyez sur une flèche et la touche Maj simultanément.

    Remarque :

    Les touches fléchées déplacent le calque d’un pixel à l’échelle d’agrandissement actuelle. Pour déplacer un calque plus précisément à l’aide des touches fléchées, effectuez un zoom dans le panneau Composition (voir Zoom sur une image pour prévisualisation).

Séparation des dimensions d’une propriété Position pour animer des composants individuellement

Par défaut, chaque propriété Position a deux ou trois composants, chacun contenant la valeur de l’une des dimensions spatiales (axes). Vous pouvez séparer les composants d’une propriété Position en propriétés individuelles (Position X, Position Y et (pour les calques 3D) Position Z). La séparation des dimensions vous permet de modifier et d’animer la position d’un calque le long de l’axe x, de l’axe y et de l’axe z, indépendamment.

Pour décomposer les propriétés Position sélectionnées en Position X, Position Y et (pour les calques 3D) Position Z, utilisez l’une des actions suivantes :

  • Choisissez Animation > Séparer les dimensions.
  • Cliquez avec le bouton droit de la souris (sous Windows) ou en maintenant la touche Ctrl (sous Mac OS) enfoncée sur une propriété Position et choisissez Séparer les dimensions dans le menu contextuel.
  • Cliquez sur le bouton Séparer les dimensions situé en bas de l’éditeur de graphiques.

Pour recomposer un ensemble de propriétés individuelles en une propriété Position unique avec plusieurs composants, utilisez les mêmes commandes que celles utilisées pour séparer les dimensions.

Remarque :

lorsque vous recomposez des propriétés Positions séparées en une propriété Position unique, certaines informations sur la trajectoire et la vitesse sont perdues, car les courbes de Bézier multiples utilisées pour représenter les composants individuels sont réduites en une courbe Bézier unique à chaque image clé. Lorsque vous séparez les dimensions, certaines informations sur la vitesse sont perdues, mais la trajectoire ne change pas. Vous devez choisir de travailler avec des dimensions séparées ou sans dimensions séparées pour chaque propriété de l’ensemble d’un projet, et non alterner entre les deux solutions.

Le choix de travailler ou non avec des dimensions séparées dépend de la tâche que vous tentez d’accomplir. L’utilisation d’une propriété pour une position offre l’avantage de lisser les déplacements plus facilement. En outre, l’utilisation d’une propriété unique pour la position permet d’utiliser des images clés itinérantes qui garantissent une vitesse uniforme. L’utilisation de dimensions séparées pour la position compromet ce lissage automatique en échange d’un plus grand contrôle d’animation spatiale. L’utilisation de dimensions séparées simplifie également les simulations, notamment lorsque les forces simulées agissant sur un calque sont orthogonales (perpendiculaires) les unes par rapport aux autres.

Par exemple, si vous animez une balle volant horizontalement et rebondissant verticalement, vous pouvez le faire plus facilement en séparant les dimensions. La propriété Position X peut être animée avec deux images clés, une pour la position de départ, une autre pour la position de fin. Cette animation horizontale représente la vitesse du jet. La propriété Position Y peut être animée avec une expression unique qui simule l’accélération due à la gravité et le rebondissement vertical au sol. Un bateau dérivant dans une rivière avec un vent de travers constitue un exemple similaire.

Remarque :

After Effects CS3 proposait une animation prédéfinie, Séparer la position XYZ, dont le résultat était semblable à celui obtenu avec la fonction Séparer les dimensions ; cette animation était toutefois moins puissante.

Alignement ou répartition de calques dans l’espace 2D

Le panneau Aligner permet d’aligner ou d’espacer correctement les calques sélectionnés. Vous pouvez aligner ou répartir les calques horizontalement et verticalement.

  1. Sélectionnez les calques à aligner ou à répartir.
  2. Choisissez Sélection ou Composition dans le menu Aligner les calques sur.

    Sélection

    Aligne les calques sélectionnés en fonction des contours des calques sélectionnés.

    Navigateur de

    Aligne les calques sélectionnés en fonction des contours de l’image de la composition.

  3. Dans le panneau Aligner, cliquez sur le bouton représentant le type d’alignement ou de répartition souhaité.
  • Pour la répartition, vous devez sélectionner trois calques ou plus. Si Sélection est défini dans le menu Aligner les calques sur, vous devez sélectionner plusieurs calques à aligner. Si Composition est défini, vous devez sélectionner un ou plusieurs calques à aligner.

  • Si Sélection est défini dans le menu Aligner les calques sur, chaque option d’alignement aligne les calques sélectionnés sur le calque qui représente le mieux le nouvel alignement. Par exemple, dans le cas d’un alignement sur le bord droit, tous les calques sélectionnés s’alignent sur le calque sélectionné avec le bord qui se trouve le plus à droite.

  • Une option de répartition espace de manière régulière les calques sélectionnés entre les calques positionnés aux deux extrémités. Par exemple, dans le cas d’une répartition verticale, les calques sélectionnés sont espacés régulièrement entre les deux calques sélectionnés se trouvant tout en haut et tout en bas, respectivement.

  • Lors de la répartition de calques de taille différente, l’espacement des calques risque de ne pas être uniforme. Par exemple, si les calques sont répartis en fonction de leur centre, la distance entre les centres est identique, mais l’espacement de calques de tailles différentes n’est pas le même.

  • Les options d’alignement et de répartition ne s’appliquent pas aux calques verrouillés.

  • Le panneau Aligner n’a aucune incidence sur l’alignement des caractères dans un calque de texte.

Remarque :

Pour déplacer des calques sélectionnés de sorte que leurs points d’ancrage se trouvent au centre de la vue actuelle, choisissez Calque > Géométrie > Centrer dans la vue ou appuyez sur Ctrl + Origine (Windows) ou Commande + Origine (Mac OS).

Sur le site Web After Effects Scripts, Charles Bordenave (nab) propose un script qui permet de répartir les calques dans un espace 3D.

Raccordement, extension ou modification rapide d’un calque

La durée d’un calque démarre à son point d’entrée et se termine à son point de sortie. La durée est le temps qui s’écoule entre le point d’entrée et le point de sortie ; la bande qui s’étend du point d’entrée au point de sortie est la bande de durée du calque.

Raccorder un calque signifie modifier son point d’entrée ou de sortie pour en changer la durée. Lorsque vous raccordez un calque créé à partir d’un métrage source animé, vous modifiez les images du métrage source qui apparaissent dans le calque ; la première image qui s’affiche est placée au point d’entrée et la dernière au point de sortie. Le raccordement d’un calque ne découpe pas les images de l’élément de métrage ; il définit simplement les images qui seront lues pour le calque.

Raccordement de calques dans le panneau Montage
Raccordement de calques dans le panneau Montage

A. Point d’entrée d’origine B. Repère d’instant de calque négatif pour calque d’image fixe C. Point d’entrée d’origine D. Bande de modification rapide représentant les images exclues pour un calque de métrage animé E. Nouveaux points d’entrée 

Lorsque vous utilisez un même métrage comme source de plusieurs calques, vous pouvez raccorder tous les calques de façon distincte afin d’afficher différentes parties de la source. Le raccordement d’un calque ne modifie pas le métrage ou le fichier source d’origine.

Vous pouvez raccorder un calque en modifiant les points d’entrée et de sortie dans les panneaux Calque ou Montage (il est également possible de raccorder un métrage avant de l’utiliser pour créer un calque ; voir Création de calques à partir d’éléments de métrages ou modification d’un calque source.

Les valeurs correspondant au point d’entrée , au point de sortie et à la durée d’un calque sont indiquées en bas du panneau Calque. Si vous souhaitez afficher ces informations pour l’ensemble des calques du panneau Montage, cliquez sur le bouton Entrée/Sortie/Durée/Extension situé en bas à gauche du panneau Montage. La durée, le point d’entrée et le point de sortie du calque sélectionné s’affichent également dans le panneau Info.

Dans le panneau Calque, les points d’entrée et de sortie sont exprimés en repères temporels de calque. Dans le panneau Montage, les points d’entrée et de sortie sont exprimés en repères temporels de composition. La durée est identique dans les deux cas (sauf si le remappage temporel et l’extension temporelle sont activés pour le calque).

Vous pouvez étendre de nombreux types de calque de la durée de votre choix en déplaçant leurs points d’entrée et de sortie. Cette possibilité s’applique aux calques remappés, aux calques de forme, aux calques créés à partir d’images fixes, aux calques de caméra, aux calques de lumière et aux calques de texte. Si vous étendez un calque et que certaines valeurs deviennent négatives (en dessous du repère temporel zéro), plusieurs signes dièse apparaissent en bas de la bande du calque pour indiquer les parties du calque situées en zone négative. Cette indication est utile si vous avez appliqué au calque des effets, tels que Laboratoire de particules ou Eclat, qui utilisent l’instant du calque pour calculer leur résultat.

Ressources en ligne relatives au raccordement, à l’extension et à la modification des calques

Jeff Almasol propose, sur son site Web redefinery, un script qui crée un panneau dont les commandes permettent de déplacer dans le temps des combinaisons variées d’éléments (point d’entrée ou de sortie d’un calque, images sources d’un calque, images clés et repères).

Raccordement ou extension de calques dans le panneau Montage

Déplacement du point de sortie sur la bande de durée d’un calque
Déplacement du point de sortie sur la bande de durée d’un calque

  1. Sélectionnez un ou plusieurs calques dans le panneau Montage.
  2. Utilisez l’une des méthodes suivantes :
    • Faites glisser l’une des extrémités de la bande de durée du calque.

    • Déplacez le repère d’instant courant à l’endroit où vous souhaitez placer le point d’entrée ou le point de sortie. Pour définir le point d’entrée sur l’instant courant, appuyez sur les touches Alt + [ (Windows) ou Option + [ (Mac OS). Pour définir le point de sortie sur l’instant courant, appuyez sur les touches Alt + ] (Windows) ou Option + ] (Mac OS).

Raccordement ou extension d’un calque dans le panneau Calque

  • Ouvrez le calque dans le panneau Calque et faites glisser l’une des extrémités de la bande de durée du calque.
  • Dans le panneau Calque, déplacez le repère d’instant courant à l’endroit où le métrage doit commencer ou se terminer, puis cliquez sur le bouton Entrée ou Sortie pour définir le point d’entrée ou de sortie sur l’instant courant.

Modification rapide d’un calque

Après avoir raccordé un calque créé à partir d’un métrage animé, une bande de modification rapide apparaît en clair ; cette bande représente les images du métrage que vous excluez de la composition. Ce rectangle clair n’apparaît pas pour un calque raccordé basé sur un métrage fixe. Vous pouvez choisir les images lues au cours d’une durée raccordée en faisant glisser la bande de modification rapide. Les points d’entrée et de sortie du calque ne sont pas affectés.

Si vous déplacez uniquement le point d’entrée ou le point de sortie d’un calque, les images clés ne bougent pas. Déplacer la bande de durée du calque par glissement affecte toutes les images clés. Déplacer la bande de modification rapide par glissement affecte les images clés sélectionnées uniquement.

Remarque :

Le but de la modification rapide est généralement de déplacer certaines images clés avec le métrage source (images clés de masque, par exemple). D’autres images clés ne doivent pas être déplacées dans le temps. Appuyez sur les touches Maj + F2 pour désélectionner les images clés et sélectionner uniquement le calque.

  • Faites glisser la bande de modification rapide vers la droite ou la gauche.
  • Faites glisser le calque vers la gauche ou la droite à l’aide de l’outil Déplacement arrière (Point d’ancrage).

Suppression partielle de la durée d’un calque

  1. Dans le panneau Montage, définissez la zone de travail sur la partie du calque à supprimer : déplacez le repère d’instant courant à l’endroit où la zone de travail doit commencer et appuyez sur la touche B. Déplacez le repère de temps à l’endroit où la zone de travail doit se terminer, puis appuyez sur la touche N.
  2. Utilisez l’une des méthodes suivantes :
    • Sélectionnez les calques dont vous souhaitez supprimer une section.

    • Sélectionnez l’option de verrouillage pour les calques non concernés par l’extraction. Appuyez sur la touche F2 pour désélectionner tous les calques.

    Remarque :

    si aucun calque n’est sélectionné, l’opération suivante supprime la section de tous les calques déverrouillés.

  3. Utilisez l’une des méthodes suivantes :
    • Pour supprimer la zone et laisser un écart de même durée que la zone supprimée, choisissez Edition > Prélever la zone de travail.

    • Pour supprimer la zone, choisissez Edition > Extraire la zone de travail. L’écart est fermé par suppression et raccord.

Mise en place ou déplacement d’un calque dans le temps

La bande de durée du calque offre une représentation visuelle de la durée du calque. Les colonnes Entrée, Sortie et Durée du panneau Montage offre une représentation numérique de la durée du calque.

Remarque :

pour choisir les colonnes à afficher dans le panneau Montage, sélectionnez Colonnes dans le menu du panneau ou cliquez avec le bouton droit de la souris (Windows) ou cliquez en maintenant la touche Contrôle enfoncée (Mac OS) sur l’en-tête d’une colonne.

Ces procédures déplacent l’intégralité du calque dans le temps.

  • Pour définir le point d’entrée ou de sortie par des valeurs numériques, cliquez sur la valeur souhaitée dans la colonne Entrée ou Sortie du calque dans le panneau Montage.
  • Pour déplacer le point d’entrée ou de sortie à l’instant présent, cliquez sur la valeur souhaitée dans la colonne Entrée ou Sortie du calque du panneau Montage tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée.
  • Pour déplacer les points d’entrée des calques sélectionnés au début de la composition, appuyez sur les touches Alt + Origine (Windows) ou Option + Origine (Mac OS).
  • Pour déplacer le point de sortie des calques sélectionnés à la fin de la composition, appuyez sur les touches Alt + Fin (Windows) ou Option + Fin (Mac OS).
  • Pour avancer les calques sélectionnés d’une image, appuyez sur les touches Alt + Pg. suiv (Windows) ou Option + Pg. suiv (Mac OS). Pour avancer les calques sélectionnés de 10 images, appuyez sur les touches Alt + Maj + Pg. suiv (Windows) ou Option + Maj + Pg. suiv (Mac OS).
  • Pour reculer les calques sélectionnés d’une image, appuyez sur les touches Alt + Pg. préc (Windows) ou Option + Pg. préc (Mac OS). Pour reculer les calques sélectionnés de 10 images, appuyez sur les touches Alt + Maj + Pg. préc (Windows) ou Option + Maj + Pg. préc (Mac OS).
  • Pour déplacer l’intégralité du calque dans le temps, faites glisser la bande de durée du calque vers la gauche ou la droite. Pour aligner la bande de durée du calque sur des points spécifiques dans le temps (par exemple, des repères ou le début et la fin de la composition), faites glisser tout en appuyant sur la touche Maj.

Remarque :

lorsque vous faites glisser un calque dans le panneau Montage, le panneau Info affiche le nom, la durée, la modification temporelle et les points d’entrée et de sortie du calque.

Bande de durée avant et après glissement
Bande de durée avant et après glissement

Jeff Almasol propose, sur son site Web redefinery, un script permettant de déplacer en groupe des calques sélectionnés, le groupe étant aligné sur un instant précis de la composition.

Agencement séquentiel de calques dans le temps

L’assistant d’image clé Calques de séquence permet de réorganiser automatiquement les calques sous la forme d’une séquence. Lors de l’utilisation de cet assistant, le premier calque sélectionné reste à sa position temporelle initiale, tandis que les autres calques sélectionnés sont repositionnés dans le panneau Montage, conformément à leur ordre de sélection.

Calques sélectionnés dans le panneau Montage
Calques sélectionnés dans le panneau Montage (en haut) et calques réorganisés sous forme de séquence avec utilisation de l’assistant d’image clé Calques de séquence (en bas)

Chevauchement de calques
En cas de chevauchement des calques, des images clés d’opacité peuvent être définies automatiquement pour créer un fondu enchaîné.

Pour qu’un calque soit inclus dans une séquence, sa durée doit être inférieure à la durée de la composition, de manière à laisser suffisamment de temps pour les autres calques (voir Raccordement, extension ou modification rapide d’un calque).

  1. Dans le panneau Montage, maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée et sélectionnez les calques de manière séquentielle, en commençant par celui qui doit s’afficher le premier.
  2. Choisissez Animation > Assistant d’image clé > Calques de séquence.
  3. Dans la boîte de dialogue Calques de séquence, Utilisez l’une des méthodes suivantes :
    • Pour disposer les calques bout à bout, laissez l’option Recouvrement désélectionnée.

    • Pour que les calques se chevauchent, sélectionnez l’option Recouvrement, entrez la durée de chevauchement requise, puis sélectionnez une transition. Sélectionnez l’option Fondu enchaîné des calques avant et arrière pour utiliser la transparence des calques sélectionnés ; sinon, choisissez l’option Fondu calque avant.

    • Pour laisser un espace entre les calques, sélectionnez l’option Recouvrement et entrez une durée négative.

Copie ou duplication d’un calque

Lorsque vous copiez un calque, vous copiez toutes ses propriétés, y compris les effets, images clés, expressions et masques.

Dupliquer un calque est un moyen rapide de copier et coller un calque à l’aide d’une seule commande. Lorsqu’il s’agit d’un calque avec cache par approche, l’ordre relatif du calque et du cache est préservé.

Lorsque vous collez des calques, ceux-ci sont placés dans l’ordre dans lequel vous les avez sélectionnés. Le premier calque sélectionné est le dernier placé et se retrouve ainsi sur le dessus de la pile de calques. Si vous sélectionnez des calques en partant du haut, ils sont empilés de la même manière une fois collés.

Remarque :

Si un composant du calque (masque ou image clé, par exemple) est sélectionné lors de la copie, seul ce composant est copié. Avant de copier, appuyez sur Maj+F2 pour désélectionner tous les composants d’un calque et maintenir sélectionné le calque proprement dit.

  • Pour copier les calques sélectionnés et placer les points d’entrée des copies au niveau de l’instant présent, choisissez Edition > Copier et appuyez sur les touches Ctrl + Alt + V (Windows) ou Commande + Option + V (Mac OS).
  • Pour copier les calques sélectionnés et placer les copies à la position temporelle des originaux, choisissez Edition > Copier, puis Edition > Coller.

Remarque :

Pour placer les copies au sommet de la pile de calques dans le panneau Montage (et non juste au-dessus des originaux), appuyez sur la touche F2 pour désélectionner les originaux avant de coller les copies.

  • Pour dupliquer les calques sélectionnés, choisissez Edition > Dupliquer ou appuyez sur les touches Ctrl + D (Windows) ou Commande + D (Mac OS).

Scission d’un calque

Dans le panneau Montage, vous pouvez scinder un calque à n’importe quel endroit, de manière à créer deux calques indépendants. La scission d’un calque est plus rapide que la duplication et le raccordement d’un calque, par exemple lorsque vous devez modifier l’ordre d’empilement d’un calque au sein d’une composition.

Remarque :

sélectionnez Créer des calques scindés au-dessus du calque original pour que les nouveaux calques scindés apparaissent au-dessus du calque original dans le panneau Montage (Edition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS)). Désélectionnez cette option pour qu’ils apparaissent en dessous.

  1. Sélectionnez un ou plusieurs calques.
  2. Déplacez le repère d’instant courant à l’endroit où vous souhaitez scinder les calques.
  3. Choisissez Edition > Scinder le calque.

Lorsque vous scindez un calque, les deux calques obtenus contiennent toutes les images clés du calque d’origine, à leur position d’origine. L’ordre des caches par approche appliqués au calque demeure inchangé, au-dessus du calque.

Une fois un calque scindé, la durée du calque d’origine se termine à l’instant de scission, et le nouveau calque démarre à ce même instant.

Si aucun calque n’est sélectionné lorsque vous choisissez Edition > Scinder le calque, tous les calques sont scindés à l’instant courant.

Paul Tuersley propose, sur le forum AE Enhancers, un script permettant de scinder des calques à l’emplacement de repères de calque.

Lloyd Alvarez propose, sur son site Web After Effects Scripts, un script qui détecte automatiquement les points de montage dans un calque de métrage et le scinde en autant de calques qu’il y a de points (ou place un repère de calque sur chacun des points de montage).

Options d’orientation automatique

Les options d’orientation automatique de chaque calque (Calque > Géométrie > Orientation automatique) indiquent dans quelle mesure leur orientation dépend des trajectoires, des points ciblés et des caméras.

Désactivé

Le calque pivote librement, indépendamment de la trajectoire, du point ciblé ou des autres calques.

Orienter sur le chemin

Le calque est placé dans la direction de la trajectoire. Vous pouvez utiliser cette option pour reproduire, avec une caméra, la perspective d’un conducteur qui regarde la route devant lui.

Orienter vers la caméra

Le calque est toujours placé face à la caméra active. Cette option est disponible pour les Calques 3D. Elle n’est pas disponible pour les caméras, les lumières et les calques 2D. Les calques de texte 3D sont dotés d’une option supplémentaire, Orienter chaque caractère indépendamment, qui oriente chaque caractère autour de son point d’ancrage individuel. La sélection de cette option active les propriétés 3D par caractère d’un calque de texte, si elles ne sont pas déjà actives (voir Propriétés de texte 3D par caractère.)

Orienter vers le point ciblé

La caméra et la lumière sont toujours orientées vers le point ciblé. Cette option est uniquement disponible pour les calques de caméras et de lumières (voir Caméras, lumières et points ciblés.)

Remarque :

si vous spécifiez une option d’orientation automatique pour un calque, puis modifiez les propriétés d’orientation ou de rotation X, Y ou Z du calque, son orientation est décalée de la même valeur. Par exemple, vous pouvez activer l’option Orienter sur le chemin d’une caméra, puis faire pivoter la caméra de 90 degrés vers la droite pour représenter la perspective d’un passager qui regarde par la fenêtre d’une voiture pendant qu’elle avance.

L’orientation automatique vers le point ciblé se produit avant que les transformations Rotation et Orientation ne soient appliquées. Pour animer une caméra ou une lumière avec l’option Orienter vers le point ciblé pour regarder temporairement ailleurs que vers le point ciblé, animez les propriétés de transformation Rotation et Orientation.

Dan Ebberts propose, sur son site Web MotionScript, une expression qui oriente automatiquement un calque le long d’un seul axe. Cela se révèle particulièrement utile, par exemple, pour retourner des caractères latéralement afin de suivre le mouvement de la caméra, tout en les laissant verticaux.

Ressources supplémentaires relatives à la sélection et à la disposition des calques

Jeff Almasol propose, sur son site Web redefinery, un script qui crée un panneau dont les commandes permettent de déplacer dans le temps des combinaisons variées d’éléments (point d’entrée ou de sortie d’un calque, images sources d’un calque, images clés et repères).

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne