Problema

Dopo aver effettuato l’accesso a un determinato account utente su un computer Macintosh o con in esecuzione Windows 7 o successivi, un’applicazione Adobe si comporta in modo anomalo. Ad esempio, l’applicazione non si avvia, esegue comandi non correttamente, restituisce errori o si chiede in modo imprevisto. Questi problemi non si verificano se effettuate il login a un account utente diverso o nuovo.

Prima di iniziare

Mac OS

Prima di effettuare le operazioni descritte nel presente documento, create una copia di backup del disco di avvio.

Quando eseguite alcune delle operazioni qui descritte, nel Finder viene visualizzata una finestra di autenticazione. Quando viene visualizzata la finestra di autenticazione, immetti il nome utente e la password dell’account utente amministratore, quindi fai clic su OK.

Esistono varie possibili cause alla base dei comportamenti anomali specifici di un account. In questo documento vengono affrontate solo le cause più comuni. Per ulteriore assistenza nella risoluzione dei problemi relativi agli account utente, contatta il supporto di Apple.

Windows

Prima di effettuare le operazioni descritte nel presente documento, create una copia di backup dell'unità di sistema.

In alcuni casi queste attività avviano una finestra dialogo Controllo account utente che richiede l'autorizzazione a continuare. Leggete le informazioni riportate nella finestra di dialogo per decidere se continuare o meno. Se scegliete di annullare la richiesta, non sarà possibile proseguire con l'attività.

Per alcune delle operazioni riportate in questo documento è previsto l'uso di cartelle nascoste. Per impostazione predefinita, in Esplora risorse di Windows non vengono visualizzate le cartelle nascoste. Per rendere visibili le cartelle nascoste, consulta Visualizzazione di cartelle, estensioni, file nascosti | Windows XP, Vista, Windows 7.

Esistono varie possibili cause alla base dei comportamenti anomali specifici di un account. In questo documento vengono affrontate solo le cause più comuni. Per ulteriore assistenza con la risoluzione dei problemi relativi agli account utente, contatta il produttore del computer o accedi alla pagina http://support.microsoft.com dell’assistenza Microsoft.

Soluzioni

Effettuate il login all'account utente nel quale l'applicazione Adobe presenta un comportamento anomalo. Eseguite quindi le seguenti operazioni, nell'ordine indicato:

Mac OS

1. Concedi autorizzazioni di lettura/scrittura nelle cartelle appropriate.

Accertati che l’account utente disponga di autorizzazioni di lettura/scrittura nelle seguenti cartelle:

  • /Applications/Adobe
  • /Applications/.AdobePatchFiles (nascosto, utilizza il comando Vai > Vai alla cartella)
  • /Applications/Utilities/Adobe
  • /Libreria/Application Support/Adobe
  • /Library/Preferences/com.adobe
  • /Utenti/[utente]/Library/Application Support/Adobe
  • /Users/[utente]/Library/Caches/Adobe
  • /Users/[utente]/Library/Caches/com.adobe
  • /Utenti/[utente]/Library/Preferences/Adobe
  • /Users/[utente]/Library/Preferences/com.adobe

Dopo aver concesso le autorizzazioni, per poter applicare le modifiche, esci dall’account utente e riaccedi o riavvia il computer.

2. Ricrea i file delle preferenze specifici per l'account dell'applicazione Adobe.

Le applicazioni Adobe memorizzano le impostazioni personalizzate dell'utente nei file delle preferenze. Per ciascun account utente è disponibile un insieme di file delle preferenze.

Quando un'applicazione Adobe mostra un comportamento anomalo solo in uno specifico account utente, uno dei file delle preferenze dell'applicazione potrebbe essere danneggiato. Potete imporre all'applicazione Adobe la creazione di file delle preferenze non danneggiati rinominando i file delle preferenze correnti. Alcune applicazioni Adobe memorizzano vari file delle preferenze in una cartella; in questo caso, potete rinominare la cartella.

Alcune applicazioni Adobe salvano i file delle preferenze sia in cartelle sia in file autonomi. Ad esempio, Adobe Photoshop CS4 utilizza sia un file delle preferenze denominato com.adobe.Photoshop.plist sia una cartella delle preferenze denominata Adobe Photoshop CS4 Settings. Per imporre a Photoshop CS4 la creazione di file delle preferenze non danneggiati, rinominate entrambi questi elementi. Ad esempio, rinominarli rispettivamente come Vecchio com.adobe.Photoshop.plist e Vecchia Adobe Photoshop CS4 Settings.

In generale, le applicazioni Adobe memorizzano i file e le cartelle delle preferenze in uno o più di questi percorsi:

  • /Utenti/[nome utente]/Library/Preferences
  • /Utenti/[nome utente]/Library/Preferences/Adobe
  • /Utenti/[nome utente]/Libreria/Application Support/Adobe

Importante: con il rilascio di Mac OS X 10.7, Apple ha reso la cartella Libreria utente nascosta per impostazione predefinita. Se hai bisogno di accedere ai file presenti nella cartella della libreria nascosta per risolvere problemi relativi ad Adobe, consulta Accesso ai file della libreria utente nascosti.

In alcune applicazioni Adobe, i file delle preferenze aggiuntivi vengono salvati in altri percorsi. Ad esempio, in Adobe Premiere Pro CS4 i file delle preferenze aggiuntivi vengono memorizzati in cartelle denominate Layouts, Settings e Styles. Questi file si trovano in /Utenti/[nome utente]/Documents/Adobe/Premiere Pro/4.0.

Per determinare i nomi e i percorsi esatti dei file e delle cartelle delle preferenze nell'applicazione Adobe in cui stai cercando di risolvere i problemi, visita la pagina www.adobe.com/it/support. Nella Knowledgebase del supporto, cercate il termine "preferenze" seguito dal nome e dalla versione dell'applicazione. Quindi consultate il documento sulla risoluzione di errori di sistema o di blocchi, o altri documenti elencati nei risultati della ricerca.

Per ricreare i file delle preferenze per un'applicazione Adobe, eseguite queste operazioni:

  1. Uscite dall'applicazione Adobe.
  2. Rinominate i file e le cartelle delle preferenze dell'applicazione Adobe.
  3. Aprite l'applicazione Adobe. L'applicazione crea i file delle preferenze.

Dopo che i file e le cartelle delle preferenze sono stati ricreati, provate a riprodurre il comportamento anomalo.

Se il problema continua a verificarsi, la causa non è un file delle preferenze danneggiato. Per ripristinare le impostazioni personalizzate dell'account utente, eliminate i nuovi file e cartelle delle preferenze. Ripristinate quindi i nomi originali di tutti gli elementi in precedenza rinominati.

Se il problema non si verifica più, la causa era un file delle preferenze danneggiato. Tuttavia, le impostazioni personalizzate associate ai file delle preferenze precedenti vengono perse.

3. Risolvi i problemi relativi ai font specifici dell'account.

In Mac OS, i font possono essere installati per tutti gli account utente o solo per uno specifico account utente. I file dei font specifici per un account sono salvati in /Utenti/[nome utente]/Library/Fonts.

Quando riscontrate un comportamento anomalo di un'applicazione Adobe solo con un particolare account, la causa potrebbe essere un file di font danneggiato che è installato solo per l'account in questione.

Utilizzate l'applicazione Libro Font, inclusa in Mac OS X, per disattivare temporaneamente tutti i font specifici di un account. Dopo aver disattivato i font specifici di un account, cercate ed eliminate il file della cache dei font Adobe. Seguite la procedura descritta di seguito.

  1. Chiudete tutte le applicazioni aperte.
  2. Se normalmente utilizzate una utilità di gestione dei font di terze parti per attivare o disattivare i font, disabilitate temporaneamente tale utilità. Per istruzioni, consultate la relativa documentazione.
  3. Aprite Libro Font. Per impostazione predefinita, Libro Font si trova nella cartella Applicazioni.
  4. Nella colonna Collezione, selezionate Utente. Effettuate una delle seguenti operazioni:

    • Se la colonna Font è vuota, non sono installati font specifici per questo account utente. Ignora le istruzioni seguenti e passa direttamente al punto 3.
    • Se viene visualizzato almeno un font nella colonna relativa, scegli Modifica > Disabilita “Utente”.
  5. Nel Finder, scegli File > Trova. Vengono visualizzate opzioni di ricerca nella parte superiore della finestra Finder in primo piano.

  6. Cercate i file della cache dei font Adobe impostando le opzioni di ricerca come segue:

    • Mac OS X v.10.4.x: nella riga superiore delle opzioni di ricerca, selezionate Inizio. Nella seconda riga, scegliete Nome e Comincia con dai menu a comparsa. Digitate AdobeFnt nella casella di testo accanto a Comincia con.
    • Mac OS X v.10.5.x e versioni successive: nella riga superiore delle opzioni di ricerca, seleziona il nome dell’account utente (mostrato tra virgolette). Nella seconda riga, scegliete Nome e Comincia con dai menu a comparsa. Digitate AdobeFnt nella casella di testo accanto a Comincia con.
  7. Nei risultati di ricerca, elimina tutti i file il cui nome inizia con AdobeFnt e termina con .lst.

  8. Aprite l'applicazione Adobe e provate a riprodurre il problema.

Se il problema si verifica nuovamente, la causa non è un font specifico dell'account. Abilita nuovamente i font specifici dell'account aprendo Libro Font e selezionando Utente nella colonna Collezione, quindi Modifica > Abilita. Passa ora al punto 3.

Se il problema non si verifica più, la causa è un font specifico dell'account. Per identificare il file di font specifico che sta causando il problema, effettuate quanto segue:

  1. Aprite Libro Font.

  2. Nella colonna Collezione, seleziona Utente.

  3. Nella colonna Font, seleziona uno dei font disabilitati.

  4. Scegli Modifica > Abilita [nome font].

  5. Aprite l'applicazione Adobe e provate a riprodurre il problema. Effettuate una delle seguenti operazioni:

    • Se il problema persiste, chiudete l'applicazione Adobe e ripetete le fasi da 3 a 5.
    • Se il problema non si verifica più, la causa è il font che avete appena riabilitato. Disabilitate questo font oppure eliminatelo e contattate il creatore del font per ottenere un file sostitutivo.

4. Elimina i file della cache Adobe specifici dell'account.

Alcune applicazioni Adobe creano file di dati temporanei, conosciuti come file della cache. Se sono presenti in un account utente troppi file della cache o file della cache danneggiati, l'applicazione Adobe può dare luogo a comportamenti anomali.

Seguite la procedura descritta di seguito.

  1. Chiudete tutte le applicazioni di Adobe.

  2. Nel Finder, accedi a /Utenti/[nome utente]/Library/Caches.

  3. Nella cartella Caches, elimina la cartella Adobe.

  4. Elimina tutte le cartelle dentro Caches il cui nome fa riferimento all’applicazione Adobe in cui hai riscontrato problemi.

  5. Eliminate tutte le cartelle dentro Caches il cui nome fa riferimento a componenti dell'applicazione Adobe in cui avete riscontrato problemi. Ad esempio, se avete problemi con Photoshop CS4, eliminate anche la cartella Adobe Camera Raw nella cartella Caches.

  6. Apri l’applicazione Adobe e prova a riprodurre il problema.

Se il problema persiste, passate al punto successivo.

5. Risolvi i problemi relativi agli elementi di login specifici dell'account.

Gli elementi di login sono applicazioni o documenti che si aprono automaticamente quando accedete a un account utente. Si aprono automaticamente anche quando avviate il computer, se avete abilitato il login automatico. Alcuni elementi di login vengono nascosti dopo essere stati aperti. Quando un'applicazione Adobe presenta un comportamento anomalo in un account specifico, potrebbe essere presente un elemento di login mal funzionante, danneggiato o incompatibile con l'applicazione Adobe.

Per stabilire se uno degli elementi di login dell'account utente è la causa del problema dell'applicazione Adobe, eseguite quanto segue:

  1. Scegli il menu Apple > Esci [nome utente].

  2. Nella finestra di dialogo di conferma, fai clic su Esci. Dopo pochi istanti, viene visualizzata la finestra di accesso.

  3. Nella finestra di login, seleziona il nome dell’account utente nel quale si riscontrano problemi.

  4. Digita la password dell’account nella casella di testo Password; manon premere invio e non selezionare Accedi.

  5. Tieni premuto il tasto Maiusc e fai clic su Accedi. Rilasciate il tasto delle maiuscole quando viene visualizzato il Dock. Gli elementi di login sono disattivati fino a quando non eseguite il logout (o riavviate il computer).

  6. Apri l’applicazione Adobe e prova a riprodurre il problema.

Se il problema continua a verificarsi, la causa non è un elemento di login. Attiva nuovamente gli elementi di accesso effettuando il logout (tramite menu Apple > Logout di [nome utente]). In seguito, effettuate nuovamente il login allo stesso account senza tenere premuto il tasto delle maiuscole. Passa ora al punto 5.

Se il problema non si verifica più, la causa è un elemento di login. Per identificare l'elemento di login specifico che sta causando il problema, effettuate quanto segue:

Se il problema si verifica nuovamente, la causa non è un font specifico dell'account. Abilita nuovamente i font specifici per l’account aprendo Libro Font, selezionando Utente nella colonna Collezione, quindi scegliendo Modifica > Abilita. Passa ora al punto 3.

Se il problema non si verifica più, la causa è un font specifico dell'account. Per identificare il file di font specifico che sta causando il problema, effettuate quanto segue:

  1. Scegliete il menu Apple > Logout di [nome utente].

  2. Accediallostesso account. Non tenere premuto il tasto Maiusc.

  3. Scegli menu Apple > Preferenze di sistema.

  4. Nella finestra Preferenze di sistema, fai clic su Account.

  5. Se l’icona nella parte inferiore della finestra raffigura un lucchetto chiuso, fai clic sull’icona ed esegui l’autenticazione.

  6. Seleziona l’account utente in cui si sono verificati i problemi.

  7. Fai clic sulla scheda degli elementi di accesso.

  8. Crea un elenco degli elementi di accesso correnti.

  9. Seleziona un elemento di accesso e premi Elimina.

  10. Aprite l'applicazione Adobe e provate a riprodurre il problema. Effettuate una delle seguenti operazioni:

    • Se il problema persiste, chiudete l'applicazione Adobe e ripetete le fasi da 9 a 10.
    • Se il problema non si verifica più, la causa è l'elemento di login che avete appena eliminato. Contattate il creatore dell'elemento di login per chiedere se è disponibile una versione aggiornata. Ripristinate gli altri elementi di login trascinando le rispettive icone nell'area Elementi login delle Preferenze di Sistema. In alternativa, reinstallate l'applicazione associata all'elemento di login.

6. Ripristina le impostazioni di accesso nella cartella Libreria dell'account utente.

Effettuate queste operazioni solo se l'account che presenta problemi ha diritti di amministratore ed è dotato di una password.

Tutti i file e le cartelle di un volume Mac OS X prevedono impostazioni di proprietà e autorizzazioni in stile Unix. Queste impostazioni determinano quali account utente hanno accesso, o non hanno accesso, ai file e alle cartelle.

Un'applicazione Adobe potrebbe mostrare un comportamento anomalo in un determinato account se le relative impostazioni di accesso per la cartella (o sottocartella) Libreria sono danneggiate o limitate in modo non corretto. Potete utilizzare i comandi Unix chmod e chown per correggere tali impostazioni. Seguite la procedura descritta di seguito.

  1. Nel Finder, scegli Vai > Inizio. La finestra del Finder in primo piano mostra la cartella Inizio dell'account utente in questione. Annotate il nome nel titolo di questa finestra. Questo nome corrisponde al “nome utente abbreviato” per l’account utente. (Questonome utente abbreviatoè necessario per completare il punto 3.)

  2. Apri l’applicazione Terminale, posizionata per impostazione predefinita in /Applicazioni/Utility.

  3. Utilizzando uno dei comandi seguenti come modelli, digitate un comando nella finestra di Terminale e premete Invio. Dopo aver premuto Invio alla fine del comando, vi viene chiesta la password. Digitate la password dell'account utente e premete nuovamente Invio. Mentre digitate i caratteri della password, non sarà visibile alcuna risposta dal sistema (ad esempio, l'inserimento di asterischi). Questo comportamento è normale.

    Importante: i comandi seguenti sono modelli e non corrispondono ai comandi da digitare. Nei comandi da digitare, sostituite nome_utente con il nome utente abbreviato identificato al punto 1. Digitate il nome utente abbreviato in lettere minuscole. In Mac OS X v10.4.x, digitate due volte il nome utente abbreviato, separando le due istanze con un segno di due punti. In Mac OS X v.10.5.x, digitate il nome utente abbreviato seguito da un segno di due punti e dalla parola staff.

    Comando modelli per Mac OS X v.10.4.x:


    sudo chown-R username:username~/Library

    Comando modello per Mac OS X v.10.5.x:

    sudo chown-R username:staff~/Library

  4. Digitate i comandi seguenti esattamente come sono, quindi premete Invio.

    sudo chmod -R 700 ~/Library

  5. Uscite da Terminale.

  6. Apri l’applicazione Adobe e prova a riprodurre il problema.

Se il problema persiste, passate al punto successivo.

7. Ripara il disco di avvio.

Se si verificano danni sul disco che riguardano solo uno specifico account utente, l'applicazione Adobe potrebbe mostrare un comportamento anomalo per tale account.

Seguite la procedura qui descritta se disponete del disco di installazione di Mac OS X fornito con il computer. Se non disponete del disco, potete riparare il disco di avvio utilizzando il comando fsck  nel Terminale. Potete anche utilizzare una utility di riparazione del disco di terze parti. Per istruzioni su come utilizzare il comando fsck, vedete l'articolo TS1417 nel sito Web del supporto Apple. Per istruzioni su come utilizzare la utility di riparazione del disco di terze parti, consultate la relativa documentazione.

  1. Inserite il disco di installazione Mac OS X nell'unità ottica del computer.
  2. Scegliete menu Apple > Riavvia.
  3. Quando sentite il suono di avvio, tenete premuto il tasto C della tastiera.
  4. Quando viene visualizzata la finestra di avvio con la barra di avanzamento, rilasciate il tasto C.
  5. Se il programma di installazione di OS X chiede di selezionare una lingua, selezionate la vostra lingua.
  6. Quando è disponibile il menu Installer (nell'angolo in alto a sinistra dello schermo), scegliete Installer > Utility Disco.
  7. In Utility Disco, selezionate il disco di avvio a sinistra.
  8. Fai clic sulla scheda di assistenzaadestra.

  9. Fai clic su Ripara disco.

  10. Se al termine della procedura di riparazione viene indicato che sono stati corretti degli errori del disco, ripetete le operazioni al punto 9. Se al termine della procedura di riparazione non vengono segnalati errori rilevati, aprite l'applicazione Adobe e provate a riprodurre l'errore.

Se il problema persiste, passate al punto successivo.

8. Utilizza un nuovo account utente.

Se l'applicazione continua a dare origine a comportamenti anomali in un particolare account, Adobe consiglia di copiare (o spostare) tutti i file personali in un nuovo account utente. Utilizzate quindi il nuovo account come account normale.

Per assistenza nella copia di file personali in un nuovo account, contatta l’assistenza Apple.

Windows

1. Concedi autorizzazioni di lettura/scrittura nelle cartelle appropriate.

Accertati che l’account utente disponga di autorizzazioni di lettura/scrittura nelle seguenti cartelle:

  • C:\Programmi\Adobe
  • C:\Programmi\Common Files\Adobe
  • C:\Programmi (x86)\Adobe
  • C:\Programmi (x86)\Common Files\Adobe
  • C:\ProgramData\Adobe
  • C:\Utenti\\AppData\Roaming\Adobe
  • C:\Utenti\\AppData\Roaming\com.adobe.
  • C:\Utenti\\AppData\Local\Adobe
  • C:\Utenti\\AppData\LocalLow\Adobe
  • C:\Utenti\\AppData\Local\VirtualStore\Program Files\Common Files\Adobe

2. Ricrea i file delle preferenze specifici per l'account dell'applicazione Adobe.

Le applicazioni Adobe memorizzano le impostazioni personalizzate dell'utente nei file delle preferenze. Per ciascun account utente è disponibile un insieme di file delle preferenze.

Quando l'applicazione Adobe presenta un comportamento anomalo solo in uno specifico account utente, uno dei file delle preferenze dell'applicazione potrebbe essere danneggiato. Per creare file di preferenze non danneggiati con l'applicazione Adobe, rinominare la cartella che contiene i file di preferenze.

Ad esempio, Adobe Premiere Pro CS4 salva i file delle preferenze in una cartella definita 4.0, posizionata in C:\Utenti\[nome utente]\AppData\Roaming\Adobe\Premiere Pro. Per fare in modo che i file delle preferenze vengano ricreati in Adobe Premiere Pro CS4, rinominate la cartella 4.0 (assegnandole ad esempio il nome Old 4.0).

In genere nelle applicazioni Adobe i file delle preferenze vengono archiviati in una delle seguenti posizioni o in entrambe:

  • C:\Utenti\[nome utente]\AppData\Roaming\Adobe
  • C:\Utenti\[nome utente]\AppData\Local\Adobe

In alcune applicazioni Adobe, i file delle preferenze aggiuntivi vengono salvati in altri percorsi. Ad esempio, Adobe Premiere Pro CS4 memorizza i file delle preferenze nelle cartelle denominate Stili e Layout, posizionate in C:\Utenti\[nome utente]\Documents\Adobe\Premiere Pro\4.0.

Per determinare i nomi esatti e le posizioni delle cartelle delle preferenze per l’applicazione Adobe di cui stai cercando di risolvere i problemi, accedi a www.adobe.com/it/support. Nella Knowledgebase del supporto, cerca il termine “preferenze” seguito dal nome e dalla versione dell’applicazione. Quindi, cercaneldocumento relativo agli errori di sistema o ai blocchi o in altri documenti elencati nei risultati di ricerca.

Per ricreare i file delle preferenze per un'applicazione Adobe, eseguite queste operazioni:

  1. Chiudete l'applicazione Adobe.

  2. Rinomina le cartelle delle preferenze dell’applicazione Adobe.

  3. Avviate l'applicazione Adobe. L'applicazione crea file delle preferenze non danneggiati.

Dopo aver ricreato i file delle preferenze, provate a riprodurre il comportamento anomalo.

Se il problema continua a verificarsi, la causa non è un file delle preferenze danneggiato. Per ripristinare le impostazioni personalizzate dell'account utente per l'applicazione Adobe, eliminate le nuove cartelle delle preferenze. Ripristinate quindi i nomi originali di tutte le cartelle che avevate rinominato.

Se il problema non si verifica più, la causa era un file delle preferenze danneggiato. Non sono associate impostazioni personalizzate ai precedenti file delle preferenze dell'account utente.

3. Elimina file temporanei specifici dell'account.

In alcune applicazioni Adobe i dati vengono archiviati in file temporanei. Un'applicazione Adobe può presentare un comportamento anomalo se il numero di file temporanei specifici dell'account è eccessivo, se tali file non sono aggiornati o sono danneggiati.

Per eliminare file temporanei, utilizzate l'utilità Pulitura disco. Vedete Delete temporary files using the Disk Cleanup utility (Windows 7 and Vista).

Per impostazione predefinita, l'utilità Pulitura disco non elimina i file presenti nella cartella Temp specifica dell'account utilizzati negli ultimi sette giorni. Potete eseguire una rimozione più completa dei file temporanei eliminando manualmente il contenuto della cartella Temp.

Dichiarazione di non responsabilità: l’eliminazione manuale della cartella Temp può causare problemi ad applicazioni di società diverse da Adobe. Procedete con cautela se decidete di eseguire questa operazione. Adobe non fornisce supporto per problemi che derivano dall'eliminazione manuale dei file della cartella Temp.

Per eliminare manualmente il contenuto della cartella Temp dell'account, procedete come segue:

  1. Chiudete tutte le applicazioni.

  2. Scegli Start > Programmi > Accessori. Fai clic con il pulsante destro del mouse sul Prompt dei comandi e scegli Esegui come amministratore.

  3. Nella finestra del Prompt dei comandi, digita il seguente comando esattamente come riportato di seguito, quindi premi Invio:

    del %temp%\*.* /s /q

    Nota: del è il comando per eliminare i file. %temp%\*.* è una combinazione della variabile ambientale per la posizione della cartella Temp dell’account con caratteri jolly che indicano tutti i file. /s estende il comando per includere tutti i file all’interno di sottocartelle. /q evita che Windows richieda la conferma di eliminazione di ciascun file.

  4. Nella finestra del prompt dei comandi viene visualizzato un elenco di file eliminati. L'elenco può includere file che non è stato possibile eliminare. È probabile che venga visualizzato il messaggio “Accesso negato” o “Impossibile accedere al file. Il file è utilizzato da un altro processo”. Questo comportamento è normale.

  5. Chiudi la finestra del Prompt dei comandi.

Dopo aver eliminato i file temporanei, aprite l'applicazione Adobe e provate a riprodurre il problema.

Se il problema persiste, passate al punto successivo.

4. Risolvi i problemi di avvio specifici dell'account.

Gli elementi di avvio sono applicazioni o documenti che si aprono automaticamente quando accedete a un account utente. Quando un'applicazione Adobe si comporta in modo anomalo in un account, è possibile che uno degli elementi di avvio dell'account non funzioni correttamente, che sia danneggiato o non sia compatibile con l'applicazione in uso.

Per stabilire se uno degli elementi di avvio dell'account utente è la causa del problema dell'applicazione Adobe, procedete come segue:

  1. In Esplora risorse di Windows, accedi a C:\Utenti\[nome utente]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

  2. Effettuate una delle seguenti operazioni:

    • Se la cartella Esecuzione automatica è vuota o non è disponibile, l'account non dispone di elementi di avvio specifici per l'account. Ignora il resto dei passaggi e procedi al punto 4.
    • Se è disponibile almeno un elemento nella cartella Esecuzione automatica, create una cartella sul desktop. Rinominate la nuova cartella Holding.
  3. Sposta tutti gli elementi dalla cartella Esecuzione automatica alla cartella Holding creata.

  4. Scegli Start > Chiudi sessione.

  5. Accedi allo stesso account.

  6. Apri l’applicazione Adobe e prova a riprodurre il problema.

Se il problema persiste, la causa è un elemento di avvio specifico dell'utente. Potete spostare tutti gli elementi che si trovano nella cartella Holding in C:\Users\[nome utente]\AppData\Roaming\Microsoft\Windows\Menu Avvio\Programmi\Esecuzione automatica. Procedi al punto 4.

Se il problema non si verifica più, la causa è un elemento di avvio specifico dell'account. Per identificare l'elemento di avvio esatto che causa il problema, procedete come segue:

  1. Chiudete l'applicazione Adobe.

  2. Sposta uno degli elementi che si trova nella cartella Holding in C:\Utenti\[nome utente]\AppData\Roaming\Microsoft\Windows\Menu Start\Programmi\Esecuzione automatica.

  3. Scegli Start > Chiudi sessione.

  4. Accedi allo stesso account.

  5. Aprite l'applicazione Adobe e provate a riprodurre il problema. Effettuate una delle seguenti operazioni:

    • Se il problema persiste, ripetete i passaggi dall'1 al 5.
    • Se il problema non si verifica più, la causa è l'elemento di avvio che avete appena riabilitato. Rimuovetelo dalla cartella Esecuzione automatica e contattate il produttore dell'elemento di avvio per informazioni sulla disponibilità della versione aggiornata. Spostate gli elementi restanti dalla cartella Holding in C:\Users\[nome utente]\AppData\Roaming\Microsoft\Windows\Menu Avvio\Programmi\Esecuzione automatica.

5. Reimposta le impostazioni di accesso nelle cartelle dati applicazioni specifiche dell’account.

Completa questo passaggio solo se l’account che presenta problemi dispone di diritti di amministrazione e non si trovasuun dominio di rete.

Gli errori specifici dell'account possono verificarsi se l’account non dispone di diritti di accesso di lettura/scrittura completi alle cartelle con i file delle preferenze dell’applicazione Adobe e i file di dati specifici dell’utente.  Puoi utilizzare il comandoicaclsper reimpostare le impostazioni di accesso. Segui la procedura descritta di seguito:

  1. Chiudi tutte le applicazioni.

  2. Scegli Start > Programmi > Accessori. Fai clic con il pulsante destro del mouse sul Prompt dei comandi e scegli Esegui come amministratore. Viene visualizzata una finestra della riga di comando.

  3. Nella finestra della riga di comando, digitate ciascuno dei comandi esattamente come riportato di seguito. Premete Invio dopo ogni comando. 

    Importante: inserisci uno spazio prima e dopo ciascuna delle opzioni -- /T, /C e /grant -- in ogni comando.

    icacls "%userprofile%\AppData\Local" /T /C /grant "%username%":F

    icacls "%userprofile%\AppData\Local" /T /C /grant "%username%":F

    icacls "%userprofile%\AppData\Local" /T /C /grant system:F

    icacls "%userprofile%\AppData\Roaming" /T /C /grant system:F

  4. Chiudete la finestra della riga di comando.

  5. Apri l’applicazione Adobe e prova a riprodurre il problema.

Se il problema persiste, passate al punto successivo.

6. Create di nuovo la chiave Adobe nel registro Windows.

Dichiarazione di non responsabilità: questa operazione richiede la modifica del Registro di sistema Windows. Il Registro di sistema contiene informazioni relative al sistema fondamentali per il computer e le applicazioni. Prima di modificare il registro, eseguitene una copia di backup. Adobe non fornisce supporto per problemi derivanti da una modifica inappropriata del registro. Per ulteriori informazioni sul Registro di sistema di Windows o l’Editor del registro di sistema, consulta il sito di assistenza di Microsoft all’indirizzo http://support.microsoft.com.

  1. Chiudi tutte le applicazioni.

  2. Fai clic su Start. Tipo regedit nella casella di ricerca e premi Invio. Viene aperto l’Editor del Registro di sistema.

  3. Nel riquadro di sinistra dell’Editor del Registro di sistema, individua e seleziona la seguente chiave del registro di sistema:

    HKEY_CURRENT_USER\Software\Adobe.

  4. Seleziona File > Esporta.

  5. Nella finestra di dialogo Esporta file del Registro di sistema, seleziona l’opzione per il ramo selezionato in Intervallo di esportazione. Immetti un nome e una posizione per la chiave del registro di sistema di backup e fai clic su Salva.

  6. Fai clic con il pulsante destro del mouse sulla chiave Adobe e scegli Elimina.

  7. Nella finestra di dialogo di conferma di eliminazione della chiave, fai clic su OK.

  8. Chiudi l’Editor del registro di sistema.

  9. Apri l’applicazione Adobe e prova a riprodurre il problema.

Se il problema persiste, la causa non è una voce di registro danneggiata. È possibile ripristinare la copia di backup della chiave Adobe eseguendo la seguente operazione:

  1. Chiudete tutte le applicazioni.

  2. Fai clic su Start. Tipo regedit nella casella di ricerca e premi Invio. Viene aperto l’Editor del Registro di sistema.

  3. Nell’Editor del Registro di sistema, scegli File > Importa.

  4. Nella finestra di dialogo Importa file del Registro di sistema, seleziona la posizione della chiave di backup salvata nei passaggi precedenti. Seleziona il file e fai clic su Apri.

7. Ripara l'unità disco rigido del sistema.

Se si verificano danni sul disco che riguardano solo uno specifico account utente, l'applicazione Adobe potrebbe funzionare in modo non corretto per tale account.

Per riparare l’unità disco rigido del sistema, consulta Riparazione e deframmentazione dei dischi rigidi (Windows 7 e Vista).

Dopo aver riparato l'unità, aprite l'applicazione Adobe e tentate di riprodurre il problema. Se il problema persiste, passate al punto successivo.

8. Utilizza un nuovo account utente.

Se il comportamento anomalo dell'applicazione si verifica in un determinato account utente, copiate (o spostate) tutti i file personali in un account in cui il problema non si verifica. Utilizzate quindi il nuovo account come il consueto account.

Per assistenza con la copia di file personali in un nuovo account utente, contattate il produttore del computer. In alternativa vedete Guida e supporto tecnico Microsoft all'indirizzo http://support.microsoft.com.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online