Nastavení zalomení řádků pro korejský text

Naposledy aktualizováno 9. 11. 2026

Přečtěte si, jak ovládat zalomení řádků v korejském textu a vytvořit tak vyváženější a čitelnější rozvržení textu.

Korejské zalomení řádku kdekoli určuje, jak aplikace Illustrator zalamuje korejský text na konci řádku. Když je tato možnost vypnutá, k zalomení řádku dochází pouze mezi slovy oddělenými mezerami. Slova, která se nevejdou, se přesunou na další řádek. Když je tato možnost zapnutá, řádky se mohou zalamovat mezi slabikami hangul, což pomáhá omezit velké mezery mezi slovy. To je užitečné zejména u úzkých textových rámců nebo při práci se zarovnaným textem.

Korejské zalomení řádku kdekoli je ve výchozím nastavení vypnuté. Tuto možnost můžete zapnout nebo vypnout pro jednotlivé odstavce v možnostech Typ v nabídce panelu Odstavec.

Vyberte textový objekt, nebo klikněte do odstavce, chcete-li tuto možnost použít pouze na daný odstavec.

Vyberte Okno > Typ > Odstavec a otevřete panel Odstavec.

V panelu Odstavec vyberte možnost Další možnosti , čímž otevřete nabídku panelu, a poté zvolte Korejské zalomení řádku kdekoli.Zaškrtávací značka znamená, že je tato možnost zapnutá. Chcete-li ji vypnout, vyberte ji znovu.

Nabídka panelu Odstavec v aplikaci Illustrator s vybranou možností Korejské zalomení řádku kdekoli.

Uložte nastavení do stylu odstavců

Stav zapnutí nebo vypnutí možnosti Korejské zalomení řádku kdekoli se ukládá se styly odstavců, takže jeden styl může použít stejné chování zalomení řádků na více odstavců najednou.

Vyberte Okno > Text > Styly odstavců pro otevření panelu Styly odstavců.

Chcete-li uložit nový styl, vyberte možnost Vytvořit nový styl v dolní části panelu. Chcete-li aktualizovat existující styl, vyberte tento styl a poté v nabídce panelu zvolte Předefinovat styl.

Dvakrát klikněte na název stylu a otevřete Možnosti stylu odstavců, poté vyberte Nastavení složení pro východní Asii.

V části Nastavení složení korejského textu zaškrtněte nebo zrušte zaškrtnutí možnosti Korejské zalomení řádku kdekoli a poté vyberte OK.

Dialogové okno Volby stylu odstavce se zapnutou možností Korejské zalamování řádků kdekoli v části Nastavení východoasijské sazby.
Nastavit možnosti východoasijské sazby pro styl odstavců.

Zachování slov pohromadě pomocí volby Bez zalomení

I když je zapnutá možnost Korean Line Break Anywhere, můžete pomocí volby No Break zachovat vybraná slova nebo fráze pohromadě na jednom řádku.

Illustrator považuje označený text za jednu jednotku. Pokud se na konec řádku nevejde, přesune se celý výběr na další řádek.

Vyberte znaky, které chcete zachovat pohromadě, například jméno osoby nebo číslo s jednotkou (například 25 kg).

Vyberte možnost Window > Type > Character a otevřete panel Character.

Na panelu Character vyberte možnost More Options , čímž otevřete nabídku panelu, a potom zvolte možnost No Break.Zaškrtnutí znamená, že je možnost zapnutá. Opětovným výběrem ji vypnete.

Kreslicí plátna Adobe Illustrator zobrazující obtékání korejského textu s vypnutou a zapnutou volbou No Break vedle možnosti No Break na panelu Character.
Použití volby No Break z nabídky panelu Character k zachování vybraného korejského textu pohromadě.

Poznámka

Volba No Break zachová vybraný rozsah pohromadě jako jednu jednotku. Pokud je rozsah delší než jeden řádek textového rámečku, přesáhne přes rámeček a místo zalomení na další řádek se nezobrazí.

Použít pravidla Kinsoku na korejský text

Když je zapnutá možnost Korean Line Break Anywhere, zalomení řádků nemusí dodržovat pravidla Kinsoku. Chcete-li tato pravidla použít, vyberte sadu z nabídky Kinsoku Set na panelu Paragraph.Sady Kinsoku můžete také přizpůsobit svému rozvržení.

Otevřít soubory ve starších verzích

  • Otevření existujícího dokumentu v aplikaci Illustrator 31.0 nebo novější automaticky nezapne možnost Korean Line Break Anywhere a nezmění rozvržení.
  • Pokud otevřete dokument, který tuto možnost používá, ve verzi starší než Illustrator 31.0, uložené rozvržení se zachová. Pokud text upravíte ve starší verzi, může se zobrazit varování a rozvržení textu se může změnit.
  • Chcete-li rozvržení zachovat, upravte soubor v aplikaci Illustrator 31.0 nebo novější. Pokud ho musíte upravit ve starší verzi, pracujte s kopií a po úpravě souboru zkontrolujte rozvržení textu.