Generator-fout oplossen bij het starten van Adobe Photoshop

Laatst bijgewerkt op 29 okt. 2026

Leer hoe je de Generator-fout in Adobe Photoshop oplost door beveiligingsinstellingen te controleren, conflicterende plug-ins te verwijderen en logboeken te controleren.

Generator is een Node.js-app die de communicatie tussen Photoshop en Generator-plug-ins verzorgt. Het biedt de logica voor het maken van assets voor Exporteren als en Afbeelding-assets.

Wanneer je Photoshop start of Bestand > Exporteren > Exporteren als selecteert, verschijnt een dialoogvenster met de melding: "Er is een probleem met Generator. Sluit Photoshop en probeer het opnieuw. Als het probleem zich blijft voordoen, verwijder je plug-ins van derde partijen of probeer je Photoshop opnieuw te installeren."

Probeer de volgende oplossingen in volgorde uit.

Beveiligingssoftware blokkeert Generator

Beveiligings- of antivirussoftware kan communicatie van de Generator op poort 8010 blokkeren of voorkomen dat het node-proces wordt uitgevoerd.

Open je beveiligings- of antivirusinstellingen.

Voeg Photoshop toe aan de lijst met toegestane apps.

Zorg dat poort 8010 open is voor de Generator.

Voeg node.exe toe aan de lijst met toegestane apps op C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe in Windows.

Sta in macOS het node-proces toe op /Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node.

Sta in Windows toe dat Photoshop toegang heeft tot gecontroleerde mappen.

Start Photoshop opnieuw op en selecteer daarna Bestand > Exporteren > Exporteren als om Generator te testen.

Een plug-in van derde partijen conflicteert met Generator

Plug-ins van derde partijen in de map Generator van Photoshop kunnen onverenigbaar zijn met je huidige versie of conflicteren met de standaard plug-in Afbeelding-assets.

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

Maak een tijdelijke map op je desktop met de naam Disabled Generator Plug-ins.

Verplaats de mappen met plug-ins van derde partijen naar de tijdelijke map. Laat de standaard plug-in Afbeeldingsassets in de map Generator staan.

Start Photoshop en selecteer Bestand > Exporteren > Exporteren als.

Als de fout verdwenen is, voeg je de plug-ins één voor één weer toe en start je Photoshop na elke toevoeging opnieuw op totdat de fout terugkomt.

Laat de standaard Image Assets-plug-in in de map Generator staan.Verplaats alleen plug-ins die je afzonderlijk hebt geïnstalleerd.

Generator start niet op en je hebt die niet nodig

Als je Exporteren als of Image Assets niet gebruikt, schakel je Generator uit als tijdelijke oplossing.

Start Photoshop.

Selecteer in Windows Bewerken > Voorkeuren > Plug-ins. Selecteer in macOS Photoshop > Instellingen > Plug-ins.

Hef de selectie van Generator inschakelen op.

Selecteer OK en start Photoshop opnieuw.

Als je Bestand > Exporteren > Exporteren als selecteert, wordt Generator weer ingeschakeld. Als je Exporteren als nodig hebt, los de Generator-fout op in plaats van Generator uitgeschakeld te laten.

Generator-logboeken tonen opstartfouten

Generator-logboeken kunnen informatie bevatten over plug-ins die niet kunnen worden geladen of systeemproblemen die verhinderen dat Generator wordt gestart.

Navigeer in Windows naar C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator.

Navigeer in macOS naar /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator.

Open het meest recente Generator-logboek en zoek naar foutmeldingen.

Als de map Generator niet bestaat, controleer je of je schrijfrechten hebt voor de bovenliggende map.

Als je extra hulp nodig hebt, gebruik je de Adobe Log Collector Tool om diagnostische logboeken te verzamelen.

De AppData-map in Windows en de Library-map in macOS zijn standaard verborgen. Instructies voor het tonen van verborgen bestanden en mappen in Windows kunnen je helpen de Windows-logboeken te vinden.

Generator-fouten treden op bij Apple Silicon

Als de generator op een Mac met Apple silicon blijft mislukken, kan het uitvoeren van Photoshop met Rosetta helpen bepalen of de compatibiliteit met de native modus het probleem veroorzaakt.

Sluit Photoshop af.

Open in Finder Programma's en zoek Adobe Photoshop op.

Control-klik op Adobe Photoshop en selecteer vervolgens Info opvragen.

Selecteer Openen met Rosetta, start Photoshop vervolgens en test de Generator.

Als de fout aanhoudt, geef je de Generator-logboeken door wanneer je contact opneemt met Adobe Support voor hulp. Voor problemen met Exporteren als die geen verband houden met Generator, gebruik je de richtlijnen voor probleemoplossing bij exporteren en opslaan.