Adobe Acrobat PDFMaker (PDFMaker 工具列/標籤的「轉換為 Adobe PDF」按鈕) 是可以從 Microsoft Office 應用程式建立 PDF 檔案的增益集。此功能會隨 Acrobat Professional 和 Standard 一併安裝。

  • 在 MS Office 2003 及較早版本中,PDFMaker 會透過 Adobe PDF 印表機建立 PostScript 檔案。然後,Adobe PDF 印表機會連接 Adobe Acrobat Distiller 應用程式以建立 PDF 檔案。
  • 在 MS Office  200720102016365中,PDFMaker 會透過 AdobePDF Library 將 Microsoft Office 文件轉換為 PDF。
  • Acrobat Distiller 或 Adobe PDF 印表機亦可以獨立使用以建立 PDF 檔案。

本文件可協助您疑難排解從 Office 應用程式使用 Acrobat PDFMaker 建立 PDF 檔案時遇到的問題。雖然本文件針對 Microsoft Word 而撰寫,但大部分疑難排解程序也適用於 Microsoft PowerPoint 和 Microsoft Excel。

 

Windows 版的 Office 2016 或 Office 365 應用程式不提供 Acrobat 功能區

適用於 Office 2016 或 Office 365 版本的 Word、Excel 和 PowerPoint

請嘗試以下步驟以解決問題:

  1. 在 Word 圖示上按滑鼠右鍵,然後選擇「以系統管理員身分執行」

    如果您看見「使用者帳戶控制」提示,請按一下「是」

  2. 開啟空白文件 - 選擇「空白文件」範本,或者您也可以開啟現有的 Word 文件。

  3. 選擇「檔案」功能表中的「選項」,畫面會隨即顯示「Word 選項」對話框。

  4. 從選項清單中選擇「附加元件」。在「管理」下拉式功能表中,選取「COM 附加元件」,然後按一下「移至」

    Word 附加元件
  5. 在「COM 附加元件」對話框中,選取「Acrobat PDFMaker Office COM 附加元件」核取方塊 (若未選取的話),然後按一下「確定」

    PDFMaker Office COM 附加元件

PDFMaker 在 Windows 上搭配 Office 2016 和 Office 365 使用時當機

安裝 Office 2016 二月份更新後,Acrobat PDFMaker 在 Windows 上搭配 Office 2016 和 Office 365 使用時當機。

Adobe 正在調查此問題,並與 Microsoft 合作以盡快解決此問題。另外,如需建立 PDF,請參閱這裡的其他做法。

檢查 Microsoft Office 的 Acrobat 相容性

在您開始疑難排解前,請確定您執行的 Acrobat 版本與 Office 版本相容。如需詳細資訊,請參閱相容的網頁瀏覽器及 PDFMaker 應用程式 | Acrobat、Reader

疑難排解 Acrobat Distiller 及 Adobe PDF 印表機 (僅限 MS Office 2003 及較舊版本適用的 PDFMaker)

Acrobat PDFMaker (適用於 MS Office 2003 及較舊版本) 透過 Adobe PDF 印表機,隨後會使用 Acrobat Distiller 應用程式來轉換 Word 文件。因此,疑難排解的第一步就是要確定 Acrobat Distiller 是否正常運作:

嘗試從 Word 使用 Adobe PDF 印表機建立 PDF 檔案

  1. 在 Word 中開啟文件,然後選擇「檔案 > 列印」。
  2. 從「印表機名稱」選單上選擇「Adobe PDF」,然後按一下「確定」。

嘗試使用 Acrobat Distiller 應用程式建立 PDF

注意: 此方法不支援進階的 PDFMaker 功能,例如維護連結和文件結構。

  1. 開啟 Word 文件,然後選擇「檔案 > 列印」。
  2. 在「列印」對話方塊中,選取 PostScript 印表機 (例如 Adobe PDF 印表機),選取「列印至檔案」,然後按一下「確定」。

    PostScript (.ps 或 .prn) 檔案便會建立。

    注意: 如果您沒有 PostScript 印表機,您可以從 Adobe 網站下載 PostScript 印表機驅動程式。驅動程式安裝完畢後,請完成第 2 步。如果您選取 Adobe PDF 印表機,請取消選取「不要傳送字體至 Adobe PDF」以建立 PostScript 檔案。

  3. 在 Acrobat 中,選擇「進階 > Acrobat Distiller」。
  4. 從「預設值」清單選擇設定 (或維持預設值)。
  5. 選擇「檔案 > 開啟」,並在「檔案類型」選單選擇「所有檔案」,選取您建立的 PS 或 PRN 檔案,然後按一下「開啟」。
  6. 指定 PDF 檔案的名稱和位置,然後按一下「儲存」。
    • 如果 Acrobat Distiller 建立 PDF 檔案,請前往疑難排解 Acrobat PDFMaker
    • 如果 Acrobat Distiller 沒有建立 PDF 檔案,請前往下一步。
  7. 若使用 Windows (NT、2000、XP、Vista、7),請到以下資料夾開啟 messages.log 檔案: %AppData%\Adobe\Acrobat\Distiller [版本編號]

  8. 檢查 messages.log 檔案的疑難排解資訊:

    • 如果檔案顯示 Acrobat Distiller 無法建立 PDF 檔案的原因,請利用 Acrobat 說明與支援的搜尋文字方塊搜尋相關文件。例如,假設檔案列出了一個 PostScript 錯誤,請根據疑難排解 PostScript 錯誤的建議來疑難排解該錯誤。
    • 如果檔案沒有顯示 Acrobat Distiller 無法建立 PDF 檔案的原因,請建立一個只含有數個字詞的 Word 檔案。然後嘗試從該文件使用 Adobe PDF 印表機和 Acrobat Distiller 應用程式來建立 PDF 檔案:
    • 如果您可以從新文件建立 PDF 檔案,問題只會出在 PDFMaker。請前往疑難排解 Acrobat PDFMaker
    • 如果您無法從新文件建立 PDF 檔案,請從其他應用程式開啟該檔案,然後嘗試使用 Acrobat Distiller 建立 PDF 檔案。如果該問題發生在其他應用程式的檔案上,請重新安裝 Acrobat Distiller。如果該問題並非發生在其他應用程式的檔案上,請使用相關內容列出的文件以疑難排解特定行為,或者搜尋 Acrobat 說明。如果您需要進一步協助,請聯絡 Adobe 技術支援團隊。

疑難排解 Acrobat PDFMaker

如果您可以使用 Adobe PDF 印表機或 Acrobat Distiller 建立 PDF 檔案,但無法使用 Acrobat PDFMaker 建立檔案,問題可能出在 Acrobat PDFMaker 功能上。若要確定是否有任何功能造成您的問題,請停用它們,然後嘗試建立 PDF 檔案:

  1. 在 Word 中,選擇「Adobe PDF > 變更轉換設定」。
  2. 從「轉換設定」選單中選擇「最小檔案大小」。
  3. 按一下「Word」標籤,然後取消選取所有選項。
  4. 按一下「書籤」標籤,然後取消選取所有書籤選項。
  5. 按一下「安全性」標籤,然後取消選取所有安全性選項。
  6. 按一下「確定」。
  7. 嘗試建立 PDF 檔案:
  • 如果你無法建立 PDF 檔案,請前往疑難排解文件特定的問題
  • 如果您可以建立 PDF 檔案,請確定哪些功能造成問題: 啟用一個功能,然後嘗試建立 PDF 檔案。重複這個步驟直到問題再次出現為止。然後,建立一個只含有數個字詞的 Word 檔案。嘗試使用相同的 Acrobat PDFMaker 設定在該文件中建立 PDF 檔案:
  • 如果您可以從新文件建立 PDF 檔案,那麼這便屬於文件特定的問題。請前往疑難排解文件特定問題
  • 如果您無法從新文件建立 PDF 檔案,那應該是最近啟用的功能造成這問題。請重新安裝 Acrobat PDFMaker。如果問題仍然出現,請聯絡 Acrobat Support 支援團隊

疑難排解文件特定的問題

如果您確定這屬於文件特定的問題,請按以下步驟進行疑難排解。

只啟用文件使用的 Acrobat PDFMaker 功能

例如,如果文件只含有標題樣式「標題 1」和「標題 2」,請在 Acrobat PDFMaker 對話方塊中停用其他標題樣式。

在 Word 中切換至「一般」文件檢視,然後使用 Acrobat PDFMaker 建立 PDF 檔案

重新建立 Word 文件以排除任何損壞

執行下列一或多個步驟:

  • 將 Word 文件的內容複製並貼到新文件中,然後建立 PDF 檔案。
  • 選取文件中的所有文字並變更其字型,然後以新名稱儲存該文件。Word 會重寫文件,這樣可以排除與 Acrobat PDFMaker 衝突的元素。儲存文件後,您可以重新改變格式為您想要的字型。
  • 如果您建立文件的 Word 版本與建立 PDF 檔案的版本不同,請在文件上進行微幅變更,然後以新名稱儲存該文件。這個程序會強制 Word 重寫文件,這樣便有可能排除與 Acrobat PDFMaker 衝突的元素。

在文件中重新建立任何自訂的標題樣式,然後建立 PDF 檔案

找出文件中的衝突元素

  1. 建立 Word 文件。
  2. 將原始 Word 文件的一半內容複製至新的 Word 文件中。
  3. 使用 Acrobat PDFMaker 將新的 Word 文件轉換為 PDF。
  • 如果問題再次出現,代表新的 Word 文件出現衝突元素。若要進一步找出衝突元素,請重複第 1-3 步,並將第二個 Word 文件的一半內容複製至另一個新的 Word 文件中。
  • 如果問題沒有出現,代表原始 Word 文件中存在衝突元素。若要進一步找出問題,請重複第 1-3 步,並將原始 Word 文件的另一半內容複製至另一個新的 Word 文件中。如果文件的兩部分都正確轉換,請關閉其他正在執行的程式,包括 Office 應用程式。刪除 .tmp 檔案 (通常位於「Windows/Temp」資料夾中)。

重新安裝程式

移除 Acrobat 和 Office 或其他特定的 Office 應用程式 (Word、PowerPoint 或 Excel)。重新安裝 Office 或其他特定的 Office 應用程式,然後重新安裝 Acrobat。

若要移除 Acrobat,請使用「新增/移除程式」控制台。如需瞭解如何移除 Office 的資訊,請參閱 Office 文件或聯絡 Microsoft。

如果 Word 文件為受保護狀態,請移除保護

如需瞭解如何移除保護的資訊,請參閱 Office 文件或聯絡 Microsoft。 

疑難排解與 Microsoft Word 中其他巨集的衝突

PDFMaker 可能與其他巨集發生衝突,例如病毒檢查程式或傳真軟體。如果其他疑難排解工作失敗,或者 PDFMaker 在安裝協力廠商巨集後出現問題,請疑難排解 PDFMaker 與其他巨集的衝突。已知不相容的巨集包括 Duden Korrektor Plus 2.0、ViaVoice 10 及較舊版本、Personal Translator 2002 Office Plus、OfficeReady Stuffit、Leuchter Informatic AG WordPlus 和 GoldMine Link to Word。

如要確定 PDFMaker 是否與另一個巨集衝突,請一次刪除或停用一個其他巨集 (請參閱以下適用的連結)。然後再嘗試使用 PDFMaker 將文件轉換為 PDF。如果問題沒有再次出現,請聯絡該巨集的製造商。

疑難排解 Microsoft Word 的問題

使用 /a 參數啟動 Word 並手動新增 PDFMaker

/a 參數會啟動 Word 並防止增益集和全域範本 (包括「正常」範本) 自動載入。/a 參數亦會鎖定設定檔案,換言之,如果使用此參數,您便無法閱讀或修改設定檔案。

注意: 如果您退出 Word,您以 /a 參數啟動 Word 的工作階段時針對偏好設定、自訂項目或巨集所作的變更都會遺失。

若要使用 /a 參數啟動 Word:

  1. 退出所有程式。
  2. 選擇「開始 > 執行」。
  3. 在「執行」對話方塊中鍵入「winword.exe /a」
  4. 按一下「確定」。「執行」對話方塊會關閉,並會啟動 Word。

若要手動載入 PDFMaker (僅限Acrobat 6.x):

  1. 退出所有程式。
  2. 選取「工具 > 範本及增益集」。
  3. 選取 PDFMaker.dot (不是 PDFMakerA.dot),並按一下「確定」,

    便會出現 PDFMaker 圖示。

若為 Acrobat 7.x、8.x、9.x、X (如適用)

若要手動載入 PDFMaker (MS Word 2003 或較舊版本):

  1. 退出所有程式。
  2. 選取「工具 > 自訂」,然後按一下「指令」標籤。
  3. 按一下「類別」面板的「工具」。
  4. 按住滑鼠按鈕,從「指令」面板將 COM 增益集拖曳至「工具」選單。當「工具」選單顯示選單指令時,將 COM 增益集拖曳至「自訂」選項的下方,然後放開滑鼠按鈕。
  5. 然後,請按一下「關閉」。
  6. 按一下「工具」選單上的「COM 增益集」。
  7. 按一下「新增」,找到增益集 (PDFMaker 增益集位於 [Acrobat 安裝路徑]\PDFMaker\Office\PDFMOfficeAddIn.dll),並按一下「確定」。

  8. 按下 Alt+F11 鍵以啟動 Visual Basic Editor。
  9. 按下 Ctrl+G 鍵以啟動 Visual Basic Editor 的即時運算視窗。
  10. 如要在 Word 中啟動 PDFMaker,請鍵入 Application.COMAddIns("PDFMaker.OfficeAddin").Connect = True。關閉 Visual Basic Editor。
  11. 確認 Adobe PDF 選單現在顯示在 Microsoft Word 選單列「說明」的右側。

手動載入 PDFMaker (MS Word 2007 和 2010):

  1. 退出所有程式。
  2. 按一下 Microsoft Office 按鈕,然後按一下「Word」選項。

  3. 按一下「增益集」。

  4. 在「管理」清單中,按一下「COM 增益集」,然後按一下「開始」。

  5. 如果「COM 增益集」對話方塊列出並已選取 Acrobat PDFMaker COM 增益集,請執行以下步驟,否則請前往第 6 步。

  6. 按一下以取消選取 Acrobat PDFMaker COM 增益集的核取方塊。

  7. 按一下「確定」以關閉「COM 增益集」對話方塊。

  8. 重複第 1 至第 3 步,然後在「Acrobat PDFMaker COM 增益集」對話方塊中,按一下以選取/核取 Acrobat PDFMaker COM 增益集的核取方塊。

  9. 確認 MS Word 功能區顯示「Acrobat」標籤。

  10. 如果「COM 增益集」對話方塊沒有列出 Acrobat PDFMaker COM 增益集,請執行「手動載入 PDFMaker (MS Word 2003 或較舊版本)」一節的第 7 至第 10 步。

建立測試的 Word 文件並啟動 PDFMaker:

  1. 在 Word 文件中鍵入一些文字。
  2. 選擇「檔案 > 儲存」,並將測試文件儲存到桌面。
  3. 按一下「轉換為 Adobe PDF」。

如果您使用 /a 參數啟動 Word 時可解決此問題,請移除 Word 啟動時載入的每個元件。依元件顯示在 Word 中的順序,一次移除一個元件。Word 啟動時會載入以下元件:

  • Word 自動巨集
  • 全域範本 (Normal.dot)
  • 增益集 (WLL)
  • Word Startup 資料夾和 Office Startup 資料夾中的範本
  • COM 增益集
  • Windows 登錄的 Word 資料機碼
  • Windows 登錄的 Word 選項機碼
  • Word 自動巨集

注意: 若需額外的 Word 啟動疑難排解,請參考以下的「Microsoft 產品支援服務」:

重新命名 Normal.dot 範本檔案

如需重新命名全域範本檔案的指示,請參閱 Microsoft 支援文章「如何在 Word 重新設定使用者選項和機碼設定」中的「全域範本 (Normal.dotm 或 Normal.dot)」一節。向下捲動頁面以瀏覽文章。

重要: 完成以上步驟後,請勿使用 /a 參數重新啟動 Word。

如果您在重新命名全域範本後可解決此問題,那麼問題出於受損的 Normal.dot 範本。有時候,您必須變更一些設定才能還原您的選項。如果您重新命名的 Normal.dot 檔案含有難以重新建立的自訂項目,例如樣式、巨集或自動圖文集項目,請嘗試使用「組合管理」將這些自訂項目從原本的 Normal.dot 檔案複製至新的 Normal.dot 檔案。

若需更多使用「組合管理」的相關資訊,請按照以下步驟操作:

  1. 啟動 Word。
  2. 選擇「說明 > Microsoft Word 說明」。
  3. 在 Office 小幫手或解答精靈鍵入「組合管理」

  4. 按一下「搜尋」以檢視傳回的主題。

如果您無法解決問題,建議您使用原本的全域範本 (Normal.dot),而不要使用新的全域範本。若要使用原本的 Normal.dot 範本,將新的 Normal.dot 範本重新命名為 Normal.dot。如東您按照本文件的指示操作後,PDFMaker 仍然遇到同樣的問題,請聯絡 Acrobat 支援團隊

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策