選取一或多個切片

執行下列任一項作業:

  • 選取「切片選取」工具 ,然後按一下影像中的切片。當處理重疊切片時,按一下基本切片中看得見的選擇範圍將其選取。
  • 選取「切片選取」工具,然後按住 Shift 鍵並按一下滑鼠鍵,將切片加入到選取範圍。
  • 在「儲存為網頁與裝置用」對話框中選取「切片選取」工具,然後按一下自動切片或影像區域的外面,並拖移過您要選取的切片 (按一下使用者切片並拖移可移動切片)。
  • 選擇「檔案 > 儲存為網頁與裝置用」。在對話框中,使用「切片」工具選取切片

註解:

使用「切片」工具或「切片選取」工具時,可以按下 Ctrl 鍵 (Windows) 或 Command 鍵 (Mac OS),在這兩個工具之間切換。

移動、靠齊及重新調整使用者切片尺寸

您可以在 Photoshop 中移動和重新調整使用者切片尺寸,但是在「儲存為網頁與裝置用」對話框中則無法這麼做

移動或重新調整使用者切片尺寸

  1. 選取一或多個使用者切片。
  2. 執行下列任一項作業:
    • 若要移動切片,請將指標移到切片選取範圍的邊界內,並將切片拖移到新的位置。按 Shift 鍵可以限制沿水平、垂直或 45 度對角線移動。

    • 若要重新調整切片尺寸,請抓住切片的側邊或角落控點並拖移。如果選取及重新調整相鄰切片的尺寸,這些切片的共同邊緣都會一起調整。

使用數值座標移動或重新調整使用者切片尺寸

  1. 選取一或多個使用者切片。
  2. 按一下選項列中的「選項」按鈕。您也可以按兩下切片以顯示選項。
  3. 在「切片選項」對話框的「尺寸」區域中,更改下列一或多個選項:

    X

    以像素為單位,指定文件視窗中切片左側邊緣與尺標原點之間的距離。

    Y

    以像素為單位,指定文件視窗中切片頂端邊緣與尺標原點之間的距離。

    註解:

    尺標的預設原點為影像的左上角。

    W

    指定切片的寬度。

    H

    指定切片的高度。

將切片靠齊參考線、使用者切片或其他物件

  1. 從「檢視 > 靠齊至」次選單選取您要的選項。
  2. 選擇「檢視 > 靠齊」核取記號表示該選項已經開啟。
  3. 依照需要移動選取的切片,切片會靠齊 4 個像素內任何選取的物件。

分割使用者切片和自動切片

使用「分割切片」對話框可水平、垂直或從這兩個方向分割切片。不論原始切片是使用者切片或自動切片,分割的切片永遠都是使用者切片。

註解:

您無法分割圖層式切片。

  1. 選取一或多個切片。
  2. 選取「切片選取」工具 ,然後按一下選項列中的「分割」。
  3. 選取「分割切片」對話框中的「預視」,預視所做的變更。
  4. 在「分割切片」對話框中,選取下列其中一個選項或者兩個都選:

    水平分割為

    以橫向分割切片。

    垂直分割為

    以縱向分割切片。

  5. 定義每一個選取切片的分割方式︰
    • 選取「縱向切割」或「橫向切割」並輸入數值,將每一個切片平均分割成這個指定數目的切片。

    • 選取並輸入「像素/切片」的數值,以建立具有指定像素數目的切片。如果切片無法以指定的像素數目平均分割,剩餘的部分會成為另一個切片。例如,若要將寬度為 100 個像素的切片分割成三個寬度為 30 個像素的新切片,剩餘的 10 個像素寬的區域也會成為一個新的切片。

  6. 按一下「確定」。

複製切片

您可以建立尺寸和最佳化設定都與原始切片相同的複製切片。如果原始切片是連結的使用者切片,複製切片也會連結到相同的連結切片組合。不論原始切片是使用者切片、圖層式切片或自動切片,複製切片永遠都是使用者切片。

  1. 選取一個切片或多個切片。
  2. 按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS),並從選取範圍內部開始拖移。

拷貝及貼上切片

您可以在影像中將選取的切片拷貝並貼入另一個影像,或是貼入另一個應用程式,例如 Dreamweaver。拷貝切片會拷貝在切片邊界中的所有圖層 (而不只是作用中圖層)。

  1. 使用「切片選取」工具 選取一或多個切片。
  2. 選擇「編輯 >拷貝」。

    註解:

    如果在文件中有作用中的選取範圍 (選取畫面像素選取範圍或是選取的路徑),就不能拷貝切片。

  3. 執行下列任一項作業:
    • 若要將切片貼到別的影像中,請開啟並顯示該影像。

    • 如果貼入 Dreamweaver,請將 Dreamweaver 文件變成作用中視窗。

  4. 選擇「編輯 > 貼上」。將切片貼入 Photoshop 影像時,會建立一個新的圖層。

    註解:

    拷貝到 Dreamweaver 的切片會保留原始 Photoshop 來源檔案的檔案名稱及路徑相關資訊。若要在 Dreamweaver 中檢視這項資訊,請用滑鼠右鍵按一下影像 (Windows) 或按住 Ctrl 鍵並按一下影像 (Mac OS),再選擇「設計備註」,然後找到「全部資訊」索引標籤上的「FilePathSrc」欄位。

組合切片

您可以將兩個或多個切片組合成一個切片。Photoshop 會以連接組合之切片的外部邊緣所建立的矩形,來決定結果切片的尺寸和位置。如果組合的切片並不相鄰,或者是比例和對齊方式不同,則新組合而成的切片可能會與其他切片重疊。

組合的切片會採用您選取的一系列切片中第一個切片的最佳化設定。不論原始切片是否包括自動切片,組合的切片永遠都是使用者切片。

註解:

您無法組合圖層式切片。

  1. 請選取兩個或多個切片。
  2. 按一下滑鼠右鍵 (Windows) 或按住 Ctrl 鍵並按滑鼠 (Mac OS),然後選擇「組合切片」。

更改切片的堆疊順序

當切片重疊時,最後建立的切片是堆疊順序中最頂端的切片。您可以更改堆疊順序,存取下面的切片,您還可以指定堆疊中的頂端及底部切片,並將切片在堆疊順序中向上或向下移動。

註解:

您無法排列自動切片的堆疊順序。

  1. 選取一個切片或多個切片。
  2. 選擇「切片選取」工具 ,然後按一下選項列中的堆疊順序選項。
    Photoshop 堆疊順序選項
    堆疊順序選項

    A. 移至最前 B. 前移 C. 後移 D. 移至最後 

對齊及均分使用者切片

您可以沿著某一邊或居中對齊使用者切片,也可以沿著垂直軸或水平軸平均分配使用者切片。經由對齊及均分使用者切片,可以消除不必要的自動切片,並產生較小、較有效率的 HTML 檔案。

註解:

對齊或均分圖層的內容,就可以對齊或均分圖層式切片。

  1. 選取要對齊的使用者切片。
  2. 選擇「切片選取」工具 ,然後選取選項列中的選項。
    Photoshop「對齊」選項
    對齊選項

    A. 上 B. 垂直居中 C. 下 D. 左 E. 水平居中 F. 右 
    Photoshop「分配」選項
    均分選項

    A. 上 B. 垂直居中 C. 下 D. 左 E. 水平居中 F. 右 

刪除切片

刪除使用者切片或圖層式切片時,會重新產生自動切片以填滿文件區域。

刪除圖層式切片,並不會刪除相關的圖層;但是,刪除與圖層式切片相關的圖層,就會刪除圖層式切片。

註解:

您無法刪除自動切片,如果刪除影像中所有的使用者切片和圖層式切片,就會剩下一個含蓋整個影像的自動切片。

  1. 選取一或多個切片。
  2. 選擇「切片」或「切片選取」工具,並按下 Backspace 或 Delete 鍵。
  3. 若要刪除全部的使用者切片和圖層式切片,請選擇「檢視 > 清除切片」。

鎖定所有切片

鎖定切片可阻止您不小心而重新調整尺寸、移動、甚至變更切片。

  1. 選擇「檢視 > 鎖定切片」。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策