Photoshop 提供了一些功能,可以協助您在其他應用程式中使用影像。由於 Adobe 產品間緊密的整合,許多 Adobe 應用程式可以直接讀入 Photoshop (PSD) 格式的檔案,也可以使用很多 Photoshop 的功能,如圖層、圖層樣式、遮色片、透明度與效果等。

準備影像供排版程式使用

如何準備排版程式所使用的影像,取決於程式辨識的檔案格式:

  • Adobe InDesign 2.0 或更新的版本可以置入 Photoshop PSD 檔,因此您不必將 Photoshop 影像儲存或轉存成不同的檔案格式,透明區域就會顯示並列印出預期的效果。

  • 其他排版排程式大多會要求您將影像儲存成 TIFF 或 EPS 檔。但是如果影像含有完全透明的區域,就必須先使用剪裁路徑定義出透明區域。請查閱排版程式的說明文件,決定讀入 Photoshop 影像的最佳格式。

如果排版程式無法置入 PSD 檔,請依照下列步驟執行:

  1. 如果影像含有透明的背景,或包含您希望是透明的區域,就需要沿著影像不透明區域的四周,建立剪裁路徑。即使已刪除了影像四周的背景,也必須在將檔案轉換成 TIFF 或 EPS 格式之前,先以剪裁路徑定義透明區域。否則,排版程式可能會以白色顯示透明的區域。
  2. 選擇「檔案 > 另存新檔」。
  3. 在「另存新檔」對話框中,從「格式」選單中選擇適當的格式。請依文件最後的輸出型式來選擇格式。列印到非 PostScript 印表機時,請選擇「TIFF」; 列印到 PostScript 印表機時,請選擇 Photoshop EPS。接著按一下「儲存」。
  4. 在「TIFF 選項」或「EPS 選項」對話框中,設定下列選項。保留所有其他選項的預設值,然後按一下「確定」。
    • 「TIFF 選項」對話框: 將「影像壓縮」設為「無」。

    • 「EPS 選項」對話框 (Windows): 將「預視」設為 TIFF (8 位元/像素),「編碼」設為 ASCII85。

    • 「EPS 選項」對話框 (Mac OS): 將「預視」設為 Mac (8 位元/像素),「編碼」設為 ASCII85。

    註解:

    如果編排程式以白色顯示透明的區域,請試印這份文件。有些編排程式無法正確地顯示剪裁路徑,但列印結果卻可以達到預期的水準。

在 Adobe Illustrator 中使用 Photoshop 圖稿

Adobe Illustrator 可開啟或置入 Photoshop 檔,因此您不需將 Photoshop 影像儲存或轉存成不同的檔案格式。將影像置入開啟的 Illustrator 檔案之後,就可以將影像當作圖稿中的一個成份來加以整合,或也可以保留影像與原始檔案的連結。雖然您無法在 Illustrator 中編輯連結的影像,但還是可以切換回 Photoshop,使用編輯原稿指令進行修改。儲存之後,您所做的任何變更都會反映在 Illustrator 中的影像中。

  1. 如果影像已在 Photoshop 中開啟,請將它儲存成 Photoshop (PSD) 檔,再關閉檔案。
  2. 在 Adobe Illustrator 中,請執行下列任一項作業:
    • 若要直接在 Illustrator 中開啟檔案,請選擇「檔案 > 開啟舊檔」。在「開啟檔案」對話框中找出影像,然後按一下「開啟」。

    • 若要將影像整合到現有的 Illustrator 檔案,請選擇「檔案 > 置入」。在「置入」對話框中找出檔案,並確認未選取「連結」選項,然後按一下「置入」。

    • 若要將影像置入檔案中,但仍保留與原稿的連結,請選擇「檔案 > 置入」。在「置入」對話框中找出檔案,選取「連結」選項,然後按一下「置入」。Illustrator 會將影像置於開啟的 Illustrator 檔中央。影像上的紅色 X 表示影像含有連結,無法編輯。

  3. 開啟或置入不含連結的影像時,會出現「Photoshop 讀入」對話框。這時請從下列選擇適當選項,然後按一下「確定」:
    • 「將 Photoshop 圖層轉換為物件」,將圖層轉換成 Illustrator 物件。這個選項可保留遮色片、混色模式、透明度,以及 (選擇性) 切片和影像地圖,但是它不支援 Photoshop 調整圖層和圖層效果。

    • 「將 Photoshop 圖層平面化為單一影像」,將所有圖層合併成單一圖層。這個選項可以保留影像的外觀,但您將無法再編輯個別的圖層。

使用影像剪裁路徑建立透明

您可以使用影像剪裁路徑,在置入排版應用程式的影像中定義透明區域。此外,Mac OS 使用者可以將 Photoshop 影像嵌入許多文字處理器的檔案中。

在列印 Photoshop 影像或是將 Photoshop 影像置入其他應用程式中時,您可能只想使用其中的一部分。例如,您可能只想使用前景物件,而不要背景物件。影像剪裁路徑可以讓您在列印或將影像置入其他應用程式時,隔離前景物件,並讓其他物件變成透明的。

註解:

路徑是向量式的,因此有明顯邊緣。當建立影像剪裁路徑時,您無法保留羽化邊緣的柔軟度,例如陰影中的邊緣。

使用和沒有使用剪裁路徑的 Photoshop
將使用影像剪裁路徑 (左圖) 與沒有使用影像剪裁路徑 (右圖) 的影像讀入 Illustrator 或 InDesign 後的情形

  1. 繪製一條工作路徑,定義您要顯示的影像區域。

    註解:

    如果您已經選取想要顯示的影像區域,可以將選取區域轉換成工作路徑。如需指示,請參閱將選取範圍轉換為路徑

  2. 在「路徑」面板中,將工作路徑儲存為路徑。
  3. 從「路徑」面板選單中選擇「剪裁路徑」、設定下列選項,然後按一下「確定」:
    • 在「路徑」中,選擇想要儲存的路徑。

    • 在「平面化」中,將平面化數值保留空白,使用印表機的預設值列印影像。如果列印時發生錯誤,請輸入平面化值,以決定 PostScript 解譯器如何繪出最接近的曲線。平面化的數值越低,用來繪製曲線的直線數目就越多,且曲線也就越精確。這些數值的範圍介於 0.2 到 100。一般來說,對於高解析度列印,也就是 1200 dpi 至 2400 dpi,建議將平面化設定為 8 到 10,而對於低解析度列印,也就是 300 dpi 至 600 dpi,則建議將平面化設定在 1 到 3 之間。

  4. 如果準備使用印刷色列印檔案,請將檔案轉換成 CMYK 模式。
  5. 執行下列任一項作業以儲存檔案:
    • 若要使用 PostScript 印表機列印檔案,請儲存為 Photoshop EPS、DCS 或 PDF 格式。

    • 若要使用非 PostScript 印表機列印檔案,請儲存為 TIFF 格式,並轉存成 Adobe InDesign 或 Adobe PageMaker® 5.0 或更新版本。

列印影像剪裁路徑

有時候製版機無法解譯影像剪裁路徑,或者影像剪裁路徑對印表機而言過於複雜,導致發生 Limitcheck 錯誤或一般的 PostScript 錯誤。有時在低解析度的印表機上列印複雜的路徑時沒有問題,但在高解析度的印表機上列印相同的路徑時,卻會發生問題。這是因為低解析度的印表機會將路徑簡化,使用比高解析度印表機少的線段來描述曲線。

您可以使用下列方式,簡化影像的剪裁路徑:

  • 手動減少路徑上的錨點數目。

  • 增加用來建立路徑的容許度設定。若要這麼做,請將現有路徑載入為選取範圍、從「路徑」面板選單中選擇「製作工作路徑」,並增加容許度設定 (較適合的起始值為 4 到 6 個像素)。然後重新建立影像剪裁路徑。

將路徑轉存到 Adobe Illustrator 中

「路徑到 Illustrator」指令讓您能夠將 Photoshop 路徑轉存為 Adobe Illustrator 檔案。以這種方式轉存路徑可以簡化合併 Photoshop 與 Illustrator 圖稿,或是在 Illustrator 圖稿上使用 Photoshop 功能的工作。例如,您可能想要轉存筆型工具路徑,並以在 Illustrator 中列印的 Photoshop 剪裁路徑,做為補漏白使用。您也可以使用這項功能,將 Illustrator 中的文字或物件對齊 Photoshop 路徑。

  1. 繪製並儲存路徑或將現有的選取範圍轉換成路徑。
  2. 選擇「檔案 > 轉存 > 路徑到 Illustrator」。
  3. 選擇轉存路徑的位置,並輸入檔名。確認從「路徑」選單中選擇「工作路徑」,以轉存路徑。
  4. 按一下「儲存」。
  5. 在 Adobe Illustrator 中開啟這個檔案。您可以操控路徑或是使用路徑,對齊增加到檔案的 Illustrator 物件。

    請注意,Adobe Illustrator 中的裁切標誌會反映出 Photoshop 影像的尺寸。只要沒有變更裁切標誌或移動路徑,就能夠維持 Photoshop 影像中的路徑位置。

Photoshop 是一種 OLE 2.0 伺服器,這表示它能支援嵌入或連結 OLE 容器應用程式中的影像 (通常是文字處理或排版程式)。例如,您可以使用拷貝與貼上或者其他方法,將 Photoshop 檔案和選取範圍插入其他 OLE 應用程式中,例如 Adobe PageMaker、Adobe FrameMaker 與 Microsoft Word。

  • 連結可讓您在 OLE 容器檔案中置入連結,以便參考到硬碟上的 Photoshop 檔案。

  • 嵌入可讓您將 Photoshop 檔案插入 OLE 容器檔案中。

    將影像插入容器應用程式之後,您可以按兩下影像,在 Photoshop 中進行編輯。在 Photoshop 中關閉影像時,容器應用程式中的影像就會更新。

  1. 執行下列任一項作業:
    • 拷貝 Photoshop 中的選取範圍,然後使用應用程式的「選擇性貼上」指令,將其插入 OLE 容器應用程式中。如需詳細資訊,請參閱文字處理或頁面版面應用程式的說明文件。您只能嵌入,而不能連結貼上的選取範圍。

    • 使用 OLE 容器應用程式的「插入物件」指令,將新的 Photoshop 影像或現有的 Photoshop 檔案插入,做為 OLE 嵌入或 OLE 連結物件。如需詳細資訊,請參閱文字處理或排版應用程式的說明文件。

在 OLE 應用程式中插入未連結的螢幕解析度點陣圖

  1. 使用「移動」工具,將選取範圍拖移到 OLE 容器應用程式中。放下物件後,它會以 72 ppi 的點陣圖顯示,而且無法在 Photoshop 中自動更新。

在 OLE 應用程式中修改和更新連結或嵌入的影像

  1. 在文字處理或排版應用程式中,按兩下連結或嵌入的影像,啟動 Photoshop (如果它尚未執行),並開啟影像進行編輯。
  2. 依需要修改影像。
  3. 執行下列任一項作業:
    • 如果是嵌入的影像,請關閉檔案,或選擇「檔案 > 更新」或「檔案 > 關閉並返回 [應用程式名稱]」。

    • 如果是連結的影像,請儲存並關閉檔案。

    註解:

    您也可以不開啟容器文件,直接修改連結的檔案。下次在文件的 OLE 容器應用程式中開啟文件時,連結的影像就會更新。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策