關於色階分佈圖

色階分佈圖會以圖表方式顯示每個色彩強度階層上的像素數,呈現像素在影像中的分佈情形。色階分佈圖會顯示陰影 (顯示於色階分佈圖的左邊)、中間調 (顯示於中間) 以及亮部 (顯示於右邊) 的細節。色階分佈圖可以幫助您判斷影像是否有足夠的細節可進行良好的校正。

色階分佈圖也提供影像色調範圍 (或稱影像色階類型) 的快速圖示。低色階影像的細節集中在陰影,高色階影像的細節集中在亮部,而平均色階影像的細部則是集中在中間調。具有完整色調範圍的影像,在所有區域中都會有一些像素。辨識色調範圍有助於決定適當的色調校正。

Photoshop 色階分佈圖範例
如何讀取色階分佈圖

A. 曝光過度的相片 B. 色調完整且曝光適度的相片 C. 曝光不足的相片 

「色階分佈圖」面板提供許多檢視影像色調和色彩資訊的選項。根據預設,色階分佈圖會顯示整個影像的色調範圍。若要顯示某部分影像的色階分佈圖資料,請先選取這個部分。

註解:

您可以在「曲線」對話框中選取「曲線顯示選項」下方的色階分佈圖,以及在「曲線內容」面板中從面板選單選擇「曲線顯示選項」然後選擇「色階分佈圖」,以覆蓋方式檢視影像色階分佈圖。

色階分佈圖面板概觀

  1. 選擇「視窗 > 色階分佈圖」,或按一下「色階分佈圖」索引標籤,開啟「色階分佈圖」面板。根據預設,「色階分佈圖」面板會在不提供任何控制項或統計資料的「精簡視圖」中開啟,但是您可以調整視圖。
    Photoshop「色階分佈圖」面板 -- 擴展視圖
    色階分佈圖面板 (擴展視圖)

    A. 色版選單 B. 面板選單 C. 不使用快取進行重新整理按鈕 D. 使用快取資料警告圖示 E. 統計資料 

調整色階分佈圖面板的檢視

  1. 從「色階分佈圖」面板選單中選擇視圖。

    擴展視圖

    顯示含統計資料的色階分佈圖。它也會顯示控制項,用於選擇以色階分佈圖表示的色版、檢視「色階分佈圖」面板中的選項、重新整理色階分佈圖以顯示未使用的快取資料,以及選擇多重圖層文件中的特定圖層。

    精簡視圖

    顯示不含控制項或統計資料的色階分佈圖。在這裡的色階分佈圖是整個影像的色階分佈圖。

    所有色版視圖

    顯示色版的各個色階分佈圖,以及「擴展視圖」的所有選項。在這裡顯示的色階分佈圖中,不包含 Alpha 色版、特別色色版或遮色片。

    Photoshop「色階分佈圖」面板 (含有以顏色顯示的色版)
    以彩色顯示所有色版並隱藏統計資料的色階分佈圖面板

檢視色階分佈圖中的特定色版

當選擇「色版分佈圖」面板的「擴展視圖」或「所有色版視圖」時,便可以從「色版」選單中選擇設定。從「擴展視圖」或「所有色版視圖」切換回「精簡視圖」時,Photoshop 會記住該色版設定。

  • 選擇單一色版,顯示色版的色階分佈圖,包括色彩色版、Alpha 色版和特別色色版。
  • 根據影像的色彩模式,選擇 RGB、CMYK 或「複合」,檢視所有色版的複合色階分佈圖。
  • 如果影像是 RGB 或 CMYK,就選擇「明度」,顯示代表複合色版之明度或強度值的色階分佈圖。
  • 如果影像是 RGB 或 CMYK,就選擇「顏色」,以顯示一個複合色階分佈圖,並在其中以色彩分別顯示個別的色彩色版。當您先選擇「擴展視圖」或「所有色版視圖」時,這個選項就是 RGB 和 CMYK 影像的預設視圖。

    當您在「所有色版視圖」的「色版」選單中選擇選項時,只會影響到面板中最上方的色階分佈圖。

檢視彩色的色版色階分佈圖

  1. 在「色階分佈圖」面板中,執行下列任一項作業:
    • 於「所有色版視圖」中,從「面板」選單中選擇「用彩色顯示色版」。

    • 在「擴展視圖」或「所有色版視圖」中,從「色版」選單中選擇個別的色版,並從「面板」選單中選擇「用彩色顯示色版」。如果切換到「精簡視圖」,色版將繼續以彩色顯示。

    • 於「擴展視圖」或「所有色版視圖」中,從「色版」選單中選擇「顏色」,以彩色顯示複合色階分佈圖。如果您切換到「精簡視圖」,將繼續顯示彩色的複合色階分佈圖。

檢視色階分佈圖統計資料

根據預設,「色階分佈圖」面板會在「擴展視圖」和「所有色版視圖」中顯示統計資料。

  1. 從「色階分佈圖」面板選單中選擇「顯示統計資料」。
  2. 執行下列任一項作業:
    • 若要檢視關於特定像素值的資訊,請將指標放在色階分佈圖中。

    • 若要檢視關於某一數值範圍的資訊,請在色階分佈圖中以拖移的方式選取該範圍。

    面板中色階分佈圖的下方將顯示下列統計資訊:

    平均值

    代表平均的強度值。

    標準差 (Std Dev)

    代表強度值差異的範圍。

    中間值

    顯示強度值範圍的中間值

    像素

    代表用來計算色階分佈圖的像素總數。

    臨界色階

    顯示指標下的區域的強度層級。

    計算

    顯示與指標下的強度層級相對應的像素總數。

    百分比

    顯示指標下的色階或色階下的累積像素數。這個值是以影像中所有像素的百分比表示的:從最左邊的 0% 到最右邊的 100%。

    快取階層

    在這個項目中,會顯示目前用來建立色階分佈圖的影像快取記憶體。快取階層高於 1 時,色階分佈圖會顯示得比較快。在此例中,色階分佈圖是從影像中具代表性的像素取樣衍生而來 (根據顯示比例)。原始影像的快取階層為 1。在高於 1 的每個階層中,平均每四個相鄰像素可得出一個像素值。因此,每個階層的尺寸大小都是較低階層的一半 (具有原像素數目的 1/4)。當 Photoshop 需要快速取得影像的概觀時,可以使用較高的階層。按一下「不使用快取進行重新整理」按鈕,可使用實際的影像圖層重繪色階分佈圖。

檢視多重圖層文件的色階分佈圖

  1. 從「色階分佈圖」面板選單中選擇「擴展視圖」。
  2. 從「來源」選單中選擇設定 (在單一圖層的文件中並不能使用「來源」選單)。

    整個影像

    顯示整個影像 (包括所有圖層) 的色階分佈圖。

    選取的圖層

    顯示在「圖層」面板中所選定圖層的色階分佈圖。

    複合影像調整

    顯示在「圖層」面板中所選定調整圖層的色階分佈圖,包括調整圖層下方所有圖層。

預視色階分佈圖調整

您可以預視對色階分佈圖所做任何色彩與色調調整的效果。

  1. 在任何色彩或色調調整指令的對話框中,選取「預視」選項。

    選取了「預視」時,「色階分佈圖」面板會顯示調整如何影響色階分佈圖。

    註解:

    使用「調整」面板進行調整時,變更會自動反映在「色階分佈圖」面板中。

    Photoshop「色階分佈圖」調整預視
    在「色階分佈圖」面板中,預視對色階分佈圖所做的調整

    A. 原始色階分佈圖 B. 調整後的色階分佈圖 C. 陰影 D. 中間調 E. 亮部 

重新整理色階分佈圖的顯示畫面

當您是從快取記憶體中讀取色階分佈圖,而不是從文件的目前狀態讀取時,「色階分佈圖」面板中會出現「使用快取資料警告」圖示 。以影像快取記憶體為準的色階分佈圖顯示速度較快,因為它是以影像中具代表性的像素取樣做為依據。您可以在「效能」偏好設定中設定最大的快取階層 (從 2 到 8)。

註解:

快取階層設定越高,可增加大型多重圖層檔案的重繪速度,但需使用更多的系統 RAM。如果 RAM 有限或您的工作主要使用較小的影像,則請使用較低的快取階層設定

  1. 若要重新整理色階分佈圖,以顯示原始影像所有像素目前的狀態,請執行下列任一項步驟:
    • 在色階分佈圖中任一位置按兩下。

    • 按一下「使用快取資料警告」圖示

    • 按一下「不使用快取進行重新整理」按鈕

    • 從「色階分佈圖」面板選單中選擇「不使用快取進行重新整理」。

    如需有關快取階層的詳細資訊,請參閱色階分佈圖面板概觀

檢視影像中的顏色數值

您可以使用「資訊」面板,在進行色彩校正時查看像素的顏色數值。使用「內容」面板時,「資訊」面板會顯示指標下像素的兩組顏色數值。左方欄位中的數值是原始的顏色數值。右方欄位中的數值是在進行調整後的顏色數值。

Photoshop 影像中的顏色數值
使用「色階」與「資訊」面板,中和影像的色調

您可以使用「滴管」工具 檢視單一位置的顏色。您也可以使用最多四個顏色取樣器 來顯示影像中一或多個位置的顏色資訊。這些取樣器會儲存在影像中,這樣您在工作時就可重複地參考,就算將影像關閉再重新開啟也是一樣。

Photoshop「顏色取樣器」和「資訊」面板
顏色取樣器和資訊面板

  1. 選擇「視窗 > 資訊」開啟「資訊」面板。
  2. 選取 (然後按住 Shift 鍵再按滑鼠左鍵)「滴管」工具 或「顏色取樣器」工具 ,然後視需要在選項列中選擇樣本尺寸。選擇「點狀樣本」可讀取單一個像素的數值,選擇其他選項則會讀取某個像素區域的平均值。
  3. 如果選取了「顏色取樣器」工具 ,則在影像上最多可以放置四個顏色取樣器。在想置入取樣器的地方按一下。

調整顏色時檢視顏色資訊

在「內容」面板中調整顏色時,您可以檢視影像中特定像素的顏色資訊。

  1. 使用「調整」面板增加調整。
  2. 在「內容」面板中進行調整。進行調整時,可在「資訊」面板中檢視之前和之後的顏色數值。將滑鼠指標移到影像上,可檢視指標位置的顏色數值。

    註解:

    如果您是使用「影像 > 調整」選單中的指令,則當您將指標移到影像上時,會啟動滴管工具 (而其他工具會暫時關閉)。這時您仍然可以使用鍵盤的快速鍵存取捲動控制項,並存取「手形」和「縮放顯示」 工具。

  3. 如果您已將顏色取樣器放在影像上,則顏色取樣器底下的顏色數值會出現在「資訊」面板的下半部。若要新增顏色取樣器,請選取「顏色取樣器」工具並按一下影像,或選取滴管工具並按住 Shift 鍵再按一下影像。

調整顏色取樣器

加入顏色取樣器後,您除了可以移動、刪除或隱藏取樣器外,也可以變更「資訊」面板中所顯示的顏色取樣器資訊。

移動或刪除顏色取樣器

  1. 選取「顏色取樣器」工具
  2. 執行下列任一項作業:
    • 若要移動顏色取樣器,請將取樣器拖移到新的位置。

    • 若要刪除顏色取樣器,請將取樣器拖離文件視窗。或者,按住 Alt 鍵 (Windows) 或 Option 鍵 (Mac OS),直到指標變成剪刀狀,再按一下取樣器。

    • 若要刪除所有的顏色取樣器,請在選項列中按一下「清除」。

    • 若要在調整對話框開啟時刪除顏色取樣器,請按住 Alt+Shift 鍵 (Windows) 或 Option+Shift 鍵 (Mac OS),並按一下取樣器。

隱藏或顯示影像中的顏色取樣器

  1. 選擇「檢視 > 輔助項目」。如果有核取標記,表示顏色取樣器是可見的。

變更資訊面板中顯示的顏色取樣器資訊

  • 若要在「資訊」面板中顯示或隱藏顏色取樣器資訊,請從「面板」選單中選擇「顏色取樣器」。如果有核取標記,表示顏色取樣器資訊是可見的。
  • 若要改變顏色取樣器用於顯示數值的色域,請將滑鼠指標移到「資訊」面板的顏色取樣器圖示 上。接著,按住滑鼠按鈕,然後從選單中選擇其他色域。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策