Erstellen von auf dynamischen Daten basierenden Grafiken

Zuletzt aktualisiert am 29. Oktober 2026

Verwende Variablen und Datensätze, um mehrere Versionen einer Vorlage mit unterschiedlichem Text und verschiedenen Bildern zu generieren.

Mit datengestützten Grafiken kannst du mehrere Bildvarianten aus einer einzigen Vorlage erstellen, indem du festlegst, welche Elemente sich ändern, und den Ersatzinhalt über Datensätze bereitstellst.

Dieser Workflow eignet sich, wenn du mehrere Versionen eines Designs mit unterschiedlichem Text, verschiedenen Bildern oder abweichender Ebenensichtbarkeit generieren musst, zum Beispiel Webbanner für verschiedene Produkte, personalisierte Zertifikate oder lokalisierte Marketing-Materialien. Deine Vorlage muss für jedes Element, das du variieren möchtest, eine separate Ebene verwenden. Informationen zum Importieren von Datensätzen aus externen Textdateien findest du im zugehörigen Artikel zum Datensatzimport.

Photoshop unterstützt drei Variablentypen, die verschiedene Aspekte deiner Vorlage steuern. Sichtbarkeitsvariablen steuern, ob Ebeneninhalt sichtbar ist. Textersetzung-Variablen ersetzen Zeichenfolgen in Textebenen. Pixelersatz-Variablen tauschen Ebenenpixel durch Inhalte aus Bilddateien aus.Du kannst mehrere Variablentypen auf eine Vorlage anwenden und mehrere Ebenen mit derselben Variablen verknüpfen, um Änderungen zu koordinieren.

Variablen für Vorlagenelemente definieren

Wähle Bild > Variablen > Definieren.

Wähle im Menü Ebene die Ebene mit dem Inhalt aus, den du variieren möchtest.

Wähle einen oder mehrere Variablentypen aus: Sichtbarkeit, Textersetzung oder Pixelersetzung.

Gib im Feld Name einen Namen mit Buchstaben, Unterstrichen, Doppelpunkten, Punkten oder Bindestrichen ohne Leerzeichen ein.

Wähle für Pixelersetzung-Variablen eine Skalierungsmethode aus (Einpassen, Füllen, Wie gehabt oder Anpassen).

Wähle eine Ausrichtungsposition aus und aktiviere Auf Begrenzungsrahmen beschneiden.

Wiederhole den Vorgang für weitere Ebenen und wähle dann OK.

Ebenen mit Variablen zeigen im Dialogfeld ein Sternchen neben ihrem Namen an. Um eine Variable umzubenennen, gehe zurück zu Bild > Variablen > Definieren, wähle die Ebene aus und gib im Feld Name einen neuen Namen ein.Um mehrere Ebenen mit derselben Variablen zu verknüpfen, wähle beim Definieren von Variablen für weitere Ebenen einen vorhandenen Variablennamen aus dem Dropdown-Menü Name aus.

Datensätze erstellen und verwalten

Wähle Bild > Variablen > Datensätze.

Wähle das Symbol für neuen Datensatz aus, um einen Datensatz basierend auf den aktuellen Werten zu erstellen.

Wähle eine Variable aus dem Menü Name aus.

Bearbeite die Variablendaten:

  • Für Sichtbarkeit-Variablen: Wähle Sichtbar oder Unsichtbar aus
  • Für Pixelersatz-Variablen: Wähle Datei aus und wähle das Ersatzbild aus
  • Für Textersatz-Variablen: Gib Text in das Feld Wert ein.

Wiederhole diesen Schritt für jede Variable im Datensatz.

Erstelle zusätzliche Datensätze für jede benötigte Designvariante.

Wähle OK, wenn du fertig bist.

Zeige in der Vorschau an, wie sich jeder Datensatz auf dein Design auswirkt: Navigiere zu Bild > Datensatz anwenden, wähle einen Datensatz aus der Liste aus und klicke auf Anwenden.Du kannst auch das Kontrollkästchen Vorschau im Dialogfeld Datensätze aktivieren, um Änderungen zu sehen, ohne das Dialogfeld zu schließen.

Verwende die Pfeilsymbole im Dialogfeld Datensätze, um zwischen den Datensätzen zu wechseln.Um einen vorhandenen Datensatz zu ändern, wähle ihn aus dem Menü Datensatz aus und bearbeite die Variablenwerte.Um einen Datensatz zu löschen, wähle ihn aus und klicke auf das Löschsymbol.

Ausgabedateien aus Datensätzen generieren

Wähle Datei > Export > Datensätze als Dateien aus.

Gib im Namensfeld einen Basisnamen für die generierten Dateien ein.

Wähle Ordner aus und wähle ein Zielverzeichnis aus.

Wähle aus der Liste aus, welche Datensätze exportiert werden sollen.

Wähle OK aus, um die Dateien zu generieren.

Photoshop erstellt für jeden Datensatz separate PSD-Dateien, indem der Basisname mit dem Namen des Datensatzes kombiniert wird.Jede Datei enthält das Muster, auf das die Werte des Datensatzes angewendet wurden.

Wenn du einen Datensatz direkt auf dein Muster anwendest (Bild > Datensatz anwenden), wird das ursprüngliche Dokument überschrieben.Arbeite immer an einer Kopie oder exportiere Datensätze stattdessen als Dateien.