Generator-Fehler beim Starten von Adobe Photoshop beheben

Zuletzt aktualisiert am 29. Oktober 2026

Erfahre, wie du den Generator-Fehler in Adobe Photoshop behebst, indem du die Sicherheitseinstellungen überprüfst, Plug-ins entfernst, die Konflikte verursachen, und die Protokolle überprüfst.

Generator ist eine Node.js-Anwendung, die die Kommunikation zwischen Photoshop und Generator-Plug-ins übernimmt. Es stellt die Logik für die Asset-Erstellung für Exportieren als und Bild-Assets bereit.

Wenn du Photoshop startest oder Datei > Exportieren > Exportieren als auswählst, wird ein Dialogfeld mit folgendem Hinweis angezeigt: „Es gibt ein Problem mit Generator. Schließe Photoshop und versuche es erneut. Besteht das Problem weiterhin, entferne alle Plug-ins von Drittanbietern oder versuche, Photoshop neu zu installieren.“

Versuchen Sie das Problem mithilfe der folgenden Verfahren in der angegebenen Reihenfolge zu lösen.

Sicherheitssoftware blockiert Generator

Sicherheits- oder Antivirensoftware kann die Kommunikation von Generator über Port 8010 blockieren oder verhindern, dass der Node-Prozess ausgeführt wird.

Öffne deine Sicherheits- oder Antiviruseinstellungen.

Füge Photoshop zur Liste der zulässigen Anwendungen hinzu.

Stelle sicher, dass Port 8010 für den Generator geöffnet ist.

Füge unter Windows node.exe zur Liste der zulässigen Anwendungen unter C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe hinzu.

Lass unter macOS den Node-Prozess unter /Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node zu.

Erlaube Photoshop unter Windows den Zugriff auf überwachte Ordner.

Starte Photoshop neu und wähle dann Datei > Exportieren > Exportieren als aus, um Generator zu testen.

Ein Plug-in von einem Drittanbieter verursacht einen Konflikt mit Generator

Plug-ins von Drittanbietern im Generator-Ordner von Photoshop sind möglicherweise nicht mit deiner aktuellen Version kompatibel oder stehen im Konflikt mit dem Standard-Plug-in Bildobjekte.

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

Erstelle auf deinem Desktop einen temporären Ordner mit dem Namen Disabled Generator Plug-ins.

Verschiebe die Ordner der Plug-ins von Drittanbietern in den temporären Ordner. Lass das standardmäßige Image Assets-Plug-in im Ordner Generator.

Starte Photoshop und wähle Datei > Exportieren > Exportieren als aus.

Wenn der Fehler nicht mehr auftritt, füge die Plug-ins einzeln wieder hinzu und starte Photoshop nach jeder Hinzufügung neu, bis der Fehler erneut auftritt.

Belasse das Standard-Plug-in Image Assets im Generator-Ordner.Verschiebe nur Plug-ins, die du separat installiert hast.

Der Generator startet nicht, und du brauchst ihn nicht

Wenn du Exportieren als oder Image Assets nicht verwendest, deaktiviere Generator als Übergangslösung.

Starten Sie Photoshop.

Wähle unter Windows Bearbeiten > Einstellungen > Plug-ins.Wähle unter macOS Photoshop > Einstellungen > Plug-ins.

Hebe die Auswahl von Generator aktivieren auf.

Wähle OK aus und starte Photoshop neu.

Wenn du Datei > Exportieren > Exportieren als auswählst, wird Generator wieder aktiviert.Wenn du Exportieren als benötigst, behebe den Generator-Fehler, anstatt Generator deaktiviert zu lassen.

Generator-Protokolle zeigen Startfehler an

Generator-Protokolle können Informationen über Plug-ins enthalten, die nicht geladen werden können, oder über Systemprobleme, die den Start von Generator verhindern.

Navigiere unter Windows zu C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator.

Navigiere unter macOS zu /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator.

Öffne das aktuellste Generator-Protokoll und suche nach Fehlermeldungen.

Wenn der Ordner Generator nicht vorhanden ist, überprüfe, ob du Schreibberechtigung für den übergeordneten Ordner hast.

Wenn du zusätzliche Hilfe benötigst, verwende das Adobe Log Collector Tool, um Diagnoseprotokolle zu erfassen.

Die Ordner AppData (Windows) und Library (macOS) sind standardmäßig ausgeblendet.Anleitung zum Anzeigen ausgeblendeter Dateien und Ordner in Windows kann dir helfen, die Windows-Protokolle zu finden.

Generator-Fehler treten bei Apple Silicon auf

Wenn der Generator auf einem Mac mit Apple-Chip weiterhin fehlschlägt, kann das Ausführen von Photoshop mit Rosetta dabei helfen, festzustellen, ob die Kompatibilität im nativen Modus die Ursache des Problems ist.

Beende Photoshop.

Öffne im Finder den Ordner Programme und suche Adobe Photoshop.

Ctrl-Klicke auf Adobe Photoshop und wähle dann Informationen aus.

Wähle Öffnen über Rosetta aus, starte dann Photoshop und teste den Generator.

Wenn der Fehler weiterhin auftritt, stelle die Generator-Protokolle bereit, wenn du den Adobe Support kontaktierst.Verwende bei Problemen mit Exportieren als, die nicht mit Generator zusammenhängen, die Anleitung zur Fehlerbehebung für Export- und Speichervorgänge.