Erstellen eines Flex-Layouts

Zuletzt aktualisiert am 9. November 2026

Lerne, wie du Flex-Layouts in Adobe InDesign mit leeren Containern, vorhandenen Objekten und automatisch anpassbaren Textrahmen erstellst.

Adobe InDesign deeplink-gen-fill

In der App ausprobieren
Erlerne anhand einer Beispieldatei, wie Flex Layout funktioniert.

Erstellen eines leeren Flex-Layouts

Wähle mehrere Objekte in deinem Dokument aus.

Wähle das Symbol Flex-Layout im Bedienfeld Eigenschaften aus. Die ausgewählten Objekte werden zu einem Flex-Container hinzugefügt.

Ziehe Objekte per Drag & Drop in den Container. Die Container-Elemente passen sich automatisch basierend auf den Einstellungen des Flex-Containers an – Richtung, Ausrichtung, Textausrichtung und Abstand.

  • Flex-Layout ist skriptfähig.
  • Drücke die Esc-Taste, um die Auswahl von einem untergeordneten Objekt zum übergeordneten Objekt innerhalb eines Flex-Layouts zu verschieben.

Textrahmen mit den Textrahmenoptionen automatisch skalieren

Füge einen Textrahmen als untergeordnetes Flex-Element in einem Flex-Layout hinzu oder wähle ein untergeordnetes Flex-Layout-Element eines Textrahmens aus.

Gehe zu Objekt > Textrahmenoptionen und wähle die Option Automatische Größe im Dialogfeld Textrahmenoptionen aus.

Wähle nur Höhe, nur Breite, Höhe und Breite oder Höhe und Breite (Proportionen beibehalten). Die Standardoption ist Aus.

Textrahmen mit den Optionen für untergeordnete Flex-Layout-Elemente automatisch anpassen

Füge einen Textrahmen als untergeordnetes Flex-Element in einem Flex-Layout hinzu oder wähle ein untergeordnetes Flex-Layout-Element eines Textrahmens aus.

In den Optionen des Flex-Layout-Elements im Bedienfeld Eigenschaften wählst du die Option Automatisch für B oder H aus. Der Rahmen passt seine Größe jetzt automatisch an den Inhalt an, anstatt überzulaufen.

Screenshot eines ausgewählten Textrahmens innerhalb eines Flex-Layouts mit den hervorgehobenen Flex-Layout-Element-Optionen im Eigenschaften-Bedienfeld.
Aktualisiere Breite und Höhe auf „Automatisch“ in den Optionen des Flex-Layout-Elements.

Erstellen eines Flex-Layouts in einem vorhandenen Dokument

Wenn du eine Auswahl in ein Flex Layout konvertierst, analysiert InDesign die Ausrichtung und den Abstand, um geeignetes Layout-Verhalten anzuwenden. Dadurch reagieren deine Layouts einheitlich auf Inhaltsänderungen.

Wähle mehrere Objekte oder Gruppen aus, die du in einem Flex-Layout verwenden möchtest.

Für Gruppen: Rechtsklick auf die ausgewählte Gruppe und Flex-Layout > in Flex-Layout konvertieren auswählen.

Für mehrere Objekte: Rechtsklick auf die ausgewählten Objekte und Flex-Layout > Zu Flex Layout hinzufügen auswählen.

Anmerkung

InDesign erkennt standardmäßig automatisch die Richtung und Eigenschaften für Flex-Layout. Wähle zum Ein- oder Ausschalten Bearbeiten > Voreinstellungen > Allgemein (Windows) bzw. InDesign > Voreinstellungen > Allgemein (macOS). Aktiviere oder deaktiviere dann die Option Flex-Layout-Einstellungen automatisch erkennen und anwenden und wähle OK.

Wenn du die automatische Erkennung verwendest, um eine Gruppe von Elementen unterschiedlicher Größe in ein Flex-Layout zu konvertieren wird die Reihenfolge nicht mehr

nach Größe angepasst. Du kannst es jetzt verwenden, um die ursprüngliche Anordnung zu erhalten, ohne dein beabsichtigtes visuelles Design zu beeinträchtigen.

InDesign erkennt Layout-Eigenschaften basierend darauf, wie die ausgewählten Objekte ausgerichtet sind:

  • Ausgerichtete Auswahlen: Die Container-Richtung entspricht der Ausrichtung, die Größenangabe wird auf Auto entlang dieser Achse gesetzt und der Abstand wird auf Abstand zwischen gesetzt.
  • Nicht ausgerichtete Auswahlen: Inhalt umbrechen wird aktiviert und der Container verwendet eine feste Größe auf der primären Achse und automatische Größenanpassung auf der sekundären Achse.

Du kannst Richtung, Ausrichtung, Abstand, Umbruch und Positionierung anpassen.

InDesign-Arbeitsbereich mit dem Flex-Layout-Bedienfeld, das die Eigenschaften zur Anpassung zeigt, geöffnet über einem konvertierten Flex-Container.
Verfeinere die Flex Layout-Eigenschaften über das Flex-Layout-Bedienfeld.

Konvertiere übergeordnete Elemente mit Flex-Layouts in Einstellungen, um verschachtelte Strukturen aufzubauen.

Füge Elemente hinzu oder entferne sie, um zu sehen, wie das Layout reagiert, und optimiere es, bis es sich reibungslos anpasst.

Anmerkung

Die automatische Erkennung erstellt keine verschachtelten Flex-Layouts. Gruppen, die bereits ein Flex-Layout enthalten, werden als einzelne Objekte behandelt. Konvertiere daher innere Gruppen manuell vor oder nach der Erstellung des äußeren Containers.