The Export for Screens workflow is a new way to generate assets of different sizes and file formats in one action. The ability to quickly export makes the generation of imaging collateral (icons, logos, images, mockups, and more) simpler and faster - especially for web and mobile workflows.

For example, in a mobile app development scenario, the User Experience Designer may want to frequently regenerate updated icons and logos. He can add these icons and logos to the Asset Export panel, and then export them to various file types and sizes in one click of a button. 

Useful features:

  • Export to multiple formats and sizes in one quick action. 
  • Export to typical or custom sizes (scales): 1x, 2x, 3x, 0.5x, 1.5x, and more.
  • The algorithm to generate PNG files has been revised to:
    • Generate PNG files faster than before. 
    • Produce better transparency in PNG-8 files.

Formats available: 

  • PNG (PNG-8, PNG-24)
  • JPEG (JPEG 100%, JPEG 85%, JPEG 50%, JPEG 25%)
  • SVG
  • PDF

Export-for-screens-dialog
The Export for Screens dialog (Assets tab).

Exporting assets (Export for Screens workflow)

Export entire artboards or individual artwork

  1. Do one of the following:

    • Shortcut: (Win) Alt + Ctrl + E / (Mac) Cmd + Opt + E. 
    • Click File> Export > Export for Devices.
    • Select artwork and click File > Export Selection.
    • Right-click selected artwork and click Collect for Export.

    In the Export for Screens dialog, edit the settings that you want to use while exporting your artwork.

  2. Select the scope of what you want to export. Two tabs are available:

    Artboards tab.

    Choose from the artboards available to export. Click an artboard to select or de-select it. Also use your mouse and the Shift key to make multiple selections.

    Assets tab.

    Choose from the assets that you have collected in the Asset Export panel. See the section Asset Export panel below.

    Note:

    Click the thumbnail or list icons to view the items differently.

    Export-for-screens-dialog_artboards-tab
    The Export for Screens dialog (Artboards tab).
  3. Based on the tab you are in, choose what you want to export as files. A check mark indicates whether the artboard or asset is selected or not.

    Artboards tab:

    • All. Select all artboards. Each artboard will be exported individually.
    • Range. Select individual artboards to export, from those available in the document. For example, 1, 2, 4-6 selects artboards 1, 2, 4, 5, and 6.
    • Full Document. Exports the entire document as one artwork.

    Assets tab:

    • All Assets. Select this option to export all the assets collected in the Assets tab.

    Note:

    To start afresh, click Clear Selection to deselect all the collected assets. You can start selecting specific artwork by clicking on thumbnails.

  4. Specify the settings for the exported files.

    • Scale. Specify the scale factor for the output file.
    • Location. Specify the folder location where exported files will be placed.
    • Open Location after Export. Select this option to specify if you want the folder that holds the exported assets to be opened using a file browser (Explorer or Finder).
    • Suffix. Provide a suffix to ensure output files have unique names.
    • Format. Specify if you need .png, .svg, .jpg, or .pdf file output.
    • Prefix. Provide a string that will serve as the start of the file names generated.
    • Add Scale button. Click Add Scale to add an additional output scale/format to export.
    • Delete button. Click the X symbol to delete an output type.
    • Presets.
      • iOS: Click to add the preset file output types generally required for iOS projects.
      • Android: Click to add the preset file output types generally required for Android form factor projects.
  5. (Optional) Click the Settings icon () to specify output settings for exported file formats.

  6. Click the Export Artboards or Export Assets button.

Asset Export panel

Collect and export in a jiffy.

The Asset Export panel displays assets that you collect from your artwork. These assets are, typically, the art that you want to export frequently.

For example, in a mobile app development scenario, the User Experience Designer may want to frequently regenerate updated icons and logos. He can add these icons and logos to the Asset Export panel, and then export them to various file types and sizes in one click of a button. 

AssetExport
The Asset Export panel

Collect artwork for export

You can collect objects in the Asset Export panel for export as multiple assets or a single asset.

Collect artwork for export as multiple assets

Web

To collect objects/ layers for export as multiple assets, add them to the Asset Export panel (Window > Asset Export). Do one of the following:

  • Drag artwork into the Asset Export panel.
  • Right-click an asset, and then choose Collect for Export > As Multiple Assets from the context menu.
  • Select artwork and then click the Add The Selected Artwork To This Panel icon () in the Asset Export panel.
  • To add the highlighted layers in the Layers panel as assets, click the Collect For Export icon at the bottom of the Layers panel.

Note:

Each time you drag artwork into the Asset Export panel, the asset is ‘collected’. This does not create a duplicate object on your artboard or in CC Libraries. When you update the artwork in your document, the corresponding asset is automatically updated in the Asset Export panel.

Collect artwork for export as a single asset

Web

Do one of the following:

  • Press Alt/ Option while dragging artwork into the Asset Export panel.
  • Right-click an asset, and then choose Collect for Export > As Single Asset from the context menu.
  • Select artwork, and then press Alt/ Option while clicking the Add The Selected Artwork To This Panel icon () in the Asset Export panel.

Exporting assets (Asset Export panel workflow)

Export assets using the Asset Export panel

  1. Click Window > Asset Export, to launch the Asset Export panel.

  2. View the collected assets in the Asset Export panel. A border indicates whether the asset is selected for export or not.

    Note:

    Only assets with a border are exported. Click a thumbnail to select or deselect it.

  3. Click the Export Settings triangle  to view or add what formats/sizes you want to export your files to:

    • Scale. Specify the scale factor for the output file. 
    • Suffix. Provide a suffix to ensure output files have unique names.
    • Format. Specify if you need .png, .svg, .jpg, or .pdf file output.
    • Add Scale button. Click to add an additional output scale/format to export.
    • Delete button. Click the X symbol to delete an output type.
    • Presets:
      • iOS: Click to add the preset file output types generally required for iOS projects.
      • Android: Click to add the preset file output types generally required for Android form factor projects.
  4. (Optional) From the fly-out menu, choose Format Settings to specify output settings for exported file formats.

  5. (Optional) From the fly-out menu, click Open Location After Export to view the exported files immediately after an export workflow.

  6. To generate files, click Export.

    While exporting assets, Illustrator creates subfolders at the export location by default based on the scaling options you choose. For example, if you select multiple scale formats in the Asset Export panel, say 1x 2x, and 3x to export a file as PNG, Illustrator creates subfolders named 1x, 2x, and 3x for the exported files. For formats that do not support scaling options, Illustrator names the subfolders based on the file formats selected for exporting—for example, SVG and PDF. 

    To export files in a folder without creating any subfolders, deselect the Create Subfolders option from the Asset Export panel or the Export For Screens dialog box.

    Note:

    To change the folder location of the asset you're exporting, or to specify details like a file prefix, use the Export for Screens dialog. Click  to open the Export For Screens dialog. All options set in the Asset Export panel are retained in the Export For Screens dialog.

Output settings for exported assets

Format-specific options for exported assets

The Format Settings dialog allows you to specify the output settings for each file type you can export to:

  • In the Export for Screens dialog, click the Settings icon to launch the Format Settings dialog.
  • In the Asset Export panel, click the fly-out menu and choose Format Settings.
Provide format-specific settings in the Format Settings dialog.
Provide format-specific settings in the Format Settings dialog.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy