When you save or export artwork, Illustrator writes the artwork data to a file. The structure of the data depends on the file format that you select.

There are five basic file formats—AI, PDF, EPS, FXG, and SVG—to which you can save artwork. These formats are called native formats because they can preserve all Illustrator data, including multiple artboards. (For PDF and SVG formats, you must select the Preserve Illustrator Editing Capabilities options to preserve all Illustrator data.) EPS and FXG can save individual artboards as separate files. SVG saves the active artboard only; however, the content from all artboards is displayed.

You can also export artwork in a variety of file formats for use outside of Illustrator. These formats are called non-native formats because Illustrator will not be able to retrieve all of the data if you reopen the file in Illustrator. For this reason, it is recommended that you save artwork in AI format until you are finished creating it, and then export the artwork to the desired format.

Note:

You may receive an error message when saving artwork that includes linked EPS files, if those files were saved in binary format (for example, in Photoshop's default EPS format). In this case, resave the EPS files in ASCII format, embed the linked files into the Illustrator artwork, or save the artwork in AI or PDF format instead of EPS format.

For a video on saving for the web, see Save artwork for the web

Save in Illustrator format

If your document contains more than one artboard and you want to save to a previous version of Illustrator, you can choose to save each artboard as a separate file or combine the content from all artboards into a single file.

  1. Choose File > Save As or File > Save A Copy.

  2. Type a filename, and choose a location for the file.

  3. Choose Illustrator (*.AI) as the file format, and click Save.

  4. In the Illustrator Options dialog box, set the desired options and click OK:

    Version

    Specifies the version of Illustrator with which you want your file to be compatible. Legacy formats don’t support all the features in the current version of Illustrator. Therefore, when you select a version other than the current version, some options for saving aren’t available, and certain kinds of data will be changed. Be sure to read the warnings at the bottom of the dialog box so that you are aware of how the data will be changed.

    Subset Embedded Fonts When Percent Of Characters Used Is Less Than

    Specifies when to embed the entire font (as opposed to just the characters used in the document) based on how many of the font’s characters are used in the document. For instance, if a font contains 1,000 characters but the document only uses 10 of those characters, you may decide that embedding the font is not worth the extra file size.

    Create PDF Compatible File

    Saves a PDF representation of the document in the Illustrator file. Select this option if you want the Illustrator file to be compatible with other Adobe applications.

    Include Linked Files

    Embeds files that are linked to the artwork.

    Embed ICC Profiles

    Creates a color-managed document.

    Use Compression

    Compresses PDF data in the Illustrator file. Using compression increases the time required to save the document, so deselect this option if you’re experiencing very slow (8 to 15 minute) save times.

    Save Each Artboard To A Separate File

    Saves each artboard as a separate file. A separate master file that includes all of the artboards is also created. All of the content that touches an artboard is included with the file for that artboard. If artwork needs to be shifted to fit it onto a single artboard, a warning appears to let you know. If you don’t select this option, the artboards are combined into a single document and are converted to object guides and (in Illustrator CS3) crop areas. The artboard used for the saved file is based on the size of the default document startup profile.

    Transparency options

    Determines what happens to transparent objects when you choose a version of Illustrator format earlier than 9.0. Select Preserve Paths to discard transparency effects and reset transparent artwork to 100% opacity and Normal blending mode. Select Preserve Appearance And Overprints to preserve overprints that don’t interact with transparent objects. Overprints that interact with transparent objects are flattened.

    Note: If your artwork contains complex, overlapping areas and you require high-resolution output, click Cancel and specify rasterization settings before continuing.

Save in EPS format

Virtually all page layout, word-processing, and graphic applications accept imported or placed encapsulated PostScript (EPS) files. The EPS format preserves many of the graphic elements you can create with Adobe Illustrator, which means that EPS files can be reopened and edited as Illustrator files. Because EPS files are based on the PostScript language, they can contain both vector and bitmap graphics. If your artwork contains multiple artboards, these artboards are preserved when you save to EPS format.

  1. If your artwork contains transparency (including overprints) and you require high-resolution output, choose Window > Flattener Preview to preview the effects of flattening.

  2. Choose File > Save As or File > Save A Copy.

  3. Type a filename, and choose a location for the file.

  4. Choose Illustrator EPS (*.EPS) as the file format, and click Save.

  5. If you want create separate files for each artboard, click Use Artboards, and select All or specify a range. Separate files are saved with a master EPS file containing all artboards. If you deselect this option, a single EPS file is created with all artboards preserved.

  6. In the EPS Options dialog box, set the desired options and click OK:

    Version

    Specifies the version of Illustrator with which you want your file to be compatible. Legacy formats don’t support all the features in the current version of Illustrator. Therefore, when you select a version other than the current version, some options for saving aren’t available, and certain kinds of data will be changed. Be sure to read the warnings at the bottom of the dialog box so that you are aware of how the data will be changed.

    Format

    Determines the characteristics of the preview image that is saved in the file. The preview image is displayed in applications that cannot display EPS artwork directly. If you don’t want to create a preview image, choose None from the Format menu. Otherwise, select a black-and-white or color format.

    If you select TIFF (8‑bit Color) format, select a background option for the preview image:

    Transparent

    Produces a transparent background.

    Opaque

    Produces a solid background. (Select Opaque if the EPS document will be used in a Microsoft Office application.)

    Transparency options

    Determines what happens to transparent objects and overprints. The available options change depending on the format version you select at the top of the dialog box.

    If you choose a CS format, specify how to save overlapping colors that are set to overprint, and select a preset (or set of options) for flattening transparency. Click Custom to customize the flattener settings.

    If you choose a Legacy format earlier than 8.0, select Preserve Paths to discard transparency effects and reset transparent artwork to 100% opacity and Normal blending mode. Select Preserve Appearance and Overprints to preserve overprints that don’t interact with transparent objects. Overprints that interact with transparent objects are flattened.

    Embed Fonts (For Other Applications)

    Embeds all fonts that contain appropriate permissions from the font vendor. Embedding fonts ensures that the original font is displayed and printed if the file is placed into another application, such as Adobe InDesign. However, if the file is opened in Illustrator on a computer that does not have the font installed, the font will be faux or substituted. This is to prevent illegal use of the embedded font.

    note: Selecting the Embed Fonts option increases the size of the saved file.

    Include Linked Files

    Embeds files that are linked to the artwork.

    Include Document Thumbnails

    Creates a thumbnail image of the artwork. The thumbnail is displayed in the Illustrator Open and Place dialog boxes.

    Include CMYK PostScript In RGB Files

    Allows RGB color documents to be printed from applications that do not support RGB output. When the EPS file is reopened in Illustrator, the RGB colors are preserved.

    Compatible Gradient And Gradient Mesh Printing

    Enables older printers and PostScript devices to print gradients and gradient meshes by converting gradient objects to JPEG format. Selecting this option can slow printing on printers that don’t have problems with gradients.

    Adobe PostScript®

    Determines what level of PostScript is used to save the artwork. PostScript Language Level 2 represents color as well as grayscale vector and bitmap images, and supports RGB, CMYK, and CIE‑based color models for both vector and bitmap graphics. PostScript Language Level 3 provides additional functionality to Language Level 2, including the ability to print mesh objects when printing to a PostScript® 3™ printer. Because printing to PostScript Language Level 2 devices converts gradient mesh objects to bitmap images, it is preferable to print artwork that contains gradient mesh objects to a PostScript 3 printer.

Save in SVG format

SVG is a vector format that produces high-quality, interactive web graphics. There are two versions of the SVG formats: SVG and Compressed SVG (SVGZ). SVGZ can reduce file sizes by 50% to 80%; however, you cannot edit SVGZ files using a text editor.

When you save artwork in an SVG format, mesh objects are rasterized. In addition, images that have no alpha channel are converted to the JPEG format. Images with an alpha channel are converted to the PNG format. If your document contains multiple artboards and you save to SVG, the active artboard is preserved. You cannot save individual artboards as separate SVG files.

  1. If the artwork contains any SVG effects, select each item to which an SVG effect has been applied, and move the effect to the bottom of the Appearance panel (just above the Opacity entry). If other effects follow an SVG effect, the SVG output will consist of a raster object. In addition, if the artwork contains multiple artboards, select the artboard you want to export.

  2. Choose File > Save As or File > Save A Copy.

  3. Type a filename, and choose a location for the file.

  4. Choose SVG (*.SVG) or SVG Compressed (*.SVGZ) as the file format, and click Save.

  5. In the SVG Options dialog box, set the desired options and click OK:

    SVG Profiles

    Specifies the SVG XML Document Type Definition for the exported file.

    SVG 1.0 and SVG 1.1

    Suitable for SVG files that will be viewed on a desktop computer. SVG 1.1 is the full version of the SVG specification, of which SVG Tiny 1.1, SVG Tiny 1.1 Plus, and SVG Basic 1.1 are subsets.

    SVG Basic 1.1

    Suitable for SVG files that will be viewed on medium powered devices, such as handheld devices. Keep in mind that not all handhelds support the SVG Basic profile. As a result, selecting this option does not guarantee that the SVG file will be viewable on all handhelds. SVG Basic does not support nonrectangular clipping and some SVG filter effects.

    SVG Tiny 1.1 and SVG Tiny 1.1+

    Suitable for SVG files that will be viewed on small devices, such as mobile phones. Keep in mind that not all mobile phones support the SVG Tiny and SVG Tiny Plus profiles. As a result, selecting either of these options does not guarantee that the SVG file will be viewable on all small devices.

    SVG Tiny 1.2

    Suitable for SVG files that will be viewed on a variety of devices ranging from PDAs and mobile phones to laptops and desktop computers.

    SVG Tiny does not support gradients, transparency, clipping, masks, symbols, patterns, underline text, strike through text, vertical text, or SVG filter effects. SVG Tiny Plus includes the ability to display gradients and transparency, but does not support clipping, masks, symbols, or SVG filter effects.

    Tip: For additional information on SVG profiles, see the SVG specification on the World Wide Web Consortium (W3C) website (www.w3.org).

    Font Type

    Specifies how fonts are exported:

    Adobe CEF

    Uses font hinting for better rendering of small fonts. This font type is supported by the Adobe SVG Viewer but may not be supported by other SVG viewers.

    SVG

    Does not use font hinting. This font type is supported by all SVG viewers.

    Convert To Outlines

    Converts type to vector paths. Use this option to preserve the visual appearance of type in all SVG Viewers.

    Font Subsetting

    Controls which glyphs (characters of a particular font) are embedded in the exported SVG file. Choose None from the Subsetting menu if you can rely on the necessary fonts being installed on end-user systems. Choose Only Glyphs Used to include only glyphs for text that exists in the current artwork. The other values (Common English, Common English + Glyphs Used, Common Roman, Common Roman+ Glyphs Used, All Glyphs) are useful when the textual content of the SVG file is dynamic (such as server-generated text or user-interactive text).

    Image Location

    Determines whether raster images are embedded directly in the file or linked to the exported JPEG or PNG images from the original Illustrator file. Embedding images increases file size but ensures that rasterized images will always be available.

    Preserve Illustrator Editing Capabilities

    Preserves Illustrator-specific data by embedding an AI file in the SVG file (resulting in a larger file size). Select this option if you plan to reopen and edit the SVG file in Illustrator. Note that if you make manual changes to the SVG data, the changes are not reflected when you reopen the file. This is because Illustrator reads the AI portion of the file, not the SVG portion.

    CSS Properties

    Determines how style attributes are saved in the SVG code. The default method, Presentation Attributes, applies properties at the highest point in the hierarchy, which allows the most flexibility for specific edits and transformations. The Style Attributes method creates the most readable files but may increase the file size. Choose this method if the SVG code will be used in transformations, for example, transformations using Extensible Stylesheet Language Transformation (XSLT). The Style Attributes <Entity References> method results in faster rendering times and reduced SVG file size. The Style Elements method is used when sharing files with HTML documents. By selecting Style Elements, you can then modify the SVG file to move a style element into an external style sheet file that is also referenced by the HTML file; however, the Style Elements option also results in slower rendering speeds.

    Decimal Places

    Specifies the precision of vector data in the SVG file. You can set a value of 1–7 decimal places. A higher value results in a larger file size and increased image quality.

    Encoding

    Determines how characters are encoded in the SVG file. UTF (UnicodeTransformation Format) encoding is supported by all XML processors. (UTF‑8 is an 8‑bit format; UTF‑16 is a 16‑bit format.) ISO 8859‑1 and UTF‑16 encoding do not preserve file metadata.

    Optimize For Adobe SVG Viewer

    Maintains the highest level of Illustrator data while still allowing the SVG file to be manually edited. Select this option to take advantage of faster rendering for features such as SVG filter effects.

    Include Adobe Graphics Server Data

    Includes all information needed for variable substitution in the SVG file.

    Include Slicing Data

    Includes slice locations and optimization settings.

    Include XMP

    Includes XMP metadata in the SVG file. Choose File > Info or use the Bridge Browser to enter metadata.

    Output Fewer <tspan> Elements

    Allows Illustrator to ignore auto-kerning settings during export, which results in a file with fewer <tspan> elements. Select this option to create an SVG file that is more editable and compact. Deselect this option if maintaining the appearance of auto-kerned text is critical.

    Use <textPath> Element For Text On Path

    Exports text on a path as a <textPath> element. However, note that the text may appear differently in the SVG Viewer than it does in Illustrator since this export mode will not always be able to maintain visual parity. In particular, overflow text will be visible in the SVG Viewer.

    Show SVG Code

    Displays the code for the SVG file in a browser window.

    Web Preview

    Displays the SVG file in a browser window.

    Device Central

    Opens the file in Device Central for previewing on a particular mobile phone or device.

Save artwork for Microsoft Office

The Save For Microsoft Office command lets you create a PNG file that you can use in Microsoft Office applications.

  1. Choose File > Save For Microsoft Office.

  2. In the Save For Office dialog box, select a location for the file, enter a filename, and click Save.

    Note:

    If you want to customize PNG settings, such as for resolution, transparency, and background color, use the Export command instead of the Save For Microsoft Office command. You can also save artwork in PNG format using the Save For Web & Devices command.

Change vector graphics to bitmap images

About rasterization

Rasterization is the process of changing a vector graphic to a bitmap image. During rasterization, Illustrator converts the graphic’s paths into pixels. The rasterization options you set determine the size and other characteristics of the resulting pixels.

You can rasterize individual vector objects using the Object > Rasterize command or the Rasterize effect. You can also rasterize an entire document by exporting it to a bitmap format, such as JPEG, GIF, or TIFF.

Rasterize a vector object

  1. Select one or more objects.

  2. Do one of the following:

    • To permanently rasterize the objects, choose Object > Rasterize.

    • To create the appearance of rasterization without changing the objects’ underlying structure, choose Effect > Rasterize.

  3. Set rasterization options and click OK.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy