About effects

Illustrator includes a variety of effects, which you can apply to an object, group, or layer to change its characteristics.

Illustrator CS3 and earlier included effects and filters, but now Illustrator includes only effects (with the exception of SVG Filters). The primary difference between a filter and an effect is that a filter permanently modifies an object or layer, but an effect and its properties can be changed or removed at any time.

Once you apply an effect to an object, the effect appears in the Appearance panel. From the Appearance panel, you can edit the effect, move it, duplicate it, delete it, or save it as part of a graphic style. When you use an effect, you must expand the object before you can access the new points.

note: Previous versions of Illustrator included filters and effects.

The effects in the top half of the Effects menu are vector effects. You can apply these effects only to vector objects or to the fill or stroke of a bitmap object in the Appearance panel. The following effects and effects categories from the top section are exceptions to this rule and can be applied to both vector and bitmap objects: 3D effects, SVG Filters, Warp effects, Transform effects, Drop Shadow, Feather, Inner Glow, and Outer Glow.

The effects in the bottom half of the Effects menu are raster effects. You can apply them to either vector or bitmap objects.

For a video on using the Appearance panel and the Graphics Styles panel, see www.adobe.com/go/lrvid4022_ai .

Apply an effect

  1. Select the object or group (or target a layer in the Layers panel).

    If you want to apply an effect to a specific attribute of an object, such as its fill or stroke, select the object and then select the attribute in the Appearance panel.

  2. Do one of the following:

    • Choose a command from the Effect menu.

    • Click Add New Effect  in the Appearance panel, and choose an effect.

  3. If a dialog box appears, set options, and then click OK.

    Note:

    To apply the effect and settings that were used last, choose Effect > Apply [Effect Name]. To apply the last used effect and set its options, choose Effect > [Effect Name].

About raster effects

Raster effects are effects that generate pixels, rather than vector data. Raster effects include SVG Filters, all of the effects at the bottom section of the Effect menu, and the Drop Shadow, Inner Glow, Outer Glow, and Feather commands in the Effect > Stylize submenu.

The Resolution Independent Effects (RIE) capability in Illustrator CS5 makes it possible to do the following:

  • When the resolution in Document Raster Effects Settings (DRES) changes, the parameters in the effect are interpreted to a different value so that there is minimal or no change in the appearance of the effect. The new modified parameter values are reflected in the Effect dialog box.

  • For effects with more than one parameter, Illustrator reinterprets only those parameters that are related to the document raster effects resolution setting.

    For example, there are different parameters in the Halftone Pattern dialog box. However, only the Size value changes when the DRES changes.

Halftone Pattern effect before and after the resolution value changes from 300 ppi to 150 ppi
Halftone Pattern effect before and after the resolution value changes from 300 ppi to 150 ppi

You set rasterization options for a document by choosing Effect > Document Raster Effects Settings. (See Rasterization options.)

Note:

If an effect looks good on‑screen, but loses detail or appears jagged when printed, increase the document raster effects resolution.

Rasterization options

You can set the following options for all raster effects in a document or when you rasterize a vector object.

Color Model

Determines the color model that is used during rasterization. You can generate an RGB or CMYK color image (depending on the color mode of your document), a grayscale image, or a 1‑bit image (which may be black and white or black and transparent, depending on the background option selected).

Resolution

Determines the number of pixels per inch (ppi) in the rasterized image. When rasterizing a vector object, select Use Document Raster Effects Resolution to use global resolution settings.

Background

Determines how transparent areas of the vector graphic are converted to pixels. Select White to fill transparent areas with white pixels, or select Transparent to make the background transparent. If you select Transparent, you create an alpha channel (for all images except 1‑bit images). The alpha channel is retained if the artwork is exported into Photoshop. (This option anti-aliases better than the Create Clipping Mask option.)

Anti-alias

Applies anti-aliasing to reduce the appearance of jagged edges in the rasterized image. When setting rasterization options for a document, deselect this option to maintain the crispness of fine lines and small text.

When rasterizing a vector object, select None to apply no anti-aliasing and maintain the hard edges of line art when it is rasterized. Select Art Optimized to apply anti-aliasing that is best suited to artwork without type. Select Type Optimized to apply anti-aliasing that is best suited to type.

Create Clipping Mask

Creates a mask that makes the background of the rasterized image appear transparent. You do not need to create a clipping mask if you selected Transparent for Background.

Add Around Object

Adds a padding or border around the rasterized image, using the specified number of pixels. The resulting image’s dimensions appear as the original dimensions plus the Add Around Object setting’s value. You can use this setting, for example, to create a snapshot effect: Specify a value for Add Around Object setting, choose White Background, and do not select Create Clipping Mask. The white boundary added to the original object becomes a visible border on the image. You can then apply a Drop Shadow or Outer Glow effect to make the original artwork look like a photo.

Applying effects to bitmap images

Effects let you apply a special look to bitmap images as well as vector objects. For example, you can apply an impressionistic look, apply lighting changes, distort images, and produce many other interesting visual effects.

Consider the following information when applying effects specifically to bitmap objects:

  • Effects do not work on linked bitmap objects. If you apply an effect to a linked bitmap, it is applied to an embedded copy of the bitmap instead of to the original. To apply the effect to the original, you must embed the original bitmap in the document.

  • Adobe Illustrator supports plug-in effects from Adobe products such as Adobe Photoshop and from non‑Adobe software developers. Once installed, most plug-in effects appear in the Effect menu and work the same way as do built-in effects.

  • Some effects can be memory-intensive, especially when applied to a high-resolution bitmap image.

Improving performance for effects

Some effects are very memory-intensive. The following techniques can help improve performance when applying these effects:

  • Select the Preview option in effect dialog boxes to save time and prevent unintended results.

  • Change the settings. Some commands, such as Glass, are extremely memory-intensive. Try different settings to increase their speed.

  • If you plan to print to a grayscale printer, convert a copy of the bitmap image to grayscale before applying effects. Note, however, that in some cases, applying an effect to a color bitmap image and then converting it to grayscale may not have the same result as applying the same effect directly to a grayscale version of the image.

Modify or delete an effect

You modify or delete an effect by using the Appearance panel.

  1. Select the object or group (or target the layer in the Layers panel) that uses the effect.

  2. Do one of the following:

    • To modify the effect, click its blue underlined name in the Appearance panel. In the effect’s dialog box, make the desired alterations, and then click OK.

    • To delete the effect, select the effect listing in the Appearance panel, and click the Delete button.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy