About Creative Cloud Libraries

A Creative Cloud Library is a collection of design assets. Several types of design assets can be added to a Creative Cloud Library. The CC Libraries in InDesign support the following assets: Colors, Color Themes, Paragraph Styles, Character Styles, and Graphics

Note:

Brush Styles and Layer Styles assets are not supported in InDesign.

How does a Creative Cloud Library help?

Creative Cloud Libraries help you organize, browse, and access creative assets. For example, you may want to create a Creative Cloud Library that contains all the components most frequently used in a specific project.

  • Aggregate. Collect components from various documents and projects.
  • Organize. Categorize components into libraries that are meaningful to your workflows and projects.
  • Collaborate. Share assets and components from your libraries with other users. Allow others to work with items in your shared libraries, or share them with more users.
  • Manage / View / Access. Use your components across computers and tools. For example, between InDesign and Photoshop or Illustrator.
  • Reuse. Use your components multiple times, wherever and whenever you want.

Libraries panel overview

CC Libraries panel
CC Libraries panel

A. Creative Cloud Library drop-down B. Show items as icons C. Show items in a list D. Add Assets E. Progress/Sync status F. Delete Asset G. Assets 

Creative Cloud Libraries are displayed in the CC Libraries panel in InDesign. If you create libraries on different computers while using the same Adobe ID, the assets and libraries are all visible in the CC Libraries panel across computers.

Use the CC Libraries panel to:

  • Create, view, rename, remove, and use a Creative Cloud Library
  • Add, remove, edit, and rename assets in a Creative Cloud Library
  • Sort and view assets in a Creative Cloud Library

Work with a Creative Cloud Library

Open the Libraries panel

To open the CC Libraries panel:

  • Click Window > CC Libraries.

Create a Creative Cloud Library

  1. Do one of the following:

    • Click the dropdown in the Libraries panel, and then choose Create New Library.
    • Click the upper-right corner of the Libraries panel to expand the flyout menu, and then choose Create New Library.
  2. Type a name, and then click Create.

Delete a Creative Cloud Library

  1. Select a library using the Libraries panel dropdown.

  2. Expand the flyout menu, and then choose Delete.

Rename a Creative Cloud Library

  1. Select a library using the Libraries panel dropdown.

  2. Expand the flyout menu, and then choose Delete.

Note:

You can migrate the assets from InDesign object libraries to new or existing Create Cloud Libraries. For details, see Migrating object library assets to CC Libraries.

Work with library assets

Colors

Note:

Hover the pointer on an available color asset to view the name and hexadecimal code of the color.

Add colors from objects in a document

  1. Select text or an object in the current document.

  2. To add the stroke color to the CC Library, click the Add Stroke Color icon in the CC Libraries panel.

    Note:

    The Add Stroke Color icon is enabled only if a stroke is applied to the selected object or text.

  3. To add the fill color to the CC Library, click the Add Fill Color icon in the CC Libraries panel.

The colors are added as swatches to the Colors category in the CC Libraries panel.

Add color swatches from the Swatches panel

  1. Open the Swatches panel (Window >Color > Swatches).

  2. Select one or more swatches from the panel.

    To add all the swatches of the following types in a group to the current CC Library, select the Group title in the Swatches panel:

    • Process (CMYK, RGB, Lab)
    • Spot (CMYK, RGB, Lab)
    • PANTONE, ANPA, etc.
  3. Click Add selected swatch to my selected CC Library .

    Note:

    If you have chosen to add the swatches in a group, the Add selected swatch to my selected CC Library button is enabled only if the group contains at least one of the supported swatches:

    • Process (CMYK, RGB, Lab)
    • Spot (CMYK, RGB, Lab)
    • PANTONE, ANPA, etc.

The swatches are added to the Colors category in the CC Libraries panel.

If you have selected a group, then all the supported swatches in the group are added to the current library.

Add color themes to CC Library

  1. Generate a color theme from an image on the current document using the Color Theme tool.

    For details on generating color themes from images on InDesign documents, see Generate color themes using the Color Theme tool.

  2. In the Color Theme tool, click Add this theme to my current CC Library .

The image theme is added to the Color Themes category in the current CC Libraries panel.

Add CC Library color or color themes to Swatches panel

  1. Right-click one or more colors or a color theme in the CC libraries panel.

  2. Choose Add to Swatches or Add Theme to Swatches, respectively from the context menu.

Apply colors to objects and text in a document

  1. Select an object or text in the active InDesign document.

  2. Click a color in a library in the CC Libraries panel (the color is applied to the active proxy [fill or stroke]).

  3. To apply a color fill, right-click the color and choose Set Color.

Note:

Use the proxy to determine what the color is applied to - the fill or stroke properties of an object or text.

Edit colors in a CC Library

  1. In the CC Libraries panel,right-click a color and choose Edit.

  2. Select a color using the Color Picker dialog and then click OK.

Paragraph and Character Styles

You can add InDesign paragraph or character styles to your CC Libraries and then share these across documents, devices, or users. You can add paragraph or character styles from text in a document, from the Paragraph or Character panels, or from the New Character Style or New Paragraph Style dialog boxes. 

Note:

Text Styles have been renamed and the assets that were categorized under the Text Styles are available under the Character Styles category.

Add paragraph or character styles from text in a document

  1. Select the text (on the current document) on which character or paragraph style is applied that you need to add to the current CC Library.

  2. Click Add Paragraph Style  or Add Character Style  in the CC Libraries panel.

The paragraph or character style is added to the Paragraph Styles or Character Styles category, respectively in the CC Libraries panel.

Add paragraph or character styles from Paragraph Styles or Character Styles panels

  1. Open the Character Styles or Paragraph Styles panel:

    • Window > Styles > Character Styles
    • Window > Styles > Paragraph Styles
  2. Select one or more styles from the panel.

    To add all the styles in a group to the current CC Library, select the Group title in the Paragraph or Character Styles panel.

  3. Click Add selected style to my current CC Library .

The selected paragraph or character styles are added to the Character Styles or Paragraph Styles category in the CC Libraries panel.

If you have selected a group, then all the paragraph or character styles are added to the current library.

Add paragraph or character styles from the New Paragraph Styles or New Character Styles dialogs

  1. Open the Character Styles or Paragraph Styles panel:

    • Window > Styles > Character Styles
    • Window > Styles > Paragraph Styles
  2. From the flyout menu, choose New Character Style or New Paragraph Style.

  3. In the New Character Style or New Paragraph Style dialog, specify the options to create a new style.

    For details, see Add paragraph and character styles.

  4. Check Add to CC Library and select the required CC Library from the drop-down list or the option to Create New Library

  5. Click OK to create the new style and simultaneously add it to the selected CC Library.

The newly created paragraph or character style is added to the Paragraph Styles or Character Styles category, respectively in the CC Libraries panel.

Apply a single CC Library paragraph or character style to text in a document

  1. Select a text object in the active InDesign document.

  2. Right-click the style in the selected CC Library and choose Apply Paragraph Style or Apply Character Style.

The Character Styles and Paragraph styles that are applied from the CC Libraries panel will be added as styles to the respective panels in InDesign.

In addition, all styles hierarchies will be maintained. For example, say Paragraph Style 2 was based on Paragraph Style 1 and that had a nested Character Style 1. In this case, both Paragraph Style 1 and Character Style 1 will be added to their respective panels. And Paragraph Style 2 will be added to the Paragraph Styles panel.

Note:

If a character or paragraph style does not have the font associated with it on the local computer, a warning icon is displayed at the lower right corner of the style thumbnail in the CC Libraries panel.

Add CC Library styles to Paragraph or Character panels

  1. Select one or more paragraph or character styles in the CC Libraries panel.

  2. Right-click the selected styles and choose Add to Paragraph Styles or Add to Character Styles.

Graphics

Add graphics from a document

  • Drag-and-drop the InDesign asset from the document onto the CC Libraries panel.

    Or click an InDesign asset in the document, and click Add Graphic  in the CC Libraries panel.

The asset is added to the Graphics category of the CC Libraries panel as an InDesign snippet.

You can also add graphics from Adobe Stock to your InDesign CC Library. For details, see Using Adobe Stock in InDesign.

Place CC Library graphics using drag-and-drop or the right-click menu

  1. Drag-and-drop the graphic from the CC Libraries panel onto the document.

    Note:

    If you drag-and-drop a graphic, by default, it is placed as a linked graphic. To place it as an embedded graphic, use the Alt+drag-and-drop combination.

    To place one or more graphics on a document, right-click the graphics in the CC Libraries panel and choose:

    Place Copy

    Place an InDesign asset as a snippet or to embed a graphic from another Creative Cloud application (such as Photoshop or Illustrator).

    Place Linked

    Place a graphic from another Creative Cloud application (such as PhotoShop or Illustrator) as a library linked graphic.

    Note:

    You cannot place an InDesign asset as a linked graphic on a document so the Place Linked option is not available if you right-click an InDesign asset.

  2. If you have used the right-click menu to place one or more graphics, the graphics are added to the placegun.

    Use the placegun to selectively add the graphics to your document.

Place a CC Library graphic using the Place From CC Libraries menu option

  1. Select File > Place From CC Libraries.

    The CC Libraries panel is filtered to display only the Graphics category.

  2. Click a graphic and click Place.

    The asset is added to the InDesign placegun.

  3. Use the placegun to place the graphic on the document.

If you place a linked graphic on a document, the graphic appears in the InDesign Links panel.

The icon to the right of each graphic in the Links panel indicates if the graphic is linked  or embedded .

To locate a linked graphic in the CC Libraries panel, right-click the graphic and select Reveal in CC Libraries.

Or select the graphic and choose Reveal in CC Libraries from the Links panel flyout menu.

Edit an InDesign asset in a CC Library

  1. Right-click the asset and choose Edit or double-click the asset.

    The asset is opened in an InDesign document window.

  2. Make the required changes and save the asset.

    The asset is added to the InDesign placegun.

    The changes are reflected in the asset in the CC Library.

Graphics placed on InDesign documents can be relinked to graphics in a CC Library. The placed graphics can also be relinked to a graphic file on the local computer.

  1. To relink a graphic to a CC Library graphic, right-click the graphic and choose Relink to CC Libraries.

    Or select the graphic and choose Relink to CC Libraries from the Links panel flyout menu.

  2. To relink to a local graphic file, right-click the graphic and choose Relink.

    Or select the graphic and choose Relink from the Links panel flyout menu.

Add and share text assets

You can add text objects from your document to Creative Cloud libraries and then share them with other users and across applications. Text assets in a library retain the character/paragraph styles and other attributes originally applied to them. You can reuse text assets in libraries across InDesign or Illustrator documents.

If a text objects has effects and appearances applied to it, you must add it to the library as a graphics asset to preserve them.

Add a text asset

In an active InDesign document, do one of the following:

  • Select a text object, click  in the CC Libraries panel, select Text from the menu, and click Add.
  • Drag the text object into the CC Libraries panel. By default, the asset is added as a text asset to the Creative Cloud library.
  • To add the text object as a graphics asset, press Control (Windows)/ Command (Mac) key while dragging the selection to the CC Libraries panel.
  • Select some text inside the text frame, click in the CC Libraries panel, select Text from the menu, and click Add. This adds only the selected text.
  • Place the insertion pointer inside any text frame, click  in the CC Libraries panel, select Text from the menu, and click Add. This adds the complete story across threaded frames as well.

Use a text asset in a document

Do one of the following:

  • Right-click a text asset in the CC Libraries panel and select one of the following options:
    • Place Linked: Creates a link in the Links panel and the link is maintained with the CC Library asset. Any update to the asset updates the linked text asset on the document. It also keeps styling information intact along with Character/Paragraph styles.
    • Place Copy: Does not create a link, any update to the CC Library text asset does not update the text asset on the document. Styling information is kept intact along with Character/Paragraph styles.
    • Place Without Styles: Only the text is brought in without any link or styling information.
  • Place the pointer inside a text frame, right-click a text asset in the CC Libraries panel, and select Place Inline.
  • Drag an asset onto the document to create a linked text asset.
  • Drag an asset with Alt key pressed to create a non-linked text asset.

Integration with Illustrator

Text assets added to libraries are also available from within the Libraries panel in Illustrator. You can edit and use text assets across these two applications. In the Libraries panel List view, the icon to the right of the text asset in the Libraries panel indicates the application in which it was created.

For more information, see Rendition of shared text assets in Illustrator and InDesign.

Edit a text asset

In the CC Libraries panel, follow these steps:

  1. Double-click the thumbnail for a text asset. Alternatively, right-click the text asset and then choose Edit.

  2. Edit the asset when it opens up in an InDesign document. 

  3. Save the document.

The text asset is updated in the Creative Cloud Library and the thumbnail is automatically refreshed. Also, the asset is updated across all locations where it is used as a linked asset.

Rename a text asset

  1. Right-click the text asset and choose Rename.

  2. Type a new name for the asset and press Enter.

Delete a text asset

In the CC Libraries panel, right-click a text asset and then choose Delete.

Manage CC Library assets

In the CC Libraries panel, you can rename, delete, duplicate, copy, or move across CC Libraries assets.

Duplicate assets

  1. Right-click one or more assets in the CC Libraries panel.

  2. If you select one asset, choose Duplicate.

    If you select multiple assets, choose Duplicate Selected Items.

Copy or move assets from one CC Library to another

  1. Right-click one or more assets in the CC Libraries panel.

  2. If you select one asset, choose Copy to or Move to.

    If you select multiple assets, choose Copy Selected Items or Move Selected Items.

  3. In the sub-menu, select the CC Library to copy or move the assets.

Rename assets

  1. Right-click an asset in the CC Libraries panel and choose Rename.

  2. Type a new name for the asset and press Enter.

Delete assets

  1. Right-click one or more assets in the CC Libraries panel.

  2. If you select one asset, choose Delete.

    If you select multiple assets, choose Delete Selected Items.

Search in the CC Libraries panel

Search for a CC library asset by its name in the CC libraries panel. You can search for assets in the following locations:

  • Current library (Default)
  • Adobe Stock
  • All libraries
  1. In the Search drop-down menu, select the location to search within.

  2. Type the asset name in the Search box and press Enter.

Collaborate with Creative Cloud users

You can share your libraries with other users for them to view, edit, use, rename, move, or delete the contents of the shared library. If another Creative Cloud subscriber has shared a library with you, you can further share it with other Creative Cloud users.

To share a library

  1. In the CC Libraries panel, select a library from the drop-down.
  2. In the CC Libraries panel, click the flyout menu, and choose Collaborate.
  3. In the browser page that opens up, provide an email address and optional message for the person you would like to share the library with.

Accept an invite

  1. Launch the Adobe Creative Cloud for Desktop app, and log in with your Adobe ID credentials.
  2. If a library has been shared with you, you will see an Updates and Requests banner at the top of the Creative Cloud for Desktop app. Click the Updates and Requests banner.
  3. From the Library Invitations section, click the Accept button available for each library collaboration invitation.

Cancel a share

  1. In the CC Libraries panel, from the drop-down, select the name of a library that you would not like to share anymore.
  2. In the CC Libraries panel, click the flyout menu, and choose Collaborate.
  3. In the browser page that opens up, delete the names of all the users that the Creative Cloud library is shared with.

Leave a shared library

  1. In the CC Libraries panel, from the drop-down, select the name of a library that you would not like to collaborate on anymore.
  2. In the CC Libraries panel, click the flyout menu, and click the Leave library option.

Delete a shared library:

Important: You can only delete a library that you own

  1. In the CC Libraries panel, from the drop-down, select the name of a library that you want to delete.
  2. In the CC Libraries panel, click the flyout menu, and click the Delete library option.
  3. Click Delete to confirm the action.

Use InDesign objects in other CC applications

The InDesign objects that you add to the Graphics category of a CC Library can be used in other CC applications such as Illustrator or Photoshop.

Since a copy of every InDesign object is stored in the form of a PDF file, when you use this object in Illustrator or Photoshop, these applications use the PDF rendition of the object.

Note:

If you use an InDesign Character Style in Illustrator or Photoshop, those applications will attempt to map the properties of the asset with the properties for character attributes available in the host application. Any properties not found in the host application will be ignored.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy